source: projects/specs/trunk/b/bind-current/bind-current-vl.spec @ 3824

Revision 3824, 20.1 KB checked in by iwamoto, 13 years ago (diff)

bind-current: new upstream release with security fix

Line 
1%define _localstatedir /var
2
3%define sname bind
4%define pname bind-current
5%define pversion 9.8.0p1
6%define sversion 9.8.0-P1
7%define bind_epoch 1
8%define old_bind_version 1:9.6.ESV.R4
9
10%define bind_uid  25
11%define bind_gid  25
12
13Summary: A DNS (Domain Name System) server.
14Summary(ja): DNS (Domain Name System) サーバ
15Name: %{pname}
16Version: %{pversion}
17Release: 1%{?_dist_release}
18Epoch: %{bind_epoch}
19License: distributable
20Group: System Environment/Daemons
21Source: ftp://ftp.isc.org/isc/bind9/%{version}/%{sname}-%{sversion}.tar.gz
22Source1: bind-manpages.tar.bz2
23Source2: named.sysconfig
24Source3: named.init
25Source4: named.logrotate
26Source5: keygen.c
27URL: http://www.isc.org/bind.html
28Patch1: bind-9.3.3rc2-rndckey.patch
29
30Buildroot: %{_tmppath}/%{name}-%{version}-root
31BuildRequires: openssl-devel glibc-devel libtool
32Requires: %{pname}-libs = %{bind_epoch}:%{version}-%{release}
33Requires(pre): shadow-utils
34Requires(post): %{pname}-utils = %{bind_epoch}:%{version}-%{release}
35Requires(post): coreutils, chkconfig
36Requires(preun): initscripts, chkconfig
37Requires(triggerpostun): chkconfig
38Conflicts: bind9 <= 9.2.1-0vl5, bind < %{bind_epoch}:%{version}-%{release}
39Obsoletes: bind9 <= 9.2.1-0vl5, bind < %{old_bind_version}
40
41Vendor: Project Vine
42Distribution: Vine Linux
43Packager: daisuke
44
45%description
46BIND (Berkeley Internet Name Domain) is an implementation of the DNS
47(Domain Name System) protocols. BIND includes a DNS server (named),
48which resolves host names to IP addresses, and a resolver library
49(routines for applications to use when interfacing with DNS).  A DNS
50server allows clients to name resources or objects and share the
51information with other network machines.  The named DNS server can be
52used on workstations as a caching name server, but is generally only
53needed on one machine for an entire network.  Note that the
54configuration files for making BIND act as a simple caching nameserver
55are included in the caching-nameserver package. 
56
57Install the bind package if you need a DNS server for your network.  If
58you want bind to act a caching name server, you will also need to install
59the caching-nameserver package.
60
61
62%package libs
63Summary: Libraries used by various DNS packages
64Group: System Environment/Libraries
65Conflicts: bind9-libs <= 9.2.1-0vl5
66Conflicts: bind-libs < %{bind_epoch}:%{version}-%{release}
67Obsoletes: bind9-libs <= 9.2.1-0vl5
68Obsoletes: bind-libs < %{old_bind_version}
69
70%description libs
71Contains libraries used by both the bind server package as well as the utils packages.
72
73
74%package utils
75Summary: Utilities for querying DNS name servers.
76Summary(ja): DNS ネームサーバに問い合わせをするユーティリティ
77Group: Applications/System
78Requires: %{pname}-libs = %{bind_epoch}:%{version}-%{release}
79Conflicts: bind9-utils <= 9.2.1-0vl5
80Conflicts: bind-utils < %{bind_epoch}:%{version}-%{release}
81Obsoletes: bind9-utils <= 9.2.1-0vl5
82Obsoletes: bind-utils < %{old_bind_version}
83
84%description utils
85Bind-utils contains a collection of utilities for querying DNS (Domain
86Name Service) name servers to find out information about Internet hosts.
87These tools will provide you with the IP addresses for given host names,
88as well as other information about registered domains and network
89addresses.
90
91You should install bind-utils if you need to get information from DNS name
92servers.
93
94
95%package devel
96Summary: Include files and libraries needed for bind DNS development.
97Summary(ja): bind DNS 開発に必要なインクルードファイルとライブラリ
98Group: Development/Libraries
99Requires: %{pname} = %{bind_epoch}:%{version}-%{release}
100Requires: %{pname}-libs = %{bind_epoch}:%{version}-%{release}
101Conflicts: bind9-devel <= 9.2.1-0vl5
102Conflicts: bind-devel < %{bind_epoch}:%{version}-%{release}
103Obsoletes: bind9-devel <= 9.2.1-0vl5
104Obsoletes: bind-devel < %{old_bind_version}
105
106%description devel
107The bind-devel package contains all the include files and the
108library required for DNS (Domain Name Service) development for
109BIND versions 9.x.x.
110
111You should install bind-devel if you want to develop bind DNS
112applications. If you install bind-devel, you'll also need to install
113bind.
114#'
115
116%prep
117%setup -n bind-%{sversion} -q
118%patch1 -p1 -b .key
119
120%build
121libtoolize --copy --force
122aclocal
123autoconf
124%configure --with-libtool --with-openssl=/usr --enable-threads
125make %{?_smp_mflags}
126
127%install
128rm -rf $RPM_BUILD_ROOT
129mkdir -p ${RPM_BUILD_ROOT}%{_sysconfdir}/{rc.d/init.d,logrotate.d}
130mkdir -p ${RPM_BUILD_ROOT}/usr/{bin,lib,sbin,include}
131mkdir -p ${RPM_BUILD_ROOT}/var/named
132mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/{man1,man5,man8}
133mkdir -p ${RPM_BUILD_ROOT}/var/run/named
134
135make DESTDIR=$RPM_BUILD_ROOT install
136install -c -m 640 bin/rndc/rndc.conf $RPM_BUILD_ROOT/etc
137install -c -m 755 contrib/named-bootconf/named-bootconf.sh $RPM_BUILD_ROOT/usr/sbin/named-bootconf
138install -c -m 755 %SOURCE3 $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/named
139install -c -m 644 %SOURCE4 $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/named
140touch $RPM_BUILD_ROOT%{_sysconfdir}/rndc.key
141gcc $RPM_OPT_FLAGS -o $RPM_BUILD_ROOT/usr/sbin/dns-keygen %{SOURCE5}
142cd $RPM_BUILD_ROOT%{_mandir}
143tar xjf %{SOURCE1}
144# newer version is contained in source
145rm -f man5/named.conf.5.gz
146mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
147cp %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/named
148
149
150%pre
151if [ "$1" -eq 1 ]; then
152  /usr/sbin/groupadd -g %{bind_gid} -f -r named >/dev/null 2>&1 || :;
153  /usr/sbin/useradd  -u %{bind_uid} -r -N -M -g named -s /sbin/nologin -d /var/named -c Named named >/dev/null 2>&1 || :;
154fi;
155:;
156
157%post
158/sbin/ldconfig
159/sbin/chkconfig --add named
160if [ "$1" -eq 1 ]; then
161  if [ ! -e /etc/rndc.key ]; then
162    /usr/sbin/rndc-confgen -a > /dev/null 2>&1
163  fi
164  [ -x /sbin/restorecon ] && /sbin/restorecon /etc/rndc.* /etc/named.* >/dev/null 2>&1 ;
165  # rndc.key has to have correct perms and ownership, CVE-2007-6283
166  [ -e /etc/rndc.key ] && chown root:named /etc/rndc.key
167  [ -e /etc/rndc.key ] && chmod 0640 /etc/rndc.key
168
169  # Check DNSSEC settings if this is a fresh install
170  if [ -r /etc/sysconfig/dnssec ]; then
171    . /etc/sysconfig/dnssec
172    [ -x /usr/sbin/dnssec-configure ] && \
173      dnssec-configure -b --norestart --dnssec="$DNSSEC" --dlv="$DLV" > \
174        /dev/null 2>&1
175  fi;
176fi
177:;
178
179%preun
180if [ "$1" -eq 0 ]; then
181   /sbin/service named stop >/dev/null 2>&1 || :
182   /sbin/chkconfig --del named ||:
183fi
184exit 0
185
186
187%postun
188if [ "$1" -ge 1 ]; then
189        %{_sysconfdir}/rc.d/init.d/named condrestart >/dev/null 2>&1 || :
190fi
191/sbin/ldconfig
192
193%triggerpostun -- bind < 8.2.2_P5-15
194/sbin/chkconfig --add named
195/sbin/ldconfig
196
197%clean
198rm -rf ${RPM_BUILD_ROOT} ${RPM_BUILD_DIR}/%{name}-%{version}
199
200
201%post libs -p /sbin/ldconfig
202
203%postun libs -p /sbin/ldconfig
204
205
206%files
207%defattr(-,root,root)
208%doc CHANGES README
209%doc doc/arm doc/draft doc/rfc doc/misc
210%config(noreplace) %{_sysconfdir}/logrotate.d/named
211%config %{_sysconfdir}/rc.d/init.d/named
212%config(noreplace) %{_sysconfdir}/sysconfig/named
213%config(noreplace) %attr(0640,root,named) %{_sysconfdir}/rndc.conf
214%config(noreplace) %attr(0640,root,named) %{_sysconfdir}/rndc.key
215%config(noreplace) %attr(0640,root,named) %{_sysconfdir}/bind.keys
216
217%{_sbindir}/dnssec*
218%{_sbindir}/lwresd
219%{_sbindir}/named
220%{_sbindir}/named-bootconf
221%{_sbindir}/named-check*
222%{_sbindir}/named-compilezone
223%{_sbindir}/rndc*
224%{_sbindir}/dns-keygen
225%{_sbindir}/arpaname
226%{_sbindir}/ddns-confgen
227%{_sbindir}/genrandom
228%{_sbindir}/isc-hmac-fixup
229%{_sbindir}/named-journalprint
230%{_sbindir}/nsec3hash
231
232%{_mandir}/man1/arpaname.1*
233%{_mandir}/man5/resolv.conf.5*
234%{_mandir}/man5/named.conf.5*
235%{_mandir}/man5/rndc.conf.5*
236%{_mandir}/man8/rndc.8*
237%{_mandir}/man8/named.8*
238%{_mandir}/man8/lwresd.8*
239%{_mandir}/man8/dnssec*.8*
240%{_mandir}/man8/named-checkconf.8*
241%{_mandir}/man8/named-checkzone.8*
242%{_mandir}/man8/named-compilezone.8*
243%{_mandir}/man8/rndc-confgen.8*
244%{_mandir}/man8/ddns-confgen.8*
245%{_mandir}/man8/genrandom.8*
246%{_mandir}/man8/isc-hmac-fixup.8*
247%{_mandir}/man8/named-journalprint.8*
248%{_mandir}/man8/nsec3hash.8*
249
250%attr(-,named,named) %dir %{_var}/named
251%attr(-,named,named) %dir %{_var}/run/named
252     
253
254%files libs
255%defattr(-,root,root)
256%{_libdir}/*.so.*
257
258%files utils
259%defattr(-,root,root)
260%{_bindir}/dig
261%{_bindir}/host
262%{_bindir}/nslookup
263%{_bindir}/nsupdate
264%{_mandir}/man1/host.1*
265%{_mandir}/man1/nsupdate.1*
266%{_mandir}/man1/dig.1*
267%{_mandir}/man5/resolver.5*
268%{_mandir}/man1/nslookup.1*
269%{_mandir}/man8/nslookup.8*
270
271
272%files devel
273%defattr(-,root,root)
274%{_libdir}/*.so
275%{_libdir}/*.la
276%{_libdir}/*.a
277%{_includedir}/*
278%{_mandir}/man3/*
279%{_mandir}/man1/isc-config.sh.1*
280%{_bindir}/isc-config.sh
281
282%changelog
283* Mon May  9 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.8.0p1-1
284- new upstream release with security fix (CVE-2011-1907)
285- fix changelog typo
286
287* Sat Apr 09 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 9.8.0-2
288- Obosoletes: bind.* < 1:9.6.ESV.R1
289
290* Thu Apr 07 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 9.8.0-1
291- update to 9.8.0
292- remove Provides: bind.* = %%{bind_epoch}:%{version}-%{release}
293
294* Mon Jan 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.7.2P2-3
295- rebuild with openssl-1.0.0c
296
297* Sun Oct 24 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.7.2P2-2
298- fix Req: in bind package
299
300* Wed Oct 20 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.7.2P2-1
301- change package name bind -> bind-current
302- add epoch 1
303- new upstream release
304
305* Sat Jul 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 9.7.1P2-1
306- new upstream release
307
308* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 9.6.1P3-4
309- rebuilt with gcc-4.4.3-3 on ppc
310
311* Sat Feb  6 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 9.6.1P3-3
312- rebuilt with new toolchains (for VineSeed)
313- s/BuildPrereq/BuildRequires/
314
315* Thu Jan 21 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P3-2
316- add man1/isc-config.sh.1 into devel file list
317
318* Wed Jan 20 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P3-1
319- new upstream release with security fix (CVE-2009-4022, 2010-0097) 
320
321* Sat Dec 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P2-1
322- new upstream release with security fix (CVE-2009-4022)
323
324* Wed Jul 29 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P1-1
325- new upstream release with security fix
326
327* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 9.6.1-1
328- new upstream release
329- clean up %%post/%%pre scriptlet
330  - create named user and group in %%pre
331  - don't remove named user/group in %%preun
332  - use rndc-confgen to create rndc.key
333
334* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 9.6.0P1-1
335- new upstream release
336- drop patch0 and patch14, merged in upstream
337
338* Sat Jan 11 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.5.1P1-1
339- new upstream release with security fix
340
341* Wed Jul 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 9.5.0P1-1
342- new upstream release with security fix
343- new versioning policy
344
345* Sun Sep 30 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 9.4.1P1-0vl1
346- new upstream release with security fix
347
348* Fri May 18 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 9.4.1-0vl1
349- new upstream release
350- build with new openssl/toolchain
351
352* Tue Jan 30 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.4-0vl1
353- new upstream release with security fix
354
355* Fri Nov 03 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2P2-0vl1
356- new upstream release
357
358* Fri Sep 08 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.2P1-0vl2
359- add Prereq sed
360
361* Wed Sep 06 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.2P1-0vl1
362- new upstream release for security fix (CVE-2006-4095,4096)
363
364* Wed Feb 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 9.3.2-0vl3
365- separate -libs package
366- remove old named.conf.5.gz
367  - newer version is contained in source
368
369* Thu Feb 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2-0vl2
370- add bsdcompat patch (Patch4)
371- add fix_h_errno patch from FC
372  - h_errno not being accessed / set correctly in libbind
373
374* Thu Feb 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2-0vl1
375- new upstream release
376
377* Sun Nov  7 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 9.2.4-0vl2
378- added PreReq to bind-utils (see: [VineSeed:09555])
379
380* Thu Oct 28 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.4-0vl1
381- new upstream release
382
383* Wed Nov 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl3
384- fix /etc/init.d/named to use rndc
385
386* Tue Nov 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl2
387- rebuild to remove unneeded dependancy
388
389* Mon Nov 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl1
390- new upstream release
391
392* Tue Mar  4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.2-0vl1
393- new upstream release
394
395* Thu Nov 28 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl7
396- fix dependancies.
397
398* Wed Nov 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl6
399- add obsoletes: and conflicts: to bind9, bind9-utils, bind9-devel <= 9.2.1-0vl5
400- change package name to bind for VineSeed.
401- use more macros.
402
403* Sat Oct 19 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl5
404- fixed some macros
405- add conflicts: to bind-* in bind9-devel and bind9-utils
406- add provides: bind = %%{version}
407
408* Sat Oct 19 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl4
409- use %%configure macros
410
411* Sat Oct 19 2002 Michihide Hotta <hotta@net-newbie.com> 9.2.1-0vl3
412- fixed inconsistent dependency
413
414* Wed Aug 14 2002 Satoshi MACHINO <machino@vinelinux.org> 9.2.1-0vl2
415- updated to 9.2.2rc1
416
417* Thu May 02 2002 Satoshi MACHINO <machino@vinelinux.org> 9.2.1-0vl0
418- updated to bind9(9.2.1), test packages ;)
419        -- based on Rawhide's bind-9.2.0-8
420        -- changed name bind9
421        -- added Conflicts: bind
422
423* Sun Feb 03 2002 Toru Sagami <sagami@vinelinux.org> 8.3.1-0vl1
424- release 8.3.1 includes security fixes
425
426* Mon Jan 14 2002 Toru Sagami <sagami@vinelinux.org> 8.3.0-0vl1
427- Upgraded to current stable release 8.3.0
428
429* Mon Oct  8 2001 <zn@mbf.nifty.com>
430- 8.2.5-0vl0: Upgraded to new upstream version.
431
432* Thu May 24 2001 <sagami@vinelinux.org>
433- 8.2.4-0vl1: eliminate CVS related files from %%doc
434
435* Thu May 17 2001 <sagami@vinelinux.org>
436- 8.2.4-0vl0
437
438* Fri Feb 02 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
439- 8.2.3-1vl2
440- built on VineSeed
441
442* Tue Jan 30 2001 KAJIKI Yoshihiro <kajiki@ylug.org>
443- add doc/old
444- build for Vine 2.1
445
446* Sat Jan 27 2001 Bernhard Rosenkraenzer <bero@redhat.com>
447- 8.2.3, fixes several security problems
448
449* Tue Nov 14 2000 Bill Nottingham <notting@redhat.com>
450- static libraries may be used in shared objects. Build with -fPIC on ia64
451
452* Fri Nov 10 2000 Bernhard Rosenkraenzer <bero@redhat.com>
453- 8.2.2-P7 (fixes Bug #20546)
454
455* Sat Aug 05 2000 Bill Nottingham <notting@redhat.com>
456- condrestart fixes
457
458* Tue Jul 18 2000 Nalin Dahyabhai <nalin@redhat.com>
459- change the init script to take condrestart, not cond-restart
460- add sh-utils, /bin/cat, perl, /bin/chmod, /usr/sbin/useradd as prereqs for
461  the %pre and %post scripts
462
463* Sun Jul 16 2000 Bernhard Rosenkraenzer <bero@redhat.com>
464- Don't prereq /etc/init.d
465
466* Sat Jul 15 2000 Bill Nottingham <notting@redhat.com>
467- move initscript back
468
469* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
470- automatic rebuild
471
472* Sun Jul  9 2000 Florian La Roche <Florian.LaRoche@redhat.de>
473- add "exit 0" for uninstall case
474
475* Fri Jul  7 2000 Florian La Roche <Florian.LaRoche@redhat.de>
476- add prereq init.d and cleanup install section
477
478* Fri Jun 30 2000 Trond Eivind Glomsr <teg@redhat.com>
479- fix the init script
480
481* Wed Jun 28 2000 Nalin Dahyabhai <nalin@redhat.com>
482- make libbind.a and nslookup.help readable again by setting INSTALL_LIB to ""
483
484* Mon Jun 26 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
485- Fix up the initscript (Bug #13033)
486- Fix build with current glibc (Bug #12755)
487- /etc/rc.d/init.d -> /etc/init.d
488- use %%{_mandir} rather than /usr/share/man
489
490* Mon Jun 19 2000 Bill Nottingham <notting@redhat.com>
491- fix conflict with man-pages
492- remove compatibilty chkconfig links
493- initscript munging
494
495* Wed Jun 14 2000 Nalin Dahyabhai <nalin@redhat.com>
496- modify logrotate setup to use PID file
497- temporarily disable optimization by unsetting $RPM_OPT_FLAGS at build-time
498- actually bump the release this time
499
500* Sun Jun  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
501- FHS compliance
502
503* Mon Apr 17 2000 Nalin Dahyabhai <nalin@redhat.com>
504- clean up restart patch
505
506* Mon Apr 10 2000 Nalin Dahyabhai <nalin@redhat.com>
507- provide /var/named (fix for bugs #9847, #10205)
508- preserve args when restarted via ndc(8) (bug #10227)
509- make resolv.conf(5) a link to resolver(5) (bug #10245)
510- fix SYSTYPE bug in all makefiles
511- move creation of named user from %%post into %%pre
512
513* Mon Feb 28 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
514- Fix TTL (patch from ISC, Bug #9820)
515
516* Wed Feb 16 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
517- fix typo in spec (it's %post, without a leading blank) introduced in -6
518- change SYSTYPE to linux
519
520* Sat Feb 11 2000 Bill Nottingham <notting@redhat.com>
521- pick a standard < 100 uid/gid for named
522
523* Thu Feb 04 2000 Elliot Lee <sopwith@redhat.com>
524- Pass named a '-u named' parameter by default, and add/remove user.
525
526* Thu Feb  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
527- fix host mx bug (Bug #9021)
528
529* Mon Jan 31 2000 Cristian Gafton <gafton@redhat.com>
530- rebuild to fix dependencies
531- man pages are compressed
532
533* Wed Jan 19 2000 Bernhard Rosenkraenzer <bero@redhat.com>
534- It's /usr/bin/killall, not /usr/sbin/killall (Bug #8063)
535
536* Mon Jan 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
537- Fix up location of named-bootconf.pl and make it executable
538  (Bug #8028)
539- bind-devel requires bind
540
541* Mon Nov 15 1999 Bernhard Rosenkraenzer <bero@redhat.com>
542- update to 8.2.2-P5
543
544* Wed Nov 10 1999 Bill Nottingham <notting@redhat.com>
545- update to 8.2.2-P3
546
547* Tue Oct 12 1999 Cristian Gafton <gafton@redhat.com>
548- add patch to stop a cache only server from complaining about lame servers
549  on every request.
550
551* Fri Sep 24 1999 Preston Brown <pbrown@redhat.com>
552- use real stop and start in named.init for restart, not ndc restart, it has
553  problems when named has changed during a package update... (# 4890)
554
555* Fri Sep 10 1999 Bill Nottingham <notting@redhat.com>
556- chkconfig --del in %preun, not %postun
557
558* Mon Aug 16 1999 Bill Nottingham <notting@redhat.com>
559- initscript munging
560
561* Mon Jul 26 1999 Bill Nottingham <notting@redhat.com>
562- fix installed chkconfig links to match init file
563
564* Sat Jul  3 1999 Jeff Johnson <jbj@redhat.com>
565- conflict with new (in man-1.24) man pages (#3876,#3877).
566
567* Tue Jun 29 1999 Bill Nottingham <notting@redhat.com>
568- fix named.logrotate (wrong %SOURCE)
569
570* Fri Jun 25 1999 Jeff Johnson <jbj@redhat.com>
571- update to 8.2.1.
572- add named.logrotate (#3571).
573- hack around egcs-1.1.2 -m486 bug (#3413, #3485).
574- vet file list.
575
576* Fri Jun 18 1999 Bill Nottingham <notting@redhat.com>
577- don't run by default
578
579* Sun May 30 1999 Jeff Johnson <jbj@redhat.com>
580- nslookup fixes (#2463).
581- missing files (#3152).
582
583* Sat May  1 1999 Stepan Kasal <kasal@math.cas.cz>
584- nslookup patched:
585  to count numRecords properly
586  to fix subsequent calls to ls -d
587  to parse "view" and "finger" commands properly
588  the view hack updated for bind-8 (using sed)
589
590* Wed Mar 31 1999 Bill Nottingham <notting@redhat.com>
591- add ISC patch
592- add quick hack to make host not crash
593- add more docs
594
595* Fri Mar 26 1999 Cristian Gafton <gafton@redhat.com>
596- add probing information in the init file to keep linuxconf happy
597- dont strip libbind
598
599* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
600- auto rebuild in the new build environment (release 3)
601
602* Wed Mar 17 1999 Preston Brown <pbrown@redhat.com>
603- removed 'done' output at named shutdown.
604
605* Tue Mar 16 1999 Cristian Gafton <gafton@redhat.com>
606- version 8.2
607
608* Wed Dec 30 1998 Cristian Gafton <gafton@redhat.com>
609- patch to use the __FDS_BITS macro
610- build for glibc 2.1
611
612* Wed Sep 23 1998 Jeff Johnson <jbj@redhat.com>
613- change named.restart to /usr/sbin/ndc restart
614
615* Sat Sep 19 1998 Jeff Johnson <jbj@redhat.com>
616- install man pages correctly.
617- change K10named to K45named.
618
619* Wed Aug 12 1998 Jeff Johnson <jbj@redhat.com>
620- don't start if /etc/named.conf doesn't exist.
621
622* Sat Aug  8 1998 Jeff Johnson <jbj@redhat.com>
623- autmagically create /etc/named.conf from /etc/named.boot in %post
624- remove echo in %post
625
626* Wed Jun 10 1998 Jeff Johnson <jbj@redhat.com>
627- merge in 5.1 mods
628
629* Sun Apr 12 1998 Manuel J. Galan <manolow@step.es>
630- Several essential modifications to build and install correctly.
631- Modified 'ndc' to avoid deprecated use of '-'
632
633* Mon Dec 22 1997 Scott Lampert <fortunato@heavymetal.org>
634- Used buildroot
635- patched bin/named/ns_udp.c to use <libelf/nlist.h> for include
636  on Redhat 5.0 instead of <nlist.h>
637
Note: See TracBrowser for help on using the repository browser.