source: projects/specs/trunk/b/bind-current/bind-current-vl.spec @ 7598

Revision 7598, 21.0 KB checked in by daisuke, 11 years ago (diff)

bind: update to 9.6-ESV-R8, remove conflicts to bind-current-libs
bind-current: update to 9.9.2-P2, remove condlicts to bind-libs

Line 
1%define _localstatedir /var
2
3%define sname bind
4%define pname bind-current
5%define pversion 9.9.2p2
6%define sversion 9.9.2-P2
7%define bind_epoch 1
8# fixed <BTS:VineLinux:1139>
9%define old_bind_version 1:9.6.ESV.R1
10
11%define bind_uid  25
12%define bind_gid  25
13
14Summary: A DNS (Domain Name System) server.
15Summary(ja): DNS (Domain Name System) サーバ
16Name: %{pname}
17Version: %{pversion}
18Release: 1%{?_dist_release}
19Epoch: %{bind_epoch}
20License: distributable
21Group: System Environment/Daemons
22Source: ftp://ftp.isc.org/isc/bind9/%{version}/%{sname}-%{sversion}.tar.gz
23Source1: bind-manpages.tar.bz2
24Source2: named.sysconfig
25Source3: named.init
26Source4: named.logrotate
27Source5: keygen.c
28URL: http://www.isc.org/bind.html
29Patch1: bind-9.3.3rc2-rndckey.patch
30
31Buildroot: %{_tmppath}/%{name}-%{version}-root
32BuildRequires: openssl-devel glibc-devel libtool
33BuildRequires: libxml2-devel
34BuildRequires: libcap-devel
35Requires: %{pname}-libs = %{bind_epoch}:%{version}-%{release}
36Requires(pre): shadow-utils
37Requires(post): %{pname}-utils = %{bind_epoch}:%{version}-%{release}
38Requires(post): coreutils, chkconfig
39Requires(preun): initscripts, chkconfig
40#Requires(triggerpostun): chkconfig
41Conflicts: bind9 <= 9.2.1-0vl5, bind < %{bind_epoch}:%{version}-%{release}
42Obsoletes: bind9 <= 9.2.1-0vl5, bind < %{old_bind_version}
43
44Vendor: Project Vine
45Distribution: Vine Linux
46Packager: daisuke
47
48%description
49BIND (Berkeley Internet Name Domain) is an implementation of the DNS
50(Domain Name System) protocols. BIND includes a DNS server (named),
51which resolves host names to IP addresses, and a resolver library
52(routines for applications to use when interfacing with DNS).  A DNS
53server allows clients to name resources or objects and share the
54information with other network machines.  The named DNS server can be
55used on workstations as a caching name server, but is generally only
56needed on one machine for an entire network.  Note that the
57configuration files for making BIND act as a simple caching nameserver
58are included in the caching-nameserver package. 
59
60Install the bind package if you need a DNS server for your network.  If
61you want bind to act a caching name server, you will also need to install
62the caching-nameserver package.
63
64
65%package libs
66Summary: Libraries used by various DNS packages
67Group: System Environment/Libraries
68
69%description libs
70Contains libraries used by both the bind server package as well as the utils packages.
71
72
73%package utils
74Summary: Utilities for querying DNS name servers.
75Summary(ja): DNS ネームサーバに問い合わせをするユーティリティ
76Group: Applications/System
77Requires: %{pname}-libs = %{bind_epoch}:%{version}-%{release}
78Conflicts: bind9-utils <= 9.2.1-0vl5
79Conflicts: bind-utils < %{bind_epoch}:%{version}-%{release}
80Obsoletes: bind9-utils <= 9.2.1-0vl5
81Obsoletes: bind-utils < %{old_bind_version}
82
83%description utils
84Bind-utils contains a collection of utilities for querying DNS (Domain
85Name Service) name servers to find out information about Internet hosts.
86These tools will provide you with the IP addresses for given host names,
87as well as other information about registered domains and network
88addresses.
89
90You should install bind-utils if you need to get information from DNS name
91servers.
92
93
94%package devel
95Summary: Include files and libraries needed for bind DNS development.
96Summary(ja): bind DNS 開発に必要なインクルードファイルとライブラリ
97Group: Development/Libraries
98Requires: %{pname} = %{bind_epoch}:%{version}-%{release}
99Requires: %{pname}-libs = %{bind_epoch}:%{version}-%{release}
100Conflicts: bind9-devel <= 9.2.1-0vl5
101Conflicts: bind-devel < %{bind_epoch}:%{version}-%{release}
102Obsoletes: bind9-devel <= 9.2.1-0vl5
103Obsoletes: bind-devel < %{old_bind_version}
104
105%description devel
106The bind-devel package contains all the include files and the
107library required for DNS (Domain Name Service) development for
108BIND versions 9.x.x.
109
110You should install bind-devel if you want to develop bind DNS
111applications. If you install bind-devel, you'll also need to install
112bind.
113#'
114
115%prep
116%setup -n bind-%{sversion} -q
117%patch1 -p1 -b .key
118perl -pi -e 's/^(SUBDIRS =.+)dlzexternal(.+)$/\1\2/' bin/tests/system/Makefile.in
119
120%build
121libtoolize --copy --force
122aclocal
123autoconf
124%configure \
125  --with-libtool \
126  --with-openssl=/usr \
127  --disable-openssl-version-ceck \
128  --enable-threads \
129  --enable-ipv6 \
130  --with-pic \
131  --with-dlz-dlopen \
132  --enable-filter-aaaa \
133  --enable-fixed-rrset
134make %{?_smp_mflags}
135
136%install
137rm -rf $RPM_BUILD_ROOT
138mkdir -p ${RPM_BUILD_ROOT}%{_sysconfdir}/{rc.d/init.d,logrotate.d}
139mkdir -p ${RPM_BUILD_ROOT}/usr/{bin,lib,sbin,include}
140mkdir -p ${RPM_BUILD_ROOT}/var/named
141mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/{man1,man5,man8}
142mkdir -p ${RPM_BUILD_ROOT}/var/run/named
143
144make DESTDIR=$RPM_BUILD_ROOT install
145install -c -m 640 bin/rndc/rndc.conf $RPM_BUILD_ROOT/etc
146install -c -m 755 contrib/named-bootconf/named-bootconf.sh $RPM_BUILD_ROOT/usr/sbin/named-bootconf
147install -c -m 755 %SOURCE3 $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/named
148install -c -m 644 %SOURCE4 $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/named
149touch $RPM_BUILD_ROOT%{_sysconfdir}/rndc.key
150gcc $RPM_OPT_FLAGS -o $RPM_BUILD_ROOT/usr/sbin/dns-keygen %{SOURCE5}
151cd $RPM_BUILD_ROOT%{_mandir}
152tar xjf %{SOURCE1}
153# newer version is contained in source
154rm -f man5/named.conf.5.gz
155mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
156cp %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/named
157
158chmod +x %{buildroot}%{_libdir}/*.so.*
159
160%pre
161if [ "$1" -eq 1 ]; then
162  /usr/sbin/groupadd -g %{bind_gid} -f -r named >/dev/null 2>&1 || :;
163  /usr/sbin/useradd  -u %{bind_uid} -r -N -M -g named -s /sbin/nologin -d /var/named -c Named named >/dev/null 2>&1 || :;
164fi;
165:;
166
167%post
168/sbin/ldconfig
169/sbin/chkconfig --add named
170if [ "$1" -eq 1 ]; then
171  if [ ! -e /etc/rndc.key ]; then
172    /usr/sbin/rndc-confgen -a > /dev/null 2>&1
173  fi
174  [ -x /sbin/restorecon ] && /sbin/restorecon /etc/rndc.* /etc/named.* >/dev/null 2>&1 ;
175  # rndc.key has to have correct perms and ownership, CVE-2007-6283
176  [ -e /etc/rndc.key ] && chown root:named /etc/rndc.key
177  [ -e /etc/rndc.key ] && chmod 0640 /etc/rndc.key
178
179  # Check DNSSEC settings if this is a fresh install
180  if [ -r /etc/sysconfig/dnssec ]; then
181    . /etc/sysconfig/dnssec
182    [ -x /usr/sbin/dnssec-configure ] && \
183      dnssec-configure -b --norestart --dnssec="$DNSSEC" --dlv="$DLV" > \
184        /dev/null 2>&1
185  fi;
186fi
187:;
188
189%preun
190if [ "$1" -eq 0 ]; then
191   /sbin/service named stop >/dev/null 2>&1 || :
192   /sbin/chkconfig --del named ||:
193fi
194exit 0
195
196
197%postun
198if [ "$1" -ge 1 ]; then
199        %{_sysconfdir}/rc.d/init.d/named condrestart >/dev/null 2>&1 || :
200fi
201/sbin/ldconfig
202
203%triggerpostun -- bind < 8.2.2_P5-15
204/sbin/chkconfig --add named
205/sbin/ldconfig
206
207%clean
208rm -rf ${RPM_BUILD_ROOT} ${RPM_BUILD_DIR}/%{name}-%{version}
209
210
211%post libs
212/sbin/ldconfig
213
214%postun libs
215/sbin/ldconfig
216
217
218%files
219%defattr(-,root,root)
220%doc CHANGES README
221%doc doc/arm doc/draft doc/rfc doc/misc
222%config(noreplace) %{_sysconfdir}/logrotate.d/named
223%config %{_sysconfdir}/rc.d/init.d/named
224%config(noreplace) %{_sysconfdir}/sysconfig/named
225%config(noreplace) %attr(0640,root,named) %{_sysconfdir}/rndc.conf
226%config(noreplace) %attr(0640,root,named) %{_sysconfdir}/rndc.key
227%config(noreplace) %attr(0640,root,named) %{_sysconfdir}/bind.keys
228
229%{_sbindir}/dnssec*
230%{_sbindir}/lwresd
231%{_sbindir}/named
232%{_sbindir}/named-bootconf
233%{_sbindir}/named-check*
234%{_sbindir}/named-compilezone
235%{_sbindir}/rndc*
236%{_sbindir}/dns-keygen
237%{_sbindir}/arpaname
238%{_sbindir}/ddns-confgen
239%{_sbindir}/genrandom
240%{_sbindir}/isc-hmac-fixup
241%{_sbindir}/named-journalprint
242%{_sbindir}/nsec3hash
243
244%{_mandir}/man1/arpaname.1*
245%{_mandir}/man5/resolv.conf.5*
246%{_mandir}/man5/named.conf.5*
247%{_mandir}/man5/rndc.conf.5*
248%{_mandir}/man8/rndc.8*
249%{_mandir}/man8/named.8*
250%{_mandir}/man8/lwresd.8*
251%{_mandir}/man8/dnssec*.8*
252%{_mandir}/man8/named-checkconf.8*
253%{_mandir}/man8/named-checkzone.8*
254%{_mandir}/man8/named-compilezone.8*
255%{_mandir}/man8/rndc-confgen.8*
256%{_mandir}/man8/ddns-confgen.8*
257%{_mandir}/man8/genrandom.8*
258%{_mandir}/man8/isc-hmac-fixup.8*
259%{_mandir}/man8/named-journalprint.8*
260%{_mandir}/man8/nsec3hash.8*
261
262%attr(-,named,named) %dir %{_var}/named
263%attr(-,named,named) %dir %{_var}/run/named
264     
265
266%files libs
267%defattr(-,root,root)
268%{_libdir}/*.so.*
269
270%files utils
271%defattr(-,root,root)
272%{_bindir}/dig
273%{_bindir}/host
274%{_bindir}/nslookup
275%{_bindir}/nsupdate
276%{_mandir}/man1/host.1*
277%{_mandir}/man1/nsupdate.1*
278%{_mandir}/man1/dig.1*
279%{_mandir}/man5/resolver.5*
280%{_mandir}/man1/nslookup.1*
281%{_mandir}/man8/nslookup.8*
282
283
284%files devel
285%defattr(-,root,root)
286%{_libdir}/*.so
287%{_libdir}/*.a
288%{_includedir}/*
289%{_mandir}/man3/*
290%{_mandir}/man1/isc-config.sh.1*
291%{_bindir}/isc-config.sh
292
293%changelog
294* Thu Mar 28 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 9.9.2p2-1
295- update to 9.9.2-P2
296- remove .la
297- remove Conflicts/Obsoletes from libs subpackage.
298- add configure options
299  --enable-ipv6 --with-pic --enable-filter-aaaa --enable-fixed-rrset
300
301* Tue Dec 18 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.8.4p1-1
302- new upstream release.
303- added an option "--with-dlz-dlopen".
304
305* Tue May 31 2011 IWAI, Masaharu <iwai@alib.jp> 9.8.0p2-2
306- Obosoletes: bind.* < 1:9.6.ESV.R1
307 - fixed <BTS:VineLinux:1139>
308
309* Sun May 29 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.8.0p2-1
310- new upstream release with security fix (CVE-2011-1910)
311
312* Tue May 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.8.0p1-2
313- add BuildRequires: libxml2-devel, libcap-devel
314
315* Mon May  9 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.8.0p1-1
316- new upstream release with security fix (CVE-2011-1907)
317- fix changelog typo
318
319* Sat Apr 09 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 9.8.0-2
320- Obosoletes: bind.* < 1:9.6.ESV.R1
321
322* Thu Apr 07 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 9.8.0-1
323- update to 9.8.0
324- remove Provides: bind.* = %%{bind_epoch}:%{version}-%{release}
325
326* Mon Jan 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.7.2P2-3
327- rebuild with openssl-1.0.0c
328
329* Sun Oct 24 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.7.2P2-2
330- fix Req: in bind package
331
332* Wed Oct 20 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.7.2P2-1
333- change package name bind -> bind-current
334- add epoch 1
335- new upstream release
336
337* Sat Jul 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 9.7.1P2-1
338- new upstream release
339
340* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 9.6.1P3-4
341- rebuilt with gcc-4.4.3-3 on ppc
342
343* Sat Feb  6 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 9.6.1P3-3
344- rebuilt with new toolchains (for VineSeed)
345- s/BuildPrereq/BuildRequires/
346
347* Thu Jan 21 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P3-2
348- add man1/isc-config.sh.1 into devel file list
349
350* Wed Jan 20 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P3-1
351- new upstream release with security fix (CVE-2009-4022, 2010-0097) 
352
353* Sat Dec 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P2-1
354- new upstream release with security fix (CVE-2009-4022)
355
356* Wed Jul 29 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P1-1
357- new upstream release with security fix
358
359* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 9.6.1-1
360- new upstream release
361- clean up %%post/%%pre scriptlet
362  - create named user and group in %%pre
363  - don't remove named user/group in %%preun
364  - use rndc-confgen to create rndc.key
365
366* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 9.6.0P1-1
367- new upstream release
368- drop patch0 and patch14, merged in upstream
369
370* Sun Jan 11 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.5.1P1-1
371- new upstream release with security fix
372
373* Wed Jul 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 9.5.0P1-1
374- new upstream release with security fix
375- new versioning policy
376
377* Sun Sep 30 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 9.4.1P1-0vl1
378- new upstream release with security fix
379
380* Fri May 18 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 9.4.1-0vl1
381- new upstream release
382- build with new openssl/toolchain
383
384* Tue Jan 30 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.4-0vl1
385- new upstream release with security fix
386
387* Fri Nov 03 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2P2-0vl1
388- new upstream release
389
390* Fri Sep 08 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.2P1-0vl2
391- add Prereq sed
392
393* Wed Sep 06 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.2P1-0vl1
394- new upstream release for security fix (CVE-2006-4095,4096)
395
396* Wed Feb 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 9.3.2-0vl3
397- separate -libs package
398- remove old named.conf.5.gz
399  - newer version is contained in source
400
401* Thu Feb 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2-0vl2
402- add bsdcompat patch (Patch4)
403- add fix_h_errno patch from FC
404  - h_errno not being accessed / set correctly in libbind
405
406* Thu Feb 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2-0vl1
407- new upstream release
408
409* Sun Nov  7 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 9.2.4-0vl2
410- added PreReq to bind-utils (see: [VineSeed:09555])
411
412* Thu Oct 28 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.4-0vl1
413- new upstream release
414
415* Wed Nov 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl3
416- fix /etc/init.d/named to use rndc
417
418* Tue Nov 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl2
419- rebuild to remove unneeded dependancy
420
421* Mon Nov 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl1
422- new upstream release
423
424* Tue Mar  4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.2-0vl1
425- new upstream release
426
427* Thu Nov 28 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl7
428- fix dependancies.
429
430* Wed Nov 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl6
431- add obsoletes: and conflicts: to bind9, bind9-utils, bind9-devel <= 9.2.1-0vl5
432- change package name to bind for VineSeed.
433- use more macros.
434
435* Sat Oct 19 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl5
436- fixed some macros
437- add conflicts: to bind-* in bind9-devel and bind9-utils
438- add provides: bind = %%{version}
439
440* Sat Oct 19 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl4
441- use %%configure macros
442
443* Sat Oct 19 2002 Michihide Hotta <hotta@net-newbie.com> 9.2.1-0vl3
444- fixed inconsistent dependency
445
446* Wed Aug 14 2002 Satoshi MACHINO <machino@vinelinux.org> 9.2.1-0vl2
447- updated to 9.2.2rc1
448
449* Thu May 02 2002 Satoshi MACHINO <machino@vinelinux.org> 9.2.1-0vl0
450- updated to bind9(9.2.1), test packages ;)
451        -- based on Rawhide's bind-9.2.0-8
452        -- changed name bind9
453        -- added Conflicts: bind
454
455* Sun Feb 03 2002 Toru Sagami <sagami@vinelinux.org> 8.3.1-0vl1
456- release 8.3.1 includes security fixes
457
458* Mon Jan 14 2002 Toru Sagami <sagami@vinelinux.org> 8.3.0-0vl1
459- Upgraded to current stable release 8.3.0
460
461* Mon Oct  8 2001 <zn@mbf.nifty.com>
462- 8.2.5-0vl0: Upgraded to new upstream version.
463
464* Thu May 24 2001 <sagami@vinelinux.org>
465- 8.2.4-0vl1: eliminate CVS related files from %%doc
466
467* Thu May 17 2001 <sagami@vinelinux.org>
468- 8.2.4-0vl0
469
470* Fri Feb 02 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
471- 8.2.3-1vl2
472- built on VineSeed
473
474* Tue Jan 30 2001 KAJIKI Yoshihiro <kajiki@ylug.org>
475- add doc/old
476- build for Vine 2.1
477
478* Sat Jan 27 2001 Bernhard Rosenkraenzer <bero@redhat.com>
479- 8.2.3, fixes several security problems
480
481* Tue Nov 14 2000 Bill Nottingham <notting@redhat.com>
482- static libraries may be used in shared objects. Build with -fPIC on ia64
483
484* Fri Nov 10 2000 Bernhard Rosenkraenzer <bero@redhat.com>
485- 8.2.2-P7 (fixes Bug #20546)
486
487* Sat Aug 05 2000 Bill Nottingham <notting@redhat.com>
488- condrestart fixes
489
490* Tue Jul 18 2000 Nalin Dahyabhai <nalin@redhat.com>
491- change the init script to take condrestart, not cond-restart
492- add sh-utils, /bin/cat, perl, /bin/chmod, /usr/sbin/useradd as prereqs for
493  the %pre and %post scripts
494
495* Sun Jul 16 2000 Bernhard Rosenkraenzer <bero@redhat.com>
496- Don't prereq /etc/init.d
497
498* Sat Jul 15 2000 Bill Nottingham <notting@redhat.com>
499- move initscript back
500
501* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
502- automatic rebuild
503
504* Sun Jul  9 2000 Florian La Roche <Florian.LaRoche@redhat.de>
505- add "exit 0" for uninstall case
506
507* Fri Jul  7 2000 Florian La Roche <Florian.LaRoche@redhat.de>
508- add prereq init.d and cleanup install section
509
510* Fri Jun 30 2000 Trond Eivind Glomsr <teg@redhat.com>
511- fix the init script
512
513* Wed Jun 28 2000 Nalin Dahyabhai <nalin@redhat.com>
514- make libbind.a and nslookup.help readable again by setting INSTALL_LIB to ""
515
516* Mon Jun 26 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
517- Fix up the initscript (Bug #13033)
518- Fix build with current glibc (Bug #12755)
519- /etc/rc.d/init.d -> /etc/init.d
520- use %%{_mandir} rather than /usr/share/man
521
522* Mon Jun 19 2000 Bill Nottingham <notting@redhat.com>
523- fix conflict with man-pages
524- remove compatibilty chkconfig links
525- initscript munging
526
527* Wed Jun 14 2000 Nalin Dahyabhai <nalin@redhat.com>
528- modify logrotate setup to use PID file
529- temporarily disable optimization by unsetting $RPM_OPT_FLAGS at build-time
530- actually bump the release this time
531
532* Sun Jun  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
533- FHS compliance
534
535* Mon Apr 17 2000 Nalin Dahyabhai <nalin@redhat.com>
536- clean up restart patch
537
538* Mon Apr 10 2000 Nalin Dahyabhai <nalin@redhat.com>
539- provide /var/named (fix for bugs #9847, #10205)
540- preserve args when restarted via ndc(8) (bug #10227)
541- make resolv.conf(5) a link to resolver(5) (bug #10245)
542- fix SYSTYPE bug in all makefiles
543- move creation of named user from %%post into %%pre
544
545* Mon Feb 28 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
546- Fix TTL (patch from ISC, Bug #9820)
547
548* Wed Feb 16 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
549- fix typo in spec (it's %post, without a leading blank) introduced in -6
550- change SYSTYPE to linux
551
552* Fri Feb 11 2000 Bill Nottingham <notting@redhat.com>
553- pick a standard < 100 uid/gid for named
554
555* Fri Feb 04 2000 Elliot Lee <sopwith@redhat.com>
556- Pass named a '-u named' parameter by default, and add/remove user.
557
558* Thu Feb  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
559- fix host mx bug (Bug #9021)
560
561* Mon Jan 31 2000 Cristian Gafton <gafton@redhat.com>
562- rebuild to fix dependencies
563- man pages are compressed
564
565* Wed Jan 19 2000 Bernhard Rosenkraenzer <bero@redhat.com>
566- It's /usr/bin/killall, not /usr/sbin/killall (Bug #8063)
567
568* Mon Jan 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
569- Fix up location of named-bootconf.pl and make it executable
570  (Bug #8028)
571- bind-devel requires bind
572
573* Mon Nov 15 1999 Bernhard Rosenkraenzer <bero@redhat.com>
574- update to 8.2.2-P5
575
576* Wed Nov 10 1999 Bill Nottingham <notting@redhat.com>
577- update to 8.2.2-P3
578
579* Tue Oct 12 1999 Cristian Gafton <gafton@redhat.com>
580- add patch to stop a cache only server from complaining about lame servers
581  on every request.
582
583* Fri Sep 24 1999 Preston Brown <pbrown@redhat.com>
584- use real stop and start in named.init for restart, not ndc restart, it has
585  problems when named has changed during a package update... (# 4890)
586
587* Fri Sep 10 1999 Bill Nottingham <notting@redhat.com>
588- chkconfig --del in %preun, not %postun
589
590* Mon Aug 16 1999 Bill Nottingham <notting@redhat.com>
591- initscript munging
592
593* Mon Jul 26 1999 Bill Nottingham <notting@redhat.com>
594- fix installed chkconfig links to match init file
595
596* Sat Jul  3 1999 Jeff Johnson <jbj@redhat.com>
597- conflict with new (in man-1.24) man pages (#3876,#3877).
598
599* Tue Jun 29 1999 Bill Nottingham <notting@redhat.com>
600- fix named.logrotate (wrong %SOURCE)
601
602* Fri Jun 25 1999 Jeff Johnson <jbj@redhat.com>
603- update to 8.2.1.
604- add named.logrotate (#3571).
605- hack around egcs-1.1.2 -m486 bug (#3413, #3485).
606- vet file list.
607
608* Fri Jun 18 1999 Bill Nottingham <notting@redhat.com>
609- don't run by default
610
611* Sun May 30 1999 Jeff Johnson <jbj@redhat.com>
612- nslookup fixes (#2463).
613- missing files (#3152).
614
615* Sat May  1 1999 Stepan Kasal <kasal@math.cas.cz>
616- nslookup patched:
617  to count numRecords properly
618  to fix subsequent calls to ls -d
619  to parse "view" and "finger" commands properly
620  the view hack updated for bind-8 (using sed)
621
622* Wed Mar 31 1999 Bill Nottingham <notting@redhat.com>
623- add ISC patch
624- add quick hack to make host not crash
625- add more docs
626
627* Fri Mar 26 1999 Cristian Gafton <gafton@redhat.com>
628- add probing information in the init file to keep linuxconf happy
629- dont strip libbind
630
631* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
632- auto rebuild in the new build environment (release 3)
633
634* Wed Mar 17 1999 Preston Brown <pbrown@redhat.com>
635- removed 'done' output at named shutdown.
636
637* Tue Mar 16 1999 Cristian Gafton <gafton@redhat.com>
638- version 8.2
639
640* Wed Dec 30 1998 Cristian Gafton <gafton@redhat.com>
641- patch to use the __FDS_BITS macro
642- build for glibc 2.1
643
644* Wed Sep 23 1998 Jeff Johnson <jbj@redhat.com>
645- change named.restart to /usr/sbin/ndc restart
646
647* Sat Sep 19 1998 Jeff Johnson <jbj@redhat.com>
648- install man pages correctly.
649- change K10named to K45named.
650
651* Wed Aug 12 1998 Jeff Johnson <jbj@redhat.com>
652- don't start if /etc/named.conf doesn't exist.
653
654* Sat Aug  8 1998 Jeff Johnson <jbj@redhat.com>
655- autmagically create /etc/named.conf from /etc/named.boot in %post
656- remove echo in %post
657
658* Wed Jun 10 1998 Jeff Johnson <jbj@redhat.com>
659- merge in 5.1 mods
660
661* Sun Apr 12 1998 Manuel J. Galan <manolow@step.es>
662- Several essential modifications to build and install correctly.
663- Modified 'ndc' to avoid deprecated use of '-'
664
665* Mon Dec 22 1997 Scott Lampert <fortunato@heavymetal.org>
666- Used buildroot
667- patched bin/named/ns_udp.c to use <libelf/nlist.h> for include
668  on Redhat 5.0 instead of <nlist.h>
669
Note: See TracBrowser for help on using the repository browser.