source: projects/specs/trunk/b/beepmp/beepmp-vl.spec @ 521

Revision 521, 6.3 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define srcname bmp
2#%%define extraver rc2
3
4# build ALSA output plugin
5%define with_alsa 1
6
7Summary:        Beep Media Player
8Name:           beepmp
9Version:        0.9.7.1
10Release:        1%{?_dist_release}
11License:        GPL
12Group:          Applications/Multimedia
13URL:            http://bmp.beep-media-player.org/
14Source:         http://prdownloads.sourceforge.net/beepmp/bmp-%{version}%{?extraver:%extraver}.tar.gz
15Source1:        %{name}.desktop
16# based on bmp-%{version}'s ja.po
17Source2:        beepmp-0.9.7.1-ja.po
18Patch2:         beepmp-0.9.7-except-flac.patch
19BuildRoot:      %{_tmppath}/%{name}-%{version}-root
20Requires:       gtk2 >= 2.4.0, libglade2 >= 2.3.1
21Requires:       esound >= 0.2, libvorbis, id3lib
22BuildRequires:  gtk2-devel >= 2.4.0, libglade2-devel >= 2.3.1
23BuildRequires:  esound-devel >= 0.2, libvorbis-devel, id3lib-devel
24
25Requires(post):   ldconfig, desktop-file-utils
26Requires(postun): ldconfig, desktop-file-utils
27
28Vendor:         Project Vine
29Distribution:   Vine Linux
30
31%description
32Beep Media Player (BMP) is a GTK2 port of the popular X Multimedia
33System (XMMS) and more.
34
35%description -l ja
36Beep Media Player (BMP) は定番の X Multimedia System (XMMS) を GTK2 に
37移植したメディアプレイヤーです。
38
39%package devel
40Summary:        BMP - Static libraries and header files.
41Summary(ja):    BMP - 静的ライブラリ及びヘッダファイル
42Group:          Development/Libraries
43Requires:       %{name} = %{version}-%{release}, gtk2-devel
44
45%description devel
46Static libraries and header files required for compiling Beep Media Player
47plugins.
48
49%description -l ja devel
50Beep Media Player のプラグインをコンパイルするのに必要な静的ライブラリ
51及びヘッダファイルです。
52
53%if %{with_alsa}
54%package alsa
55Summary:        BMP - ALSA output plugin
56Summary(ja):    BMP - ALSA 出力プラグイン
57Group:          Applications/Multimedia
58Requires:       %{name} = %{version}-%{release}
59Requires:       alsa-lib >= 1.0.0
60BuildRequires:  alsa-lib-devel >= 1.0.0
61
62%description alsa
63Output plugin for Beep Media Player to use with the Advanced Linux Sound
64Architecture (ALSA).
65
66%description -l ja alsa
67Beep Media Player で Advanced Linux Sound Architecture (ALSA) を用いて
68音声を出力するためのプラグインです。
69%endif
70
71%prep
72%setup -q -n %{srcname}-%{version}%{?extraver:%extraver}
73
74%patch2 -p1 -b .ex-flac
75%__cp -f %{SOURCE2} po/ja.po
76
77%build
78%configure \
79%if ! %{with_alsa}
80        --disable-alsa \
81%endif
82        --disable-gconf \
83        --disable-gnome-vfs
84%__make %{_smp_mflags}
85( cd po ; %__make update-gmo )
86
87%install
88%__rm -rf %{buildroot}
89%__make DESTDIR=%{buildroot} install
90%find_lang %{srcname}
91
92%__rm -f %{buildroot}%{_libdir}/bmp/*/*.la
93%__rm -f %{buildroot}%{_datadir}/applications/bmp.desktop
94%__install -p -m644 %{SOURCE1} %{buildroot}%{_datadir}/applications
95
96%__mv -f %{buildroot}%{_datadir}/pixmaps/bmp.png %{buildroot}%{_datadir}/pixmaps/beepmp.png
97
98%post
99%{_syssbindir}/ldconfig
100%{_bindir}/update-desktop-database %{_datadir}/applications >& /dev/null ||:
101
102%postun
103%{_syssbindir}/ldconfig
104%{_bindir}/update-desktop-database %{_datadir}/applications >& /dev/null ||:
105
106%clean
107%__rm -rf %{buildroot}
108
109%files -f %{srcname}.lang
110%defattr(-,root,root,-)
111%doc AUTHORS COPYING ChangeLog NEWS README FAQ
112%{_bindir}/beep-media-player
113%{_datadir}/bmp
114%{_datadir}/pixmaps/*
115%{_datadir}/applications/%{name}.desktop
116%dir %{_libdir}/bmp
117%dir %{_libdir}/bmp/Input
118%{_libdir}/bmp/Input/libcdaudio.so
119%{_libdir}/bmp/Input/libwav.so
120%{_libdir}/bmp/Input/libmpg123.so
121%{_libdir}/bmp/Input/libvorbis.so
122%dir %{_libdir}/bmp/Output
123%{_libdir}/bmp/Output/*.so
124%if %{with_alsa}
125%exclude %{_libdir}/bmp/Output/libALSA.*
126%endif
127%{_libdir}/bmp/Visualization
128%{_libdir}/lib*.so.*
129%{_mandir}/man1/*
130
131%files devel
132%defattr(-,root,root,-)
133%{_includedir}/bmp
134%{_libdir}/lib*.so
135%{_libdir}/lib*.la
136#%{_libdir}/lib*.a
137%{_libdir}/pkgconfig/*.pc
138
139%if %{with_alsa}
140%files alsa
141%defattr(-,root,root,-)
142%{_libdir}/bmp/Output/libALSA.so
143%endif
144
145%changelog
146* Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 0.9.7.1-1vl5
147- applied new versioning policy, spec in utf-8
148
149* Mon May 21 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.7.1-0vl3
150- rebuilt with new toolchain
151
152* Sat Jan 14 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.7.1-0vl2
153- fix %%files
154
155* Wed Jan 11 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.7.1-0vl1
156- upstream release
157- drop obsolete patches
158- update ja.po
159
160* Thu Jun 23 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.7-0vl5
161- rebuild with alsa support
162- remove %%{_libdir}/bmp/*/*.la
163
164* Fri Apr 01 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.7-0vl4
165- add beepmp.png (source3)
166- update desktop file
167  - add application/ogg
168  - use beepmp.png
169- run update-desktop-database at post/postun
170- add Requires(post/postun): ldconfig, desktop-file-utils
171
172* Thu Feb 10 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.7-0vl3
173- add except-flac.patch (patch2)
174      to prevent mpg123 plugin's hijacking FLAC stream
175  (ref. http://bugs.xmms.org/show_bug.cgi?id=2038)
176
177* Sat Jan 29 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.7-0vl2
178- use correct field name "date" in vorbis plugin (patch1)
179  - thanks, MVA [VinePlus:02251]
180- fix typo in ja.po
181
182* Sun Dec 12 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.7-0vl1
183- upstream release
184- update ja.po
185
186* Fri Nov 12 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.7-0vl0.rc2.2
187- update ja.po
188
189* Sun Nov 07 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.7-0vl0.rc2.1
190- update ja.po
191- add playlist-drawstring-utf8.patch (patch1)
192
193* Fri Nov 05 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.7-0vl0.rc2
194- initial build for Vine Linux
195
196* Tue Jul 6 2004 Chong Kai Xiong <descender@phreaker.net> 0:0.9.7-1
197- fixed file list to own package-specific directories
198- remove vendor, add epoch tag, explicit requires, add unzip to requires
199- force version match between plugins and main package
200- use %find_lang
201- don't install INSTALL
202
203* Thu Jun 24 2004 Chong Kai Xiong <descender@phreaker.net> 0.9.7-3
204- added support for GConf and GNOME VFS
205- fixed file list
206
207* Fri May 28 2004 Chong Kai Xiong <descender@phreaker.net> 0.9.7-2
208- require libglade 2.0
209
210* Sun Apr 05 2004 Chong Kai Xiong <descender@phreaker.net> 0.9.7-1
211- require GTK 2.4 and ALSA 1.0
212
213* Tue Jan 13 2004 David Lau <coder_sku@sourceforge.net> 0.9.6-3
214- removes plugin .la's
215
216* Wed Dec 24 2003 Chong Kai Xiong <descender@phreaker.net> 0.9.6-2
217- first fully usable version
218
219* Tue Nov 29 2003 Chong Kai Xiong <descender@phreaker.net> 0.9.6-1
220- added support for --with switches
221
222* Tue Nov 11 2003 Chong Kai Xiong <descender@phreaker.net> 1.0.0pre6
223- initial build
Note: See TracBrowser for help on using the repository browser.