source: projects/specs/trunk/b/bcel/bcel-vl.spec @ 9447

Revision 9447, 9.1 KB checked in by inagaki, 9 years ago (diff)

2015-03-21 Ryoichi INAGAKi <ryo1@…>

  • antlr, junit, xalan-j2: updated
  • bcel, xml-stylebook: new


Line 
1# Copyright (c) 2000-2007, JPackage Project
2# All rights reserved.
3#
4# Redistribution and use in source and binary forms, with or without
5# modification, are permitted provided that the following conditions
6# are met:
7#
8# 1. Redistributions of source code must retain the above copyright
9#    notice, this list of conditions and the following disclaimer.
10# 2. Redistributions in binary form must reproduce the above copyright
11#    notice, this list of conditions and the following disclaimer in the
12#    documentation and/or other materials provided with the
13#    distribution.
14# 3. Neither the name of the JPackage Project nor the names of its
15#    contributors may be used to endorse or promote products derived
16#    from this software without specific prior written permission.
17#
18# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
19# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
20# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
21# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
22# OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
23# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
24# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
25# DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
26# THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
27# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
28# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
29#
30
31Name:           bcel
32Version:        5.2
33Release:        8%{?_dist_release}
34Summary:        Byte Code Engineering Library
35
36License:        ASL 2.0
37Group:          Development/Libraries
38URL:            http://commons.apache.org/proper/commons-bcel/
39
40Source0:        %{name}-%{version}.tar.gz
41
42BuildRoot:      %{_tmppath}/%{name}-%{version}-root
43BuildArch:      noarch
44Requires:       regexp
45#Requires(post):    javapackages-tools >= 1.7.2
46#Requires(postun):  javapackages-tools >= 1.7.2
47
48%description
49The Byte Code Engineering Library (formerly known as JavaClass) is
50intended to give users a convenient possibility to analyze, create, and
51manipulate (binary) Java class files (those ending with .class). Classes
52are represented by objects which contain all the symbolic information of
53the given class: methods, fields and byte code instructions, in
54particular.  Such objects can be read from an existing file, be
55transformed by a program (e.g. a class loader at run-time) and dumped to
56a file again. An even more interesting application is the creation of
57classes from scratch at run-time. The Byte Code Engineering Library
58(BCEL) may be also useful if you want to learn about the Java Virtual
59Machine (JVM) and the format of Java .class files.  BCEL is already
60being used successfully in several projects such as compilers,
61optimizers, obsfuscators and analysis tools, the most popular probably
62being the Xalan XSLT processor at Apache.
63
64%package javadoc
65Summary:        Javadoc for %{name}
66Summary(ja):    %{name} の Javadoc
67Group:          Documentation
68
69%description javadoc
70%{summary}.
71
72%package manual
73Summary:        Manual for %{name}
74Summary(ja):    %{name} のマニュアル
75Group:          Documentation
76
77%description manual
78%{summary}.
79
80%prep
81%setup -q
82#cat <<EOT
83#
84# This is initial build for Vine Linux.
85# Binary archive is provided.
86#
87#EOT
88
89# fix wrong-file-end-of-line-encoding
90#sed -i 's/\r//' docs/verifier/V_API_SD.eps docs/eps/classloader.fig
91
92%build
93# nothing to do
94
95%install
96rm -rf %{buildroot}
97# jars
98mkdir -p %{buildroot}%{_javadir}
99install -m 0644 %{name}-%{version}.jar \
100    %{buildroot}%{_javadir}/%{name}-%{version}.jar
101(
102    cd %{buildroot}%{_javadir}
103    for jar in *-%{version}*; do
104        ln -s ${jar} `echo $jar | %{__sed}  "s|-%{version}||g"`
105    done
106)
107
108# javadoc
109mkdir -p %{buildroot}%{_javadocdir}/%{name}-%{version}
110cp -pr docs/apidocs/* %{buildroot}%{_javadocdir}/%{name}-%{version}
111rm -rf docs/apidocs
112
113ln -s %{name}-%{version} %{buildroot}%{_javadocdir}/%{name}
114
115# manual
116mkdir -p %{buildroot}%{_docdir}/%{name}-%{version}
117cp -pr docs/* %{buildroot}%{_docdir}/%{name}-%{version}
118#cp -p LICENSE.txt %{buildroot}%{_docdir}/%{name}-%{version}
119
120%clean
121rm -rf %{buildroot}
122
123
124%files
125%defattr(0644,root,root,0755)
126%doc LICENSE.txt
127#doc %{_docdir}/%{name}-%{version}
128#doc %{_docdir}/%{name}-%{version}/LICENSE.txt
129%{_javadir}/*
130#{_datadir}/maven2/poms/*
131#{_mavendepmapfragdir}
132
133%files javadoc
134%defattr(0644,root,root,0755)
135%{_javadocdir}/%{name}-%{version}
136%doc %{_javadocdir}/%{name}
137
138%files manual
139%defattr(0644,root,root,0755)
140%doc %{_docdir}/%{name}-%{version}
141
142%changelog
143* Fri Mar 20 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 5.2-8
144- Initial build for Vine Linux
145
146* Mon Nov 30 2009 Dennis Gregorovic <dgregor@redhat.com> - 0:5.2-7.2
147- Rebuilt for RHEL 6
148
149* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0:5.2-7.1
150- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
151
152* Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0:5.2-6.1
153- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
154
155* Thu Dec 04 2008 Permaine Cheung <pcheung at redhat.com> 0:5.2-5.1
156- Do not install poms in /usr/share/maven2/default_poms
157
158* Wed Jul  9 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0:5.2-5
159- drop repotag
160
161* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0:5.2-4jpp.2
162- Autorebuild for GCC 4.3
163
164* Tue Jan 22 2008 Permaine Cheung <pcheung at redhat.com> 0:5.2-3jpp.1
165- Merge with upstream
166
167* Mon Jan 07 2008 Permaine Cheung <pcheung at redhat.com> 0:5.2-2jpp.2
168- Fixed unowned directory (Bugzilla 246185)
169
170* Fri Nov 16 2007 Ralph Apel <r.apel@r-apel.de> 0:5.2-3jpp
171- Install poms unconditionally
172- Add pom in ./maven2/default_poms
173- Add org.apache.bcel:bcel depmap frag
174
175* Wed Sep 19 2007 Permaine Cheung <pcheung at redhat.com> 0:5.2-2jpp.1
176- Update to 5.2 in Fedora
177
178* Mon Sep  4 2007 Jason Corley <jason.corley@gmail.com> 0:5.2-2jpp
179- use official 5.2 release tarballs and location
180- change vendor and distribution to macros
181- add missing requires on and maven-plugin-test, maven-plugins-base, and
182  maven-plugin-xdoc
183- macro bracket fixes
184- remove demo subpackage (examples are not included in the distribution tarball)
185- build in mock
186
187* Wed Jun 27 2007 Ralph Apel <r.apel@r-apel.de> 0:5.2-1jpp
188- Upgrade to 5.2
189- Drop bootstrap option: not necessary any more
190- Add pom and depmap frags
191
192* Fri Feb 09 2007 Ralph Apel <r.apel@r-apel.de> 0:5.1-10jpp
193- Fix empty-%%post and empty-%%postun
194- Fix no-cleaning-of-buildroot
195
196* Fri Feb 09 2007 Ralph Apel <r.apel@r-apel.de> 0:5.1-9jpp
197- Optionally build without maven
198- Add bootstrap option
199
200* Thu Aug 10 2006 Matt Wringe <mwringe at redhat.com> 0:5.1-8jpp
201- Add missing requires for Javadoc task
202
203* Sun Jul 23 2006 Matt Wringe <mwringe at redhat.com> 0:5.1-7jpp
204- Add conditional native compilation
205- Change spec file encoding from ISO-8859-1 to UTF-8
206- Add missing BR werken.xpath and ant-apache-regexp
207
208* Tue Apr 11 2006 Ralph Apel <r.apel@r-apel.de> 0:5.1-6jpp
209- First JPP-1.7 release
210- Use tidyed sources from svn
211- Add resources to build the manual
212- Add examples to -demo subpackage
213- Build with maven by default
214- Add option to build with straight ant
215
216* Fri Nov 19 2004 David Walluck <david@jpackage.org> 0:5.1-5jpp
217- rebuild to fix packager
218
219* Sat Nov 06 2004 David Walluck <david@jpackage.org> 0:5.1-4jpp
220- rebuild with javac 1.4.2
221
222* Sat Oct 16 2004 David Walluck <david@jpackage.org> 0:5.1-3jpp
223- rebuild for JPackage 1.6
224
225* Fri Aug 20 2004 Ralph Apel <r.apel at r-apel.de> 0:5.1-2jpp
226- Build with ant-1.6.2
227
228* Sun May 11 2003 David Walluck <david@anti-microsoft.org> 0:5.1-1jpp
229- 5.1
230- update for JPackage 1.5
231
232* Mon Mar 24 2003 Nicolas Mailhot <Nicolas.Mailhot (at) JPackage.org> - 5.0-6jpp
233- For jpackage-utils 1.5
234
235* Tue Feb 25 2003 Ville Skyttä <ville.skytta at iki.fi> - 5.0-5jpp
236- Rebuild to get docdir right on modern distros.
237- Fix License tag and source file perms.
238- Built with IBM's 1.3.1SR3 (doesn't build with Sun's 1.4.1_01).
239
240* Tue Jun 11 2002 Henri Gomez <hgomez@slib.fr> 5.0-4jpp
241- use sed instead of bash 2.x extension in link area to make spec compatible
242  with distro using bash 1.1x
243
244* Tue May 07 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 5.0-3jpp
245- vendor, distribution, group tags
246
247* Wed Jan 23 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 5.0-2jpp
248- section macro
249- no dependencies for manual and javadoc package
250
251* Tue Jan 22 2002 Henri Gomez <hgomez@slib.fr> 5.0-1jpp
252- bcel is now a jakarta apache project
253- dependency on jakarta-regexp instead of gnu.regexp
254- created manual package
255
256* Sat Dec 8 2001 Guillaume Rousse <guillomovitch@users.sourceforge.net> 4.4.1-2jpp
257- javadoc into javadoc package
258- Requires: and BuildRequires: gnu.regexp
259
260* Wed Nov 21 2001 Christian Zoffoli <czoffoli@littlepenguin.org> 4.4.1-1jpp
261- removed packager tag
262- new jpp extension
263- 4.4.1
264
265* Thu Oct 11 2001 Guillaume Rousse <guillomovitch@users.sourceforge.net> 4.4.0-2jpp
266- first unified release
267- used lower case for name
268- used original tarball
269- s/jPackage/JPackage
270
271* Mon Aug 27 2001 Guillaume Rousse <guillomovitch@users.sourceforge.net> 4.4.0-1mdk
272- first Mandrake release
Note: See TracBrowser for help on using the repository browser.