source: projects/specs/trunk/b/bareftp/bareftp-vl.spec @ 8067

Revision 8067, 2.4 KB checked in by Takemikaduchi, 10 years ago (diff)

new upstream release or rebuild

Line 
1%define pkg_version 0.3.10
2%define pkg_release 1%{?_dist_release}
3
4Summary:        File Transfer Client
5Summary(ja):    ファイル転送クライアント
6Name:           bareftp
7Version:        %{pkg_version}
8Release:        %{pkg_release}
9Source0:        http://www.bareftp.org/release/%{name}-%{version}.tar.gz
10License:        GPL
11Group:          Applications/Internet
12URL:            http://www.bareftp.org/
13
14Requires(post):         desktop-file-utils
15Requires(postun):       desktop-file-utils
16
17BuildRequires:  mono-devel >= 2.0
18BuildRequires:  gtk-sharp2 >= 2.12
19BuildRequires:  gnome-sharp2 >= 2.20
20BuildRequires:  gconf-sharp2 >= 2.20
21BuildRequires:  gnome-keyring-sharp-devel
22
23BuildRoot:      %{_tmppath}/%{name}-%{version}-root
24
25Vendor: Project Vine
26Distribution: Vine Linux
27Packager: Takemikaduchi
28
29
30%description
31bareFTP is a file transfer client supporting the FTP, FTP over SSL/TLS (FTPS) and
32SSH File Transfer Protocol (SFTP). It is written in C#, targeting the Mono framework
33and the GNOME desktop environment. bareFTP is free and open source software released
34under the terms of the GPL license.
35
36%prep
37%setup -q
38
39%build
40%configure
41%{__make} %{?_smp_mflags}
42
43%install
44%{__rm} -rf ${RPM_BUILD_ROOT}
45%{__make} install DESTDIR=${RPM_BUILD_ROOT}
46
47find $RPM_BUILD_ROOT -name '*.a' -exec rm -f {} ';'
48find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
49
50%find_lang %{name}
51
52%clean
53%{__rm} -rf ${RPM_BUILD_ROOT}
54
55%post
56umask 022
57update-mime-database %{_datadir}/mime 2>&1 > /dev/null || :
58touch --no-create %{_datadir}/icons/hicolor > /dev/null || :
59update-desktop-database -q > /dev/null || :
60
61%postun
62update-mime-database %{_datadir}/mime 2>&1 > /dev/null || :
63update-desktop-database -q > /dev/null || :
64
65if [ $1 -eq 0 ]; then
66        touch --no-create %{_datadir}/icons/hicolor > /dev/null
67        gtk-update-icon-cache -q %{_datadir}/icons/hicolor > /dev/null
68fi
69
70%files -f %{name}.lang
71%defattr(-,root,root)
72%doc COPYING ChangeLog NEWS README
73%{_bindir}/bareftp
74%{_libdir}/bareftp/*
75%{_libexecdir}/bareftp/*
76%{_datadir}/applications/bareftp.desktop
77%{_datadir}/icons/hicolor/*/apps/*
78%{_mandir}/man1/bareftp.1.gz
79
80
81%changelog
82* Sat Dec 28 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.3.10-1
83- new upstream release
84
85* Sat Jul 02 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.3.8-1
86- new upstream release
87
88* Fri Dec 10 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.3.7-1
89- new upstream release
90
91* Tue Nov 16 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.3.6-1
92- new upstream release
93
94* Sat Jun 05 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.3.4-1
95- initial build for Vine Linux
96
Note: See TracBrowser for help on using the repository browser.