source: projects/specs/trunk/b/baloo/baloo-vl.spec @ 10547

Revision 10547, 3.9 KB checked in by Takemikaduchi, 8 years ago (diff)

rebuild with gcc-5.4.0

Line 
1Name: baloo
2Summary: The file indexing and file search framework for KDE.
3Summary(ja): ファイルのインデックス作成及び検索のフレームワーク
4Version: 4.14.3
5Release: 2%{?_dist_release}
6
7License: GPLv2
8Group: System Environment/Libraries
9URL: https://community.kde.org/Baloo
10
11Source: ftp://ftp.kde.org/pub/kde/stable/%{version}/src/%{name}-%{version}.tar.xz
12
13BuildRoot: %{_tmppath}/%{name}-%{version}-root
14
15BuildRequires: kdelibs-devel
16BuildRequires: kdepimlibs-devel
17BuildRequires: qjson-devel
18BuildRequires: kfilemetadata-devel
19BuildRequires: xapian-core-devel
20BuildRequires: akonadi-devel
21
22Vendor: Project Vine
23Distribution: Vine Linux
24Packager: Takemikaduchi
25
26%description
27Baloo is the file indexing and file search framework for KDE.
28Baloo focuses on providing a very small memory footprint along with
29with extremely fast searching. It internally uses a mixture of sqlite
30along with Xapian to store the file index.
31
32%package libs
33Summary: %{name} runtime libraries
34Summary(ja): %{name} のラインタイムライブラリ
35Group:   System Environment/Libraries
36Requires: kdelibs >= %{version}
37
38%description libs
39%{summary}.
40
41%package devel
42Summary: Development files for kdepim
43Summary(ja): %{name} の開発用ファイル
44Group: Development/Libraries
45Requires: %{name}-libs = %{version}-%{release}
46Requires: kdelibs-devel
47
48%description devel
49Development files for %{name}.
50Install %{name}-devel if you want to write or compile %{name} plugins.
51
52%package akonadi
53Summary: Akonadi runtime support for %{name}
54Summary(ja): %{name} の Akonadi サポート
55Group: System Environment/Libraries
56Requires: %{name} = %{version}-%{release}
57Requires: akonadi
58
59%description akonadi
60%{summary}.
61
62%prep
63%setup -q
64
65%build
66mkdir -p %{_target_platform}
67pushd %{_target_platform}
68%cmake \
69    -DCMAKE_BUILD_TYPE=release \
70    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
71    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
72    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
73    -DLIB_INSTALL_DIR:PATH=%{_libdir} \
74    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
75    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
76    -DKDEPIM_BUILD_MOBILE:BOOL=OFF \
77    ..
78popd
79
80make %{?_smp_mflags} -C %{_target_platform}
81
82%install
83rm -rf $RPM_BUILD_ROOT
84make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
85
86%post
87touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
88
89%posttrans
90gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
91
92%postun
93if [ $1 -eq 0 ] ; then
94  touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
95  gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
96fi
97
98%post libs -p /sbin/ldconfig
99
100%postun libs -p /sbin/ldconfig
101
102%clean
103rm -rf $RPM_BUILD_ROOT
104
105%files
106%defattr(-,root,root,-)
107%doc COPYING COPYING.LIB
108%config %{_sysconfdir}/dbus-1/system.d/org.kde.baloo.filewatch.conf
109%{_bindir}/baloo_file
110%{_bindir}/baloo_file_cleaner
111%{_bindir}/baloo_file_extractor
112%{_bindir}/balooctl
113%{_bindir}/baloosearch
114%{_bindir}/balooshow
115%{_libdir}/kde4/*.so
116%{_libexecdir}/kde4/kde_baloo_filewatch_raiselimit
117%{_datadir}/autostart/baloo_file.desktop
118%{_datadir}/dbus-1/interfaces/org.kde.baloo.file.indexer.xml
119%{_datadir}/dbus-1/system-services/org.kde.baloo.filewatch.service
120%{_datadir}/icons/hicolor/*/*/*
121%{_datadir}/kde4/services/*
122%{_datadir}/kde4/servicetypes/*
123%{_datadir}/polkit-1/actions/*.policy
124
125%files libs
126%defattr(-,root,root,-)
127%{_libdir}/lib*.so.*
128
129%files devel
130%defattr(-,root,root,-)
131%{_includedir}/kde4/%{name}
132%{_libdir}/lib*.so
133%{_libdir}/cmake/Baloo/*.cmake
134
135%files akonadi
136%defattr(-,root,root,-)
137%{_bindir}/akonadi_baloo_indexer
138%{_libdir}/kde4/akonadi/akonadi_baloo_searchplugin.so
139%{_libdir}/kde4/akonadi/akonadibaloosearchplugin.desktop
140%{_datadir}/akonadi/agents/akonadibalooindexingagent.desktop
141
142%changelog
143* Mon Jul 04 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.14.3-2
144- rebuild with gcc-5.4.0
145
146* Thu Jan 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.14.3-1
147- initial build
Note: See TracBrowser for help on using the repository browser.