source: projects/specs/trunk/a/avant-window-navigator/avant-window-navigator-vl.spec @ 1928

Revision 1928, 7.2 KB checked in by owa, 14 years ago (diff)

rebuilt with rpm-4.8.1

Line 
1# -*- coding: utf-8-unix -*-
2%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
3
4Name:           avant-window-navigator
5Version:        0.2.6
6Release:        6%{?_dist_release}
7
8Summary:        Fully customisable dock-like window navigator for GNOME
9Summary(ja):    Gnome + Compiz 向けの Dock 機能を兼ね備えたウィンドウナビゲータ
10
11Group:          User Interface/Desktops
12#libawn is LGPLv2+, rest is GPLv2+
13License:        GPLv2+ and LGPLv2+
14URL:            https://launchpad.net/awn
15Source0:        https://launchpad.net/awn/0.2/0.2/+download/%{name}-%{version}.tar.gz
16#fixes schemas file
17Patch0:         avant-window-navigator-schemas.patch
18#fixes issue where awn only appears on one desktop, #469032
19Patch1:         avant-window-navigator-0.2.6-sticky.patch
20
21BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
22
23
24BuildRequires:  libwnck-devel
25BuildRequires:  dbus-glib-devel
26BuildRequires:  gnome-common
27BuildRequires:  pygtk2-devel
28BuildRequires:  GConf2-devel
29BuildRequires:  startup-notification-devel
30BuildRequires:  gnome-desktop-devel >= 2.26.0
31BuildRequires:  libgnome-devel
32BuildRequires:  gnome-vfs2-devel
33BuildRequires:  gnome-python
34BuildRequires:  libXdamage-devel libXcomposite-devel libXres-devel
35BuildRequires:  gettext, intltool
36BuildRequires:  desktop-file-utils
37BuildRequires:  pyxdg
38BuildRequires:  pycairo-devel
39
40Requires:       gnome-python-gnomedesktop, pyxdg
41#Requires:       gnome-python-gconf
42Requires(pre):  GConf2
43Requires(post): GConf2
44Requires(preun): GConf2
45
46%description
47Avant Window Navgator (Awn) is a dock-like bar which sits at the bottom of
48the screen (in all its composited-goodness) tracking open windows.
49
50%description -l ja
51Avant Window Navgator (Awn) は、
52Gnome + Compiz 向けの Dock 機能を兼ね備えたウィンドウナビゲータバーです。
53起動しているアプリケーションウィンドウを追跡し、
54画面下部に並べます。
55
56%package devel
57Summary:    Fully customisable dock-like window navigator for GNOME
58Group:      Development/Libraries
59Requires:   %{name} = %{version}-%{release}
60
61%description devel
62This package includes all header files and library of AWN for development.
63
64%prep
65%setup -q
66%patch0 -p1
67%patch1 -p0
68
69#fix permissions
70chmod 0644 $RPM_BUILD_DIR/%{name}-%{version}/src/xutils.h
71chmod 0644 $RPM_BUILD_DIR/%{name}-%{version}/src/xutils.c
72chmod 0644 $RPM_BUILD_DIR/%{name}-%{version}/src/inlinepixbufs.h
73
74
75%build
76%configure \
77    --disable-static \
78    --disable-schemas \
79    ;
80
81#make %{?_smp_mflags}
82%__make
83
84
85%install
86rm -rf $RPM_BUILD_ROOT
87export GCONF_DISABLE_MAKEFILE_  _INSTALL=1
88make install DESTDIR=$RPM_BUILD_ROOT
89find ${RPM_BUILD_ROOT} -name '*.la' | xargs rm
90
91%find_lang %{name}
92
93desktop-file-install --vendor vine --delete-original  \
94        --dir $RPM_BUILD_ROOT%{_datadir}/applications   \
95        --remove-category Application \
96        $RPM_BUILD_ROOT%{_datadir}/applications/avant-window-navigator.desktop
97
98desktop-file-install --vendor vine --delete-original  \
99        --dir $RPM_BUILD_ROOT%{_datadir}/applications   \
100        --remove-category Application \
101        $RPM_BUILD_ROOT%{_datadir}/applications/awn-manager.desktop
102
103
104%pre
105if [ "$1" -gt 1 ]; then
106    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
107    gconftool-2 --makefile-uninstall-rule \
108      %{_sysconfdir}/gconf/schemas/awn.schemas >/dev/null || :
109fi
110
111%post
112export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
113gconftool-2 --makefile-install-rule \
114  %{_sysconfdir}/gconf/schemas/awn.schemas > /dev/null || :
115
116/sbin/ldconfig
117
118touch --no-create %{_datadir}/icons/hicolor
119if [ -x %{_bindir}/gtk-update-icon-cache ]; then
120  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
121fi
122
123
124%preun
125if [ "$1" -eq 0 ]; then
126    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
127    gconftool-2 --makefile-uninstall-rule \
128      %{_sysconfdir}/gconf/schemas/awn.schemas > /dev/null || :
129fi
130
131
132%postun
133/sbin/ldconfig
134
135touch --no-create %{_datadir}/icons/hicolor
136if [ -x %{_bindir}/gtk-update-icon-cache ]; then
137  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
138fi
139
140
141%clean
142rm -rf $RPM_BUILD_ROOT
143
144
145%files -f %{name}.lang
146%defattr(-,root,root,-)
147%doc AUTHORS COPYING COPYING.LIB ChangeLog README
148%doc %{_datadir}/gtk-doc/html/libawn
149%{_bindir}/*
150%{_libdir}/libawn*.so.*
151%{_libdir}/awn
152%config(noreplace) %{_sysconfdir}/gconf/schemas/awn.schemas
153%{_datadir}/applications/*
154%{_datadir}/avant-window-navigator
155%{_datadir}/icons/hicolor/*/apps/awn-manager*
156%{python_sitelib}/awn
157
158
159%files devel
160%defattr(-,root,root,-)
161%{_includedir}/libawn
162%{_libdir}/libawn*.so
163%{_libdir}/pkgconfig/*.pc
164
165
166%changelog
167* Mon Sep 27 2010 Shu KONNO <owa@bg.wakwak.com> 0.2.6-6
168- rebuilt with rpm-4.8.1 for pkg-config
169
170* Mon Apr 19 2010 Shu KONNO <owa@bg.wakwak.com> 0.2.6-5
171- rebuilt with python-2.6
172
173* Mon Jul 26 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.2.6-4
174- added Summary(ja) and %%description -l ja
175
176* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.6-3
177- rebuild with gnome-desktop-2.26.0
178
179* Mon Feb 16 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.2.6-2
180- corrected *.desktop
181
182* Mon Feb 02 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.2.6-1
183- initial build
184
185* Sat Dec 20 2008 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.2.6-14
186- Add missing libXres buildrequires
187
188* Thu Dec 04 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.2.6-13
189- Rebuild for Python 2.6
190
191* Thu Dec 04 2008 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.2.6-12
192- Add patch to fix metacity sticky bug, #469032
193
194* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.2.6-11
195- Rebuild for Python 2.6
196
197* Fri Nov 28 2008 Caol叩n McNamara <caolanm@redhat.com - 0.2.6-10
198- rebuild for dependencies
199
200* Sun Aug 03 2008 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.2.6-9
201- Add patch to fix empty string in schemas file. #457683
202
203* Sat Mar 22 2008 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.2.6-8
204- Add missing pyxdg requires
205
206* Tue Mar 20 2008 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.2.6-6
207- Incorparate the python package in main, #438411
208* Mon Mar 17 2008 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.2.6-3
209- Fix python package
210
211* Mon Mar 17 2008 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.2.6-2
212- Add missing pyxdg build depenency
213
214* Mon Mar 17 2008 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.2.6-1
215- New release
216- Re-enable gconf scriplets
217- Add missing scriplets
218- Update license
219
220* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.2.1-3
221- Autorebuild for GCC 4.3
222
223* Thu Nov 04 2007 Sindre Pedersen Bj淡rdal <foolish[AT]guezz.net> - 0.2.1-2
224- New Release
225* Wed Oct 21 2007 Huang Peng <phuang@redhat.com> - 0.2-1
226- Update to 0.2
227* Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 0.1.1-4
228- Rebuild for selinux ppc32 issue.
229* Tue Jun 05 2007 Sindre Pedersen Bj淡rdal <foolish[AT]guezz.net> - 0.1.1-3
230- Own %%{_datadir}/avant-window-navigator
231* Tue Jun 05 2007 Sindre Pedersen Bj淡rdal <foolish[AT]guezz.net> - 0.1.1-2
232- Add missing BRs
233- Fix gconf scriplets
234* Thu May 01 2007 Sindre Pedersen Bj淡rdal <foolish[AT]guezz.net> - 0.1.1-1
235- Initial build
236
Note: See TracBrowser for help on using the repository browser.