source: projects/specs/trunk/a/avant-window-navigator/avant-window-navigator-vl.spec @ 4173

Revision 4173, 8.3 KB checked in by munepi, 13 years ago (diff)

updated avant-window-navigator-vl.spec

Line 
1# -*- coding: utf-8-unix -*-
2%global bzr bzr830
3
4Name:           avant-window-navigator
5Version:        0.4.1
6Release:        1%{?bzr:.%bzr}%{?_dist_release}
7
8Summary:        Fully customisable dock-like window navigator for GNOME
9
10Group:          User Interface/Desktops
11#libawn is LGPLv2+, rest is GPLv2+
12License:        GPLv2+ and LGPLv2+
13URL:            https://launchpad.net/awn
14# upstream snapshot:
15# bzr branch lp:awn
16# bzr export --root=avant-window-navigator-0.4.1-bzr830 avant-window-navigator-0.4.1-bzr830.tar.gz
17#
18Source0:       %{name}-%{version}-%{bzr}.tar.gz
19
20BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
21
22
23BuildRequires:  libwnck-devel
24BuildRequires:  dbus-glib-devel
25BuildRequires:  pygtk2-devel
26BuildRequires:  pycairo-devel
27BuildRequires:  GConf2-devel
28BuildRequires:  startup-notification-devel
29BuildRequires:  gnome-desktop-devel libgnome-devel gnome-python
30BuildRequires:  libXdamage-devel libXcomposite-devel libXres-devel
31BuildRequires:  gettext, intltool
32BuildRequires:  desktop-file-utils
33BuildRequires:  pyxdg libgtop2-devel
34BuildRequires:  libdesktop-agnostic-bin >= 0.3.91
35BuildRequires:  libdesktop-agnostic-devel >= 0.3.91
36BuildRequires:  vala
37BuildRequires:  libtool
38
39Requires:       gnome-python, gnome-python-gnomedesktop, pyxdg
40Requires:       libdesktop-agnostic-bin >= 0.3.91
41Requires:       python-desktop-agnostic >= 0.3.91
42Requires(pre):  GConf2
43Requires(post): GConf2
44Requires(preun): GConf2
45
46%description
47Avant Window Navgator (Awn) is a dock-like bar which sits at the bottom of
48the screen (in all its composited-goodness) tracking open windows.
49
50%package devel
51Summary:    Fully customisable dock-like window navigator for GNOME
52Group:      Development/Libraries
53Requires:   %{name} = %{version}-%{release}
54
55%description devel
56This package includes all header files and library of AWN for development.
57
58%prep
59%setup -q -n %{name}-%{version}%{?bzr:-%{bzr}}
60
61
62%build
63intltoolize --copy --force --automake
64gtkdocize --copy
65autoreconf --force --install
66
67%configure \
68    --disable-static \
69    --with-gnu-ld \
70    --with-vala \
71    --disable-shave \
72    ;
73%__sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
74%__sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
75%__make %{?_smp_mflags}
76
77
78%install
79%__rm -rf $RPM_BUILD_ROOT
80export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
81%__make install DESTDIR=$RPM_BUILD_ROOT
82find ${RPM_BUILD_ROOT} -name '*.la' | xargs %__rm
83
84#remove shebangs
85%__sed -i -e '/^#!\//, 1d' $RPM_BUILD_ROOT%{_datadir}/avant-window-navigator/awn-settings/awnSettings.py
86%__sed -i -e '/^#!\//, 1d' $RPM_BUILD_ROOT%{_datadir}/avant-window-navigator/awn-settings/awnSettingsHelper.py
87
88
89%find_lang %{name}
90
91desktop-file-install --vendor vine --delete-original  \
92        --dir $RPM_BUILD_ROOT%{_datadir}/applications   \
93        --remove-category Application \
94        $RPM_BUILD_ROOT%{_datadir}/applications/avant-window-navigator.desktop
95
96desktop-file-install --vendor vine --delete-original  \
97        --dir $RPM_BUILD_ROOT%{_datadir}/applications   \
98        --remove-category Application \
99        $RPM_BUILD_ROOT%{_datadir}/applications/awn-settings.desktop
100
101
102%pre
103##obsolete schemas: awn awn-applets-shared
104for schema in awn awn-applets-shared; do
105    if [ -f %{_sysconfdir}/gconf/schemas/${schema}.schemas ]; then
106        export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
107        gconftool-2 --makefile-uninstall-rule \
108            %{_sysconfdir}/gconf/schemas/${schema}.schemas >/dev/null || :
109    fi
110done
111
112
113%post
114##upgrade schemas:
115##avant-window-navigator awn-applet-taskmanager awn-applet-simple-launcher
116for schema in avant-window-navigator \
117              awn-applet-taskmanager \
118              awn-applet-simple-launcher; do
119    if [ -f %{_sysconfdir}/gconf/schemas/${schema}.schemas ]; then
120        export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
121        gconftool-2 --makefile-install-rule \
122            %{_sysconfdir}/gconf/schemas/${schema}.schemas >/dev/null || :
123    fi
124done
125
126/sbin/ldconfig
127
128touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
129
130
131%preun
132if [ "$1" -eq 0 ]; then
133    for schema in avant-window-navigator \
134                  awn-applet-taskmanager \
135                  awn-applet-simple-launcher; do
136        if [ -f %{_sysconfdir}/gconf/schemas/${schema}.schemas ]; then
137            export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
138            gconftool-2 --makefile-uninstall-rule \
139                %{_sysconfdir}/gconf/schemas/${schema}.schemas >/dev/null || :
140        fi
141    done
142fi
143
144
145%postun
146/sbin/ldconfig
147
148if [ $1 -eq 0 ] ; then
149    touch --no-create %{_datadir}/icons/hicolor &>/dev/null
150    if [ -x %{_bindir}/gtk-update-icon-cache ]; then
151      %{_bindir}/gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
152    fi
153fi
154
155
156%posttrans
157if [ -x %{_bindir}/gtk-update-icon-cache ]; then
158    %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
159fi
160
161
162%clean
163%__rm -rf $RPM_BUILD_ROOT
164
165
166%files -f %{name}.lang
167%defattr(-,root,root,-)
168%doc AUTHORS COPYING COPYING.LIB ChangeLog README
169#%doc %{_datadir}/gtk-doc/html/libawn
170%{_bindir}/*
171%{_libdir}/libawn*.so.*
172%dir %{_libdir}/awn
173%dir %{_libdir}/awn/applets
174%{_libdir}/awn/applets/*/*.so
175%config(noreplace) %{_sysconfdir}/gconf/schemas/avant-window-navigator.schemas
176%config(noreplace) %{_sysconfdir}/gconf/schemas/awn-applet-taskmanager.schemas
177%config(noreplace) %{_sysconfdir}/gconf/schemas/awn-applet-simple-launcher.schemas
178%{_datadir}/applications/*
179%dir %{_datadir}/avant-window-navigator
180%{_datadir}/avant-window-navigator/*
181%{_datadir}/icons/hicolor/*/apps/*
182%{_datadir}/icons/hicolor/scalable/categories/awn-plugins.svg
183%dir %{python_sitearch}/awn
184%{python_sitearch}/awn/*
185
186%files devel
187%defattr(-,root,root,-)
188%doc AUTHORS COPYING COPYING.LIB ChangeLog README
189%dir %{_includedir}/libawn
190%{_includedir}/libawn/*
191%{_libdir}/libawn*.so
192%{_libdir}/pkgconfig/*.pc
193%{_datadir}/pygtk/2.0/defs/awn.defs
194%{_datadir}/vala/vapi/awn.*
195
196
197%changelog
198* Sat Jun 18 2011 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.1-1.bzr830
199- updated to source 0.4.1 (bzr830) based on Fedora rawhide
200
201* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.6-3
202- rebuild with gnome-desktop-2.26.0
203
204* Mon Feb 16 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.2.6-2
205- corrected *.desktop
206
207* Mon Feb 02 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.2.6-1
208- initial build
209
210* Sat Dec 20 2008 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.2.6-14
211- Add missing libXres buildrequires
212
213* Thu Dec 04 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.2.6-13
214- Rebuild for Python 2.6
215
216* Thu Dec 04 2008 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.2.6-12
217- Add patch to fix metacity sticky bug, #469032
218
219* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.2.6-11
220- Rebuild for Python 2.6
221
222* Fri Nov 28 2008 Caol叩n McNamara <caolanm@redhat.com - 0.2.6-10
223- rebuild for dependencies
224
225* Sun Aug 03 2008 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.2.6-9
226- Add patch to fix empty string in schemas file. #457683
227
228* Sat Mar 22 2008 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.2.6-8
229- Add missing pyxdg requires
230
231* Tue Mar 20 2008 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.2.6-6
232- Incorparate the python package in main, #438411
233* Mon Mar 17 2008 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.2.6-3
234- Fix python package
235
236* Mon Mar 17 2008 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.2.6-2
237- Add missing pyxdg build depenency
238
239* Mon Mar 17 2008 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.2.6-1
240- New release
241- Re-enable gconf scriplets
242- Add missing scriplets
243- Update license
244
245* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.2.1-3
246- Autorebuild for GCC 4.3
247
248* Thu Nov 04 2007 Sindre Pedersen Bj淡rdal <foolish[AT]guezz.net> - 0.2.1-2
249- New Release
250* Wed Oct 21 2007 Huang Peng <phuang@redhat.com> - 0.2-1
251- Update to 0.2
252* Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 0.1.1-4
253- Rebuild for selinux ppc32 issue.
254* Tue Jun 05 2007 Sindre Pedersen Bj淡rdal <foolish[AT]guezz.net> - 0.1.1-3
255- Own %%{_datadir}/avant-window-navigator
256* Tue Jun 05 2007 Sindre Pedersen Bj淡rdal <foolish[AT]guezz.net> - 0.1.1-2
257- Add missing BRs
258- Fix gconf scriplets
259* Thu May 01 2007 Sindre Pedersen Bj淡rdal <foolish[AT]guezz.net> - 0.1.1-1
260- Initial build
261
Note: See TracBrowser for help on using the repository browser.