source: projects/specs/trunk/a/avahi/avahi-vl.spec @ 3707

Revision 3707, 26.1 KB checked in by iwamoto, 13 years ago (diff)

avahi: add patch for security fix
libwmf: add patch for security fix

Line 
1%define pythonlib %(python -c 'from distutils.sysconfig import get_python_lib; print get_python_lib(0)')
2%define _localstatedir %{_var}
3
4%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
5
6Summary:        Local network service discovery
7Summary(ja):    ローカルネットワークサービス検出システム
8Name:           avahi
9Version:        0.6.25
10Release:        5%{?_dist_release}
11Group:          System Environment/Base
12License:        LGPL
13URL:            http://avahi.org
14
15Source0:        %{name}-%{version}.tar.gz
16Patch10:        avahi-0.6.25-vine.patch
17
18# security fixes
19Patch110:       avahi-0.6.2x-CVE-2010-2244.patch
20Patch120:       avahi-0.6-CVE-2011-1002.patch
21
22BuildRoot:      %{_tmppath}/%{name}-%{version}-root
23BuildRequires:  gtk2-devel, qt-devel, libglade2-devel, glib2-devel
24BuildRequires:  qt4-devel
25BuildRequires:  libdaemon-devel >= 0.12
26BuildRequires:  libcap-devel, dbus-devel, expat-devel
27BuildRequires:  python, dbus-python, gdbm-devel, pygtk2, libmng-devel
28BuildRequires:  xorg-x11-devel, mesa-libGL-devel
29Requires:       dbus, libdaemon, expat, python, dbus-python, libcap
30Requires(post): initscripts, chkconfig >= 1.3.34
31Obsoletes:      howl, howl-libs
32
33Vendor: Project Vine
34Distribution: Vine Linux
35
36%description
37Avahi is a system which facilitates service discovery on
38a local network -- this means that you can plug your laptop or
39computer into a network and instantly be able to view other people who
40you can chat with, find printers to print to or find files being
41shared. This kind of technology is already found in MacOS X (branded
42'Rendezvous', 'Bonjour' and sometimes 'ZeroConf') and is very
43convenient.
44
45%package tools
46Summary: Tools for mDNS browsing and publishing
47Group: System Environment/Base
48Requires: %{name} = %{version}, gtk2, pygtk2, libglade2, pygtk2-libglade, gdbm
49
50%description tools
51Tools that use avahi to browse and publish mDNS services and hosts.
52
53%package ui
54Summary: UI libraries for avahi
55Summary(ja): avahi 用 UI ライブラリ
56Group: System Environment/Libraries
57Requires: %{name} = %{version}
58Requires: gtk2
59
60%description ui
61Libraries for easy use of avahi from gtk applications.
62
63%package ui-devel
64Summary: Libraries and header files for avahi ui development
65Group: Development/Libraries
66Requires: %{name}-devel = %{version}
67Requires: %{name}-ui = %{version}
68Requires: gtk2-devel
69
70%description ui-devel
71The avahi-ui-devel package contains the header files and libraries
72necessary for developing programs using avahi with gtk+.
73
74%package glib
75Summary: Glib libraries for avahi
76Summary(ja): avahi 用 glib ライブラリ
77Group: System Environment/Libraries
78Requires: %{name} = %{version}
79Requires: glib2
80
81%description glib
82Libraries for easy use of avahi from glib applications.
83
84%package glib-devel
85Summary: Libraries and header files for avahi glib development
86Group: Development/Libraries
87Requires: %{name}-devel = %{version}
88Requires: %{name}-glib = %{version}
89Requires: glib2-devel
90
91%description glib-devel
92The avahi-glib-devel package contains the header files and libraries
93necessary for developing programs using avahi with glib.
94
95%package gobject
96Summary: GObject library for Avahi
97Summary(ja): Avahi 用 GObject ライブラリ
98Group: System Environment/Base
99Requires: glib2
100Requires: %{name}-glib = %{version}-%{release}
101
102%description gobject
103This library contains a GObject wrapper for the Avahi API
104
105%package gobject-devel
106Summary: Libraries and header files for Avahi GObject development
107Summary(ja): Avahi GObject 開発用ライブラリとヘッダファイル
108Group: Development/Libraries
109Requires: %{name}-gobject = %{version}-%{release}
110Requires: %{name}-devel = %{version}-%{release}
111Requires: %{name}-glib-devel = %{version}-%{release}
112
113%description gobject-devel
114The avahi-gobject-devel package contains the header files and libraries
115necessary for developing programs using avahi-gobject.
116
117%package qt3
118Summary: Qt3 libraries for avahi
119Summary(ja): avahi 用 Qt3 ライブラリ
120Group: System Environment/Libraries
121Requires: %{name} = %{version}
122Requires: qt
123
124%description qt3
125Libraries for easy use of avahi from Qt3 applications.
126
127%package qt3-devel
128Summary: Libraries and header files for avahi Qt3 development
129Group: Development/Libraries
130Requires: %{name}-devel = %{version}
131Requires: %{name}-qt3 = %{version}
132Requires: qt-devel
133
134%description qt3-devel
135The avahi-qt3-devel package contains the header files and libraries
136necessary for developing programs using avahi with Qt3.
137
138%package qt4
139Summary: Qt4 libraries for avahi
140Summary(ja): avahi 用 Qt4 ライブラリ
141Group: System Environment/Base
142Requires: %{name} = %{version}-%{release}
143
144%description qt4
145Libraries for easy use of avahi from Qt4 applications.
146
147%package qt4-devel
148Summary: Libraries and header files for avahi Qt4 development
149Group: Development/Libraries
150Requires: %{name}-devel = %{version}-%{release}
151Requires: %{name}-qt4 = %{version}-%{release}
152Requires: qt4-devel
153
154%description qt4-devel
155Th avahi-qt4-devel package contains the header files and libraries
156necessary for developing programs using avahi with Qt4.
157
158%package devel
159Summary: Libraries and header files for avahi development
160Group: Development/Libraries
161Requires: %{name} = %{version}
162Obsoletes: howl-devel
163
164%description devel
165The avahi-devel package contains the header files and libraries
166necessary for developing programs using avahi.
167
168# compat32
169%package -n compat32-%{name}
170Summary:        Local network service discovery
171Summary(ja):    ローカルネットワークサービス検出システム
172Group:          System Environment/Base
173Requires: %{name} = %{version}-%{release}
174
175%description -n compat32-%{name}
176Avahi is a system which facilitates service discovery on
177a local network -- this means that you can plug your laptop or
178computer into a network and instantly be able to view other people who
179you can chat with, find printers to print to or find files being
180shared. This kind of technology is already found in MacOS X (branded
181'Rendezvous', 'Bonjour' and sometimes 'ZeroConf') and is very
182convenient.
183
184%package -n compat32-%{name}-ui
185Summary: UI libraries for avahi
186Summary(ja): avahi 用 UI ライブラリ
187Group: System Environment/Libraries
188Requires: %{name}-ui = %{version}-%{release}
189Requires: compat32-%{name} = %{version}-%{release}
190Requires: compat32-gtk2
191
192%description -n compat32-%{name}-ui
193Libraries for easy use of avahi from gtk applications.
194
195%package -n compat32-%{name}-ui-devel
196Summary: Libraries and header files for avahi ui development
197Group: Development/Libraries
198Requires: %{name}-ui-devel = %{version}-%{release}
199Requires: compat32-%{name}-devel = %{version}-%{release}
200Requires: compat32-%{name}-ui = %{version}-%{release}
201Requires: compat32-gtk2-devel
202
203%description -n compat32-%{name}-ui-devel
204The avahi-ui-devel package contains the header files and libraries
205necessary for developing programs using avahi with gtk+.
206
207%package -n compat32-%{name}-glib
208Summary: Glib libraries for avahi
209Summary(ja): avahi 用 glib ライブラリ
210Group: System Environment/Libraries
211Requires: %{name}-glib = %{version}-%{release}
212Requires: compat32-%{name} = %{version}-%{release}
213Requires: compat32-glib2
214
215%description -n compat32-%{name}-glib
216Libraries for easy use of avahi from glib applications.
217
218%package -n compat32-%{name}-glib-devel
219Summary: Libraries and header files for avahi glib development
220Group: Development/Libraries
221Requires: %{name}-glib-devel = %{version}-%{release}
222Requires: compat32-%{name}-devel = %{version}-%{release}
223Requires: compat32-%{name}-glib = %{version}-%{release}
224Requires: compat32-glib2-devel
225
226%description -n compat32-%{name}-glib-devel
227The avahi-glib-devel package contains the header files and libraries
228necessary for developing programs using avahi with glib.
229
230%package -n compat32-%{name}-gobject
231Summary: GObject library for Avahi
232Summary(ja): Avahi 用 GObject ライブラリ
233Group: System Environment/Base
234Requires: %{name}-gobject = %{version}-%{release}
235Requires: compat32-glib2
236Requires: compat32-%{name}-glib = %{version}-%{release}
237
238%description -n compat32-%{name}-gobject
239This library contains a GObject wrapper for the Avahi API
240
241%package -n compat32-%{name}-gobject-devel
242Summary: Libraries and header files for Avahi GObject development
243Summary(ja): Avahi GObject 開発用ライブラリとヘッダファイル
244Group: Development/Libraries
245Requires: %{name}-gobject-devel = %{version}-%{release}
246Requires: compat32-%{name}-gobject = %{version}-%{release}
247Requires: compat32-%{name}-devel = %{version}-%{release}
248Requires: compat32-%{name}-glib-devel = %{version}-%{release}
249
250%description -n compat32-%{name}-gobject-devel
251The avahi-gobject-devel package contains the header files and libraries
252necessary for developing programs using avahi-gobject.
253
254%package -n compat32-%{name}-qt3
255Summary: Qt3 libraries for avahi
256Summary(ja): avahi 用 Qt3 ライブラリ
257Group: System Environment/Libraries
258Requires: %{name}-qt3 = %{version}-%{release}
259Requires: compat32-%{name} = %{version}-%{release}
260Requires: compat32-qt
261
262%description -n compat32-%{name}-qt3
263Libraries for easy use of avahi from Qt3 applications.
264
265%package -n compat32-%{name}-qt3-devel
266Summary: Libraries and header files for avahi Qt3 development
267Group: Development/Libraries
268Requires: %{name}-qt3-devel = %{version}-%{release}
269Requires: compat32-%{name}-devel = %{version}-%{release}
270Requires: compat32-%{name}-qt3 = %{version}-%{release}
271Requires: compat32-qt-devel
272
273%description -n compat32-%{name}-qt3-devel
274The avahi-qt3-devel package contains the header files and libraries
275necessary for developing programs using avahi with Qt3.
276
277%package -n compat32-%{name}-qt4
278Summary: Qt4 libraries for avahi
279Summary(ja): avahi 用 Qt4 ライブラリ
280Group: System Environment/Base
281Requires: %{name}-qt4 = %{version}-%{release}
282Requires: compat32-%{name} = %{version}-%{release}
283
284%description -n compat32-%{name}-qt4
285Libraries for easy use of avahi from Qt4 applications.
286
287%package -n compat32-%{name}-qt4-devel
288Summary: Libraries and header files for avahi Qt4 development
289Group: Development/Libraries
290Requires: %{name}-qt4-devel = %{version}-%{release}
291Requires: compat32-%{name}-devel = %{version}-%{release}
292Requires: compat32-%{name}-qt4 = %{version}-%{release}
293Requires: compat32-qt4-devel
294
295%description -n compat32-%{name}-qt4-devel
296Th avahi-qt4-devel package contains the header files and libraries
297necessary for developing programs using avahi with Qt4.
298
299%package -n compat32-%{name}-devel
300Summary: Libraries and header files for avahi development
301Group: Development/Libraries
302Requires: %{name}-devel = %{version}-%{release}
303Requires: compat32-%{name} = %{version}-%{release}
304
305%description -n compat32-%{name}-devel
306The avahi-devel package contains the header files and libraries
307necessary for developing programs using avahi.
308
309%define avahi_user_uid 70
310
311%prep
312%setup -q
313%patch10 -p1 -b .vine
314
315# security fixes
316%patch110 -p1 -b .CVE-2010-2244
317%patch120 -p1 -b .CVE-2011-1002
318
319
320%build
321autoreconf -i
322
323%configure --with-distro=vine \
324  --disable-monodoc --without-python-twisted \
325  --with-avahi-user=avahi --with-avahi-group=avahi \
326  --enable-compat-howl --enable-compat-libdns_sd \
327  --with-avahi-priv-access-group=avahi \
328  --with-autoipd-user=avahi-autoipd \
329  --with-autoipd-group=avahi-autoipd \
330  --disable-mono
331
332%__make -C avahi-python clean
333%__make %{?_smp_mflags}
334
335%install
336rm -rf $RPM_BUILD_ROOT
337make install DESTDIR=$RPM_BUILD_ROOT
338
339rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
340rm -f $RPM_BUILD_ROOT%{_libdir}/*.a
341
342# remove example
343rm -f $RPM_BUILD_ROOT%{_sysconfdir}/avahi/services/ssh.service
344
345# remove desktop file for avahi-discover
346rm -f $RPM_BUILD_ROOT%{_datadir}/applications/avahi-discover.desktop
347
348# create /var/run/avahi-daemon to ensure correct selinux policy for it:
349mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/run/avahi-daemon
350
351# remove the documentation directory - let \%doc handle it:
352rm -rf $RPM_BUILD_ROOT%{_datadir}/%{name}-%{version}
353
354# remove avahi-bookmarks - unusable without python-twisted,
355# which has been judged dangerous and is removed from the
356# Fedora Core distribution:
357rm -f $RPM_BUILD_ROOT/%{_bindir}/avahi-bookmarks $RPM_BUILD_ROOT/%{_mandir}/man1/avahi-bookmarks*
358#
359# move initscripts into /etc/rc.d/init.d :
360mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/rc.d/init.d
361mv $RPM_BUILD_ROOT/%{_sysconfdir}/init.d/* $RPM_BUILD_ROOT/%{_sysconfdir}/rc.d/init.d
362rm -rf $RPM_BUILD_ROOT/%{_sysconfdir}/init.d/*
363#
364# Make /etc/avahi/etc/localtime owned by avahi:
365mkdir -p $RPM_BUILD_ROOT/etc/avahi/etc
366touch $RPM_BUILD_ROOT/etc/avahi/etc/localtime
367:;
368
369%clean
370rm -rf $RPM_BUILD_ROOT
371
372%pre
373# Add the "avahi" group
374/usr/sbin/groupadd -f -r avahi
375# Add the "avahi" user
376/usr/sbin/useradd -g avahi -c 'Avahi daemon' -u %{avahi_user_uid} \
377        -s /sbin/nologin -r -d '/' avahi 2> /dev/null || :
378
379%post
380/sbin/ldconfig
381dbus-send --system --type=method_call --dest=org.freedesktop.DBus / org.freedesktop.DBus.ReloadConfig >/dev/null 2>&1 || :
382/sbin/chkconfig --add avahi-daemon >/dev/null 2>&1 ||:
383/sbin/chkconfig avahi-daemon resetpriorities >/dev/null 2>&1 ||:
384/sbin/chkconfig --add avahi-dnsconfd >/dev/null 2>&1 ||:
385/sbin/chkconfig avahi-dnsconfd resetpriorities >/dev/null 2>&1 ||:
386if [ "$1" -eq 1 ]; then
387   if [ -s /etc/localtime ]; then
388        cp -fp /etc/localtime /etc/avahi/etc/localtime || :;
389   fi
390fi
391
392%postun
393/sbin/ldconfig
394if [ "$1" -ge "1" ]; then
395   /sbin/service avahi-daemon condrestart >/dev/null 2>&1
396   /sbin/service avahi-dnsconfd condrestart >/dev/null 2>&1
397fi
398     
399%preun
400if [ "$1" -eq 0 ]; then
401    /sbin/service avahi-daemon stop > /dev/null 2>&1
402    /sbin/chkconfig --del avahi-daemon
403    /sbin/service avahi-dnsconfd stop >/dev/null 2>&1
404    /sbin/chkconfig --del avahi-dnsconfd
405fi
406
407%post ui -p /sbin/ldconfig
408
409%postun ui -p /sbin/ldconfig
410
411%post glib -p /sbin/ldconfig
412
413%postun glib -p /sbin/ldconfig
414
415%post qt3 -p /sbin/ldconfig
416
417%postun qt3 -p /sbin/ldconfig
418
419%post qt4 -p /sbin/ldconfig
420
421%postun qt4 -p /sbin/ldconfig
422
423%post gobject -p /sbin/ldconfig
424
425%postun gobject -p /sbin/ldconfig
426
427# compat32
428%post -n compat32-%{name} -p /sbin/ldconfig
429
430%postun -n compat32-%{name} -p /sbin/ldconfig
431
432%post -n compat32-%{name}-ui -p /sbin/ldconfig
433
434%postun -n compat32-%{name}-ui -p /sbin/ldconfig
435
436%post -n compat32-%{name}-glib -p /sbin/ldconfig
437
438%postun -n compat32-%{name}-glib -p /sbin/ldconfig
439
440%post -n compat32-%{name}-qt3 -p /sbin/ldconfig
441
442%postun -n compat32-%{name}-qt3 -p /sbin/ldconfig
443
444%post -n compat32-%{name}-qt4 -p /sbin/ldconfig
445
446%postun -n compat32-%{name}-qt4 -p /sbin/ldconfig
447
448%post -n compat32-%{name}-gobject -p /sbin/ldconfig
449
450%postun -n compat32-%{name}-gobject -p /sbin/ldconfig
451
452%files
453%defattr(0644,root,root,0755)
454%doc docs/* avahi-daemon/example.service avahi-daemon/ssh.service
455%attr(755,root,root) %{_sysconfdir}/rc.d/init.d/*
456%dir %{_sysconfdir}/avahi
457%dir %{_sysconfdir}/avahi/etc
458%ghost %{_sysconfdir}/avahi/etc/localtime
459%{_sysconfdir}/avahi/hosts
460%dir %{_sysconfdir}/avahi/services
461%dir %{_localstatedir}/run/avahi-daemon
462%config %{_sysconfdir}/avahi/avahi-autoipd.action
463%config %{_sysconfdir}/avahi/avahi-daemon.conf
464%config %{_sysconfdir}/avahi/avahi-dnsconfd.action
465%config %{_sysconfdir}/avahi/services/*
466%config %{_sysconfdir}/dbus-1/system.d/avahi-dbus.conf
467%attr(755,root,root) %{_sbindir}/*
468%attr(755,root,root) %{_libdir}/libavahi-common.so.*
469%attr(755,root,root) %{_libdir}/libavahi-core.so.*
470%attr(755,root,root) %{_libdir}/libavahi-client.so.*
471%attr(755,root,root) %{_libdir}/libhowl.so.*
472%attr(755,root,root) %{_libdir}/libdns_sd.so.*
473%attr(755,root,root) %{_datadir}/avahi
474%{_datadir}/locale/*
475%{_libdir}/avahi
476%exclude %{_datadir}/avahi/interfaces
477%{_mandir}/man5/*
478%{_mandir}/man8/*
479
480%files tools
481%defattr(0755, root, root, 0755)
482%{_bindir}/*
483%{pythonlib}/*
484%attr(0644,root,root) %{_mandir}/man1/*
485%{_datadir}/avahi/interfaces/
486%{_datadir}/applications/*
487
488%files devel
489%defattr(0644, root, root, 0755)
490%attr(755,root,root) %{_libdir}/libavahi-common.so
491%attr(755,root,root) %{_libdir}/libavahi-core.so
492%attr(755,root,root) %{_libdir}/libavahi-client.so
493%attr(755,root,root) %{_libdir}/libhowl.so
494%attr(755,root,root) %{_libdir}/libdns_sd.so
495%{_includedir}/avahi-client
496%{_includedir}/avahi-common
497%{_includedir}/avahi-core
498%{_includedir}/avahi-compat-howl
499%{_includedir}/avahi-compat-libdns_sd
500%{_libdir}/pkgconfig/avahi-core.pc
501%{_libdir}/pkgconfig/avahi-client.pc
502%{_libdir}/pkgconfig/avahi-compat-howl.pc
503%{_libdir}/pkgconfig/avahi-compat-libdns_sd.pc
504
505%files ui
506%defattr(0755, root, root, 0755)
507%{_libdir}/libavahi-ui.so.*
508
509%files ui-devel
510%defattr(0644, root, root, 0755)
511%attr(755,root,root) %{_libdir}/libavahi-ui.so
512%{_includedir}/avahi-ui
513%{_libdir}/pkgconfig/avahi-ui.pc
514
515%files glib
516%defattr(0755, root, root, 0755)
517%{_libdir}/libavahi-glib.so.*
518
519%files glib-devel
520%defattr(0644, root, root, 0755)
521%attr(755,root,root) %{_libdir}/libavahi-glib.so
522%{_includedir}/avahi-glib
523%{_libdir}/pkgconfig/avahi-glib.pc
524
525%files gobject
526%defattr(0755, root, root, 0755)
527%{_libdir}/libavahi-gobject.so.*
528
529%files gobject-devel
530%defattr(0644, root, root, 0755)
531%attr(755,root,root) %{_libdir}/libavahi-gobject.so
532%{_includedir}/avahi-gobject
533%{_libdir}/pkgconfig/avahi-gobject.pc
534
535%files qt3
536%defattr(0644, root, root, 0755)
537%attr(755,root,root) %{_libdir}/libavahi-qt3.so.*
538
539%files qt3-devel
540%defattr(0644, root, root, 0755)
541%attr(755,root,root) %{_libdir}/libavahi-qt3.so
542%{_includedir}/avahi-qt3
543%{_libdir}/pkgconfig/avahi-qt3.pc
544
545%files qt4
546%defattr(0644, root, root, 0755)
547%attr(755,root,root) %{_libdir}/libavahi-qt4.so.*
548
549%files qt4-devel
550%defattr(0644, root, root, 0755)
551%attr(755,root,root) %{_libdir}/libavahi-qt4.so
552%{_includedir}/avahi-qt4/
553%{_libdir}/pkgconfig/avahi-qt4.pc
554
555# compat32
556%if %{build_compat32}
557%files -n compat32-%{name}
558%defattr(0644,root,root,0755)
559%attr(755,root,root) %{_libdir}/libavahi-common.so.*
560%attr(755,root,root) %{_libdir}/libavahi-core.so.*
561%attr(755,root,root) %{_libdir}/libavahi-client.so.*
562%attr(755,root,root) %{_libdir}/libhowl.so.*
563%attr(755,root,root) %{_libdir}/libdns_sd.so.*
564%{_libdir}/avahi
565
566%files -n compat32-%{name}-devel
567%defattr(0644, root, root, 0755)
568%attr(755,root,root) %{_libdir}/libavahi-common.so
569%attr(755,root,root) %{_libdir}/libavahi-core.so
570%attr(755,root,root) %{_libdir}/libavahi-client.so
571%attr(755,root,root) %{_libdir}/libhowl.so
572%attr(755,root,root) %{_libdir}/libdns_sd.so
573%{_libdir}/pkgconfig/avahi-core.pc
574%{_libdir}/pkgconfig/avahi-client.pc
575%{_libdir}/pkgconfig/avahi-compat-howl.pc
576%{_libdir}/pkgconfig/avahi-compat-libdns_sd.pc
577
578%files -n compat32-%{name}-ui
579%defattr(0755, root, root, 0755)
580%{_libdir}/libavahi-ui.so.*
581
582%files -n compat32-%{name}-ui-devel
583%defattr(0644, root, root, 0755)
584%attr(755,root,root) %{_libdir}/libavahi-ui.so
585%{_libdir}/pkgconfig/avahi-ui.pc
586
587%files -n compat32-%{name}-glib
588%defattr(0755, root, root, 0755)
589%{_libdir}/libavahi-glib.so.*
590
591%files -n compat32-%{name}-glib-devel
592%defattr(0644, root, root, 0755)
593%attr(755,root,root) %{_libdir}/libavahi-glib.so
594%{_libdir}/pkgconfig/avahi-glib.pc
595
596%files -n compat32-%{name}-gobject
597%defattr(0755, root, root, 0755)
598%{_libdir}/libavahi-gobject.so.*
599
600%files -n compat32-%{name}-gobject-devel
601%defattr(0644, root, root, 0755)
602%attr(755,root,root) %{_libdir}/libavahi-gobject.so
603%{_libdir}/pkgconfig/avahi-gobject.pc
604
605%files -n compat32-%{name}-qt3
606%defattr(0644, root, root, 0755)
607%attr(755,root,root) %{_libdir}/libavahi-qt3.so.*
608
609%files -n compat32-%{name}-qt3-devel
610%defattr(0644, root, root, 0755)
611%attr(755,root,root) %{_libdir}/libavahi-qt3.so
612%{_libdir}/pkgconfig/avahi-qt3.pc
613
614%files -n compat32-%{name}-qt4
615%defattr(0644, root, root, 0755)
616%attr(755,root,root) %{_libdir}/libavahi-qt4.so.*
617
618%files -n compat32-%{name}-qt4-devel
619%defattr(0644, root, root, 0755)
620%attr(755,root,root) %{_libdir}/libavahi-qt4.so
621%{_libdir}/pkgconfig/avahi-qt4.pc
622%endif
623
624%changelog
625* Tue Apr 26 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.6.25-5
626- add patch120 for fix CVE-2011-1002 (incorrect fix CVE-2010-2244)
627- add patch110 for fix CVE-2010-2244 (DNS packets)
628
629* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.6.25-4
630- rebuild with rpm-4.8.1 for pkg-config file
631
632* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.6.25-3
633- rebuilt with gcc-4.4.3-3 on ppc
634
635* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 0.6.25-2
636- rebuilt with python-2.6.4
637
638* Sat Sep 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.25-1
639- new upstream release
640- update vine patch
641  - startup avahi-daemon earlier
642
643* Mon Jul 13 2009 NAKAMURA Kenta <kenta@vinelinux.org> 0.6.24-2
644- added qt4 subpackage
645- added compat32 package for x86_64 arch support
646
647* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.24-1
648- new upstream release
649
650* Fri Jan 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.6.23-2
651- fixed %%pre: add the "avahi" user to the "avahi" group
652
653* Mon Sep 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.23-1
654- new upstream release
655
656* Thu Jul 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.22-1
657- new upstream release
658- add gobject, gobject-devel sub package
659- enable avahi-autoipd
660
661* Wed Jul 23 2008 Shu KONNO <owa@bg.wakwak.com> 0.6.20-1vl5
662- built with python-2.5.2
663- s/automake-1.9/automake/
664- fixed python library path
665- applied new versioning policy
666
667* Wed Feb 20 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.6.20-0vl2
668- rebuild with expat-2.0.1
669
670* Mon Jul 23 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.20-0vl1
671- new upstream release
672
673* Thu May 10 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.18-0vl2
674- rebuild with new environment/toolchain
675
676* Tue May 08 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.18-0vl1
677- new upstream release
678
679* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.17-0vl2
680- require new chkconfig to reset initscript priorities
681
682* Thu Apr 26 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.17-0vl1
683- new upstream release
684
685* Fri Jan 12 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.6.13-0vl3
686- add patch110 for fix CVE-2006-6870
687- add Vendor/Distribution Tag
688
689* Wed Dec 27 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.13-0vl2
690- rebuilt for VineSeed
691
692* Thu Dec 07 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.6.13-0vl1.1
693- add patch100 for fix CVE-2006-5461
694- add BuildRequires:  XOrg-gl-devel tag
695
696* Thu Sep 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.13-0vl1
697- new upstream release
698- refine %%post scripts
699- add condrestart daemon in %%postun
700
701* Mon May 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.10-0vl1
702- new upstream release
703
704* Thu Mar 23 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.9-0vl2
705- move /var/lib/run/avahi-daemon to /var/run
706
707* Sun Mar 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.9-0vl1
708- initial build for Vine Linux based on FC package
709- add Patch10 to support Vine Linux
710
711* Thu Feb 23 2006 Jason Vas Dias <jvdias@redhat.com> - 0.6.8-1
712- Upgrade to upstream version 0.6.8
713- fix bug 182462: +Requires(post): initscripts, chkconfig, ldconfig
714
715* Fri Feb 17 2006 Jason Vas Dias <jvdias@redhat.com> - 0.6.7-1
716- Upgrade to upstream version 0.6.7
717
718* Fri Feb 17 2006 Karsten Hopp <karsten@redhat.de> - 0.6.6-4
719- BuildRequires pygtk2
720
721* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.6.6-3.1
722- bump again for double-long bug on ppc(64)
723
724* Fri Feb 10 2006 Jason Vas Dias <jvdias@redhat.com> - 0.6.6-3
725- rebuild for new gcc (again)
726- further fix for bug 178746: fix avahi-dnsconfd initscript
727
728* Tue Feb 07 2006 Jason Vas Dias <jvdias@redhat.com> - 0.6.6-2
729- rebuild for new gcc, glibc, glibc-kernheaders
730
731* Wed Feb 01 2006 Jason Vas Dias <jvdias@redhat.com> - 0.6.6-1
732- fix bug 179448: mis-alignment of input cmsghdr msg->msg_control buffer on ia64
733- Upgrade to 0.6.6
734
735* Thu Jan 26 2006 Jason Vas Dias <jvdias@redhat.com> - 0.6.5-1
736- Upgrade to upstream version 0.6.5
737- Make /etc/avahi/etc and /etc/avahi/etc/localtime owned by avahi
738  package; copy system localtime into chroot in post
739
740* Mon Jan 23 2006 Jason Vas Dias <jvdias@redhat.com> - 0.6.4-4
741- fix bug 178689: copy localtime to chroot
742- fix bug 178784: fix avahi-dnsconfd initscript
743
744* Fri Jan 20 2006 Peter Jones <pjones@redhat.com> - 0.6.4-3
745- fix subsystem locking in the initscript
746
747* Thu Jan 19 2006 Jason Vas Dias <jvdias@redhat.com> - 0.6.4-2
748- fix bug 178127: fully localize the initscript
749
750* Mon Jan 16 2006 Jason Vas Dias <jvdias@redhat.com> - 0.6.4-1
751- Upgrade to upstream version 0.6.4
752
753* Thu Jan 12 2006 Jason Vas Dias <jvdias@redhat.com> - 0.6.3-2
754- fix bug 177610: Enable mono support with new avahi-sharp package
755- fix bug 177609: add gdbm / gdbm-devel Requires for avahi-browse
756
757* Mon Jan 09 2006 Jason Vas Dias <jvdias@redhat.com> - 0.6.3-1
758- Upgrade to upstream version 0.6.3
759- fix bug 177148: initscript start should not fail if avahi-daemon running
760 
761* Thu Dec 22 2005 Jason Vas Dias <jvdias@redhat.com> - 0.6.1-3
762- move initscripts from /etc/init.d to /etc/rc.d/init.d
763
764* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
765- rebuilt
766
767* Fri Dec 09 2005 Jason Vas Dias<jvdias@redhat.com> - 0.6.1-2
768- fix bug 175352: Do not chkconfig --add avahi-daemon
769  if user has already configured it
770
771* Wed Dec 07 2005 Jason Vas Dias<jvdias@redhat.com> - 0.6.1-1
772- Upgrade to 0.6.1
773
774* Mon Dec 05 2005 Jason Vas Dias<jvdias@redhat.com> - 0.6-6
775- fix bug 174799 - fix .spec file \%files permissions
776
777* Fri Dec 02 2005 Jason Vas Dias<jvdias@redhat.com> - 0.6-5
778- python-twisted has been removed from the FC-5 distribution - disable its use
779
780* Thu Dec 01 2005 Jason Vas Dias<jvdias@redhat.com> - 0.6-4
781- Rebuild for dbus-0.6 - remove use of DBUS_NAME_FLAG_PROHIBIT_REPLACEMENT
782
783* Wed Nov 30 2005 Jason Vas Dias<jvdias@redhat.com> - 0.6-3
784- fix bug 172047 - tools should require python-twisted
785- fix bug 173985 - docs directory permissions
786
787* Mon Nov 21 2005 Jason Vas Dias<jvdias@redhat.com> - 0.6-1
788- Upgrade to upstream version 0.6 - now provides 'avahi-howl-compat'
789  libraries / includes.
790
791* Mon Nov 14 2005 Jason Vas Dias<jvdias@redhat.com> - 0.5.2-7
792- fix bug 172034: fix ownership of /var/run/avahi-daemon/
793- fix bug 172772: .spec file improvements from matthias@rpmforge.net
794 
795* Mon Oct 31 2005 Jason Vas Dias<jvdias@redhat.com> - 0.5.2-6
796- put back avahi-devel Obsoletes: howl-devel
797
798* Mon Oct 31 2005 Alexander Larsson <alexl@redhat.com> - 0.5.2-5
799- Obsoletes howl, howl-libs, as we want to get rid of them on updates
800- No provides yet, as the howl compat library is in Avahi 0.6.0.
801
802* Sun Oct 30 2005 Florian La Roche <laroche@redhat.com>
803- disable the Obsoletes: howl until the transition is complete
804
805* Fri Oct 28 2005 Jason Vas Dias<jvdias@redhat.com> - 0.5.2-3
806- change initscript to start avahi-daemon AFTER messagebus
807
808* Wed Oct 26 2005 Karsten Hopp <karsten@redhat.de> 0.5.2-2
809- add buildrequires dbus-python
810
811* Fri Oct 21 2005 Alexander Larsson <alexl@redhat.com> - 0.5.2-1
812- Initial package
Note: See TracBrowser for help on using the repository browser.