source: projects/specs/trunk/a/avahi/avahi-vl.spec @ 521

Revision 521, 25.6 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define pythonlib %(python -c 'from distutils.sysconfig import get_python_lib; print get_python_lib(0)')
2%define _localstatedir %{_var}
3
4%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
5
6Summary:        Local network service discovery
7Summary(ja):    ローカルネットワークサービス検出システム
8Name:           avahi
9Version:        0.6.25
10Release:        3%{?_dist_release}
11Group:          System Environment/Base
12License:        LGPL
13URL:            http://avahi.org
14
15Source0:        %{name}-%{version}.tar.gz
16Patch10:        avahi-0.6.25-vine.patch
17
18BuildRoot:      %{_tmppath}/%{name}-%{version}-root
19BuildRequires:  gtk2-devel, qt-devel, libglade2-devel, glib2-devel
20BuildRequires:  qt4-devel
21BuildRequires:  libdaemon-devel >= 0.12
22BuildRequires:  libcap-devel, dbus-devel, expat-devel
23BuildRequires:  python, dbus-python, gdbm-devel, pygtk2, libmng-devel
24BuildRequires:  xorg-x11-devel, mesa-libGL-devel
25Requires:       dbus, libdaemon, expat, python, dbus-python, libcap
26Requires(post): initscripts, chkconfig >= 1.3.34
27Obsoletes:      howl, howl-libs
28
29Vendor: Project Vine
30Distribution: Vine Linux
31
32%description
33Avahi is a system which facilitates service discovery on
34a local network -- this means that you can plug your laptop or
35computer into a network and instantly be able to view other people who
36you can chat with, find printers to print to or find files being
37shared. This kind of technology is already found in MacOS X (branded
38'Rendezvous', 'Bonjour' and sometimes 'ZeroConf') and is very
39convenient.
40
41%package tools
42Summary: Tools for mDNS browsing and publishing
43Group: System Environment/Base
44Requires: %{name} = %{version}, gtk2, pygtk2, libglade2, pygtk2-libglade, gdbm
45
46%description tools
47Tools that use avahi to browse and publish mDNS services and hosts.
48
49%package ui
50Summary: UI libraries for avahi
51Summary(ja): avahi 用 UI ライブラリ
52Group: System Environment/Libraries
53Requires: %{name} = %{version}
54Requires: gtk2
55
56%description ui
57Libraries for easy use of avahi from gtk applications.
58
59%package ui-devel
60Summary: Libraries and header files for avahi ui development
61Group: Development/Libraries
62Requires: %{name}-devel = %{version}
63Requires: %{name}-ui = %{version}
64Requires: gtk2-devel
65
66%description ui-devel
67The avahi-ui-devel package contains the header files and libraries
68necessary for developing programs using avahi with gtk+.
69
70%package glib
71Summary: Glib libraries for avahi
72Summary(ja): avahi 用 glib ライブラリ
73Group: System Environment/Libraries
74Requires: %{name} = %{version}
75Requires: glib2
76
77%description glib
78Libraries for easy use of avahi from glib applications.
79
80%package glib-devel
81Summary: Libraries and header files for avahi glib development
82Group: Development/Libraries
83Requires: %{name}-devel = %{version}
84Requires: %{name}-glib = %{version}
85Requires: glib2-devel
86
87%description glib-devel
88The avahi-glib-devel package contains the header files and libraries
89necessary for developing programs using avahi with glib.
90
91%package gobject
92Summary: GObject library for Avahi
93Summary(ja): Avahi 用 GObject ライブラリ
94Group: System Environment/Base
95Requires: glib2
96Requires: %{name}-glib = %{version}-%{release}
97
98%description gobject
99This library contains a GObject wrapper for the Avahi API
100
101%package gobject-devel
102Summary: Libraries and header files for Avahi GObject development
103Summary(ja): Avahi GObject 開発用ライブラリとヘッダファイル
104Group: Development/Libraries
105Requires: %{name}-gobject = %{version}-%{release}
106Requires: %{name}-devel = %{version}-%{release}
107Requires: %{name}-glib-devel = %{version}-%{release}
108
109%description gobject-devel
110The avahi-gobject-devel package contains the header files and libraries
111necessary for developing programs using avahi-gobject.
112
113%package qt3
114Summary: Qt3 libraries for avahi
115Summary(ja): avahi 用 Qt3 ライブラリ
116Group: System Environment/Libraries
117Requires: %{name} = %{version}
118Requires: qt
119
120%description qt3
121Libraries for easy use of avahi from Qt3 applications.
122
123%package qt3-devel
124Summary: Libraries and header files for avahi Qt3 development
125Group: Development/Libraries
126Requires: %{name}-devel = %{version}
127Requires: %{name}-qt3 = %{version}
128Requires: qt-devel
129
130%description qt3-devel
131The avahi-qt3-devel package contains the header files and libraries
132necessary for developing programs using avahi with Qt3.
133
134%package qt4
135Summary: Qt4 libraries for avahi
136Summary(ja): avahi 用 Qt4 ライブラリ
137Group: System Environment/Base
138Requires: %{name} = %{version}-%{release}
139
140%description qt4
141Libraries for easy use of avahi from Qt4 applications.
142
143%package qt4-devel
144Summary: Libraries and header files for avahi Qt4 development
145Group: Development/Libraries
146Requires: %{name}-devel = %{version}-%{release}
147Requires: %{name}-qt4 = %{version}-%{release}
148Requires: qt4-devel
149
150%description qt4-devel
151Th avahi-qt4-devel package contains the header files and libraries
152necessary for developing programs using avahi with Qt4.
153
154%package devel
155Summary: Libraries and header files for avahi development
156Group: Development/Libraries
157Requires: %{name} = %{version}
158Obsoletes: howl-devel
159
160%description devel
161The avahi-devel package contains the header files and libraries
162necessary for developing programs using avahi.
163
164# compat32
165%package -n compat32-%{name}
166Summary:        Local network service discovery
167Summary(ja):    ローカルネットワークサービス検出システム
168Group:          System Environment/Base
169Requires: %{name} = %{version}-%{release}
170
171%description -n compat32-%{name}
172Avahi is a system which facilitates service discovery on
173a local network -- this means that you can plug your laptop or
174computer into a network and instantly be able to view other people who
175you can chat with, find printers to print to or find files being
176shared. This kind of technology is already found in MacOS X (branded
177'Rendezvous', 'Bonjour' and sometimes 'ZeroConf') and is very
178convenient.
179
180%package -n compat32-%{name}-ui
181Summary: UI libraries for avahi
182Summary(ja): avahi 用 UI ライブラリ
183Group: System Environment/Libraries
184Requires: %{name}-ui = %{version}-%{release}
185Requires: compat32-%{name} = %{version}-%{release}
186Requires: compat32-gtk2
187
188%description -n compat32-%{name}-ui
189Libraries for easy use of avahi from gtk applications.
190
191%package -n compat32-%{name}-ui-devel
192Summary: Libraries and header files for avahi ui development
193Group: Development/Libraries
194Requires: %{name}-ui-devel = %{version}-%{release}
195Requires: compat32-%{name}-devel = %{version}-%{release}
196Requires: compat32-%{name}-ui = %{version}-%{release}
197Requires: compat32-gtk2-devel
198
199%description -n compat32-%{name}-ui-devel
200The avahi-ui-devel package contains the header files and libraries
201necessary for developing programs using avahi with gtk+.
202
203%package -n compat32-%{name}-glib
204Summary: Glib libraries for avahi
205Summary(ja): avahi 用 glib ライブラリ
206Group: System Environment/Libraries
207Requires: %{name}-glib = %{version}-%{release}
208Requires: compat32-%{name} = %{version}-%{release}
209Requires: compat32-glib2
210
211%description -n compat32-%{name}-glib
212Libraries for easy use of avahi from glib applications.
213
214%package -n compat32-%{name}-glib-devel
215Summary: Libraries and header files for avahi glib development
216Group: Development/Libraries
217Requires: %{name}-glib-devel = %{version}-%{release}
218Requires: compat32-%{name}-devel = %{version}-%{release}
219Requires: compat32-%{name}-glib = %{version}-%{release}
220Requires: compat32-glib2-devel
221
222%description -n compat32-%{name}-glib-devel
223The avahi-glib-devel package contains the header files and libraries
224necessary for developing programs using avahi with glib.
225
226%package -n compat32-%{name}-gobject
227Summary: GObject library for Avahi
228Summary(ja): Avahi 用 GObject ライブラリ
229Group: System Environment/Base
230Requires: %{name}-gobject = %{version}-%{release}
231Requires: compat32-glib2
232Requires: compat32-%{name}-glib = %{version}-%{release}
233
234%description -n compat32-%{name}-gobject
235This library contains a GObject wrapper for the Avahi API
236
237%package -n compat32-%{name}-gobject-devel
238Summary: Libraries and header files for Avahi GObject development
239Summary(ja): Avahi GObject 開発用ライブラリとヘッダファイル
240Group: Development/Libraries
241Requires: %{name}-gobject-devel = %{version}-%{release}
242Requires: compat32-%{name}-gobject = %{version}-%{release}
243Requires: compat32-%{name}-devel = %{version}-%{release}
244Requires: compat32-%{name}-glib-devel = %{version}-%{release}
245
246%description -n compat32-%{name}-gobject-devel
247The avahi-gobject-devel package contains the header files and libraries
248necessary for developing programs using avahi-gobject.
249
250%package -n compat32-%{name}-qt3
251Summary: Qt3 libraries for avahi
252Summary(ja): avahi 用 Qt3 ライブラリ
253Group: System Environment/Libraries
254Requires: %{name}-qt3 = %{version}-%{release}
255Requires: compat32-%{name} = %{version}-%{release}
256Requires: compat32-qt
257
258%description -n compat32-%{name}-qt3
259Libraries for easy use of avahi from Qt3 applications.
260
261%package -n compat32-%{name}-qt3-devel
262Summary: Libraries and header files for avahi Qt3 development
263Group: Development/Libraries
264Requires: %{name}-qt3-devel = %{version}-%{release}
265Requires: compat32-%{name}-devel = %{version}-%{release}
266Requires: compat32-%{name}-qt3 = %{version}-%{release}
267Requires: compat32-qt-devel
268
269%description -n compat32-%{name}-qt3-devel
270The avahi-qt3-devel package contains the header files and libraries
271necessary for developing programs using avahi with Qt3.
272
273%package -n compat32-%{name}-qt4
274Summary: Qt4 libraries for avahi
275Summary(ja): avahi 用 Qt4 ライブラリ
276Group: System Environment/Base
277Requires: %{name}-qt4 = %{version}-%{release}
278Requires: compat32-%{name} = %{version}-%{release}
279
280%description -n compat32-%{name}-qt4
281Libraries for easy use of avahi from Qt4 applications.
282
283%package -n compat32-%{name}-qt4-devel
284Summary: Libraries and header files for avahi Qt4 development
285Group: Development/Libraries
286Requires: %{name}-qt4-devel = %{version}-%{release}
287Requires: compat32-%{name}-devel = %{version}-%{release}
288Requires: compat32-%{name}-qt4 = %{version}-%{release}
289Requires: compat32-qt4-devel
290
291%description -n compat32-%{name}-qt4-devel
292Th avahi-qt4-devel package contains the header files and libraries
293necessary for developing programs using avahi with Qt4.
294
295%package -n compat32-%{name}-devel
296Summary: Libraries and header files for avahi development
297Group: Development/Libraries
298Requires: %{name}-devel = %{version}-%{release}
299Requires: compat32-%{name} = %{version}-%{release}
300
301%description -n compat32-%{name}-devel
302The avahi-devel package contains the header files and libraries
303necessary for developing programs using avahi.
304
305%define avahi_user_uid 70
306
307%prep
308%setup -q
309%patch10 -p1 -b .vine
310
311%build
312autoreconf -i
313
314%configure --with-distro=vine \
315  --disable-monodoc --without-python-twisted \
316  --with-avahi-user=avahi --with-avahi-group=avahi \
317  --enable-compat-howl --enable-compat-libdns_sd \
318  --with-avahi-priv-access-group=avahi \
319  --with-autoipd-user=avahi-autoipd \
320  --with-autoipd-group=avahi-autoipd \
321  --disable-mono
322
323%__make -C avahi-python clean
324%__make %{?_smp_mflags}
325
326%install
327rm -rf $RPM_BUILD_ROOT
328make install DESTDIR=$RPM_BUILD_ROOT
329
330rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
331rm -f $RPM_BUILD_ROOT%{_libdir}/*.a
332
333# remove example
334rm -f $RPM_BUILD_ROOT%{_sysconfdir}/avahi/services/ssh.service
335
336# remove desktop file for avahi-discover
337rm -f $RPM_BUILD_ROOT%{_datadir}/applications/avahi-discover.desktop
338
339# create /var/run/avahi-daemon to ensure correct selinux policy for it:
340mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/run/avahi-daemon
341
342# remove the documentation directory - let \%doc handle it:
343rm -rf $RPM_BUILD_ROOT%{_datadir}/%{name}-%{version}
344
345# remove avahi-bookmarks - unusable without python-twisted,
346# which has been judged dangerous and is removed from the
347# Fedora Core distribution:
348rm -f $RPM_BUILD_ROOT/%{_bindir}/avahi-bookmarks $RPM_BUILD_ROOT/%{_mandir}/man1/avahi-bookmarks*
349#
350# move initscripts into /etc/rc.d/init.d :
351mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/rc.d/init.d
352mv $RPM_BUILD_ROOT/%{_sysconfdir}/init.d/* $RPM_BUILD_ROOT/%{_sysconfdir}/rc.d/init.d
353rm -rf $RPM_BUILD_ROOT/%{_sysconfdir}/init.d/*
354#
355# Make /etc/avahi/etc/localtime owned by avahi:
356mkdir -p $RPM_BUILD_ROOT/etc/avahi/etc
357touch $RPM_BUILD_ROOT/etc/avahi/etc/localtime
358:;
359
360%clean
361rm -rf $RPM_BUILD_ROOT
362
363%pre
364# Add the "avahi" group
365/usr/sbin/groupadd -f -r avahi
366# Add the "avahi" user
367/usr/sbin/useradd -g avahi -c 'Avahi daemon' -u %{avahi_user_uid} \
368        -s /sbin/nologin -r -d '/' avahi 2> /dev/null || :
369
370%post
371/sbin/ldconfig
372dbus-send --system --type=method_call --dest=org.freedesktop.DBus / org.freedesktop.DBus.ReloadConfig >/dev/null 2>&1 || :
373/sbin/chkconfig --add avahi-daemon >/dev/null 2>&1 ||:
374/sbin/chkconfig avahi-daemon resetpriorities >/dev/null 2>&1 ||:
375/sbin/chkconfig --add avahi-dnsconfd >/dev/null 2>&1 ||:
376/sbin/chkconfig avahi-dnsconfd resetpriorities >/dev/null 2>&1 ||:
377if [ "$1" -eq 1 ]; then
378   if [ -s /etc/localtime ]; then
379        cp -fp /etc/localtime /etc/avahi/etc/localtime || :;
380   fi
381fi
382
383%postun
384/sbin/ldconfig
385if [ "$1" -ge "1" ]; then
386   /sbin/service avahi-daemon condrestart >/dev/null 2>&1
387   /sbin/service avahi-dnsconfd condrestart >/dev/null 2>&1
388fi
389     
390%preun
391if [ "$1" -eq 0 ]; then
392    /sbin/service avahi-daemon stop > /dev/null 2>&1
393    /sbin/chkconfig --del avahi-daemon
394    /sbin/service avahi-dnsconfd stop >/dev/null 2>&1
395    /sbin/chkconfig --del avahi-dnsconfd
396fi
397
398%post ui -p /sbin/ldconfig
399
400%postun ui -p /sbin/ldconfig
401
402%post glib -p /sbin/ldconfig
403
404%postun glib -p /sbin/ldconfig
405
406%post qt3 -p /sbin/ldconfig
407
408%postun qt3 -p /sbin/ldconfig
409
410%post qt4 -p /sbin/ldconfig
411
412%postun qt4 -p /sbin/ldconfig
413
414%post gobject -p /sbin/ldconfig
415
416%postun gobject -p /sbin/ldconfig
417
418# compat32
419%post -n compat32-%{name} -p /sbin/ldconfig
420
421%postun -n compat32-%{name} -p /sbin/ldconfig
422
423%post -n compat32-%{name}-ui -p /sbin/ldconfig
424
425%postun -n compat32-%{name}-ui -p /sbin/ldconfig
426
427%post -n compat32-%{name}-glib -p /sbin/ldconfig
428
429%postun -n compat32-%{name}-glib -p /sbin/ldconfig
430
431%post -n compat32-%{name}-qt3 -p /sbin/ldconfig
432
433%postun -n compat32-%{name}-qt3 -p /sbin/ldconfig
434
435%post -n compat32-%{name}-qt4 -p /sbin/ldconfig
436
437%postun -n compat32-%{name}-qt4 -p /sbin/ldconfig
438
439%post -n compat32-%{name}-gobject -p /sbin/ldconfig
440
441%postun -n compat32-%{name}-gobject -p /sbin/ldconfig
442
443%files
444%defattr(0644,root,root,0755)
445%doc docs/* avahi-daemon/example.service avahi-daemon/ssh.service
446%attr(755,root,root) %{_sysconfdir}/rc.d/init.d/*
447%dir %{_sysconfdir}/avahi
448%dir %{_sysconfdir}/avahi/etc
449%ghost %{_sysconfdir}/avahi/etc/localtime
450%{_sysconfdir}/avahi/hosts
451%dir %{_sysconfdir}/avahi/services
452%dir %{_localstatedir}/run/avahi-daemon
453%config %{_sysconfdir}/avahi/avahi-autoipd.action
454%config %{_sysconfdir}/avahi/avahi-daemon.conf
455%config %{_sysconfdir}/avahi/avahi-dnsconfd.action
456%config %{_sysconfdir}/avahi/services/*
457%config %{_sysconfdir}/dbus-1/system.d/avahi-dbus.conf
458%attr(755,root,root) %{_sbindir}/*
459%attr(755,root,root) %{_libdir}/libavahi-common.so.*
460%attr(755,root,root) %{_libdir}/libavahi-core.so.*
461%attr(755,root,root) %{_libdir}/libavahi-client.so.*
462%attr(755,root,root) %{_libdir}/libhowl.so.*
463%attr(755,root,root) %{_libdir}/libdns_sd.so.*
464%attr(755,root,root) %{_datadir}/avahi
465%{_datadir}/locale/*
466%{_libdir}/avahi
467%exclude %{_datadir}/avahi/interfaces
468%{_mandir}/man5/*
469%{_mandir}/man8/*
470
471%files tools
472%defattr(0755, root, root, 0755)
473%{_bindir}/*
474%{pythonlib}/*
475%attr(0644,root,root) %{_mandir}/man1/*
476%{_datadir}/avahi/interfaces/
477%{_datadir}/applications/*
478
479%files devel
480%defattr(0644, root, root, 0755)
481%attr(755,root,root) %{_libdir}/libavahi-common.so
482%attr(755,root,root) %{_libdir}/libavahi-core.so
483%attr(755,root,root) %{_libdir}/libavahi-client.so
484%attr(755,root,root) %{_libdir}/libhowl.so
485%attr(755,root,root) %{_libdir}/libdns_sd.so
486%{_includedir}/avahi-client
487%{_includedir}/avahi-common
488%{_includedir}/avahi-core
489%{_includedir}/avahi-compat-howl
490%{_includedir}/avahi-compat-libdns_sd
491%{_libdir}/pkgconfig/avahi-core.pc
492%{_libdir}/pkgconfig/avahi-client.pc
493%{_libdir}/pkgconfig/avahi-compat-howl.pc
494%{_libdir}/pkgconfig/avahi-compat-libdns_sd.pc
495
496%files ui
497%defattr(0755, root, root, 0755)
498%{_libdir}/libavahi-ui.so.*
499
500%files ui-devel
501%defattr(0644, root, root, 0755)
502%attr(755,root,root) %{_libdir}/libavahi-ui.so
503%{_includedir}/avahi-ui
504%{_libdir}/pkgconfig/avahi-ui.pc
505
506%files glib
507%defattr(0755, root, root, 0755)
508%{_libdir}/libavahi-glib.so.*
509
510%files glib-devel
511%defattr(0644, root, root, 0755)
512%attr(755,root,root) %{_libdir}/libavahi-glib.so
513%{_includedir}/avahi-glib
514%{_libdir}/pkgconfig/avahi-glib.pc
515
516%files gobject
517%defattr(0755, root, root, 0755)
518%{_libdir}/libavahi-gobject.so.*
519
520%files gobject-devel
521%defattr(0644, root, root, 0755)
522%attr(755,root,root) %{_libdir}/libavahi-gobject.so
523%{_includedir}/avahi-gobject
524%{_libdir}/pkgconfig/avahi-gobject.pc
525
526%files qt3
527%defattr(0644, root, root, 0755)
528%attr(755,root,root) %{_libdir}/libavahi-qt3.so.*
529
530%files qt3-devel
531%defattr(0644, root, root, 0755)
532%attr(755,root,root) %{_libdir}/libavahi-qt3.so
533%{_includedir}/avahi-qt3
534%{_libdir}/pkgconfig/avahi-qt3.pc
535
536%files qt4
537%defattr(0644, root, root, 0755)
538%attr(755,root,root) %{_libdir}/libavahi-qt4.so.*
539
540%files qt4-devel
541%defattr(0644, root, root, 0755)
542%attr(755,root,root) %{_libdir}/libavahi-qt4.so
543%{_includedir}/avahi-qt4/
544%{_libdir}/pkgconfig/avahi-qt4.pc
545
546# compat32
547%if %{build_compat32}
548%files -n compat32-%{name}
549%defattr(0644,root,root,0755)
550%attr(755,root,root) %{_libdir}/libavahi-common.so.*
551%attr(755,root,root) %{_libdir}/libavahi-core.so.*
552%attr(755,root,root) %{_libdir}/libavahi-client.so.*
553%attr(755,root,root) %{_libdir}/libhowl.so.*
554%attr(755,root,root) %{_libdir}/libdns_sd.so.*
555%{_libdir}/avahi
556
557%files -n compat32-%{name}-devel
558%defattr(0644, root, root, 0755)
559%attr(755,root,root) %{_libdir}/libavahi-common.so
560%attr(755,root,root) %{_libdir}/libavahi-core.so
561%attr(755,root,root) %{_libdir}/libavahi-client.so
562%attr(755,root,root) %{_libdir}/libhowl.so
563%attr(755,root,root) %{_libdir}/libdns_sd.so
564%{_libdir}/pkgconfig/avahi-core.pc
565%{_libdir}/pkgconfig/avahi-client.pc
566%{_libdir}/pkgconfig/avahi-compat-howl.pc
567%{_libdir}/pkgconfig/avahi-compat-libdns_sd.pc
568
569%files -n compat32-%{name}-ui
570%defattr(0755, root, root, 0755)
571%{_libdir}/libavahi-ui.so.*
572
573%files -n compat32-%{name}-ui-devel
574%defattr(0644, root, root, 0755)
575%attr(755,root,root) %{_libdir}/libavahi-ui.so
576%{_libdir}/pkgconfig/avahi-ui.pc
577
578%files -n compat32-%{name}-glib
579%defattr(0755, root, root, 0755)
580%{_libdir}/libavahi-glib.so.*
581
582%files -n compat32-%{name}-glib-devel
583%defattr(0644, root, root, 0755)
584%attr(755,root,root) %{_libdir}/libavahi-glib.so
585%{_libdir}/pkgconfig/avahi-glib.pc
586
587%files -n compat32-%{name}-gobject
588%defattr(0755, root, root, 0755)
589%{_libdir}/libavahi-gobject.so.*
590
591%files -n compat32-%{name}-gobject-devel
592%defattr(0644, root, root, 0755)
593%attr(755,root,root) %{_libdir}/libavahi-gobject.so
594%{_libdir}/pkgconfig/avahi-gobject.pc
595
596%files -n compat32-%{name}-qt3
597%defattr(0644, root, root, 0755)
598%attr(755,root,root) %{_libdir}/libavahi-qt3.so.*
599
600%files -n compat32-%{name}-qt3-devel
601%defattr(0644, root, root, 0755)
602%attr(755,root,root) %{_libdir}/libavahi-qt3.so
603%{_libdir}/pkgconfig/avahi-qt3.pc
604
605%files -n compat32-%{name}-qt4
606%defattr(0644, root, root, 0755)
607%attr(755,root,root) %{_libdir}/libavahi-qt4.so.*
608
609%files -n compat32-%{name}-qt4-devel
610%defattr(0644, root, root, 0755)
611%attr(755,root,root) %{_libdir}/libavahi-qt4.so
612%{_libdir}/pkgconfig/avahi-qt4.pc
613%endif
614
615%changelog
616* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.6.25-3
617- rebuilt with gcc-4.4.3-3 on ppc
618
619* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 0.6.25-2
620- rebuilt with python-2.6.4
621
622* Sat Sep 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.25-1
623- new upstream release
624- update vine patch
625  - startup avahi-daemon earlier
626
627* Mon Jul 13 2009 NAKAMURA Kenta <kenta@vinelinux.org> 0.6.24-2
628- added qt4 subpackage
629- added compat32 package for x86_64 arch support
630
631* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.24-1
632- new upstream release
633
634* Fri Jan 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.6.23-2
635- fixed %%pre: add the "avahi" user to the "avahi" group
636
637* Mon Sep 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.23-1
638- new upstream release
639
640* Thu Jul 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.22-1
641- new upstream release
642- add gobject, gobject-devel sub package
643- enable avahi-autoipd
644
645* Wed Jul 23 2008 Shu KONNO <owa@bg.wakwak.com> 0.6.20-1vl5
646- built with python-2.5.2
647- s/automake-1.9/automake/
648- fixed python library path
649- applied new versioning policy
650
651* Wed Feb 20 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.6.20-0vl2
652- rebuild with expat-2.0.1
653
654* Mon Jul 23 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.20-0vl1
655- new upstream release
656
657* Thu May 10 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.18-0vl2
658- rebuild with new environment/toolchain
659
660* Tue May 08 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.18-0vl1
661- new upstream release
662
663* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.17-0vl2
664- require new chkconfig to reset initscript priorities
665
666* Thu Apr 26 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.17-0vl1
667- new upstream release
668
669* Fri Jan 12 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.6.13-0vl3
670- add patch110 for fix CVE-2006-6870
671- add Vendor/Distribution Tag
672
673* Wed Dec 27 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.13-0vl2
674- rebuilt for VineSeed
675
676* Thu Dec 07 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.6.13-0vl1.1
677- add patch100 for fix CVE-2006-5461
678- add BuildRequires:  XOrg-gl-devel tag
679
680* Thu Sep 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.13-0vl1
681- new upstream release
682- refine %%post scripts
683- add condrestart daemon in %%postun
684
685* Mon May 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.10-0vl1
686- new upstream release
687
688* Thu Mar 23 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.9-0vl2
689- move /var/lib/run/avahi-daemon to /var/run
690
691* Sun Mar 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.9-0vl1
692- initial build for Vine Linux based on FC package
693- add Patch10 to support Vine Linux
694
695* Thu Feb 23 2006 Jason Vas Dias <jvdias@redhat.com> - 0.6.8-1
696- Upgrade to upstream version 0.6.8
697- fix bug 182462: +Requires(post): initscripts, chkconfig, ldconfig
698
699* Fri Feb 17 2006 Jason Vas Dias <jvdias@redhat.com> - 0.6.7-1
700- Upgrade to upstream version 0.6.7
701
702* Fri Feb 17 2006 Karsten Hopp <karsten@redhat.de> - 0.6.6-4
703- BuildRequires pygtk2
704
705* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.6.6-3.1
706- bump again for double-long bug on ppc(64)
707
708* Fri Feb 10 2006 Jason Vas Dias <jvdias@redhat.com> - 0.6.6-3
709- rebuild for new gcc (again)
710- further fix for bug 178746: fix avahi-dnsconfd initscript
711
712* Tue Feb 07 2006 Jason Vas Dias <jvdias@redhat.com> - 0.6.6-2
713- rebuild for new gcc, glibc, glibc-kernheaders
714
715* Wed Feb 01 2006 Jason Vas Dias <jvdias@redhat.com> - 0.6.6-1
716- fix bug 179448: mis-alignment of input cmsghdr msg->msg_control buffer on ia64
717- Upgrade to 0.6.6
718
719* Thu Jan 26 2006 Jason Vas Dias <jvdias@redhat.com> - 0.6.5-1
720- Upgrade to upstream version 0.6.5
721- Make /etc/avahi/etc and /etc/avahi/etc/localtime owned by avahi
722  package; copy system localtime into chroot in post
723
724* Mon Jan 23 2006 Jason Vas Dias <jvdias@redhat.com> - 0.6.4-4
725- fix bug 178689: copy localtime to chroot
726- fix bug 178784: fix avahi-dnsconfd initscript
727
728* Fri Jan 20 2006 Peter Jones <pjones@redhat.com> - 0.6.4-3
729- fix subsystem locking in the initscript
730
731* Thu Jan 19 2006 Jason Vas Dias <jvdias@redhat.com> - 0.6.4-2
732- fix bug 178127: fully localize the initscript
733
734* Mon Jan 16 2006 Jason Vas Dias <jvdias@redhat.com> - 0.6.4-1
735- Upgrade to upstream version 0.6.4
736
737* Thu Jan 12 2006 Jason Vas Dias <jvdias@redhat.com> - 0.6.3-2
738- fix bug 177610: Enable mono support with new avahi-sharp package
739- fix bug 177609: add gdbm / gdbm-devel Requires for avahi-browse
740
741* Mon Jan 09 2006 Jason Vas Dias <jvdias@redhat.com> - 0.6.3-1
742- Upgrade to upstream version 0.6.3
743- fix bug 177148: initscript start should not fail if avahi-daemon running
744 
745* Thu Dec 22 2005 Jason Vas Dias <jvdias@redhat.com> - 0.6.1-3
746- move initscripts from /etc/init.d to /etc/rc.d/init.d
747
748* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
749- rebuilt
750
751* Fri Dec 09 2005 Jason Vas Dias<jvdias@redhat.com> - 0.6.1-2
752- fix bug 175352: Do not chkconfig --add avahi-daemon
753  if user has already configured it
754
755* Wed Dec 07 2005 Jason Vas Dias<jvdias@redhat.com> - 0.6.1-1
756- Upgrade to 0.6.1
757
758* Mon Dec 05 2005 Jason Vas Dias<jvdias@redhat.com> - 0.6-6
759- fix bug 174799 - fix .spec file \%files permissions
760
761* Fri Dec 02 2005 Jason Vas Dias<jvdias@redhat.com> - 0.6-5
762- python-twisted has been removed from the FC-5 distribution - disable its use
763
764* Thu Dec 01 2005 Jason Vas Dias<jvdias@redhat.com> - 0.6-4
765- Rebuild for dbus-0.6 - remove use of DBUS_NAME_FLAG_PROHIBIT_REPLACEMENT
766
767* Wed Nov 30 2005 Jason Vas Dias<jvdias@redhat.com> - 0.6-3
768- fix bug 172047 - tools should require python-twisted
769- fix bug 173985 - docs directory permissions
770
771* Mon Nov 21 2005 Jason Vas Dias<jvdias@redhat.com> - 0.6-1
772- Upgrade to upstream version 0.6 - now provides 'avahi-howl-compat'
773  libraries / includes.
774
775* Mon Nov 14 2005 Jason Vas Dias<jvdias@redhat.com> - 0.5.2-7
776- fix bug 172034: fix ownership of /var/run/avahi-daemon/
777- fix bug 172772: .spec file improvements from matthias@rpmforge.net
778 
779* Mon Oct 31 2005 Jason Vas Dias<jvdias@redhat.com> - 0.5.2-6
780- put back avahi-devel Obsoletes: howl-devel
781
782* Mon Oct 31 2005 Alexander Larsson <alexl@redhat.com> - 0.5.2-5
783- Obsoletes howl, howl-libs, as we want to get rid of them on updates
784- No provides yet, as the howl compat library is in Avahi 0.6.0.
785
786* Sun Oct 30 2005 Florian La Roche <laroche@redhat.com>
787- disable the Obsoletes: howl until the transition is complete
788
789* Fri Oct 28 2005 Jason Vas Dias<jvdias@redhat.com> - 0.5.2-3
790- change initscript to start avahi-daemon AFTER messagebus
791
792* Wed Oct 26 2005 Karsten Hopp <karsten@redhat.de> 0.5.2-2
793- add buildrequires dbus-python
794
795* Fri Oct 21 2005 Alexander Larsson <alexl@redhat.com> - 0.5.2-1
796- Initial package
Note: See TracBrowser for help on using the repository browser.