source: projects/specs/trunk/a/autogen/autogen-vl.spec @ 8225

Revision 8225, 4.2 KB checked in by yasumichi, 10 years ago (diff)

new upstream release

Line 
1Version:    5.18.1
2Release:    1%{?_dist_release}
3
4Summary:    AutoGen - The Automated Program Generator
5Name:       autogen
6URL:        http://www.gnu.org/software/autogen/       
7License:    GPL2
8Group:      Development/Tools
9Source:     ftp://ftp.gnu.org/gnu/autogen/rel%{version}/autogen-%{version}.tar.xz
10BuildRoot:  %{_tmppath}/%{name}-root
11
12Requires:       install-info
13Requires:       guile
14BuildRequires:  guile-devel
15BuildRequires:  libxml2-devel
16
17Vendor: Project Vine
18Distribution: Vine Linux
19Packager: yasumichi
20
21%description
22AutoGen is a tool designed for generating program files that contain
23repetitive text with varied substitutions.  Its goal is to simplify the
24maintenance of programs that contain large amounts of repetitious text.
25This is especially valuable if there are several blocks of such text
26that must be kept synchronized in parallel tables.
27
28Some parts are released under different licensing:
29
30libopts LGPL  This is a tear-off, redistributable option processing library
31autofsm BSD   This is a template for producing finite state machine programs
32
33The Copyright itself is privately held by Bruce Korb.
34
35%prep
36%setup -q
37chmod -R +rw *
38
39%build
40%configure
41make CFLAGS="$RPM_OPT_FLAGS"
42
43if [ `id -u` -eq 0 ] && egrep -q ^nobody /etc/passwd
44then
45    echo "switching to user nobody to run 'make check'"
46    chown -R nobody . ; su -c "umask 002; make check || touch FAIL" nobody
47else
48    make check
49fi
50[ -f FAIL ] && exit 1
51
52%install
53[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
54mkdir -p ${RPM_BUILD_ROOT}
55make install DESTDIR=${RPM_BUILD_ROOT}
56
57rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
58
59# IF we have a valid file list OR the build root is _the_ root,
60# THEN skip the file list generation.
61#
62if test \( -f autogen-filelist \
63        -a -s autogen-filelist \) \
64        -o ${#RPM_BUILD_ROOT} -le 1
65then : ; else
66  ( cd ${RPM_BUILD_ROOT}
67    rm -f usr/share/info/dir
68    find . -type f | grep -v 'usr/share/doc'
69  ) | sed -e 's@^\./@/@' \
70          -e'/usr\/share\/info/s,$,.gz,' \
71          -e'/usr\/share\/man/s,$,.gz,' \
72    | sort \
73    > autogen-filelist
74fi
75
76%post
77/sbin/ldconfig
78/sbin/install-info --info-dir=%{_infodir} %{_infodir}/autogen.info.gz
79
80%preun
81/sbin/install-info --delete --info-dir=%{_infodir} %{_infodir}/autogen.info.gz
82
83%postun -p /sbin/ldconfig
84
85%clean
86rm -rf ${RPM_BUILD_ROOT}
87
88%files -f autogen-filelist
89%defattr(-,root,root)
90%doc AUTHORS TODO COPYING NEWS THANKS README VERSION
91#%%{_libdir}/libguileopts.so
92#%%{_libdir}/libguileopts.so.0
93%{_libdir}/libopts.so
94%{_libdir}/libopts.so.25
95
96%changelog
97* Mon Jan 27 2014 Yasumichi Akahoshi <yasumichi@vinelinux.org> 5.18.1-1
98- new upstream release
99- change archive format
100- add dependencies
101
102* Sun Oct 03 2010 Shu KONNO <owa@bg.wakwak.com> 5.9.9-2
103- rebuilt with rpm-4.8.1 for pkg-config
104
105* Tue Nov 03 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 5.9.9-1
106- new upstream release.
107- build with guile-1.8.7
108- add Vendor, Distribution and Packager.
109
110* Tue Jan 13 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 5.9.7-1
111- new upstream release
112- build with guile-1.8.6
113- correct spec tag (Vendor -> URL)
114
115* Tue May 13 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 5.9.4-3vl5
116- use macro for Release
117
118* Sat May 10 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 5.9.4-2vl5
119- rebuild with guile-1.6.7-5vl5
120
121* Fri May 09 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 5.9.4-1vl5
122- apply new virsioning policy.
123- remove *.la
124
125* Sat Jan 05 2008 Shu KONNO <owa@bg.wakwak.com> 5.9.4-0vl1
126- updated to last stable release
127
128* Thu Jan 03 2008 Shu KONNO <owa@bg.wakwak.com> 5.8.7-5vl2
129- added %%{_libdir}/lib*.so* in %%files
130
131* Sun Dec 17 2006 Yasumichi Akahoshi <yasumichi@vinelinux.org> 5.8.7-5vl1
132- build for VineSeed
133* Sat Oct 14 2006 Bruce Korb <bkorb@veritas.com> Regenerated
134* Fri Dec 31 2004 Bruce Korb <bkorb@gnu.org> Restored the file list
135* Wed Oct 27 2004 Ed Swierk <eswierk@users.sf.net> fixed up for Fedora
136* Tue Dec 16 2003 Richard Zidlicky <rz@linux-m68k.org> 5.5.7pre5-5
137- fix %%doc
138- add post/pre scriptlets
139- change default prefix
140* Sat Mar 15 2003 Bruce Korb <bkorb@gnu.org>
141- Rework as a template to automatically produce a properly configured RPM
142* Fri Aug 9 2002 Bruce Korb <bkorb@gnu.org>
143- Pull stuff from Thomas Steudten's version of this file
Note: See TracBrowser for help on using the repository browser.