source: projects/specs/trunk/a/autogen/autogen-vl.spec @ 521

Revision 521, 3.8 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Version:    5.9.9
2Release:    1%{?_dist_release}
3
4Summary:    AutoGen - The Automated Program Generator
5Name:       autogen
6URL:        http://www.gnu.org/software/autogen/       
7License:    GPL2
8Group:      Development/Tools
9Source:     ftp://ftp.gnu.org/gnu/autogen/rel%{version}/autogen-%{version}.tar.bz2
10BuildRoot:  %{_tmppath}/%{name}-root
11
12Vendor: Project Vine
13Distribution: Vine Linux
14Packager: yasumichi
15
16%description
17AutoGen is a tool designed for generating program files that contain
18repetitive text with varied substitutions.  Its goal is to simplify the
19maintenance of programs that contain large amounts of repetitious text.
20This is especially valuable if there are several blocks of such text
21that must be kept synchronized in parallel tables.
22
23Some parts are released under different licensing:
24
25libopts LGPL  This is a tear-off, redistributable option processing library
26autofsm BSD   This is a template for producing finite state machine programs
27
28The Copyright itself is privately held by Bruce Korb.
29
30%prep
31%setup -q
32chmod -R +rw *
33
34%build
35%configure
36make CFLAGS="$RPM_OPT_FLAGS"
37
38if [ `id -u` -eq 0 ] && egrep -q ^nobody /etc/passwd
39then
40    echo "switching to user nobody to run 'make check'"
41    chown -R nobody . ; su -c "umask 002; make check || touch FAIL" nobody
42else
43    make check
44fi
45[ -f FAIL ] && exit 1
46
47%install
48[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
49mkdir -p ${RPM_BUILD_ROOT}
50make install DESTDIR=${RPM_BUILD_ROOT}
51
52rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
53
54# IF we have a valid file list OR the build root is _the_ root,
55# THEN skip the file list generation.
56#
57if test \( -f autogen-filelist \
58        -a -s autogen-filelist \) \
59        -o ${#RPM_BUILD_ROOT} -le 1
60then : ; else
61  ( cd ${RPM_BUILD_ROOT}
62    rm -f usr/share/info/dir
63    find . -type f | grep -v 'usr/share/doc'
64  ) | sed -e 's@^\./@/@' \
65          -e'/usr\/share\/info/s,$,.gz,' \
66          -e'/usr\/share\/man/s,$,.gz,' \
67    | sort \
68    > autogen-filelist
69fi
70
71%post
72/sbin/ldconfig
73/sbin/install-info --info-dir=%{_infodir} %{_infodir}/autogen.info.gz
74
75%preun
76/sbin/install-info --delete --info-dir=%{_infodir} %{_infodir}/autogen.info.gz
77
78%postun -p /sbin/ldconfig
79
80%clean
81rm -rf ${RPM_BUILD_ROOT}
82
83%files -f autogen-filelist
84%defattr(-,root,root)
85%doc AUTHORS TODO COPYING NEWS NOTES THANKS README VERSION
86%{_libdir}/libguileopts.so
87%{_libdir}/libguileopts.so.0
88%{_libdir}/libopts.so
89%{_libdir}/libopts.so.25
90
91%changelog
92* Tue Nov 03 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 5.9.9-1
93- new upstream release.
94- build with guile-1.8.7
95- add Vendor, Distribution and Packager.
96
97* Tue Jan 13 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 5.9.7-1
98- new upstream release
99- build with guile-1.8.6
100- correct spec tag (Vendor -> URL)
101
102* Tue May 13 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 5.9.4-3vl5
103- use macro for Release
104
105* Sat May 10 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 5.9.4-2vl5
106- rebuild with guile-1.6.7-5vl5
107
108* Fri May 09 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 5.9.4-1vl5
109- apply new virsioning policy.
110- remove *.la
111
112* Sat Jan 05 2008 Shu KONNO <owa@bg.wakwak.com> 5.9.4-0vl1
113- updated to last stable release
114
115* Thu Jan 03 2008 Shu KONNO <owa@bg.wakwak.com> 5.8.7-5vl2
116- added %%{_libdir}/lib*.so* in %%files
117
118* Sun Dec 17 2006 Yasumichi Akahoshi <yasumichi@vinelinux.org> 5.8.7-5vl1
119- build for VineSeed
120* Sat Oct 14 2006 Bruce Korb <bkorb@veritas.com> Regenerated
121* Fri Dec 31 2004 Bruce Korb <bkorb@gnu.org> Restored the file list
122* Wed Oct 27 2004 Ed Swierk <eswierk@users.sf.net> fixed up for Fedora
123* Tue Dec 16 2003 Richard Zidlicky <rz@linux-m68k.org> 5.5.7pre5-5
124- fix %%doc
125- add post/pre scriptlets
126- change default prefix
127* Sat Mar 15 2003 Bruce Korb <bkorb@gnu.org>
128- Rework as a template to automatically produce a properly configured RPM
129* Fri Aug 9 2002 Bruce Korb <bkorb@gnu.org>
130- Pull stuff from Thomas Steudten's version of this file
Note: See TracBrowser for help on using the repository browser.