source: projects/specs/trunk/a/autofs/autofs-vl.spec @ 864

Revision 864, 17.7 KB checked in by daisuke, 14 years ago (diff)

autofs:

  • update to 5.0.5
  • update upstream patches
Line 
1Summary: A tool for automatically mounting and unmounting filesystems.
2Summary(ja): 自動的にファイルシステムをマウント/アンマウントするツール
3Name: autofs
4Version: 5.0.5
5Release: 1%{?_dist_release}
6Epoch: 1
7License: GPL
8Group: System Environment/Daemons
9Source: ftp://ftp.kernel.org/pub/linux/daemons/autofs/autofs-%{version}.tar.bz2
10# upstream patches
11Patch1: autofs-5.0.5-fix-included-map-read-fail-handling.patch
12Patch2: autofs-5.0.5-refactor-ldap-sasl-bind.patch
13Patch3: autofs-5.0.4-add-mount-wait-parameter.patch
14Patch4: autofs-5.0.5-special-case-cifs-escapes.patch
15Patch5: autofs-5.0.5-fix-libxml2-workaround-configure.patch
16Patch6: autofs-5.0.5-more-code-analysis-corrections.patch
17Patch7: autofs-5.0.5-fix-backwards-ifndef-INET6.patch
18Patch8: autofs-5.0.5-fix-stale-init-for-file-map-instance.patch
19Patch9: autofs-5.0.5-fix-ext4-fsck-at-mount.patch
20Patch10: autofs-5.0.5-dont-use-master_lex_destroy-to-clear-parse-buffer.patch
21Patch11: autofs-5.0.5-make-documentation-for-set-log-priority-clearer.patch
22Patch12: autofs-5.0.5-fix-timeout-in-connect_nb.patch
23Patch13: autofs-5.0.5-fix-pidof-init-script-usage.patch
24Patch14: autofs-5.0.5-check-for-path-mount-location-in-generic-module.patch
25Patch15: autofs-5.0.5-dont-fail-mount-on-access-fail.patch
26Patch16: autofs-5.0.5-fix-rpc-large-export-list.patch
27Patch17: autofs-5.0.5-fix-memory-leak-on-reload.patch
28Patch18: autofs-5.0.5-dont-connect-at-ldap-lookup-module-init.patch
29Patch19: autofs-5.0.5-fix-random-selection-option.patch
30Patch20: autofs-5.0.5-fix-disable-timeout.patch
31Patch21: autofs-5.0.5-fix-strdup-return-value-check.patch
32Patch22: autofs-5.0.5-fix-reconnect-get-base-dn.patch
33Patch23: autofs-5.0.5-add-sasl-mutex-callbacks.patch
34Patch24: autofs-5.0.5-fix-get-qdn-fail.patch
35Patch25: autofs-5.0.5-fix-ampersand-escape-in-auto-smb.patch
36Patch26: autofs-5.0.5-add-locality-as-valid-ldap-master-map-attribute.patch
37Patch27: autofs-5.0.5-add-locality-as-valid-ldap-master-map-attribute-fix.patch
38
39## Vine Patch(es)
40Patch100: autofs-3.1.7-initdir.patch
41Patch101: autofs-5.0.3-rc.autofs_LSB.patch
42
43Buildroot: %{_tmppath}/%{name}-%{version}-root
44BuildRequires: openldap-devel
45BuildRequires: bind-devel, libxml2-devel, openssl-devel
46BuildRequires: util-linux-ng, nfs-utils, e2fsprogs
47BuildRequires: flex, bison
48Requires(post): /sbin/chkconfig
49Requires(preun): /sbin/service
50Requires(postun): /sbin/chkconfig
51Requires(postun): /sbin/service
52Requires: kernel >= 2.6.17
53Requires: bash, sed, gawk, coreutils, grep, module-init-tools, procps
54Provides: autofs-ldap
55Obsoletes: autofs-ldap <= 4.1.4-11vl2
56
57
58%description
59Autofs controls the operation of the automount daemons. The automount
60daemons automatically mount filesystems when you use them and
61unmount them after a period of inactivity. Filesystems can include
62network filesystems, CD-ROMs, floppies and others.
63
64Install this package if you want a program for automatically mounting
65and unmounting filesystems. If your Vine Linux machine is on a
66network, you should install autofs.
67
68%description -l ja
69autofs は automount デーモンの動作を制御します.
70automount デーモンは,ファイルシステムを使う時に自動的にマウントし,
71一定時間使わなければアンマウントしてくれます.
72対象となるファイルシステムには NFS, CD-ROM, フロッピー等があります.
73
74ファイルシステムを自動的にマウント/アンマウントさせたい場合は
75このパッケージをインストールして下さい.Vine Linux をインストールした
76マシンをネットワークに接続しているのならば,autofs をインストール
77すると良いでしょう.
78
79
80%prep
81%setup -q
82echo %{version}-%{release} > .version
83%patch1 -p1
84%patch2 -p1
85%patch3 -p1
86%patch4 -p1
87%patch5 -p1
88%patch6 -p1
89%patch7 -p1
90%patch8 -p1
91%patch9 -p1
92%patch10 -p1
93%patch11 -p1
94%patch12 -p1
95%patch13 -p1
96%patch14 -p1
97%patch15 -p1
98%patch16 -p1
99%patch17 -p1
100%patch18 -p1
101%patch19 -p1
102%patch20 -p1
103%patch21 -p1
104%patch22 -p1
105%patch23 -p1
106%patch24 -p1
107%patch25 -p1
108%patch26 -p1
109%patch27 -p1
110
111## Vine Patch(es)
112if [ "%{_initdir}" = "/etc/rc.d/init.d" ]; then
113    patch -p1 -b --suffix .initdir < %{PATCH100}
114fi
115%patch101 -p1 -b .lsb
116
117%build
118CFLAGS="$RPM_OPT_FLAGS -ggdb"; export CFLAGS
119%configure --without-hesiod --without-sasl \
120           --disable-mount-locking --enable-ignore-busy
121make initdir=/etc/rc.d/init.d STRIP=:
122make -C redhat
123
124%install
125[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
126mkdir -p -m755 $RPM_BUILD_ROOT%{_initdir}
127mkdir -p -m755 $RPM_BUILD_ROOT%{_libdir}/autofs
128mkdir -p -m755 $RPM_BUILD_ROOT%{_mandir}/{man5,man8}
129mkdir -p -m755 $RPM_BUILD_ROOT%{_sbindir}
130mkdir -p -m755 $RPM_BUILD_ROOT/etc/sysconfig
131
132make install mandir=%{_mandir} initdir=/etc/rc.d/init.d INSTALLROOT=$RPM_BUILD_ROOT
133make -C redhat
134install -m 755 -d $RPM_BUILD_ROOT/misc
135install -m 755 redhat/autofs.init $RPM_BUILD_ROOT/etc/rc.d/init.d/autofs
136install -m 644 redhat/autofs.sysconfig $RPM_BUILD_ROOT/etc/sysconfig/autofs
137
138%clean
139[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
140
141
142%post
143/sbin/chkconfig --add autofs
144
145
146%postun
147if [ $1 -ge 1 ] ; then
148        /sbin/service autofs condrestart > /dev/null 2>&1 || :
149fi
150
151%preun
152if [ "$1" = 0 ] ; then
153        /sbin/service autofs stop > /dev/null 2>&1
154        chkconfig --del autofs
155fi
156
157
158%files
159%defattr(-,root,root)
160%doc CHANGELOG COPYING COPYRIGHT CREDITS patches/*
161%doc samples/*
162%doc README README.*
163%config %{_initdir}/autofs
164%config(noreplace,missingok) /etc/auto.master
165%config(noreplace,missingok) /etc/auto.misc
166%config(noreplace,missingok) /etc/auto.net
167%config(noreplace,missingok) /etc/auto.smb
168%config(noreplace) /etc/autofs_ldap_auth.conf
169%config(noreplace) /etc/sysconfig/autofs
170%{_sbindir}/automount
171%dir /misc
172%dir %{_libdir}/autofs
173%{_libdir}/autofs/*.so
174%{_mandir}/*/*
175
176
177%changelog
178* Sun Apr 18 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 5.0.5-1
179- new upstream release
180- update upstream patches (Patch0-27)
181
182* Wed May 06 2009 NAKAMURA Kenta <kenta@vinelinux.org> 5.0.3-4
183- added Patch101: autofs-5.0.3-rc.autofs_LSB.patch to support LSB Header
184
185* Mon Jan 05 2009 NAKAMURA Kenta <kenta@vinelinux.org> 5.0.3-3
186- rebuilt with openldap-2.4.11
187
188* Sun Sep 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 5.0.3-2
189- make autofs.init executable. (<BTS:wishes:0160>)
190
191* Mon Sep 01 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 5.0.3-1vl5
192- new upstream release
193- update fedora patches
194
195* Sat Aug 30 2008 Shu KONNO <owa@bg.wakwak.com> 4.1.4-12vl5
196- applied new versioning policy, spec in utf-8
197
198* Fri Apr 06 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.1.4-11vl5
199- fix sort option on auto.net (<BTS:490>)
200
201* Mon Sep 18 2006 NAKAMURA Kenta <kenta@vinelinux.org> 4.1.4-11vl4
202- added patch15 and patch16 imported from Fedora Core 5
203
204* Mon Sep 04 2006 NAKAMURA Kenta <kenta@vinelinux.org> 4.1.4-11vl3
205- added Obsoletes: autofs-ldap
206- added BuildPrereq: openldap-devel
207
208* Sun Aug 27 2006 NAKAMURA Kenta <kenta@vinelinux.org> 4.1.4-11vl2
209- removed --without-openldap configure option
210- rebuilt with openldap-2.3.27-0vl1
211
212* Sun Oct 30 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.1.4-11vl1
213- updated based on Fedora
214  * Wed Oct 26 2005  <jmoyer@redhat.com> - 1:4.1.4-11
215  - Check the return code of is_local_addr in get_best_mount. (bz #169523)
216  * Wed Oct 26 2005  <jmoyer@redhat.com> - 1:4.1.4-10
217  - Fix a buffer overflow with large key lengths
218  - change to the upstream reentrant syslog patch from the band-aid deferred
219    syslog patch.
220  - Get rid of the init script patch that hard-coded the release to redhat.
221    This should be handled properly by all red hat distros.
222  * Wed May  4 2005 Jeff Moyer <jmoyer@redhat.com> - 1:4.1.4-8
223  - Add in the deferred syslog patch.  This fixes a hung automounter issue
224    related to unsafe calls to syslog in signal handler context.
225  * Tue May  3 2005 Jeff Moyer <jmoyer@redhat.com> - 1:4.1.4-7
226  - I reversed the checking for multimount entries, breaking those configs!
227    This update puts the code back the way it was before I broke it.
228  * Tue Apr 26 2005 Jeff Moyer <jmoyer@redhat.com> - 1:4.1.4-6
229  - Fix a race between mounting a share and updating the cache in the parent
230    process.  If the mount completed first, the parent would not expire the
231    stale entry, leaving it first on the list.  This causes map updates to not
232    be recognized (well, worse, they are recognized after the first expire, but
233    not subsequent ones).  Fixes a regression, bug #137026 (rhel3 bug).
234  * Fri Apr 15 2005 Chris Feist <cfeist@redhat.com> - 1:4.1.4-5
235  - Fixed regression with -browse not taking effect.
236  * Wed Apr 13 2005 Jeff Moyer <jmoyer@redhat.com> - 1:4.1.4-4
237  - Finish up with the merge breakage.
238  - Temporary fix for the multimount detection code.  It seems half-baked.
239  * Wed Apr 13 2005 Jeff Moyer <jmoyer@redhat.com> - 1:4.1.4-3
240  - Fix up the one-auto-master patch.  My "improvements" had side-effects.
241  * Wed Oct 27 2004 Chris Feist <cfeist@redhat.com> - 1:4.1.3-34
242  - Added a patch to fix the automounter failing on ldap maps
243    when it couldn't get the whole map.  (ie. when the search
244    limit was lower than the number of results)
245- updated Patch101
246- s/Red Hat/Vines/ in description
247
248* Wed Jun 23 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 3.1.7-42vl3
249- fix init script (Patch102)
250  not to create lock file when no mountpoints are defined
251
252* Tue Oct 28 2003 Tomoya TAKA <taka@vinelinux.org> 3.1.7-42vl2
253- do not compile/install autofs-ldap-auto-master
254
255* Sun Oct  5 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.1.7-42vl1
256- based on Rawhide 3.1.7-42
257  - Fri Apr 25 2003 Nalin Dahyabhai <nalin@redhat.com> 3.1.7-37
258  - sync with current linux/auto_fs.h from the current kernel tree (#88562)
259  - Tue Apr  2 2002 Nalin Dahyabhai <nalin@redhat.com> 3.1.7-28
260  - try to properly handle nisplus maps (patch from Steve Foster via the
261    autofs mailing list)
262  - override the STRIP makefile variable to not strip binaries (that's the
263    build root policy's job)
264  - Wed Aug 29 2001 Nalin Dahyabhai <nalin@redhat.com> 3.1.7-21
265  - don't inhibit starting if we have a subsys lock around -- that's the
266    wrong thing to do anyway
267  - don't create a subsys lock if we're unconfigured (#52755)
268- rebuild with new toolchain
269- s/Copyright/License/
270
271* Tue Jan 29 2002 Toru Sagami <sagami@vinelinux.org> 3.1.7-2vl2
272- make /etc/vine-release read by autofs.init
273
274* Fri Jan 19 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
275- 3.1.7-2vl1
276- rebuilt for VineSeed
277- use better macros (%%{_initdir})
278- add Patch100 to cope with initdir :-(
279
280* Thu Jan 18 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
281- 3.1.7-2vl0
282- based on 3.1.7-2 from Rawhide
283- remove /etc/init.d from PreReq
284- build without openldap and hesiod
285- BuildPreReq: bind-devel again for Vine
286- added Japanese summary and description
287
288* Tue Jan  9 2001 Nalin Dahyabhai <nalin@redhat.com>
289- fix option parsing in lookup_multi (I think)
290- fix multi option handling in our hacked-up init script (reported by Thiago
291  Bartolomei on the autofs mailing list)
292
293* Wed Dec  6 2000 Nalin Dahyabhai <nalin@redhat.com>
294- update to 3.1.7
295- add the man pages back in (fell out in 3.1.6)
296
297* Tue Nov 28 2000 Nalin Dahyabhai <nalin@redhat.com>
298- don't require /etc/auto.master to be there to start
299
300* Mon Nov 27 2000 Nalin Dahyabhai <nalin@redhat.com>
301- update to 3.1.6
302- disable hesiod support because the new bind-devel doesn't include it
303- try to use nsswitch.conf for getting the contents of auto.master
304- only convert YP map names auto_home and auto_mnt
305
306* Fri Sep  8 2000 Nalin Dahyabhai <nalin@redhat.com>
307- add -lresolv to build properly with OpenLDAP 2
308
309* Wed Aug 23 2000 Nalin Dahyabhai <nalin@redhat.com>
310- convert YP map names that start with "auto_" to "auto." (#16753)
311
312* Wed Aug 16 2000 Nalin Dahyabhai <nalin@redhat.com>
313- add an extra pause after the initial shutdown attempt
314
315* Fri Aug 11 2000 Nalin Dahyabhai <nalin@redhat.com>
316- patch init script to not shut down --submount mounts on reload
317- remove temporary files again during reload
318
319* Thu Aug 10 2000 Nalin Dahyabhai <nalin@redhat.com>
320- revert to 3.1.5
321- add 3.1.6pre1 patch to handle LDAP maps
322- add Epoch: to upgrade from Raw Hide or Pinstripe
323- update to 3.1.6pre2
324
325* Fri Aug  4 2000 Nalin Dahyabhai <nalin@redhat.com>
326- work around kernel insmod concurrency problem (#14972) by loading the module
327  at start-time
328
329* Wed Aug  2 2000 Nalin Dahyabhai <nalin@redhat.com>
330- fix duplicate detection for false matches (e.g. "/user" == "/users") (#15183)
331
332* Mon Aug  1 2000 Nalin Dahyabhai <nalin@redhat.com>
333- merge ldap subpackage back into the main one and Obsolete: it
334- clean up build warnings
335- fix errors automounting ext2 filesystems due to uninitialized option string
336
337* Sat Jul 15 2000 Bill Nottingham <notting@redhat.com>
338- move initscript back
339
340* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
341- automatic rebuild
342
343* Mon Jul 10 2000 Nalin Dahyabhai <nalin@redhat.com>
344- move the init script to the right place
345
346* Fri Jul  7 2000 Nalin Dahyabhai <nalin@redhat.com>
347- add /net directory to the package
348
349* Thu Jul  6 2000 Nalin Dahyabhai <nalin@redhat.com>
350- do manual unmounting in shutdown script
351- change initscripts prereq to /etc/init.d
352- move autoconf invocation to setup section
353
354* Wed Jul  5 2000 Nalin Dahyabhai <nalin@redhat.com>
355- move condrestart to postun
356- make condrestart check the right file to determine if already running
357
358* Wed Jul  5 2000 Florian La Roche <Florian.LaRoche@redhat.com>
359- ignore errors in post script
360
361* Tue Jul  4 2000 Matt Wilson <msw@redhat.com>
362- use full path to chkconfig
363- full *correct* path to chkconfig
364
365* Tue Jun 27 2000 Nalin Dahyabhai <nalin@redhat.com>
366- smoother starting/stopping on upgrades/removal
367
368* Thu Jun 15 2000 Nalin Dahyabhai <nalin@redhat.com>
369- be more aggressive when shutting down autofs
370- add condrestart support
371
372* Mon Jun  5 2000 Nalin Dahyabhai <nalin@redhat.com>
373- move man pages to %{_mandir}
374
375* Wed May 31 2000 Nalin Dahyabhai <nalin@redhat.com>
376- tweak argument parsing (bug #11801)
377
378* Mon May 22 2000 Nalin Dahyabhai <nalin@redhat.com>
379- rebuild in new build environment
380
381* Mon May  8 2000 Nalin Dahyabhai <nalin@redhat.com>
382- fix duplicate detection logic (duh!)
383
384* Tue May  2 2000 Nalin Dahyabhai <nalin@redhat.com>
385- add config: and processname: tags to init script
386
387* Sun Apr 30 2000 Nalin Dahyabhai <nalin@redhat.com>
388- fix shutdown logic (test -z $pid fails with multiple autofs daemons)
389
390* Wed Apr 26 2000 Nalin Dahyabhai <nalin@redhat.com>
391- split off autofs4 for testing & development
392- update patches for autofs4 for feeding back to autofs list
393- make auto.master a noreplace file
394
395* Mon Apr 17 2000 Nalin Dahyabhai <nalin@redhat.com>
396- split lookup_ldap into a subpackage (bug #10874)
397
398* Tue Apr 11 2000 Nalin Dahyabhai <nalin@redhat.com>
399- add LDAP map support, requires openldap
400- tweak init script patch to use fields 2+ for the map name instead of just 2
401
402* Wed Apr 05 2000 Nalin Dahyabhai <nalin@redhat.com>
403- fix bug #10402 by fixing the init script, hopefully for everybody
404- merge patches for the init script into a single patch to send to hpa
405- patch to build on 2.2 and late-series 2.3 kernels
406
407* Tue Feb 29 2000 Nalin Dahyabhai <nalin@redhat.com>
408- enable hesiod support over libbind
409
410* Mon Feb 28 2000 Nalin Dahyabhai <nalin@redhat.com>
411- fix init script bug when startup failed
412- fix option passing in init script
413
414* Sun Feb 13 2000 Nalin Dahyabhai <nalin@redhat.com>
415- make autofs start after ypbind by moving start priority 18, stop to 82
416- make sure that calls to "ps aux" include "www" to avoid snippage
417
418* Wed Feb  2 2000 Nalin Dahyabhai <nalin@redhat.com>
419- make sure all the docs get packaged
420- make init script do status messages like others
421- add "nosuid,nodev" to options for /misc/cd
422- switch to using INSTALLROOT during make install
423
424* Fri Jan 21 2000 Nalin Dahyabhai <nalin@redhat.com>
425- update to 3.1.4
426
427* Mon Sep 20 1999 Cristian Gafton <gafton@redhat.com>
428- use ps axw instead of ps ax in the init script
429
430* Fri Sep 10 1999 Bill Nottingham <notting@redhat.com>
431- chkconfig --del in %preun, not %postun
432
433* Tue Sep 07 1999 Cristian Gafton <gafton@redhat.com>
434- add patch from HJLu to handle NIS auto.master better
435
436* Wed Aug 25 1999 Cristian Gafton <gafton@redhat.com>
437- fix bug #4708
438
439* Sat Aug 21 1999 Bill Nottingham <notting@redhat.com>
440- fix perms on /usr/lib/autofs/*
441- add support for specifying maptype in auto.master
442
443* Fri Aug 13 1999 Cristian Gafton <gafton@redhat.com>
444- add patch from rth to avoid an infinite loop
445
446* Wed Apr 28 1999 Cristian Gafton <gafton@redhat.com>
447- use "autofs" instead of "automount" for /var/lock/subsys lock file
448
449* Fri Apr 09 1999 Cristian Gafton <gafton@redhat.com>
450- enahanced initscript to try to load maps over NIS
451- changed the mount point back to misc (there is a reason we leave /mnt
452  alone)
453- patched back autofs.misc to the version shipped on 5.2 to avoid replacing
454  yet one more config file for those who upgrade
455
456* Wed Mar 24 1999 Preston Brown <pbrown@redhat.com>
457- upgrade to 3.1.3, fixing smbfs stuff and other things
458- changed mountpoint from /misc to /mnt
459
460* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
461- auto rebuild in the new build environment (release 10)
462
463* Mon Feb  8 1999 Bill Nottingham <notting@redhat.com>
464- build for kernel-2.2/glibc2.1
465
466* Tue Oct  6 1998 Bill Nottingham <notting@redhat.com>
467- fix bash2 breakage in init script
468
469* Sun Aug 23 1998 Jeff Johnson <jbj@redhat.com>
470- typo in man page.
471
472* Mon Jul 20 1998 Jeff Johnson <jbj@redhat.com>
473- added sparc to ExclusiveArch.
474
475* Thu May 07 1998 Prospector System <bugs@redhat.com>
476- translations modified for de, fr, tr
477
478* Thu Apr 30 1998 Cristian Gafton <gafton@redhat.com>
479- updated to 3.1.1
480
481* Wed Apr 22 1998 Michael K. Johnson <johnsonm@redhat.com>
482- enhanced initscripts
483
484* Fri Dec 05 1997 Michael K. Johnson <johnsonm@redhat.com>
485- Link with -lnsl for glibc compliance.
486
487* Thu Oct 23 1997 Michael K. Johnson <johnsonm@redhat.com>
488- exclusivearch for i386 for now, since our kernel packages on
489  other platforms don't include autofs yet.
490- improvements to initscripts.
491
492* Thu Oct 16 1997 Michael K. Johnson <johnsonm@redhat.com>
493- Built package from 0.3.14 for 5.0
Note: See TracBrowser for help on using the repository browser.