source: projects/specs/trunk/a/autoconf213/autoconf213-vl.spec @ 521

Revision 521, 7.5 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: A GNU tool for automatically configuring source code.
2Summary(ja): ソースコードを自動的に設定するための GNU ツール
3Name: autoconf213
4Version: 2.13
5Release: 6%{?_dist_release}
6License: GPL
7Group: Development/Tools
8URL: http://www.gnu.org/software/autoconf/
9Source0: ftp://prep.ai.mit.edu/pub/gnu/autoconf/autoconf-%{version}.tar.gz
10Source1: filter-requires-%{name}.sh
11Patch0: autoconf-2.12-race.patch
12Patch1: autoconf-2.13-mawk.patch
13Patch2: autoconf-2.13-notmp.patch
14Patch3: autoconf-2.13-c++exit.patch
15Patch4: autoconf-2.13-headers.patch
16Patch5: autoconf-2.13-autoscan.patch
17Patch6: autoconf-2.13-exit.patch
18Patch7: autoconf-2.13-wait3test.patch
19Patch8: autoconf-2.13-make-defs-62361.patch
20Patch9: autoconf-2.13-versioning.patch
21#Prereq: /sbin/install-info
22Requires: gawk, m4, perl, coreutils
23BuildArchitectures: noarch
24BuildRoot: %{_tmppath}/%{name}-%{version}-root
25
26%define __find_requires %{SOURCE1}
27
28%description
29GNU's Autoconf is a tool for configuring source code and Makefiles.
30Using Autoconf, programmers can create portable and configurable
31packages, since the person building the package is allowed to specify
32various configuration options.
33
34You should install Autoconf if you are developing software and you
35would like to use it to create shell scripts that will configure your
36source code packages. If you are installing Autoconf, you will also
37need to install the GNU m4 package.
38
39Note that the Autoconf package is not required for the end-user who
40may be configuring software with an Autoconf-generated script;
41Autoconf is only required for the generation of the scripts, not their
42use.
43
44%description -l ja
45GNU autoconf はソースコードと Makefile を自動的に設定する GNU ツール
46です.Autoconf を使えば,プログラマは移植や設定が容易なパッケージを
47作ることができます.そのため,パッケージ作成者はさまざまな設定
48オプションを指定できます。
49
50ソフトウェアを開発していてソースコードパッケージを設定するシェル
51スクリプトを生成したいとお考えなら,Autoconf をインストールしてください.
52Autoconf をインストールするためには GNU m4 パッケージもインストールする
53必要があります.
54
55Autoconf が生成したスクリプトを使ってソフトウェアを設定するかもしれない
56エンドユーザには Autoconf パッケージが必要ないことに注目してください.
57Autoconf が必要になるのはスクリプトを生成するときのみで,使うときには
58必要ありません.
59
60%prep
61%setup -q -n autoconf-%{version}
62%patch0 -p1
63%patch1 -p1
64%patch2 -p1
65%patch3 -p1
66%patch4 -p1
67%patch5 -p1
68%patch6 -p1
69%patch7 -p1
70%patch8 -p1
71%patch9 -p1 -b .version
72
73
74%build
75%configure --program-suffix=-%{version}
76make
77
78%install
79rm -rf ${RPM_BUILD_ROOT}
80#mkdir -p ${RPM_BUILD_ROOT}%{_infodir}
81%makeinstall
82
83mv ${RPM_BUILD_ROOT}%{_infodir}/autoconf.info ${RPM_BUILD_ROOT}%{_infodir}/%{name}.info
84
85# We don't want to include the standards.info stuff in the package,
86# because it comes from binutils...
87rm -f ${RPM_BUILD_ROOT}%{_infodir}/standards*
88
89gzip -9nf ${RPM_BUILD_ROOT}%{_infodir}/*
90
91cp install-sh ${RPM_BUILD_ROOT}%{_datadir}/autoconf
92
93
94%clean
95rm -rf ${RPM_BUILD_ROOT}
96
97
98#%post
99#/sbin/install-info %{_infodir}/autoconf.info.gz %{_infodir}/dir
100
101
102#%preun
103#if [ "$1" = 0 ]; then
104#    /sbin/install-info --del %{_infodir}/autoconf.info.gz %{_infodir}/dir
105#fi
106
107%files
108%defattr(-,root,root)
109%doc AUTHORS COPYING NEWS README TODO
110%{_bindir}/*
111%{_infodir}/*.info*
112%{_datadir}/autoconf-%{version}
113
114
115%changelog
116* Thu Oct 09 2008 Shu KONNO <owa@bg.wakwak.com> 2.13-6
117- spec in utf-8
118
119* Mon Apr 28 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.13-5
120- rebuilt with perl-5.10.0-1
121- added Source1 (for perl(find.pl))
122
123* Thu Dec 14 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.13-4vl2
124- s/Copyright/License/
125- added Japanese summary and description (copied from autoconf)
126
127* Sun Dec 08 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.13-4vl1
128- based on 2.13-4 from Rawhide and built for Vine linux
129
130* Fri Jun 28 2002 Jens Petersen <petersen@redhat.com> 2.13-4
131- update url (#66840)
132- added doc files
133
134* Fri Jun 21 2002 Tim Powers <timp@redhat.com> 2.13-3
135- automated rebuild
136
137* Thu May 23 2002 Tim Powers <timp@redhat.com> 2.13-2
138- automated rebuild
139
140* Wed May 15 2002 Jens Petersen <petersen@redhat.com> 2.13-1
141- new package based on autoconf-2.13-17
142- don't make unversioned bindir symlinks
143- version datadir
144- version info filename, but don't install-info it
145- update AC_OUTPUT_MAKE_DEFS to fix problem with c++exit patch (#62361)
146
147* Wed Mar 27 2002 Jens Petersen <petersen@redhat.com> 2.13-17
148- add URL
149
150* Wed Feb 27 2002 Jens Petersen <petersen@redhat.com> 2.13-16
151- add version suffix to bindir files and symlink them to their
152unversioned names
153
154* Mon Feb 25 2002 Elliot Lee <sopwith@redhat.com> 2.13-15
155- Add wait3test.patch to make sure that the child process actually does
156something that the kernel will take note of. Fixes the failing wait3 test
157that was worked around in time-1.7-15.
158
159* Mon Aug  6 2001 Tim Powers <timp@redhat.com>
160- rebuilt to fix bug #50761
161
162* Thu Jul 26 2001 Than Ngo <than@redhat.com>
163- add patch to fix exit status
164
165* Tue Jul 10 2001 Jens Petersen <petersen@redhat.com>
166- add patch to include various standard C headers as needed
167  by various autoconf tests (#19114)
168- add patch to autoscan.pl to get a better choice of init
169  file (#42071), to test for CPP after CC (#42072) and to
170  detect C++ source and g++ (#42073).
171
172* Tue Jun 26 2001 Jens Petersen <petersen@redhat.com>
173- Add a back-port of _AC_PROG_CXX_EXIT_DECLARATION
174  from version 2.50 to make detection of C++ exit()
175  declaration prototype platform independent.  The check is
176  done in AC_PROG_CXX with the result stored in "confdefs.h".
177  The exit() prototype in AC_TRY_RUN_NATIVE is no longer needed.
178  (fixes #18829)
179
180* Wed Nov 29 2000 Bernhard Rosenkraenzer <bero@redhat.com>
181- Fix up interoperability with glibc 2.2 and gcc 2.96:
182  AC_TRY_RUN_NATIVE in C++ mode added a prototype for exit() to
183  the test code without throwing an exception, causing a conflict
184  with stdlib.h --> AC_TRY_RUN_NATIVE for C++ code including stdlib.h
185  always failed, returning wrong results
186
187* Fri Jul 21 2000 Nalin Dahyabhai <nalin@redhat.com>
188- add textutils as a dependency (#14439)
189
190* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
191- automatic rebuild
192
193* Mon Jun  5 2000 Jeff Johnson <jbj@redhat.com>
194- FHS packaging.
195
196* Sun Mar 26 2000 Florian La Roche <Florian.LaRoche@redhat.com>
197- fix preun
198
199* Fri Mar 26 1999 Cristian Gafton <gafton@redhat.com>
200- add patch to help autoconf clean after itself and not leave /tmp clobbered
201  with acin.* and acout.* files (can you say annoying?)
202
203* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
204- auto rebuild in the new build environment (release 4)
205- use gawk, not mawk
206
207* Thu Mar 18 1999 Preston Brown <pbrown@redhat.com>
208- moved /usr/lib/autoconf to /usr/share/autoconf (with automake)
209
210* Wed Feb 24 1999 Preston Brown <pbrown@redhat.com>
211- Injected new description and group.
212
213* Tue Jan 12 1999 Jeff Johnson <jbj@redhat.com>
214- update to 2.13.
215
216* Fri Dec 18 1998 Cristian Gafton <gafton@redhat.com>
217- build against glibc 2.1
218
219* Mon Oct 05 1998 Cristian Gafton <gafton@redhat.com>
220- requires perl
221
222* Thu Aug 27 1998 Cristian Gafton <gafton@redhat.com>
223- patch for fixing /tmp race conditions
224
225* Sun Oct 19 1997 Erik Troan <ewt@redhat.com>
226- spec file cleanups
227- made a noarch package
228- uses autoconf
229- uses install-info
230
231* Thu Jul 17 1997 Erik Troan <ewt@redhat.com>
232- built with glibc
Note: See TracBrowser for help on using the repository browser.