source: projects/specs/trunk/a/auto-install/auto-install-vl.spec @ 9515

Revision 9515, 2.7 KB checked in by inagaki, 9 years ago (diff)

2015-04-17 Ryoichi INAGAKI <ryo1@…>

  • auto-install, js2-mode, lua-mode, migemo, php-mode, po-mode: updated


Line 
1%define _noVersionedDependencies        1
2%define prereq_ge()  %(LC_ALL="C" rpm -q --queryformat 'Requires(pre):%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
3%define emacsen_pkgdir /usr/lib/emacsen-common/packages
4%define origname auto-install
5%define origver  1.58
6
7Name:            %{origname}
8Version:         %{origver}
9Release:         1%{?_dist_release}
10Summary:         Auto install elisp file
11Summary(ja):     Emacs Lisp ファイルを自動的にインストールするツール
12
13Source0:         http://www.emacswiki.org/emacs/download/auto-install.el
14Source1:         %{origname}-install.sh
15Source2:         %{origname}-remove.sh
16Source3:         vine-default-%{origname}.el
17Source4:         %{origname}-init.el
18Source5:         http://www.gnu.org/licenses/gpl-3.0.txt
19
20License:         GPLv3+
21Group:           Applications/Editors/Emacs
22URL:             http://www.emacswiki.org/emacs/auto-install.el
23
24BuildRoot:       %{_tmppath}/%{name}-%{version}-root
25BuildArch:       noarch
26
27Requires(post):  emacsen
28Requires(preun): emacsen
29%prereq_ge       emacsen-common
30Conflicts:       flim < 1.14.9-2
31
32Distribution:    Vine Linux
33Vendor:          Project Vine
34Packager:        iwaim
35
36%description
37Auto install elisp file.
38
39%prep
40%setup -q -T -c %{origname}-%{origver}
41%{__cp} -a %{SOURCE5} .
42
43%build
44
45%install
46[ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
47[ "%{buildroot}" != "/" ] && mkdir -p %{buildroot}
48
49mkdir -p %{buildroot}%{_datadir}/emacs/site-lisp/%{origname}/packages
50mkdir -p %{buildroot}%{emacsen_pkgdir}/install
51mkdir -p %{buildroot}%{emacsen_pkgdir}/remove
52
53#
54# install el files
55#
56
57cp -p %{SOURCE0} %{SOURCE3} %{SOURCE4} %{buildroot}%{_datadir}/emacs/site-lisp/%{origname}
58
59
60#
61# install script (bytecompile el and install elc , remove)
62#
63
64%_installemacsenscript %{origname} %{SOURCE1}
65
66%_removeemacsenscript  %{origname} %{SOURCE2}
67
68
69%clean
70[ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
71
72%post
73#
74# bytecompile and install
75#
76if [ "$1" = 2 ]; then
77
78%_emacsenPackageRemove %{origname}
79
80fi
81
82%_addemacsenlist %{origname}
83
84%_emacsenPackageInstall %{origname}
85
86
87%preun
88if [ "$1" = 0 ]; then
89
90%_emacsenPackageRemove %{origname}
91
92%_removeemacsenlist %{origname}
93
94fi
95
96
97%files
98%defattr(-,root,root)
99%doc gpl-3.0.txt
100%{_datadir}/emacs/site-lisp/%{origname}
101%{emacsen_pkgdir}/install/%{origname}
102%{emacsen_pkgdir}/remove/%{origname}
103
104
105%changelog
106* Fri Apr 17 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.58-1
107- updated to 1.58
108
109* Tue Feb 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.24-3
110- rebuild with Vine6 environment
111
112* Sun Mar  7 2010 IWAI, Masaharu <iwai@alib.jp> 0.1.24-2
113- update Conflicts flim version
114
115* Tue Feb 23 2010 IWAI, Masaharu <iwai@alib.jp> 0.1.24-1
116- first release for Vine Linux
Note: See TracBrowser for help on using the repository browser.