source: projects/specs/trunk/a/aumix/aumix-vl.spec @ 521

Revision 521, 7.0 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define      version 2.6.1
2%define      release 6%{?_dist_release}
3
4Summary:     An ncurses-based audio mixer.
5Summary(ja): ncurses ベースのオーディオミキサ
6Name:        aumix
7Version:     %{version}
8Release:     %{release}
9License:     GPL
10Group:       Applications/Multimedia
11Source:      http://www.jpj.net/~trevor/aumix/%{name}-%{version}.tar.gz
12Source10:    aumixrc.default
13Patch0:      aumix-2.6.1-interactive_c.patch
14Requires:    initscripts >= 4.42
15BuildRoot:   %{_tmppath}/%{name}-%{version}-root
16Obsoletes:   aumix-X11
17
18%description
19Aumix is a tty-based, interactive method of controlling a sound card
20mixer. It lets you adjust the input levels from the CD, microphone,
21and board synthesizers, as well as the output volume. Aumix can
22adjust audio mixers from the command line, from a script, or
23interactively at the console or terminal with an
24ncurses-based interface.
25
26Install aumix if you need to control an audio mixer.  If you want to use
27Aumix's GUI, you'll need to install ncurses and gpm for mouse support.
28
29%description -l ja
30Aumix は tty ベースでインタラクティブにサウンドカードのミキシングを操作
31するプログラムです.これを使うことにより CD,マイクロフォン,オンボード
32シンセサイザの入力レベルを調節することが出来ますし,出力レベルに関しても
33操作することが出来ます.
34Aumix によるオーディオミキサの操作は,コマンドライン,スクリプト,コンソール
35ターミナル上の ncurses ベースのインタフェースを用いた対話形式等,様々な
36方法で行うことが出来ます.
37
38%prep
39%setup -q
40%patch0 -p0 -b .interactive_c
41
42%build
43%configure --prefix=/ --with-alsa \
44        --without-ncurses --without-gtk \
45        --without-gpm
46make
47mv src/aumix ./aumix-minimal
48make distclean
49%configure --with-alsa \
50        --without-gtk \
51        --without-gpm
52make
53
54
55%install
56rm -rf ${RPM_BUILD_ROOT}
57%makeinstall
58make prefix=${RPM_BUILD_ROOT}/usr install -C po
59mkdir -p ${RPM_BUILD_ROOT}/bin
60install -c -m755 aumix-minimal ${RPM_BUILD_ROOT}/bin
61strip -R .comment \
62        ${RPM_BUILD_ROOT}/bin/aumix-minimal \
63        ${RPM_BUILD_ROOT}/usr/bin/aumix
64
65install -d ${RPM_BUILD_ROOT}%{_sysconfdir}
66install -m644 %{SOURCE10} ${RPM_BUILD_ROOT}%{_sysconfdir}/.aumixrc
67
68%clean
69rm -rf ${RPM_BUILD_ROOT}
70
71
72%files
73%defattr(-,root,root)
74%doc README TODO NEWS ChangeLog
75/bin/aumix-minimal
76%config(noreplace) %{_sysconfdir}/.aumixrc
77%{_bindir}/aumix
78%{_mandir}/man1/aumix.*
79%{_datadir}/aumix
80%{_datadir}/locale/*/*/aumix.mo
81
82%changelog
83* Sun Jul 12 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.1-6
84- drop X11 version
85  - remove X11 subpackage
86  - add Obsoletes: aumix-X11
87
88* Sat May 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.1-5
89- rebuild without gpm
90  - add --without-gpm to configure option
91
92* Fri May 29 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.6.1-4vl5
93- rebuilt with gpm-1.20.6
94
95* Wed Sep 10 2008 Shu KONNO <owa@bg.wakwak.com> 2.6.1-3vl5
96- applied new versioning policy, spec in utf-8
97- added aumix-2.6.1-interactive_c.patch
98
99* Wed Oct 18 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.6.1-2vl6
100- modified SOURCE10 (100% volume is too lousy on some environment)
101
102* Wed Sep 06 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.1-2vl5
103- use /etc/.aumixrc for default setting instead of /etc/aumixrc
104
105* Wed Sep 06 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.1-2vl4
106- use License: instead of Copyright:
107- new upstream source
108- add default aumixrc
109
110* Mon Jun 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
111- 2.6.1-2vl3
112- rebuilt for VineSeed (with new %%{mandir} definition)
113- added Japanese summary and description
114
115* Sat Dec 09 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
116- 2.6.1-2vl2
117- rebuilt with ncurses >= 5.0 (and with gpm rebuilt with ncurses5)
118
119* Sun Nov 19 2000 Satoshi MACHINO <machino@vinelinux.org> 2.6.1-2vl1
120- build on Vine Linux with gcc-2.95.3
121
122
123* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
124- automatic rebuild
125
126* Tue Jun 27 2000 Preston Brown <pbrown@redhat.com>
127- make desktop entry a config file
128- 2.6.1
129- the nogtk patch has been rolled into the main distro, removed.
130
131* Thu Jun  8 2000 Bill Nottingham <notting@redhat.com>
132- FHS stuff
133
134* Mon May 22 2000 Bill Nottingham <notting@redhat.com>
135- make desktop link point to correct binary (#11413)
136
137* Wed Apr 13 2000 Bill Nottingham <notting@redhat.com>
138- 2.6
139
140* Wed Mar 29 2000 Bill Nottingham <notting@redhat.com>
141- 2.5
142
143* Wed Mar 22 2000 Bernhard Rosenkraenzer <bero@redhat.com>
144- 2.3
145- rebuild with current libncurses
146- fix up and re-enable aumix-X11, and move it to a separate package
147- add a .desktop file for aumix-X11
148
149* Mon Mar 13 2000 Bill Nottingham <notting@redhat.com>
150- update to 2.2
151
152* Thu Feb  3 2000 Bill Nottingham <notting@redhat.com>
153- handle compressed man pages
154
155* Mon Dec 20 1999 Bill Nottingham <notting@redhat.com>
156- update to 1.30.1
157
158* Mon Nov 29 1999 Bill Nottingham <notting@redhat.com>
159- update to 1.28
160
161* Thu Nov  4 1999 Bill Nottingham <notting@redhat.com>
162- update to 1.26
163
164* Mon Oct 18 1999 Bill Nottingham <notting@redhat.com>
165- update to 1.23.1
166
167* Mon Oct  4 1999 Bill Nottingham <notting@redhat.com>
168- update to 1.23
169
170* Mon Sep 20 1999 Bill Nottingham <notting@redhat.com>
171- oops, fix regular aumix
172
173* Fri Sep 17 1999 Bill Nottingham <notting@redhat.com>
174- add stripped down version in /bin
175- kill sound.init (in initscripts now)
176
177* Fri Sep 10 1999 Bill Nottingham <notting@redhat.com>
178- chkconfig --del in %preun, not %postun
179
180* Mon Aug 16 1999 Bill Nottingham <notting@redhat.com>
181- initscript munging
182
183* Wed Jun 23 1999 Bill Nottingham <notting@redhat.com>
184- move initscript from rhsound to here. Woohoo - we got rid of a package! ;)
185
186* Tue Jun 22 1999 Bill Nottingham <notting@redhat.com>
187- 1.22.1
188
189* Mon Jun 14 1999 Bill Nottingham <notting@redhat.com>
190- 1.22
191
192* Sat May 21 1999 Bill Nottingham <notting@redhat.com>
193- 1.18.4
194
195* Thu May 06 1999 Bill Nottingham <notting@redhat.com>
196- update to 1.18.3
197
198* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
199- auto rebuild in the new build environment (release 2)
200
201* Wed Feb 24 1999 Bill Nottingham <notting@redhat.com>
202- update to 1.18.2
203
204* Mon Feb 22 1999 Bill Nottingham <notting@redhat.com>
205- update to 1.18.1
206
207* Mon Feb  8 1999 Bill Nottingham <notting@redhat.com>
208- update to 1.17
209
210* Mon Feb  1 1999 Bill Nottingham <notting@redhat.com>
211- update to 1.15
212
213* Fri Dec 18 1998 Bill Nottingham <notting@redhat.com>
214- update to 1.14
215
216* Sat Oct 10 1998 Cristian Gafton <gafton@redhat.com>
217- strip binary
218
219* Fri Oct  2 1998 Bill Nottingham <notting@redhat.com>
220- updated to 1.13
221
222* Fri Aug 28 1998 Bill Nottingham <notting@redhat.com>
223- updated to 1.12
224
225* Mon Aug 17 1998 Bill Nottingham <notting@redhat.com>
226- updated to 1.11
227
228* Tue May 05 1998 Prospector System <bugs@redhat.com>
229- translations modified for de, fr, tr
230
231* Thu Apr 09 1998 Cristian Gafton <gafton@redhat.com>
232- updated to 1.8
233
234* Tue Oct 21 1997 Otto Hammersmith <otto@redhat.com>
235- fixed source url
236- updated version
237
238* Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
239- built with glibc
240
241* Thu Mar 20 1997 Michael Fulbright <msf@redhat.com>
242- Updated to v. 1.6.1.
243
Note: See TracBrowser for help on using the repository browser.