source: projects/specs/trunk/a/audiofile/audiofile-vl.spec @ 521

Revision 521, 4.7 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary:        A library for accessing various audio file formats
4Summary(ja):    さまざまなオーディオフォーマットを扱うライブラリ
5Name:           audiofile
6Version:        0.2.6
7Release: 2%{?_dist_release}
8License:        LGPL
9Group:          System Environment/Libraries
10Source:         ftp://oss.sgi.com/projects/download/%{name}-%{version}.tar.bz2
11URL:            http://www.68k.org/~michael/audiofile/
12BuildRoot:      %{_tmppath}/%{name}-%{version}-root
13
14%description
15Library to handle various audio file formats.
16Used by the esound daemon.
17
18%description -l ja
19さまざまなオーディオフォーマットを扱うライブラリです.
20esound デーモンで使用します.
21
22
23%package -n compat32-%{name}
24Summary:        A library for accessing various audio file formats
25Summary(ja):    さまざまなオーディオフォーマットを扱うライブラリ
26Group:          System Environment/Libraries
27Requires:       %{name} = %{version}
28
29%description -n compat32-%{name}
30Library to handle various audio file formats.
31Used by the esound daemon.
32
33%description -n compat32-%{name} -l ja
34さまざまなオーディオフォーマットを扱うライブラリです.
35esound デーモンで使用します.
36
37
38%package devel
39Summary:        Libraries, includes, etc to develop audiofile applications
40Summary(ja):    オーディオファイルアプリケーションの開発用ライブラリ
41Group:          Development/Libraries
42Requires:       %{name} = %{version}
43Requires:       pkgconfig
44
45%description devel
46Libraries, include files, etc you can use to develop audiofile applications.
47
48%description devel -l ja
49オーディオファイルアプリケーションの開発に使用できる,
50ライブラリやヘッダーファイルなどです.
51
52
53%package -n compat32-%{name}-devel
54Summary:        Libraries, includes, etc to develop audiofile applications
55Summary(ja):    オーディオファイルアプリケーションの開発用ライブラリ
56Group:          Development/Libraries
57Requires:       %{name}-devel    = %{version}
58Requires:       compat32-%{name} = %{version}
59
60%description -n compat32-%{name}-devel
61Libraries, include files, etc you can use to develop audiofile applications.
62
63%description -n compat32-%{name}-devel -l ja
64オーディオファイルアプリケーションの開発に使用できる,
65ライブラリやヘッダーファイルなどです.
66
67
68%prep
69%setup -q
70
71%build
72%configure --enable-largefile
73make
74
75
76%install
77[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
78mkdir -p $RPM_BUILD_ROOT
79
80%makeinstall
81rm -f $RPM_BUILD_ROOT%{_libdir}/*.{a,la}
82
83%clean
84[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
85
86
87%post -p /sbin/ldconfig
88
89%postun -p /sbin/ldconfig
90
91%if %{build_compat32}
92%post -n compat32-%{name} -p /sbin/ldconfig
93
94%postun -n compat32-%{name} -p /sbin/ldconfig
95%endif
96
97
98%files
99%defattr(-, root, root)
100%doc ACKNOWLEDGEMENTS AUTHORS COPYING* ChangeLog INSTALL NEWS NOTES
101%doc README TODO docs
102%{_bindir}/sfconvert
103%{_bindir}/sfinfo
104%{_libdir}/lib*.so.*
105
106%files devel
107%defattr(-, root, root)
108%{_bindir}/audiofile-config
109%{_libdir}/pkgconfig/*.pc
110%{_libdir}/lib*.so
111%{_includedir}/*
112%{_datadir}/aclocal/*.m4
113
114
115%if %{build_compat32}
116%files -n compat32-%{name}
117%defattr(-, root, root)
118%{_libdir}/lib*.so.*
119
120%files -n compat32-%{name}-devel
121%defattr(-, root, root)
122%{_libdir}/pkgconfig/*.pc
123%{_libdir}/lib*.so
124%endif
125
126
127%changelog
128* Tue Mar 31 2009 Daisuke SUZUKI <daisuke@linux.or.jp>  0.2.6-2
129- spec in utf-8
130- remove static lib
131
132* Mon May 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.2.6-1
133- applied new versioning policy
134- removed *.la file from devel package
135- added %%post and %%postun section
136
137* Mon Mar 06 2006 NAKAMURA Kenta <kenta@c.csce.kyushu-u.ac.jp> 0.2.6-0vl3
138- added compat32-* packages for x86_64 architecture support
139
140* Thu Feb 02 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.2.6-0vl2
141- rebuild
142- update URL
143
144* Sat Oct 23 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.2.6-0vl1
145- new upstream release
146
147* Mon Sep 29 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.2.4-0vl1
148- new upstream release
149
150* Sun Sep 21 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.2.3-7vl2
151- add .la files to devel package
152
153* Thu Aug 21 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.2.3-7vl1
154- based on Rawhide 0.2.3-7
155- rebuild with new toolchains
156- fixed URL
157
158* Fri Mar 08 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.2.3-0vl1
159- updated to new upstream release
160
161* Fri Mar 23 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.2.1-0vl1
162- New upstream release.
163- Use rpmmacros.
164
165* Sun Nov 19 2000 Satoshi MACHINO <machino@vinelinux.org> 0.1.9-1vl4
166- build with gcc-2.95.3
167- removed strip
168
169* Sun Jul 23 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
170- libtoolize
171
172* Fri Sep 17 1999 Kazuhito Nishi <nishi@imasy.or.jp>
173- First try at a spec file for Vine
Note: See TracBrowser for help on using the repository browser.