source: projects/specs/trunk/a/audacious/audacious-vl.spec @ 521

Revision 521, 8.1 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define _aud_ver        2.1
2#%%define extraver alpha5
3
4Summary:        Audacious - a versatile and handy multi platform media player
5Summary(ja):    Audacious - 多くのフォーマットに対応した便利なメディアプレイヤー
6Name:           audacious
7Version:        2.1
8Release:        2%{?_dist_release}
9License:        GPLv3
10Group:          Applications/Multimedia
11URL:            http://audacious-media-player.org/
12Source:         http://distfiles.atheme.org/%{name}-%{version}%{?extraver:-%extraver}.tgz
13Source1:        audacious2.desktop
14#Source2:       audacious-1.3.0-ja.po
15#Patch1:        audacious-1.3.0-alpha3-use-xfont.patch
16BuildRoot:      %{_tmppath}/%{name}-%{version}-root
17
18BuildRequires:  glib2-devel
19BuildRequires:  gtk2-devel
20BuildRequires:  libglade2-devel
21BuildRequires:  libmowgli-devel
22BuildRequires:  mcs-devel
23BuildRequires:  dbus-devel
24BuildRequires:  dbus-glib-devel
25BuildRequires:  libSM-devel
26BuildRequires:  libsamplerate-devel
27BuildRequires:  oniguruma-devel
28
29Requires:       %{name}-libs = %{version}-%{release}
30Requires:       audacious-plugins >= %{_aud_ver}
31
32Requires(post):   /sbin/ldconfig, desktop-file-utils
33Requires(postun): /sbin/ldconfig, desktop-file-utils
34
35Vendor:         Project Vine
36Distribution:   Vine Linux
37
38%description
39Audacious is a media player that currently uses a skinned user
40interface based on Winamp 2.x skins. It is based on BMP.
41
42%package libs
43Summary: Library files for the Audacious media player
44Group: System Environment/Libraries
45
46%description libs
47Library files for the Audacious media player.
48
49%package devel
50Summary:        Development files for Audacious
51Summary(ja):    Audacious の開発用ファイル
52Group:          Development/Libraries
53Requires:       %{name}-libs = %{version}-%{release}
54Requires:       gtk2-devel >= %{_gtk2_ver}
55Requires:       glib2-devel >= %{_glib2_ver}
56Requires:       mcs-devel >= %{_libmcs_ver}
57Requires:       dbus-devel
58Requires:       dbus-glib-devel
59Requires:       libsamplerate-devel
60
61%description devel
62This package contains header files required to develop plugins for
63Audacious.
64
65%description -l ja devel
66このパッケージには、Audacious のプラグインを開発するために必要なヘッダ
67ファイルが含まれています。
68
69%prep
70%setup -q -n %{name}-%{version}%{?extraver:-%extraver}
71
72# update ja.po
73#__cp -f %{SOURCE2} po/ja.po
74
75%build
76%configure \
77        --enable-chardet                \
78        --enable-samplerate             \
79        --with-regexlib=oniguruma
80
81# update audacious.pot & ja.gmo
82#( cd po ;
83#  %__make %{_smp_mflags} VERBOSE=1 update-po )
84
85make %{?_smp_mflags} VERBOSE=1
86
87%install
88rm -rf $RPM_BUILD_ROOT
89make DESTDIR=$RPM_BUILD_ROOT install
90
91%find_lang %{name}
92
93%__mkdir_p %{buildroot}%{_libdir}/audacious/Container
94%__mkdir_p %{buildroot}%{_libdir}/audacious/Effect
95%__mkdir_p %{buildroot}%{_libdir}/audacious/General
96%__mkdir_p %{buildroot}%{_libdir}/audacious/Input
97%__mkdir_p %{buildroot}%{_libdir}/audacious/Output
98%__mkdir_p %{buildroot}%{_libdir}/audacious/Transport
99%__mkdir_p %{buildroot}%{_libdir}/audacious/Visualization
100
101install -p -m644 %{SOURCE1} %{buildroot}%{_datadir}/applications
102
103mkdir -p $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps
104mv $RPM_BUILD_ROOT%{_datadir}/pixmaps/audacious2.png $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps
105
106%clean
107rm -rf $RPM_BUILD_ROOT
108
109%post
110%{_bindir}/update-desktop-database %{_datadir}/applications >& /dev/null ||:
111touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
112
113%postun
114%{_bindir}/update-desktop-database %{_datadir}/applications >& /dev/null ||:
115if [ $1 -eq 0 ] ; then
116    touch --no-create %{_datadir}/icons/hicolor &>/dev/null
117    gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
118fi
119
120%posttrans
121gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
122
123%post libs -p /sbin/ldconfig
124
125%postun libs -p /sbin/ldconfig
126
127%files -f %{name}.lang
128%defattr(-,root,root,-)
129%doc AUTHORS COPYING NEWS* README* TODO*
130%{_bindir}/audacious2
131%{_bindir}/audtool2
132%{_libdir}/audacious
133%{_datadir}/audacious
134%{_datadir}/applications/*.desktop
135%{_datadir}/icons/hicolor/48x48/apps/*
136%{_mandir}/man1/audacious2.1*
137%{_mandir}/man1/audtool2.1*
138
139%files libs
140%defattr(-,root,root,-)
141%{_libdir}/lib*.so.*
142
143%files devel
144%defattr(-,root,root,-)
145%{_includedir}/audacious
146%{_includedir}/libSAD
147%{_includedir}/libaudcore
148%{_libdir}/*.so
149%{_libdir}/pkgconfig/*.pc
150
151%changelog
152* Thu Aug 13 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.1-2
153- added BuildRequires: libsamplerate-devel to devel package
154
155* Sun Aug  9 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.1-1
156- new upstream release
157
158* Sun Apr 26 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.5.1-5
159- rebuilt with libmowgli-0.7.0
160
161* Sat Apr  4 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.5.1-4
162- added BuildRequires: dbus-devel, dbus-glib-devel
163- added Requires: dbus-devel, dbus-glib-devel to devel package
164
165* Wed Mar 25 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.5.1-3
166- rebuilt again with oniguruma-5.9.1 (ppc)
167
168* Thu Mar 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.5.1-2vl5
169- rebuilt with oniguruma-5.9.1
170
171* Sat Dec  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.5.1-1vl5
172- new upstream release (dropped Patch1 and Source2)
173
174* Sun Sep 14 2008 Shu KONNO <owa@bg.wakwak.com> 1.3.2-1vl5
175- applied new versioning policy, spec in utf-8
176
177* Tue Sep 04 2007 KAZUKI SHIMURA <ksh753@y5.dion.ne.jp> 1.3.2-0vl3
178- update desktop file (source1)
179
180* Tue Aug 21 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.3.2-0vl2
181- add Requires: mcs-devel for audacious-devel subpackage
182
183* Fri May 18 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.2-0vl1
184- new upstream release
185- build with new environment/toolchain
186
187* Mon Mar 12 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.1-0vl1
188- new upstream release
189- drop '--disable-gconf' option from %%configure
190
191* Fri Mar 09 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.0-0vl1
192- new upstream release
193- update ja.po (source2)
194- add BuildRequires: mcs-devel, libsamplerate-devel
195
196* Wed Feb 21 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.0-0vl0.0alpha5
197- update to 1.3.0alpha5
198- update ja.po (source2)
199- drop obsolete playlist-set-utf8-name.patch (patch2)
200- add new file: libaudid3tag.so
201
202* Mon Feb 12 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.0-0vl0.0alpha4.1
203- add playlist-set-utf8-name.patch (patch2)
204  to use utf-8-converted filename as playlist title
205
206* Thu Feb 08 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.0-0vl0.0alpha4
207- update to 1.3.0alpha4
208- update ja.po (source2)
209- update URLs
210
211* Wed Jan 31 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.0-0vl0.0alpha3
212- update to 1.3.0alpha3
213- update ja.po (source2)
214- update use-xfont.patch (patch1)
215- fix typo
216
217* Sun Jan 21 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.0-0vl0.0alpha2.1
218- update ja.po (source2)
219
220* Sat Jan 13 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.0-0vl0.0alpha2
221- update to 1.3.0alpha2
222- use oniguruma regex library
223  - add BuildRequires: oniguruma-devel
224  - add '--with-regexlib=oniguruma' option to %%configure
225
226* Thu Nov 30 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.2-0vl2
227- add '--enable-chardet' option to %%configure again
228
229* Wed Nov 29 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.2-0vl1
230- new upstream release
231- update ja.po (source2)
232
233* Sun Aug 27 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.2-0vl1
234- new upstream release
235
236* Tue Aug 01 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.1-0vl2
237- oops, really update ja.po (source2)
238
239* Mon Jul 31 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.1-0vl1
240- new upstream release
241- make with 'VERBOSE=1'
242- drop obsolete POTFILES.in (source3)
243- make update-po before make
244  - 1.1.1 contains old version of audacious.pot...
245- update ja.po (source2)
246
247* Sat Jul 22 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.0-0vl2
248- overwrite POTFILES.in (source3)
249  - 1.1.0 contains old version of POTFILES.in
250- update ja.po (source2)
251
252* Sat Jul 22 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.0-0vl1
253- new upstream release
254- drop unneeded patch0 (was merged)
255- add '--enable-ipv6 --enable-chardet' to %%configure option
256- add BuildRequires: taglib-devel instead of id3lib-devel
257- update ja.po (source2)
258
259* Sun Jun 04 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.0-0vl2
260- add flac-filename-utf8.patch (patch0)
261      to convert filename on fileinfo box for FLAC files to UTF-8
262- add use-xfont.patch (patch1)
263      to disable 'Use Bitmap fonts if available' by default
264- add ja.po (source2)
265
266* Sat Jun 03 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.0-0vl1
267- initial build
Note: See TracBrowser for help on using the repository browser.