source: projects/specs/trunk/a/audacious/audacious-vl.spec @ 1158

Revision 1158, 8.2 KB checked in by inagaki, 14 years ago (diff)

updated: alien, audacious, audacious-plugins
NEW: libcddb, self-build-audacious-plugins-extra

Line 
1%define _aud_ver        2.3
2#define extraver alpha5
3
4Summary:        Audacious - a versatile and handy multi platform media player
5Summary(ja):    Audacious - 多くのフォーマットに対応した便利なメディアプレイヤー
6Name:           audacious
7Version:        2.3
8Release:        1%{?_dist_release}
9License:        GPLv3
10Group:          Applications/Multimedia
11URL:            http://audacious-media-player.org/
12Source:         http://distfiles.atheme.org/%{name}-%{version}%{?extraver:-%extraver}.tgz
13Source1:        audacious2.desktop
14#Source2:       audacious2-gtkui.desktop
15
16BuildRoot:      %{_tmppath}/%{name}-%{version}-root
17BuildRequires:  glib2-devel
18BuildRequires:  gtk2-devel
19BuildRequires:  libmowgli-devel
20BuildRequires:  mcs-devel
21BuildRequires:  dbus-devel
22BuildRequires:  dbus-glib-devel
23BuildRequires:  libSM-devel
24BuildRequires:  oniguruma-devel
25
26Requires:       %{name}-libs = %{version}-%{release}
27Requires:       audacious-plugins >= %{_aud_ver}
28
29Requires(post):   desktop-file-utils
30Requires(postun): desktop-file-utils
31
32Vendor:         Project Vine
33Distribution:   Vine Linux
34
35%description
36Audacious is a media player that currently uses a skinned user
37interface based on Winamp 2.x skins. It is based on BMP.
38
39%package libs
40Summary: Library files for the Audacious media player
41Group: System Environment/Libraries
42
43%description libs
44Library files for the Audacious media player.
45
46%package devel
47Summary:        Development files for Audacious
48Summary(ja):    Audacious の開発用ファイル
49Group:          Development/Libraries
50Requires:       %{name}-libs = %{version}-%{release}
51Requires:       glib2-devel >= 2.12.0
52Requires:       gtk2-devel >= 2.8.0
53Requires:       pango-devel >= 1.8.0
54Requires:       cairo-devel >= 1.2.4
55Requires:       libmowgli-devel >= 0.4.0
56Requires:       mcs-devel >= 0.7
57Requires:       dbus-devel >= 0.60
58Requires:       dbus-glib-devel >= 0.60
59
60%description devel
61This package contains header files required to develop plugins for
62Audacious.
63
64%description -l ja devel
65このパッケージには、Audacious のプラグインを開発するために必要なヘッダ
66ファイルが含まれています。
67
68%prep
69%setup -q -n %{name}-%{version}%{?extraver:-%extraver}
70
71%build
72%configure \
73        --enable-chardet                \
74        --with-regexlib=oniguruma
75
76make %{?_smp_mflags} VERBOSE=1
77
78%install
79rm -rf $RPM_BUILD_ROOT
80make DESTDIR=$RPM_BUILD_ROOT install
81
82%find_lang %{name}
83
84%__mkdir_p %{buildroot}%{_libdir}/audacious/Container
85%__mkdir_p %{buildroot}%{_libdir}/audacious/Effect
86%__mkdir_p %{buildroot}%{_libdir}/audacious/General
87%__mkdir_p %{buildroot}%{_libdir}/audacious/Input
88%__mkdir_p %{buildroot}%{_libdir}/audacious/Output
89%__mkdir_p %{buildroot}%{_libdir}/audacious/Transport
90%__mkdir_p %{buildroot}%{_libdir}/audacious/Visualization
91
92install -p -m644 %{SOURCE1} %{buildroot}%{_datadir}/applications
93rm -f $RPM_BUILD_ROOT%{_datadir}/applications/audacious2-gtkui.desktop
94#install -p -m644 %{SOURCE2} %{buildroot}%{_datadir}/applications
95
96mkdir -p $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps
97mv $RPM_BUILD_ROOT%{_datadir}/pixmaps/audacious2.png $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps
98
99# fixes symbolic link
100pushd $RPM_BUILD_ROOT%{_bindir}
101ln -sf audacious2 audacious
102ln -sf audtool2 audtool
103popd
104
105%clean
106rm -rf $RPM_BUILD_ROOT
107
108%post
109%{_bindir}/update-desktop-database %{_datadir}/applications >& /dev/null ||:
110touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
111
112%postun
113%{_bindir}/update-desktop-database %{_datadir}/applications >& /dev/null ||:
114if [ $1 -eq 0 ] ; then
115    touch --no-create %{_datadir}/icons/hicolor &>/dev/null
116    gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
117fi
118
119%posttrans
120gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
121
122%post libs -p /sbin/ldconfig
123
124%postun libs -p /sbin/ldconfig
125
126%files -f %{name}.lang
127%defattr(-,root,root,-)
128%doc AUTHORS COPYING NEWS* README*
129%{_bindir}/audacious*
130%{_bindir}/audtool*
131%{_libdir}/audacious
132%{_datadir}/audacious
133%{_datadir}/applications/*.desktop
134%{_datadir}/icons/hicolor/48x48/apps/*
135%{_mandir}/man1/audacious2.1*
136%{_mandir}/man1/audtool2.1*
137
138%files libs
139%defattr(-,root,root,-)
140%{_libdir}/lib*.so.*
141
142%files devel
143%defattr(-,root,root,-)
144%{_includedir}/audacious
145%{_includedir}/libaudcore
146%{_includedir}/libaudgui
147%{_includedir}/libaudtag
148%{_libdir}/*.so
149%{_libdir}/pkgconfig/*.pc
150
151%changelog
152* Sat May 29 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.3-1
153- new upstream release
154
155* Thu Aug 13 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.1-2
156- added BuildRequires: libsamplerate-devel to devel package
157
158* Sun Aug  9 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.1-1
159- new upstream release
160
161* Sun Apr 26 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.5.1-5
162- rebuilt with libmowgli-0.7.0
163
164* Sat Apr  4 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.5.1-4
165- added BuildRequires: dbus-devel, dbus-glib-devel
166- added Requires: dbus-devel, dbus-glib-devel to devel package
167
168* Wed Mar 25 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.5.1-3
169- rebuilt again with oniguruma-5.9.1 (ppc)
170
171* Thu Mar 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.5.1-2vl5
172- rebuilt with oniguruma-5.9.1
173
174* Sat Dec  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.5.1-1vl5
175- new upstream release (dropped Patch1 and Source2)
176
177* Sun Sep 14 2008 Shu KONNO <owa@bg.wakwak.com> 1.3.2-1vl5
178- applied new versioning policy, spec in utf-8
179
180* Tue Sep 04 2007 KAZUKI SHIMURA <ksh753@y5.dion.ne.jp> 1.3.2-0vl3
181- update desktop file (source1)
182
183* Tue Aug 21 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.3.2-0vl2
184- add Requires: mcs-devel for audacious-devel subpackage
185
186* Fri May 18 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.2-0vl1
187- new upstream release
188- build with new environment/toolchain
189
190* Mon Mar 12 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.1-0vl1
191- new upstream release
192- drop '--disable-gconf' option from %%configure
193
194* Fri Mar 09 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.0-0vl1
195- new upstream release
196- update ja.po (source2)
197- add BuildRequires: mcs-devel, libsamplerate-devel
198
199* Wed Feb 21 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.0-0vl0.0alpha5
200- update to 1.3.0alpha5
201- update ja.po (source2)
202- drop obsolete playlist-set-utf8-name.patch (patch2)
203- add new file: libaudid3tag.so
204
205* Mon Feb 12 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.0-0vl0.0alpha4.1
206- add playlist-set-utf8-name.patch (patch2)
207  to use utf-8-converted filename as playlist title
208
209* Thu Feb 08 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.0-0vl0.0alpha4
210- update to 1.3.0alpha4
211- update ja.po (source2)
212- update URLs
213
214* Wed Jan 31 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.0-0vl0.0alpha3
215- update to 1.3.0alpha3
216- update ja.po (source2)
217- update use-xfont.patch (patch1)
218- fix typo
219
220* Sun Jan 21 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.0-0vl0.0alpha2.1
221- update ja.po (source2)
222
223* Sat Jan 13 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.0-0vl0.0alpha2
224- update to 1.3.0alpha2
225- use oniguruma regex library
226  - add BuildRequires: oniguruma-devel
227  - add '--with-regexlib=oniguruma' option to %%configure
228
229* Thu Nov 30 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.2-0vl2
230- add '--enable-chardet' option to %%configure again
231
232* Wed Nov 29 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.2-0vl1
233- new upstream release
234- update ja.po (source2)
235
236* Sun Aug 27 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.2-0vl1
237- new upstream release
238
239* Tue Aug 01 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.1-0vl2
240- oops, really update ja.po (source2)
241
242* Mon Jul 31 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.1-0vl1
243- new upstream release
244- make with 'VERBOSE=1'
245- drop obsolete POTFILES.in (source3)
246- make update-po before make
247  - 1.1.1 contains old version of audacious.pot...
248- update ja.po (source2)
249
250* Sat Jul 22 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.0-0vl2
251- overwrite POTFILES.in (source3)
252  - 1.1.0 contains old version of POTFILES.in
253- update ja.po (source2)
254
255* Sat Jul 22 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.0-0vl1
256- new upstream release
257- drop unneeded patch0 (was merged)
258- add '--enable-ipv6 --enable-chardet' to %%configure option
259- add BuildRequires: taglib-devel instead of id3lib-devel
260- update ja.po (source2)
261
262* Sun Jun 04 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.0-0vl2
263- add flac-filename-utf8.patch (patch0)
264      to convert filename on fileinfo box for FLAC files to UTF-8
265- add use-xfont.patch (patch1)
266      to disable 'Use Bitmap fonts if available' by default
267- add ja.po (source2)
268
269* Sat Jun 03 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.0-0vl1
270- initial build
Note: See TracBrowser for help on using the repository browser.