source: projects/specs/trunk/a/audacious-plugins/audacious-plugins-vl.spec @ 521

Revision 521, 16.5 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1# to enable features, rpmbuild with '--with feature'
2%define with_aac        %{?_with_aac:1}%{!?_with_aac:0}
3%define with_wma        %{?_with_wma:1}%{!?_with_wma:0}
4%define with_lame       %{?_with_lame:1}%{!?_with_lame:0}
5
6%define _audacious_ver          2.1-1%{?_dist_release}
7%define _gtk2_ver               2.8.0
8%define _glib2_ver              2.10.0
9# to build OSD plugin, pango >= 1.14.7, cairo >= 1.2.6 are required
10%define _pango_ver              1.8.0
11%define _esound_ver             0.2
12%define _libvorbis_ver          1.0
13%define _libogg_ver             1.0
14%define _libsndfile_ver         0.19
15%define _flac_ver               1.2.0
16%define _arts_ver               0.9.5
17%define _alsa_ver               1.0
18%define _libmb_ver              2.0.0
19%define _curl_ver               7.9.7
20%define _libxml2_ver            2.0.0
21%define _sdl_ver                1.2.5
22%define _libmtp_ver             0.3.5
23
24#%%define extraver alpha5
25
26%define plugindir %{_libdir}/audacious
27
28Summary:        Audacious Media Player plugins
29Summary(ja):    Audacious メディアプレイヤー プラグイン集
30Name:           audacious-plugins
31Version:        2.1
32Release:        1%{?_dist_release}
33# LGPLv2+: adplug, bio2jack, rocklight
34# MIT: crystalizer, dockalbumart
35# BSD: lastfm
36License:        GPLv2 and GPLv2+ and LGPLv2+ and MIT and BSD
37Group:          Applications/Multimedia
38URL:            http://audacious-media-player.org/
39Source:         http://distfiles.atheme.org/audacious-plugins-%{version}%{?extraver:-%extraver}.tgz
40#Source1:       audacious-plugins-1.3.0-ja.po
41#Source2:       audacious-plugins-1.3.0-POTFILES.in
42Patch10:        audacious-plugins-1.5.1-libmtp-0.3.5-API.patch
43BuildRoot:      %{_tmppath}/%{name}-%{version}-root
44
45BuildRequires:  audacious-devel >= %{_audacious_ver}
46BuildRequires:  glib2-devel >= %{_glib2_ver}, gtk2-devel >= %{_gtk2_ver}
47BuildRequires:  pango-devel >= %{_pango_ver}
48BuildRequires:  esound-devel >= %{_esound_ver}
49#BuildRequires: libmad-devel
50BuildRequires:  libvorbis-devel >= %{_libvorbis_ver}
51BuildRequires:  libogg-devel >= %{_libogg_ver}
52BuildRequires:  libsndfile-devel >= %{_libsndfile_ver}
53BuildRequires:  flac-devel >= %{_flac_ver}
54BuildRequires:  arts-devel >= %{_arts_ver}
55BuildRequires:  alsa-lib-devel >= %{_alsa_ver}
56BuildRequires:  libmusicbrainz-devel >= %{_libmb_ver}
57BuildRequires:  curl-devel >= %{_curl_ver}
58BuildRequires:  libxml2-devel >= %{_libxml2_ver}
59BuildRequires:  SDL-devel >= %{_sdl_ver}
60BuildRequires:  libprojectm-devel
61BuildRequires:  libsamplerate-devel
62BuildRequires:  mesa-libGLU-devel
63BuildRequires:  neon-devel
64BuildRequires:  lirc
65BuildRequires:  pulseaudio-libs-devel
66BuildRequires:  libmtp-devel >= %{_libmtp_ver}
67BuildRequires:  jack-audio-connection-kit-devel
68BuildRequires:  bluez-libs-devel
69
70Requires:       audacious >= %{_audacious_ver}
71Requires:       glib2 >= %{_glib2_ver}, gtk2 >= %{_gtk2_ver}
72Requires:       pango >= %{_pango_ver}
73#Requires:      libmad
74Requires:       libvorbis >= %{_libvorbis_ver}
75Requires:       libogg >= %{_libogg_ver}
76Requires:       libsndfile >= %{_libsndfile_ver}
77Requires:       alsa-lib >= %{_alsa_ver}
78Requires:       libxml2 >= %{_libxml2_ver}
79
80Obsoletes:      audacious < 1.2.0
81Obsoletes:      beepmp, beepmp-alsa
82
83Vendor:         Project Vine
84Distribution:   Vine Linux
85
86%description
87Audacious is a media player that currently uses a skinned user interface
88based on Winamp 2.x skins.
89
90This package provides essential plugins for audio input, audio output and
91visualization.
92
93%package -n audacious-jack
94Summary: Audacious output plugin for JACK sound service
95Group: Applications/Multimedia
96Requires: audacious >= %{_audacious_ver}
97
98%description -n audacious-jack
99This package provides an Audacious output plugin that uses the
100JACK sound service.
101
102%package -n audacious-flac
103Summary:        Audacious plugin to play FLAC files
104Summary(ja):    FLAC ファイルを再生するための Audacious プラグイン
105Group:          Applications/Multimedia
106Requires:       audacious >= %{_audacious_ver}
107Requires:       flac >= %{_flac_ver}
108Obsoletes:      beepmp-flac
109
110%description -n audacious-flac
111This package contains a input plugin that enables playback of FLAC files
112in Audacious.
113
114%description -l ja -n audacious-flac
115このパッケージには、Audacious で FLAC ファイル (*.flac/fla) を再生するため
116の入力プラグインが含まれています。
117
118%package -n audacious-tta
119Summary:        Audacious plugin to play TTA files
120Summary(ja):    TTA ファイルを再生するための Audacious プラグイン
121Group:          Applications/Multimedia
122Requires:       audacious >= %{_audacious_ver}
123#Requires:      libid3tag
124
125%description -n audacious-tta
126This package contains a input plugin that enables playback of TTA files
127in Audacious.
128
129%description -l ja -n audacious-tta
130このパッケージには、Audacious で TTA ファイル (*.tta) を再生するための
131入力プラグインが含まれています。
132
133%if %{with_aac}
134%package -n audacious-aac
135Summary:        Audacious plugin to play AAC files
136Summary(ja):    AAC ファイルを再生するための Audacious プラグイン
137Group:          Applications/Multimedia
138Requires:       audacious >= %{_audacious_ver}
139
140%description -n audacious-aac
141This package contains a input plugin that enables playback of AAC files
142in Audacious.
143
144%description -l ja -n audacious-aac
145このパッケージには、Audacious で AAC ファイル (*.aac) を再生するため入力
146プラグインが含まれています。
147%endif
148
149%if %{with_wma}
150%package -n audacious-wma
151Summary:        Audacious plugin to play WMA files
152Summary(ja):    WMA ファイルを再生するための Audacious プラグイン
153Group:          Applications/Multimedia
154Requires:       audacious >= %{_audacious_ver}
155
156%description -n audacious-wma
157This package contains a input plugin that enables playback of WMA files
158in Audacious.
159
160%description -l ja -n audacious-wma
161このパッケージには、Audacious で WMA ファイル (*.wma) を再生するため入力
162プラグインが含まれています。
163%endif
164
165%if %{with_lame}
166%package -n audacious-lame
167Summary:        Audacious plugin to encode MP3 files using LAME
168Summary(ja):    LAME を利用して MP3 ファイルをエンコードするための Audacious プラグイン
169Group:          Applications/Multimedia
170BuildRequires:  lame-devel
171Requires:       audacious >= %{_audacious_ver}
172Requires:       lame
173
174%description -n audacious-lame
175This package contains a output plugin that enables encoding of MP3 files
176using LAME in Audacious.
177
178%description -l ja -n audacious-lame
179このパッケージには、Audacious で LAME を利用して MP3 ファイル (*.mp3) を
180エンコードするため出力プラグインが含まれています。
181%endif
182
183%package -n audacious-esd
184Summary:        Audacious plugin to output audio via EsounD
185Summary(ja):    Audacious EsounD オーディオ出力プラグイン
186Group:          Applications/Multimedia
187Requires:       audacious >= %{_audacious_ver}
188Requires:       esound >= %{_esound_ver}
189
190%description -n audacious-esd
191This package contains an audio output plugin via EsounD for Audacious.
192
193%description -l ja -n audacious-esd
194このパッケージには、Audacious で EsounD を用いて音声を出力するための
195プラグインが含まれています。
196
197%package -n audacious-scrobbler
198Summary:        Audacious plugin to use audioscrobbler
199Summary(ja):    Audacious audioscrobbler プラグイン
200Group:          Applications/Multimedia
201Requires:       audacious >= %{_audacious_ver}
202Requires:       libmusicbrainz >= %{_libmb_ver}
203Requires:       curl >= %{_curl_ver}
204Obsoletes:      audioscrobbler-beepmp
205
206%description -n audacious-scrobbler
207This package contains an audioscrobbler plugin for Audacious.
208
209%package -n audacious-visualization
210Summary:        Audacious visualization plugins
211Summary(ja):    Audacious 視覚化プラグイン
212Group:          Applications/Multimedia
213Requires:       audacious >= %{_audacious_ver}
214Requires:       SDL >= %{_sdl_ver}
215Requires:       libprojectm
216Obsoletes:      audacious-paranormal
217
218%description -n audacious-visualization
219This package contains extra visualization plugin for Audacious.
220
221%description -l ja -n audacious-visualization
222このパッケージには、Audacious で再生した音声を視覚化する追加のプラグインが
223含まれています。
224
225%prep
226%setup -q -n %{name}-%{version}%{?extraver:-%extraver}
227#patch10 -p1
228
229# update ja.po
230#%__cp -f %{SOURCE1} po/ja.po
231# overwrite POTFILES.in
232#%__cp -f %{SOURCE2} po/POTFILES.in
233
234%build
235%configure \
236        --enable-ipv6           \
237        --enable-chardet        \
238%if %{with_aac}
239        --enable-aac            \
240%else
241        --disable-aac           \
242%endif
243%if %{with_wma}
244        --enable-wma            \
245%else
246        --disable-wma           \
247%endif
248%if %{with_lame}
249        --enable-lame           \
250%else
251        --disable-lame          \
252%endif
253        --disable-musepack     \
254        --disable-mp3
255
256# update audacious-plugins.pot & ja.gmo
257#( cd po ;
258#  %__make %{_smp_mflags} VERBOSE=1 update-po )
259
260%__make %{_smp_mflags} VERBOSE=1
261
262%install
263%__rm -rf %{buildroot}
264%__make DESTDIR=%{buildroot} install
265
266%find_lang %{name}
267
268%clean
269%__rm -rf %{buildroot}
270
271%files -f %{name}.lang
272%defattr(-,root,root,-)
273%doc AUTHORS COPYING
274
275# container plugins
276%{plugindir}/Container/m3u.so
277%{plugindir}/Container/pls.so
278%{plugindir}/Container/xspf.so
279
280# effect plugins
281%{plugindir}/Effect/audiocompress.so
282%{plugindir}/Effect/crystalizer.so
283%{plugindir}/Effect/echo.so
284%{plugindir}/Effect/ladspa.so
285%{plugindir}/Effect/sndstretch.so
286%{plugindir}/Effect/stereo.so
287%{plugindir}/Effect/voice_removal.so
288
289# general plugins
290%{plugindir}/General/alarm.so
291%{plugindir}/General/aosd.so
292%{plugindir}/General/bluetooth.so
293%{plugindir}/General/evdev-plug.so
294%{plugindir}/General/gnomeshortcuts.so
295%{plugindir}/General/gtkui.so
296%{plugindir}/General/hotkey.so
297%{plugindir}/General/lirc.so
298%{plugindir}/General/mtp_up.so
299%{plugindir}/General/skins.so
300%{plugindir}/General/song_change.so
301%{plugindir}/General/statusicon.so
302%{plugindir}/General/streambrowser.so
303%{plugindir}/General/vfstrace.so
304
305# input plugins
306%{plugindir}/Input/alac.so
307%{plugindir}/Input/console.so
308%{plugindir}/Input/cuesheet_ng.so
309%{plugindir}/Input/demac.so
310#{plugindir}/Input/madplug.so
311%{plugindir}/Input/metronom.so
312%{plugindir}/Input/modplug.so
313%{plugindir}/Input/psf2.so
314%{plugindir}/Input/sndfile.so
315%{plugindir}/Input/timidity.so
316%{plugindir}/Input/tonegen.so
317%{plugindir}/Input/vorbis.so
318%{plugindir}/Input/vtx.so
319%{plugindir}/Input/xsf.so
320
321# output plugins
322%{plugindir}/Output/ALSA.so
323%{plugindir}/Output/OSS.so
324%{plugindir}/Output/crossfade.so
325%{plugindir}/Output/filewriter.so
326%{plugindir}/Output/null.so
327%{plugindir}/Output/pulse_audio.so
328
329# transport plugins
330%{plugindir}/Transport/gio.so
331%{plugindir}/Transport/lastfm.so
332%{plugindir}/Transport/neon.so
333
334# visualization plugins
335%{plugindir}/Visualization/blur_scope.so
336%{plugindir}/Visualization/spectrum.so
337
338%dir %{_datadir}/audacious
339%{_datadir}/audacious/images/bookmarks.png
340%{_datadir}/audacious/images/shoutcast.png
341%{_datadir}/audacious/images/streambrowser-*.png
342%{_datadir}/audacious/images/xiph.png
343
344%files -n audacious-jack
345%defattr(-,root,root,-)
346%{plugindir}/Output/jackout.so
347
348%files -n audacious-flac
349%defattr(-,root,root,-)
350%{plugindir}/Input/flacng.so
351
352%files -n audacious-tta
353%defattr(-,root,root,-)
354%{plugindir}/Input/tta.so
355
356%if %{with_aac}
357%files -n audacious-aac
358%defattr(-,root,root,-)
359%{plugindir}/Input/aac.so
360%endif
361
362%if %{with_wma}
363%files -n audacious-wma
364%defattr(-,root,root,-)
365%{plugindir}/Input/wma.so
366%endif
367
368%if %{with_lame}
369%files -n audacious-lame
370%defattr(-,root,root,-)
371%{plugindir}/Output/lame.so
372%endif
373
374%files -n audacious-esd
375%defattr(-,root,root,-)
376%{plugindir}/Output/ESD.so
377
378%files -n audacious-scrobbler
379%defattr(-,root,root,-)
380%{plugindir}/General/scrobbler.so
381%{_datadir}/audacious/images/audioscrobbler*.png
382
383%files -n audacious-visualization
384%defattr(-,root,root,-)
385%{plugindir}/Visualization/paranormal.so
386%{plugindir}/Visualization/rocklight.so
387%{plugindir}/Visualization/projectm.so
388%{_datadir}/audacious/paranormal
389
390%changelog
391* Sun Aug  9 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.1-1
392- new upstream release
393- added --disable-mp3 options
394
395* Tue Apr 28 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.5.1-4
396- add BuildRequires: libmtp-devel >= 0.3.5
397- add Patch10 to fix mtp.c for API changes on libmtp >= 0.3.0
398
399* Sun Apr 26 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.5.1-3
400- rebuilt with libmowgli-0.7.0
401
402* Sat Mar 14 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.5.1-2
403- add BuildRequires: libsamplerate-devel and mesa-libGLU-devel
404- add BuildRequires: neon-devel, lirc and pulseaudio-libs-devel
405
406* Sat Dec  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.5.1-1vl5
407- new upstream release
408
409* Sun Sep 14 2008 Shu KONNO <owa@bg.wakwak.com> 1.3.5-1vl5
410- applied new versioning policy, spec in utf-8
411
412* Sat Sep 22 2007 KAZUKI SHIMURA <ksh753@y5.dion.ne.jp> 1.3.5-0vl2
413- add Obsoletes: beepmp, beepmp-alsa
414- add Obsoletes: beepmp-flac to audacious-flac package
415- add Obsoletes: audioscrobbler-beepmp to audacious-scrobbler package
416
417* Sat Aug 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.5-0vl1
418- new upstream release
419- rebuilt with flac-1.2.0
420
421* Fri May 18 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.4-0vl1
422- new upstream release
423- build with new environment/toolchain
424
425* Mon Mar 12 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.1-0vl1
426- new upstream release
427
428* Fri Mar 09 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.0-0vl1
429- new upstream release
430- update ja.po (source1)
431- update %%_audacious_ver
432- overwrite POTFILES.in (source3)
433  - 1.3.0 contains old version of POTFILES.in
434- drop obsolete id3tag.h.patch (patch0)
435- drop BuildRequires: libglade2-devel, taglib-devel
436- add %%with_lame macro
437  - enable lame plugin if rpmbuild with '--with lame'
438
439* Thu Feb 22 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.0-0vl0.0alpha5.1
440- add BuildRequires: libmad-devel
441- add id3tag.h.patch (patch0)
442
443* Wed Feb 21 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.0-0vl0.0alpha5
444- update to 1.3.0alpha5
445- update ja.po (source1)
446- update %%_audacious_ver
447- drop obsolete avoid-null-dereference.patch (patch0)
448- drop BuildRequires: libid3tag-devel
449  - NOTE: taglib is not used, but required in configure.ac
450- add plugin to core package
451  - libmadplug.so instead of libmpg123.so (Input)
452- move plugin to visualization package
453  - librocklight.so (Visualization)
454- add Requires: audacious instead of %%{name} to sub packages
455
456* Fri Feb 09 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.0-0vl0.0alpha4.1
457- add avoid-null-dereference.patch (patch0) to avoid crash
458
459  r1316 | nenolod | 2007-02-08 03:35:13 +0900 (Thu, 08 Feb 2007) | 2 lines
460  - avoid NULL dereference. closes mandriva #28603.
461
462* Thu Feb 08 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.0-0vl0.0alpha4
463- update to 1.3.0alpha4
464- update ja.po (source1)
465- update %%_audacious_ver
466- update URLs
467- add BuildRequires: libprojectM-devel
468- add plugin to visualization package
469  - libprojectm.so (Visualization)
470
471* Wed Jan 31 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.0-0vl0.0alpha3
472- update to 1.3.0alpha3
473- update ja.po (source1)
474- add BuildRequires: libid3tag-devel
475- add plugins to core package
476  - libcurl.so, libevdev-plug.so, libstatusicon.so (General)
477- add new package: audacious-tta
478  - libtta.so (Input)
479
480* Sun Jan 21 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.0-0vl0.0alpha2.1
481- update ja.po (source1)
482
483* Sat Jan 13 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.0-0vl0.0alpha2
484- update to 1.3.0alpha2
485- update %%_audacious_ver
486- drop '--disable-gnome-vfs' option from %%configure (no longer supported)
487- add audacious-1.2.2's ja.po (source1)
488  to use some translations prior to plugin separation
489- add plugins to core package:
490  - libstdio.so (Container)
491  - libmetronom.so, libmodplug.so (Input)
492  - librocklight.so (Visualization)
493- rename paranormal package to visualization
494  - add Obsoletes: audacious-paranormal
495  - add plugin: librovascope.so
496- fix typo
497
498* Thu Nov 30 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.5-0vl2
499- separate paranormal package
500- add BuildRequires: SDL-devel
501
502* Thu Nov 30 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.5-0vl1
503- initial build based on audacious
504
505* Sun Aug 27 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.2-0vl1
506- new upstream release
507
508* Tue Aug 01 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.1-0vl2
509- oops, really update ja.po (source2)
510
511* Mon Jul 31 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.1-0vl1
512- new upstream release
513- make with 'VERBOSE=1'
514- drop obsolete POTFILES.in (source3)
515- make update-po before make
516  - 1.1.1 contains old version of audacious.pot...
517- update ja.po (source2)
518
519* Sat Jul 22 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.0-0vl2
520- overwrite POTFILES.in (source3)
521  - 1.1.0 contains old version of POTFILES.in
522- update ja.po (source2)
523
524* Sat Jul 22 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.0-0vl1
525- new upstream release
526- drop unneeded patch0 (was merged)
527- add '--enable-ipv6 --enable-chardet' to %%configure option
528- add BuildRequires: taglib-devel instead of id3lib-devel
529- update ja.po (source2)
530
531* Sun Jun 04 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.0-0vl2
532- add flac-filename-utf8.patch (patch0)
533      to convert filename on fileinfo box for FLAC files to UTF-8
534- add use-xfont.patch (patch1)
535      to disable 'Use Bitmap fonts if available' by default
536- add ja.po (source2)
537
538* Sat Jun 03 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.0-0vl1
539- initial build
Note: See TracBrowser for help on using the repository browser.