source: projects/specs/trunk/a/auctex/auctex-vl.spec @ 4203

Revision 4203, 10.5 KB checked in by munepi, 13 years ago (diff)

updated auctex-vl.spec: For vl5, reverted initial elisp files to 11.86-2

RevLine 
[521]1%define prereq_ge()  %(LC_ALL="C" rpm -q --queryformat 'Requires(post):%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
2
3%define origname        auctex
4%define emacspkg        preview-latex
5
6%define texmf           %{_datadir}/texmf
7%define build_texmf     %{buildroot}%{texmf}
8
9%define exec_texhash    [ -x %{_bindir}/texhash ] && %{_bindir}/env - %{_bindir}/texhash 2> /dev/null
10%define exec_updmap     [ -x %{_bindir}/updmap-sys ] && %{_bindir}/env - %{_bindir}/updmap-sys --nostop 2> /dev/null
11
12
13Summary:        Enhanced TeX modes for Emacsen
14Name:           %{origname}
[696]15Version:        11.86
[4203]16Release:        5%{?_dist_release}
[521]17Group:          Applications/Editors/Emacs
18License:        GPLv3+
19URL:            http://www.gnu.org/software/auctex/
20Source:         http://ftp.gnu.org/pub/gnu/auctex/auctex-%{version}.tar.gz
21Source1:        %{origname}-install.sh
22Source2:        %{origname}-remove.sh
23Source3:        %{origname}-init.el
24Source4:        vine-default-%{origname}.el
25
26Source5:        %{emacspkg}-install.sh
27Source6:        %{emacspkg}-remove.sh
28Source7:        %{emacspkg}-init.el
29Source8:        vine-default-%{emacspkg}.el
30
[4203]31## for vl5
32Source13:       %{origname}-init-vl5.el
33Source14:       vine-default-%{origname}-vl5.el
34Source17:       %{emacspkg}-init-vl5.el
35Source18:       vine-default-%{emacspkg}-vl5.el
36
[4202]37## vine
38## for vl5
39Patch:          auctex-11.86-vine.patch
40## for vl6 or higher
41Patch1:         auctex-11.86-plt09-vine.patch
[521]42
43Requires:       %{emacspkg} = %{version}-%{release}
44BuildRequires:  texinfo
[2434]45%if %{?_dist_release} == "vl5"
[521]46BuildRequires:  tetex
[2434]47%else
48BuildRequires:  texlive
49%endif
50## Note: "BR: emacs >= 23.1" need to build auctex
51BuildRequires:  emacs >= 23.1
52
[521]53%prereq_ge      emacsen emacsen-common
54Requires(post): /sbin/install-info
55
56Obsoletes:      auctex-emacs auctex-xemacs
57
58BuildArch:      noarch
59BuildRoot:      %{_tmppath}/%{name}-%{version}-root
60
61Vendor:         Project Vine
62Distribution:   Vine Linux
63Packager:       munepi
64
65
66%description
67AUCTeX is an extensible package that supports writing and formatting TeX files
68for most variants of Emacs. 
69
70AUCTeX supports many different TeX macro packages, including AMS-TeX, LaTeX,
71Texinfo and basic support for ConTeXt.  Documentation can be found under
72/usr/share/doc, e.g. the reference card (tex-ref.pdf) and the FAQ.  The AUCTeX
73manual is available in Emacs info (C-h i d m AUCTeX RET).  On the AUCTeX home
74page, we provide manuals in various formats.
75
76This version of AUCTeX comes with preview-latex, an addictive productivity
77tool providing a fine-grained interactive folding WYSIWYG display in the
78source buffer.
79
80If you are AUCTeX user and you install both yatex and auctex on your system,
[2750]81you may add the following configure in your emacs init file
82%if %{?_dist_release} == "vl5"
83~/.emacs.el:
84%else
85~/.emacs.d/emacsXX-vine-default.el (XX: emacs major version):
86%endif
[521]87
[2750]88;; I am AUCTeX user!!!
[521]89(setq vine-default-yatex nil)
90
91
92%package -n %{emacspkg}
93Summary:        Emacs/LaTeX inline preview
94Group:          Applications/Editors/Emacs
95Requires(post):       %{origname} = %{version}-%{release}
96BuildRequires:  emacsen
97%prereq_ge      emacsen-common
98
99%description -n %{emacspkg}
100AUCTeX is an extensible package that supports writing and formatting TeX files
101for most variants of Emacs. 
102
103AUCTeX supports many different TeX macro packages, including AMS-TeX, LaTeX,
104Texinfo and basic support for ConTeXt.  Documentation can be found under
105/usr/share/doc, e.g. the reference card (tex-ref.pdf) and the FAQ.  The AUCTeX
106manual is available in Emacs info (C-h i d m AUCTeX RET).  On the AUCTeX home
107page, we provide manuals in various formats.
108
109This version of AUCTeX comes with preview-latex, an addictive productivity
110tool providing a fine-grained interactive folding WYSIWYG display in the
111source buffer.
112
113Does your neck hurt from turning between previewer windows and the
114source too often? This Elisp/LaTeX package will render your displayed
115LaTeX equations right into the editing window where they belong.
116
117
118%prep
119%setup -q -n %{origname}-%{version}
[4202]120%if %{?_dist_release} == "vl5"
[521]121%patch -p1 -b .vine
[4202]122%else
123%patch1 -p1 -b .vine
124%endif
[521]125
126%build
127%configure --with-emacs INSTALL_INFO=: --without-texmf-dir
128%__make
129
130## output auctex.el
131%__cp -a auctex.el auctex.el.vine
132cat>auctex.el<<EOF
133;;; auctex.el
134;;
135;; This can be used for starting up AUCTeX.  The following somewhat
136;; strange trick causes tex-site.el to be loaded in a way that can be
137;; safely undone using (unload-feature 'tex-site).
138;;
139;; (autoload 'TeX-load-hack
140;;   "/some/where/tex-site.el")
141;; (TeX-load-hack)
142
143;;
144;; No any settings provide in this file.
145;;
146EOF
147
148## remove all *.elc
[4202]149find . -type f -name "*.elc" -exec %__rm -f {} ';'
[521]150
151
152%install
153
[4202]154[ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
[521]155
156## install preview package
157pushd preview
158%__make install-texmf \
159    previewtexmfdir=%{build_texmf}/tex/latex/preview \
160    previewdocdir=%{build_texmf}/doc/latex/preview
161%__rm -f %{build_texmf}/doc/latex/preview/preview.dvi
162%__install -p -m0644 latex/preview.pdf %{build_texmf}/doc/latex/preview/
163popd
164
165
166%__mkdir_p ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{name}
167%__mkdir_p ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{emacspkg}
168%__mkdir_p $RPM_BUILD_ROOT/%{emacsen_pkgdir}/install
169%__mkdir_p $RPM_BUILD_ROOT/%{emacsen_pkgdir}/remove
170%__mkdir_p ${RPM_BUILD_ROOT}%{_infodir}
171
172
173#
174# install el files
175#
176
177## <auctex>
178%__install -p -m0644 *.el \
179    ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/%{name}/
180%__cp -ra images style \
181    ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{name}/
182
[4203]183%if %{?_dist_release} == "vl5"
184    %__install -p -m0644 %{SOURCE13} \
185        ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/%{name}/%{origname}-init.el
186    %__install -p -m0644 %{SOURCE14} \
187        ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/%{name}/vine-default-%{origname}.el
188%else
189    %__install -p -m0644 %{SOURCE3} %{SOURCE4} \
190        ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/%{name}/
191%endif
[521]192## </auctex>
193
194## <preview-latex>
195pushd preview
196%__install -p -m0644 *.el \
197    ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/%{emacspkg}/
198%__cp -ra images \
199    ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/%{emacspkg}/
200popd
201
[4203]202%if %{?_dist_release} == "vl5"
203    %__install -p -m0644 %{SOURCE17} \
204        ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/%{emacspkg}/%{emacspkg}-init.el
205    %__install -p -m0644 %{SOURCE18} \
206        ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/%{emacspkg}/vine-default-%{emacspkg}.el
207%else
208    %__install -p -m0644 %{SOURCE7} %{SOURCE8} \
209        ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/%{emacspkg}/
210%endif
[521]211## </preview-latex>
212
213
214#
215# install info files
216#
217
218%__install -p -m 0644 doc/%{origname}.info doc/%{emacspkg}.info \
219    ${RPM_BUILD_ROOT}%{_infodir}/
220
221
222#
223# install script (bytecompile el and install elc, remove)
224#
225
226%_installemacsenscript %{origname} %{SOURCE1}
227
228%_removeemacsenscript  %{origname} %{SOURCE2}
229
230%_installemacsenscript %{emacspkg} %{SOURCE5}
231
232%_removeemacsenscript  %{emacspkg} %{SOURCE6}
233
234
235%clean
236[ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
237
238
239%post
240#
241# bytecompile and install
242#
243
244if [ "$1" = 2 ]; then
245
246%_emacsenPackageRemove %{origname}
247
248fi
249
250%_addemacsenlist %{origname}
251
252%_emacsenPackageInstall %{origname}
253
254/sbin/install-info %{_infodir}/%{origname}.info.gz %{_infodir}/dir \
255  --section="A much enhanced LaTeX mode for GNU Emacs"
256
257
258%post -n %{emacspkg}
259#
260# bytecompile and install
261#
262
263if [ "$1" = 2 ]; then
264
265    %_emacsenPackageRemove %{emacspkg}
266
267fi
268
269%_addemacsenlist %{emacspkg}
270
271%_emacsenPackageInstall %{emacspkg}
272
273/sbin/install-info \
274    %{_infodir}/%{emacspkg}.info.gz %{_infodir}/dir \
275    --section="A much enhanced LaTeX mode for GNU Emacs"
276
277
278%preun
279if [ "$1" = 0 ]; then
280    %_emacsenPackageRemove %{origname}
281
282    %_removeemacsenlist %{origname}
283
284    /sbin/install-info --delete \
285        %{_infodir}/%{origname}.info.gz %{_infodir}/dir \
286        --section="A much enhanced LaTeX mode for GNU Emacs"
287fi
288
289
290%preun -n %{emacspkg}
291if [ "$1" = 0 ]; then
292
293    %_emacsenPackageRemove %{emacspkg}
294
295    %_removeemacsenlist %{emacspkg}
296
297    /sbin/install-info --delete \
298        %{_infodir}/preview-latex.info.gz %{_infodir}/dir \
299        --section="A much enhanced LaTeX mode for GNU Emacs"
300fi
301
302
303%files
304%defattr(-,root,root)
305%doc CHANGES COPYING ChangeLog FAQ INSTALL README RELEASE TODO doc/*.{tex,pdf}
306%{_infodir}/%{origname}*
307%{_datadir}/emacs/site-lisp/%{origname}/
308%{emacsen_pkgdir}/install/%{origname}
309%{emacsen_pkgdir}/remove/%{origname}
310
311
312%files -n %{emacspkg}
313%defattr(-,root,root)
314%doc preview/COPYING preview/ChangeLog{,.1}
315%{_infodir}/%{emacspkg}*
316%{texmf}/doc/latex/preview/preview.pdf
317%{texmf}/tex/latex/preview/*
318%{_datadir}/emacs/site-lisp/%{emacspkg}/
319%{emacsen_pkgdir}/install/%{emacspkg}
320%{emacsen_pkgdir}/remove/%{emacspkg}
321
322
323
324%changelog
[4203]325* Thu Jun 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.86-5
326- For vl5, reverted initial elisp files to 11.86-2
327
[4202]328* Thu Jun 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.86-4
329- supported TeX Live 2009
330
[2750]331* Tue Feb 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.86-3
332- updated auctex-init.el and preview-latex-init.el
333  - output "Loading vine-default-xxxxx ..." to the buffer *Messages*
334
[2434]335* Mon Jan 03 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.86-2
336- fixed requirements
337  - set BuildRequires: emacs >= 23.1
338  - set BuildRequires: texlive (for vl6)
339
[696]340* Sun Mar 28 2010 Munehiro Yamamoto <munepi@vinelinux.org> 11.86-1
341- new versioning release
342
[521]343* Sun Sep 13 2009 Munehiro Yamamoto <munepi@vinelinux.org> 11.85-1
344- new versioning release
345- dropped old version patches
346- changed to GPLv3+ in License tag
347- changed to http://www.gnu.org/software/auctex/ in URL tag
348- download from http://ftp.gnu.org/pub/gnu/auctex in Source0
349- added preview-latex package
350- setup vine-default
351
352* Sun Sep 14 2008 Shu KONNO <owa@bg.wakwak.com> 11.13-1vl5
353- applied new versioning policy, spec in utf-8
354- added macro %%emacsen_pkgdir
355
356* Tue Sep 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 11.13-0vl2
357- changed Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
358- s/Copyright/License/
359
360* Wed Dec 25 2002 Jun Nishii <jun@vinelinux.org> 11.13-0vl1
361- ver.up
362
363* Mon Apr 22 2002 Jun Nishii <jun@vinelinux.org> 10.0g-0vl3
364- minor fix of tex-jp.el
365
366* Wed Mar  6 2002 Jun Nishii <jun@vinelinux.org> 10.0g-0vl2
367- emasenize
368
369* Tue Apr 24 2001 Jun Nishii <jun@vinelinux.org>
370- 10.0g-0vl1
371
372* Thu Sep 21 2000 Jun Nishii <jun@vinelinux.org>
373- 9.10p-0vl2
374- minor modification of spec file
375
376* Fri Jan 14 2000 Jun Nishii <jun@vinelinux.org>
377- 9.10p-0vl1
378- change directories
379- minor customization
380
381* Wed Dec 22 1999 Jun Nishii <jun@vinelinux.org>
382- 9.10p
383
384* Thu Dec 16 1999 Jun Nishii <jun@vinelinux.org>
385- build auctex for emacs
386
387* Fri Feb 19 1999 Jun Nishii <jun@vinelinux.org>
388- updated to 9.9p
389
390* Sat Nov 14 1998 Jun Nishii <jun@vinelinux.org>
391- first release for 9.8l
392
Note: See TracBrowser for help on using the repository browser.