source: projects/specs/trunk/a/auctex/auctex-vl.spec @ 4202

Revision 4202, 9.6 KB checked in by munepi, 13 years ago (diff)

updated auctex-vl.spec: supported TeX Live 2009

RevLine 
[521]1%define prereq_ge()  %(LC_ALL="C" rpm -q --queryformat 'Requires(post):%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
2
3%define origname        auctex
4%define emacspkg        preview-latex
5
6%define texmf           %{_datadir}/texmf
7%define build_texmf     %{buildroot}%{texmf}
8
9%define exec_texhash    [ -x %{_bindir}/texhash ] && %{_bindir}/env - %{_bindir}/texhash 2> /dev/null
10%define exec_updmap     [ -x %{_bindir}/updmap-sys ] && %{_bindir}/env - %{_bindir}/updmap-sys --nostop 2> /dev/null
11
12
13Summary:        Enhanced TeX modes for Emacsen
14Name:           %{origname}
[696]15Version:        11.86
[4202]16Release:        4%{?_dist_release}
[521]17Group:          Applications/Editors/Emacs
18License:        GPLv3+
19URL:            http://www.gnu.org/software/auctex/
20Source:         http://ftp.gnu.org/pub/gnu/auctex/auctex-%{version}.tar.gz
21Source1:        %{origname}-install.sh
22Source2:        %{origname}-remove.sh
23Source3:        %{origname}-init.el
24Source4:        vine-default-%{origname}.el
25
26Source5:        %{emacspkg}-install.sh
27Source6:        %{emacspkg}-remove.sh
28Source7:        %{emacspkg}-init.el
29Source8:        vine-default-%{emacspkg}.el
30
[4202]31## vine
32## for vl5
33Patch:          auctex-11.86-vine.patch
34## for vl6 or higher
35Patch1:         auctex-11.86-plt09-vine.patch
[521]36
37Requires:       %{emacspkg} = %{version}-%{release}
38BuildRequires:  texinfo
[2434]39%if %{?_dist_release} == "vl5"
[521]40BuildRequires:  tetex
[2434]41%else
42BuildRequires:  texlive
43%endif
44## Note: "BR: emacs >= 23.1" need to build auctex
45BuildRequires:  emacs >= 23.1
46
[521]47%prereq_ge      emacsen emacsen-common
48Requires(post): /sbin/install-info
49
50Obsoletes:      auctex-emacs auctex-xemacs
51
52BuildArch:      noarch
53BuildRoot:      %{_tmppath}/%{name}-%{version}-root
54
55Vendor:         Project Vine
56Distribution:   Vine Linux
57Packager:       munepi
58
59
60%description
61AUCTeX is an extensible package that supports writing and formatting TeX files
62for most variants of Emacs. 
63
64AUCTeX supports many different TeX macro packages, including AMS-TeX, LaTeX,
65Texinfo and basic support for ConTeXt.  Documentation can be found under
66/usr/share/doc, e.g. the reference card (tex-ref.pdf) and the FAQ.  The AUCTeX
67manual is available in Emacs info (C-h i d m AUCTeX RET).  On the AUCTeX home
68page, we provide manuals in various formats.
69
70This version of AUCTeX comes with preview-latex, an addictive productivity
71tool providing a fine-grained interactive folding WYSIWYG display in the
72source buffer.
73
74If you are AUCTeX user and you install both yatex and auctex on your system,
[2750]75you may add the following configure in your emacs init file
76%if %{?_dist_release} == "vl5"
77~/.emacs.el:
78%else
79~/.emacs.d/emacsXX-vine-default.el (XX: emacs major version):
80%endif
[521]81
[2750]82;; I am AUCTeX user!!!
[521]83(setq vine-default-yatex nil)
84
85
86%package -n %{emacspkg}
87Summary:        Emacs/LaTeX inline preview
88Group:          Applications/Editors/Emacs
89Requires(post):       %{origname} = %{version}-%{release}
90BuildRequires:  emacsen
91%prereq_ge      emacsen-common
92
93%description -n %{emacspkg}
94AUCTeX is an extensible package that supports writing and formatting TeX files
95for most variants of Emacs. 
96
97AUCTeX supports many different TeX macro packages, including AMS-TeX, LaTeX,
98Texinfo and basic support for ConTeXt.  Documentation can be found under
99/usr/share/doc, e.g. the reference card (tex-ref.pdf) and the FAQ.  The AUCTeX
100manual is available in Emacs info (C-h i d m AUCTeX RET).  On the AUCTeX home
101page, we provide manuals in various formats.
102
103This version of AUCTeX comes with preview-latex, an addictive productivity
104tool providing a fine-grained interactive folding WYSIWYG display in the
105source buffer.
106
107Does your neck hurt from turning between previewer windows and the
108source too often? This Elisp/LaTeX package will render your displayed
109LaTeX equations right into the editing window where they belong.
110
111
112%prep
113%setup -q -n %{origname}-%{version}
[4202]114%if %{?_dist_release} == "vl5"
[521]115%patch -p1 -b .vine
[4202]116%else
117%patch1 -p1 -b .vine
118%endif
[521]119
120%build
121%configure --with-emacs INSTALL_INFO=: --without-texmf-dir
122%__make
123
124## output auctex.el
125%__cp -a auctex.el auctex.el.vine
126cat>auctex.el<<EOF
127;;; auctex.el
128;;
129;; This can be used for starting up AUCTeX.  The following somewhat
130;; strange trick causes tex-site.el to be loaded in a way that can be
131;; safely undone using (unload-feature 'tex-site).
132;;
133;; (autoload 'TeX-load-hack
134;;   "/some/where/tex-site.el")
135;; (TeX-load-hack)
136
137;;
138;; No any settings provide in this file.
139;;
140EOF
141
142## remove all *.elc
[4202]143find . -type f -name "*.elc" -exec %__rm -f {} ';'
[521]144
145
146%install
147
[4202]148[ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
[521]149
150## install preview package
151pushd preview
152%__make install-texmf \
153    previewtexmfdir=%{build_texmf}/tex/latex/preview \
154    previewdocdir=%{build_texmf}/doc/latex/preview
155%__rm -f %{build_texmf}/doc/latex/preview/preview.dvi
156%__install -p -m0644 latex/preview.pdf %{build_texmf}/doc/latex/preview/
157popd
158
159
160%__mkdir_p ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{name}
161%__mkdir_p ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{emacspkg}
162%__mkdir_p $RPM_BUILD_ROOT/%{emacsen_pkgdir}/install
163%__mkdir_p $RPM_BUILD_ROOT/%{emacsen_pkgdir}/remove
164%__mkdir_p ${RPM_BUILD_ROOT}%{_infodir}
165
166
167#
168# install el files
169#
170
171## <auctex>
172%__install -p -m0644 *.el \
173    ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/%{name}/
174%__cp -ra images style \
175    ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{name}/
176
177%__install -p -m0644 %{SOURCE3} %{SOURCE4} \
178    ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/%{name}/
179## </auctex>
180
181## <preview-latex>
182pushd preview
183%__install -p -m0644 *.el \
184    ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/%{emacspkg}/
185%__cp -ra images \
186    ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/%{emacspkg}/
187popd
188
189%__install -p -m0644 %{SOURCE7} %{SOURCE8} \
190    ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/%{emacspkg}/
191## </preview-latex>
192
193
194#
195# install info files
196#
197
198%__install -p -m 0644 doc/%{origname}.info doc/%{emacspkg}.info \
199    ${RPM_BUILD_ROOT}%{_infodir}/
200
201
202#
203# install script (bytecompile el and install elc, remove)
204#
205
206%_installemacsenscript %{origname} %{SOURCE1}
207
208%_removeemacsenscript  %{origname} %{SOURCE2}
209
210%_installemacsenscript %{emacspkg} %{SOURCE5}
211
212%_removeemacsenscript  %{emacspkg} %{SOURCE6}
213
214
215%clean
216[ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
217
218
219%post
220#
221# bytecompile and install
222#
223
224if [ "$1" = 2 ]; then
225
226%_emacsenPackageRemove %{origname}
227
228fi
229
230%_addemacsenlist %{origname}
231
232%_emacsenPackageInstall %{origname}
233
234/sbin/install-info %{_infodir}/%{origname}.info.gz %{_infodir}/dir \
235  --section="A much enhanced LaTeX mode for GNU Emacs"
236
237
238%post -n %{emacspkg}
239#
240# bytecompile and install
241#
242
243if [ "$1" = 2 ]; then
244
245    %_emacsenPackageRemove %{emacspkg}
246
247fi
248
249%_addemacsenlist %{emacspkg}
250
251%_emacsenPackageInstall %{emacspkg}
252
253/sbin/install-info \
254    %{_infodir}/%{emacspkg}.info.gz %{_infodir}/dir \
255    --section="A much enhanced LaTeX mode for GNU Emacs"
256
257
258%preun
259if [ "$1" = 0 ]; then
260    %_emacsenPackageRemove %{origname}
261
262    %_removeemacsenlist %{origname}
263
264    /sbin/install-info --delete \
265        %{_infodir}/%{origname}.info.gz %{_infodir}/dir \
266        --section="A much enhanced LaTeX mode for GNU Emacs"
267fi
268
269
270%preun -n %{emacspkg}
271if [ "$1" = 0 ]; then
272
273    %_emacsenPackageRemove %{emacspkg}
274
275    %_removeemacsenlist %{emacspkg}
276
277    /sbin/install-info --delete \
278        %{_infodir}/preview-latex.info.gz %{_infodir}/dir \
279        --section="A much enhanced LaTeX mode for GNU Emacs"
280fi
281
282
283%files
284%defattr(-,root,root)
285%doc CHANGES COPYING ChangeLog FAQ INSTALL README RELEASE TODO doc/*.{tex,pdf}
286%{_infodir}/%{origname}*
287%{_datadir}/emacs/site-lisp/%{origname}/
288%{emacsen_pkgdir}/install/%{origname}
289%{emacsen_pkgdir}/remove/%{origname}
290
291
292%files -n %{emacspkg}
293%defattr(-,root,root)
294%doc preview/COPYING preview/ChangeLog{,.1}
295%{_infodir}/%{emacspkg}*
296%{texmf}/doc/latex/preview/preview.pdf
297%{texmf}/tex/latex/preview/*
298%{_datadir}/emacs/site-lisp/%{emacspkg}/
299%{emacsen_pkgdir}/install/%{emacspkg}
300%{emacsen_pkgdir}/remove/%{emacspkg}
301
302
303
304%changelog
[4202]305* Thu Jun 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.86-4
306- supported TeX Live 2009
307
[2750]308* Tue Feb 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.86-3
309- updated auctex-init.el and preview-latex-init.el
310  - output "Loading vine-default-xxxxx ..." to the buffer *Messages*
311
[2434]312* Mon Jan 03 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.86-2
313- fixed requirements
314  - set BuildRequires: emacs >= 23.1
315  - set BuildRequires: texlive (for vl6)
316
[696]317* Sun Mar 28 2010 Munehiro Yamamoto <munepi@vinelinux.org> 11.86-1
318- new versioning release
319
[521]320* Sun Sep 13 2009 Munehiro Yamamoto <munepi@vinelinux.org> 11.85-1
321- new versioning release
322- dropped old version patches
323- changed to GPLv3+ in License tag
324- changed to http://www.gnu.org/software/auctex/ in URL tag
325- download from http://ftp.gnu.org/pub/gnu/auctex in Source0
326- added preview-latex package
327- setup vine-default
328
329* Sun Sep 14 2008 Shu KONNO <owa@bg.wakwak.com> 11.13-1vl5
330- applied new versioning policy, spec in utf-8
331- added macro %%emacsen_pkgdir
332
333* Tue Sep 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 11.13-0vl2
334- changed Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
335- s/Copyright/License/
336
337* Wed Dec 25 2002 Jun Nishii <jun@vinelinux.org> 11.13-0vl1
338- ver.up
339
340* Mon Apr 22 2002 Jun Nishii <jun@vinelinux.org> 10.0g-0vl3
341- minor fix of tex-jp.el
342
343* Wed Mar  6 2002 Jun Nishii <jun@vinelinux.org> 10.0g-0vl2
344- emasenize
345
346* Tue Apr 24 2001 Jun Nishii <jun@vinelinux.org>
347- 10.0g-0vl1
348
349* Thu Sep 21 2000 Jun Nishii <jun@vinelinux.org>
350- 9.10p-0vl2
351- minor modification of spec file
352
353* Fri Jan 14 2000 Jun Nishii <jun@vinelinux.org>
354- 9.10p-0vl1
355- change directories
356- minor customization
357
358* Wed Dec 22 1999 Jun Nishii <jun@vinelinux.org>
359- 9.10p
360
361* Thu Dec 16 1999 Jun Nishii <jun@vinelinux.org>
362- build auctex for emacs
363
364* Fri Feb 19 1999 Jun Nishii <jun@vinelinux.org>
365- updated to 9.9p
366
367* Sat Nov 14 1998 Jun Nishii <jun@vinelinux.org>
368- first release for 9.8l
369
Note: See TracBrowser for help on using the repository browser.