source: projects/specs/trunk/a/atk/atk-vl.spec @ 9475

Revision 9475, 9.6 KB checked in by Takemikaduchi, 9 years ago (diff)

GNOME-3.16.0

Line 
1# Something's not quite right with libtool....
2%define __libtoolize :
3%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
4
5%define glib2_base_version 2.44.0
6%define glib2_version %{glib2_base_version}
7
8Summary: Interfaces for accessibility support.
9Summary(ja): アクセシビリティサポートのためのインタフェース
10Name: atk
11Version: 2.16.0
12Release: 1%{?_dist_release}
13License: LGPL
14Group: System Environment/Libraries
15Source: ftp://ftp.gnome.org/pub/GNOME/sources/atk/2.16/atk-%{version}.tar.xz
16URL: http://developer.gnome.org/projects/gap/
17
18BuildRoot: %{_tmppath}/%{name}-%{version}-root
19
20BuildRequires: glib2-devel >= %{glib2_version}
21BuildRequires: gobject-introspection-devel >= 0.6.7
22
23Vendor: Project Vine
24Distribution: Vine Linux
25Packager: Takemikaduchi
26
27%description
28The ATK library provides a set of interfaces for adding accessibility
29support to applications and graphical user interface toolkits. By
30supporting the ATK interfaces, an application or toolkit can be used
31with tools such as screen readers, magnifiers, and alternative input
32devices.
33
34%package -n compat32-%{name}
35Summary: Interfaces for accessibility support.
36Summary(ja): アクセシビリティサポートのためのインタフェース
37Group: System Environment/Libraries
38Requires: atk = %{version}
39
40%description -n compat32-%{name}
41The ATK library provides a set of interfaces for adding accessibility
42support to applications and graphical user interface toolkits. By
43supporting the ATK interfaces, an application or toolkit can be used
44with tools such as screen readers, magnifiers, and alternative input
45devices.
46
47%package devel
48Summary: Accessability Toolkit development files
49Summary(ja): アクセシビリティツールキットの開発用ファイル
50Group: Development/Libraries
51Requires: atk = %{version}
52Requires: glib2-devel >= %{glib2_version}
53
54%description devel
55The atk-devel package includes the static libraries, header files, and
56developer docs for the atk package.
57
58Install atk-devel if you want to develop programs which will use ATK.
59
60%package -n compat32-%{name}-devel
61Summary: Accessability Toolkit development files
62Summary(ja): アクセシビリティツールキットの開発用ファイル
63Group: Development/Libraries
64Requires: %{name}-devel    = %{version}
65Requires: compat32-%{name} = %{version}
66
67%description -n compat32-%{name}-devel
68The atk-devel package includes the static libraries, header files, and
69developer docs for the atk package.
70
71Install atk-devel if you want to develop programs which will use ATK.
72
73%prep
74%setup -q -n atk-%{version}
75
76%build
77%configure --disable-gtk-doc --enable-introspection=yes
78make %{?_smp_mflags}
79
80%install
81rm -rf $RPM_BUILD_ROOT
82
83%makeinstall
84
85%find_lang atk10
86
87# remove unpackaged files
88rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
89
90%clean
91rm -rf $RPM_BUILD_ROOT
92
93%post -p /sbin/ldconfig
94
95%postun -p /sbin/ldconfig
96
97%post -n compat32-%{name} -p /sbin/ldconfig
98
99%postun -n compat32-%{name} -p /sbin/ldconfig
100
101
102%files -f atk10.lang
103%defattr(-, root, root)
104%doc README AUTHORS COPYING ChangeLog
105%{_libdir}/libatk*.so.*
106%{_libdir}/girepository-1.0
107
108%files devel
109%defattr(-, root, root)
110%{_includedir}/*
111%{_libdir}/libatk*.so
112%{_libdir}/pkgconfig/*.pc
113%{_datadir}/gtk-doc/*
114%{_datadir}/gir-1.0
115
116%if %{build_compat32}
117%files -n compat32-%{name}
118%defattr(-, root, root)
119%{_libdir}/libatk*.so.*
120
121%files -n compat32-%{name}-devel
122%defattr(-, root, root)
123%{_libdir}/libatk*.so
124%endif
125
126%changelog
127* Sat Mar 28 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.16.0-1
128- new upstream release
129
130* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.14.0-1
131- new upstream release
132
133* Fri Mar 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.12.0-1
134- new upstream release
135
136* Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.10.0-2
137- rebuild with VineSeed environment
138
139* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.10.0-1
140- new upstream release
141
142* Wed Apr 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.0-1
143- new upstream release
144
145* Wed Sep 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.0-1
146- new upstream release
147
148* Sat Mar 31 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4.0-1
149- new upstream release
150
151* Wed Sep 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.0-1
152- new upstream release
153
154* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.1.92-1
155- new upstream release
156
157* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.1.5-1
158- new upstream release
159
160* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.1.0-1
161- new upstream release
162
163* Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.30.2-1
164- add BuildRequires: gobject-introspection-devel
165- add configure option (--enable-introspection=yes)
166
167* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 1.30.0-2
168- build with rpm-4.8.1-1 for pkg-config file
169
170* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.30.0-1
171- new upstream release
172
173* Fri Sep 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.28.0-1
174- new upstream release
175
176* Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.26.0-1
177- new upstream release
178
179* Mon Sep 22 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.24.0-1
180- new upstream release
181- spec in UTF-8
182
183* Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.22.0-1vl5
184- used %%{?_dist_release}
185
186* Tue Mar 11 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.22.0-0vl1
187- new upstream release
188
189* Sun Nov 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.20.0-0vl1
190- new upstream release
191
192* Wed Apr 25 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.18.0-0vl1
193- new upstream release
194
195* Mon Dec 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.12.4-0vl1
196- new upstream release
197
198* Sat Jul 29 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.12.1-0vl1
199- new upstream release
200
201* Fri Mar 17 2006 NAKAMURA Kenta <kenta@c.csce.kyushu-u.ac.jp> 1.11.3-0vl2
202- added compat32-* packages for x86_64 architecture support
203
204* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.11.3-0vl1
205- new upstream release
206
207* Sun Mar 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.11.2-0vl1
208- new upstream release
209
210* Wed Nov 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10.3-0vl1
211- new upstream release
212
213* Fri May 20 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.10.1-0vl1
214- new upstream release
215
216* Mon Jan 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0-0vl1
217- new upstream release
218
219* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.0-0vl1
220- new upstream release
221
222* Sat May  1 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.1-0vl1
223- new upstream release
224
225* Thu Mar 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-0vl1
226- new upstream release
227
228* Sun Feb 01 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.1-0vl1
229- new upstream release
230- fix kanji code of spec file.
231
232* Thu Sep 04 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.0-0vl1
233- new upstream release
234
235* Mon Sep 01 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.6-0vl1
236- new upstream release
237
238* Tue Jun 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.3-0vl1
239- new upstream release
240
241* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2-0vl1
242- new upstream release
243
244* Sat Jan  4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-0vl1
245- new upstream release
246
247* Wed Dec 25 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-0vl1
248- new upstream release
249
250* Fri Dec 13 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.4-0vl1
251- new upstream release
252- build for Vine Linux
253
254* Wed Jul 31 2002 Owen Taylor <otaylor@redhat.com>
255- Remove fixed-ltmain.sh
256- Version 1.0.3
257
258* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
259- automated rebuild
260
261* Tue Jun 04 2002 Havoc Pennington <hp@redhat.com>
262- rebuild in different environment
263
264* Tue Jun  4 2002 Havoc Pennington <hp@redhat.com>
265- 1.0.2
266
267* Thu May 23 2002 Tim Powers <timp@redhat.com>
268- automated rebuild
269
270* Wed Apr 24 2002 Havoc Pennington <hp@redhat.com>
271 - rebuild in different environment
272
273* Wed Apr  3 2002 Alex Larsson <alexl@redhat.com>
274- Update to version 1.0.1
275
276* Fri Mar  8 2002 Owen Taylor <otaylor@redhat.com>
277- Version 1.0.0
278
279* Mon Feb 25 2002 Alex Larsson <alexl@redhat.com>
280- Update to 0.13
281
282* Thu Feb 21 2002 Alex Larsson <alexl@redhat.com>
283- Bump for rebuild
284
285* Mon Feb 18 2002 Havoc Pennington <hp@redhat.com>
286- rebuild for glib 1.3.14
287
288* Fri Feb 15 2002 Havoc Pennington <hp@redhat.com>
289- add horrible buildrequires hack
290
291* Thu Feb 14 2002 Havoc Pennington <hp@redhat.com>
292- 0.12.90 cvs snap
293
294* Tue Jan 29 2002 Owen Taylor <otaylor@redhat.com>
295- Version 0.10
296
297* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
298- automated rebuild
299
300* Wed Jan  2 2002 Havoc Pennington <hp@redhat.com>
301- new snap 0.8.90
302
303* Sun Nov 25 2001 Havoc Pennington <hp@redhat.com>
304- rebuild with glib hacked to work on 64-bit
305
306* Sun Nov 25 2001 Havoc Pennington <hp@redhat.com>
307- Version 0.7
308- add explicit check for required glib2 version before we do the build,
309  so we don't end up with bad RPMs on --nodeps builds
310
311* Fri Oct 26 2001 Havoc Pennington <hp@redhat.com>
312- rebuild due to hosage on ia64 build system causing link to old glib
313
314* Thu Oct 25 2001 Owen Taylor <otaylor@redhat.com>
315- Version 0.6
316
317* Thu Sep 27 2001 Havoc Pennington <hp@redhat.com>
318- 0.5
319- sync with Owen's version
320
321* Wed Sep 19 2001 Havoc Pennington <hp@redhat.com>
322- 0.4
323- fix requires
324- --enable-static
325- put static libs back in file list
326
327* Mon Sep 10 2001 Havoc Pennington <hp@redhat.com>
328- update to CVS snapshot
329
330* Wed Sep 05 2001 Havoc Pennington <hp@redhat.com>
331- require specific pango version
332- fix ltmain.sh to destroy all relinking BS
333
334* Tue Sep  4 2001 root <root@dhcpd37.meridian.redhat.com>
335- Version 0.2
336
337* Sat Jul 21 2001 Owen Taylor <otaylor@redhat.com>
338- Configure with --disable-gtk-doc
339
340* Tue Jul 10 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
341- Add post- and postun-sections running ldconfig
342
343* Wed Jun 13 2001 Havoc Pennington <hp@redhat.com>
344- 0.2
345
346* Fri May  4 2001 Owen Taylor <otaylor@redhat.com>
347- Initial version
Note: See TracBrowser for help on using the repository browser.