source: projects/specs/trunk/a/atk/atk-vl.spec @ 8353

Revision 8353, 9.4 KB checked in by Takemikaduchi, 10 years ago (diff)

GNOME-3.12.0

Line 
1# Something's not quite right with libtool....
2%define __libtoolize :
3%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
4
5%define glib2_base_version 2.40.0
6%define glib2_version %{glib2_base_version}
7
8Summary: Interfaces for accessibility support.
9Summary(ja): アクセシビリティサポートのためのインタフェース
10Name: atk
11Version: 2.12.0
12Release: 1%{?_dist_release}
13License: LGPL
14Group: System Environment/Libraries
15Source: ftp://ftp.gnome.org/pub/GNOME/sources/atk/2.12/atk-%{version}.tar.xz
16URL: http://developer.gnome.org/projects/gap/
17
18BuildRoot: %{_tmppath}/%{name}-%{version}-root
19
20BuildRequires: glib2-devel >= %{glib2_version}
21BuildRequires: gobject-introspection-devel >= 0.6.7
22
23Vendor: Project Vine
24Distribution: Vine Linux
25Packager: Takemikaduchi
26
27%description
28The ATK library provides a set of interfaces for adding accessibility
29support to applications and graphical user interface toolkits. By
30supporting the ATK interfaces, an application or toolkit can be used
31with tools such as screen readers, magnifiers, and alternative input
32devices.
33
34%package -n compat32-%{name}
35Summary: Interfaces for accessibility support.
36Summary(ja): アクセシビリティサポートのためのインタフェース
37Group: System Environment/Libraries
38Requires: atk = %{version}
39
40%description -n compat32-%{name}
41The ATK library provides a set of interfaces for adding accessibility
42support to applications and graphical user interface toolkits. By
43supporting the ATK interfaces, an application or toolkit can be used
44with tools such as screen readers, magnifiers, and alternative input
45devices.
46
47%package devel
48Summary: Accessability Toolkit development files
49Summary(ja): アクセシビリティツールキットの開発用ファイル
50Group: Development/Libraries
51Requires: atk = %{version}
52Requires: glib2-devel >= %{glib2_version}
53
54%description devel
55The atk-devel package includes the static libraries, header files, and
56developer docs for the atk package.
57
58Install atk-devel if you want to develop programs which will use ATK.
59
60%package -n compat32-%{name}-devel
61Summary: Accessability Toolkit development files
62Summary(ja): アクセシビリティツールキットの開発用ファイル
63Group: Development/Libraries
64Requires: %{name}-devel    = %{version}
65Requires: compat32-%{name} = %{version}
66
67%description -n compat32-%{name}-devel
68The atk-devel package includes the static libraries, header files, and
69developer docs for the atk package.
70
71Install atk-devel if you want to develop programs which will use ATK.
72
73%prep
74%setup -q -n atk-%{version}
75
76%build
77%configure --disable-gtk-doc --enable-introspection=yes
78make %{?_smp_mflags}
79
80%install
81rm -rf $RPM_BUILD_ROOT
82
83%makeinstall
84
85%find_lang atk10
86
87# remove unpackaged files
88rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
89
90%clean
91rm -rf $RPM_BUILD_ROOT
92
93%post -p /sbin/ldconfig
94
95%postun -p /sbin/ldconfig
96
97%post -n compat32-%{name} -p /sbin/ldconfig
98
99%postun -n compat32-%{name} -p /sbin/ldconfig
100
101
102%files -f atk10.lang
103%defattr(-, root, root)
104%doc README AUTHORS COPYING ChangeLog
105%{_libdir}/libatk*.so.*
106%{_libdir}/girepository-1.0
107
108%files devel
109%defattr(-, root, root)
110%{_includedir}/*
111%{_libdir}/libatk*.so
112%{_libdir}/pkgconfig/*.pc
113%{_datadir}/gtk-doc/*
114%{_datadir}/gir-1.0
115
116%if %{build_compat32}
117%files -n compat32-%{name}
118%defattr(-, root, root)
119%{_libdir}/libatk*.so.*
120
121%files -n compat32-%{name}-devel
122%defattr(-, root, root)
123%{_libdir}/libatk*.so
124%endif
125
126%changelog
127* Fri Mar 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.12.0-1
128- new upstream release
129
130* Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.10.0-2
131- rebuild with VineSeed environment
132
133* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.10.0-1
134- new upstream release
135
136* Wed Apr 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.0-1
137- new upstream release
138
139* Wed Sep 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.0-1
140- new upstream release
141
142* Sat Mar 31 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4.0-1
143- new upstream release
144
145* Wed Sep 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.0-1
146- new upstream release
147
148* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.1.92-1
149- new upstream release
150
151* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.1.5-1
152- new upstream release
153
154* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.1.0-1
155- new upstream release
156
157* Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.30.2-1
158- add BuildRequires: gobject-introspection-devel
159- add configure option (--enable-introspection=yes)
160
161* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 1.30.0-2
162- build with rpm-4.8.1-1 for pkg-config file
163
164* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.30.0-1
165- new upstream release
166
167* Fri Sep 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.28.0-1
168- new upstream release
169
170* Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.26.0-1
171- new upstream release
172
173* Mon Sep 22 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.24.0-1
174- new upstream release
175- spec in UTF-8
176
177* Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.22.0-1vl5
178- used %%{?_dist_release}
179
180* Tue Mar 11 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.22.0-0vl1
181- new upstream release
182
183* Sun Nov 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.20.0-0vl1
184- new upstream release
185
186* Wed Apr 25 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.18.0-0vl1
187- new upstream release
188
189* Mon Dec 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.12.4-0vl1
190- new upstream release
191
192* Sat Jul 29 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.12.1-0vl1
193- new upstream release
194
195* Fri Mar 17 2006 NAKAMURA Kenta <kenta@c.csce.kyushu-u.ac.jp> 1.11.3-0vl2
196- added compat32-* packages for x86_64 architecture support
197
198* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.11.3-0vl1
199- new upstream release
200
201* Sun Mar 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.11.2-0vl1
202- new upstream release
203
204* Wed Nov 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10.3-0vl1
205- new upstream release
206
207* Fri May 20 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.10.1-0vl1
208- new upstream release
209
210* Mon Jan 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0-0vl1
211- new upstream release
212
213* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.0-0vl1
214- new upstream release
215
216* Sat May  1 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.1-0vl1
217- new upstream release
218
219* Thu Mar 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-0vl1
220- new upstream release
221
222* Sun Feb 01 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.1-0vl1
223- new upstream release
224- fix kanji code of spec file.
225
226* Thu Sep 04 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.0-0vl1
227- new upstream release
228
229* Mon Sep 01 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.6-0vl1
230- new upstream release
231
232* Tue Jun 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.3-0vl1
233- new upstream release
234
235* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2-0vl1
236- new upstream release
237
238* Sat Jan  4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-0vl1
239- new upstream release
240
241* Wed Dec 25 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-0vl1
242- new upstream release
243
244* Fri Dec 13 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.4-0vl1
245- new upstream release
246- build for Vine Linux
247
248* Wed Jul 31 2002 Owen Taylor <otaylor@redhat.com>
249- Remove fixed-ltmain.sh
250- Version 1.0.3
251
252* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
253- automated rebuild
254
255* Tue Jun 04 2002 Havoc Pennington <hp@redhat.com>
256- rebuild in different environment
257
258* Tue Jun  4 2002 Havoc Pennington <hp@redhat.com>
259- 1.0.2
260
261* Thu May 23 2002 Tim Powers <timp@redhat.com>
262- automated rebuild
263
264* Wed Apr 24 2002 Havoc Pennington <hp@redhat.com>
265 - rebuild in different environment
266
267* Wed Apr  3 2002 Alex Larsson <alexl@redhat.com>
268- Update to version 1.0.1
269
270* Fri Mar  8 2002 Owen Taylor <otaylor@redhat.com>
271- Version 1.0.0
272
273* Mon Feb 25 2002 Alex Larsson <alexl@redhat.com>
274- Update to 0.13
275
276* Thu Feb 21 2002 Alex Larsson <alexl@redhat.com>
277- Bump for rebuild
278
279* Mon Feb 18 2002 Havoc Pennington <hp@redhat.com>
280- rebuild for glib 1.3.14
281
282* Fri Feb 15 2002 Havoc Pennington <hp@redhat.com>
283- add horrible buildrequires hack
284
285* Thu Feb 14 2002 Havoc Pennington <hp@redhat.com>
286- 0.12.90 cvs snap
287
288* Tue Jan 29 2002 Owen Taylor <otaylor@redhat.com>
289- Version 0.10
290
291* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
292- automated rebuild
293
294* Wed Jan  2 2002 Havoc Pennington <hp@redhat.com>
295- new snap 0.8.90
296
297* Sun Nov 25 2001 Havoc Pennington <hp@redhat.com>
298- rebuild with glib hacked to work on 64-bit
299
300* Sun Nov 25 2001 Havoc Pennington <hp@redhat.com>
301- Version 0.7
302- add explicit check for required glib2 version before we do the build,
303  so we don't end up with bad RPMs on --nodeps builds
304
305* Fri Oct 26 2001 Havoc Pennington <hp@redhat.com>
306- rebuild due to hosage on ia64 build system causing link to old glib
307
308* Thu Oct 25 2001 Owen Taylor <otaylor@redhat.com>
309- Version 0.6
310
311* Thu Sep 27 2001 Havoc Pennington <hp@redhat.com>
312- 0.5
313- sync with Owen's version
314
315* Wed Sep 19 2001 Havoc Pennington <hp@redhat.com>
316- 0.4
317- fix requires
318- --enable-static
319- put static libs back in file list
320
321* Mon Sep 10 2001 Havoc Pennington <hp@redhat.com>
322- update to CVS snapshot
323
324* Wed Sep 05 2001 Havoc Pennington <hp@redhat.com>
325- require specific pango version
326- fix ltmain.sh to destroy all relinking BS
327
328* Tue Sep  4 2001 root <root@dhcpd37.meridian.redhat.com>
329- Version 0.2
330
331* Sat Jul 21 2001 Owen Taylor <otaylor@redhat.com>
332- Configure with --disable-gtk-doc
333
334* Tue Jul 10 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
335- Add post- and postun-sections running ldconfig
336
337* Wed Jun 13 2001 Havoc Pennington <hp@redhat.com>
338- 0.2
339
340* Fri May  4 2001 Owen Taylor <otaylor@redhat.com>
341- Initial version
Note: See TracBrowser for help on using the repository browser.