source: projects/specs/trunk/a/atk/atk-vl.spec @ 4650

Revision 4650, 8.8 KB checked in by Takemikaduchi, 13 years ago (diff)

GNOME-3.1.5

Line 
1# Something's not quite right with libtool....
2%define __libtoolize :
3%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
4
5%define glib2_base_version 2.28.0
6%define glib2_version %{glib2_base_version}
7
8Summary: Interfaces for accessibility support.
9Summary(ja): アクセシビリティサポートのためのインタフェース
10Name: atk
11Version: 2.1.5
12Release: 1%{?_dist_release}
13License: LGPL
14Group: System Environment/Libraries
15Source: ftp://ftp.gnome.org/pub/GNOME/sources/atk/2.1/atk-%{version}.tar.xz
16URL: http://developer.gnome.org/projects/gap/
17BuildRoot: %{_tmppath}/%{name}-%{version}-root
18BuildRequires: glib2-devel >= %{glib2_version}
19BuildRequires: gobject-introspection-devel >= 0.6.7
20
21Vendor: Project Vine
22Distribution: Vine Linux
23Packager: Takemikaduchi
24
25%description
26The ATK library provides a set of interfaces for adding accessibility
27support to applications and graphical user interface toolkits. By
28supporting the ATK interfaces, an application or toolkit can be used
29with tools such as screen readers, magnifiers, and alternative input
30devices.
31
32%package -n compat32-%{name}
33Summary: Interfaces for accessibility support.
34Summary(ja): アクセシビリティサポートのためのインタフェース
35Group: System Environment/Libraries
36Requires: atk = %{version}
37
38%description -n compat32-%{name}
39The ATK library provides a set of interfaces for adding accessibility
40support to applications and graphical user interface toolkits. By
41supporting the ATK interfaces, an application or toolkit can be used
42with tools such as screen readers, magnifiers, and alternative input
43devices.
44
45%package devel
46Summary: Accessability Toolkit development files
47Summary(ja): アクセシビリティツールキットの開発用ファイル
48Group: Development/Libraries
49Requires: atk = %{version}
50Requires: glib2-devel >= %{glib2_version}
51
52%description devel
53The atk-devel package includes the static libraries, header files, and
54developer docs for the atk package.
55
56Install atk-devel if you want to develop programs which will use ATK.
57
58%package -n compat32-%{name}-devel
59Summary: Accessability Toolkit development files
60Summary(ja): アクセシビリティツールキットの開発用ファイル
61Group: Development/Libraries
62Requires: %{name}-devel    = %{version}
63Requires: compat32-%{name} = %{version}
64
65%description -n compat32-%{name}-devel
66The atk-devel package includes the static libraries, header files, and
67developer docs for the atk package.
68
69Install atk-devel if you want to develop programs which will use ATK.
70
71%prep
72%setup -q -n atk-%{version}
73
74%build
75#libtoolize --force --copy
76#aclocal
77#autoconf
78%configure --disable-gtk-doc --enable-introspection=yes
79make %{?_smp_mflags}
80
81%install
82rm -rf $RPM_BUILD_ROOT
83
84%makeinstall
85
86%find_lang atk10
87
88# remove unpackaged files
89rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
90
91%clean
92rm -rf $RPM_BUILD_ROOT
93
94%post -p /sbin/ldconfig
95
96%postun -p /sbin/ldconfig
97
98%post -n compat32-%{name} -p /sbin/ldconfig
99
100%postun -n compat32-%{name} -p /sbin/ldconfig
101
102
103%files -f atk10.lang
104%defattr(-, root, root)
105%doc README AUTHORS COPYING ChangeLog
106%{_libdir}/libatk*.so.*
107%{_libdir}/girepository-1.0
108
109%files devel
110%defattr(-, root, root)
111%{_includedir}/*
112%{_libdir}/libatk*.so
113%{_libdir}/pkgconfig/*.pc
114%{_datadir}/gtk-doc/*
115%{_datadir}/gir-1.0
116
117%if %{build_compat32}
118%files -n compat32-%{name}
119%defattr(-, root, root)
120%{_libdir}/libatk*.so.*
121
122%files -n compat32-%{name}-devel
123%defattr(-, root, root)
124%{_libdir}/libatk*.so
125%{_libdir}/pkgconfig/*.pc
126%endif
127
128%changelog
129* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.1.5-1
130- new upstream release
131
132* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.1.0-1
133- new upstream release
134
135* Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.30.2-1
136- add BuildRequires: gobject-introspection-devel
137- add configure option (--enable-introspection=yes)
138
139* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 1.30.0-2
140- build with rpm-4.8.1-1 for pkg-config file
141
142* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.30.0-1
143- new upstream release
144
145* Fri Sep 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.28.0-1
146- new upstream release
147
148* Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.26.0-1
149- new upstream release
150
151* Mon Sep 22 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.24.0-1
152- new upstream release
153- spec in UTF-8
154
155* Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.22.0-1vl5
156- used %%{?_dist_release}
157
158* Tue Mar 11 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.22.0-0vl1
159- new upstream release
160
161* Sun Nov 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.20.0-0vl1
162- new upstream release
163
164* Wed Apr 25 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.18.0-0vl1
165- new upstream release
166
167* Mon Dec 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.12.4-0vl1
168- new upstream release
169
170* Sat Jul 29 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.12.1-0vl1
171- new upstream release
172
173* Fri Mar 17 2006 NAKAMURA Kenta <kenta@c.csce.kyushu-u.ac.jp> 1.11.3-0vl2
174- added compat32-* packages for x86_64 architecture support
175
176* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.11.3-0vl1
177- new upstream release
178
179* Sun Mar 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.11.2-0vl1
180- new upstream release
181
182* Wed Nov 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10.3-0vl1
183- new upstream release
184
185* Fri May 20 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.10.1-0vl1
186- new upstream release
187
188* Mon Jan 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0-0vl1
189- new upstream release
190
191* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.0-0vl1
192- new upstream release
193
194* Sat May  1 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.1-0vl1
195- new upstream release
196
197* Thu Mar 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-0vl1
198- new upstream release
199
200* Sun Feb 01 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.1-0vl1
201- new upstream release
202- fix kanji code of spec file.
203
204* Thu Sep 04 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.0-0vl1
205- new upstream release
206
207* Mon Sep 01 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.6-0vl1
208- new upstream release
209
210* Tue Jun 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.3-0vl1
211- new upstream release
212
213* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2-0vl1
214- new upstream release
215
216* Sat Jan  4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-0vl1
217- new upstream release
218
219* Wed Dec 25 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-0vl1
220- new upstream release
221
222* Fri Dec 13 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.4-0vl1
223- new upstream release
224- build for Vine Linux
225
226* Wed Jul 31 2002 Owen Taylor <otaylor@redhat.com>
227- Remove fixed-ltmain.sh
228- Version 1.0.3
229
230* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
231- automated rebuild
232
233* Tue Jun 04 2002 Havoc Pennington <hp@redhat.com>
234- rebuild in different environment
235
236* Tue Jun  4 2002 Havoc Pennington <hp@redhat.com>
237- 1.0.2
238
239* Thu May 23 2002 Tim Powers <timp@redhat.com>
240- automated rebuild
241
242* Wed Apr 24 2002 Havoc Pennington <hp@redhat.com>
243 - rebuild in different environment
244
245* Wed Apr  3 2002 Alex Larsson <alexl@redhat.com>
246- Update to version 1.0.1
247
248* Fri Mar  8 2002 Owen Taylor <otaylor@redhat.com>
249- Version 1.0.0
250
251* Mon Feb 25 2002 Alex Larsson <alexl@redhat.com>
252- Update to 0.13
253
254* Thu Feb 21 2002 Alex Larsson <alexl@redhat.com>
255- Bump for rebuild
256
257* Mon Feb 18 2002 Havoc Pennington <hp@redhat.com>
258- rebuild for glib 1.3.14
259
260* Fri Feb 15 2002 Havoc Pennington <hp@redhat.com>
261- add horrible buildrequires hack
262
263* Thu Feb 14 2002 Havoc Pennington <hp@redhat.com>
264- 0.12.90 cvs snap
265
266* Tue Jan 29 2002 Owen Taylor <otaylor@redhat.com>
267- Version 0.10
268
269* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
270- automated rebuild
271
272* Wed Jan  2 2002 Havoc Pennington <hp@redhat.com>
273- new snap 0.8.90
274
275* Sun Nov 25 2001 Havoc Pennington <hp@redhat.com>
276- rebuild with glib hacked to work on 64-bit
277
278* Sun Nov 25 2001 Havoc Pennington <hp@redhat.com>
279- Version 0.7
280- add explicit check for required glib2 version before we do the build,
281  so we don't end up with bad RPMs on --nodeps builds
282
283* Fri Oct 26 2001 Havoc Pennington <hp@redhat.com>
284- rebuild due to hosage on ia64 build system causing link to old glib
285
286* Thu Oct 25 2001 Owen Taylor <otaylor@redhat.com>
287- Version 0.6
288
289* Thu Sep 27 2001 Havoc Pennington <hp@redhat.com>
290- 0.5
291- sync with Owen's version
292
293* Wed Sep 19 2001 Havoc Pennington <hp@redhat.com>
294- 0.4
295- fix requires
296- --enable-static
297- put static libs back in file list
298
299* Mon Sep 10 2001 Havoc Pennington <hp@redhat.com>
300- update to CVS snapshot
301
302* Wed Sep 05 2001 Havoc Pennington <hp@redhat.com>
303- require specific pango version
304- fix ltmain.sh to destroy all relinking BS
305
306* Tue Sep  4 2001 root <root@dhcpd37.meridian.redhat.com>
307- Version 0.2
308
309* Sat Jul 21 2001 Owen Taylor <otaylor@redhat.com>
310- Configure with --disable-gtk-doc
311
312* Tue Jul 10 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
313- Add post- and postun-sections running ldconfig
314
315* Wed Jun 13 2001 Havoc Pennington <hp@redhat.com>
316- 0.2
317
318* Fri May  4 2001 Owen Taylor <otaylor@redhat.com>
319- Initial version
Note: See TracBrowser for help on using the repository browser.