source: projects/specs/trunk/a/atk/atk-vl.spec @ 6890

Revision 6890, 9.1 KB checked in by Takemikaduchi, 12 years ago (diff)

GNOME-3.6.0 & Cinnamon-1.6.1

Line 
1# Something's not quite right with libtool....
2%define __libtoolize :
3%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
4
5%define glib2_base_version 2.32.0
6%define glib2_version %{glib2_base_version}
7
8Summary: Interfaces for accessibility support.
9Summary(ja): アクセシビリティサポートのためのインタフェース
10Name: atk
11Version: 2.6.0
12Release: 1%{?_dist_release}
13License: LGPL
14Group: System Environment/Libraries
15Source: ftp://ftp.gnome.org/pub/GNOME/sources/atk/2.6/atk-%{version}.tar.xz
16URL: http://developer.gnome.org/projects/gap/
17BuildRoot: %{_tmppath}/%{name}-%{version}-root
18BuildRequires: glib2-devel >= %{glib2_version}
19BuildRequires: gobject-introspection-devel >= 0.6.7
20
21Vendor: Project Vine
22Distribution: Vine Linux
23Packager: Takemikaduchi
24
25%description
26The ATK library provides a set of interfaces for adding accessibility
27support to applications and graphical user interface toolkits. By
28supporting the ATK interfaces, an application or toolkit can be used
29with tools such as screen readers, magnifiers, and alternative input
30devices.
31
32%package -n compat32-%{name}
33Summary: Interfaces for accessibility support.
34Summary(ja): アクセシビリティサポートのためのインタフェース
35Group: System Environment/Libraries
36Requires: atk = %{version}
37
38%description -n compat32-%{name}
39The ATK library provides a set of interfaces for adding accessibility
40support to applications and graphical user interface toolkits. By
41supporting the ATK interfaces, an application or toolkit can be used
42with tools such as screen readers, magnifiers, and alternative input
43devices.
44
45%package devel
46Summary: Accessability Toolkit development files
47Summary(ja): アクセシビリティツールキットの開発用ファイル
48Group: Development/Libraries
49Requires: atk = %{version}
50Requires: glib2-devel >= %{glib2_version}
51
52%description devel
53The atk-devel package includes the static libraries, header files, and
54developer docs for the atk package.
55
56Install atk-devel if you want to develop programs which will use ATK.
57
58%package -n compat32-%{name}-devel
59Summary: Accessability Toolkit development files
60Summary(ja): アクセシビリティツールキットの開発用ファイル
61Group: Development/Libraries
62Requires: %{name}-devel    = %{version}
63Requires: compat32-%{name} = %{version}
64
65%description -n compat32-%{name}-devel
66The atk-devel package includes the static libraries, header files, and
67developer docs for the atk package.
68
69Install atk-devel if you want to develop programs which will use ATK.
70
71%prep
72%setup -q -n atk-%{version}
73
74%build
75#libtoolize --force --copy
76#aclocal
77#autoconf
78%configure --disable-gtk-doc --enable-introspection=yes
79make %{?_smp_mflags}
80
81%install
82rm -rf $RPM_BUILD_ROOT
83
84%makeinstall
85
86%find_lang atk10
87
88# remove unpackaged files
89rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
90
91%clean
92rm -rf $RPM_BUILD_ROOT
93
94%post -p /sbin/ldconfig
95
96%postun -p /sbin/ldconfig
97
98%post -n compat32-%{name} -p /sbin/ldconfig
99
100%postun -n compat32-%{name} -p /sbin/ldconfig
101
102
103%files -f atk10.lang
104%defattr(-, root, root)
105%doc README AUTHORS COPYING ChangeLog
106%{_libdir}/libatk*.so.*
107%{_libdir}/girepository-1.0
108
109%files devel
110%defattr(-, root, root)
111%{_includedir}/*
112%{_libdir}/libatk*.so
113%{_libdir}/pkgconfig/*.pc
114%{_datadir}/gtk-doc/*
115%{_datadir}/gir-1.0
116
117%if %{build_compat32}
118%files -n compat32-%{name}
119%defattr(-, root, root)
120%{_libdir}/libatk*.so.*
121
122%files -n compat32-%{name}-devel
123%defattr(-, root, root)
124%{_libdir}/libatk*.so
125%endif
126
127%changelog
128* Wed Sep 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.0-1
129- new upstream release
130
131* Sat Mar 31 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4.0-1
132- new upstream release
133
134* Wed Sep 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.0-1
135- new upstream release
136
137* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.1.92-1
138- new upstream release
139
140* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.1.5-1
141- new upstream release
142
143* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.1.0-1
144- new upstream release
145
146* Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.30.2-1
147- add BuildRequires: gobject-introspection-devel
148- add configure option (--enable-introspection=yes)
149
150* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 1.30.0-2
151- build with rpm-4.8.1-1 for pkg-config file
152
153* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.30.0-1
154- new upstream release
155
156* Fri Sep 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.28.0-1
157- new upstream release
158
159* Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.26.0-1
160- new upstream release
161
162* Mon Sep 22 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.24.0-1
163- new upstream release
164- spec in UTF-8
165
166* Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.22.0-1vl5
167- used %%{?_dist_release}
168
169* Tue Mar 11 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.22.0-0vl1
170- new upstream release
171
172* Sun Nov 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.20.0-0vl1
173- new upstream release
174
175* Wed Apr 25 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.18.0-0vl1
176- new upstream release
177
178* Mon Dec 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.12.4-0vl1
179- new upstream release
180
181* Sat Jul 29 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.12.1-0vl1
182- new upstream release
183
184* Fri Mar 17 2006 NAKAMURA Kenta <kenta@c.csce.kyushu-u.ac.jp> 1.11.3-0vl2
185- added compat32-* packages for x86_64 architecture support
186
187* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.11.3-0vl1
188- new upstream release
189
190* Sun Mar 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.11.2-0vl1
191- new upstream release
192
193* Wed Nov 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10.3-0vl1
194- new upstream release
195
196* Fri May 20 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.10.1-0vl1
197- new upstream release
198
199* Mon Jan 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0-0vl1
200- new upstream release
201
202* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.0-0vl1
203- new upstream release
204
205* Sat May  1 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.1-0vl1
206- new upstream release
207
208* Thu Mar 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-0vl1
209- new upstream release
210
211* Sun Feb 01 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.1-0vl1
212- new upstream release
213- fix kanji code of spec file.
214
215* Thu Sep 04 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.0-0vl1
216- new upstream release
217
218* Mon Sep 01 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.6-0vl1
219- new upstream release
220
221* Tue Jun 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.3-0vl1
222- new upstream release
223
224* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2-0vl1
225- new upstream release
226
227* Sat Jan  4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-0vl1
228- new upstream release
229
230* Wed Dec 25 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-0vl1
231- new upstream release
232
233* Fri Dec 13 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.4-0vl1
234- new upstream release
235- build for Vine Linux
236
237* Wed Jul 31 2002 Owen Taylor <otaylor@redhat.com>
238- Remove fixed-ltmain.sh
239- Version 1.0.3
240
241* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
242- automated rebuild
243
244* Tue Jun 04 2002 Havoc Pennington <hp@redhat.com>
245- rebuild in different environment
246
247* Tue Jun  4 2002 Havoc Pennington <hp@redhat.com>
248- 1.0.2
249
250* Thu May 23 2002 Tim Powers <timp@redhat.com>
251- automated rebuild
252
253* Wed Apr 24 2002 Havoc Pennington <hp@redhat.com>
254 - rebuild in different environment
255
256* Wed Apr  3 2002 Alex Larsson <alexl@redhat.com>
257- Update to version 1.0.1
258
259* Fri Mar  8 2002 Owen Taylor <otaylor@redhat.com>
260- Version 1.0.0
261
262* Mon Feb 25 2002 Alex Larsson <alexl@redhat.com>
263- Update to 0.13
264
265* Thu Feb 21 2002 Alex Larsson <alexl@redhat.com>
266- Bump for rebuild
267
268* Mon Feb 18 2002 Havoc Pennington <hp@redhat.com>
269- rebuild for glib 1.3.14
270
271* Fri Feb 15 2002 Havoc Pennington <hp@redhat.com>
272- add horrible buildrequires hack
273
274* Thu Feb 14 2002 Havoc Pennington <hp@redhat.com>
275- 0.12.90 cvs snap
276
277* Tue Jan 29 2002 Owen Taylor <otaylor@redhat.com>
278- Version 0.10
279
280* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
281- automated rebuild
282
283* Wed Jan  2 2002 Havoc Pennington <hp@redhat.com>
284- new snap 0.8.90
285
286* Sun Nov 25 2001 Havoc Pennington <hp@redhat.com>
287- rebuild with glib hacked to work on 64-bit
288
289* Sun Nov 25 2001 Havoc Pennington <hp@redhat.com>
290- Version 0.7
291- add explicit check for required glib2 version before we do the build,
292  so we don't end up with bad RPMs on --nodeps builds
293
294* Fri Oct 26 2001 Havoc Pennington <hp@redhat.com>
295- rebuild due to hosage on ia64 build system causing link to old glib
296
297* Thu Oct 25 2001 Owen Taylor <otaylor@redhat.com>
298- Version 0.6
299
300* Thu Sep 27 2001 Havoc Pennington <hp@redhat.com>
301- 0.5
302- sync with Owen's version
303
304* Wed Sep 19 2001 Havoc Pennington <hp@redhat.com>
305- 0.4
306- fix requires
307- --enable-static
308- put static libs back in file list
309
310* Mon Sep 10 2001 Havoc Pennington <hp@redhat.com>
311- update to CVS snapshot
312
313* Wed Sep 05 2001 Havoc Pennington <hp@redhat.com>
314- require specific pango version
315- fix ltmain.sh to destroy all relinking BS
316
317* Tue Sep  4 2001 root <root@dhcpd37.meridian.redhat.com>
318- Version 0.2
319
320* Sat Jul 21 2001 Owen Taylor <otaylor@redhat.com>
321- Configure with --disable-gtk-doc
322
323* Tue Jul 10 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
324- Add post- and postun-sections running ldconfig
325
326* Wed Jun 13 2001 Havoc Pennington <hp@redhat.com>
327- 0.2
328
329* Fri May  4 2001 Owen Taylor <otaylor@redhat.com>
330- Initial version
Note: See TracBrowser for help on using the repository browser.