source: projects/specs/trunk/a/aspell/aspell-vl.spec @ 521

Revision 521, 12.4 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define _noVersionedDependencies        1
2%define prereq_ge()  %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
3
4Summary: A spelling checker.
5Summary(ja): スペルチェッカ
6Name: aspell
7Version: 0.50.5
8Release: 1%{?_dist_release}
9License: LGPL
10Group: Applications/Text
11URL: http://aspell.net/
12Source0: ftp://ftp.gnu.org/gnu/aspell/aspell-%{version}.tar.gz
13Source2: ftp://ftp.gnu.org/gnu/aspell/aspell-en-0.51-0.tar.bz2
14Source10: %{name}-install.sh
15Source11: %{name}-remove.sh
16Source12: %{name}-init.el
17Source100: aspell.conf
18Patch0: aspell-0.50.5.prefix.patch
19Patch1: aspell-compress-bug.patch
20Buildrequires: gcc-c++
21BuildRoot: %{_tmppath}/%{name}-%{version}-root
22Provides: pspell
23Obsoletes: ispell, pspell
24
25
26%description
27GNU Aspell is a spell checker designed to eventually replace Ispell. It can
28either be used as a library or as an independent spell checker. Its main
29feature is that it does a much better job of coming up with possible
30suggestions than just about any other spell checker out there for the
31English language, including Ispell and Microsoft Word. It also has many
32other technical enhancements over Ispell such as using shared memory for
33dictionaries and intelligently handling personal dictionaries when more
34than one Aspell process is open at once.
35
36
37%package        devel
38Summary: Static libraries and header files for Aspell development.
39Group: Development/Libraries
40Requires: aspell = %{version}-%{release}
41Obsoletes: pspell-devel
42
43%description    devel
44Aspell is a spelling checker. The aspell-devel package includes the
45static libraries and header files needed for Aspell development.
46
47
48%package        el
49Summary: Emacs lisp for aspell
50Group: Applications/Editors/Emacs
51Requires: aspell = %{version}-%{release}
52PreReq: emacsen-common
53
54%description    el
55Aspell is a spelling checker. The aspell-el package includes the
56elisp for using aspell within emacsen.
57
58
59%prep
60rm -rf $RPM_BUILD_ROOT
61%setup -q -n aspell-%{version} -a 2
62%patch0 -p1 -b .prefix
63%patch1 -p0 -b .compress
64
65%build
66%configure
67make
68
69pushd aspell-en-0.51-0
70echo "ASPELL = ../prog/aspell --data-dir=../data" > Makefile
71echo "DEST_DIR = $RPM_BUILD_ROOT" >> Makefile
72echo "WORD_LIST_COMPRESS = ../prog/word-list-compress" >> Makefile
73echo "dictdir = ${RPM_BUILD_ROOT}%{_libdir}/aspell" >> Makefile
74echo "datadir = ${RPM_BUILD_ROOT}%{_datadir}/aspell" >> Makefile
75cat Makefile.pre >> Makefile
76make
77popd
78
79%install
80%makeinstall
81
82mv ${RPM_BUILD_ROOT}%{_datadir}/aspell/ispell ${RPM_BUILD_ROOT}%{_bindir}
83mv ${RPM_BUILD_ROOT}%{_datadir}/aspell/spell ${RPM_BUILD_ROOT}%{_bindir}
84
85rm -f ${RPM_BUILD_ROOT}%{_libdir}/libaspell.la
86rm -f ${RPM_BUILD_ROOT}%{_libdir}/libpspell.la
87
88# Add by H.Irokawa(2004.02.23)
89mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}
90install -m 644 %{SOURCE100} $RPM_BUILD_ROOT%{_sysconfdir}/aspell.conf
91
92mkdir -p $RPM_BUILD_ROOT/usr/share/emacs/site-lisp/aspell
93mkdir -p ${RPM_BUILD_ROOT}%{_prefix}/lib/emacsen-common/packages/install
94mkdir -p ${RPM_BUILD_ROOT}%{_prefix}/lib/emacsen-common/packages/remove
95
96install -m 644 %{SOURCE12} $RPM_BUILD_ROOT/usr/share/emacs/site-lisp/%{name}
97
98# install  script( bytecompile el and install elc , remove )
99
100%_installemacsenscript %{name} %{SOURCE10}
101
102%_removeemacsenscript  %{name} %{SOURCE11}
103
104rm -f $RPM_BUILD_ROOT/usr/share/doc/aspell/manual.aux
105
106pushd aspell-en-0.51-0
107make install
108popd
109
110   
111%post
112/sbin/ldconfig
113
114%post el
115if [ "$1" = 2 ]; then
116
117  %_emacsenPackageRemove %{name}
118
119fi
120
121%_addemacsenlist %{name}
122
123%_emacsenPackageInstall %{name}
124       
125
126%postun
127/sbin/ldconfig
128
129%preun el
130if [ "$1" = 0 ]; then
131
132  %_emacsenPackageRemove %{name}
133
134  %_removeemacsenlist %{name}
135
136fi
137
138
139%clean
140rm -rf $RPM_BUILD_ROOT
141
142%files
143%defattr(-,root,root)
144%config %{_sysconfdir}/aspell.conf
145%doc README TODO
146%doc %{_docdir}/aspell/*
147
148%{_bindir}/*
149%{_libdir}/lib*.so.*
150%{_libdir}/aspell/*
151%{_datadir}/aspell/*
152
153%files          devel
154%defattr(-,root,root)
155/usr/include/aspell.h
156/usr/include/pspell/pspell.h
157%{_libdir}/lib*spell.so
158
159%files          el
160%{_datadir}/emacs/site-lisp/%{name}/
161%{_prefix}/lib/emacsen-common/packages/install/%{name}
162%{_prefix}/lib/emacsen-common/packages/remove/%{name}
163
164%changelog
165* Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 0.50.5-1vl5
166- applied new versioning policy, spec in utf-8
167
168* Sun May 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.50.5-0vl3
169- rebuilt with new toolchain
170
171* Mon Sep 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.50.5-0vl2
172- changed aspell-el Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
173
174* Sun Jul 23 2006 NAKAMURA Kenta <kenta@vinelinux.org> 0.50.5-0vl1
175- upgrade to new upstream
176- drop aspell-0.50.3-gcc33.patch
177- update prefix.patch
178
179* Sat Oct 30 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.50.3-0vl8
180- merged with errata package
181  * Wed Oct  6 2004 IKEDA Katsumi <ikeda@webmasters.gr.jp> 0.50.3-0vl5.1
182  - added aspell-compress-bug.patch (CAN-2004-0548).
183
184* Fri Oct 15 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.50.3-0vl7
185- fixed typo (s/%postun el/%preun el/)
186
187* Fri Oct 15 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.50.3-0vl6
188- split elisp-related files into the aspell-el subpackage
189
190* Thu Mar  4 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.50.3-0vl5
191- add PreReq: emacsen-common
192
193* Mon Feb 23 2004 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 0.50.3-0vl4
194- add /etc/aspell.conf
195- modded aspell-init.el(Japanese blended English spell check)
196
197* Wed Feb 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.50.3-0vl3
198- add %{_bindir}/{ispell,spell} for compatibility script
199- enable site-start.d stuff
200
201* Mon Nov 17 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.50.3-0vl2
202- fixed spec file character code to EUC-JP
203
204* Wed Jun 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.50.3-0vl1
205- build for Vine Linux
206- merge aspell-en
207
208* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
209- rebuilt
210
211* Fri May 30 2003 Joe Orton <jorton@redhat.com> 7:0.50.3-10
212- rebuild again to fix libpspell deps
213
214* Fri May 30 2003 Joe Orton <jorton@redhat.com> 7:0.50.3-9
215- remove ExcludeArch
216
217* Thu May 22 2003 Jeremy Katz <katzj@redhat.com> 7:0.50.3-8
218- fix build with gcc 3.3
219
220* Wed May 22 2003 Adrian Havill <havill@redhat.com> 0.50.3-7
221- require aspell-en for upgrades
222
223* Sun May 11 2003 Jeremy Katz <katzj@redhat.com> 6:0.50.3-6
224- -devel should obsolete pspell-devel
225
226* Tue May  6 2003 Joe Orton <jorton@redhat.com> 0.50.3-5
227- include libpspell.so in devel package
228
229* Wed May  1 2003 Adrian Havill <havill@redhat.com> 0.50.3-4
230- removed .la files
231
232* Wed Apr 16 2003 Adrian Havill <havill@redhat.com> 0.50.3-3
233- Changed the header for provides, obsoletes, epoch
234- fixed config prefix in dirs.h
235
236* Wed Apr 16 2003 Adrian Havill <havill@redhat.com> 0.50.3-1
237- upgrade to 0.50.3
238
239* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
240- rebuilt
241
242* Fri Nov  8 2002 Tim Powers <timp@redhat.com>
243- fix broken pspell epoch dep
244- create $RPM_BUILD_ROOT/usr/bin by hand
245- remove /usr/doc
246- fix hardcoding of /usr/lib so that we can build on x86_64
247
248* Tue Aug 13 2002 Nalin Dahyabhai <nalin@redhat.com> 0.33.7.1-16
249- require pspell and pspell-devel using the proper epoch
250
251* Sat Aug 10 2002 Elliot Lee <sopwith@redhat.com>
252- rebuilt with gcc-3.2 (we hope)
253
254* Mon Jul 22 2002 Tim Powers <timp@redhat.com> 0.33.7.1-14
255- rebuild using gcc-3.2-0.1
256
257* Fri Jun 21 2002 Tim Powers <timp@redhat.com> 0.33.7.1-13
258- automated rebuild
259
260* Thu Jun 13 2002 Trond Eivind Glomsr藷?<teg@redhat.com> 0.33.7.1-12
261- Rebuild to make it work again... #66708
262
263* Thu May 23 2002 Tim Powers <timp@redhat.com>
264- automated rebuild
265
266* Mon May 13 2002 Trond Eivind Glomsr藷?<teg@redhat.com> 0.33.7.1-10
267- Rebuild
268
269* Thu Feb 21 2002 Trond Eivind Glomsr藷?<teg@redhat.com> 0.33.7.1-9
270- Disable evil patch
271
272* Mon Jan 28 2002 Trond Eivind Glomsr藷?<teg@redhat.com> 0.33.7.1-8
273- Build on more archs (doh)
274
275* Tue Jan 22 2002 Trond Eivind Glomsr藷?<teg@redhat.com> 0.33.7.1-7
276- Make it compile with new compiler (evil workaround)
277
278* Wed Jan 16 2002 Trond Eivind Glomsr藷?<teg@redhat.com> 0.33.7.1-5
279- Rebuild
280- Unexclude alpha
281
282* Fri Dec 14 2001 Trond Eivind Glomsr藷?<teg@redhat.com> 0.33.7.1-3
283- Rebuild
284- Don't build on alpha
285
286* Mon Oct 29 2001 Bernhard Rosenkraenzer <bero@redhat.com> 0.33.7.1-2
287- "make it work with gcc 3.1" ;)
288
289* Tue Sep 18 2001 Trond Eivind Glomsr藷?<teg@redhat.com> 0.33.7.1-1
290- 0.33.7.1, which is a "make it work with gcc 3" release
291
292* Wed Sep 12 2001 Tim Powers <timp@redhat.com>
293- rebuild with new gcc and binutils
294
295* Thu Aug  9 2001 Trond Eivind Glomsr藷?<teg@redhat.com> 0.33.7-1
296- 0.33.7 bugfix release. Requested by the author, it fixes
297  coredumps in sug-mode and when not using typo-analyses.
298  It also contains code cleanups so it compiles with -ansi
299- should fix coredump on IA64 (#49746)
300
301* Wed Jul 11 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
302- Add the .la files in the main package - used for dynamic loading
303
304* Sun Jun  3 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
305- 0.33.6.3, which includes the fix made yesterday
306
307* Sat Jun  2 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
308- Make it search for directories in the correct location
309
310* Wed May 30 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
311- No more workarounds at the specfile level
312
313* Tue May 29 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
314- Use custom ltmain.sh to work around buggy bundled libtool
315
316* Sun May 20 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
317- 0.33.6
318- use standard %%configure macro - it works now.
319
320* Fri May 11 2001 Bernhard Rosenkraenzer <bero@redhat.com> 0.33.5-2
321- Rebuild with new libltdl
322
323* Mon Apr 23 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
324- 0.33.5
325
326* Thu Nov 30 2000 Trond Eivind Glomsr藷?<teg@redhat.com>
327- use new emacs init scheme for Emacs and XEmacs
328
329* Wed Nov 22 2000 Trond Eivind Glomsr藷?<teg@redhat.com>
330-  .32.6
331
332* Sat Aug 19 2000 Trond Eivind Glomsr藷?<teg@redhat.com>
333- .32.5 bugfix release (also contains improved documentation),
334  obsolete old patch
335- the compatibility scripts are now part of the package itself
336- clean up build procedure
337- remove manual.aux file from docs (#16424)
338
339* Sun Aug 06 2000 Trond Eivind Glomsr藷?<teg@redhat.com>
340- .32.1 bugfix release, obsolete old patch
341- rename to 0.32.1
342- add patch from author to change his email address
343- add spell and ispell compatibility scripts
344
345* Fri Aug 04 2000 Trond Eivind Glomsr藷?<teg@redhat.com>
346- rebuild
347
348* Tue Aug 01 2000 Trond Eivind Glomsr藷?<teg@redhat.com>
349- remember to obsolete ispell
350- build the Canadian and British dictionaries here now,
351  as part of the main package. Same package names and
352  descriptions.
353
354* Mon Jul 24 2000 Trond Eivind Glomsr藷?<teg@redhat.com>
355- .32
356- remove old patches, add a patch since namespace isn't
357  polluted as much anymore (as opposed to older toolchain)
358
359* Wed Jul 19 2000 Trond Eivind Glomsr藷?<teg@redhat.com>
360- rebuild
361
362* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
363- automatic rebuild
364
365* Tue Jul  4 2000 Jakub Jelinek <jakub@redhat.com>
366- Rebuild with new C++
367
368* Fri Jun 30 2000 Trond Eivind Glomsr藷?<teg@redhat.com>
369- use RPM_OPT_FLAGS, not just -O0
370- dont include .la-files
371
372* Fri Jun 23 2000 Trond Eivind Glomsr藷?<teg@redhat.com>
373- excludearch ia64
374
375* Fri Jun 23 2000 Trond Eivind Glomsr藷?<teg@redhat.com>
376- patch to work around compiler bug(?) wrt. inline functions
377- use CFLAGS and CXXFLAGS
378- set them to -O0 to work around YACB
379- copy libtool files for IA64 support
380
381* Sun Jun 18 2000 Trond Eivind Glomsr藷?<teg@redhat.com>
382- update to .31.1. My patch was upstreamed and is no longer needed.
383- new patch added so DESTDIR works properly
384
385* Fri Jun 16 2000 Trond Eivind Glomsr藷?<teg@redhat.com>
386- (this entry includes some old ones...)
387- update to .31
388- added patch to make it compile with a pickier compiler
389- include /usr/share/pspell
390
391* Mon May 1 2000 Tim Powers <timp@redhat.com>
392- updated to .30.1
393- used build fixes from Ryan Weaver's 0.30.1-1 package on sourceforge
394- updated URL, download/ftp location
395- removed redundant define's at top of spec file
396
397* Thu Jul 8 1999 Tim Powers <timp@redhat.com>
398- built for Powertools 6.1
399- removed %serial definitions from spec file to make versioning
400  consistant with the other packages we ship.
401- changed build root path
402- general spec file cleanups
403
404* Tue Mar  2 1999 Ryan Weaver <ryanw@infohwy.com>
405  [aspell-.27.2-2]
406- Changes from .27.1 to .27.2 (Mar 1, 1999)
407- Fixed a major bug that caused aspell to dump core when used
408  without any arguments
409- Fixed another major bug that caused aspell to do nothing when used
410  in interactive mode.
411- Added an option to exit in Aspell's interactive mode.
412- Removed some old documentation files from the distribution.
413- Minor changes on to the section on using Aspell with egcs.
414- Minor changes to remove -Wall warnings.
Note: See TracBrowser for help on using the repository browser.