source: projects/specs/trunk/a/aspell/aspell-vl.spec @ 10476

Revision 10476, 14.9 KB checked in by tomop, 8 years ago (diff)

aspell-0.60.6.1-2

Line 
1%define _noVersionedDependencies        1
2
3%define ver 0.60.6.1
4%define rel 2
5
6Summary:         A spelling checker.
7Summary(ja):     スペルチェッカ
8Name:            aspell
9Version:         %{ver}
10Release:         %{rel}%{?_dist_release}
11License:         LGPL
12Group:           Applications/Text
13URL:             http://aspell.net/
14Vendor:          Project Vine
15Distribution:    Vine Linux
16
17Source0:         ftp://ftp.gnu.org/gnu/aspell/aspell-%{version}.tar.gz
18Source10:        %{name}-install.sh
19Source11:        %{name}-remove.sh
20Source12:        %{name}-init.el
21Source100:       aspell.conf
22Patch1003:       aspell-0.60.3-install_info.patch
23Patch1005:       aspell-0.60.5-fileconflict.patch
24Patch1007:       aspell-0.60.5-pspell_conf.patch
25Patch1008:       aspell-0.60.6-zero.patch
26Patch1009:       aspell-0.60.6-mp.patch
27
28BuildRequires:   gcc-c++ gettext ncurses-devel pkgconfig
29BuildRequires:   chrpath
30Requires(post):  %{_syssbindir}/install-info
31Requires(preun): %{_syssbindir}/install-info
32BuildRoot:       %{_tmppath}/%{name}-%{version}-root
33Provides:        pspell
34Obsoletes:       ispell, pspell
35
36
37%description
38GNU Aspell is a spell checker designed to eventually replace Ispell. It can
39either be used as a library or as an independent spell checker. Its main
40feature is that it does a much better job of coming up with possible
41suggestions than just about any other spell checker out there for the
42English language, including Ispell and Microsoft Word. It also has many
43other technical enhancements over Ispell such as using shared memory for
44dictionaries and intelligently handling personal dictionaries when more
45than one Aspell process is open at once.
46
47
48%package        devel
49Summary: Static libraries and header files for Aspell development.
50Group: Development/Libraries
51Requires: aspell = %{version}-%{release}
52Obsoletes: pspell-devel
53
54%description    devel
55Aspell is a spelling checker. The aspell-devel package includes the
56static libraries and header files needed for Aspell development.
57
58
59%package        el
60Summary: Emacs lisp for aspell
61Group: Applications/Editors/Emacs
62Requires: aspell = %{version}-%{release}
63Requires: emacsen-common
64
65%description    el
66Aspell is a spelling checker. The aspell-el package includes the
67elisp for using aspell within emacsen.
68
69
70%prep
71%setup -q
72%patch1003 -p1 -b .iinfo
73%patch1005 -p1 -b .fc
74%patch1007 -p1 -b .mlib
75%patch1008 -p1 -b .zero
76%patch1009 -p1 -b .ai
77iconv -f windows-1252 -t utf-8 manual/aspell.info -o manual/aspell.info.aux
78mv manual/aspell.info.aux manual/aspell.info
79
80%build
81%configure --disable-rpath
82make %{?_smp_mflags}
83cp scripts/aspell-import examples/aspell-import
84chmod 644 examples/aspell-import
85cp manual/aspell-import.1 examples/aspell-import.1
86
87
88%install
89rm -rf %{buildroot}
90%makeinstall
91
92mv %{buildroot}%{_libdir}/aspell-*/ispell %{buildroot}%{_bindir}
93mv %{buildroot}%{_libdir}/aspell-*/spell %{buildroot}%{_bindir}
94
95chrpath --delete %{buildroot}%{_libdir}/aspell-0.60//nroff-filter.so
96chrpath --delete %{buildroot}%{_libdir}/aspell-0.60//sgml-filter.so
97chrpath --delete %{buildroot}%{_libdir}/aspell-0.60//context-filter.so
98chrpath --delete %{buildroot}%{_libdir}/aspell-0.60//email-filter.so
99chrpath --delete %{buildroot}%{_libdir}/aspell-0.60//tex-filter.so
100chrpath --delete %{buildroot}%{_libdir}/aspell-0.60//texinfo-filter.so
101chrpath --delete %{buildroot}%{_bindir}/aspell
102chrpath --delete %{buildroot}%{_libdir}/libpspell.so.*
103
104rm -f %{buildroot}%{_libdir}/libaspell.la
105rm -f %{buildroot}%{_libdir}/libpspell.la
106rm -f %{buildroot}%{_libdir}/aspell-0.60/*-filter.la
107rm -f %{buildroot}%{_bindir}/aspell-import
108rm -f %{buildroot}%{_mandir}/man1/aspell-import.1*
109
110
111# Add by H.Irokawa(2004.02.23)
112mkdir -p %{buildroot}%{_sysconfdir}
113install -m 644 %{SOURCE100} %{buildroot}%{_sysconfdir}/aspell.conf
114
115mkdir -p $RPM_BUILD_ROOT/usr/share/emacs/site-lisp/aspell
116mkdir -p %{buildroot}%{_prefix}/lib/emacsen-common/packages/install
117mkdir -p %{buildroot}%{_prefix}/lib/emacsen-common/packages/remove
118
119install -m 644 %{SOURCE12} %{buildroot}/usr/share/emacs/site-lisp/%{name}
120
121# install  script( bytecompile el and install elc , remove )
122
123%_installemacsenscript %{name} %{SOURCE10}
124
125%_removeemacsenscript  %{name} %{SOURCE11}
126
127rm -f $RPM_BUILD_ROOT/usr/share/doc/aspell/manual.aux
128
129%find_lang %{name}
130   
131%post
132/sbin/ldconfig
133# info
134if [ "$1" = 0 ] ; then
135%{_syssbindir}/install-info %{_infodir}/aspell.info.gz %{_infodir}/dir
136fi
137
138%post devel
139/sbin/ldconfig
140# info
141if [ "$1" = 0 ] ; then
142%{_syssbindir}/install-info %{_infodir}/aspell-dev.info.gz %{_infodir}/dir
143fi
144
145%post el
146if [ "$1" = 2 ]; then
147
148  %_emacsenPackageRemove %{name}
149
150fi
151
152%_addemacsenlist %{name}
153
154%_emacsenPackageInstall %{name}
155       
156
157%postun
158/sbin/ldconfig
159
160%preun
161if [ $1 = 0 ]; then
162%{_syssbindir}/install-info --delete %{_infodir}/aspell.info.gz %{_infodir}/dir
163fi
164
165%preun devel
166if [ $1 = 0 ]; then
167%{_syssbindir}/install-info --delete %{_infodir}/aspell-dev.info.gz %{_infodir}/dir
168fi
169
170%preun el
171if [ "$1" = 0 ]; then
172
173  %_emacsenPackageRemove %{name}
174
175  %_removeemacsenlist %{name}
176
177fi
178
179
180%clean
181rm -rf %{buildroot}
182
183%files -f %{name}.lang
184%defattr(-,root,root)
185%config(noreplace) %{_sysconfdir}/aspell.conf
186%doc README TODO COPYING examples/aspell-import examples/aspell-import.1
187%dir %{_libdir}/aspell-0.60
188%{_bindir}/a*
189%{_bindir}/ispell
190%{_bindir}/pr*
191%{_bindir}/run-with-aspell
192%{_bindir}/spell
193%{_bindir}/word-list-compress
194%{_libdir}/lib*.so.*
195%{_libdir}/aspell-0.60/*
196%{_infodir}/aspell.*
197%{_mandir}/man1/aspell.1.*
198%{_mandir}/man1/run-with-aspell.1*
199%{_mandir}/man1/word-list-compress.1*
200%{_mandir}/man1/prezip-bin.1.*
201
202%files          devel
203%defattr(-,root,root)
204%{_bindir}/pspell-config
205%{_includedir}/aspell.h
206%{_includedir}/pspell
207%{_infodir}/aspell-dev.info*
208%{_libdir}/lib*spell.so
209%{_libdir}/pkgconfig/aspell.pc
210%{_mandir}/man1/pspell-config.1*
211
212%files          el
213%{_datadir}/emacs/site-lisp/%{name}/
214%{_prefix}/lib/emacsen-common/packages/install/%{name}
215%{_prefix}/lib/emacsen-common/packages/remove/%{name}
216
217%changelog
218* Fri Jul  1 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.60.6.1-2
219- rebuilt with new toolchain.
220
221* Tue Mar 06 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.60.6.1-1
222- updated to 0.60.6.1
223- import Patch1009 from Fedora
224
225* Tue May  3 2011 IWAI, Masaharu <iwai@alib.jp> 0.60.6-2
226- update aspell.conf (Source100)
227
228* Sat Apr 16 2011 IWAI, Masaharu <iwai@alib.jp> 0.60.6-1
229- new upstream release
230- sync Fedora 0.60.6-14
231 - split English dictionary package: create aspell-en package
232 - drop unnecessary patches
233  - prefix patch (Patch0)
234  - fix compress patch (Patch1)
235 - add some patches (Patch1003, 1005, 1007, 1008)
236 - create aspell.pc file
237 - update files
238 - add post, preun scripts for info file
239 - add Requires(post,preun) for installing info file
240- noreplace aspell.conf
241
242* Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 0.50.5-1vl5
243- applied new versioning policy, spec in utf-8
244
245* Sun May 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.50.5-0vl3
246- rebuilt with new toolchain
247
248* Mon Sep 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.50.5-0vl2
249- changed aspell-el Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
250
251* Sun Jul 23 2006 NAKAMURA Kenta <kenta@vinelinux.org> 0.50.5-0vl1
252- upgrade to new upstream
253- drop aspell-0.50.3-gcc33.patch
254- update prefix.patch
255
256* Sat Oct 30 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.50.3-0vl8
257- merged with errata package
258  * Wed Oct  6 2004 IKEDA Katsumi <ikeda@webmasters.gr.jp> 0.50.3-0vl5.1
259  - added aspell-compress-bug.patch (CAN-2004-0548).
260
261* Fri Oct 15 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.50.3-0vl7
262- fixed typo (s/%postun el/%preun el/)
263
264* Fri Oct 15 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.50.3-0vl6
265- split elisp-related files into the aspell-el subpackage
266
267* Thu Mar  4 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.50.3-0vl5
268- add PreReq: emacsen-common
269
270* Mon Feb 23 2004 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 0.50.3-0vl4
271- add /etc/aspell.conf
272- modded aspell-init.el(Japanese blended English spell check)
273
274* Wed Feb 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.50.3-0vl3
275- add %{_bindir}/{ispell,spell} for compatibility script
276- enable site-start.d stuff
277
278* Mon Nov 17 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.50.3-0vl2
279- fixed spec file character code to EUC-JP
280
281* Wed Jun 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.50.3-0vl1
282- build for Vine Linux
283- merge aspell-en
284
285* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
286- rebuilt
287
288* Fri May 30 2003 Joe Orton <jorton@redhat.com> 7:0.50.3-10
289- rebuild again to fix libpspell deps
290
291* Fri May 30 2003 Joe Orton <jorton@redhat.com> 7:0.50.3-9
292- remove ExcludeArch
293
294* Thu May 22 2003 Jeremy Katz <katzj@redhat.com> 7:0.50.3-8
295- fix build with gcc 3.3
296
297* Thu May 22 2003 Adrian Havill <havill@redhat.com> 0.50.3-7
298- require aspell-en for upgrades
299
300* Sun May 11 2003 Jeremy Katz <katzj@redhat.com> 6:0.50.3-6
301- -devel should obsolete pspell-devel
302
303* Tue May  6 2003 Joe Orton <jorton@redhat.com> 0.50.3-5
304- include libpspell.so in devel package
305
306* Thu May  1 2003 Adrian Havill <havill@redhat.com> 0.50.3-4
307- removed .la files
308
309* Wed Apr 16 2003 Adrian Havill <havill@redhat.com> 0.50.3-3
310- Changed the header for provides, obsoletes, epoch
311- fixed config prefix in dirs.h
312
313* Wed Apr 16 2003 Adrian Havill <havill@redhat.com> 0.50.3-1
314- upgrade to 0.50.3
315
316* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
317- rebuilt
318
319* Fri Nov  8 2002 Tim Powers <timp@redhat.com>
320- fix broken pspell epoch dep
321- create $RPM_BUILD_ROOT/usr/bin by hand
322- remove /usr/doc
323- fix hardcoding of /usr/lib so that we can build on x86_64
324
325* Tue Aug 13 2002 Nalin Dahyabhai <nalin@redhat.com> 0.33.7.1-16
326- require pspell and pspell-devel using the proper epoch
327
328* Sat Aug 10 2002 Elliot Lee <sopwith@redhat.com>
329- rebuilt with gcc-3.2 (we hope)
330
331* Mon Jul 22 2002 Tim Powers <timp@redhat.com> 0.33.7.1-14
332- rebuild using gcc-3.2-0.1
333
334* Fri Jun 21 2002 Tim Powers <timp@redhat.com> 0.33.7.1-13
335- automated rebuild
336
337* Thu Jun 13 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.33.7.1-12
338- Rebuild to make it work again... #66708
339
340* Thu May 23 2002 Tim Powers <timp@redhat.com>
341- automated rebuild
342
343* Mon May 13 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.33.7.1-10
344- Rebuild
345
346* Thu Feb 21 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.33.7.1-9
347- Disable evil patch
348
349* Mon Jan 28 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.33.7.1-8
350- Build on more archs (doh)
351
352* Tue Jan 22 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.33.7.1-7
353- Make it compile with new compiler (evil workaround)
354
355* Wed Jan 16 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.33.7.1-5
356- Rebuild
357- Unexclude alpha
358
359* Fri Dec 14 2001 Trond Eivind Glomsrød <teg@redhat.com> 0.33.7.1-3
360- Rebuild
361- Don't build on alpha
362
363* Mon Oct 29 2001 Bernhard Rosenkraenzer <bero@redhat.com> 0.33.7.1-2
364- "make it work with gcc 3.1" ;)
365
366* Tue Sep 18 2001 Trond Eivind Glomsrød <teg@redhat.com> 0.33.7.1-1
367- 0.33.7.1, which is a "make it work with gcc 3" release
368
369* Wed Sep 12 2001 Tim Powers <timp@redhat.com>
370- rebuild with new gcc and binutils
371
372* Thu Aug  9 2001 Trond Eivind Glomsrød <teg@redhat.com> 0.33.7-1
373- 0.33.7 bugfix release. Requested by the author, it fixes
374  coredumps in sug-mode and when not using typo-analyses.
375  It also contains code cleanups so it compiles with -ansi
376- should fix coredump on IA64 (#49746)
377
378* Wed Jul 11 2001 Trond Eivind Glomsrød <teg@redhat.com>
379- Add the .la files in the main package - used for dynamic loading
380
381* Sun Jun  3 2001 Trond Eivind Glomsrød <teg@redhat.com>
382- 0.33.6.3, which includes the fix made yesterday
383
384* Sat Jun  2 2001 Trond Eivind Glomsrød <teg@redhat.com>
385- Make it search for directories in the correct location
386
387* Wed May 30 2001 Trond Eivind Glomsrød <teg@redhat.com>
388- No more workarounds at the specfile level
389
390* Tue May 29 2001 Trond Eivind Glomsrød <teg@redhat.com>
391- Use custom ltmain.sh to work around buggy bundled libtool
392
393* Sun May 20 2001 Trond Eivind Glomsrød <teg@redhat.com>
394- 0.33.6
395- use standard %%configure macro - it works now.
396
397* Fri May 11 2001 Bernhard Rosenkraenzer <bero@redhat.com> 0.33.5-2
398- Rebuild with new libltdl
399
400* Mon Apr 23 2001 Trond Eivind Glomsrød <teg@redhat.com>
401- 0.33.5
402
403* Thu Nov 30 2000 Trond Eivind Glomsrød <teg@redhat.com>
404- use new emacs init scheme for Emacs and XEmacs
405
406* Wed Nov 22 2000 Trond Eivind Glomsrød <teg@redhat.com>
407-  .32.6
408
409* Sat Aug 19 2000 Trond Eivind Glomsrød <teg@redhat.com>
410- .32.5 bugfix release (also contains improved documentation),
411  obsolete old patch
412- the compatibility scripts are now part of the package itself
413- clean up build procedure
414- remove manual.aux file from docs (#16424)
415
416* Sun Aug 06 2000 Trond Eivind Glomsrød <teg@redhat.com>
417- .32.1 bugfix release, obsolete old patch
418- rename to 0.32.1
419- add patch from author to change his email address
420- add spell and ispell compatibility scripts
421
422* Fri Aug 04 2000 Trond Eivind Glomsrød <teg@redhat.com>
423- rebuild
424
425* Tue Aug 01 2000 Trond Eivind Glomsrød <teg@redhat.com>
426- remember to obsolete ispell
427- build the Canadian and British dictionaries here now,
428  as part of the main package. Same package names and
429  descriptions.
430
431* Mon Jul 24 2000 Trond Eivind Glomsrød <teg@redhat.com>
432- .32
433- remove old patches, add a patch since namespace isn't
434  polluted as much anymore (as opposed to older toolchain)
435
436* Wed Jul 19 2000 Trond Eivind Glomsrød <teg@redhat.com>
437- rebuild
438
439* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
440- automatic rebuild
441
442* Tue Jul  4 2000 Jakub Jelinek <jakub@redhat.com>
443- Rebuild with new C++
444
445* Fri Jun 30 2000 Trond Eivind Glomsrød <teg@redhat.com>
446- use RPM_OPT_FLAGS, not just -O0
447- dont include .la-files
448
449* Fri Jun 23 2000 Trond Eivind Glomsrød <teg@redhat.com>
450- excludearch ia64
451
452* Fri Jun 23 2000 Trond Eivind Glomsrød <teg@redhat.com>
453- patch to work around compiler bug(?) wrt. inline functions
454- use CFLAGS and CXXFLAGS
455- set them to -O0 to work around YACB
456- copy libtool files for IA64 support
457
458* Sun Jun 18 2000 Trond Eivind Glomsrød <teg@redhat.com>
459- update to .31.1. My patch was upstreamed and is no longer needed.
460- new patch added so DESTDIR works properly
461
462* Fri Jun 16 2000 Trond Eivind Glomsrød <teg@redhat.com>
463- (this entry includes some old ones...)
464- update to .31
465- added patch to make it compile with a pickier compiler
466- include /usr/share/pspell
467
468* Mon May 1 2000 Tim Powers <timp@redhat.com>
469- updated to .30.1
470- used build fixes from Ryan Weaver's 0.30.1-1 package on sourceforge
471- updated URL, download/ftp location
472- removed redundant define's at top of spec file
473
474* Thu Jul 8 1999 Tim Powers <timp@redhat.com>
475- built for Powertools 6.1
476- removed %serial definitions from spec file to make versioning
477  consistant with the other packages we ship.
478- changed build root path
479- general spec file cleanups
480
481* Tue Mar  2 1999 Ryan Weaver <ryanw@infohwy.com>
482  [aspell-.27.2-2]
483- Changes from .27.1 to .27.2 (Mar 1, 1999)
484- Fixed a major bug that caused aspell to dump core when used
485  without any arguments
486- Fixed another major bug that caused aspell to do nothing when used
487  in interactive mode.
488- Added an option to exit in Aspell's interactive mode.
489- Removed some old documentation files from the distribution.
490- Minor changes on to the section on using Aspell with egcs.
491- Minor changes to remove -Wall warnings.
Note: See TracBrowser for help on using the repository browser.