source: projects/specs/trunk/a/aspell/aspell-vl.spec @ 5850

Revision 5850, 14.7 KB checked in by shaolin, 12 years ago (diff)
  • aspell: new upstream version
  • hunspell: new upstream version
RevLine 
[521]1%define _noVersionedDependencies        1
2
[5850]3%define ver 0.60.6.1
4%define rel 1
[3500]5
[5850]6Summary:         A spelling checker.
7Summary(ja):     スペルチェッカ
8Name:            aspell
9Version:         %{ver}
10Release:         %{rel}%{?_dist_release}
11License:         LGPL
12Group:           Applications/Text
13URL:             http://aspell.net/
14Source0:         ftp://ftp.gnu.org/gnu/aspell/aspell-%{version}.tar.gz
15Source10:        %{name}-install.sh
16Source11:        %{name}-remove.sh
17Source12:        %{name}-init.el
18Source100:       aspell.conf
19Patch1003:       aspell-0.60.3-install_info.patch
20Patch1005:       aspell-0.60.5-fileconflict.patch
21Patch1007:       aspell-0.60.5-pspell_conf.patch
22Patch1008:       aspell-0.60.6-zero.patch
23Patch1009:       aspell-0.60.6-mp.patch
[3500]24
[5850]25BuildRequires:   gcc-c++ gettext ncurses-devel pkgconfig
26BuildRequires:   chrpath
27Requires(post):  %{_syssbindir}/install-info
28Requires(preun): %{_syssbindir}/install-info
29BuildRoot:       %{_tmppath}/%{name}-%{version}-root
30Provides:        pspell
31Obsoletes:       ispell, pspell
[521]32
33
34%description
35GNU Aspell is a spell checker designed to eventually replace Ispell. It can
36either be used as a library or as an independent spell checker. Its main
37feature is that it does a much better job of coming up with possible
38suggestions than just about any other spell checker out there for the
39English language, including Ispell and Microsoft Word. It also has many
40other technical enhancements over Ispell such as using shared memory for
41dictionaries and intelligently handling personal dictionaries when more
42than one Aspell process is open at once.
43
44
45%package        devel
46Summary: Static libraries and header files for Aspell development.
47Group: Development/Libraries
48Requires: aspell = %{version}-%{release}
49Obsoletes: pspell-devel
50
51%description    devel
52Aspell is a spelling checker. The aspell-devel package includes the
53static libraries and header files needed for Aspell development.
54
55
56%package        el
57Summary: Emacs lisp for aspell
58Group: Applications/Editors/Emacs
59Requires: aspell = %{version}-%{release}
[3500]60Requires: emacsen-common
[521]61
62%description    el
63Aspell is a spelling checker. The aspell-el package includes the
64elisp for using aspell within emacsen.
65
66
67%prep
[3500]68%setup -q
69%patch1003 -p1 -b .iinfo
70%patch1005 -p1 -b .fc
71%patch1007 -p1 -b .mlib
72%patch1008 -p1 -b .zero
[5850]73%patch1009 -p1 -b .ai
[3500]74iconv -f windows-1252 -t utf-8 manual/aspell.info -o manual/aspell.info.aux
75mv manual/aspell.info.aux manual/aspell.info
[521]76
77%build
[5850]78%configure --disable-rpath
[3500]79make %{?_smp_mflags}
[5850]80cp scripts/aspell-import examples/aspell-import
81chmod 644 examples/aspell-import
82cp manual/aspell-import.1 examples/aspell-import.1
[521]83
[5850]84
[521]85%install
[5850]86rm -rf %{buildroot}
[521]87%makeinstall
88
[5850]89mv %{buildroot}%{_libdir}/aspell-*/ispell %{buildroot}%{_bindir}
90mv %{buildroot}%{_libdir}/aspell-*/spell %{buildroot}%{_bindir}
[521]91
[5850]92chrpath --delete %{buildroot}%{_libdir}/aspell-0.60//nroff-filter.so
93chrpath --delete %{buildroot}%{_libdir}/aspell-0.60//sgml-filter.so
94chrpath --delete %{buildroot}%{_libdir}/aspell-0.60//context-filter.so
95chrpath --delete %{buildroot}%{_libdir}/aspell-0.60//email-filter.so
96chrpath --delete %{buildroot}%{_libdir}/aspell-0.60//tex-filter.so
97chrpath --delete %{buildroot}%{_libdir}/aspell-0.60//texinfo-filter.so
98chrpath --delete %{buildroot}%{_bindir}/aspell
99chrpath --delete %{buildroot}%{_libdir}/libpspell.so.*
[521]100
[5850]101rm -f %{buildroot}%{_libdir}/libaspell.la
102rm -f %{buildroot}%{_libdir}/libpspell.la
103rm -f %{buildroot}%{_libdir}/aspell-0.60/*-filter.la
104rm -f %{buildroot}%{_bindir}/aspell-import
105rm -f %{buildroot}%{_mandir}/man1/aspell-import.1*
106
107
[521]108# Add by H.Irokawa(2004.02.23)
[5850]109mkdir -p %{buildroot}%{_sysconfdir}
110install -m 644 %{SOURCE100} %{buildroot}%{_sysconfdir}/aspell.conf
[521]111
112mkdir -p $RPM_BUILD_ROOT/usr/share/emacs/site-lisp/aspell
[5850]113mkdir -p %{buildroot}%{_prefix}/lib/emacsen-common/packages/install
114mkdir -p %{buildroot}%{_prefix}/lib/emacsen-common/packages/remove
[521]115
[5850]116install -m 644 %{SOURCE12} %{buildroot}/usr/share/emacs/site-lisp/%{name}
[521]117
118# install  script( bytecompile el and install elc , remove )
119
120%_installemacsenscript %{name} %{SOURCE10}
121
122%_removeemacsenscript  %{name} %{SOURCE11}
123
124rm -f $RPM_BUILD_ROOT/usr/share/doc/aspell/manual.aux
125
[3500]126%find_lang %{name}
[521]127   
128%post
129/sbin/ldconfig
[3500]130# info
131if [ "$1" = 0 ] ; then
132%{_syssbindir}/install-info %{_infodir}/aspell.info.gz %{_infodir}/dir
133fi
[521]134
[3500]135%post devel
136/sbin/ldconfig
137# info
138if [ "$1" = 0 ] ; then
139%{_syssbindir}/install-info %{_infodir}/aspell-dev.info.gz %{_infodir}/dir
140fi
141
[521]142%post el
143if [ "$1" = 2 ]; then
144
145  %_emacsenPackageRemove %{name}
146
147fi
148
149%_addemacsenlist %{name}
150
151%_emacsenPackageInstall %{name}
152       
153
154%postun
155/sbin/ldconfig
156
[3500]157%preun
158if [ $1 = 0 ]; then
159%{_syssbindir}/install-info --delete %{_infodir}/aspell.info.gz %{_infodir}/dir
160fi
161
162%preun devel
163if [ $1 = 0 ]; then
164%{_syssbindir}/install-info --delete %{_infodir}/aspell-dev.info.gz %{_infodir}/dir
165fi
166
[521]167%preun el
168if [ "$1" = 0 ]; then
169
170  %_emacsenPackageRemove %{name}
171
172  %_removeemacsenlist %{name}
173
174fi
175
176
177%clean
[5850]178rm -rf %{buildroot}
[521]179
[3500]180%files -f %{name}.lang
[521]181%defattr(-,root,root)
[3500]182%config(noreplace) %{_sysconfdir}/aspell.conf
[5850]183%doc README TODO COPYING examples/aspell-import examples/aspell-import.1
184%dir %{_libdir}/aspell-0.60
185%{_bindir}/a*
186%{_bindir}/ispell
187%{_bindir}/pr*
188%{_bindir}/run-with-aspell
189%{_bindir}/spell
190%{_bindir}/word-list-compress
[521]191%{_libdir}/lib*.so.*
[5850]192%{_libdir}/aspell-0.60/*
193%{_infodir}/aspell.*
194%{_mandir}/man1/aspell.1.*
195%{_mandir}/man1/run-with-aspell.1*
196%{_mandir}/man1/word-list-compress.1*
197%{_mandir}/man1/prezip-bin.1.*
[521]198
199%files          devel
200%defattr(-,root,root)
[5850]201%{_bindir}/pspell-config
[3500]202%{_includedir}/aspell.h
203%{_includedir}/pspell
204%{_infodir}/aspell-dev.info*
[521]205%{_libdir}/lib*spell.so
[3500]206%{_libdir}/pkgconfig/aspell.pc
[5850]207%{_mandir}/man1/pspell-config.1*
[521]208
209%files          el
210%{_datadir}/emacs/site-lisp/%{name}/
211%{_prefix}/lib/emacsen-common/packages/install/%{name}
212%{_prefix}/lib/emacsen-common/packages/remove/%{name}
213
214%changelog
[5850]215* Tue Mar 06 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.60.6.1-1
216- updated to 0.60.6.1
217- import Patch1009 from Fedora
218
[3772]219* Tue May  3 2011 IWAI, Masaharu <iwai@alib.jp> 0.60.6-2
220- update aspell.conf (Source100)
221
[3500]222* Sat Apr 16 2011 IWAI, Masaharu <iwai@alib.jp> 0.60.6-1
223- new upstream release
224- sync Fedora 0.60.6-14
225 - split English dictionary package: create aspell-en package
226 - drop unnecessary patches
227  - prefix patch (Patch0)
228  - fix compress patch (Patch1)
229 - add some patches (Patch1003, 1005, 1007, 1008)
230 - create aspell.pc file
231 - update files
232 - add post, preun scripts for info file
233 - add Requires(post,preun) for installing info file
234- noreplace aspell.conf
235
[521]236* Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 0.50.5-1vl5
237- applied new versioning policy, spec in utf-8
238
239* Sun May 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.50.5-0vl3
240- rebuilt with new toolchain
241
242* Mon Sep 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.50.5-0vl2
243- changed aspell-el Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
244
245* Sun Jul 23 2006 NAKAMURA Kenta <kenta@vinelinux.org> 0.50.5-0vl1
246- upgrade to new upstream
247- drop aspell-0.50.3-gcc33.patch
248- update prefix.patch
249
250* Sat Oct 30 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.50.3-0vl8
251- merged with errata package
252  * Wed Oct  6 2004 IKEDA Katsumi <ikeda@webmasters.gr.jp> 0.50.3-0vl5.1
253  - added aspell-compress-bug.patch (CAN-2004-0548).
254
255* Fri Oct 15 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.50.3-0vl7
256- fixed typo (s/%postun el/%preun el/)
257
258* Fri Oct 15 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.50.3-0vl6
259- split elisp-related files into the aspell-el subpackage
260
261* Thu Mar  4 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.50.3-0vl5
262- add PreReq: emacsen-common
263
264* Mon Feb 23 2004 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 0.50.3-0vl4
265- add /etc/aspell.conf
266- modded aspell-init.el(Japanese blended English spell check)
267
268* Wed Feb 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.50.3-0vl3
269- add %{_bindir}/{ispell,spell} for compatibility script
270- enable site-start.d stuff
271
272* Mon Nov 17 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.50.3-0vl2
273- fixed spec file character code to EUC-JP
274
275* Wed Jun 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.50.3-0vl1
276- build for Vine Linux
277- merge aspell-en
278
279* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
280- rebuilt
281
282* Fri May 30 2003 Joe Orton <jorton@redhat.com> 7:0.50.3-10
283- rebuild again to fix libpspell deps
284
285* Fri May 30 2003 Joe Orton <jorton@redhat.com> 7:0.50.3-9
286- remove ExcludeArch
287
288* Thu May 22 2003 Jeremy Katz <katzj@redhat.com> 7:0.50.3-8
289- fix build with gcc 3.3
290
291* Wed May 22 2003 Adrian Havill <havill@redhat.com> 0.50.3-7
292- require aspell-en for upgrades
293
294* Sun May 11 2003 Jeremy Katz <katzj@redhat.com> 6:0.50.3-6
295- -devel should obsolete pspell-devel
296
297* Tue May  6 2003 Joe Orton <jorton@redhat.com> 0.50.3-5
298- include libpspell.so in devel package
299
300* Wed May  1 2003 Adrian Havill <havill@redhat.com> 0.50.3-4
301- removed .la files
302
303* Wed Apr 16 2003 Adrian Havill <havill@redhat.com> 0.50.3-3
304- Changed the header for provides, obsoletes, epoch
305- fixed config prefix in dirs.h
306
307* Wed Apr 16 2003 Adrian Havill <havill@redhat.com> 0.50.3-1
308- upgrade to 0.50.3
309
310* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
311- rebuilt
312
313* Fri Nov  8 2002 Tim Powers <timp@redhat.com>
314- fix broken pspell epoch dep
315- create $RPM_BUILD_ROOT/usr/bin by hand
316- remove /usr/doc
317- fix hardcoding of /usr/lib so that we can build on x86_64
318
319* Tue Aug 13 2002 Nalin Dahyabhai <nalin@redhat.com> 0.33.7.1-16
320- require pspell and pspell-devel using the proper epoch
321
322* Sat Aug 10 2002 Elliot Lee <sopwith@redhat.com>
323- rebuilt with gcc-3.2 (we hope)
324
325* Mon Jul 22 2002 Tim Powers <timp@redhat.com> 0.33.7.1-14
326- rebuild using gcc-3.2-0.1
327
328* Fri Jun 21 2002 Tim Powers <timp@redhat.com> 0.33.7.1-13
329- automated rebuild
330
[3500]331* Thu Jun 13 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.33.7.1-12
[521]332- Rebuild to make it work again... #66708
333
334* Thu May 23 2002 Tim Powers <timp@redhat.com>
335- automated rebuild
336
[3500]337* Mon May 13 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.33.7.1-10
[521]338- Rebuild
339
[3500]340* Thu Feb 21 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.33.7.1-9
[521]341- Disable evil patch
342
[3500]343* Mon Jan 28 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.33.7.1-8
[521]344- Build on more archs (doh)
345
[3500]346* Tue Jan 22 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.33.7.1-7
[521]347- Make it compile with new compiler (evil workaround)
348
[3500]349* Wed Jan 16 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.33.7.1-5
[521]350- Rebuild
351- Unexclude alpha
352
[3500]353* Fri Dec 14 2001 Trond Eivind Glomsrød <teg@redhat.com> 0.33.7.1-3
[521]354- Rebuild
355- Don't build on alpha
356
357* Mon Oct 29 2001 Bernhard Rosenkraenzer <bero@redhat.com> 0.33.7.1-2
358- "make it work with gcc 3.1" ;)
359
[3500]360* Tue Sep 18 2001 Trond Eivind Glomsrød <teg@redhat.com> 0.33.7.1-1
[521]361- 0.33.7.1, which is a "make it work with gcc 3" release
362
363* Wed Sep 12 2001 Tim Powers <timp@redhat.com>
364- rebuild with new gcc and binutils
365
[3500]366* Thu Aug  9 2001 Trond Eivind Glomsrød <teg@redhat.com> 0.33.7-1
[521]367- 0.33.7 bugfix release. Requested by the author, it fixes
368  coredumps in sug-mode and when not using typo-analyses.
369  It also contains code cleanups so it compiles with -ansi
370- should fix coredump on IA64 (#49746)
371
[3500]372* Wed Jul 11 2001 Trond Eivind Glomsrød <teg@redhat.com>
[521]373- Add the .la files in the main package - used for dynamic loading
374
[3500]375* Sun Jun  3 2001 Trond Eivind Glomsrød <teg@redhat.com>
[521]376- 0.33.6.3, which includes the fix made yesterday
377
[3500]378* Sat Jun  2 2001 Trond Eivind Glomsrød <teg@redhat.com>
[521]379- Make it search for directories in the correct location
380
[3500]381* Wed May 30 2001 Trond Eivind Glomsrød <teg@redhat.com>
[521]382- No more workarounds at the specfile level
383
[3500]384* Tue May 29 2001 Trond Eivind Glomsrød <teg@redhat.com>
[521]385- Use custom ltmain.sh to work around buggy bundled libtool
386
[3500]387* Sun May 20 2001 Trond Eivind Glomsrød <teg@redhat.com>
[521]388- 0.33.6
389- use standard %%configure macro - it works now.
390
391* Fri May 11 2001 Bernhard Rosenkraenzer <bero@redhat.com> 0.33.5-2
392- Rebuild with new libltdl
393
[3500]394* Mon Apr 23 2001 Trond Eivind Glomsrød <teg@redhat.com>
[521]395- 0.33.5
396
[3500]397* Thu Nov 30 2000 Trond Eivind Glomsrød <teg@redhat.com>
[521]398- use new emacs init scheme for Emacs and XEmacs
399
[3500]400* Wed Nov 22 2000 Trond Eivind Glomsrød <teg@redhat.com>
[521]401-  .32.6
402
[3500]403* Sat Aug 19 2000 Trond Eivind Glomsrød <teg@redhat.com>
[521]404- .32.5 bugfix release (also contains improved documentation),
405  obsolete old patch
406- the compatibility scripts are now part of the package itself
407- clean up build procedure
408- remove manual.aux file from docs (#16424)
409
[3500]410* Sun Aug 06 2000 Trond Eivind Glomsrød <teg@redhat.com>
[521]411- .32.1 bugfix release, obsolete old patch
412- rename to 0.32.1
413- add patch from author to change his email address
414- add spell and ispell compatibility scripts
415
[3500]416* Fri Aug 04 2000 Trond Eivind Glomsrød <teg@redhat.com>
[521]417- rebuild
418
[3500]419* Tue Aug 01 2000 Trond Eivind Glomsrød <teg@redhat.com>
[521]420- remember to obsolete ispell
421- build the Canadian and British dictionaries here now,
422  as part of the main package. Same package names and
423  descriptions.
424
[3500]425* Mon Jul 24 2000 Trond Eivind Glomsrød <teg@redhat.com>
[521]426- .32
427- remove old patches, add a patch since namespace isn't
428  polluted as much anymore (as opposed to older toolchain)
429
[3500]430* Wed Jul 19 2000 Trond Eivind Glomsrød <teg@redhat.com>
[521]431- rebuild
432
433* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
434- automatic rebuild
435
436* Tue Jul  4 2000 Jakub Jelinek <jakub@redhat.com>
437- Rebuild with new C++
438
[3500]439* Fri Jun 30 2000 Trond Eivind Glomsrød <teg@redhat.com>
[521]440- use RPM_OPT_FLAGS, not just -O0
441- dont include .la-files
442
[3500]443* Fri Jun 23 2000 Trond Eivind Glomsrød <teg@redhat.com>
[521]444- excludearch ia64
445
[3500]446* Fri Jun 23 2000 Trond Eivind Glomsrød <teg@redhat.com>
[521]447- patch to work around compiler bug(?) wrt. inline functions
448- use CFLAGS and CXXFLAGS
449- set them to -O0 to work around YACB
450- copy libtool files for IA64 support
451
[3500]452* Sun Jun 18 2000 Trond Eivind Glomsrød <teg@redhat.com>
[521]453- update to .31.1. My patch was upstreamed and is no longer needed.
454- new patch added so DESTDIR works properly
455
[3500]456* Fri Jun 16 2000 Trond Eivind Glomsrød <teg@redhat.com>
[521]457- (this entry includes some old ones...)
458- update to .31
459- added patch to make it compile with a pickier compiler
460- include /usr/share/pspell
461
462* Mon May 1 2000 Tim Powers <timp@redhat.com>
463- updated to .30.1
464- used build fixes from Ryan Weaver's 0.30.1-1 package on sourceforge
465- updated URL, download/ftp location
466- removed redundant define's at top of spec file
467
468* Thu Jul 8 1999 Tim Powers <timp@redhat.com>
469- built for Powertools 6.1
470- removed %serial definitions from spec file to make versioning
471  consistant with the other packages we ship.
472- changed build root path
473- general spec file cleanups
474
475* Tue Mar  2 1999 Ryan Weaver <ryanw@infohwy.com>
476  [aspell-.27.2-2]
477- Changes from .27.1 to .27.2 (Mar 1, 1999)
478- Fixed a major bug that caused aspell to dump core when used
479  without any arguments
480- Fixed another major bug that caused aspell to do nothing when used
481  in interactive mode.
482- Added an option to exit in Aspell's interactive mode.
483- Removed some old documentation files from the distribution.
484- Minor changes on to the section on using Aspell with egcs.
485- Minor changes to remove -Wall warnings.
Note: See TracBrowser for help on using the repository browser.