source: projects/specs/trunk/a/aspell/aspell-vl.spec @ 3500

Revision 3500, 13.3 KB checked in by iwaim, 13 years ago (diff)

aspell-0.60.6-1

RevLine 
[521]1%define _noVersionedDependencies        1
[3500]2%define prereq_ge()  %(LC_ALL="C" rpm -q --queryformat 'Requires:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
[521]3
[3500]4%define ver 0.60.6
5%define rel 1
6
[521]7Summary: A spelling checker.
8Summary(ja): スペルチェッカ
9Name: aspell
[3500]10Version: %{ver}
11Release: %{rel}%{?_dist_release}
[521]12License: LGPL
13Group: Applications/Text
14URL: http://aspell.net/
15Source0: ftp://ftp.gnu.org/gnu/aspell/aspell-%{version}.tar.gz
16Source10: %{name}-install.sh
17Source11: %{name}-remove.sh
18Source12: %{name}-init.el
19Source100: aspell.conf
[3500]20Patch1003: aspell-0.60.3-install_info.patch
21Patch1005: aspell-0.60.5-fileconflict.patch
22Patch1007: aspell-0.60.5-pspell_conf.patch
23Patch1008: aspell-0.60.6-zero.patch
24
[521]25Buildrequires: gcc-c++
[3500]26Requires(post,preun): %{_syssbindir}/install-info
[521]27BuildRoot: %{_tmppath}/%{name}-%{version}-root
28Provides: pspell
29Obsoletes: ispell, pspell
30
31
32%description
33GNU Aspell is a spell checker designed to eventually replace Ispell. It can
34either be used as a library or as an independent spell checker. Its main
35feature is that it does a much better job of coming up with possible
36suggestions than just about any other spell checker out there for the
37English language, including Ispell and Microsoft Word. It also has many
38other technical enhancements over Ispell such as using shared memory for
39dictionaries and intelligently handling personal dictionaries when more
40than one Aspell process is open at once.
41
42
43%package        devel
44Summary: Static libraries and header files for Aspell development.
45Group: Development/Libraries
46Requires: aspell = %{version}-%{release}
47Obsoletes: pspell-devel
48
49%description    devel
50Aspell is a spelling checker. The aspell-devel package includes the
51static libraries and header files needed for Aspell development.
52
53
54%package        el
55Summary: Emacs lisp for aspell
56Group: Applications/Editors/Emacs
57Requires: aspell = %{version}-%{release}
[3500]58Requires: emacsen-common
[521]59
60%description    el
61Aspell is a spelling checker. The aspell-el package includes the
62elisp for using aspell within emacsen.
63
64
65%prep
66rm -rf $RPM_BUILD_ROOT
[3500]67%setup -q
68%patch1003 -p1 -b .iinfo
69%patch1005 -p1 -b .fc
70%patch1007 -p1 -b .mlib
71%patch1008 -p1 -b .zero
72iconv -f windows-1252 -t utf-8 manual/aspell.info -o manual/aspell.info.aux
73mv manual/aspell.info.aux manual/aspell.info
[521]74
75%build
76%configure
[3500]77make %{?_smp_mflags}
[521]78
79%install
80%makeinstall
81
[3500]82mv ${RPM_BUILD_ROOT}%{_libdir}/aspell-*/ispell ${RPM_BUILD_ROOT}%{_bindir}
83mv ${RPM_BUILD_ROOT}%{_libdir}/aspell-*/spell ${RPM_BUILD_ROOT}%{_bindir}
[521]84
85rm -f ${RPM_BUILD_ROOT}%{_libdir}/libaspell.la
86rm -f ${RPM_BUILD_ROOT}%{_libdir}/libpspell.la
[3500]87rm -f ${RPM_BUILD_ROOT}%{_libdir}/aspell-0.60/*-filter.la
[521]88
89# Add by H.Irokawa(2004.02.23)
90mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}
91install -m 644 %{SOURCE100} $RPM_BUILD_ROOT%{_sysconfdir}/aspell.conf
92
93mkdir -p $RPM_BUILD_ROOT/usr/share/emacs/site-lisp/aspell
94mkdir -p ${RPM_BUILD_ROOT}%{_prefix}/lib/emacsen-common/packages/install
95mkdir -p ${RPM_BUILD_ROOT}%{_prefix}/lib/emacsen-common/packages/remove
96
97install -m 644 %{SOURCE12} $RPM_BUILD_ROOT/usr/share/emacs/site-lisp/%{name}
98
99# install  script( bytecompile el and install elc , remove )
100
101%_installemacsenscript %{name} %{SOURCE10}
102
103%_removeemacsenscript  %{name} %{SOURCE11}
104
105rm -f $RPM_BUILD_ROOT/usr/share/doc/aspell/manual.aux
106
[3500]107%find_lang %{name}
[521]108   
109%post
110/sbin/ldconfig
[3500]111# info
112if [ "$1" = 0 ] ; then
113%{_syssbindir}/install-info %{_infodir}/aspell.info.gz %{_infodir}/dir
114fi
[521]115
[3500]116%post devel
117/sbin/ldconfig
118# info
119if [ "$1" = 0 ] ; then
120%{_syssbindir}/install-info %{_infodir}/aspell-dev.info.gz %{_infodir}/dir
121fi
122
[521]123%post el
124if [ "$1" = 2 ]; then
125
126  %_emacsenPackageRemove %{name}
127
128fi
129
130%_addemacsenlist %{name}
131
132%_emacsenPackageInstall %{name}
133       
134
135%postun
136/sbin/ldconfig
137
[3500]138%preun
139if [ $1 = 0 ]; then
140%{_syssbindir}/install-info --delete %{_infodir}/aspell.info.gz %{_infodir}/dir
141fi
142
143%preun devel
144if [ $1 = 0 ]; then
145%{_syssbindir}/install-info --delete %{_infodir}/aspell-dev.info.gz %{_infodir}/dir
146fi
147
[521]148%preun el
149if [ "$1" = 0 ]; then
150
151  %_emacsenPackageRemove %{name}
152
153  %_removeemacsenlist %{name}
154
155fi
156
157
158%clean
159rm -rf $RPM_BUILD_ROOT
160
[3500]161%files -f %{name}.lang
[521]162%defattr(-,root,root)
[3500]163%config(noreplace) %{_sysconfdir}/aspell.conf
[521]164%doc README TODO
165%{_bindir}/*
166%{_libdir}/lib*.so.*
[3500]167%{_libdir}/aspell-*
168%{_infodir}/aspell.info*
169%{_mandir}/man1/*
[521]170
171%files          devel
172%defattr(-,root,root)
[3500]173%{_includedir}/aspell.h
174%{_includedir}/pspell
175%{_infodir}/aspell-dev.info*
[521]176%{_libdir}/lib*spell.so
[3500]177%{_libdir}/pkgconfig/aspell.pc
[521]178
179%files          el
180%{_datadir}/emacs/site-lisp/%{name}/
181%{_prefix}/lib/emacsen-common/packages/install/%{name}
182%{_prefix}/lib/emacsen-common/packages/remove/%{name}
183
184%changelog
[3500]185* Sat Apr 16 2011 IWAI, Masaharu <iwai@alib.jp> 0.60.6-1
186- new upstream release
187- sync Fedora 0.60.6-14
188 - split English dictionary package: create aspell-en package
189 - drop unnecessary patches
190  - prefix patch (Patch0)
191  - fix compress patch (Patch1)
192 - add some patches (Patch1003, 1005, 1007, 1008)
193 - create aspell.pc file
194 - update files
195 - add post, preun scripts for info file
196 - add Requires(post,preun) for installing info file
197- noreplace aspell.conf
198
[521]199* Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 0.50.5-1vl5
200- applied new versioning policy, spec in utf-8
201
202* Sun May 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.50.5-0vl3
203- rebuilt with new toolchain
204
205* Mon Sep 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.50.5-0vl2
206- changed aspell-el Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
207
208* Sun Jul 23 2006 NAKAMURA Kenta <kenta@vinelinux.org> 0.50.5-0vl1
209- upgrade to new upstream
210- drop aspell-0.50.3-gcc33.patch
211- update prefix.patch
212
213* Sat Oct 30 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.50.3-0vl8
214- merged with errata package
215  * Wed Oct  6 2004 IKEDA Katsumi <ikeda@webmasters.gr.jp> 0.50.3-0vl5.1
216  - added aspell-compress-bug.patch (CAN-2004-0548).
217
218* Fri Oct 15 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.50.3-0vl7
219- fixed typo (s/%postun el/%preun el/)
220
221* Fri Oct 15 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.50.3-0vl6
222- split elisp-related files into the aspell-el subpackage
223
224* Thu Mar  4 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.50.3-0vl5
225- add PreReq: emacsen-common
226
227* Mon Feb 23 2004 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 0.50.3-0vl4
228- add /etc/aspell.conf
229- modded aspell-init.el(Japanese blended English spell check)
230
231* Wed Feb 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.50.3-0vl3
232- add %{_bindir}/{ispell,spell} for compatibility script
233- enable site-start.d stuff
234
235* Mon Nov 17 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.50.3-0vl2
236- fixed spec file character code to EUC-JP
237
238* Wed Jun 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.50.3-0vl1
239- build for Vine Linux
240- merge aspell-en
241
242* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
243- rebuilt
244
245* Fri May 30 2003 Joe Orton <jorton@redhat.com> 7:0.50.3-10
246- rebuild again to fix libpspell deps
247
248* Fri May 30 2003 Joe Orton <jorton@redhat.com> 7:0.50.3-9
249- remove ExcludeArch
250
251* Thu May 22 2003 Jeremy Katz <katzj@redhat.com> 7:0.50.3-8
252- fix build with gcc 3.3
253
254* Wed May 22 2003 Adrian Havill <havill@redhat.com> 0.50.3-7
255- require aspell-en for upgrades
256
257* Sun May 11 2003 Jeremy Katz <katzj@redhat.com> 6:0.50.3-6
258- -devel should obsolete pspell-devel
259
260* Tue May  6 2003 Joe Orton <jorton@redhat.com> 0.50.3-5
261- include libpspell.so in devel package
262
263* Wed May  1 2003 Adrian Havill <havill@redhat.com> 0.50.3-4
264- removed .la files
265
266* Wed Apr 16 2003 Adrian Havill <havill@redhat.com> 0.50.3-3
267- Changed the header for provides, obsoletes, epoch
268- fixed config prefix in dirs.h
269
270* Wed Apr 16 2003 Adrian Havill <havill@redhat.com> 0.50.3-1
271- upgrade to 0.50.3
272
273* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
274- rebuilt
275
276* Fri Nov  8 2002 Tim Powers <timp@redhat.com>
277- fix broken pspell epoch dep
278- create $RPM_BUILD_ROOT/usr/bin by hand
279- remove /usr/doc
280- fix hardcoding of /usr/lib so that we can build on x86_64
281
282* Tue Aug 13 2002 Nalin Dahyabhai <nalin@redhat.com> 0.33.7.1-16
283- require pspell and pspell-devel using the proper epoch
284
285* Sat Aug 10 2002 Elliot Lee <sopwith@redhat.com>
286- rebuilt with gcc-3.2 (we hope)
287
288* Mon Jul 22 2002 Tim Powers <timp@redhat.com> 0.33.7.1-14
289- rebuild using gcc-3.2-0.1
290
291* Fri Jun 21 2002 Tim Powers <timp@redhat.com> 0.33.7.1-13
292- automated rebuild
293
[3500]294* Thu Jun 13 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.33.7.1-12
[521]295- Rebuild to make it work again... #66708
296
297* Thu May 23 2002 Tim Powers <timp@redhat.com>
298- automated rebuild
299
[3500]300* Mon May 13 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.33.7.1-10
[521]301- Rebuild
302
[3500]303* Thu Feb 21 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.33.7.1-9
[521]304- Disable evil patch
305
[3500]306* Mon Jan 28 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.33.7.1-8
[521]307- Build on more archs (doh)
308
[3500]309* Tue Jan 22 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.33.7.1-7
[521]310- Make it compile with new compiler (evil workaround)
311
[3500]312* Wed Jan 16 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.33.7.1-5
[521]313- Rebuild
314- Unexclude alpha
315
[3500]316* Fri Dec 14 2001 Trond Eivind Glomsrød <teg@redhat.com> 0.33.7.1-3
[521]317- Rebuild
318- Don't build on alpha
319
320* Mon Oct 29 2001 Bernhard Rosenkraenzer <bero@redhat.com> 0.33.7.1-2
321- "make it work with gcc 3.1" ;)
322
[3500]323* Tue Sep 18 2001 Trond Eivind Glomsrød <teg@redhat.com> 0.33.7.1-1
[521]324- 0.33.7.1, which is a "make it work with gcc 3" release
325
326* Wed Sep 12 2001 Tim Powers <timp@redhat.com>
327- rebuild with new gcc and binutils
328
[3500]329* Thu Aug  9 2001 Trond Eivind Glomsrød <teg@redhat.com> 0.33.7-1
[521]330- 0.33.7 bugfix release. Requested by the author, it fixes
331  coredumps in sug-mode and when not using typo-analyses.
332  It also contains code cleanups so it compiles with -ansi
333- should fix coredump on IA64 (#49746)
334
[3500]335* Wed Jul 11 2001 Trond Eivind Glomsrød <teg@redhat.com>
[521]336- Add the .la files in the main package - used for dynamic loading
337
[3500]338* Sun Jun  3 2001 Trond Eivind Glomsrød <teg@redhat.com>
[521]339- 0.33.6.3, which includes the fix made yesterday
340
[3500]341* Sat Jun  2 2001 Trond Eivind Glomsrød <teg@redhat.com>
[521]342- Make it search for directories in the correct location
343
[3500]344* Wed May 30 2001 Trond Eivind Glomsrød <teg@redhat.com>
[521]345- No more workarounds at the specfile level
346
[3500]347* Tue May 29 2001 Trond Eivind Glomsrød <teg@redhat.com>
[521]348- Use custom ltmain.sh to work around buggy bundled libtool
349
[3500]350* Sun May 20 2001 Trond Eivind Glomsrød <teg@redhat.com>
[521]351- 0.33.6
352- use standard %%configure macro - it works now.
353
354* Fri May 11 2001 Bernhard Rosenkraenzer <bero@redhat.com> 0.33.5-2
355- Rebuild with new libltdl
356
[3500]357* Mon Apr 23 2001 Trond Eivind Glomsrød <teg@redhat.com>
[521]358- 0.33.5
359
[3500]360* Thu Nov 30 2000 Trond Eivind Glomsrød <teg@redhat.com>
[521]361- use new emacs init scheme for Emacs and XEmacs
362
[3500]363* Wed Nov 22 2000 Trond Eivind Glomsrød <teg@redhat.com>
[521]364-  .32.6
365
[3500]366* Sat Aug 19 2000 Trond Eivind Glomsrød <teg@redhat.com>
[521]367- .32.5 bugfix release (also contains improved documentation),
368  obsolete old patch
369- the compatibility scripts are now part of the package itself
370- clean up build procedure
371- remove manual.aux file from docs (#16424)
372
[3500]373* Sun Aug 06 2000 Trond Eivind Glomsrød <teg@redhat.com>
[521]374- .32.1 bugfix release, obsolete old patch
375- rename to 0.32.1
376- add patch from author to change his email address
377- add spell and ispell compatibility scripts
378
[3500]379* Fri Aug 04 2000 Trond Eivind Glomsrød <teg@redhat.com>
[521]380- rebuild
381
[3500]382* Tue Aug 01 2000 Trond Eivind Glomsrød <teg@redhat.com>
[521]383- remember to obsolete ispell
384- build the Canadian and British dictionaries here now,
385  as part of the main package. Same package names and
386  descriptions.
387
[3500]388* Mon Jul 24 2000 Trond Eivind Glomsrød <teg@redhat.com>
[521]389- .32
390- remove old patches, add a patch since namespace isn't
391  polluted as much anymore (as opposed to older toolchain)
392
[3500]393* Wed Jul 19 2000 Trond Eivind Glomsrød <teg@redhat.com>
[521]394- rebuild
395
396* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
397- automatic rebuild
398
399* Tue Jul  4 2000 Jakub Jelinek <jakub@redhat.com>
400- Rebuild with new C++
401
[3500]402* Fri Jun 30 2000 Trond Eivind Glomsrød <teg@redhat.com>
[521]403- use RPM_OPT_FLAGS, not just -O0
404- dont include .la-files
405
[3500]406* Fri Jun 23 2000 Trond Eivind Glomsrød <teg@redhat.com>
[521]407- excludearch ia64
408
[3500]409* Fri Jun 23 2000 Trond Eivind Glomsrød <teg@redhat.com>
[521]410- patch to work around compiler bug(?) wrt. inline functions
411- use CFLAGS and CXXFLAGS
412- set them to -O0 to work around YACB
413- copy libtool files for IA64 support
414
[3500]415* Sun Jun 18 2000 Trond Eivind Glomsrød <teg@redhat.com>
[521]416- update to .31.1. My patch was upstreamed and is no longer needed.
417- new patch added so DESTDIR works properly
418
[3500]419* Fri Jun 16 2000 Trond Eivind Glomsrød <teg@redhat.com>
[521]420- (this entry includes some old ones...)
421- update to .31
422- added patch to make it compile with a pickier compiler
423- include /usr/share/pspell
424
425* Mon May 1 2000 Tim Powers <timp@redhat.com>
426- updated to .30.1
427- used build fixes from Ryan Weaver's 0.30.1-1 package on sourceforge
428- updated URL, download/ftp location
429- removed redundant define's at top of spec file
430
431* Thu Jul 8 1999 Tim Powers <timp@redhat.com>
432- built for Powertools 6.1
433- removed %serial definitions from spec file to make versioning
434  consistant with the other packages we ship.
435- changed build root path
436- general spec file cleanups
437
438* Tue Mar  2 1999 Ryan Weaver <ryanw@infohwy.com>
439  [aspell-.27.2-2]
440- Changes from .27.1 to .27.2 (Mar 1, 1999)
441- Fixed a major bug that caused aspell to dump core when used
442  without any arguments
443- Fixed another major bug that caused aspell to do nothing when used
444  in interactive mode.
445- Added an option to exit in Aspell's interactive mode.
446- Removed some old documentation files from the distribution.
447- Minor changes on to the section on using Aspell with egcs.
448- Minor changes to remove -Wall warnings.
Note: See TracBrowser for help on using the repository browser.