source: projects/specs/trunk/a/arts/arts-vl.spec @ 521

Revision 521, 13.8 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define beta 0
2%define alsa 1
3%define run_test 0
4%define make_cvs 1
5
6Name: arts
7Summary: aRts (analog realtime synthesizer) - the KDE sound system
8Epoch: 1
9Version: 1.5.10
10%if %{beta}
11Release: 0.%{beta}%{?_dist_release}
12%else
13Release: 2%{?_dist_release}
14%endif
15License: LGPLv2
16Group: System Environment/Daemons
17
18%if %{beta}
19Source: ftp://ftp.kde.org/pub/kde/unstable/%{version}-%{beta}/src/%{name}-%{version}-%{beta}.tar.bz2
20%else
21Source: ftp://ftp.kde.org/pub/kde/stable/%{version}/src/%{name}-%{version}.tar.bz2
22%endif
23
24Patch1: arts-1.1.4-debug.patch
25Patch2: arts-1.3.92-glib2.patch
26Patch5: arts-1.3.1-alsa.patch
27Patch6: arts-1.5.8-glibc.patch
28Patch7: arts-1.5.0-check_tmp_dir.patch
29Patch8: arts-1.5.2-multilib.patch
30# kde#93359
31Patch50: arts-1.5.4-dlopenext.patch
32Patch51: kde-3.5-libtool-shlibext.patch
33# upstream patches
34
35BuildRoot: %{_tmppath}/%{name}-%{version}-root
36#PreReq: ldconfig
37BuildRequires: gcc-c++ libjpeg-devel
38BuildRequires: mesa-libGL-devel mesa-libGLU-devel
39BuildRequires: libmng-devel zlib-devel audiofile-devel
40BuildRequires: qt-devel >= 3.3.2, libpng-devel >= 1.2.5
41BuildRequires: libogg-devel libvorbis-devel glib2-devel
42BuildRequires: esound-devel jack-audio-connection-kit-devel
43BuildRequires: pkgconfig
44#libmad-devel
45%if %{alsa}
46BuildRequires: alsa-lib-devel
47%endif
48%if %{run_test}
49BuildRequires: kdelibs
50%endif
51
52# We don't want to require X11, Qt or glib2, arts is perfectly usable without
53# them, they're just used by addons the qtmcop, gmcop and x11globalcomm addons
54AutoReq: off
55#Requires: XFree86-gl XFree86-libs freetype2 libjpeg libmng libpng zlib
56#Requires: audiofile glibc
57Obsoletes: kdelibs-sound
58Provides: kdelibs-sound
59
60%description
61arts (analog real-time synthesizer) is the sound system of KDE 3.
62
63The principle of arts is to create/process sound using small modules which do
64certain tasks. These may be create a waveform (oscillators), play samples,
65filter data, add signals, perform effects like delay/flanger/chorus, or
66output the data to the soundcard.
67
68By connecting all those small modules together, you can perform complex
69tasks like simulating a mixer, generating an instrument or things like
70playing a wave file with some effects.
71
72%package devel
73Summary: Development files for the aRts sound server
74Group: Development/Libraries
75Requires: %{name} = %{epoch}:%{version}-%{release}
76Requires: glib2-devel
77Obsoletes: kdelibs-sound-devel
78Provides: kdelibs-sound-devel
79
80%description devel
81arts (analog real-time synthesizer) is the sound system of KDE 3.
82
83The principle of arts is to create/process sound using small modules which do
84certain tasks. These may be create a waveform (oscillators), play samples,
85filter data, add signals, perform effects like delay/flanger/chorus, or
86output the data to the soundcard.
87
88By connecting all those small modules together, you can perform complex
89tasks like simulating a mixer, generating an instrument or things like
90playing a wave file with some effects.
91
92Install arts-devel if you intend to write applications using arts (such as
93KDE applications using sound).
94
95%prep
96%setup -q
97%patch1 -p1 -b .debug
98%patch2 -p1 -b .glib
99%patch5 -p1 -b .alsa
100%patch6 -p1 -b .glibc
101%patch7 -p1 -b .check_tmp_dir
102%patch8 -p1 -b .multilib
103
104%patch50 -p1 -b .dlopenext
105%patch51 -p1 -b .libtool-shlibext
106
107%if %{make_cvs}
108  make -f admin/Makefile.common cvs
109%endif
110
111%build
112unset QTDIR || : ; . /etc/profile.d/qt.sh
113
114%configure \
115    --includedir=%{_includedir}/kde \
116    --with-qt-libraries=$QTDIR/lib \
117    --disable-rpath --disable-warnings \
118    --disable-dependency-tracking \
119    --enable-new-ldflags \
120    --disable-libmad \
121%if %{alsa}
122    --with-alsa \
123%endif
124    --enable-final
125
126make %{?_smp_mflags}
127
128%if %{run_test}
129make check
130%endif
131
132%install
133rm -rf $RPM_BUILD_ROOT
134export PATH=`pwd`:$PATH
135make DESTDIR=$RPM_BUILD_ROOT install
136
137## remove references to optional external libraries in .la files (#178733)
138find $RPM_BUILD_ROOT%{_libdir} -name "*.la" | xargs \
139 sed -i \
140 -e "s|-lmad||g" \
141 -e "s|%{_libdir}/libmad.la||g" \
142 -e "s|-lvorbisfile||g" \
143 -e "s|-lvorbisenc||g" \
144 -e "s|-lvorbis||g" \
145 -e "s|-logg||g" \
146 -e "s|-lasound||g" \
147 -e "s|-laudiofile||g" \
148 -e "s|-lesd||g" \
149 -e "s|%{_libdir}/libesd.la||g" \
150 -e "s|-lgmodule-2.0||g" \
151 -e "s|-lgthread-2.0||g" \
152 -e "s|-lglib-2.0||g" \
153 -e "s|-laudio ||g" \
154 -e "s|-lpng -lz ||g" \
155 -e "s|%{_libdir}/libartsc.la||g" \
156 -e "s@-lboost_filesystem@@g" \
157 -e "s@-lboost_regex@@g" \
158 -e "s@-ljack@@g"
159
160#rm -rf $RPM_BUILD_ROOT%{_libdir}/lib*.la
161
162#chmod a+x $RPM_BUILD_ROOT%{_libdir}/*
163
164%clean
165rm -rf $RPM_BUILD_ROOT
166
167%post -p /sbin/ldconfig
168
169%postun -p /sbin/ldconfig
170
171%files
172%defattr(-,root,root)
173%doc COPYING.LIB
174%dir %{_libdir}/mcop
175%dir %{_libdir}/mcop/Arts
176%{_bindir}/arts*
177%exclude %{_bindir}/artsc-config
178%{_libdir}/mcop/Arts/*
179%{_libdir}/mcop/*.mcopclass
180%{_libdir}/mcop/*.mcoptype
181%{_libdir}/lib*.so.*
182%{_libdir}/lib*.la
183
184%files devel
185%defattr(-,root,root)
186%{_bindir}/artsc-config
187%{_bindir}/mcopidl
188%{_includedir}/kde/arts
189%{_includedir}/kde/artsc
190%{_libdir}/lib*.so
191%{_libdir}/pkgconfig/artsc.pc
192
193%changelog
194* Sat May  9 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.5.10-2
195- updated to 1.5.10
196- added Patch1,2,5,8,50 and 51 from Fedora
197- added lib*.la files again...
198
199* Wed Apr 15 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.5.10-1
200- updated to 1.5.10
201- added BuildRequires: jack-audio-connection-kit-devel
202- removed static library
203
204* Sun Jul 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.5.8-1vl5
205- applied new versioning policy
206- updated build dependancies
207
208* Wed Oct 10 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.8-0vl2
209- rebuild for VineSeed
210
211* Wed Oct 10 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.8-0vl1
212- new upstream release
213
214* Mon Jun 18 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.7-0vl2
215- rebuild for VineSeed
216
217* Sun May 20 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.7-0vl1
218- new upstream release
219
220* Wed Jan 17 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.6-0vl1
221- new upstream release
222
223* Tue Nov 14 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.5-0vl5
224- rebuild for VineSeed
225
226* Tue Nov 14 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.5-0vl4
227- add Patch0 [VineLinux:0369]
228
229* Sat Oct 14 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.5.5-0vl3
230- added --with-qt-libraries option
231- removed --libdir=%%{_libdir} option
232
233* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.5-0vl2
234- rebuild for VineSeed
235
236* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.5-0vl1
237- new upstream release
238
239* Mon Aug  7 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.4-0vl2
240- rebuild for VineSeed
241
242* Mon Aug  7 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.4-0vl1
243- new upstream release
244- drop Patch0
245
246* Sat Aug 05 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.5.3-0vl5
247- added --libdir=%%{_libdir} to ./configure option
248
249* Mon Jun 12 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.3-0vl4
250- rebuild for VineSeed
251
252* Mon Jun 12 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.3-0vl3
253- add Patch0 (CVE-2006-2916)
254
255* Wed May 24 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.3-0vl2
256- rebuild for VineSeed
257
258* Wed May 24 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.3-0vl1
259- new upstream release
260
261* Mon Mar 20 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.2-0vl2
262- rebuild for VineSeed
263
264* Mon Mar 20 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.2-0vl1
265- new upstream release
266
267* Tue Jan 24 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.1-0vl2
268- rebuild for VineSeed
269
270* Tue Jan 24 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.1-0vl1
271- new upstream release
272
273* Mon Dec 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0-0vl3
274- add "%%{epoch}:" to Requires in arts-devel
275
276* Thu Dec  8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.0-0vl2
277- rebuild for VineSeed
278
279* Mon Nov 21 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.0-0vl1
280- new upstream release
281
282* Fri Nov 11 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.0-0vl0.rc1
283- new upstream release
284
285* Thu Oct 13 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.92-0vl1
286- new upstream release
287
288* Mon Sep 12 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.91-0vl1
289- new upstream release
290
291* Fri Jul 22 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.2-0vl2
292- rebuild for VineSeed
293
294* Fri Jul 22 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.2-0vl1
295- new upstream release
296
297* Mon Jun 27 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.1-0vl2
298- add alsa support for VineSeed
299- add --disable-rpath to configure option
300
301* Mon Jun 20 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.1-0vl1
302- new upstream release
303- use %%{?_smp_mflags} for make option
304- add BuildPrereq: esound-devel libmad-devel
305
306* Wed Mar 16 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.0-0vl2
307- rebuild for VineSeed
308
309* Thu Mar 10 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.0-0vl1
310- new upstream release
311
312* Tue Mar  1 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.0-0vl0.rc1
313- new upstream release (1.4.0-rc1)
314
315* Mon Feb  7 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.92-0vl1
316- new upstream release
317
318* Tue Jan 25 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.91-0vl1
319- new upstream release
320
321* Sun Dec 12 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.2-0vl2
322- rebuild for VineSeed
323
324* Wed Dec  1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.2-0vl1
325- source upgrade
326
327* Tue Oct  5 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.1-0vl1
328- source upgrade
329- refine %%files
330
331* Sun Sep  5 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.0-0vl1
332- source upgrade
333
334* Tue Aug 10 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.3-0vl2
335- rebuild with qt32
336
337* Fri Jun  4 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.3-0vl1
338- source upgrade
339- remove lines about vine26
340- BuildPrereq: XOrg-devel XOrg-gl-devel
341
342* Fri Apr 30 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.2-0vl1
343- source upgrade
344
345* Thu Mar  4 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.1-0vl1
346- source upgrade
347
348* Sun Feb  1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.0-0vl1
349- source upgrade
350- add Requires: glib2 to arts-devel package
351
352* Sat Jan 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.5-0vl2
353- rebuild for VineSeedPlus
354
355* Sat Jan 10 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.5-0vl1
356- source upgrade
357- build for VinePlus/2.6
358- (VinePlus/2.6) BuildPrereq: autoconf258
359
360* Sun Dec 21 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.4-0vl3
361- build for VineSeed with new toolchain and qt-3.2.3
362- add BuildPrereq: gcc-c++ gcc-g77 glib2-devel pkgconfig
363
364* Sun Oct 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.4-0.26vl2
365- rebuild with qt-3.2.1-0.26vl3
366
367* Sun Oct 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.4-0vl2
368- rebuild with qt-3.2.1-0vl3
369
370* Tue Sep 17 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.4-0vl1
371- source upgrade
372- build with gcc-3.2.3
373
374* Thu Jul 17 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.3-0vl1
375- source upgrade
376
377* Sun Jun 29 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.2-0vl3
378- change spec to build with gcc295
379- change make option for SMP and add script
380
381* Wed Jun 18 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.2-0vl2
382- build with gcc295
383- add KDEDIR and QTDIR
384
385* Sat May 10 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.2-0vl1
386- source upgrade
387
388* Mon Apr 21 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.1-0vl3
389- rebuilt with libpng >= 1.2.5 when %{vine26} is set to 0 (ie VineSeedPlus)
390
391* Mon Apr 21 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.1-0vl2
392- rebuild with qt-3.1.2-0vl2
393
394* Sat Mar 22 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.1-0vl1
395- source upgrade
396
397* Mon Feb 24 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1-0vl4
398- rebuild with qt-3.1.1-0vl3
399
400* Tue Feb 11 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1-0vl3
401- change spec to build both VineSeed and Vine2.5/2.6
402
403* Fri Jan 31 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1-0vl2
404- OOPS! rebuild with spec that changed 1.1-0vl0.2
405
406* Fri Jan 31 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1-0vl1
407- source upgrade to kde-3.1-stable
408
409* Wed Jan 22 2003 Tomoya TAKA <taka@vinelinux.org> 1.1-0vl0.2
410- add '-fPIC' to FLAGS on alpha
411
412* Wed Jan  8 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1-0vl0.1
413- source upgrade to kde-3.1-rc6
414- stop using objprelink2, it does not work with gcc3
415
416* Tue Oct 16 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0.4-0vl2
417- objprelink2 support only i386 (add %ifarch i386 ... again)
418-
419* Thu Oct 10 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0.4-0vl1
420- source upgrade
421
422* Tue Oct  8 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0.3-0vl4
423- rebuild with qt-3.0.5-0vl1
424- BuildPrereq: qt-devel >= 3.0.5 autoconf253 objprelink2
425
426* Thu Aug 20 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.0.3-0vl3
427- add BuildPrereq: libogg-devel libvorbis-devel
428
429* Wed Jul 10 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.0.3-0vl2
430- rebuild
431
432* Mon Jul  8 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.0.3-0vl1
433- source upgrade
434
435* Thu Jul  4 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.0.2-0vl1
436- source upgrade
437
438* Fri Jun  7 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.0.1-0vl1
439- source upgrade to 1.0.1
440- add BuildPrereq: objprelink for i386
441
442* Wed Apr 24 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.0.0-0vl2
443- add configure option `--with-xinerama'
444- add `Requires: %%{name} = %%{version}-%%{release}' for arts-devel
445
446* Thu Apr  4 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.0.0-0vl1
447- source upgrade to 1.0.0
448
449* Sat Mar 30 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 0.9.9-1vl1
450- source update to cvs-20020329
451- build for VineSeed
452- merged with 3.0-0.cvs20020313.1
453- Epoch: 1
454- add BuildPrereq: autoconf252 automake15
455
456* Wed Mar 13 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0-0.cvs20020313.1
457- Build with autoconf 2.53, automake 1.5
458
459* Thu Feb 14 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0-0.cvs20020114.1
460- initial package
Note: See TracBrowser for help on using the repository browser.