source: projects/specs/trunk/a/arts/arts-vl.spec @ 10547

Revision 10547, 16.0 KB checked in by Takemikaduchi, 8 years ago (diff)

rebuild with gcc-5.4.0

Line 
1%define run_test 0
2
3Name: arts
4Summary: aRts (analog realtime synthesizer) - the KDE 3 sound system
5Summary(ja): aRts - KDE 3 サウンドシステム
6Epoch: 1
7Version: 1.5.10
8Release: 8%{?_dist_release}
9
10Group: System Environment/Daemons
11License: LGPLv2+
12URL: http://www.kde.org
13
14Source: ftp://ftp.kde.org/pub/kde/stable/3.5.10/src/%{name}-%{version}.tar.bz2
15Source1: gslconfig-wrapper.h
16
17Patch1: arts-1.1.4-debug.patch
18Patch2: arts-1.3.92-glib2.patch
19Patch5: arts-1.3.1-alsa.patch
20Patch6: arts-1.5.8-glibc.patch
21Patch7: arts-1.5.0-check_tmp_dir.patch
22Patch8: arts-1.5.2-multilib.patch
23# don't pop up a dialog on CPU overload (#361891)
24Patch9: arts-1.5.10-cpu-overload-quiet.patch
25# kde#93359
26Patch50: arts-1.5.4-dlopenext.patch
27Patch51: kde-3.5-libtool-shlibext.patch
28# upstream patches
29
30# security patches
31# CVE-2009-3736 libtool: libltdl may load and execute code from a library in the current directory
32Patch200: libltdl-CVE-2009-3736.patch
33
34# tweak autoconfigury so that it builds with autoconf 2.64 or 2.65
35Patch300: arts-acinclude.patch
36# remove flawed and obsolete automake version check in admin/cvs.sh
37Patch301: kde3-automake-version.patch
38# fix build failure with automake 1.13: add the --add-missing --copy flags
39# also add --force-missing to get aarch64 support (#925029/#925627)
40Patch302: kde3-automake-add-missing.patch
41
42BuildRoot: %{_tmppath}/%{name}-%{version}-root
43BuildRequires: alsa-lib-devel
44BuildRequires: audiofile-devel
45BuildRequires: automake libtool
46BuildRequires: chrpath
47# BuildRequires: esound-devel
48BuildRequires: glib2-devel
49BuildRequires: libvorbis-devel
50BuildRequires: pkgconfig
51BuildRequires: qt-devel >= 3.3.8
52
53%if %{run_test}
54BuildRequires: kdelibs3
55%endif
56
57# used in artsdsp
58Requires: which
59
60Obsoletes: kdelibs-sound
61Provides: kdelibs-sound
62
63%description
64arts (analog real-time synthesizer) is the sound system of KDE 3.
65
66The principle of arts is to create/process sound using small modules which do
67certain tasks. These may be create a waveform (oscillators), play samples,
68filter data, add signals, perform effects like delay/flanger/chorus, or
69output the data to the soundcard.
70
71By connecting all those small modules together, you can perform complex
72tasks like simulating a mixer, generating an instrument or things like
73playing a wave file with some effects.
74
75%package devel
76Summary: Development files for the aRts sound server
77Summary(ja): aRts サウンドサーバの開発用ファイル
78Group: Development/Libraries
79Requires: %{name} = %{epoch}:%{version}-%{release}
80Requires: glib2-devel
81Requires: pkgconfig
82Requires: qt-devel
83Obsoletes: kdelibs-sound-devel
84Provides: kdelibs-sound-devel
85
86%description devel
87arts (analog real-time synthesizer) is the sound system of KDE 3.
88
89The principle of arts is to create/process sound using small modules which do
90certain tasks. These may be create a waveform (oscillators), play samples,
91filter data, add signals, perform effects like delay/flanger/chorus, or
92output the data to the soundcard.
93
94By connecting all those small modules together, you can perform complex
95tasks like simulating a mixer, generating an instrument or things like
96playing a wave file with some effects.
97
98Install arts-devel if you intend to write applications using arts (such as
99KDE applications using sound).
100
101%prep
102%setup -q
103%patch1 -p1 -b .debug
104%patch2 -p1 -b .glib
105%patch5 -p1 -b .alsa
106%patch6 -p1 -b .glibc
107%patch7 -p1 -b .check_tmp_dir
108%patch8 -p1 -b .multilib
109%patch9 -p1 -b .cpu-overload-quiet
110
111%patch50 -p1 -b .dlopenext
112%patch51 -p1 -b .libtool-shlibext
113
114%patch200 -p1 -b .CVE-2009-3736
115
116%patch300 -p1 -b .acinclude
117%patch301 -p1 -b .automake-version
118%patch302 -p1 -b .automake-add-missing
119make -f admin/Makefile.common cvs
120
121%build
122unset QTDIR || : ; . /etc/profile.d/qt.sh
123
124%configure \
125    --includedir=%{_includedir}/kde \
126    --with-qt-libraries=$QTDIR/lib \
127    --disable-rpath \
128    --disable-debug --disable-warnings \
129    --disable-dependency-tracking \
130    --enable-new-ldflags \
131    --disable-libmad \
132    --with-alsa \
133    --without-esd \
134    --enable-final
135
136# kill rpath harder, inspired by https://fedoraproject.org/wiki/Packaging:Guidelines?rd=Packaging/Guidelines#Removing_Rpath
137# other more standard variants didnt work or caused other problems
138sed -i -e 's|"/lib /usr/lib|"/%{_lib} %{_libdir}|' libtool
139
140## hack for artsdsp (see http://bugzilla.redhat.com/329671)
141#make %{?_smp_mflags} -k || \
142#  sed -i -e "s|-Wp,-D_FORTIFY_SOURCE=2||" artsc/Makefile && \
143make %{?_smp_mflags}
144
145%if %{run_test}
146make check
147%endif
148
149%install
150rm -rf $RPM_BUILD_ROOT
151export PATH=`pwd`:$PATH
152make DESTDIR=$RPM_BUILD_ROOT install
153
154# Ugly hack to allow parallel installation of 32-bit and 64-bit arts-devel
155mv  $RPM_BUILD_ROOT%{_includedir}/kde/arts/gsl/gslconfig.h \
156    $RPM_BUILD_ROOT%{_includedir}/kde/arts/gsl/gslconfig-%{_arch}.h
157install -p -m644 %{SOURCE1}  $RPM_BUILD_ROOT%{_includedir}/kde/arts/gsl/gslconfig.h
158
159  ## remove references to optional external libraries in .la files (#178733)
160find $RPM_BUILD_ROOT%{_libdir} -name "*.la" | xargs \
161 sed -i \
162 -e "s|-lmad||g" \
163 -e "s|%{_libdir}/libmad.la||g" \
164 -e "s|-lvorbisfile||g" \
165 -e "s|-lvorbisenc||g" \
166 -e "s|-lvorbis||g" \
167 -e "s|-logg||g" \
168 -e "s|-lasound||g" \
169 -e "s|-laudiofile||g" \
170 -e "s|-lesd||g" \
171 -e "s|%{_libdir}/libesd.la||g" \
172 -e "s|-lgmodule-2.0||g" \
173 -e "s|-lgthread-2.0||g" \
174 -e "s|-lglib-2.0||g" \
175 -e "s|-laudio ||g" \
176 -e "s|-lpng -lz ||g" \
177 -e "s|%{_libdir}/libartsc.la||g" \
178 -e "s@-lboost_filesystem@@g" \
179 -e "s@-lboost_regex@@g" \
180 -e "s@-ljack@@g"
181
182#rm -rf $RPM_BUILD_ROOT%{_libdir}/lib*.la
183
184#chmod a+x $RPM_BUILD_ROOT%{_libdir}/*
185
186%check
187## Verify rpath, or lack thereof
188test -z "$(chrpath --list %{buildroot}%{_bindir}/artsd 2>/dev/null | grep RPATH=%{_libdir})"
189
190%clean
191rm -rf $RPM_BUILD_ROOT
192
193%post -p /sbin/ldconfig
194
195%postun -p /sbin/ldconfig
196
197%files
198%defattr(-,root,root)
199%doc COPYING.LIB
200%dir %{_libdir}/mcop
201%dir %{_libdir}/mcop/Arts
202%{_bindir}/arts*
203%exclude %{_bindir}/artsc-config
204%{_libdir}/mcop/Arts/*
205%{_libdir}/mcop/*.mcopclass
206%{_libdir}/mcop/*.mcoptype
207%{_libdir}/lib*.so.*
208%{_libdir}/lib*.la
209
210%files devel
211%defattr(-,root,root)
212%{_bindir}/artsc-config
213%{_bindir}/mcopidl
214%{_includedir}/kde/arts
215%{_includedir}/kde/artsc
216%{_libdir}/lib*.so
217%{_libdir}/pkgconfig/artsc.pc
218
219%changelog
220* Mon Jul 04 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.5.10-8
221- rebuild with gcc-5.4.0
222- remove BuildRequires: esound-devel
223
224* Sun Sep 28 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.5.10-7
225- added Patch301 and 302 from FC
226
227* Mon May 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.5.10-6
228- rebuild with audiofile-0.3.4
229
230* Sun Sep 26 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.5.10-5
231- rebuilt with rpm-4.8.1 for pkg-config
232
233* Sat Jul 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.5.10-4
234- disabled AutoReq: off
235
236* Sat Mar 20 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.5.10-3
237- rebuilt with new toolchain
238- added Patch9, 200 and 300 from FC
239  * Wed Dec 16 2009 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1.5.10-11
240  - don't pop up a dialog on CPU overload (#361891)
241  * Thu Dec 10 2009 Stepan Kasal <skasal@redhat.com> - 1.5.10-10
242  - patch autoconfigury to build with autoconf >= 2.64
243  * Sun Dec 06 2009 Than Ngo <than@redhat.com> - 1.5.10-9
244  - fix url
245  - fix security issues in libltdl (CVE-2009-3736)
246- added Japanese summary
247- fixed duplicated entry at last changelog
248
249* Sat May  9 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.5.10-2
250- added Patch1,2,5,8,50 and 51 from Fedora
251- added lib*.la files again...
252
253* Wed Apr 15 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.5.10-1
254- updated to 1.5.10
255- added BuildRequires: jack-audio-connection-kit-devel
256- removed static library
257
258* Sun Jul 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.5.8-1vl5
259- applied new versioning policy
260- updated build dependancies
261
262* Wed Oct 10 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.8-0vl2
263- rebuild for VineSeed
264
265* Wed Oct 10 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.8-0vl1
266- new upstream release
267
268* Mon Jun 18 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.7-0vl2
269- rebuild for VineSeed
270
271* Sun May 20 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.7-0vl1
272- new upstream release
273
274* Wed Jan 17 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.6-0vl1
275- new upstream release
276
277* Tue Nov 14 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.5-0vl5
278- rebuild for VineSeed
279
280* Tue Nov 14 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.5-0vl4
281- add Patch0 [VineLinux:0369]
282
283* Sat Oct 14 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.5.5-0vl3
284- added --with-qt-libraries option
285- removed --libdir=%%{_libdir} option
286
287* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.5-0vl2
288- rebuild for VineSeed
289
290* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.5-0vl1
291- new upstream release
292
293* Mon Aug  7 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.4-0vl2
294- rebuild for VineSeed
295
296* Mon Aug  7 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.4-0vl1
297- new upstream release
298- drop Patch0
299
300* Sat Aug 05 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.5.3-0vl5
301- added --libdir=%%{_libdir} to ./configure option
302
303* Mon Jun 12 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.3-0vl4
304- rebuild for VineSeed
305
306* Mon Jun 12 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.3-0vl3
307- add Patch0 (CVE-2006-2916)
308
309* Wed May 24 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.3-0vl2
310- rebuild for VineSeed
311
312* Wed May 24 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.3-0vl1
313- new upstream release
314
315* Mon Mar 20 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.2-0vl2
316- rebuild for VineSeed
317
318* Mon Mar 20 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.2-0vl1
319- new upstream release
320
321* Tue Jan 24 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.1-0vl2
322- rebuild for VineSeed
323
324* Tue Jan 24 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.1-0vl1
325- new upstream release
326
327* Mon Dec 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0-0vl3
328- add "%%{epoch}:" to Requires in arts-devel
329
330* Thu Dec  8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.0-0vl2
331- rebuild for VineSeed
332
333* Mon Nov 21 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.0-0vl1
334- new upstream release
335
336* Fri Nov 11 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.0-0vl0.rc1
337- new upstream release
338
339* Thu Oct 13 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.92-0vl1
340- new upstream release
341
342* Mon Sep 12 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.91-0vl1
343- new upstream release
344
345* Fri Jul 22 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.2-0vl2
346- rebuild for VineSeed
347
348* Fri Jul 22 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.2-0vl1
349- new upstream release
350
351* Mon Jun 27 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.1-0vl2
352- add alsa support for VineSeed
353- add --disable-rpath to configure option
354
355* Mon Jun 20 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.1-0vl1
356- new upstream release
357- use %%{?_smp_mflags} for make option
358- add BuildPrereq: esound-devel libmad-devel
359
360* Wed Mar 16 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.0-0vl2
361- rebuild for VineSeed
362
363* Thu Mar 10 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.0-0vl1
364- new upstream release
365
366* Tue Mar  1 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.0-0vl0.rc1
367- new upstream release (1.4.0-rc1)
368
369* Mon Feb  7 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.92-0vl1
370- new upstream release
371
372* Tue Jan 25 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.91-0vl1
373- new upstream release
374
375* Sun Dec 12 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.2-0vl2
376- rebuild for VineSeed
377
378* Wed Dec  1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.2-0vl1
379- source upgrade
380
381* Tue Oct  5 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.1-0vl1
382- source upgrade
383- refine %%files
384
385* Sun Sep  5 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.0-0vl1
386- source upgrade
387
388* Tue Aug 10 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.3-0vl2
389- rebuild with qt32
390
391* Fri Jun  4 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.3-0vl1
392- source upgrade
393- remove lines about vine26
394- BuildPrereq: XOrg-devel XOrg-gl-devel
395
396* Fri Apr 30 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.2-0vl1
397- source upgrade
398
399* Thu Mar  4 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.1-0vl1
400- source upgrade
401
402* Sun Feb  1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.0-0vl1
403- source upgrade
404- add Requires: glib2 to arts-devel package
405
406* Sat Jan 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.5-0vl2
407- rebuild for VineSeedPlus
408
409* Sat Jan 10 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.5-0vl1
410- source upgrade
411- build for VinePlus/2.6
412- (VinePlus/2.6) BuildPrereq: autoconf258
413
414* Sun Dec 21 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.4-0vl3
415- build for VineSeed with new toolchain and qt-3.2.3
416- add BuildPrereq: gcc-c++ gcc-g77 glib2-devel pkgconfig
417
418* Sun Oct 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.4-0.26vl2
419- rebuild with qt-3.2.1-0.26vl3
420
421* Sun Oct 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.4-0vl2
422- rebuild with qt-3.2.1-0vl3
423
424* Tue Sep 17 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.4-0vl1
425- source upgrade
426- build with gcc-3.2.3
427
428* Thu Jul 17 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.3-0vl1
429- source upgrade
430
431* Sun Jun 29 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.2-0vl3
432- change spec to build with gcc295
433- change make option for SMP and add script
434
435* Wed Jun 18 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.2-0vl2
436- build with gcc295
437- add KDEDIR and QTDIR
438
439* Sat May 10 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.2-0vl1
440- source upgrade
441
442* Mon Apr 21 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.1-0vl3
443- rebuilt with libpng >= 1.2.5 when %{vine26} is set to 0 (ie VineSeedPlus)
444
445* Mon Apr 21 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.1-0vl2
446- rebuild with qt-3.1.2-0vl2
447
448* Sat Mar 22 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.1-0vl1
449- source upgrade
450
451* Mon Feb 24 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1-0vl4
452- rebuild with qt-3.1.1-0vl3
453
454* Tue Feb 11 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1-0vl3
455- change spec to build both VineSeed and Vine2.5/2.6
456
457* Fri Jan 31 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1-0vl2
458- OOPS! rebuild with spec that changed 1.1-0vl0.2
459
460* Fri Jan 31 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1-0vl1
461- source upgrade to kde-3.1-stable
462
463* Wed Jan 22 2003 Tomoya TAKA <taka@vinelinux.org> 1.1-0vl0.2
464- add '-fPIC' to FLAGS on alpha
465
466* Wed Jan  8 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1-0vl0.1
467- source upgrade to kde-3.1-rc6
468- stop using objprelink2, it does not work with gcc3
469
470* Tue Oct 16 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0.4-0vl2
471- objprelink2 support only i386 (add %ifarch i386 ... again)
472-
473* Thu Oct 10 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0.4-0vl1
474- source upgrade
475
476* Tue Oct  8 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0.3-0vl4
477- rebuild with qt-3.0.5-0vl1
478- BuildPrereq: qt-devel >= 3.0.5 autoconf253 objprelink2
479
480* Thu Aug 20 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.0.3-0vl3
481- add BuildPrereq: libogg-devel libvorbis-devel
482
483* Wed Jul 10 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.0.3-0vl2
484- rebuild
485
486* Mon Jul  8 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.0.3-0vl1
487- source upgrade
488
489* Thu Jul  4 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.0.2-0vl1
490- source upgrade
491
492* Fri Jun  7 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.0.1-0vl1
493- source upgrade to 1.0.1
494- add BuildPrereq: objprelink for i386
495
496* Wed Apr 24 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.0.0-0vl2
497- add configure option `--with-xinerama'
498- add `Requires: %%{name} = %%{version}-%%{release}' for arts-devel
499
500* Thu Apr  4 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.0.0-0vl1
501- source upgrade to 1.0.0
502
503* Sat Mar 30 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 0.9.9-1vl1
504- source update to cvs-20020329
505- build for VineSeed
506- merged with 3.0-0.cvs20020313.1
507- Epoch: 1
508- add BuildPrereq: autoconf252 automake15
509
510* Wed Mar 13 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0-0.cvs20020313.1
511- Build with autoconf 2.53, automake 1.5
512
513* Thu Feb 14 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0-0.cvs20020114.1
514- initial package
Note: See TracBrowser for help on using the repository browser.