source: projects/specs/trunk/a/arpwatch/arpwatch-vl.spec @ 521

Revision 521, 14.7 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define arpwatch_ver    2.1a15
2%define _vararpwatch    %{_localstatedir}/arpwatch
3%define PCAP_UID 77
4%define PCAP_GID 77
5
6Summary: Network monitoring tools for tracking IP addresses on a network.
7Summary(ja): ¥Í¥Ã¥È¥ï¡¼¥¯¤Î IP ¥¢¥É¥ì¥¹¤òÄÉÀפ¹¤ë´Æ»ë¥Ä¡¼¥ë
8Name: arpwatch
9Version: %{arpwatch_ver}
10Release: 0vl1
11Epoch: 1
12License: BSD
13Group: Applications/System
14
15Source0: ftp://ftp.ee.lbl.gov/arpwatch-%{version}.tar.gz
16Source3: arpwatch.init
17Source5: arpwatch.sysconfig
18Source6: arpwatch-ethercodes.dat
19
20Patch1: arpwatch-2.1a4-fhs.patch
21Patch2: arpwatch-2.1a10-man.patch
22Patch3: arpwatch-drop.patch
23Patch4: arpwatch-drop-man.patch
24Patch5: arp2ethers.patch
25Patch6: arpwatch-addr.patch
26
27BuildRequires: autoconf automake libpcap
28Requires(post): chkconfig
29Requires(postun): initscripts
30Requires(pre): shadow-utils
31Requires(preun): chkconfig initscripts
32BuildRoot: %{_tmppath}/%{name}-%{version}-root
33
34Vendor: Project Vine
35Distribution: Vine Linux
36
37
38%description
39The arpwatch package contains arpwatch and arpsnmp. Arpwatch and
40arpsnmp are both network monitoring tools. Both utilities monitor
41Ethernet or FDDI network traffic and build databases of Ethernet/IP
42address pairs, and can report certain changes via email.
43
44Install the arpwatch package if you need networking monitoring devices
45which will automatically keep track of the IP addresses on your
46network.
47
48%description -l ja
49arpwatch ¥Ñ¥Ã¥±¡¼¥¸¤Ë¤Ï arpwatch ¤È arpsnmp ¤¬´Þ¤Þ¤ì¤Þ¤¹¡£¤³¤ì¤é¤Ï
50¥Í¥Ã¥È¥ï¡¼¥¯¤Î´Æ»ë¥Ä¡¼¥ë¤Ç¤¹¡£¤³¤ì¤é¤Î¥æ¡¼¥Æ¥£¥ê¥Æ¥£¤Ï¥¤¡¼¥µ¥Í¥Ã¥È¤ä
51FDDI ¥Í¥Ã¥È¥ï¡¼¥¯¤Î¥È¥é¥Õ¥£¥Ã¥¯¤ò´Æ»ë¤·¡¢¥¤¡¼¥µ¥Í¥Ã¥È¥¢¥É¥ì¥¹¤È IP
52¥¢¥É¥ì¥¹¤È¤ÎÂбþ¤Î¥Ç¡¼¥¿¥Ù¡¼¥¹¤ò¹½ÃÛ¤·¡¢ÊѲ½¤¬¤¢¤Ã¤¿¤é¥á¡¼¥ë¤ÇÄÌÃÎ
53¤¹¤ë¤³¤È¤¬¤Ç¤­¤Þ¤¹¡£
54
55¥Í¥Ã¥È¥ï¡¼¥¯¾å¤Î IP ¥¢¥É¥ì¥¹¤ÎÊѲ½¤ò¼«Æ°Åª¤ËÊÝ»ý¤¹¤ë¤è¤¦¤Ê¥Ç¥Ð¥¤¥¹¤ò
56´Æ»ë¤·¤¿¤¤¾ì¹ç¡¢arpwatch ¥Ñ¥Ã¥±¡¼¥¸¤ò¥¤¥ó¥¹¥È¡¼¥ë¤·¤Æ²¼¤µ¤¤¡£
57
58
59%prep
60%setup -q
61
62%patch1 -p1 -b .fhs
63%patch2 -p1 -b .arpsnmpman
64%patch3 -p1 -b .droproot
65%patch4 -p0 -b .droprootman
66#patch5 -p1 -b .arp2ether
67%patch6 -p1 -b .addr
68chmod u+w ethercodes.dat
69cp %SOURCE6 ethercodes.dat
70
71
72%build
73aclocal
74autoconf
75CFLAGS="$CFLAGS -I/usr/include/pcap" %configure
76make ARPDIR=%{_vararpwatch}
77
78
79%install
80rm -rf ${RPM_BUILD_ROOT}
81mkdir -p ${RPM_BUILD_ROOT}%{_libdir}
82mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/man{3,8}
83mkdir -p ${RPM_BUILD_ROOT}%{_sbindir}
84
85make DESTDIR=${RPM_BUILD_ROOT} install install-man
86mkdir -p ${RPM_BUILD_ROOT}%{_vararpwatch}
87for n in arp2ethers arpfetch massagevendor massagevendor-old; do
88        install -m755 $n ${RPM_BUILD_ROOT}%{_vararpwatch}
89done
90for n in *.awk *.dat; do
91        install -m644 $n ${RPM_BUILD_ROOT}%{_vararpwatch}
92#for n in *.awk *.dat missingcodes.txt; do
93#       install -m644 $n ${RPM_BUILD_ROOT}%{_vararpwatch}
94done
95( cd ${RPM_BUILD_ROOT}
96  mkdir -p .%{_initdir}
97  install -c -m755 $RPM_SOURCE_DIR/arpwatch.init .%{_initdir}/arpwatch
98  mkdir -p .%{_sysconfdir}/sysconfig
99  install -c -m644 $RPM_SOURCE_DIR/arpwatch.sysconfig .%{_sysconfdir}/sysconfig/arpwatch
100)
101
102
103%clean
104rm -rf ${RPM_BUILD_ROOT}
105
106%post
107/sbin/chkconfig --add arpwatch
108
109%pre
110/usr/sbin/groupadd -g %{PCAP_GID} pcap  2> /dev/null || : 
111/usr/sbin/useradd -u %{PCAP_UID} -g %{PCAP_GID} \
112        -s /bin/nologin -M -r -d %{_vararpwatch} pcap 2> /dev/null || :
113
114%postun
115if [ "$1" -ge "1" ]; then
116  /sbin/service arpwatch condrestart >/dev/null 2>&1
117fi
118
119%preun
120if [ $1 = 0 ]; then
121        /sbin/service arpwatch stop > /dev/null 2>&1
122        /sbin/chkconfig --del arpwatch
123fi
124
125
126%files
127%defattr(-,root,root)
128%doc README CHANGES
129%{_sbindir}/arpwatch
130%{_sbindir}/arpsnmp
131%{_mandir}/man8/arpwatch.8*
132%{_mandir}/man8/arpsnmp.8*
133%config %{_initdir}/arpwatch
134%config(noreplace) %{_sysconfdir}/sysconfig/arpwatch
135%defattr(-,pcap,pcap)
136%dir    %{_vararpwatch}
137%config %{_vararpwatch}/arp.dat
138%config %{_vararpwatch}/ethercodes.dat
139#config %{_vararpwatch}/missingcodes.txt
140%{_vararpwatch}/*.awk
141%{_vararpwatch}/arp2ethers
142%{_vararpwatch}/arpfetch
143%{_vararpwatch}/massagevendor
144%{_vararpwatch}/massagevendor-old
145
146%changelog
147* Sun Sep  2 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:2.1a15-0vl1
148- s/Serial/Epoch/
149- s/Copyright/License/
150- updated to 2.1a15
151- dropped Patch5 (merged into new upstream)
152
153* Fri Feb 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.1a11-13vl3
154- arpwatch standalone package splitted from tcpdump.
155- merge 2.1a11-9vl2 changes
156  * Thu May 21 2002 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp> 3.6.2-9vl2
157    change arpwatch.init to use /etc/sysconfig/arpwatch
158
159* Fri Feb 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1:3.7.1-0vl1
160- update to new upstream release tcpdump 3.7.1
161- drop unneeded patches
162- use autoconf213, automake14
163- split arpwatch from tcpdump package
164
165* Fri Feb 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1:3.6.2-13vl2
166- add patch16 to fix  print_bgp security bug
167  - errata 20030221-3
168
169* Wed Jun 12 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1:3.6.2-13vl1
170- merged with 3.6.2-13
171- fix buffer overflow for errata
172  * Thu May 16 2002 Harald Hoyer <harald@redhat.de> 12:3.6.2-13
173  - added official 3.6.3 fix
174  - fixed 6.2 compat #63113
175  * Wed Jan 23 2002 Harald Hoyer <harald@redhat.de> 12:3.6.2-12
176  - tcpdump-3.6.2-snaplen.patch added to fix #55145
177  * Tue Dec 18 2001 Harald Hoyer <harald@redhat.de> 12:3.6.2-10
178  - took old purge patch for filters
179  - fixed #54225,#58346
180  - drop root by default #49635
181  - fixed #54593
182  - fixed #57711
183
184* Thu Oct 25 2001 IWAI Masaharu <iwaim@cc.mbn.or.jp>
185- 3.6.2-9vl1
186- used PRM macros
187- changed File Name to Package Name in Prereq tag
188- marged 3.6.2-9 (RedHat7.2)
189
190  * Tue Jan 23 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
191  - 3.4-19vl2
192  - use better macros
193 
194  * Thu Sep 21 2000 Yoshihiro Kajiki <kajiki@ylug.org>
195  - add libpcap-0.4-guy-gerald.patch to fix the timeout problem (by Ethereal)
196  - add Japanese summarys and descriptions
197  - modify spec file to build as a normal user
198 
199  * Thu Feb 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
200  - Compile shared libpcap with -fPIC (Bug #6342)
201 
202  * Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
203  - fix descriptions
204  - man pages are compressed
205 
206  * Wed Dec 22 1999 Jeff Johnson <jbj@redhat.com>
207  - remove sparc64 SIOCGIFNAME hack, not needed with (at least) kernel 2.2.12-40.
208  - upgrade to ANK ss991030 snapshot with pcap magic fix (#6773).
209  - add getprotobyname lookup (#6725).
210  - getservbyname port lookup appears functional (#7569).
211  - remove uid 2090 backdoor (sorry Dave) (#7116).
212 
213  * Thu Sep 09 1999 Cristian Gafton <gafton@redhat.com>
214  - fox the pcap.h header
215 
216  * Fri Aug 20 1999 Jeff Johnson <jbj@redhat.com>
217  - prevent segfault on obscure spoofed ip header (#4634).
218 
219  * Wed Aug 18 1999 Jeff Johnson <jbj@redhat.com>
220  - add defattr to arpwatch (#4591).
221 
222  * Mon Aug 16 1999 Bill Nottingham <notting@redhat.com>
223  - initscript munging
224
225  * Sun Aug  8 1999 Jeff Johnson <jbj@redhat.com>
226  - add -DWORDS_BIGINDIAN to tcpdump compile on sparc sparc61.
227 
228  * Tue Aug  3 1999 Jeff Johnson <jbj@redhat.com>
229  - include A. Kuznetsov's patches to libpcap/tcpdump.
230  - added arpsnmp to package (#3258).
231  - arp2ethers written for different of awk (#4326).
232
233  * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
234  - auto rebuild in the new build environment (release 10)
235
236  * Fri Mar 19 1999 Jeff Johnson <jbj@redhat.com>
237  - strip binaries.
238 
239  * Wed Jan 13 1999 Bill Nottingham <notting@redhat.com>
240  - autoconf fixes for arm
241
242  * Tue Sep 29 1998 Jeff Johnson <jbj@redhat.com>
243  - libpcap description typo.
244
245  * Sat Sep 19 1998 Jeff Johnson <jbj@redhat.com>
246  - fix arpwatch summary line.
247 
248  * Mon Aug 17 1998 Jeff Johnson <jbj@redhat.com>
249  - enable arpwatch
250 
251  * Mon Aug  3 1998 Jeff Johnson <jbj@redhat.com>
252  - separate package for libpcap.
253  - update tcpdump to 3.4, libpcap to 0.4.
254  - added arpwatch (but disabled for now)
255 
256  * Thu May 07 1998 Prospector System <bugs@redhat.com>
257  - translations modified for de, fr, tr
258 
259  * Sat May  2 1998 Alan Cox <alan@rehat.com>
260  - Added the SACK printing fix so you can dump Linux 2.1+.
261 
262  * Tue Oct 21 1997 Erik Troan <ewt@redhat.com>
263  - updated to release 3.4a5
264  - uses a buildroot and %attr
265 
266  * Thu Jul 17 1997 Erik Troan <ewt@redhat.com>
267  - built against glibc
268
269* Fri Aug 31 2001 Harald Hoyer <harald@redhat.de> 12:3.6.2-9
270- took better fix for #52654 from tcpdump cvs
271
272* Thu Aug 30 2001 Harald Hoyer <harald@redhat.de> 11:3.6.2-8
273- fixed #52654
274
275* Thu Jul 19 2001 Harald Hoyer <harald@redhat.de> 10:3.6.2-7
276- added shared library to libpcap (#47174)
277- afs printing security patch (#49294)
278
279* Wed Jun 20 2001 Harald Hoyer <harald@redhat.de>
280- use initgroups, instead of setgroups
281
282* Mon Jun 18 2001 Harald Hoyer <harald@redhat.de>
283- added dropgroup patches (#44563)
284
285* Mon May 07 2001 Harald Hoyer <harald@redhat.de>
286- switched to Pekka's tcpdump-3.6.2 package
287- incremented epoch
288
289* Sat Apr 14 2001 Pekka Savola <pekkas@netcore.fi>
290- fix building of tcpslice on glibc 2.2.2 (time.h)
291- disable /etc/init.d requirement and fix %post scripts in arpwatch
292
293* Wed Feb 14 2001 Harald Hoyer <harald@redhat.de>
294- glibc sys/time -> time include patch
295
296* Wed Feb  7 2001 Trond Eivind Glomsr <teg@redhat.com>
297- Add space to this check
298
299* Wed Feb 07 2001 Harald Hoyer <harald@redhat.com>
300- added check for presence of /etc/sysconfig/arpwatch (#23172)
301
302* Wed Feb  7 2001 Pekka Savola <pekkas@netcore.fi>
303- update to 3.6.2, 0.6.2 and new CVS of tcpslice.
304- i18n'ize arpwatch init script
305
306* Fri Feb  2 2001 Trond Eivind Glomsr <teg@redhat.com>
307- i18nize initscript
308
309* Mon Jan 29 2001 Harald Hoyer <harald@redhat.com>
310- fixed EINTR stopping for e.g. SIGSTOP. (#22008)
311- added -u option for tcpdump (#20231)
312- new arpwatch version (#23172)
313- added "all" and "one" interface for -i (#20907)
314- added arpwatch sysconfig (#23172)
315
316* Mon Jan 22 2001 Harald Hoyer <harald@redhat.com>
317- more (potential) overflows in libpcap. #21373
318- documentation fix for #20906
319
320* Sun Jan 14 2001 Pekka Savola <pekkas@netcore.fi>
321- use --enable-ipv6
322- Add two patches from CVS to enhance 802.2 printing, and more importantly,
323  to be able to specify 'no stp'
324
325* Sat Jan 13 2001 Pekka Savola <pekkas@netcore.fi>
326- Make SMB printing output a lot more quiet unless in verbose mode.
327- Make -n resolve port/protocol numbers but not hostnames, -nn for no
328  resolving at all
329- Separate droproot patch from a more generic man/usage fix one
330- Add non-promiscuous mode -by default patch, but don't apply it by default
331
332* Thu Jan 11 2001 Pekka Savola <pekkas@netcore.fi>
333- Update to tcpdump 3.6.1 and libpcap 0.6.1 releases.
334
335* Mon Jan  8 2001 Pekka Savola <pekkas@netcore.fi>
336- Update to 20010108 CVS, disable some upstreamed patches.
337- Change some additional .1 pages to .8.
338- Add droproot patch, some --usage and man page fixes.
339
340* Mon Jan  1 2001 Pekka Savola <pekkas@netcore.fi>
341- Initial packaging with latest tcpdump.org CVS tcpdump-3.6 and libpcap-0.6.
342- add earlier print-domain.c, the latest is segfaulting
343- don't unnecesessarily include snprintf.o, it didn't compile with gcc 2.96 anyway
344- don't use savestr, require openssl, tweak tweak tweak
345- add tcpslice, patch it a bit for egcs detection
346
347* Sun Dec 31 2000 Pekka Savola <pekkas@netcore.fi>
348- tcpdump: spice up the manpage about interfaces
349- tcpdump: add 'all' and 'any' keywords to -i, saner default behaviour.
350- upgrade arpwatch to 2.1a10
351
352* Sun Nov 26 2000 Jeff Johnson <jbj@redhat.com>
353- more (potential) overflows in libpcap.
354
355* Sun Nov 12 2000 Jeff Johnson <jbj@redhat.com>
356- eliminate still more buffer overflows (from FreeBSD) (#20069).
357
358* Thu Nov  2 2000 Jeff Johnson <jbj@redhat.com>
359- eliminate more buffer overflows (from FreeBSD) (#20069).
360- 802.1q ether type incorrect (#19850).
361- add -u flag to drop arpwatch privs (#19696).
362
363* Sun Oct 15 2000 Jeff Johnson <jbj@redhat.com>
364- updated ethercodes.dat
365
366* Thu Oct 12 2000 Jeff Johnson <jbj@redhat.com>
367- fix arpwatch tmp race (#18943).
368
369* Fri Aug 11 2000 Bill Nottingham <notting@redhat.com>
370- fix condrestart
371
372* Fri Aug 11 2000 Jeff Johnson <jbj@redhat.com>
373- correct arpsnmp man pages (#15442).
374- don't print harmless ENOPROTOOPT message (#13518).
375
376* Fri Aug  4 2000 Jeff Johnson <jbj@redhat.com>
377- rebuild with final kernel headers (#13518).
378
379* Sat Jul 22 2000 Jeff Johnson <jbj@redhat.com>
380- add STP patch (#14112).
381
382* Fri Jul 14 2000 Matt Wilson <msw@redhat.com>
383- source /etc/init.d/functions
384- back out /etc/init.d/arpwatch, place file in /etc/rc.d
385- move initscript to /etc/init.d
386- changed initscript to use start() and stop() functions
387- added condrestart to init script
388- added %%post %%preun %%postun scripts to register arpwatch script
389- added Prereq: for all things needed in post/preun/postun
390
391* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
392- automatic rebuild
393
394* Tue Jul 11 2000 Jeff Johnson <jbj@redhat.com>
395- updated man page and help (pekkas@netcore.fi) (#10739 et al).
396
397* Sun Jun 18 2000 Jeff Johnson <jbj@redhat/com>
398- FHS packaging.
399
400* Tue May  9 2000 Bill Nottingham <notting@redhat.com>
401- minor tweaks for ia64 (prototypes)
402
403* Thu Feb 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
404- Compile shared libpcap with -fPIC (Bug #6342)
405
406* Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
407- fix descriptions
408- man pages are compressed
409
410* Wed Dec 22 1999 Jeff Johnson <jbj@redhat.com>
411- remove sparc64 SIOCGIFNAME hack, not needed with (at least) kernel 2.2.12-40.
412- upgrade to ANK ss991030 snapshot with pcap magic fix (#6773).
413- add getprotobyname lookup (#6725).
414- getservbyname port lookup appears functional (#7569).
415- remove uid 2090 backdoor (sorry Dave) (#7116).
416
417* Thu Sep 09 1999 Cristian Gafton <gafton@redhat.com>
418- fox the pcap.h header
419
420* Fri Aug 20 1999 Jeff Johnson <jbj@redhat.com>
421- prevent segfault on obscure spoofed ip header (#4634).
422
423* Wed Aug 18 1999 Jeff Johnson <jbj@redhat.com>
424- add defattr to arpwatch (#4591).
425
426* Mon Aug 16 1999 Bill Nottingham <notting@redhat.com>
427- initscript munging
428
429* Sun Aug  8 1999 Jeff Johnson <jbj@redhat.com>
430- add -DWORDS_BIGINDIAN to tcpdump compile on sparc sparc61.
431
432* Tue Aug  3 1999 Jeff Johnson <jbj@redhat.com>
433- include A. Kuznetsov's patches to libpcap/tcpdump.
434- added arpsnmp to package (#3258).
435- arp2ethers written for different of awk (#4326).
436
437* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
438- auto rebuild in the new build environment (release 10)
439
440* Fri Mar 19 1999 Jeff Johnson <jbj@redhat.com>
441- strip binaries.
442
443* Wed Jan 13 1999 Bill Nottingham <notting@redhat.com>
444- autoconf fixes for arm
445
446* Tue Sep 29 1998 Jeff Johnson <jbj@redhat.com>
447- libpcap description typo.
448
449* Sat Sep 19 1998 Jeff Johnson <jbj@redhat.com>
450- fix arpwatch summary line.
451
452* Mon Aug 17 1998 Jeff Johnson <jbj@redhat.com>
453- enable arpwatch
454
455* Mon Aug  3 1998 Jeff Johnson <jbj@redhat.com>
456- separate package for libpcap.
457- update tcpdump to 3.4, libpcap to 0.4.
458- added arpwatch (but disabled for now)
459
460* Thu May 07 1998 Prospector System <bugs@redhat.com>
461- translations modified for de, fr, tr
462
463* Sat May  2 1998 Alan Cox <alan@rehat.com>
464- Added the SACK printing fix so you can dump Linux 2.1+.
465
466* Tue Oct 21 1997 Erik Troan <ewt@redhat.com>
467- updated to release 3.4a5
468- uses a buildroot and %attr
469
470* Thu Jul 17 1997 Erik Troan <ewt@redhat.com>
471- built against glibc
Note: See TracBrowser for help on using the repository browser.