source: projects/specs/trunk/a/arpack/arpack-vl.spec @ 12030

Revision 12030, 2.8 KB checked in by ara_t, 5 years ago (diff)

arpack: update to 3.7.0

Line 
1%define pkg_name    arpack
2%define pkg_version 3.7.0
3%define pkg_release 1%{?_dist_release}
4
5Summary: A collection of Fortran77 subroutines designed to solve large scale eigenvalue problems
6Name:    %{pkg_name}
7Version: %{pkg_version}
8Release: %{pkg_release}
9
10License: BSD Software License
11Group:   System Environment/Libraries
12URL:     https://github.com/opencollab/arpack-ng
13Source0: %{name}-ng-%{version}.tar.gz
14
15BuildRoot: %{_tmppath}/%{name}-%{version}-root
16BuildRequires: cmake
17BuildRequires: gcc-gfortran
18BuildRequires: blas-devel lapack-devel
19Requires: blas lapack
20
21Vendor: Project Vine
22Distribution: Vine Linux
23Packager: ara_t
24
25
26%description
27ARPACK-NG is a collection of Fortran77 subroutines designed to solve
28large scale eigenvalue problems.
29
30Important Features:
31
32* Reverse Communication Interface.
33* Single and Double Precision Real Arithmetic Versions for Symmetric,
34  Non-symmetric, Standard or Generalized Problems.
35* Single and Double Precision Complex Arithmetic Versions for Standard or
36  Generalized Problems.
37* Routines for Banded Matrices - Standard or Generalized Problems.
38* Routines for The Singular Value Decomposition.
39* Example driver routines that may be used as templates to implement numerous
40  Shift-Invert strategies for all problem types, data types and precision.
41
42This project is a joint project between Debian, Octave and Scilab in order to
43provide a common and maintained version of arpack.
44
45
46%package devel
47Summary:     Header files for arpack library
48Summary(ja): arpack ライブラリのヘッダファイル
49Group:       Development/Libraries
50Requires: %{name} = %{version}-%{release}
51
52%description devel
53Header files for %{name} library.
54
55%description devel -l ja
56%{name}のヘッダーファイル
57
58
59%prep
60%{__rm} -rf ${RPM_BUILD_ROOT}
61%setup -q -n %{name}-ng-%{version}
62
63%build
64./bootstrap
65%{configure} \
66 --enable-shared \
67 --disable-static
68%{__make}
69
70%install
71%{make_install}
72%{__rm} ${RPM_BUILD_ROOT}%{_libdir}/*.la
73
74%clean
75%{__rm} -rf ${RPM_BUILD_ROOT}
76
77%post -p %{_syssbindir}/ldconfig
78%postun -p %{_syssbindir}/ldconfig
79
80
81%files
82%defattr(-,root,root)
83%doc CHANGES COPYING README.md TODO
84%doc DOCUMENTS EXAMPLES
85%{_libdir}/libarpack.so.*
86
87%files devel
88%defattr(-,root,root)
89%{_includedir}/
90%{_libdir}/libarpack.so
91%{_libdir}/pkgconfig/arpack.pc
92
93
94%changelog
95* Fri Jan 25 2019 Toshiaki Ara <ara_t@384.jp> 3.7.0-1
96- update to 3.7.0
97
98* Wed Sep 19 2018 Toshiaki Ara <ara_t@384.jp> 3.6.3-1
99- update to 3.6.3
100
101* Wed Aug 08 2018 Toshiaki Ara <ara_t@384.jp> 3.6.2-1
102- update to 3.6.2
103
104* Wed Jun 06 2018 Toshiaki Ara <ara_t@384.jp> 3.6.0-1
105- update to 3.6.0
106- separate subpackage arpack-devel
107
108* Thu Jul 28 2016 Toshiaki Ara <ara_t@384.jp> 3.4.0-1
109- update to 3.4.0 for VineSeed
110- add BuildRequires: cmake
111
112* Mon Apr 11 2016 Toshiaki Ara <ara_t@384.jp> 3.2.0-2
113- correct SPEC file
114
115* Sat Mar 19 2016 Toshiaki Ara <ara_t@384.jp> 3.2.0-1
116- new package
117
Note: See TracBrowser for help on using the repository browser.