source: projects/specs/trunk/a/arpack/arpack-vl.spec @ 10151

Revision 10151, 2.0 KB checked in by ara_t, 8 years ago (diff)

A collection of Fortran77 subroutines designed to solve large scale eigenvalue problems

Line 
1%define pkg_name    arpack
2%define pkg_version 3.2.0
3%define pkg_release 2%{?_dist_release}
4
5Summary: A collection of Fortran77 subroutines designed to solve large scale eigenvalue problems
6Name:    %{pkg_name}
7Version: %{pkg_version}
8Release: %{pkg_release}
9
10License: BSD Software License
11Group:   System Environment/Libraries
12URL:     https://github.com/opencollab/arpack-ng
13Source0: %{name}-ng-%{version}.tar.gz
14
15BuildRoot: %{_tmppath}/%{name}-%{version}-root
16BuildRequires: gcc-gfortran
17BuildRequires: blas-devel lapack-devel
18Requires: blas lapack
19
20Vendor: Project Vine
21Distribution: Vine Linux
22Packager: ara_t
23
24
25%description
26ARPACK-NG is a collection of Fortran77 subroutines designed to solve
27large scale eigenvalue problems.
28
29Important Features:
30
31* Reverse Communication Interface.
32* Single and Double Precision Real Arithmetic Versions for Symmetric,
33  Non-symmetric, Standard or Generalized Problems.
34* Single and Double Precision Complex Arithmetic Versions for Standard or
35  Generalized Problems.
36* Routines for Banded Matrices - Standard or Generalized Problems.
37* Routines for The Singular Value Decomposition.
38* Example driver routines that may be used as templates to implement numerous
39  Shift-Invert strategies for all problem types, data types and precision.
40
41This project is a joint project between Debian, Octave and Scilab in order to
42provide a common and maintained version of arpack.
43
44
45%prep
46%{__rm} -rf ${RPM_BUILD_ROOT}
47%setup -q -n %{name}-ng-%{version}
48
49%build
50%{configure} \
51 --enable-shared \
52 --disable-static
53%{__make}
54
55%install
56%{make_install}
57%{__rm} ${RPM_BUILD_ROOT}%{_libdir}/*.la
58
59%clean
60%{__rm} -rf ${RPM_BUILD_ROOT}
61
62%post -p %{_syssbindir}/ldconfig
63%postun -p %{_syssbindir}/ldconfig
64
65
66%files
67%defattr(-,root,root)
68%doc CHANGES COPYING README TODO
69%{_libdir}/libarpack.so*
70%{_libdir}/pkgconfig/arpack.pc
71
72
73%changelog
74* Mon Apr 11 2016 Toshiaki Ara <ara_t@384.jp> 3.2.0-2
75- correct SPEC file
76
77* Sat Mar 19 2016 Toshiaki Ara <ara_t@384.jp> 3.2.0-1
78- new package
79
Note: See TracBrowser for help on using the repository browser.