source: projects/specs/trunk/a/aqbanking/aqbanking-vl.spec @ 521

Revision 521, 7.8 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2
3Name: aqbanking
4Summary: A library for online banking functions and financial data import/export
5Version: 3.7.2
6Release: 1%{?_dist_release}
7Source: http://download.sourceforge.net/aqbanking/%{name}-%{version}.tar.gz
8Group: System Environment/Libraries
9License: GPLv2+
10URL: http://www.aquamaniac.de/aqbanking/
11Patch2: aqbanking-3.7.2-pkgconfig.patch
12Patch3: aqbanking-2.1.0-conflict.patch
13BuildRoot: %{_tmppath}/%{name}-%{version}-root
14# qbanking
15BuildRequires: qt-devel
16# python
17BuildRequires: python, PyXML, gmp-devel
18BuildRequires: gwenhywfar-devel >= 3.4.1
19BuildRequires: libofx-devel >= 0.9.0
20BuildRequires: gettext
21BuildRequires: libtool
22Requires(post): /sbin/ldconfig
23Requires(postun): /sbin/ldconfig
24Obsoletes: aqhbci <= 1.0.3
25Obsoletes: g2banking < %{version}
26
27%description
28The intention of AqBanking is to provide a middle layer between the
29program and the various Online Banking libraries (e.g. AqHBCI). The
30first backend which is already supported is AqHBCI, a library which
31implements a client for the German HBCI (Home Banking Computer
32Interface) protocol. Additionally, Aqbanking provides various plugins
33to simplify import and export of financial data. Currently there are
34import plugins for the following formats: DTAUS (German financial
35format), SWIFT (MT940 and MT942).
36
37%package devel
38Summary: Development headers for Aqbanking
39Group: Development/Libraries
40Requires: %{name} = %{version}-%{release}
41Requires: pkgconfig
42# for %{_datadir}/aclocal
43Requires: automake
44Obsoletes: aqhbci-devel <= 1.0.3
45Obsoletes: g2banking-devel < %{version}
46
47%description devel
48This package contains aqbanking-config and header files for writing and
49compiling programs using Aqbanking.
50
51%package -n qbanking
52Summary: Qt bindings for Aqbanking
53Group: System Environment/Libraries
54Requires: %{name} = %{version}-%{release}
55Requires(post): /sbin/ldconfig
56Requires(postun): /sbin/ldconfig
57Obsoletes: aqhbci-qt-tools <= 1.0.3
58Obsoletes: kbanking < %{version}
59
60%description -n qbanking
61This package contains the qbanking KDE bindings for the Aqbanking
62online banking library.
63
64%package -n qbanking-devel
65Summary: Development headers for qbanking
66Group: Development/Libraries
67Requires: %{name}-devel = %{version}-%{release}
68Requires: qbanking = %{version}-%{release}
69Requires: pkgconfig
70Requires: qt-devel
71Obsoletes: kbanking-devel < %{version}
72
73%description -n qbanking-devel
74This package contains qbanking-config and header files for writing and
75compiling programs using the qbanking bindings for Aqbanking.
76
77%package -n python-%{name}
78Summary: Python bindings for Aqbanking
79Group: Development/Libraries
80Requires: %{name} = %{version}-%{release}
81
82%description -n python-%{name}
83This package contains python bindings for Aqbanking.
84
85%prep
86%setup -q
87%patch2 -p1 -b .pkgconfig
88%patch3 -p1 -b .conflict
89
90%build
91[ -z "$QTDIR" ] && . /etc/profile.d/qt.sh
92%{configure} --disable-static \
93  --with-kde3-libs=%{_libdir} \
94  --enable-libofx \
95  --enable-python
96
97make LIBTOOL=/usr/bin/libtool
98
99%install
100rm -rf $RPM_BUILD_ROOT
101
102make DESTDIR=$RPM_BUILD_ROOT LIBTOOL=/usr/bin/libtool install
103
104find $RPM_BUILD_ROOT -name *.la -exec rm -f {} \;
105find $RPM_BUILD_ROOT -name *.a -exec rm -f {} \;
106
107cd tutorials
108make clean
109rm -rf .deps
110cd ..
111
112mkdir -p $RPM_BUILD_ROOT/%{_datadir}/doc/%{name}-%{version}
113mv $RPM_BUILD_ROOT/%{_datadir}/doc/{aqbanking,aqhbci} $RPM_BUILD_ROOT/%{_datadir}/doc/%{name}-%{version}
114mv AUTHORS README COPYING ChangeLog NEWS $RPM_BUILD_ROOT/%{_datadir}/doc/%{name}-%{version}
115%find_lang %{name}
116
117%clean
118rm -rf $RPM_BUILD_ROOT
119
120%post -p /sbin/ldconfig
121
122%postun -p /sbin/ldconfig
123
124%post -n qbanking -p /sbin/ldconfig
125
126%postun -n qbanking -p /sbin/ldconfig
127
128%files -f %{name}.lang
129%defattr(-,root,root)
130%doc %{_datadir}/doc/%{name}-%{version}
131%{_libdir}/libaq*.so.*
132%{_libdir}/aqbanking
133%exclude %{_libdir}/aqbanking/plugins/*/debugger
134%exclude %{_libdir}/aqbanking/plugins/*/frontends/qbanking
135%exclude %{_libdir}/aqbanking/plugins/*/wizards
136%{_libdir}/gwenhywfar/*
137%{_datadir}/aqbanking
138%exclude %{_datadir}/aqbanking/frontends/*
139%exclude %{_datadir}/aqbanking/i18n
140%{_bindir}/*-tool3
141
142%files devel
143%defattr(-,root,root)
144%doc doc/0[12]* tutorials
145%{_bindir}/hbcixml3
146%{_bindir}/aq*-config
147%{_libdir}/libaq*.so
148%{_includedir}/aq*
149%{_libdir}/pkgconfig/*
150%{_datadir}/aclocal/aq*
151
152%files -n qbanking
153%defattr(-,root,root)
154%{_bindir}/qb-help5
155%{_libdir}/libqbanking.so.*
156%{_libdir}/aqbanking/plugins/*/debugger
157%{_libdir}/aqbanking/plugins/*/frontends/qbanking
158%{_libdir}/aqbanking/plugins/*/wizards
159%{_datadir}/aqbanking/i18n
160%{_datadir}/aqbanking/frontends/qbanking
161
162%files -n qbanking-devel
163%defattr(-,root,root)
164%{_includedir}/qbanking
165%{_libdir}/libqbanking.so
166
167%files -n python-%{name}
168%defattr(-,root,root)
169%{python_sitelib}/%{name}
170
171%changelog
172* Sat Oct 11 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.7.1-1
173- update to 3.7.2
174- obsolete the no-longer-existing g2banking/kbanking packages
175
176* Mon Jan 21 2008 NAKAMURA Kenta <kenta@vinelinux.org> 2.3.3-0vl1
177- update to 2.3.3
178
179* Sat Dec 29 2007 NAKAMURA Kenta <kenta@vinelinux.org> 2.3.2-2vl1
180- modify and build for VineSeed
181
182* Wed Aug 29 2007 Bill Nottingham <notting@redhat.com> - 2.3.2-2
183- Rebuild for selinux ppc32 issue.
184- fix build with current glibc/headers
185
186* Fri Aug  3 2007 Bill Nottingham <notting@redhat.com>
187- tweak license tag
188
189* Wed Jul 11 2007 Bill Nottingham <notting@redhat.com> - 2.3.2-1
190- update to 2.3.2
191
192* Mon Jun 25 2007 Bill Nottingham <notting@redhat.com> - 2.2.9-3
193- fix some build bogosity
194
195* Wed Jun 20 2007 Bill Nottingham <notting@redhat.com> - 2.2.9-2
196- add a dist tag
197
198* Mon Mar 19 2007 Bill Nottingham <notting@redhat.com> - 2.2.9-1
199- update to 2.2.9
200
201* Wed Jan 17 2007 Bill Nottingham <notting@redhat.com> - 2.1.0-14
202- fix docdir, obsoletes for aqhbci-devel, and %%clean
203
204* Tue Jan 16 2007 Bill Nottingham <notting@redhat.com> - 2.1.0-13
205- fix docs
206- add PyXML buildreq
207
208* Mon Jan 15 2007 Bill Nottingham <notting@redhat.com> - 2.1.0-12
209- fix missing %%defattrs
210- fix %%excludes
211- other cleanups from review
212- use %%{_python_sitelib}
213- require automake
214- twiddle aqhbci obsoletes
215
216* Sat Jan 13 2007 Bill Nottingham <notting@redhat.com> - 2.1.0-11
217- split into a variety of packages
218
219* Thu Dec  7 2006 Jeremy Katz <katzj@redhat.com> - 2.1.0-10
220- rebuild for python 2.5
221
222* Thu Sep  7 2006 Bill Nottingham <notting@redhat.com> - 2.1.0-9
223- rebuild for fixed debuginfo (#205248)
224
225* Fri Sep  1 2006 Bill Nottingham <notting@redhat.com> - 2.1.0-8
226- fix multilib conficts (#205204)
227
228* Mon Aug 28 2006 Bill Nottingham <notting@redhat.com> - 2.1.0-4
229- rebuild against latest libofx
230
231* Tue Aug  1 2006 Bill Nottingham <notting@redhat.com> - 2.1.0-3
232- reenable visibility
233
234* Fri Jul 14 2006 Bill Nottingham <notting@redhat.com> - 2.1.0-2
235- port *-config to pkgconfig
236- don't use -fvisibility=hidden
237
238* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.1.0-1.1
239- rebuild
240
241* Tue Jul 11 2006 Bill Nottingham <notting@redhat.com> - 2.1.0-1
242- update to 2.1.0
243
244* Mon Jun 12 2006 Bill Nottingham <notting@redhat.com> - 1.8.1beta-5
245- buildreq autoconf, libtool
246
247* Tue May 30 2006 Bill Nottingham <notting@redhat.com> - 1.8.1beta-4
248- add gettext buildreq (#193348)
249
250* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.8.1beta-3.1
251- bump again for double-long bug on ppc(64)
252
253* Tue Feb 07 2006 Karsten Hopp <karsten@redhat.de> 1.8.1beta-3
254- buildrequire libofx-devel instead of libofx (pulls in libofx)
255
256* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.8.1beta-2.1
257- rebuilt for new gcc4.1 snapshot and glibc changes
258
259* Sun Jan 22 2006 Bill Nottingham <notting@redhat.com> 1.8.1beta-2
260- add an obsolete (#178554)
261
262* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
263- rebuilt
264
265* Mon Mar  7 2005 Bill Nottingham <notting@redhat.com> 1.0.4beta-2
266- rebuild
267
268* Wed Feb  9 2005 Bill Nottingham <notting@redhat.com> 1.0.4beta-1
269- initial packaging, adopt upstream specfile
Note: See TracBrowser for help on using the repository browser.