source: projects/specs/trunk/a/apt-cron/apt-cron-vl.spec @ 521

Revision 521, 1.3 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Name: apt-cron
2Version: 0.1
3Release: 1%{?_dist_release}
4Vendor: Project Vine
5Distribution: Vine Linux
6License: GPL
7Group: Applications/Administration
8Source0: apt-cron.init
9Source1: apt-cron.cron
10Source2: apt-cron.logrotate
11BuildRoot: %{_tmppath}/%{name}-%{version}-root
12BuildArch: noarch
13Requires: apt
14Prereq: chkconfig
15Summary: Daily apt update
16
17%description
18Enable daily run of apt update by cron or anacron.
19
20%prep
21
22%build
23
24%install
25%__rm -rf %{buildroot}
26%__mkdir_p %{buildroot}/etc/rc.d/init.d/
27%__install %{SOURCE0} %{buildroot}/etc/rc.d/init.d/apt-cron
28%__mkdir_p %{buildroot}/etc/cron.daily/
29%__install %{SOURCE1} %{buildroot}/etc/cron.daily/apt-cron
30%__mkdir_p %{buildroot}/etc/logrotate.d/
31%__install -m644 %{SOURCE2} %{buildroot}/etc/logrotate.d/apt-cron
32
33%clean
34%__rm -rf %{buildroot}
35
36%post
37/sbin/chkconfig --add apt-cron
38
39%preun
40if [ $1 = 0 ]; then
41    /sbin/chkconfig --del apt-cron
42fi
43
44%files
45%defattr(-,root,root)
46/etc/rc.d/init.d/apt-cron
47/etc/cron.daily/apt-cron
48/etc/logrotate.d/apt-cron
49
50%changelog
51* Sun Sep 14 2008 Shu KONNO <owa@bg.wakwak.com> 0.1-1vl5
52- applied new versioning policy
53
54* Sun Jul 22 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.1-0vl2
55- changed Group to Applications/Administration
56
57* Fri Jun 18 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 0.1-0vl1
58- Initial build.
59
Note: See TracBrowser for help on using the repository browser.