source: projects/specs/trunk/a/apel/apel-vl.spec @ 521

Revision 521, 5.9 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define _noVersionedDependencies        1
2%define prereq_ge()  %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
3
4%define       origver       10.7
5%define       origname      apel       
6
7Summary:      A Portable Emacs Library
8Summary(ja):  Emacs 用の 基礎的な関数を提供するライブラリ
9Name:         %{origname}
10Version:      %{origver}
11Release:      2%{?_dist_release}
12
13Source0:      http://kanji.zinbun.kyoto-u.ac.jp/~tomo/lemi/dist/apel/apel-%{origver}.tar.gz
14Source1:      apel-install.sh
15Source2:      apel-remove.sh
16Source3:      apel-init.el
17
18Patch10:      apel-10.3-APEL-ELS.diff
19
20License:      1993-1999 Free Software Foundation, Inc., Dan Rich, Morioka Tomohiko, Kobayashi Shuhei
21Group:        Applications/Editors/Emacs
22BuildRoot:    %{_tmppath}/%{name}-%{version}-root
23BuildArch:    noarch
24
25Requires(post,preun): emacsen
26%prereq_ge    emacsen-common
27Obsoletes:    %{origname}-el
28Conflicts:    semi <= 1.14.5-0vl2
29
30Vendor:       Project Vine
31Distribution: Vine Linux
32Packager:     Kazuhisa TAKEI <takei@vinelinux.org>
33
34
35%description
36This package contains following .el files for emacsen:
37
38  APEL       %{origver}
39
40APEL stands for "A Portable Emacs Library".
41It provides basic functions and macros for emacsen.
42
43Note: in order to rebuild this SRPM package, you need emacsen
44and emacsen-common installed.
45
46
47%description -l ja
48このパッケージは GNU Emacs %{emacsver} 上で使用する
49以下の elisp を収めています.
50
51  APEL       %{origver}
52
53APEL は "A Portable Emacs Library" の略です.
54Emacs 環境のための基礎的な関数やマクロを提供します.
55
56注意:この SRPM パッケージを rebuild するには、emacsen と emacsen-common が
57インストールされている必要があります.
58
59
60%prep
61%setup  -n %{origname}-%{origver}
62
63%patch10 -p1
64
65
66%install
67
68[ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
69[ "${RPM_BUILD_ROOT}" != "/" ] && mkdir -p ${RPM_BUILD_ROOT}
70
71mkdir -p $RPM_BUILD_ROOT/%{_datadir}/emacs/site-lisp/%{origname}
72mkdir -p $RPM_BUILD_ROOT/%{_libdir}/emacsen-common/packages/install
73mkdir -p $RPM_BUILD_ROOT/%{_libdir}/emacsen-common/packages/remove
74
75#
76# install el files
77#
78
79cp Makefile EMU-* APEL-* *.el %{SOURCE3} \
80   ${RPM_BUILD_ROOT}/usr/share/emacs/site-lisp/%{origname}
81
82#
83# install  script( bytecompile el and install elc , remove )   
84#
85
86%_installemacsenscript %{origname} %{SOURCE1}
87
88%_removeemacsenscript  %{origname} %{SOURCE2}
89
90
91%post
92
93#
94# bytecompile and install
95#
96
97if [ "$1" = 2 ]; then
98
99%_emacsenPackageRemove %{origname}
100
101fi
102
103%_addemacsenlist %{origname}
104
105%_emacsenPackageInstall %{origname}
106
107
108%preun
109
110if [ "$1" = 0 ]; then
111
112%_emacsenPackageRemove %{origname}
113
114%_removeemacsenlist %{origname}
115
116fi
117
118
119%triggerpostun -- apel-el
120
121%_emacsenPackageInstall %{origname}
122
123
124%clean
125[ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
126
127
128%files
129%defattr(-,root,root)
130%doc ChangeLog README*
131/usr/share/emacs/site-lisp/%{origname}/
132/usr/lib/emacsen-common/packages/install/%{origname}
133/usr/lib/emacsen-common/packages/remove/%{origname}
134
135 
136%changelog
137* Sun Mar 29 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 10.7-2
138- spec in utf8
139
140* Fri May  2 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 10.7-1
141- applied new versioning policy
142
143* Fri Dec  7 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 10.7-0vl1
144- updated to 10.7
145
146* Mon Sep 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 10.6-0vl3
147- changed Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
148
149* Wed Dec 24 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 10.6-0vl2
150- rebuilt
151
152* Tue Jul  8 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 10.6-0vl1
153- updated to new upstream version 10.6
154
155* Mon Jun 09 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 10.5-0vl1
156- updated to new upstream version 10.5
157
158* Mon May 19 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 10.4-0vl1
159- update.
160- Tag Changed(Copyright -> License)
161
162* Fri Jan 11 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 10.3-0vl9
163- Obsoletes: apel-el now, instead of Conflicts:
164- added %%triggerpostun -- apel-el
165
166* Fri Dec 28 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 10.3-0vl8
167- package name changed apel-el -> apel again
168- added Source3 for forthcoming site-start mechanism
169
170* Thu Dec 06 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 10.3-0vl7
171- activate file-detect and atype (Patch10), especially for xemacs
172
173* Thu Dec 06 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 10.3-0vl6
174- fixed the target directory for emu modules to be installed
175- included missing documents again
176- cleanup the spec file
177
178* Wed Jul 18 2001 Kazuhisa TAKEI <takei@vinelinux.org>
179- emacsenize
180
181* Wed Jul 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
182- 1.14.3-0vl2
183- back to Requires: emacs = 20.7 -> emacs >= 20.7 (for emacs-beta)
184
185* Wed Jul 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
186- 1.14.3-0vl1
187- updated to apel-10.3, flim-1.14.3, semi-1.14.3, emh-1.14.1
188
189* Fri Aug 25 2000 MATSUBAYASHI 'Shaolin' Kohji
190- 1.13.7-8
191- added %define _noVersionedDependencies 1
192
193* Fri Aug 25 2000 MATSUBAYASHI 'Shaolin' Kohji
194- 1.13.7-7
195- modified %files section to handle compressed man page(s)
196
197* Wed May 10 2000 MATSUBAYASHI 'Shaolin' Kohji
198- 1.13.7-6
199- apel updated to 10.2
200
201* Mon Jan 24 2000 MATSUBAYASHI 'Shaolin' Kohji
202- 1.13.7-5
203- added patch (see emacs-mime-ja: 00303) to format texinfo correctly
204
205* Thu Dec 24 1999 MATSUBAYASHI 'Shaolin' Kohji
206- 1.13.7-4
207- updated in sync with apel-10.0 / clime-1.13.6 release
208
209* Wed Dec  1 1999 MATSUBAYASHI 'Shaolin' Kohji
210- 1.13.7-3
211- change Group to Applications/Editors/EmacsLisp
212
213* Mon Nov 29 1999 MATSUBAYASHI 'Shaolin' Kohji
214- 1.13.7-2
215- added patches (see emacs-mime-ja:00183, emacs-mime-ja:00184)
216- now emh-1.10.1 and rmail-mime-1.13.0 are also included
217- documentation files are properly stored under /usr/doc directory
218
219* Wed Nov  3 1999 MATSUBAYASHI 'Shaolin' Kohji
220- 1.13.7-1
221- updated to apel-9.23 / clime-1.13.5 / semi-1.13.7 release
222- added Japanese / English info files to be installed
Note: See TracBrowser for help on using the repository browser.