source: projects/specs/trunk/a/apache2/apache2-vl.spec @ 8601

Revision 8601, 27.5 KB checked in by daisuke, 10 years ago (diff)

apache2: small fix

Line 
1%define contentdir %{_datadir}/apache2
2%define docroot /var/www/apache2
3%define suexec_caller www-data
4%define mmn 20051115
5%define mmnisa %{mmn}%{__isa_name}%{__isa_bits}
6%define pkgname apache2
7%define vstring Vine
8
9Summary: Apache HTTP Server
10Name: %{pkgname}
11Version: 2.4.9
12Release: 2%{_dist_release}
13URL: http://httpd.apache.org/
14
15Vendor: Project Vine
16Distribution: Vine Linux
17Packager: daisuke
18
19Source0: http://www.apache.org/dist/httpd/httpd-%{version}.tar.bz2
20Source2: index.html
21Source3: apache2.logrotate
22Source4: apache2.init
23Source6: poweredby-vine.png
24Source7: apache2.tmpfiles
25Source10: httpd.conf
26Source11: 00-base.conf
27Source12: 00-mpm.conf
28Source13: 00-lua.conf
29Source14: 01-cgi.conf
30Source15: 00-dav.conf
31Source16: 00-proxy.conf
32Source17: 00-ssl.conf
33Source18: 01-ldap.conf
34Source19: 00-proxyhtml.conf
35Source20: userdir.conf
36Source21: ssl.conf
37Source22: welcome.conf
38Source23: manual.conf
39Source25: 01-session.conf
40# Documentation
41Source30: README.confd
42Source31: README.confmod
43# add vine entry to config.layout
44Source100: vine-config.layout
45
46# build/scripts patches
47Patch1: httpd-2.4.1-apctl.patch
48Patch2: httpd-2.4.1-apxs.patch
49Patch3: httpd-2.4.1-deplibs.patch
50# Features/functional changes
51Patch23: httpd-2.4.4-export.patch
52Patch24: httpd-2.4.1-corelimit.patch
53Patch26: httpd-2.4.4-r1337344+.patch
54Patch27: httpd-2.4.2-icons.patch
55Patch30: httpd-2.4.4-cachehardmax.patch
56Patch31: httpd-2.4.6-sslmultiproxy.patch
57Patch32: httpd-2.4.7-r1537535.patch
58Patch33: httpd-2.4.9-r1573626.patch
59# Bug fixes
60Patch55: httpd-2.4.4-malformed-host.patch
61Patch56: httpd-2.4.4-mod_unique_id.patch
62
63# Security fixes
64
65License: Apache Software License
66Group: System Environment/Daemons
67BuildRoot: %{_tmppath}/%{name}-%{version}-root
68BuildRequires: db4-devel, expat-devel, xmlto
69BuildRequires: findutils, perl, openldap-devel, zlib-devel
70BuildRequires: apr-devel, apr-util-devel
71BuildRequires: pcre-devel, sqlite3-devel
72BuildRequires: lua-devel, libxml2-devel
73BuildRequires: www-common
74Requires: mailcap, gawk, file, findutils, apr, apr-util
75Requires(pre): www-common
76Requires(pre): chkconfig, mktemp, fileutils
77Requires(pre): sh-utils, textutils, shadow-utils
78Requires(post): alternatives
79Provides: webserver
80Provides: httpd = %{version}
81Provides: httpd-mmn = %{mmn}
82Provides: apache2-mmn = %{mmn}
83Obsoletes: apache2-apr, apache2-apr-devel
84Obsoletes: apache < 2.0, apache-devel < 2.0
85
86%description
87Apache is a powerful, full-featured, efficient, and freely-available
88Web server. Apache is also the most popular Web server on the
89Internet.
90
91%package devel
92Group: Development/Libraries
93Summary: Development tools for the Apache HTTP server.
94Requires: libtool, apache2 = %{version}
95Requires: apr-devel, apr-util-devel
96
97%description devel
98The httpd-devel package contains the APXS binary and other files
99that you need to build Dynamic Shared Objects (DSOs) for Apache.
100
101If you are installing the Apache HTTP server and you want to be
102able to compile or develop additional modules for Apache, you need
103to install this package.
104
105%package manual
106Group: Applications/Documentation
107Summary: Documentation for the Apache HTTP server.
108
109%description manual
110The httpd-manual package contains the complete manual and
111reference guide for the Apache HTTP server. The information can
112also be found at http://httpd.apache.org/docs/.
113
114%package -n mod_ssl-apache2
115Group: System Environment/Daemons
116Summary: SSL/TLS module for the Apache HTTP server
117Epoch: 1
118BuildRequires: openssl-devel
119Requires(pre): openssl, dev, /bin/cat
120Requires: apache2, make, apache2-mmn = %{mmn}
121
122%description -n mod_ssl-apache2
123The mod_ssl module provides strong cryptography for the Apache Web
124server via the Secure Sockets Layer (SSL) and Transport Layer
125Security (TLS) protocols.
126
127%prep
128%setup -q -n httpd-%{version}
129
130%patch1 -p1 -b .apctl
131%patch2 -p1 -b .apxs
132%patch3 -p1 -b .deplibs
133
134%patch23 -p1 -b .export
135%patch24 -p1 -b .corelimit
136%patch26 -p1 -b .r1337344+
137%patch27 -p1 -b .icons
138%patch30 -p1 -b .cachehardmax
139%patch31 -p1 -b .sslmultiproxy
140%patch32 -p1 -b .r1537535
141%patch33 -p1 -b .r1573626
142
143%patch55 -p1 -b .malformedhost
144%patch56 -p1 -b .uniqueid
145
146# Patch in the vendor string
147sed -i '/^#define PLATFORM/s/Unix/%{vstring}/' os/unix/os.h
148
149# Prevent use of setcap in "install-suexec-caps" target.
150sed -i '/suexec/s,setcap ,echo Skipping setcap for ,' Makefile.in
151
152# add Vine configure's option to config.layout
153sed -e "s|${prefix}/lib|${prefix}/%{_lib}|" \
154  < $RPM_SOURCE_DIR/vine-config.layout >> config.layout
155
156%build
157# remove bundled apr, apr-util, pcre
158rm -rf srclib/{apr,apr-util,pcre}
159
160# regenerate configure scripts
161autoheader && autoconf || exit 1
162
163CFLAGS="$RPM_OPT_FLAGS"
164SH_LDFLAGS="-Wl,-z,relro"
165export CFLAGS SH_LDFLAGS
166
167AP_CONFOPTS="\
168        --prefix=%{_sysconfdir}/apache2 \
169        --exec-prefix=%{_prefix} \
170        --bindir=%{_bindir} \
171        --sbindir=%{_sbindir} \
172        --mandir=%{_mandir} \
173        --libdir=%{_libdir} \
174        --sysconfdir=%{_sysconfdir}/apache2/conf \
175        --includedir=%{_includedir}/apache2 \
176        --libexecdir=%{_libdir}/apache2/modules \
177        --datadir=%{contentdir} \
178        --with-installbuilddir=%{_libdir}/apache2/build \
179        --enable-layout=Vine \
180        --with-program-name=apache2 \
181        --with-ldap \
182        --enable-ldap --enable-authnz-ldap \
183        --enable-mods-shared=all \
184        --enable-cache=shared \
185        --enable-cgi=shared \
186        --enable-cgid=shared \
187        --enable-rewrite=shared \
188        --enable-disk-cache=shared \
189        --enable-file-cache=shared \
190        --enable-mem-cache=shared \
191        --enable-authn-anon --enable-authn-alias \
192        --with-apr=%{_prefix} --with-apr-util=%{_prefix} \
193        --enable-suexec --with-suexec \
194        --enable-suexec-capabilities \
195        --with-suexec-caller=%{suexec_caller} \
196        --with-suexec-docroot=%{docroot} \
197        --with-suexec-logfile=%{_localstatedir}/log/apache2/suexec.log \
198        --with-suexec-bin=%{_libdir}/%{pkgname}/suexec \
199        --with-suexec-uidmin=500 --with-suexec-gidmin=500 \
200        --with-pcre \
201        --enable-pie \
202        --enable-ssl --with-ssl \
203        --enable-deflate \
204        --enable-proxy --enable-proxy-connect \
205        --enable-proxy-http --enable-proxy-ftp \
206        --enable-case-filter --enable-case-filter-in \
207        --enable-mpms-shared=all"
208./configure ${AP_CONFOPTS}
209make %{?_smp_mflags}
210
211%install
212rm -rf $RPM_BUILD_ROOT
213
214make DESTDIR=$RPM_BUILD_ROOT install
215
216# create apache2ctl symlink
217ln -sf apachectl $RPM_BUILD_ROOT%{_sbindir}/apache2ctl
218
219# install conf file/directory
220mkdir $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf.d \
221      $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf.modules.d \
222      $RPM_BUILD_ROOT%{_sysconfdir}/apache2/sites.d
223install -m 644 $RPM_SOURCE_DIR/README.confd \
224   $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf.d/README
225install -m 644 $RPM_SOURCE_DIR/README.confmod \
226   $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf.modules.d/README
227
228for f in 00-base.conf 00-mpm.conf 00-lua.conf 01-cgi.conf 00-dav.conf \
229         00-proxy.conf 00-ssl.conf 01-ldap.conf 00-proxyhtml.conf \
230         01-ldap.conf 01-session.conf; do
231  install -m 644 -p $RPM_SOURCE_DIR/$f \
232                    $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf.modules.d/$f
233done
234
235for f in welcome.conf ssl.conf manual.conf userdir.conf; do
236  install -m 644 -p $RPM_SOURCE_DIR/$f \
237     $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf.d/$f
238done
239
240# Split-out extra config shipped as default in conf.d:
241for f in autoindex; do
242  mv docs/conf/extra/httpd-${f}.conf \
243     $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf.d/${f}.conf
244done
245         
246# Extra config trimmed:
247rm -v docs/conf/extra/httpd-{ssl,userdir}.conf
248
249rm $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/*.conf
250install -m 644 -p $RPM_SOURCE_DIR/httpd.conf \
251   $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/httpd.conf
252ln -sf httpd.conf $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/apache2.conf
253
254# tmpfiles.d configuration
255mkdir -p $RPM_BUILD_ROOT%{_prefix}/lib/tmpfiles.d
256install -m 644 -p $RPM_SOURCE_DIR/apache2.tmpfiles \
257   $RPM_BUILD_ROOT%{_prefix}/lib/tmpfiles.d/apache2.conf
258
259# Other directories
260mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/lib/dav \
261         $RPM_BUILD_ROOT/run/apache2/htcacheclean
262
263# Create cache directory
264mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/cache/apache2 \
265         $RPM_BUILD_ROOT%{_localstatedir}/cache/apache2/proxy \
266         $RPM_BUILD_ROOT%{_localstatedir}/cache/apache2/ssl
267
268# Make the MMN accessible to module packages
269echo %{mmnisa} > $RPM_BUILD_ROOT%{_includedir}/apache2/.mmn
270mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/rpm
271cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.apache2 <<EOF
272%%_httpd_mmn %{mmnisa}
273%%_httpd_apxs %%{_bindir}/apxs
274%%_httpd_modconfdir %%{_sysconfdir}/apache2/conf.modules.d
275%%_httpd_confdir %%{_sysconfdir}/apache2/conf.d
276%%_httpd_contentdir %{contentdir}
277%%_httpd_moddir %%{_libdir}/apache2/modules
278%%_apache2_mmn %{mmnisa}
279%%_apache2_apxs %%{_bindir}/apxs
280%%_apache2_modconfdir %%{_sysconfdir}/apache2/conf.modules.d
281%%_apache2_confdir %%{_sysconfdir}/apache2/conf.d
282%%_apache2_contentdir %{contentdir}
283%%_apache2_moddir %%{_libdir}/apache2/modules
284EOF
285
286# Handle contentdir
287mkdir $RPM_BUILD_ROOT%{contentdir}/noindex
288install -m 644 -p $RPM_SOURCE_DIR/index.html \
289        $RPM_BUILD_ROOT%{contentdir}/noindex/index.html
290install -m 644 -p $RPM_SOURCE_DIR/poweredby-vine.png \
291        $RPM_BUILD_ROOT%{contentdir}/icons/
292rm -rf %{contentdir}/htdocs
293
294# remove manual sources
295find $RPM_BUILD_ROOT%{contentdir}/manual \( \
296    -name \*.xml -o -name \*.xml.* -o -name \*.ent -o -name \*.xsl -o -name \*.dtd \
297    \) -print0 | xargs -0 rm -f
298
299# Strip the manual down just to English and replace the typemaps with flat files:
300set +x
301for f in `find $RPM_BUILD_ROOT%{contentdir}/manual -name \*.html -type f`; do
302   if test -f ${f}.en; then
303      cp ${f}.en ${f}
304      rm ${f}.*
305   fi
306done
307set -x
308
309# Clean Document Root
310rm -v $RPM_BUILD_ROOT%{docroot}/html/*.html
311rm -v $RPM_BUILD_ROOT/var/www/cgi-bin/*
312
313# symlinks for /etc/apache2
314ln -s ../..%{_localstatedir}/log/apache2 $RPM_BUILD_ROOT/etc/apache2/logs
315ln -s /run/apache2 $RPM_BUILD_ROOT/etc/apache2/run
316ln -s ../..%{_libdir}/apache2/modules $RPM_BUILD_ROOT/etc/apache2/modules
317
318# install SYSV init stuff
319mkdir -p $RPM_BUILD_ROOT/etc/rc.d/init.d
320install -m755 $RPM_SOURCE_DIR/apache2.init \
321        $RPM_BUILD_ROOT/etc/rc.d/init.d/apache2
322%{__perl} -pi -e "s:\@docdir\@:%{_docdir}/%{name}-%{version}:g" \
323        $RPM_BUILD_ROOT/etc/rc.d/init.d/apache2
324
325# Install logrotate config
326mkdir -p $RPM_BUILD_ROOT/etc/logrotate.d
327install -m 644 -p $RPM_SOURCE_DIR/apache2.logrotate \
328        $RPM_BUILD_ROOT/etc/logrotate.d/apache2
329
330# fix man page paths
331sed -e "s|/usr/local/apache2/conf/httpd.conf|/etc/apache2/conf/httpd.conf|" \
332    -e "s|/usr/local/apache2/conf/mime.types|/etc/mime.types|" \
333    -e "s|/usr/local/apache2/conf/magic|/etc/apache2/conf/magic|" \
334    -e "s|/usr/local/apache2/logs/error_log|/var/log/apache2/error_log|" \
335    -e "s|/usr/local/apache2/logs/access_log|/var/log/apache2/access_log|" \
336    -e "s|/usr/local/apache2/logs/httpd.pid|/run/apache2/apache2.pid|" \
337    -e "s|/usr/local/apache2|/etc/httpd|" < docs/man/httpd.8 \
338  > $RPM_BUILD_ROOT%{_mandir}/man8/httpd.8
339
340# Make ap_config_layout.h libdir-agnostic
341sed -i '/.*DEFAULT_..._LIBEXECDIR/d;/DEFAULT_..._INSTALLBUILDDIR/d' \
342    $RPM_BUILD_ROOT%{_includedir}/apache2/ap_config_layout.h
343
344# Fix path to instdso in special.mk
345sed -i '/instdso/s,top_srcdir,top_builddir,' \
346    $RPM_BUILD_ROOT%{_libdir}/apache2/build/special.mk
347
348# Remove unpackaged files
349rm -vf \
350      $RPM_BUILD_ROOT%{_libdir}/*.exp \
351      $RPM_BUILD_ROOT/etc/apache2/conf/mime.types \
352      $RPM_BUILD_ROOT%{_libdir}/apache2/modules/*.exp \
353      $RPM_BUILD_ROOT%{_libdir}/apache2/build/config.nice \
354      $RPM_BUILD_ROOT%{_bindir}/{ap?-config,dbmmanage} \
355      $RPM_BUILD_ROOT%{_sbindir}/{checkgid,envvars*} \
356      $RPM_BUILD_ROOT%{contentdir}/htdocs/* \
357      $RPM_BUILD_ROOT%{_mandir}/man1/dbmmanage.* \
358      $RPM_BUILD_ROOT%{contentdir}/cgi-bin/*
359
360rm -rf $RPM_BUILD_ROOT/etc/apache2/conf/{original,extra}
361
362
363
364%triggerpostun -- apache < 2.0
365/sbin/chkconfig --add apache2
366
367
368%post
369/sbin/chkconfig --add apache2
370
371%preun
372if [ $1 = 0 ]; then
373        /sbin/service apache2 stop > /dev/null 2>&1
374        /sbin/chkconfig --del apache2
375fi
376
377%postun
378if [ "$1" -ge 1 ]; then
379        /sbin/service apache2 condrestart
380fi
381/sbin/ldconfig
382
383%define sslcert %{_sysconfdir}/pki/tls/certs/localhost.crt
384%define sslkey %{_sysconfdir}/pki/tls/private/localhost.key
385
386%post -n mod_ssl-apache2
387umask 077
388
389if [ -f %{sslkey} -o -f %{sslcert} ]; then
390  exit 0
391fi
392
393%{_bindir}/openssl genrsa \
394  -rand /proc/apm:/proc/cpuinfo:/proc/dma:/proc/filesystems:/proc/interrupts:/proc/ioports:/proc/pci:/proc/rtc:/proc/uptime \
395  2048 > %{sslkey} 2> /dev/null ||:
396
397FQDN=`hostname` ||:
398if [ "x${FQDN}" = "x" ]; then
399   FQDN=localhost.localdomain
400fi
401   
402cat << EOF | %{_bindir}/openssl req -new -key %{sslkey} \
403         -x509 -sha256 -days 3650 -set_serial $RANDOM -extensions v3_req \
404         -out %{sslcert} 2>/dev/null ||:
405--
406SomeState
407SomeCity
408SomeOrganization
409SomeOrganizationalUnit
410${FQDN}
411root@${FQDN}
412EOF
413
414%clean
415rm -rf $RPM_BUILD_ROOT
416
417%files
418%defattr(-,root,root)
419
420%doc ABOUT_APACHE README CHANGES LAYOUT LICENSE
421%doc migration.html migration.css
422%doc docs/conf/extra/*.conf
423
424%dir %{_sysconfdir}/apache2
425%{_sysconfdir}/apache2/modules
426%{_sysconfdir}/apache2/logs
427%{_sysconfdir}/apache2/run
428%dir %{_sysconfdir}/apache2/conf
429%config(noreplace) %{_sysconfdir}/apache2/conf/httpd.conf
430%config(noreplace) %{_sysconfdir}/apache2/conf/apache2.conf
431%config(noreplace) %{_sysconfdir}/apache2/conf/magic
432
433%config(noreplace) %{_sysconfdir}/logrotate.d/apache2
434
435%config %{_sysconfdir}/rc.d/init.d/apache2
436
437%dir %{_sysconfdir}/apache2/conf.d
438%{_sysconfdir}/apache2/conf.d/README
439%config(noreplace) %{_sysconfdir}/apache2/conf.d/*.conf
440%exclude %{_sysconfdir}/apache2/conf.d/ssl.conf
441%exclude %{_sysconfdir}/apache2/conf.d/manual.conf
442
443%dir %{_sysconfdir}/apache2/conf.modules.d
444%{_sysconfdir}/apache2/conf.modules.d/README
445%config(noreplace) %{_sysconfdir}/apache2/conf.modules.d/*.conf
446%exclude %{_sysconfdir}/apache2/conf.modules.d/00-ssl.conf
447
448%dir %{_sysconfdir}/apache2/sites.d
449
450%{_prefix}/lib/tmpfiles.d/apache2.conf
451
452%{_bindir}/ab
453%{_bindir}/ht*
454%{_bindir}/logresolve
455%{_sbindir}/ht*
456%{_sbindir}/apache2
457%{_sbindir}/apachectl
458%{_sbindir}/apache2ctl
459%{_sbindir}/rotatelogs
460%{_sbindir}/fcgistarter
461%attr(4510,root,%{suexec_caller}) %{_sbindir}/suexec
462
463%dir %{_libdir}/apache2
464%dir %{_libdir}/apache2/modules
465%{_libdir}/apache2/modules/mod_*.so
466%exclude %{_libdir}/apache2/modules/mod_ssl.so
467
468%dir %{contentdir}
469%dir %{contentdir}/icons
470%dir %{contentdir}/error
471%dir %{contentdir}/error/include
472%dir %{contentdir}/noindex
473%{contentdir}/icons/*
474%{contentdir}/error/README
475%{contentdir}/error/*.var
476%{contentdir}/error/include/*.html
477%{contentdir}/noindex/index.html
478
479%dir %{docroot}/html
480%dir /var/www/cgi-bin
481
482%attr(0710,root,www-data) %dir /run/apache2
483%attr(0700,www-data,www-data) %dir /run/apache2/htcacheclean
484
485%attr(0700,root,root) %dir %{_localstatedir}/log/apache2
486%attr(0700,www-data,www-data) %dir %{_localstatedir}/lib/dav
487%attr(0700,www-data,www-data) %dir %{_localstatedir}/cache/apache2
488%attr(0700,www-data,www-data) %dir %{_localstatedir}/cache/apache2/proxy
489
490%{_mandir}/man1/*
491%exclude %{_mandir}/man1/apxs*
492
493%{_mandir}/man8/*
494
495
496%files manual
497%defattr(-,root,root)
498%{contentdir}/manual
499%config(noreplace) %{_sysconfdir}/apache2/conf.d/manual.conf
500
501
502%files -n mod_ssl-apache2
503%defattr(-,root,root)
504%{_libdir}/apache2/modules/mod_ssl.so
505%config(noreplace) %{_sysconfdir}/apache2/conf.modules.d/00-ssl.conf
506%config(noreplace) %{_sysconfdir}/apache2/conf.d/ssl.conf
507%attr(0700,www-data,www-data) %dir %{_localstatedir}/cache/apache2/ssl
508
509
510%files devel
511%defattr(-,root,root)
512%{_includedir}/apache2
513%{_bindir}/apxs
514%{_mandir}/man1/apxs*
515%dir %{_libdir}/apache2/build
516%{_libdir}/apache2/build/*.mk
517%{_libdir}/apache2/build/*.sh
518%{_sysconfdir}/rpm/macros.apache2
519
520
521%changelog
522* Wed Jun 25 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 2.4.9-2
523- modify dependency
524
525* Wed Jun 25 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 2.4.9-1
526- update to 2.4.9
527- remove suffix '2' from {htdigest,htpasswd,rotatelogs}2
528- use /run instead of /var/run
529- remove /etc/apache2/conf/ssl* , use /etc/pki now.
530- move suexec from %%{_libdir}/apache2 to %%{_sbindir}
531- split all LoadModules to conf.modules.d/*.conf
532- split module configs to conf.d/*.conf
533- cleanup docroot, move apache specific files to %%{_datadir}/apache2
534- add BR: lua-devel, libxml2-devel
535- add /etc/apache2/sites.d for virtual host settings.
536
537* Wed Dec 25 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.25-2
538- merge VineSeed spec file
539  * Wed Oct 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.23-2
540  - rebuild with pcre-8.31
541
542  * Wed Mar 21 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.23-1
543  - update to 2.2.23
544  - add R(pre): www-common, BR: www-common
545  - move apache contents to %{contentdir}
546
547* Sat Sep 28 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.25-1
548- new upstream release with security fix (CVE-2013-1862,1896)
549- drop patch100 (is included in new release)
550
551* Fri May 17 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.24-2
552- add patch100 for fix CVE-2013-1862 (mod_rewrite)
553
554* Wed Feb 27 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.24-1
555- new upstream release with security fix (CVE-2012-3499, 4558)
556
557* Sun Sep 16 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.23-1
558- new upstream release with security fix (CVE-2012-3502,CVE-2012-2687)
559- update patch22 to fit new release
560- update man filename convert list
561
562* Wed Mar 21 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.22-1
563- update to 2.2.22
564  - CVE-2012-0021 (mod_log_config)
565  - CVE-2012-0031
566  - CVE-2012-0053
567- remove upstreamed patches
568
569* Fri Dec  9 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.21-5
570- add patch120 for fix CVE-2011-4317 (mod_rewrite/mod_proxy)
571
572* Fri Nov 18 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.21-4
573- add patch110 for fix CVE-2011-3607-4415 (ModSetEnvIf)
574
575* Wed Oct 12 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.21-3
576- add patch70 for fix byterange filter
577
578* Tue Oct 11 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.21-2
579- add Patch100 for fix CVE-2011-3368 (mod_proxy)
580
581* Wed Sep 14 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.21-1
582- new upstream release with security fix (CVE-2011-3348)
583- regression fixes of CVE-2011-3192 byterange fix in 2.2.20
584
585* Tue Sep  6 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.20-3
586- update Patch101 (Thanks to debian team)
587
588* Sat Sep  3 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.20-2
589- add Patch101 for fix CVE-2011-3192 regression
590
591* Thu Sep  1 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.20-1
592- new upstream release with security fix (CVE-2011-3192)
593- drop patch100 (is included in new release)
594
595* Thu Aug 25 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.19-2
596- add patch100 for fix CVE-2011-3192 (Range Header DoS)
597
598* Mon May 23 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.19-1
599- update to 2.2.19
600
601* Sat Apr 30 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.14-9
602- remove old Obsoletes/Conflicts
603
604* Tue Jan 11 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.14-8
605- rebuild with openssl-1.0.0c
606
607* Sat Aug 21 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.14-7
608- add  patch120 for fix CVE-2010-1452 (mod_dav/mod_cache) from mdk2010
609
610* Wed Aug 18 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.14-6
611- add R(post): alternatives
612
613* Sat Mar 20 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 2.2.14-5
614- add patch110 for fix CVE-2010-0434 from mdk 2010
615
616* Sun Mar  7 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 2.2.14-4
617- add patch100 for fix CVE-2010-0408 (mod_proxy_ajp)
618
619* Fri Feb  5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.2.14-3
620- rebuilt with rpm-4.8.0-3 (on ppc)
621
622* Tue Feb 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.14-2
623- rebuild with db4-4.8.0
624
625* Tue Jan 05 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.14-1
626- new upstream release with security fix
627  (CVE-2009-2699, CVE-2009-3095, CVE-2009-3094)
628- fix ssl.conf (2.2.13-1 includes wrong file)
629
630* Sun Aug 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.13-1
631- new upstream release
632
633* Wed Jul 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.12-1
634- new upstream release
635  (including security fix for CVE-2009-1890, CVE-2009-1191,
636   CVE-2009-1195, CVE-2009-1955, CVE-2009-1956, CVE-2009-0023)
637
638* Fri Jan 09 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.11-2
639- rebuilt with openldap-2.4.11
640
641* Fri Jan  2 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.11-1
642- new upstream release
643
644* Sat Oct 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.10-1
645- new upstream release (including security fix for CVE-2008-2939)
646
647* Fri Jun 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.9-1
648- new upstream release (including security fix for CVE-2008-2364, CVE-2007-6420)
649- built with db4-4.6.21, apr 1.3.0
650
651* Sun Apr 27 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 2.2.8-1
652- add Patch60 (to fix bug#31418).
653
654* Thu Feb 21 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.8-0vl2
655- rebuild with expat-2.0.1
656
657* Tue Jan 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.8-0vl1
658- new upstream release
659
660* Sat Nov  3 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.6-0vl2
661- added postun script from VinePlus/4.0 package
662  * Tue Sep 11 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.3-0vl3.2
663  - add postun script to restart daemon with message
664
665* Sun Jul 01 2007 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.3-0vl8
666- updated Patch2: httpd-2.2.3-apxs.patch
667
668* Sun Jun 24 2007 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.3-0vl7
669- modified libdir in config.layout for lib64 architecture
670
671* Sun May 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.3-0vl6
672- rebuilt with openssl-0.9.8e
673
674* Thu May 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.2.3-0vl5
675- rebuilt with new toolchain and db4-4.3.x
676
677* Wed Feb  7 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.3-0vl4
678- added BuildRequires: pcre-devel, sqlite3-devel <BTS:VineLinux:474>
679
680* Mon Sep 11 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.2.3-0vl3
681- change manual Group to Applications/Documentation. <BTS:VineLinux:163>
682
683* Sun Aug 27 2006 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.3-0vl2
684- rebuilt with openldap-2.3.27-0vl1
685
686* Sat Jul 29 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.3-0vl1
687- new upstream release including security fix (CVE-2006-3747)
688
689* Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
690- new upstream release
691  - update to 2.2.2
692- remove apr/apr-devel subpackage,
693  use external apr/apr-util instead of internal one.
694
695* Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.58-0vl1
696- new upstream release
697- use apache2.prefork as default.
698
699* Thu Mar 23 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.55-0vl3
700- rebuild to use new _localstatedir (rpm-4.4.2-0vl11)
701- remove unpackaged files in %%install section
702
703* Fri Jan 27 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.55-0vl2
704- fix logrotate configuration (use apache2.pid instead of httpd.pid)
705  (BTS:10)
706- use Epoch instead of Serial
707
708* Sat Oct 15 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.55-0vl1
709- new upstream release
710- drop obsolete security patches which is merged in upstream
711
712* Sat Oct 08 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.54-0vl1
713- new upstream release
714
715* Sun Sep 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.53-0vl2
716- added Patch122 to 125 for secutiry fix
717  (CAN-2004-{1268,2088,2700,2728})
718- fix %install section
719
720* Sun Apr 10 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.53-0vl1
721- new upstream release
722
723* Sat Nov 06 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.52-0vl1
724- new upstream release
725
726* Sun Oct 24 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.50-0vl4
727- rebuilt with db4-4.2.52
728
729* Sat Sep  4 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 2.0.50-0vl3
730- separate apr, apr-devel packages
731- add BuildPreReq: zlib-devel
732
733* Sun Jul 11 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.50-0vl2
734- fix %%files to include instdso.sh
735  thanks to jax <jax AT morejams DOT no-ip DOT com>
736- add %%{?_smp_mflags} to make option.
737
738* Sun Jul  4 2004 IWAI, Masaharu <iwai@alib.jp> 2.0.50-0vl1
739- new upstream version
740
741* Sun Nov 23 2003 IWAI, Masaharu <iwai@alib.jp> 2.0.48-0vl1
742- new upstream version
743
744* Mon Sep 15 2003 IWAI, Masaharu <iwai@alib.jp> 2.0.47-0vl1
745- new upstream version
746- update apxs patch (Patch101)
747- fix dependency:
748    - change file name to package name in Requires and {Build,}Prereq
749- add BuildPrereq: openldap-devel
750- update %%files section
751- rename httpd.8 manpage
752
753* Mon May 12 2003 Satoshi MACHINO <machino@vinelinux.org> 2.0.45-0vl1
754- new upstream version
755- used vine-config.layout in srclib
756
757* Mon May 12 2003 Satoshi MACHINO <machino@vinelinux.org> 2.0.44-0vl9
758- rebuild
759
760* Sun Apr  6 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl8
761- change pkg name from mod_ssl to mod_ssl-apache2
762- remove "apache-manual" entry from Obsoletes:
763
764* Thu Apr  3 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl7
765- remove "mod_dav" and "apache-devel" from Obsoletes:
766- enable MPMS(worker %mpms )
767
768* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl6
769- add correct config_vars.mk
770
771* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl5
772- apply apxs's patch ( from Debian)
773
774* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl4
775- add apr-config,apu-config to devel's %file
776
777* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl3
778- change apxs path ( /usr/sbin -> /usr/bin
779- add symlink under /etc/apache2/conf
780  (logs, run), httpd.conf -> apache2.conf
781- fixed apache2 initscript.
782
783* Sat Mar 29 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl2
784- build Vine Linux
785- new upstream version
786- sharing with apache1
787
788* Wed Sep  4 2002 Nalin Dahyabhai <nalin@redhat.com> 2.0.40-8
789- link httpd with libssl to avoid library loading/unloading weirdness
790
791* Tue Sep  3 2002 Joe Orton <jorton@redhat.com> 2.0.40-7
792- add LoadModule lines for proxy modules in httpd.conf (#73349)
793- fix permissions of conf/ssl.*/ directories; add Makefiles for
794  certificate management (#73352)
795
796* Mon Sep  2 2002 Joe Orton <jorton@redhat.com> 2.0.40-6
797- provide "httpd-mmn" to manage module ABI compatibility
798
799* Sun Sep  1 2002 Joe Orton <jorton@redhat.com> 2.0.40-5
800- fix SSL session cache (#69699)
801- revert addition of LDAP support to apr-util
802
803* Mon Aug 26 2002 Joe Orton <jorton@redhat.com> 2.0.40-4
804- set SIGXFSZ disposition to "ignored" (#69520)
805- make dummy connections to the first listener in config (#72692)
806
807* Mon Aug 26 2002 Joe Orton <jorton@redhat.com> 2.0.40-3
808- allow "apachectl configtest" on a 1.3 httpd.conf
809- add mod_deflate
810- enable LDAP support in apr-util
811- don't package everything in /var/www/error as config(noreplace)
812
813* Wed Aug 21 2002 Bill Nottingham <notting@redhat.com> 2.0.40-2
814- add trigger (#68657)
815
816* Mon Aug 12 2002 Joe Orton <jorton@redhat.com> 2.0.40-1
817- update to 2.0.40
818
819* Wed Jul 24 2002 Joe Orton <jorton@redhat.com> 2.0.36-8
820- improve comment on use of UserDir in default config (#66886)
821
822* Wed Jul 10 2002 Joe Orton <jorton@redhat.com> 2.0.36-7
823- use /sbin/nologin as shell for apache user (#68371)
824- add patch from CVS to fix possible infinite loop when processing
825  internal redirects
826
827* Wed Jun 26 2002 Gary Benson <gbenson@redhat.com> 2.0.36-6
828- modify init script to detect 1.3.x httpd.conf's and direct users
829  to the migration guide
830
831* Tue Jun 25 2002 Gary Benson <gbenson@redhat.com> 2.0.36-5
832- patch apachectl to detect 1.3.x httpd.conf's and direct users
833  to the migration guide
834- ship the migration guide
835
836* Fri Jun 21 2002 Joe Orton <jorton@redhat.com>
837- move /etc/httpd2 back to /etc/httpd
838- add noindex.html page and poweredby logo; tweak default config
839  to load noindex.html if no default "/" page is present.
840- add patch to prevent mutex errors on graceful restart
841
842* Fri Jun 21 2002 Tim Powers <timp@redhat.com> 2.0.36-4
843- automated rebuild
844
845* Wed Jun 12 2002 Joe Orton <jorton@redhat.com> 2.0.36-3
846- add patch to fix SSL mutex handling
847
848* Wed Jun 12 2002 Joe Orton <jorton@redhat.com> 2.0.36-2
849- improved config directory patch
850
851* Mon May 20 2002 Joe Orton <jorton@redhat.com>
852- initial build; based heavily on apache.spec and mod_ssl.spec
853- fixes: #65214, #58490, #57376, #61265, #65518, #58177, #57245
854
Note: See TracBrowser for help on using the repository browser.