source: projects/specs/trunk/a/apache2/apache2-vl.spec @ 521

Revision 521, 23.0 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define contentdir /var/www
2%define suexec_caller apache
3%define mmn 20020903
4%define pkgname apache2
5
6Summary: Apache HTTP Server
7Name: %{pkgname}
8Version: 2.2.14
9Release: 3%{_dist_release}
10URL: http://httpd.apache.org/
11
12Vendor: Project Vine
13Distribution: Vine Linux
14Packager: daisuke
15
16Source0: http://www.apache.org/dist/httpd/httpd-%{version}.tar.bz2
17Source1: index.html.ja
18Source3: apache2.logrotate
19Source4: apache2.init
20Source5: README.confd
21Source6: vine.png
22Source10: httpd.conf
23Source11: apache-ssl.conf
24Source12: migration.html
25Source13: migration.css
26Source14: mod_ssl-Makefile.crt
27Source15: mod_ssl-Makefile.crl
28# add vine entry to config.layout
29Source100: vine-config.layout
30# man files
31Source101: apache2.8
32Source102: apache2ctl.8
33#Source103: config_vars.mk
34# build/scripts patches
35Patch1: httpd-2.1.10-apctl.patch
36Patch2: httpd-2.2.3-apxs.patch
37Patch3: httpd-2.0.45-deplibs.patch
38Patch4: httpd-2.1.10-disablemods.patch
39# features/functional changes
40Patch21: httpd-2.0.40-xfsz.patch
41Patch22: httpd-2.1.10-pod.patch
42Patch23: httpd-2.0.45-export.patch
43Patch24: httpd-2.0.48-corelimit.patch
44# Bug fixes
45Patch54: httpd-2.2.0-authnoprov.patch
46Patch60: httpd-2.2.3-sslusername.patch
47
48# Security fixes
49
50
51License: Apache Software License
52Group: System Environment/Daemons
53BuildRoot: %{_tmppath}/%{name}-%{version}-root
54BuildRequires: db4-devel, expat-devel
55BuildRequires: findutils, perl, openldap-devel, zlib-devel
56BuildRequires: apr-devel, apr-util-devel
57BuildRequires: pcre-devel, sqlite3-devel
58Requires: mailcap, gawk, file, findutils, apr, apr-util
59Requires(pre): chkconfig, mktemp, fileutils
60Requires(pre): sh-utils, textutils, shadow-utils
61Provides: webserver
62Provides: httpd = %{version}
63Provides: httpd-mmn = %{mmn}
64Conflicts: thttpd
65Obsoletes: secureweb
66Obsoletes: apache2-apr, apache2-apr-devel
67
68%description
69Apache is a powerful, full-featured, efficient, and freely-available
70Web server. Apache is also the most popular Web server on the
71Internet.
72
73%package devel
74Group: Development/Libraries
75Summary: Development tools for the Apache HTTP server.
76Obsoletes: secureweb-devel
77Requires: libtool, httpd = %{version}
78Requires: apr-devel, apr-util-devel
79
80%description devel
81The httpd-devel package contains the APXS binary and other files
82that you need to build Dynamic Shared Objects (DSOs) for Apache.
83
84If you are installing the Apache HTTP server and you want to be
85able to compile or develop additional modules for Apache, you need
86to install this package.
87
88%package manual
89Group: Applications/Documentation
90Summary: Documentation for the Apache HTTP server.
91Obsoletes: secureweb-manual
92
93%description manual
94The httpd-manual package contains the complete manual and
95reference guide for the Apache HTTP server. The information can
96also be found at http://httpd.apache.org/docs/.
97
98%package -n mod_ssl-apache2
99Group: System Environment/Daemons
100Summary: SSL/TLS module for the Apache HTTP server
101Epoch: 1
102BuildRequires: openssl-devel
103Requires(pre): openssl, dev, /bin/cat
104Requires: httpd, make, httpd-mmn = %{mmn}
105
106%description -n mod_ssl-apache2
107The mod_ssl module provides strong cryptography for the Apache Web
108server via the Secure Sockets Layer (SSL) and Transport Layer
109Security (TLS) protocols.
110
111%prep
112%setup -q -n httpd-%{version}
113
114%patch1 -p1 -b .apctl
115%patch2 -p1 -b .apxs
116#patch3 -p1 -b .deplibs
117%patch4 -p1 -b .disablemods
118
119%patch21 -p0 -b .xfsz
120%patch22 -p1 -b .pod
121%patch23 -p1 -b .export
122%patch24 -p1 -b .corelimit
123
124%patch54 -p1 -b .authnoprov
125%patch60 -p1 -b .sslusername
126
127
128# copy across the migration guide and sed it's location into apachectl
129cp $RPM_SOURCE_DIR/migration.{html,css} .
130%{__perl} -pi -e "s:\@docdir\@:%{_docdir}/%{name}-%{version}:g" \
131        support/apachectl.in
132
133
134# add Vine configure's option to config.layout
135sed -e "s|${prefix}/lib|${prefix}/%{_lib}|" \
136  < $RPM_SOURCE_DIR/vine-config.layout >> config.layout
137
138# regenerate configure scripts
139./buildconf
140
141%build
142# remove bundled apr, apr-util, pcre
143rm -rf srclib/{apr,apr-util,pcre}
144
145#CFLAGS="$RPM_OPT_FLAGS -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64"
146#AP_LIBS="-lssl -lcrypto"
147#export CFLAGS AP_LIBS
148CFLAGS="$RPM_OPT_FLAGS"
149SH_LDFLAGS="-Wl,-z,relro"
150export CFLAGS SH_LDFLAGS
151
152%define mpms worker prefork
153%define prefer_mpm prefork
154
155AP_CONFOPTS="\
156        --prefix=%{_sysconfdir}/apache2 \
157        --exec-prefix=%{_prefix} \
158        --bindir=%{_bindir} \
159        --sbindir=%{_sbindir} \
160        --mandir=%{_mandir} \
161        --libdir=%{_libdir} \
162        --sysconfdir=%{_sysconfdir}/apache2/conf \
163        --includedir=%{_includedir}/apache2 \
164        --libexecdir=%{_libdir}/apache2/modules \
165        --datadir=%{contentdir} \
166        --with-installbuilddir=%{_libdir}/apache2/build \
167        --enable-layout=Vine \
168        --with-program-name=apache2 \
169        --with-ldap \
170        --enable-ldap --enable-authnz-ldap \
171        --enable-mods-shared=all \
172        --enable-cache=shared \
173        --enable-cgi=shared \
174        --enable-cgid=shared \
175        --enable-rewrite=shared \
176        --enable-disk-cache=shared \
177        --enable-file-cache=shared \
178        --enable-mem-cache=shared \
179        --enable-authn-anon --enable-authn-alias \
180        --with-apr=%{_prefix} --with-apr-util=%{_prefix} \
181        --enable-suexec --with-suexec \
182        --with-suexec-caller=%{suexec_caller} \
183        --with-suexec-docroot=%{contentdir} \
184        --with-suexec-logfile=%{_localstatedir}/log/apache2/suexec.log \
185        --with-suexec-bin=%{_libdir}/%{pkgname}/suexec \
186        --with-suexec-uidmin=500 --with-suexec-gidmin=500 \
187        --with-pcre \
188        --enable-ssl --with-ssl \
189        --enable-deflate \
190        --enable-proxy --enable-proxy-connect \
191        --enable-proxy-http --enable-proxy-ftp"
192#all  mpm build
193for mpm in %{mpms}; do
194   mkdir mpm-$mpm;
195   cd mpm-$mpm;
196   ../configure $AP_CONFOPTS --with-mpm=$mpm --srcdir=../ ;
197   make %{?_smp_mflags} ;
198#   mv apache2 apache2.$mpm ;
199   cd ../
200done
201
202%install
203rm -rf $RPM_BUILD_ROOT
204
205# Classify ab and logresolve as section 1 commands, as they are in /usr/bin
206cp -p docs/man/ab.8 docs/man/ab.1
207sed -e "1s/logresolve 8/logresolve 1/" \
208  < docs/man/logresolve.8 > docs/man/logresolve.1
209#rm docs/man/logresolve.8
210
211# install mpms binary
212pushd mpm-prefork
213  make DESTDIR=$RPM_BUILD_ROOT install
214  rm -f $RPM_BUILD_ROOT/%{_sbindir}/apache2
215popd
216
217for mpm in %{mpms}; do
218    install -m755 mpm-$mpm/apache2 $RPM_BUILD_ROOT/%{_sbindir}/apache2.$mpm
219done
220
221# install conf file/directory
222mkdir $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf.d
223install -m 644 $RPM_SOURCE_DIR/README.confd \
224   $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf.d/README
225install -m 644 $RPM_SOURCE_DIR/apache-ssl.conf \
226   $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf.d/ssl.conf
227
228rm $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/*.conf
229install -m 644 $RPM_SOURCE_DIR/httpd.conf \
230   $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/httpd.conf
231
232# mod_ssl bits
233for suffix in crl crt csr key prm; do
234   mkdir $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/ssl.${suffix}
235done
236
237# Makefiles for certificate management
238for ext in crt crl; do
239  install -m 644 $RPM_SOURCE_DIR/mod_ssl-Makefile.${ext} \
240        $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/ssl.${ext}/Makefile.${ext}
241done
242ln -s ../../../usr/share/ssl/certs/Makefile $RPM_BUILD_ROOT/etc/apache2/conf
243
244# for holding mod_dav lock database
245mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/lib/dav
246
247# create a prototype session cache
248mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/cache/mod_ssl
249touch $RPM_BUILD_ROOT%{_localstatedir}/cache/mod_ssl/scache.{dir,pag,sem}
250
251# move utilities to /usr/bin
252mv $RPM_BUILD_ROOT%{_sbindir}/{ab,htdbm,logresolve,htpasswd,htdigest} \
253   $RPM_BUILD_ROOT%{_bindir}
254
255# Make the MMN accessible to module packages
256echo %{mmn} > $RPM_BUILD_ROOT%{_includedir}/apache2/.mmn
257
258# docroot
259# mkdir $RPM_BUILD_ROOT%{contentdir}/html
260install -m 644 $RPM_SOURCE_DIR/index.html.ja \
261        $RPM_BUILD_ROOT%{contentdir}/error/noindex.html
262rm -r $RPM_BUILD_ROOT%{contentdir}/manual/style
263
264install -m 644 $RPM_SOURCE_DIR/vine.png \
265        $RPM_BUILD_ROOT%{contentdir}/icons
266
267# logs
268# rmdir $RPM_BUILD_ROOT%{_sysconfdir}/apache2/logs
269mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/log/apache2
270
271ln -sf %{_sysconfdir}/%{pkgname}/conf/httpd.conf $RPM_BUILD_ROOT/%{_sysconfdir}/%{pkgname}/conf/apache2.conf
272
273
274# symlinks for /etc/apache2
275ln -s ../..%{_localstatedir}/log/apache2 $RPM_BUILD_ROOT/etc/apache2/logs
276ln -s ../..%{_localstatedir}/run $RPM_BUILD_ROOT/etc/apache2/run
277ln -s ../..%{_libdir}/apache2/modules $RPM_BUILD_ROOT/etc/apache2/modules
278ln -s ../..%{_libdir}/apache2/build $RPM_BUILD_ROOT/etc/apache2/build
279
280# install SYSV init stuff
281mkdir -p $RPM_BUILD_ROOT/etc/rc.d/init.d
282install -m755 $RPM_SOURCE_DIR/apache2.init \
283        $RPM_BUILD_ROOT/etc/rc.d/init.d/apache2
284%{__perl} -pi -e "s:\@docdir\@:%{_docdir}/%{name}-%{version}:g" \
285        $RPM_BUILD_ROOT/etc/rc.d/init.d/apache2
286
287# install log rotation stuff
288mkdir -p $RPM_BUILD_ROOT/etc/logrotate.d
289install -m644 $RPM_SOURCE_DIR/apache2.logrotate \
290        $RPM_BUILD_ROOT/etc/logrotate.d/apache2
291
292mv $RPM_BUILD_ROOT/%{_sbindir}/apachectl $RPM_BUILD_ROOT/%{_sbindir}/apache2ctl
293
294# fix man page paths
295sed -e "s|/usr/local/apache2/conf/httpd.conf|/etc/apache2/conf/httpd.conf|" \
296    -e "s|/usr/local/apache2/conf/mime.types|/etc/mime.types|" \
297    -e "s|/usr/local/apache2/conf/magic|/etc/apache2/conf/magic|" \
298    -e "s|/usr/local/apache2/logs/error_log|/var/log/apache2/error_log|" \
299    -e "s|/usr/local/apache2/logs/access_log|/var/log/apache2/access_log|" \
300    -e "s|/usr/local/apache2/logs/httpd.pid|/var/run/apache2.pid|" \
301    -e "s|/usr/local/apache2|/etc/httpd|" < $RPM_SOURCE_DIR/apache2.8 \
302  > $RPM_BUILD_ROOT%{_mandir}/man8/apache2.8
303
304install -m644 $RPM_SOURCE_DIR/apache2ctl.8 \
305        $RPM_BUILD_ROOT%{_mandir}/man8/apache2ctl.8
306
307# change command name to avoid conflict with apache1 pacjage
308%define cflcmd /usr/bin/htdigest /usr/bin/htpasswd /usr/sbin/rotatelogs
309
310for i in %{cflcmd}; do \
311  echo $i
312  mv $RPM_BUILD_ROOT$i $RPM_BUILD_ROOT$i"2";
313done;
314
315mv $RPM_BUILD_ROOT/%{_sbindir}/apxs $RPM_BUILD_ROOT/%{_bindir}/apxs
316
317%define cflman usr/share/man/man1/dbmmanage.1 usr/share/man/man1/htdigest.1 usr/share/man/man1/htpasswd.1 usr/share/man/man8/rotatelogs.8 usr/share/man/man8/suexec.8 usr/share/man/man8/apxs.8 usr/share/man/man8/httpd.8
318
319(cd $RPM_BUILD_ROOT;
320for i in %{cflman}; do \
321    echo $i | sed -e "s|\.1|2\.1|" -e "s|\.8|2\.8|" |    xargs mv $i ;
322   
323done;
324)
325
326#cp $RPM_SOURCE_DIR/config_vars.mk $RPM_BUILD_ROOT/%{_sysconfdir}/%{pkgname}/build/.
327mv $RPM_BUILD_ROOT/%{_sbindir}/suexec $RPM_BUILD_ROOT/%{_libdir}/%{pkgname}/suexec
328
329
330rm -f $RPM_BUILD_ROOT%{_mandir}/man1/ab*
331rm -f $RPM_BUILD_ROOT%{_mandir}/man1/logresolve*
332# conflict with apache 1, so removed...
333rm -f $RPM_BUILD_ROOT%{_mandir}/man8/ab*
334rm -f $RPM_BUILD_ROOT%{_mandir}/man8/logresolve*
335
336# remove unpackaged files
337rm -f $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/mime.types \
338      $RPM_BUILD_ROOT%{_libdir}/*.la \
339      $RPM_BUILD_ROOT%{_libdir}/*.exp \
340      $RPM_BUILD_ROOT%{_libdir}/apache2/modules/*.exp \
341      $RPM_BUILD_ROOT%{_libdir}/apache2/build/config.nice \
342      $RPM_BUILD_ROOT%{_sbindir}/{apache2,checkgid,dbmmanage,envvars*} \
343      $RPM_BUILD_ROOT%{contentdir}/html/* \
344      $RPM_BUILD_ROOT%{contentdir}/cgi-bin/*
345
346%pre
347# Add the "apache" user
348/usr/sbin/useradd -c "Apache" -u 48 \
349        -s /sbin/nologin -r -d %{contentdir} apache 2> /dev/null || :
350
351%triggerpostun -- apache < 2.0
352/sbin/chkconfig --add apache2
353
354
355%post
356# Register the httpd service
357for mpm in %{mpms}; do
358  /sbin/update-alternatives --install %{_sbindir}/apache2 apache2 %{_sbindir}/apache2.$mpm 20;
359done
360/sbin/update-alternatives --install %{_sbindir}/apache2 apache2 %{_sbindir}/apache2.%{prefer_mpm} 30
361/sbin/chkconfig --add apache2
362
363%preun
364if [ $1 = 0 ]; then
365        /sbin/service apache2 stop > /dev/null 2>&1
366        /sbin/chkconfig --del apache2
367        for mpm in %{mpms}; do
368          /sbin/update-alternatives --remove apache2 %{_sbindir}/apache2.$mpm;
369        done 
370fi
371
372%postun
373if [ "$1" -ge 1 ]; then
374        /sbin/service apache2 condrestart
375fi
376/sbin/ldconfig
377
378%post -n mod_ssl-apache2
379/sbin/ldconfig ### is this needed?
380umask 077
381
382if [ ! -f %{_sysconfdir}/apache2/conf/ssl.key/server.key ] ; then
383%{_bindir}/openssl genrsa -rand /proc/apm:/proc/cpuinfo:/proc/dma:/proc/filesystems:/proc/interrupts:/proc/ioports:/proc/pci:/proc/rtc:/proc/uptime 1024 > %{_sysconfdir}/apache2/conf/ssl.key/server.key 2> /dev/null
384fi
385
386FQDN=`hostname`
387if [ "x${FQDN}" = "x" ]; then
388   FQDN=localhost.localdomain
389fi
390
391if [ ! -f %{_sysconfdir}/apache2/conf/ssl.crt/server.crt ] ; then
392cat << EOF | %{_bindir}/openssl req -new -key %{_sysconfdir}/apache2/conf/ssl.key/server.key -x509 -days 365 -out %{_sysconfdir}/apache2/conf/ssl.crt/server.crt 2>/dev/null
393--
394SomeState
395SomeCity
396SomeOrganization
397SomeOrganizationalUnit
398${FQDN}
399root@${FQDN}
400EOF
401fi
402
403%clean
404rm -rf $RPM_BUILD_ROOT
405
406%files
407%defattr(-,root,root)
408
409%doc ABOUT_APACHE README CHANGES LAYOUT LICENSE
410%doc migration.html migration.css
411
412%dir %{_sysconfdir}/apache2
413%{_sysconfdir}/apache2/modules
414%{_sysconfdir}/apache2/logs
415%{_sysconfdir}/apache2/run
416%dir %{_sysconfdir}/apache2/conf
417%config(noreplace) %{_sysconfdir}/apache2/conf/*.conf
418%config(noreplace) %{_sysconfdir}/apache2/conf/magic
419
420%config %{_sysconfdir}/logrotate.d/apache2
421%config %{_sysconfdir}/rc.d/init.d/apache2
422
423%dir %{_sysconfdir}/apache2/conf.d
424%{_sysconfdir}/apache2/conf.d/README
425
426%dir %{_sysconfdir}/apache2/conf/extra
427%config %{_sysconfdir}/apache2/conf/extra/*
428
429%dir %{_sysconfdir}/apache2/conf/original
430%{_sysconfdir}/apache2/conf/original/*
431
432%{_bindir}/ab
433%{_bindir}/ht*
434%{_bindir}/logresolve
435%{_sbindir}/ht*
436%{_sbindir}/apache2.*
437%{_sbindir}/apache2ctl
438%{_sbindir}/rotatelogs2
439%attr(4510,root,%{suexec_caller}) %{_libdir}/%{pkgname}/suexec
440
441%dir %{_libdir}/apache2
442%dir %{_libdir}/apache2/modules
443# everything but mod_ssl.so:
444%{_libdir}/apache2/modules/mod_[a-r]*.so
445%{_libdir}/apache2/modules/mod_s[petu]*.so
446%{_libdir}/apache2/modules/mod_[t-z]*.so
447
448%dir %{contentdir}
449%dir %{contentdir}/cgi-bin
450%dir %{contentdir}/html
451%dir %{contentdir}/icons
452%dir %{contentdir}/error
453%dir %{contentdir}/error/include
454%{contentdir}/icons/*
455%{contentdir}/error/README
456%{contentdir}/error/noindex.html
457%config(noreplace) %{contentdir}/error/*.var
458%config(noreplace) %{contentdir}/error/include/*.html
459
460%attr(0700,root,root) %dir %{_localstatedir}/log/apache2
461
462%attr(0700,apache,apache) %dir %{_localstatedir}/lib/dav
463
464%{_mandir}/man1/*
465
466%{_mandir}/man8/*
467
468%files manual
469%defattr(-,root,root)
470%{contentdir}/manual
471
472%files -n mod_ssl-apache2
473%defattr(-,root,root)
474%{_libdir}/apache2/modules/mod_ssl.so
475%config(noreplace) %{_sysconfdir}/apache2/conf.d/ssl.conf
476%attr(0700,root,root) %dir %{_sysconfdir}/apache2/conf/ssl.*
477%config %{_sysconfdir}/apache2/conf/Makefile
478%config %{_sysconfdir}/apache2/conf/ssl.*/*
479%attr(0700,apache,root) %dir %{_localstatedir}/cache/mod_ssl
480%attr(0600,apache,root) %ghost %{_localstatedir}/cache/mod_ssl/scache.dir
481%attr(0600,apache,root) %ghost %{_localstatedir}/cache/mod_ssl/scache.pag
482%attr(0600,apache,root) %ghost %{_localstatedir}/cache/mod_ssl/scache.sem
483
484%files devel
485%defattr(-,root,root)
486%{_includedir}/apache2
487%{_sysconfdir}/apache2/build
488%{_bindir}/apxs
489%{_mandir}/man8/apxs*
490%{_libdir}/apache2/build/*.mk
491%{_libdir}/apache2/build/*.sh
492
493%changelog
494* Fri Feb  5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.2.14-3
495- rebuilt with rpm-4.8.0-3 (on ppc)
496
497* Tue Feb 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.14-2
498- rebuild with db4-4.8.0
499
500* Tue Jan 05 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.14-1
501- new upstream release with security fix
502  (CVE-2009-2699, CVE-2009-3095, CVE-2009-3094)
503- fix ssl.conf (2.2.13-1 includes wrong file)
504
505* Sun Aug 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.13-1
506- new upstream release
507
508* Wed Jul 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.12-1
509- new upstream release
510  (including security fix for CVE-2009-1890, CVE-2009-1191,
511   CVE-2009-1195, CVE-2009-1955, CVE-2009-1956, CVE-2009-0023)
512
513* Fri Jan 09 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.11-2
514- rebuilt with openldap-2.4.11
515
516* Fri Jan  2 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.11-1
517- new upstream release
518
519* Sat Oct 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.10-1
520- new upstream release (including security fix for CVE-2008-2939)
521
522* Fri Jun 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.9-1
523- new upstream release (including security fix for CVE-2008-2364, CVE-2007-6420)
524- built with db4-4.6.21, apr 1.3.0
525
526* Sun Apr 27 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 2.2.8-1
527- add Patch60 (to fix bug#31418).
528
529* Thu Feb 21 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.8-0vl2
530- rebuild with expat-2.0.1
531
532* Tue Jan 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.8-0vl1
533- new upstream release
534
535* Sat Nov  3 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.6-0vl2
536- added postun script from VinePlus/4.0 package
537  * Tue Sep 11 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.3-0vl3.2
538  - add postun script to restart daemon with message
539
540* Sun Jul 01 2007 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.3-0vl8
541- updated Patch2: httpd-2.2.3-apxs.patch
542
543* Sun Jun 24 2007 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.3-0vl7
544- modified libdir in config.layout for lib64 architecture
545
546* Sun May 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.3-0vl6
547- rebuilt with openssl-0.9.8e
548
549* Thu May 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.2.3-0vl5
550- rebuilt with new toolchain and db4-4.3.x
551
552* Tue Feb  7 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.3-0vl4
553- added BuildRequires: pcre-devel, sqlite3-devel <BTS:VineLinux:474>
554
555* Mon Sep 11 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.2.3-0vl3
556- change manual Group to Applications/Documentation. <BTS:VineLinux:163>
557
558* Sun Aug 27 2006 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.3-0vl2
559- rebuilt with openldap-2.3.27-0vl1
560
561* Sat Jul 29 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.3-0vl1
562- new upstream release including security fix (CVE-2006-3747)
563
564* Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
565- new upstream release
566  - update to 2.2.2
567- remove apr/apr-devel subpackage,
568  use external apr/apr-util instead of internal one.
569
570* Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.58-0vl1
571- new upstream release
572- use apache2.prefork as default.
573
574* Thu Mar 23 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.55-0vl3
575- rebuild to use new _localstatedir (rpm-4.4.2-0vl11)
576- remove unpackaged files in %%install section
577
578* Fri Jan 27 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.55-0vl2
579- fix logrotate configuration (use apache2.pid instead of httpd.pid)
580  (BTS:10)
581- use Epoch instead of Serial
582
583* Sat Oct 15 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.55-0vl1
584- new upstream release
585- drop obsolete security patches which is merged in upstream
586
587* Sat Oct 08 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.54-0vl1
588- new upstream release
589
590* Sun Sep 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.53-0vl2
591- added Patch122 to 125 for secutiry fix
592  (CAN-2004-{1268,2088,2700,2728})
593- fix %install section
594
595* Sun Apr 10 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.53-0vl1
596- new upstream release
597
598* Sat Nov 06 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.52-0vl1
599- new upstream release
600
601* Sun Oct 24 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.50-0vl4
602- rebuilt with db4-4.2.52
603
604* Sat Sep  4 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 2.0.50-0vl3
605- separate apr, apr-devel packages
606- add BuildPreReq: zlib-devel
607
608* Sun Jul 11 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.50-0vl2
609- fix %%files to include instdso.sh
610  thanks to jax <jax AT morejams DOT no-ip DOT com>
611- add %%{?_smp_mflags} to make option.
612
613* Sun Jul  4 2004 IWAI, Masaharu <iwai@alib.jp> 2.0.50-0vl1
614- new upstream version
615
616* Sun Nov 23 2003 IWAI, Masaharu <iwai@alib.jp> 2.0.48-0vl1
617- new upstream version
618
619* Mon Sep 15 2003 IWAI, Masaharu <iwai@alib.jp> 2.0.47-0vl1
620- new upstream version
621- update apxs patch (Patch101)
622- fix dependency:
623    - change file name to package name in Requires and {Build,}Prereq
624- add BuildPrereq: openldap-devel
625- update %%files section
626- rename httpd.8 manpage
627
628* Tue May 12 2003 Satoshi MACHINO <machino@vinelinux.org> 2.0.45-0vl1
629- new upstream version
630- used vine-config.layout in srclib
631
632* Tue May 12 2003 Satoshi MACHINO <machino@vinelinux.org> 2.0.44-0vl9
633- rebuild
634
635* Sun Apr  6 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl8
636- change pkg name from mod_ssl to mod_ssl-apache2
637- remove "apache-manual" entry from Obsoletes:
638
639* Thu Apr  3 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl7
640- remove "mod_dav" and "apache-devel" from Obsoletes:
641- enable MPMS(worker %mpms )
642
643* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl6
644- add correct config_vars.mk
645
646* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl5
647- apply apxs's patch ( from Debian)
648
649* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl4
650- add apr-config,apu-config to devel's %file
651
652* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl3
653- change apxs path ( /usr/sbin -> /usr/bin
654- add symlink under /etc/apache2/conf
655  (logs, run), httpd.conf -> apache2.conf
656- fixed apache2 initscript.
657
658* Sat Mar 29 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl2
659- build Vine Linux
660- new upstream version
661- sharing with apache1
662
663* Wed Sep  4 2002 Nalin Dahyabhai <nalin@redhat.com> 2.0.40-8
664- link httpd with libssl to avoid library loading/unloading weirdness
665
666* Tue Sep  3 2002 Joe Orton <jorton@redhat.com> 2.0.40-7
667- add LoadModule lines for proxy modules in httpd.conf (#73349)
668- fix permissions of conf/ssl.*/ directories; add Makefiles for
669  certificate management (#73352)
670
671* Mon Sep  2 2002 Joe Orton <jorton@redhat.com> 2.0.40-6
672- provide "httpd-mmn" to manage module ABI compatibility
673
674* Sun Sep  1 2002 Joe Orton <jorton@redhat.com> 2.0.40-5
675- fix SSL session cache (#69699)
676- revert addition of LDAP support to apr-util
677
678* Mon Aug 26 2002 Joe Orton <jorton@redhat.com> 2.0.40-4
679- set SIGXFSZ disposition to "ignored" (#69520)
680- make dummy connections to the first listener in config (#72692)
681
682* Mon Aug 26 2002 Joe Orton <jorton@redhat.com> 2.0.40-3
683- allow "apachectl configtest" on a 1.3 httpd.conf
684- add mod_deflate
685- enable LDAP support in apr-util
686- don't package everything in /var/www/error as config(noreplace)
687
688* Wed Aug 21 2002 Bill Nottingham <notting@redhat.com> 2.0.40-2
689- add trigger (#68657)
690
691* Mon Aug 12 2002 Joe Orton <jorton@redhat.com> 2.0.40-1
692- update to 2.0.40
693
694* Wed Jul 24 2002 Joe Orton <jorton@redhat.com> 2.0.36-8
695- improve comment on use of UserDir in default config (#66886)
696
697* Wed Jul 10 2002 Joe Orton <jorton@redhat.com> 2.0.36-7
698- use /sbin/nologin as shell for apache user (#68371)
699- add patch from CVS to fix possible infinite loop when processing
700  internal redirects
701
702* Wed Jun 26 2002 Gary Benson <gbenson@redhat.com> 2.0.36-6
703- modify init script to detect 1.3.x httpd.conf's and direct users
704  to the migration guide
705
706* Tue Jun 25 2002 Gary Benson <gbenson@redhat.com> 2.0.36-5
707- patch apachectl to detect 1.3.x httpd.conf's and direct users
708  to the migration guide
709- ship the migration guide
710
711* Fri Jun 21 2002 Joe Orton <jorton@redhat.com>
712- move /etc/httpd2 back to /etc/httpd
713- add noindex.html page and poweredby logo; tweak default config
714  to load noindex.html if no default "/" page is present.
715- add patch to prevent mutex errors on graceful restart
716
717* Fri Jun 21 2002 Tim Powers <timp@redhat.com> 2.0.36-4
718- automated rebuild
719
720* Wed Jun 12 2002 Joe Orton <jorton@redhat.com> 2.0.36-3
721- add patch to fix SSL mutex handling
722
723* Wed Jun 12 2002 Joe Orton <jorton@redhat.com> 2.0.36-2
724- improved config directory patch
725
726* Mon May 20 2002 Joe Orton <jorton@redhat.com>
727- initial build; based heavily on apache.spec and mod_ssl.spec
728- fixes: #65214, #58490, #57376, #61265, #65518, #58177, #57245
Note: See TracBrowser for help on using the repository browser.