source: projects/specs/trunk/a/apache2/apache2-vl.spec @ 3942

Revision 3942, 23.7 KB checked in by daisuke, 13 years ago (diff)

apache2: update to 2.2.19

Line 
1%define contentdir /var/www
2%define suexec_caller apache
3%define mmn 20051115
4%define pkgname apache2
5
6Summary: Apache HTTP Server
7Name: %{pkgname}
8Version: 2.2.19
9Release: 1%{_dist_release}
10URL: http://httpd.apache.org/
11
12Vendor: Project Vine
13Distribution: Vine Linux
14Packager: daisuke
15
16Source0: http://www.apache.org/dist/httpd/httpd-%{version}.tar.bz2
17Source1: index.html.ja
18Source3: apache2.logrotate
19Source4: apache2.init
20Source5: README.confd
21Source6: vine.png
22Source10: httpd.conf
23Source11: apache-ssl.conf
24Source12: migration.html
25Source13: migration.css
26Source14: mod_ssl-Makefile.crt
27Source15: mod_ssl-Makefile.crl
28# add vine entry to config.layout
29Source100: vine-config.layout
30# man files
31Source101: apache2.8
32Source102: apache2ctl.8
33#Source103: config_vars.mk
34# build/scripts patches
35Patch1: httpd-2.1.10-apctl.patch
36Patch2: httpd-2.2.3-apxs.patch
37Patch3: httpd-2.0.45-deplibs.patch
38Patch4: httpd-2.1.10-disablemods.patch
39# features/functional changes
40Patch21: httpd-2.0.40-xfsz.patch
41Patch22: httpd-2.1.10-pod.patch
42Patch23: httpd-2.0.45-export.patch
43Patch24: httpd-2.0.48-corelimit.patch
44# Bug fixes
45Patch54: httpd-2.2.0-authnoprov.patch
46Patch60: httpd-2.2.3-sslusername.patch
47
48# Security fixes
49
50License: Apache Software License
51Group: System Environment/Daemons
52BuildRoot: %{_tmppath}/%{name}-%{version}-root
53BuildRequires: db4-devel, expat-devel
54BuildRequires: findutils, perl, openldap-devel, zlib-devel
55BuildRequires: apr-devel, apr-util-devel
56BuildRequires: pcre-devel, sqlite3-devel
57Requires: mailcap, gawk, file, findutils, apr, apr-util
58Requires(pre): chkconfig, mktemp, fileutils
59Requires(pre): sh-utils, textutils, shadow-utils
60Requires(post): alternatives
61Provides: webserver
62Provides: httpd = %{version}
63Provides: httpd-mmn = %{mmn}
64Obsoletes: apache2-apr, apache2-apr-devel
65
66%description
67Apache is a powerful, full-featured, efficient, and freely-available
68Web server. Apache is also the most popular Web server on the
69Internet.
70
71%package devel
72Group: Development/Libraries
73Summary: Development tools for the Apache HTTP server.
74Requires: libtool, httpd = %{version}
75Requires: apr-devel, apr-util-devel
76
77%description devel
78The httpd-devel package contains the APXS binary and other files
79that you need to build Dynamic Shared Objects (DSOs) for Apache.
80
81If you are installing the Apache HTTP server and you want to be
82able to compile or develop additional modules for Apache, you need
83to install this package.
84
85%package manual
86Group: Applications/Documentation
87Summary: Documentation for the Apache HTTP server.
88
89%description manual
90The httpd-manual package contains the complete manual and
91reference guide for the Apache HTTP server. The information can
92also be found at http://httpd.apache.org/docs/.
93
94%package -n mod_ssl-apache2
95Group: System Environment/Daemons
96Summary: SSL/TLS module for the Apache HTTP server
97Epoch: 1
98BuildRequires: openssl-devel
99Requires(pre): openssl, dev, /bin/cat
100Requires: httpd, make, httpd-mmn = %{mmn}
101
102%description -n mod_ssl-apache2
103The mod_ssl module provides strong cryptography for the Apache Web
104server via the Secure Sockets Layer (SSL) and Transport Layer
105Security (TLS) protocols.
106
107%prep
108%setup -q -n httpd-%{version}
109
110%patch1 -p1 -b .apctl
111%patch2 -p1 -b .apxs
112#patch3 -p1 -b .deplibs
113%patch4 -p1 -b .disablemods
114
115%patch21 -p0 -b .xfsz
116%patch22 -p1 -b .pod
117%patch23 -p1 -b .export
118%patch24 -p1 -b .corelimit
119
120%patch54 -p1 -b .authnoprov
121%patch60 -p1 -b .sslusername
122
123
124# copy across the migration guide and sed it's location into apachectl
125cp $RPM_SOURCE_DIR/migration.{html,css} .
126%{__perl} -pi -e "s:\@docdir\@:%{_docdir}/%{name}-%{version}:g" \
127        support/apachectl.in
128
129
130# add Vine configure's option to config.layout
131sed -e "s|${prefix}/lib|${prefix}/%{_lib}|" \
132  < $RPM_SOURCE_DIR/vine-config.layout >> config.layout
133
134# regenerate configure scripts
135./buildconf
136
137%build
138# remove bundled apr, apr-util, pcre
139rm -rf srclib/{apr,apr-util,pcre}
140
141#CFLAGS="$RPM_OPT_FLAGS -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64"
142#AP_LIBS="-lssl -lcrypto"
143#export CFLAGS AP_LIBS
144CFLAGS="$RPM_OPT_FLAGS"
145SH_LDFLAGS="-Wl,-z,relro"
146export CFLAGS SH_LDFLAGS
147
148%define mpms worker prefork
149%define prefer_mpm prefork
150
151AP_CONFOPTS="\
152        --prefix=%{_sysconfdir}/apache2 \
153        --exec-prefix=%{_prefix} \
154        --bindir=%{_bindir} \
155        --sbindir=%{_sbindir} \
156        --mandir=%{_mandir} \
157        --libdir=%{_libdir} \
158        --sysconfdir=%{_sysconfdir}/apache2/conf \
159        --includedir=%{_includedir}/apache2 \
160        --libexecdir=%{_libdir}/apache2/modules \
161        --datadir=%{contentdir} \
162        --with-installbuilddir=%{_libdir}/apache2/build \
163        --enable-layout=Vine \
164        --with-program-name=apache2 \
165        --with-ldap \
166        --enable-ldap --enable-authnz-ldap \
167        --enable-mods-shared=all \
168        --enable-cache=shared \
169        --enable-cgi=shared \
170        --enable-cgid=shared \
171        --enable-rewrite=shared \
172        --enable-disk-cache=shared \
173        --enable-file-cache=shared \
174        --enable-mem-cache=shared \
175        --enable-authn-anon --enable-authn-alias \
176        --with-apr=%{_prefix} --with-apr-util=%{_prefix} \
177        --enable-suexec --with-suexec \
178        --with-suexec-caller=%{suexec_caller} \
179        --with-suexec-docroot=%{contentdir} \
180        --with-suexec-logfile=%{_localstatedir}/log/apache2/suexec.log \
181        --with-suexec-bin=%{_libdir}/%{pkgname}/suexec \
182        --with-suexec-uidmin=500 --with-suexec-gidmin=500 \
183        --with-pcre \
184        --enable-ssl --with-ssl \
185        --enable-deflate \
186        --enable-proxy --enable-proxy-connect \
187        --enable-proxy-http --enable-proxy-ftp"
188#all  mpm build
189for mpm in %{mpms}; do
190   mkdir mpm-$mpm;
191   cd mpm-$mpm;
192   ../configure $AP_CONFOPTS --with-mpm=$mpm --srcdir=../ ;
193   make %{?_smp_mflags} ;
194#   mv apache2 apache2.$mpm ;
195   cd ../
196done
197
198%install
199rm -rf $RPM_BUILD_ROOT
200
201# Classify ab and logresolve as section 1 commands, as they are in /usr/bin
202cp -p docs/man/ab.8 docs/man/ab.1
203sed -e "1s/logresolve 8/logresolve 1/" \
204  < docs/man/logresolve.8 > docs/man/logresolve.1
205#rm docs/man/logresolve.8
206
207# install mpms binary
208pushd mpm-prefork
209  make DESTDIR=$RPM_BUILD_ROOT install
210  rm -f $RPM_BUILD_ROOT/%{_sbindir}/apache2
211popd
212
213for mpm in %{mpms}; do
214    install -m755 mpm-$mpm/apache2 $RPM_BUILD_ROOT/%{_sbindir}/apache2.$mpm
215done
216
217# install conf file/directory
218mkdir $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf.d
219install -m 644 $RPM_SOURCE_DIR/README.confd \
220   $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf.d/README
221install -m 644 $RPM_SOURCE_DIR/apache-ssl.conf \
222   $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf.d/ssl.conf
223
224rm $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/*.conf
225install -m 644 $RPM_SOURCE_DIR/httpd.conf \
226   $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/httpd.conf
227
228# mod_ssl bits
229for suffix in crl crt csr key prm; do
230   mkdir $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/ssl.${suffix}
231done
232
233# Makefiles for certificate management
234for ext in crt crl; do
235  install -m 644 $RPM_SOURCE_DIR/mod_ssl-Makefile.${ext} \
236        $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/ssl.${ext}/Makefile.${ext}
237done
238ln -s ../../../usr/share/ssl/certs/Makefile $RPM_BUILD_ROOT/etc/apache2/conf
239
240# for holding mod_dav lock database
241mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/lib/dav
242
243# create a prototype session cache
244mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/cache/mod_ssl
245touch $RPM_BUILD_ROOT%{_localstatedir}/cache/mod_ssl/scache.{dir,pag,sem}
246
247# move utilities to /usr/bin
248mv $RPM_BUILD_ROOT%{_sbindir}/{ab,htdbm,logresolve,htpasswd,htdigest} \
249   $RPM_BUILD_ROOT%{_bindir}
250
251# Make the MMN accessible to module packages
252echo %{mmn} > $RPM_BUILD_ROOT%{_includedir}/apache2/.mmn
253
254# docroot
255# mkdir $RPM_BUILD_ROOT%{contentdir}/html
256install -m 644 $RPM_SOURCE_DIR/index.html.ja \
257        $RPM_BUILD_ROOT%{contentdir}/error/noindex.html
258rm -r $RPM_BUILD_ROOT%{contentdir}/manual/style
259
260install -m 644 $RPM_SOURCE_DIR/vine.png \
261        $RPM_BUILD_ROOT%{contentdir}/icons
262
263# logs
264# rmdir $RPM_BUILD_ROOT%{_sysconfdir}/apache2/logs
265mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/log/apache2
266
267ln -sf %{_sysconfdir}/%{pkgname}/conf/httpd.conf $RPM_BUILD_ROOT/%{_sysconfdir}/%{pkgname}/conf/apache2.conf
268
269
270# symlinks for /etc/apache2
271ln -s ../..%{_localstatedir}/log/apache2 $RPM_BUILD_ROOT/etc/apache2/logs
272ln -s ../..%{_localstatedir}/run $RPM_BUILD_ROOT/etc/apache2/run
273ln -s ../..%{_libdir}/apache2/modules $RPM_BUILD_ROOT/etc/apache2/modules
274ln -s ../..%{_libdir}/apache2/build $RPM_BUILD_ROOT/etc/apache2/build
275
276# install SYSV init stuff
277mkdir -p $RPM_BUILD_ROOT/etc/rc.d/init.d
278install -m755 $RPM_SOURCE_DIR/apache2.init \
279        $RPM_BUILD_ROOT/etc/rc.d/init.d/apache2
280%{__perl} -pi -e "s:\@docdir\@:%{_docdir}/%{name}-%{version}:g" \
281        $RPM_BUILD_ROOT/etc/rc.d/init.d/apache2
282
283# install log rotation stuff
284mkdir -p $RPM_BUILD_ROOT/etc/logrotate.d
285install -m644 $RPM_SOURCE_DIR/apache2.logrotate \
286        $RPM_BUILD_ROOT/etc/logrotate.d/apache2
287
288mv $RPM_BUILD_ROOT/%{_sbindir}/apachectl $RPM_BUILD_ROOT/%{_sbindir}/apache2ctl
289
290# fix man page paths
291sed -e "s|/usr/local/apache2/conf/httpd.conf|/etc/apache2/conf/httpd.conf|" \
292    -e "s|/usr/local/apache2/conf/mime.types|/etc/mime.types|" \
293    -e "s|/usr/local/apache2/conf/magic|/etc/apache2/conf/magic|" \
294    -e "s|/usr/local/apache2/logs/error_log|/var/log/apache2/error_log|" \
295    -e "s|/usr/local/apache2/logs/access_log|/var/log/apache2/access_log|" \
296    -e "s|/usr/local/apache2/logs/httpd.pid|/var/run/apache2.pid|" \
297    -e "s|/usr/local/apache2|/etc/httpd|" < $RPM_SOURCE_DIR/apache2.8 \
298  > $RPM_BUILD_ROOT%{_mandir}/man8/apache2.8
299
300install -m644 $RPM_SOURCE_DIR/apache2ctl.8 \
301        $RPM_BUILD_ROOT%{_mandir}/man8/apache2ctl.8
302
303# change command name to avoid conflict with apache1 pacjage
304%define cflcmd /usr/bin/htdigest /usr/bin/htpasswd /usr/sbin/rotatelogs
305
306for i in %{cflcmd}; do \
307  echo $i
308  mv $RPM_BUILD_ROOT$i $RPM_BUILD_ROOT$i"2";
309done;
310
311mv $RPM_BUILD_ROOT/%{_sbindir}/apxs $RPM_BUILD_ROOT/%{_bindir}/apxs
312
313%define cflman usr/share/man/man1/dbmmanage.1 usr/share/man/man1/htdigest.1 usr/share/man/man1/htpasswd.1 usr/share/man/man8/rotatelogs.8 usr/share/man/man8/suexec.8 usr/share/man/man8/apxs.8 usr/share/man/man8/httpd.8
314
315(cd $RPM_BUILD_ROOT;
316for i in %{cflman}; do \
317    echo $i | sed -e "s|\.1|2\.1|" -e "s|\.8|2\.8|" |    xargs mv $i ;
318   
319done;
320)
321
322#cp $RPM_SOURCE_DIR/config_vars.mk $RPM_BUILD_ROOT/%{_sysconfdir}/%{pkgname}/build/.
323mv $RPM_BUILD_ROOT/%{_sbindir}/suexec $RPM_BUILD_ROOT/%{_libdir}/%{pkgname}/suexec
324
325
326rm -f $RPM_BUILD_ROOT%{_mandir}/man1/ab*
327rm -f $RPM_BUILD_ROOT%{_mandir}/man1/logresolve*
328# conflict with apache 1, so removed...
329rm -f $RPM_BUILD_ROOT%{_mandir}/man8/ab*
330rm -f $RPM_BUILD_ROOT%{_mandir}/man8/logresolve*
331
332# remove unpackaged files
333rm -f $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/mime.types \
334      $RPM_BUILD_ROOT%{_libdir}/*.la \
335      $RPM_BUILD_ROOT%{_libdir}/*.exp \
336      $RPM_BUILD_ROOT%{_libdir}/apache2/modules/*.exp \
337      $RPM_BUILD_ROOT%{_libdir}/apache2/build/config.nice \
338      $RPM_BUILD_ROOT%{_sbindir}/{apache2,checkgid,dbmmanage,envvars*} \
339      $RPM_BUILD_ROOT%{contentdir}/html/* \
340      $RPM_BUILD_ROOT%{contentdir}/cgi-bin/*
341
342%pre
343# Add the "apache" user
344/usr/sbin/useradd -c "Apache" -u 48 \
345        -s /sbin/nologin -r -d %{contentdir} apache 2> /dev/null || :
346
347%triggerpostun -- apache < 2.0
348/sbin/chkconfig --add apache2
349
350
351%post
352# Register the httpd service
353for mpm in %{mpms}; do
354  /sbin/update-alternatives --install %{_sbindir}/apache2 apache2 %{_sbindir}/apache2.$mpm 20;
355done
356/sbin/update-alternatives --install %{_sbindir}/apache2 apache2 %{_sbindir}/apache2.%{prefer_mpm} 30
357/sbin/chkconfig --add apache2
358
359%preun
360if [ $1 = 0 ]; then
361        /sbin/service apache2 stop > /dev/null 2>&1
362        /sbin/chkconfig --del apache2
363        for mpm in %{mpms}; do
364          /sbin/update-alternatives --remove apache2 %{_sbindir}/apache2.$mpm;
365        done 
366fi
367
368%postun
369if [ "$1" -ge 1 ]; then
370        /sbin/service apache2 condrestart
371fi
372/sbin/ldconfig
373
374%post -n mod_ssl-apache2
375/sbin/ldconfig ### is this needed?
376umask 077
377
378if [ ! -f %{_sysconfdir}/apache2/conf/ssl.key/server.key ] ; then
379%{_bindir}/openssl genrsa -rand /proc/apm:/proc/cpuinfo:/proc/dma:/proc/filesystems:/proc/interrupts:/proc/ioports:/proc/pci:/proc/rtc:/proc/uptime 1024 > %{_sysconfdir}/apache2/conf/ssl.key/server.key 2> /dev/null
380fi
381
382FQDN=`hostname`
383if [ "x${FQDN}" = "x" ]; then
384   FQDN=localhost.localdomain
385fi
386
387if [ ! -f %{_sysconfdir}/apache2/conf/ssl.crt/server.crt ] ; then
388cat << EOF | %{_bindir}/openssl req -new -key %{_sysconfdir}/apache2/conf/ssl.key/server.key -x509 -days 365 -out %{_sysconfdir}/apache2/conf/ssl.crt/server.crt 2>/dev/null
389--
390SomeState
391SomeCity
392SomeOrganization
393SomeOrganizationalUnit
394${FQDN}
395root@${FQDN}
396EOF
397fi
398
399%clean
400rm -rf $RPM_BUILD_ROOT
401
402%files
403%defattr(-,root,root)
404
405%doc ABOUT_APACHE README CHANGES LAYOUT LICENSE
406%doc migration.html migration.css
407
408%dir %{_sysconfdir}/apache2
409%{_sysconfdir}/apache2/modules
410%{_sysconfdir}/apache2/logs
411%{_sysconfdir}/apache2/run
412%dir %{_sysconfdir}/apache2/conf
413%config(noreplace) %{_sysconfdir}/apache2/conf/*.conf
414%config(noreplace) %{_sysconfdir}/apache2/conf/magic
415
416%config %{_sysconfdir}/logrotate.d/apache2
417%config %{_sysconfdir}/rc.d/init.d/apache2
418
419%dir %{_sysconfdir}/apache2/conf.d
420%{_sysconfdir}/apache2/conf.d/README
421
422%dir %{_sysconfdir}/apache2/conf/extra
423%config %{_sysconfdir}/apache2/conf/extra/*
424
425%dir %{_sysconfdir}/apache2/conf/original
426%{_sysconfdir}/apache2/conf/original/*
427
428%{_bindir}/ab
429%{_bindir}/ht*
430%{_bindir}/logresolve
431%{_sbindir}/ht*
432%{_sbindir}/apache2.*
433%{_sbindir}/apache2ctl
434%{_sbindir}/rotatelogs2
435%attr(4510,root,%{suexec_caller}) %{_libdir}/%{pkgname}/suexec
436
437%dir %{_libdir}/apache2
438%dir %{_libdir}/apache2/modules
439# everything but mod_ssl.so:
440%{_libdir}/apache2/modules/mod_[a-r]*.so
441%{_libdir}/apache2/modules/mod_s[petu]*.so
442%{_libdir}/apache2/modules/mod_[t-z]*.so
443
444%dir %{contentdir}
445%dir %{contentdir}/cgi-bin
446%dir %{contentdir}/html
447%dir %{contentdir}/icons
448%dir %{contentdir}/error
449%dir %{contentdir}/error/include
450%{contentdir}/icons/*
451%{contentdir}/error/README
452%{contentdir}/error/noindex.html
453%config(noreplace) %{contentdir}/error/*.var
454%config(noreplace) %{contentdir}/error/include/*.html
455
456%attr(0700,root,root) %dir %{_localstatedir}/log/apache2
457
458%attr(0700,apache,apache) %dir %{_localstatedir}/lib/dav
459
460%{_mandir}/man1/*
461
462%{_mandir}/man8/*
463
464%files manual
465%defattr(-,root,root)
466%{contentdir}/manual
467
468%files -n mod_ssl-apache2
469%defattr(-,root,root)
470%{_libdir}/apache2/modules/mod_ssl.so
471%config(noreplace) %{_sysconfdir}/apache2/conf.d/ssl.conf
472%attr(0700,root,root) %dir %{_sysconfdir}/apache2/conf/ssl.*
473%config %{_sysconfdir}/apache2/conf/Makefile
474%config %{_sysconfdir}/apache2/conf/ssl.*/*
475%attr(0700,apache,root) %dir %{_localstatedir}/cache/mod_ssl
476%attr(0600,apache,root) %ghost %{_localstatedir}/cache/mod_ssl/scache.dir
477%attr(0600,apache,root) %ghost %{_localstatedir}/cache/mod_ssl/scache.pag
478%attr(0600,apache,root) %ghost %{_localstatedir}/cache/mod_ssl/scache.sem
479
480%files devel
481%defattr(-,root,root)
482%{_includedir}/apache2
483%{_sysconfdir}/apache2/build
484%{_bindir}/apxs
485%{_mandir}/man8/apxs*
486%{_libdir}/apache2/build/*.mk
487%{_libdir}/apache2/build/*.sh
488
489%changelog
490* Mon May 23 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.19-1
491- update to 2.2.19
492
493* Sat Apr 30 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.14-9
494- remove old Obsoletes/Conflicts
495
496* Tue Jan 11 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.14-8
497- rebuild with openssl-1.0.0c
498
499* Sat Aug 21 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.14-7
500- add  patch120 for fix CVE-2010-1452 (mod_dav/mod_cache) from mdk2010
501
502* Wed Aug 18 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.14-6
503- add R(post): alternatives
504
505* Sat Mar 20 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 2.2.14-5
506- add patch110 for fix CVE-2010-0434 from mdk 2010
507
508* Sun Mar  7 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 2.2.14-4
509- add patch100 for fix CVE-2010-0408 (mod_proxy_ajp)
510
511* Fri Feb  5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.2.14-3
512- rebuilt with rpm-4.8.0-3 (on ppc)
513
514* Tue Feb 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.14-2
515- rebuild with db4-4.8.0
516
517* Tue Jan 05 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.14-1
518- new upstream release with security fix
519  (CVE-2009-2699, CVE-2009-3095, CVE-2009-3094)
520- fix ssl.conf (2.2.13-1 includes wrong file)
521
522* Sun Aug 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.13-1
523- new upstream release
524
525* Wed Jul 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.12-1
526- new upstream release
527  (including security fix for CVE-2009-1890, CVE-2009-1191,
528   CVE-2009-1195, CVE-2009-1955, CVE-2009-1956, CVE-2009-0023)
529
530* Fri Jan 09 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.11-2
531- rebuilt with openldap-2.4.11
532
533* Fri Jan  2 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.11-1
534- new upstream release
535
536* Sat Oct 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.10-1
537- new upstream release (including security fix for CVE-2008-2939)
538
539* Fri Jun 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.9-1
540- new upstream release (including security fix for CVE-2008-2364, CVE-2007-6420)
541- built with db4-4.6.21, apr 1.3.0
542
543* Sun Apr 27 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 2.2.8-1
544- add Patch60 (to fix bug#31418).
545
546* Thu Feb 21 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.8-0vl2
547- rebuild with expat-2.0.1
548
549* Tue Jan 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.8-0vl1
550- new upstream release
551
552* Sat Nov  3 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.6-0vl2
553- added postun script from VinePlus/4.0 package
554  * Tue Sep 11 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.3-0vl3.2
555  - add postun script to restart daemon with message
556
557* Sun Jul 01 2007 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.3-0vl8
558- updated Patch2: httpd-2.2.3-apxs.patch
559
560* Sun Jun 24 2007 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.3-0vl7
561- modified libdir in config.layout for lib64 architecture
562
563* Sun May 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.3-0vl6
564- rebuilt with openssl-0.9.8e
565
566* Thu May 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.2.3-0vl5
567- rebuilt with new toolchain and db4-4.3.x
568
569* Tue Feb  7 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.3-0vl4
570- added BuildRequires: pcre-devel, sqlite3-devel <BTS:VineLinux:474>
571
572* Mon Sep 11 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.2.3-0vl3
573- change manual Group to Applications/Documentation. <BTS:VineLinux:163>
574
575* Sun Aug 27 2006 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.3-0vl2
576- rebuilt with openldap-2.3.27-0vl1
577
578* Sat Jul 29 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.3-0vl1
579- new upstream release including security fix (CVE-2006-3747)
580
581* Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
582- new upstream release
583  - update to 2.2.2
584- remove apr/apr-devel subpackage,
585  use external apr/apr-util instead of internal one.
586
587* Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.58-0vl1
588- new upstream release
589- use apache2.prefork as default.
590
591* Thu Mar 23 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.55-0vl3
592- rebuild to use new _localstatedir (rpm-4.4.2-0vl11)
593- remove unpackaged files in %%install section
594
595* Fri Jan 27 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.55-0vl2
596- fix logrotate configuration (use apache2.pid instead of httpd.pid)
597  (BTS:10)
598- use Epoch instead of Serial
599
600* Sat Oct 15 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.55-0vl1
601- new upstream release
602- drop obsolete security patches which is merged in upstream
603
604* Sat Oct 08 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.54-0vl1
605- new upstream release
606
607* Sun Sep 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.53-0vl2
608- added Patch122 to 125 for secutiry fix
609  (CAN-2004-{1268,2088,2700,2728})
610- fix %install section
611
612* Sun Apr 10 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.53-0vl1
613- new upstream release
614
615* Sat Nov 06 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.52-0vl1
616- new upstream release
617
618* Sun Oct 24 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.50-0vl4
619- rebuilt with db4-4.2.52
620
621* Sat Sep  4 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 2.0.50-0vl3
622- separate apr, apr-devel packages
623- add BuildPreReq: zlib-devel
624
625* Sun Jul 11 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.50-0vl2
626- fix %%files to include instdso.sh
627  thanks to jax <jax AT morejams DOT no-ip DOT com>
628- add %%{?_smp_mflags} to make option.
629
630* Sun Jul  4 2004 IWAI, Masaharu <iwai@alib.jp> 2.0.50-0vl1
631- new upstream version
632
633* Sun Nov 23 2003 IWAI, Masaharu <iwai@alib.jp> 2.0.48-0vl1
634- new upstream version
635
636* Mon Sep 15 2003 IWAI, Masaharu <iwai@alib.jp> 2.0.47-0vl1
637- new upstream version
638- update apxs patch (Patch101)
639- fix dependency:
640    - change file name to package name in Requires and {Build,}Prereq
641- add BuildPrereq: openldap-devel
642- update %%files section
643- rename httpd.8 manpage
644
645* Tue May 12 2003 Satoshi MACHINO <machino@vinelinux.org> 2.0.45-0vl1
646- new upstream version
647- used vine-config.layout in srclib
648
649* Tue May 12 2003 Satoshi MACHINO <machino@vinelinux.org> 2.0.44-0vl9
650- rebuild
651
652* Sun Apr  6 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl8
653- change pkg name from mod_ssl to mod_ssl-apache2
654- remove "apache-manual" entry from Obsoletes:
655
656* Thu Apr  3 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl7
657- remove "mod_dav" and "apache-devel" from Obsoletes:
658- enable MPMS(worker %mpms )
659
660* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl6
661- add correct config_vars.mk
662
663* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl5
664- apply apxs's patch ( from Debian)
665
666* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl4
667- add apr-config,apu-config to devel's %file
668
669* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl3
670- change apxs path ( /usr/sbin -> /usr/bin
671- add symlink under /etc/apache2/conf
672  (logs, run), httpd.conf -> apache2.conf
673- fixed apache2 initscript.
674
675* Sat Mar 29 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl2
676- build Vine Linux
677- new upstream version
678- sharing with apache1
679
680* Wed Sep  4 2002 Nalin Dahyabhai <nalin@redhat.com> 2.0.40-8
681- link httpd with libssl to avoid library loading/unloading weirdness
682
683* Tue Sep  3 2002 Joe Orton <jorton@redhat.com> 2.0.40-7
684- add LoadModule lines for proxy modules in httpd.conf (#73349)
685- fix permissions of conf/ssl.*/ directories; add Makefiles for
686  certificate management (#73352)
687
688* Mon Sep  2 2002 Joe Orton <jorton@redhat.com> 2.0.40-6
689- provide "httpd-mmn" to manage module ABI compatibility
690
691* Sun Sep  1 2002 Joe Orton <jorton@redhat.com> 2.0.40-5
692- fix SSL session cache (#69699)
693- revert addition of LDAP support to apr-util
694
695* Mon Aug 26 2002 Joe Orton <jorton@redhat.com> 2.0.40-4
696- set SIGXFSZ disposition to "ignored" (#69520)
697- make dummy connections to the first listener in config (#72692)
698
699* Mon Aug 26 2002 Joe Orton <jorton@redhat.com> 2.0.40-3
700- allow "apachectl configtest" on a 1.3 httpd.conf
701- add mod_deflate
702- enable LDAP support in apr-util
703- don't package everything in /var/www/error as config(noreplace)
704
705* Wed Aug 21 2002 Bill Nottingham <notting@redhat.com> 2.0.40-2
706- add trigger (#68657)
707
708* Mon Aug 12 2002 Joe Orton <jorton@redhat.com> 2.0.40-1
709- update to 2.0.40
710
711* Wed Jul 24 2002 Joe Orton <jorton@redhat.com> 2.0.36-8
712- improve comment on use of UserDir in default config (#66886)
713
714* Wed Jul 10 2002 Joe Orton <jorton@redhat.com> 2.0.36-7
715- use /sbin/nologin as shell for apache user (#68371)
716- add patch from CVS to fix possible infinite loop when processing
717  internal redirects
718
719* Wed Jun 26 2002 Gary Benson <gbenson@redhat.com> 2.0.36-6
720- modify init script to detect 1.3.x httpd.conf's and direct users
721  to the migration guide
722
723* Tue Jun 25 2002 Gary Benson <gbenson@redhat.com> 2.0.36-5
724- patch apachectl to detect 1.3.x httpd.conf's and direct users
725  to the migration guide
726- ship the migration guide
727
728* Fri Jun 21 2002 Joe Orton <jorton@redhat.com>
729- move /etc/httpd2 back to /etc/httpd
730- add noindex.html page and poweredby logo; tweak default config
731  to load noindex.html if no default "/" page is present.
732- add patch to prevent mutex errors on graceful restart
733
734* Fri Jun 21 2002 Tim Powers <timp@redhat.com> 2.0.36-4
735- automated rebuild
736
737* Wed Jun 12 2002 Joe Orton <jorton@redhat.com> 2.0.36-3
738- add patch to fix SSL mutex handling
739
740* Wed Jun 12 2002 Joe Orton <jorton@redhat.com> 2.0.36-2
741- improved config directory patch
742
743* Mon May 20 2002 Joe Orton <jorton@redhat.com>
744- initial build; based heavily on apache.spec and mod_ssl.spec
745- fixes: #65214, #58490, #57376, #61265, #65518, #58177, #57245
746
Note: See TracBrowser for help on using the repository browser.