source: projects/specs/trunk/a/apache2/apache2-vl.spec @ 3749

Revision 3749, 23.9 KB checked in by daisuke, 13 years ago (diff)

apache2: remove old/unneeded Obsoletes/Conflics?

Line 
1%define contentdir /var/www
2%define suexec_caller apache
3%define mmn 20020903
4%define pkgname apache2
5
6Summary: Apache HTTP Server
7Name: %{pkgname}
8Version: 2.2.14
9Release: 9%{_dist_release}
10URL: http://httpd.apache.org/
11
12Vendor: Project Vine
13Distribution: Vine Linux
14Packager: daisuke
15
16Source0: http://www.apache.org/dist/httpd/httpd-%{version}.tar.bz2
17Source1: index.html.ja
18Source3: apache2.logrotate
19Source4: apache2.init
20Source5: README.confd
21Source6: vine.png
22Source10: httpd.conf
23Source11: apache-ssl.conf
24Source12: migration.html
25Source13: migration.css
26Source14: mod_ssl-Makefile.crt
27Source15: mod_ssl-Makefile.crl
28# add vine entry to config.layout
29Source100: vine-config.layout
30# man files
31Source101: apache2.8
32Source102: apache2ctl.8
33#Source103: config_vars.mk
34# build/scripts patches
35Patch1: httpd-2.1.10-apctl.patch
36Patch2: httpd-2.2.3-apxs.patch
37Patch3: httpd-2.0.45-deplibs.patch
38Patch4: httpd-2.1.10-disablemods.patch
39# features/functional changes
40Patch21: httpd-2.0.40-xfsz.patch
41Patch22: httpd-2.1.10-pod.patch
42Patch23: httpd-2.0.45-export.patch
43Patch24: httpd-2.0.48-corelimit.patch
44# Bug fixes
45Patch54: httpd-2.2.0-authnoprov.patch
46Patch60: httpd-2.2.3-sslusername.patch
47
48# Security fixes
49Patch100: apache2-2.2.14-CVE-2010-0408.patch
50Patch110: httpd-2.2.x-CVE-2010-0434.diff
51Patch120: httpd-2.2.x-CVE-2010-1452.diff
52
53License: Apache Software License
54Group: System Environment/Daemons
55BuildRoot: %{_tmppath}/%{name}-%{version}-root
56BuildRequires: db4-devel, expat-devel
57BuildRequires: findutils, perl, openldap-devel, zlib-devel
58BuildRequires: apr-devel, apr-util-devel
59BuildRequires: pcre-devel, sqlite3-devel
60Requires: mailcap, gawk, file, findutils, apr, apr-util
61Requires(pre): chkconfig, mktemp, fileutils
62Requires(pre): sh-utils, textutils, shadow-utils
63Requires(post): alternatives
64Provides: webserver
65Provides: httpd = %{version}
66Provides: httpd-mmn = %{mmn}
67Obsoletes: apache2-apr, apache2-apr-devel
68
69%description
70Apache is a powerful, full-featured, efficient, and freely-available
71Web server. Apache is also the most popular Web server on the
72Internet.
73
74%package devel
75Group: Development/Libraries
76Summary: Development tools for the Apache HTTP server.
77Requires: libtool, httpd = %{version}
78Requires: apr-devel, apr-util-devel
79
80%description devel
81The httpd-devel package contains the APXS binary and other files
82that you need to build Dynamic Shared Objects (DSOs) for Apache.
83
84If you are installing the Apache HTTP server and you want to be
85able to compile or develop additional modules for Apache, you need
86to install this package.
87
88%package manual
89Group: Applications/Documentation
90Summary: Documentation for the Apache HTTP server.
91
92%description manual
93The httpd-manual package contains the complete manual and
94reference guide for the Apache HTTP server. The information can
95also be found at http://httpd.apache.org/docs/.
96
97%package -n mod_ssl-apache2
98Group: System Environment/Daemons
99Summary: SSL/TLS module for the Apache HTTP server
100Epoch: 1
101BuildRequires: openssl-devel
102Requires(pre): openssl, dev, /bin/cat
103Requires: httpd, make, httpd-mmn = %{mmn}
104
105%description -n mod_ssl-apache2
106The mod_ssl module provides strong cryptography for the Apache Web
107server via the Secure Sockets Layer (SSL) and Transport Layer
108Security (TLS) protocols.
109
110%prep
111%setup -q -n httpd-%{version}
112
113%patch1 -p1 -b .apctl
114%patch2 -p1 -b .apxs
115#patch3 -p1 -b .deplibs
116%patch4 -p1 -b .disablemods
117
118%patch21 -p0 -b .xfsz
119%patch22 -p1 -b .pod
120%patch23 -p1 -b .export
121%patch24 -p1 -b .corelimit
122
123%patch54 -p1 -b .authnoprov
124%patch60 -p1 -b .sslusername
125
126%patch100 -p4 -b .CVE-2010-0408
127%patch110 -p0 -b .CVE-2010-0434
128%patch120 -p0 -b .CVE-2010-1452
129
130# copy across the migration guide and sed it's location into apachectl
131cp $RPM_SOURCE_DIR/migration.{html,css} .
132%{__perl} -pi -e "s:\@docdir\@:%{_docdir}/%{name}-%{version}:g" \
133        support/apachectl.in
134
135
136# add Vine configure's option to config.layout
137sed -e "s|${prefix}/lib|${prefix}/%{_lib}|" \
138  < $RPM_SOURCE_DIR/vine-config.layout >> config.layout
139
140# regenerate configure scripts
141./buildconf
142
143%build
144# remove bundled apr, apr-util, pcre
145rm -rf srclib/{apr,apr-util,pcre}
146
147#CFLAGS="$RPM_OPT_FLAGS -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64"
148#AP_LIBS="-lssl -lcrypto"
149#export CFLAGS AP_LIBS
150CFLAGS="$RPM_OPT_FLAGS"
151SH_LDFLAGS="-Wl,-z,relro"
152export CFLAGS SH_LDFLAGS
153
154%define mpms worker prefork
155%define prefer_mpm prefork
156
157AP_CONFOPTS="\
158        --prefix=%{_sysconfdir}/apache2 \
159        --exec-prefix=%{_prefix} \
160        --bindir=%{_bindir} \
161        --sbindir=%{_sbindir} \
162        --mandir=%{_mandir} \
163        --libdir=%{_libdir} \
164        --sysconfdir=%{_sysconfdir}/apache2/conf \
165        --includedir=%{_includedir}/apache2 \
166        --libexecdir=%{_libdir}/apache2/modules \
167        --datadir=%{contentdir} \
168        --with-installbuilddir=%{_libdir}/apache2/build \
169        --enable-layout=Vine \
170        --with-program-name=apache2 \
171        --with-ldap \
172        --enable-ldap --enable-authnz-ldap \
173        --enable-mods-shared=all \
174        --enable-cache=shared \
175        --enable-cgi=shared \
176        --enable-cgid=shared \
177        --enable-rewrite=shared \
178        --enable-disk-cache=shared \
179        --enable-file-cache=shared \
180        --enable-mem-cache=shared \
181        --enable-authn-anon --enable-authn-alias \
182        --with-apr=%{_prefix} --with-apr-util=%{_prefix} \
183        --enable-suexec --with-suexec \
184        --with-suexec-caller=%{suexec_caller} \
185        --with-suexec-docroot=%{contentdir} \
186        --with-suexec-logfile=%{_localstatedir}/log/apache2/suexec.log \
187        --with-suexec-bin=%{_libdir}/%{pkgname}/suexec \
188        --with-suexec-uidmin=500 --with-suexec-gidmin=500 \
189        --with-pcre \
190        --enable-ssl --with-ssl \
191        --enable-deflate \
192        --enable-proxy --enable-proxy-connect \
193        --enable-proxy-http --enable-proxy-ftp"
194#all  mpm build
195for mpm in %{mpms}; do
196   mkdir mpm-$mpm;
197   cd mpm-$mpm;
198   ../configure $AP_CONFOPTS --with-mpm=$mpm --srcdir=../ ;
199   make %{?_smp_mflags} ;
200#   mv apache2 apache2.$mpm ;
201   cd ../
202done
203
204%install
205rm -rf $RPM_BUILD_ROOT
206
207# Classify ab and logresolve as section 1 commands, as they are in /usr/bin
208cp -p docs/man/ab.8 docs/man/ab.1
209sed -e "1s/logresolve 8/logresolve 1/" \
210  < docs/man/logresolve.8 > docs/man/logresolve.1
211#rm docs/man/logresolve.8
212
213# install mpms binary
214pushd mpm-prefork
215  make DESTDIR=$RPM_BUILD_ROOT install
216  rm -f $RPM_BUILD_ROOT/%{_sbindir}/apache2
217popd
218
219for mpm in %{mpms}; do
220    install -m755 mpm-$mpm/apache2 $RPM_BUILD_ROOT/%{_sbindir}/apache2.$mpm
221done
222
223# install conf file/directory
224mkdir $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf.d
225install -m 644 $RPM_SOURCE_DIR/README.confd \
226   $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf.d/README
227install -m 644 $RPM_SOURCE_DIR/apache-ssl.conf \
228   $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf.d/ssl.conf
229
230rm $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/*.conf
231install -m 644 $RPM_SOURCE_DIR/httpd.conf \
232   $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/httpd.conf
233
234# mod_ssl bits
235for suffix in crl crt csr key prm; do
236   mkdir $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/ssl.${suffix}
237done
238
239# Makefiles for certificate management
240for ext in crt crl; do
241  install -m 644 $RPM_SOURCE_DIR/mod_ssl-Makefile.${ext} \
242        $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/ssl.${ext}/Makefile.${ext}
243done
244ln -s ../../../usr/share/ssl/certs/Makefile $RPM_BUILD_ROOT/etc/apache2/conf
245
246# for holding mod_dav lock database
247mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/lib/dav
248
249# create a prototype session cache
250mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/cache/mod_ssl
251touch $RPM_BUILD_ROOT%{_localstatedir}/cache/mod_ssl/scache.{dir,pag,sem}
252
253# move utilities to /usr/bin
254mv $RPM_BUILD_ROOT%{_sbindir}/{ab,htdbm,logresolve,htpasswd,htdigest} \
255   $RPM_BUILD_ROOT%{_bindir}
256
257# Make the MMN accessible to module packages
258echo %{mmn} > $RPM_BUILD_ROOT%{_includedir}/apache2/.mmn
259
260# docroot
261# mkdir $RPM_BUILD_ROOT%{contentdir}/html
262install -m 644 $RPM_SOURCE_DIR/index.html.ja \
263        $RPM_BUILD_ROOT%{contentdir}/error/noindex.html
264rm -r $RPM_BUILD_ROOT%{contentdir}/manual/style
265
266install -m 644 $RPM_SOURCE_DIR/vine.png \
267        $RPM_BUILD_ROOT%{contentdir}/icons
268
269# logs
270# rmdir $RPM_BUILD_ROOT%{_sysconfdir}/apache2/logs
271mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/log/apache2
272
273ln -sf %{_sysconfdir}/%{pkgname}/conf/httpd.conf $RPM_BUILD_ROOT/%{_sysconfdir}/%{pkgname}/conf/apache2.conf
274
275
276# symlinks for /etc/apache2
277ln -s ../..%{_localstatedir}/log/apache2 $RPM_BUILD_ROOT/etc/apache2/logs
278ln -s ../..%{_localstatedir}/run $RPM_BUILD_ROOT/etc/apache2/run
279ln -s ../..%{_libdir}/apache2/modules $RPM_BUILD_ROOT/etc/apache2/modules
280ln -s ../..%{_libdir}/apache2/build $RPM_BUILD_ROOT/etc/apache2/build
281
282# install SYSV init stuff
283mkdir -p $RPM_BUILD_ROOT/etc/rc.d/init.d
284install -m755 $RPM_SOURCE_DIR/apache2.init \
285        $RPM_BUILD_ROOT/etc/rc.d/init.d/apache2
286%{__perl} -pi -e "s:\@docdir\@:%{_docdir}/%{name}-%{version}:g" \
287        $RPM_BUILD_ROOT/etc/rc.d/init.d/apache2
288
289# install log rotation stuff
290mkdir -p $RPM_BUILD_ROOT/etc/logrotate.d
291install -m644 $RPM_SOURCE_DIR/apache2.logrotate \
292        $RPM_BUILD_ROOT/etc/logrotate.d/apache2
293
294mv $RPM_BUILD_ROOT/%{_sbindir}/apachectl $RPM_BUILD_ROOT/%{_sbindir}/apache2ctl
295
296# fix man page paths
297sed -e "s|/usr/local/apache2/conf/httpd.conf|/etc/apache2/conf/httpd.conf|" \
298    -e "s|/usr/local/apache2/conf/mime.types|/etc/mime.types|" \
299    -e "s|/usr/local/apache2/conf/magic|/etc/apache2/conf/magic|" \
300    -e "s|/usr/local/apache2/logs/error_log|/var/log/apache2/error_log|" \
301    -e "s|/usr/local/apache2/logs/access_log|/var/log/apache2/access_log|" \
302    -e "s|/usr/local/apache2/logs/httpd.pid|/var/run/apache2.pid|" \
303    -e "s|/usr/local/apache2|/etc/httpd|" < $RPM_SOURCE_DIR/apache2.8 \
304  > $RPM_BUILD_ROOT%{_mandir}/man8/apache2.8
305
306install -m644 $RPM_SOURCE_DIR/apache2ctl.8 \
307        $RPM_BUILD_ROOT%{_mandir}/man8/apache2ctl.8
308
309# change command name to avoid conflict with apache1 pacjage
310%define cflcmd /usr/bin/htdigest /usr/bin/htpasswd /usr/sbin/rotatelogs
311
312for i in %{cflcmd}; do \
313  echo $i
314  mv $RPM_BUILD_ROOT$i $RPM_BUILD_ROOT$i"2";
315done;
316
317mv $RPM_BUILD_ROOT/%{_sbindir}/apxs $RPM_BUILD_ROOT/%{_bindir}/apxs
318
319%define cflman usr/share/man/man1/dbmmanage.1 usr/share/man/man1/htdigest.1 usr/share/man/man1/htpasswd.1 usr/share/man/man8/rotatelogs.8 usr/share/man/man8/suexec.8 usr/share/man/man8/apxs.8 usr/share/man/man8/httpd.8
320
321(cd $RPM_BUILD_ROOT;
322for i in %{cflman}; do \
323    echo $i | sed -e "s|\.1|2\.1|" -e "s|\.8|2\.8|" |    xargs mv $i ;
324   
325done;
326)
327
328#cp $RPM_SOURCE_DIR/config_vars.mk $RPM_BUILD_ROOT/%{_sysconfdir}/%{pkgname}/build/.
329mv $RPM_BUILD_ROOT/%{_sbindir}/suexec $RPM_BUILD_ROOT/%{_libdir}/%{pkgname}/suexec
330
331
332rm -f $RPM_BUILD_ROOT%{_mandir}/man1/ab*
333rm -f $RPM_BUILD_ROOT%{_mandir}/man1/logresolve*
334# conflict with apache 1, so removed...
335rm -f $RPM_BUILD_ROOT%{_mandir}/man8/ab*
336rm -f $RPM_BUILD_ROOT%{_mandir}/man8/logresolve*
337
338# remove unpackaged files
339rm -f $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/mime.types \
340      $RPM_BUILD_ROOT%{_libdir}/*.la \
341      $RPM_BUILD_ROOT%{_libdir}/*.exp \
342      $RPM_BUILD_ROOT%{_libdir}/apache2/modules/*.exp \
343      $RPM_BUILD_ROOT%{_libdir}/apache2/build/config.nice \
344      $RPM_BUILD_ROOT%{_sbindir}/{apache2,checkgid,dbmmanage,envvars*} \
345      $RPM_BUILD_ROOT%{contentdir}/html/* \
346      $RPM_BUILD_ROOT%{contentdir}/cgi-bin/*
347
348%pre
349# Add the "apache" user
350/usr/sbin/useradd -c "Apache" -u 48 \
351        -s /sbin/nologin -r -d %{contentdir} apache 2> /dev/null || :
352
353%triggerpostun -- apache < 2.0
354/sbin/chkconfig --add apache2
355
356
357%post
358# Register the httpd service
359for mpm in %{mpms}; do
360  /sbin/update-alternatives --install %{_sbindir}/apache2 apache2 %{_sbindir}/apache2.$mpm 20;
361done
362/sbin/update-alternatives --install %{_sbindir}/apache2 apache2 %{_sbindir}/apache2.%{prefer_mpm} 30
363/sbin/chkconfig --add apache2
364
365%preun
366if [ $1 = 0 ]; then
367        /sbin/service apache2 stop > /dev/null 2>&1
368        /sbin/chkconfig --del apache2
369        for mpm in %{mpms}; do
370          /sbin/update-alternatives --remove apache2 %{_sbindir}/apache2.$mpm;
371        done 
372fi
373
374%postun
375if [ "$1" -ge 1 ]; then
376        /sbin/service apache2 condrestart
377fi
378/sbin/ldconfig
379
380%post -n mod_ssl-apache2
381/sbin/ldconfig ### is this needed?
382umask 077
383
384if [ ! -f %{_sysconfdir}/apache2/conf/ssl.key/server.key ] ; then
385%{_bindir}/openssl genrsa -rand /proc/apm:/proc/cpuinfo:/proc/dma:/proc/filesystems:/proc/interrupts:/proc/ioports:/proc/pci:/proc/rtc:/proc/uptime 1024 > %{_sysconfdir}/apache2/conf/ssl.key/server.key 2> /dev/null
386fi
387
388FQDN=`hostname`
389if [ "x${FQDN}" = "x" ]; then
390   FQDN=localhost.localdomain
391fi
392
393if [ ! -f %{_sysconfdir}/apache2/conf/ssl.crt/server.crt ] ; then
394cat << EOF | %{_bindir}/openssl req -new -key %{_sysconfdir}/apache2/conf/ssl.key/server.key -x509 -days 365 -out %{_sysconfdir}/apache2/conf/ssl.crt/server.crt 2>/dev/null
395--
396SomeState
397SomeCity
398SomeOrganization
399SomeOrganizationalUnit
400${FQDN}
401root@${FQDN}
402EOF
403fi
404
405%clean
406rm -rf $RPM_BUILD_ROOT
407
408%files
409%defattr(-,root,root)
410
411%doc ABOUT_APACHE README CHANGES LAYOUT LICENSE
412%doc migration.html migration.css
413
414%dir %{_sysconfdir}/apache2
415%{_sysconfdir}/apache2/modules
416%{_sysconfdir}/apache2/logs
417%{_sysconfdir}/apache2/run
418%dir %{_sysconfdir}/apache2/conf
419%config(noreplace) %{_sysconfdir}/apache2/conf/*.conf
420%config(noreplace) %{_sysconfdir}/apache2/conf/magic
421
422%config %{_sysconfdir}/logrotate.d/apache2
423%config %{_sysconfdir}/rc.d/init.d/apache2
424
425%dir %{_sysconfdir}/apache2/conf.d
426%{_sysconfdir}/apache2/conf.d/README
427
428%dir %{_sysconfdir}/apache2/conf/extra
429%config %{_sysconfdir}/apache2/conf/extra/*
430
431%dir %{_sysconfdir}/apache2/conf/original
432%{_sysconfdir}/apache2/conf/original/*
433
434%{_bindir}/ab
435%{_bindir}/ht*
436%{_bindir}/logresolve
437%{_sbindir}/ht*
438%{_sbindir}/apache2.*
439%{_sbindir}/apache2ctl
440%{_sbindir}/rotatelogs2
441%attr(4510,root,%{suexec_caller}) %{_libdir}/%{pkgname}/suexec
442
443%dir %{_libdir}/apache2
444%dir %{_libdir}/apache2/modules
445# everything but mod_ssl.so:
446%{_libdir}/apache2/modules/mod_[a-r]*.so
447%{_libdir}/apache2/modules/mod_s[petu]*.so
448%{_libdir}/apache2/modules/mod_[t-z]*.so
449
450%dir %{contentdir}
451%dir %{contentdir}/cgi-bin
452%dir %{contentdir}/html
453%dir %{contentdir}/icons
454%dir %{contentdir}/error
455%dir %{contentdir}/error/include
456%{contentdir}/icons/*
457%{contentdir}/error/README
458%{contentdir}/error/noindex.html
459%config(noreplace) %{contentdir}/error/*.var
460%config(noreplace) %{contentdir}/error/include/*.html
461
462%attr(0700,root,root) %dir %{_localstatedir}/log/apache2
463
464%attr(0700,apache,apache) %dir %{_localstatedir}/lib/dav
465
466%{_mandir}/man1/*
467
468%{_mandir}/man8/*
469
470%files manual
471%defattr(-,root,root)
472%{contentdir}/manual
473
474%files -n mod_ssl-apache2
475%defattr(-,root,root)
476%{_libdir}/apache2/modules/mod_ssl.so
477%config(noreplace) %{_sysconfdir}/apache2/conf.d/ssl.conf
478%attr(0700,root,root) %dir %{_sysconfdir}/apache2/conf/ssl.*
479%config %{_sysconfdir}/apache2/conf/Makefile
480%config %{_sysconfdir}/apache2/conf/ssl.*/*
481%attr(0700,apache,root) %dir %{_localstatedir}/cache/mod_ssl
482%attr(0600,apache,root) %ghost %{_localstatedir}/cache/mod_ssl/scache.dir
483%attr(0600,apache,root) %ghost %{_localstatedir}/cache/mod_ssl/scache.pag
484%attr(0600,apache,root) %ghost %{_localstatedir}/cache/mod_ssl/scache.sem
485
486%files devel
487%defattr(-,root,root)
488%{_includedir}/apache2
489%{_sysconfdir}/apache2/build
490%{_bindir}/apxs
491%{_mandir}/man8/apxs*
492%{_libdir}/apache2/build/*.mk
493%{_libdir}/apache2/build/*.sh
494
495%changelog
496* Sat Apr 30 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.14-9
497- remove old Obsoletes/Conflicts
498
499* Tue Jan 11 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.14-8
500- rebuild with openssl-1.0.0c
501
502* Sat Aug 21 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.14-7
503- add  patch120 for fix CVE-2010-1452 (mod_dav/mod_cache) from mdk2010
504
505* Wed Aug 18 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.14-6
506- add R(post): alternatives
507
508* Sat Mar 20 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 2.2.14-5
509- add patch110 for fix CVE-2010-0434 from mdk 2010
510
511* Sun Mar  7 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 2.2.14-4
512- add patch100 for fix CVE-2010-0408 (mod_proxy_ajp)
513
514* Fri Feb  5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.2.14-3
515- rebuilt with rpm-4.8.0-3 (on ppc)
516
517* Tue Feb 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.14-2
518- rebuild with db4-4.8.0
519
520* Tue Jan 05 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.14-1
521- new upstream release with security fix
522  (CVE-2009-2699, CVE-2009-3095, CVE-2009-3094)
523- fix ssl.conf (2.2.13-1 includes wrong file)
524
525* Sun Aug 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.13-1
526- new upstream release
527
528* Wed Jul 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.12-1
529- new upstream release
530  (including security fix for CVE-2009-1890, CVE-2009-1191,
531   CVE-2009-1195, CVE-2009-1955, CVE-2009-1956, CVE-2009-0023)
532
533* Fri Jan 09 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.11-2
534- rebuilt with openldap-2.4.11
535
536* Fri Jan  2 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.11-1
537- new upstream release
538
539* Sat Oct 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.10-1
540- new upstream release (including security fix for CVE-2008-2939)
541
542* Fri Jun 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.9-1
543- new upstream release (including security fix for CVE-2008-2364, CVE-2007-6420)
544- built with db4-4.6.21, apr 1.3.0
545
546* Sun Apr 27 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 2.2.8-1
547- add Patch60 (to fix bug#31418).
548
549* Thu Feb 21 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.8-0vl2
550- rebuild with expat-2.0.1
551
552* Tue Jan 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.8-0vl1
553- new upstream release
554
555* Sat Nov  3 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.6-0vl2
556- added postun script from VinePlus/4.0 package
557  * Tue Sep 11 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.3-0vl3.2
558  - add postun script to restart daemon with message
559
560* Sun Jul 01 2007 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.3-0vl8
561- updated Patch2: httpd-2.2.3-apxs.patch
562
563* Sun Jun 24 2007 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.3-0vl7
564- modified libdir in config.layout for lib64 architecture
565
566* Sun May 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.3-0vl6
567- rebuilt with openssl-0.9.8e
568
569* Thu May 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.2.3-0vl5
570- rebuilt with new toolchain and db4-4.3.x
571
572* Tue Feb  7 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.3-0vl4
573- added BuildRequires: pcre-devel, sqlite3-devel <BTS:VineLinux:474>
574
575* Mon Sep 11 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.2.3-0vl3
576- change manual Group to Applications/Documentation. <BTS:VineLinux:163>
577
578* Sun Aug 27 2006 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.3-0vl2
579- rebuilt with openldap-2.3.27-0vl1
580
581* Sat Jul 29 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.3-0vl1
582- new upstream release including security fix (CVE-2006-3747)
583
584* Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
585- new upstream release
586  - update to 2.2.2
587- remove apr/apr-devel subpackage,
588  use external apr/apr-util instead of internal one.
589
590* Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.58-0vl1
591- new upstream release
592- use apache2.prefork as default.
593
594* Thu Mar 23 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.55-0vl3
595- rebuild to use new _localstatedir (rpm-4.4.2-0vl11)
596- remove unpackaged files in %%install section
597
598* Fri Jan 27 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.55-0vl2
599- fix logrotate configuration (use apache2.pid instead of httpd.pid)
600  (BTS:10)
601- use Epoch instead of Serial
602
603* Sat Oct 15 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.55-0vl1
604- new upstream release
605- drop obsolete security patches which is merged in upstream
606
607* Sat Oct 08 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.54-0vl1
608- new upstream release
609
610* Sun Sep 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.53-0vl2
611- added Patch122 to 125 for secutiry fix
612  (CAN-2004-{1268,2088,2700,2728})
613- fix %install section
614
615* Sun Apr 10 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.53-0vl1
616- new upstream release
617
618* Sat Nov 06 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.52-0vl1
619- new upstream release
620
621* Sun Oct 24 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.50-0vl4
622- rebuilt with db4-4.2.52
623
624* Sat Sep  4 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 2.0.50-0vl3
625- separate apr, apr-devel packages
626- add BuildPreReq: zlib-devel
627
628* Sun Jul 11 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.50-0vl2
629- fix %%files to include instdso.sh
630  thanks to jax <jax AT morejams DOT no-ip DOT com>
631- add %%{?_smp_mflags} to make option.
632
633* Sun Jul  4 2004 IWAI, Masaharu <iwai@alib.jp> 2.0.50-0vl1
634- new upstream version
635
636* Sun Nov 23 2003 IWAI, Masaharu <iwai@alib.jp> 2.0.48-0vl1
637- new upstream version
638
639* Mon Sep 15 2003 IWAI, Masaharu <iwai@alib.jp> 2.0.47-0vl1
640- new upstream version
641- update apxs patch (Patch101)
642- fix dependency:
643    - change file name to package name in Requires and {Build,}Prereq
644- add BuildPrereq: openldap-devel
645- update %%files section
646- rename httpd.8 manpage
647
648* Tue May 12 2003 Satoshi MACHINO <machino@vinelinux.org> 2.0.45-0vl1
649- new upstream version
650- used vine-config.layout in srclib
651
652* Tue May 12 2003 Satoshi MACHINO <machino@vinelinux.org> 2.0.44-0vl9
653- rebuild
654
655* Sun Apr  6 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl8
656- change pkg name from mod_ssl to mod_ssl-apache2
657- remove "apache-manual" entry from Obsoletes:
658
659* Thu Apr  3 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl7
660- remove "mod_dav" and "apache-devel" from Obsoletes:
661- enable MPMS(worker %mpms )
662
663* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl6
664- add correct config_vars.mk
665
666* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl5
667- apply apxs's patch ( from Debian)
668
669* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl4
670- add apr-config,apu-config to devel's %file
671
672* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl3
673- change apxs path ( /usr/sbin -> /usr/bin
674- add symlink under /etc/apache2/conf
675  (logs, run), httpd.conf -> apache2.conf
676- fixed apache2 initscript.
677
678* Sat Mar 29 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl2
679- build Vine Linux
680- new upstream version
681- sharing with apache1
682
683* Wed Sep  4 2002 Nalin Dahyabhai <nalin@redhat.com> 2.0.40-8
684- link httpd with libssl to avoid library loading/unloading weirdness
685
686* Tue Sep  3 2002 Joe Orton <jorton@redhat.com> 2.0.40-7
687- add LoadModule lines for proxy modules in httpd.conf (#73349)
688- fix permissions of conf/ssl.*/ directories; add Makefiles for
689  certificate management (#73352)
690
691* Mon Sep  2 2002 Joe Orton <jorton@redhat.com> 2.0.40-6
692- provide "httpd-mmn" to manage module ABI compatibility
693
694* Sun Sep  1 2002 Joe Orton <jorton@redhat.com> 2.0.40-5
695- fix SSL session cache (#69699)
696- revert addition of LDAP support to apr-util
697
698* Mon Aug 26 2002 Joe Orton <jorton@redhat.com> 2.0.40-4
699- set SIGXFSZ disposition to "ignored" (#69520)
700- make dummy connections to the first listener in config (#72692)
701
702* Mon Aug 26 2002 Joe Orton <jorton@redhat.com> 2.0.40-3
703- allow "apachectl configtest" on a 1.3 httpd.conf
704- add mod_deflate
705- enable LDAP support in apr-util
706- don't package everything in /var/www/error as config(noreplace)
707
708* Wed Aug 21 2002 Bill Nottingham <notting@redhat.com> 2.0.40-2
709- add trigger (#68657)
710
711* Mon Aug 12 2002 Joe Orton <jorton@redhat.com> 2.0.40-1
712- update to 2.0.40
713
714* Wed Jul 24 2002 Joe Orton <jorton@redhat.com> 2.0.36-8
715- improve comment on use of UserDir in default config (#66886)
716
717* Wed Jul 10 2002 Joe Orton <jorton@redhat.com> 2.0.36-7
718- use /sbin/nologin as shell for apache user (#68371)
719- add patch from CVS to fix possible infinite loop when processing
720  internal redirects
721
722* Wed Jun 26 2002 Gary Benson <gbenson@redhat.com> 2.0.36-6
723- modify init script to detect 1.3.x httpd.conf's and direct users
724  to the migration guide
725
726* Tue Jun 25 2002 Gary Benson <gbenson@redhat.com> 2.0.36-5
727- patch apachectl to detect 1.3.x httpd.conf's and direct users
728  to the migration guide
729- ship the migration guide
730
731* Fri Jun 21 2002 Joe Orton <jorton@redhat.com>
732- move /etc/httpd2 back to /etc/httpd
733- add noindex.html page and poweredby logo; tweak default config
734  to load noindex.html if no default "/" page is present.
735- add patch to prevent mutex errors on graceful restart
736
737* Fri Jun 21 2002 Tim Powers <timp@redhat.com> 2.0.36-4
738- automated rebuild
739
740* Wed Jun 12 2002 Joe Orton <jorton@redhat.com> 2.0.36-3
741- add patch to fix SSL mutex handling
742
743* Wed Jun 12 2002 Joe Orton <jorton@redhat.com> 2.0.36-2
744- improved config directory patch
745
746* Mon May 20 2002 Joe Orton <jorton@redhat.com>
747- initial build; based heavily on apache.spec and mod_ssl.spec
748- fixes: #65214, #58490, #57376, #61265, #65518, #58177, #57245
749
Note: See TracBrowser for help on using the repository browser.