source: projects/specs/trunk/a/apache2/apache2-vl.spec @ 877

Revision 877, 23.4 KB checked in by inagaki, 14 years ago (diff)

updated: apache2

Line 
1%define contentdir /var/www
2%define suexec_caller apache
3%define mmn 20020903
4%define pkgname apache2
5
6Summary: Apache HTTP Server
7Name: %{pkgname}
8Version: 2.2.14
9Release: 5%{_dist_release}
10URL: http://httpd.apache.org/
11
12Vendor: Project Vine
13Distribution: Vine Linux
14Packager: daisuke
15
16Source0: http://www.apache.org/dist/httpd/httpd-%{version}.tar.bz2
17Source1: index.html.ja
18Source3: apache2.logrotate
19Source4: apache2.init
20Source5: README.confd
21Source6: vine.png
22Source10: httpd.conf
23Source11: apache-ssl.conf
24Source12: migration.html
25Source13: migration.css
26Source14: mod_ssl-Makefile.crt
27Source15: mod_ssl-Makefile.crl
28# add vine entry to config.layout
29Source100: vine-config.layout
30# man files
31Source101: apache2.8
32Source102: apache2ctl.8
33#Source103: config_vars.mk
34# build/scripts patches
35Patch1: httpd-2.1.10-apctl.patch
36Patch2: httpd-2.2.3-apxs.patch
37Patch3: httpd-2.0.45-deplibs.patch
38Patch4: httpd-2.1.10-disablemods.patch
39# features/functional changes
40Patch21: httpd-2.0.40-xfsz.patch
41Patch22: httpd-2.1.10-pod.patch
42Patch23: httpd-2.0.45-export.patch
43Patch24: httpd-2.0.48-corelimit.patch
44# Bug fixes
45Patch54: httpd-2.2.0-authnoprov.patch
46Patch60: httpd-2.2.3-sslusername.patch
47
48# Security fixes
49Patch100: apache2-2.2.14-CVE-2010-0408.patch
50Patch110: httpd-2.2.x-CVE-2010-0434.diff
51
52License: Apache Software License
53Group: System Environment/Daemons
54BuildRoot: %{_tmppath}/%{name}-%{version}-root
55BuildRequires: db4-devel, expat-devel
56BuildRequires: findutils, perl, openldap-devel, zlib-devel
57BuildRequires: apr-devel, apr-util-devel
58BuildRequires: pcre-devel, sqlite3-devel
59Requires: mailcap, gawk, file, findutils, apr, apr-util
60Requires(pre): chkconfig, mktemp, fileutils
61Requires(pre): sh-utils, textutils, shadow-utils
62Provides: webserver
63Provides: httpd = %{version}
64Provides: httpd-mmn = %{mmn}
65Conflicts: thttpd
66Obsoletes: secureweb
67Obsoletes: apache2-apr, apache2-apr-devel
68
69%description
70Apache is a powerful, full-featured, efficient, and freely-available
71Web server. Apache is also the most popular Web server on the
72Internet.
73
74%package devel
75Group: Development/Libraries
76Summary: Development tools for the Apache HTTP server.
77Obsoletes: secureweb-devel
78Requires: libtool, httpd = %{version}
79Requires: apr-devel, apr-util-devel
80
81%description devel
82The httpd-devel package contains the APXS binary and other files
83that you need to build Dynamic Shared Objects (DSOs) for Apache.
84
85If you are installing the Apache HTTP server and you want to be
86able to compile or develop additional modules for Apache, you need
87to install this package.
88
89%package manual
90Group: Applications/Documentation
91Summary: Documentation for the Apache HTTP server.
92Obsoletes: secureweb-manual
93
94%description manual
95The httpd-manual package contains the complete manual and
96reference guide for the Apache HTTP server. The information can
97also be found at http://httpd.apache.org/docs/.
98
99%package -n mod_ssl-apache2
100Group: System Environment/Daemons
101Summary: SSL/TLS module for the Apache HTTP server
102Epoch: 1
103BuildRequires: openssl-devel
104Requires(pre): openssl, dev, /bin/cat
105Requires: httpd, make, httpd-mmn = %{mmn}
106
107%description -n mod_ssl-apache2
108The mod_ssl module provides strong cryptography for the Apache Web
109server via the Secure Sockets Layer (SSL) and Transport Layer
110Security (TLS) protocols.
111
112%prep
113%setup -q -n httpd-%{version}
114
115%patch1 -p1 -b .apctl
116%patch2 -p1 -b .apxs
117#patch3 -p1 -b .deplibs
118%patch4 -p1 -b .disablemods
119
120%patch21 -p0 -b .xfsz
121%patch22 -p1 -b .pod
122%patch23 -p1 -b .export
123%patch24 -p1 -b .corelimit
124
125%patch54 -p1 -b .authnoprov
126%patch60 -p1 -b .sslusername
127
128%patch100 -p4 -b .CVE-2010-0408
129%patch110 -p0 -b .CVE-2010-0434
130
131# copy across the migration guide and sed it's location into apachectl
132cp $RPM_SOURCE_DIR/migration.{html,css} .
133%{__perl} -pi -e "s:\@docdir\@:%{_docdir}/%{name}-%{version}:g" \
134        support/apachectl.in
135
136
137# add Vine configure's option to config.layout
138sed -e "s|${prefix}/lib|${prefix}/%{_lib}|" \
139  < $RPM_SOURCE_DIR/vine-config.layout >> config.layout
140
141# regenerate configure scripts
142./buildconf
143
144%build
145# remove bundled apr, apr-util, pcre
146rm -rf srclib/{apr,apr-util,pcre}
147
148#CFLAGS="$RPM_OPT_FLAGS -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64"
149#AP_LIBS="-lssl -lcrypto"
150#export CFLAGS AP_LIBS
151CFLAGS="$RPM_OPT_FLAGS"
152SH_LDFLAGS="-Wl,-z,relro"
153export CFLAGS SH_LDFLAGS
154
155%define mpms worker prefork
156%define prefer_mpm prefork
157
158AP_CONFOPTS="\
159        --prefix=%{_sysconfdir}/apache2 \
160        --exec-prefix=%{_prefix} \
161        --bindir=%{_bindir} \
162        --sbindir=%{_sbindir} \
163        --mandir=%{_mandir} \
164        --libdir=%{_libdir} \
165        --sysconfdir=%{_sysconfdir}/apache2/conf \
166        --includedir=%{_includedir}/apache2 \
167        --libexecdir=%{_libdir}/apache2/modules \
168        --datadir=%{contentdir} \
169        --with-installbuilddir=%{_libdir}/apache2/build \
170        --enable-layout=Vine \
171        --with-program-name=apache2 \
172        --with-ldap \
173        --enable-ldap --enable-authnz-ldap \
174        --enable-mods-shared=all \
175        --enable-cache=shared \
176        --enable-cgi=shared \
177        --enable-cgid=shared \
178        --enable-rewrite=shared \
179        --enable-disk-cache=shared \
180        --enable-file-cache=shared \
181        --enable-mem-cache=shared \
182        --enable-authn-anon --enable-authn-alias \
183        --with-apr=%{_prefix} --with-apr-util=%{_prefix} \
184        --enable-suexec --with-suexec \
185        --with-suexec-caller=%{suexec_caller} \
186        --with-suexec-docroot=%{contentdir} \
187        --with-suexec-logfile=%{_localstatedir}/log/apache2/suexec.log \
188        --with-suexec-bin=%{_libdir}/%{pkgname}/suexec \
189        --with-suexec-uidmin=500 --with-suexec-gidmin=500 \
190        --with-pcre \
191        --enable-ssl --with-ssl \
192        --enable-deflate \
193        --enable-proxy --enable-proxy-connect \
194        --enable-proxy-http --enable-proxy-ftp"
195#all  mpm build
196for mpm in %{mpms}; do
197   mkdir mpm-$mpm;
198   cd mpm-$mpm;
199   ../configure $AP_CONFOPTS --with-mpm=$mpm --srcdir=../ ;
200   make %{?_smp_mflags} ;
201#   mv apache2 apache2.$mpm ;
202   cd ../
203done
204
205%install
206rm -rf $RPM_BUILD_ROOT
207
208# Classify ab and logresolve as section 1 commands, as they are in /usr/bin
209cp -p docs/man/ab.8 docs/man/ab.1
210sed -e "1s/logresolve 8/logresolve 1/" \
211  < docs/man/logresolve.8 > docs/man/logresolve.1
212#rm docs/man/logresolve.8
213
214# install mpms binary
215pushd mpm-prefork
216  make DESTDIR=$RPM_BUILD_ROOT install
217  rm -f $RPM_BUILD_ROOT/%{_sbindir}/apache2
218popd
219
220for mpm in %{mpms}; do
221    install -m755 mpm-$mpm/apache2 $RPM_BUILD_ROOT/%{_sbindir}/apache2.$mpm
222done
223
224# install conf file/directory
225mkdir $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf.d
226install -m 644 $RPM_SOURCE_DIR/README.confd \
227   $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf.d/README
228install -m 644 $RPM_SOURCE_DIR/apache-ssl.conf \
229   $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf.d/ssl.conf
230
231rm $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/*.conf
232install -m 644 $RPM_SOURCE_DIR/httpd.conf \
233   $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/httpd.conf
234
235# mod_ssl bits
236for suffix in crl crt csr key prm; do
237   mkdir $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/ssl.${suffix}
238done
239
240# Makefiles for certificate management
241for ext in crt crl; do
242  install -m 644 $RPM_SOURCE_DIR/mod_ssl-Makefile.${ext} \
243        $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/ssl.${ext}/Makefile.${ext}
244done
245ln -s ../../../usr/share/ssl/certs/Makefile $RPM_BUILD_ROOT/etc/apache2/conf
246
247# for holding mod_dav lock database
248mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/lib/dav
249
250# create a prototype session cache
251mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/cache/mod_ssl
252touch $RPM_BUILD_ROOT%{_localstatedir}/cache/mod_ssl/scache.{dir,pag,sem}
253
254# move utilities to /usr/bin
255mv $RPM_BUILD_ROOT%{_sbindir}/{ab,htdbm,logresolve,htpasswd,htdigest} \
256   $RPM_BUILD_ROOT%{_bindir}
257
258# Make the MMN accessible to module packages
259echo %{mmn} > $RPM_BUILD_ROOT%{_includedir}/apache2/.mmn
260
261# docroot
262# mkdir $RPM_BUILD_ROOT%{contentdir}/html
263install -m 644 $RPM_SOURCE_DIR/index.html.ja \
264        $RPM_BUILD_ROOT%{contentdir}/error/noindex.html
265rm -r $RPM_BUILD_ROOT%{contentdir}/manual/style
266
267install -m 644 $RPM_SOURCE_DIR/vine.png \
268        $RPM_BUILD_ROOT%{contentdir}/icons
269
270# logs
271# rmdir $RPM_BUILD_ROOT%{_sysconfdir}/apache2/logs
272mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/log/apache2
273
274ln -sf %{_sysconfdir}/%{pkgname}/conf/httpd.conf $RPM_BUILD_ROOT/%{_sysconfdir}/%{pkgname}/conf/apache2.conf
275
276
277# symlinks for /etc/apache2
278ln -s ../..%{_localstatedir}/log/apache2 $RPM_BUILD_ROOT/etc/apache2/logs
279ln -s ../..%{_localstatedir}/run $RPM_BUILD_ROOT/etc/apache2/run
280ln -s ../..%{_libdir}/apache2/modules $RPM_BUILD_ROOT/etc/apache2/modules
281ln -s ../..%{_libdir}/apache2/build $RPM_BUILD_ROOT/etc/apache2/build
282
283# install SYSV init stuff
284mkdir -p $RPM_BUILD_ROOT/etc/rc.d/init.d
285install -m755 $RPM_SOURCE_DIR/apache2.init \
286        $RPM_BUILD_ROOT/etc/rc.d/init.d/apache2
287%{__perl} -pi -e "s:\@docdir\@:%{_docdir}/%{name}-%{version}:g" \
288        $RPM_BUILD_ROOT/etc/rc.d/init.d/apache2
289
290# install log rotation stuff
291mkdir -p $RPM_BUILD_ROOT/etc/logrotate.d
292install -m644 $RPM_SOURCE_DIR/apache2.logrotate \
293        $RPM_BUILD_ROOT/etc/logrotate.d/apache2
294
295mv $RPM_BUILD_ROOT/%{_sbindir}/apachectl $RPM_BUILD_ROOT/%{_sbindir}/apache2ctl
296
297# fix man page paths
298sed -e "s|/usr/local/apache2/conf/httpd.conf|/etc/apache2/conf/httpd.conf|" \
299    -e "s|/usr/local/apache2/conf/mime.types|/etc/mime.types|" \
300    -e "s|/usr/local/apache2/conf/magic|/etc/apache2/conf/magic|" \
301    -e "s|/usr/local/apache2/logs/error_log|/var/log/apache2/error_log|" \
302    -e "s|/usr/local/apache2/logs/access_log|/var/log/apache2/access_log|" \
303    -e "s|/usr/local/apache2/logs/httpd.pid|/var/run/apache2.pid|" \
304    -e "s|/usr/local/apache2|/etc/httpd|" < $RPM_SOURCE_DIR/apache2.8 \
305  > $RPM_BUILD_ROOT%{_mandir}/man8/apache2.8
306
307install -m644 $RPM_SOURCE_DIR/apache2ctl.8 \
308        $RPM_BUILD_ROOT%{_mandir}/man8/apache2ctl.8
309
310# change command name to avoid conflict with apache1 pacjage
311%define cflcmd /usr/bin/htdigest /usr/bin/htpasswd /usr/sbin/rotatelogs
312
313for i in %{cflcmd}; do \
314  echo $i
315  mv $RPM_BUILD_ROOT$i $RPM_BUILD_ROOT$i"2";
316done;
317
318mv $RPM_BUILD_ROOT/%{_sbindir}/apxs $RPM_BUILD_ROOT/%{_bindir}/apxs
319
320%define cflman usr/share/man/man1/dbmmanage.1 usr/share/man/man1/htdigest.1 usr/share/man/man1/htpasswd.1 usr/share/man/man8/rotatelogs.8 usr/share/man/man8/suexec.8 usr/share/man/man8/apxs.8 usr/share/man/man8/httpd.8
321
322(cd $RPM_BUILD_ROOT;
323for i in %{cflman}; do \
324    echo $i | sed -e "s|\.1|2\.1|" -e "s|\.8|2\.8|" |    xargs mv $i ;
325   
326done;
327)
328
329#cp $RPM_SOURCE_DIR/config_vars.mk $RPM_BUILD_ROOT/%{_sysconfdir}/%{pkgname}/build/.
330mv $RPM_BUILD_ROOT/%{_sbindir}/suexec $RPM_BUILD_ROOT/%{_libdir}/%{pkgname}/suexec
331
332
333rm -f $RPM_BUILD_ROOT%{_mandir}/man1/ab*
334rm -f $RPM_BUILD_ROOT%{_mandir}/man1/logresolve*
335# conflict with apache 1, so removed...
336rm -f $RPM_BUILD_ROOT%{_mandir}/man8/ab*
337rm -f $RPM_BUILD_ROOT%{_mandir}/man8/logresolve*
338
339# remove unpackaged files
340rm -f $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/mime.types \
341      $RPM_BUILD_ROOT%{_libdir}/*.la \
342      $RPM_BUILD_ROOT%{_libdir}/*.exp \
343      $RPM_BUILD_ROOT%{_libdir}/apache2/modules/*.exp \
344      $RPM_BUILD_ROOT%{_libdir}/apache2/build/config.nice \
345      $RPM_BUILD_ROOT%{_sbindir}/{apache2,checkgid,dbmmanage,envvars*} \
346      $RPM_BUILD_ROOT%{contentdir}/html/* \
347      $RPM_BUILD_ROOT%{contentdir}/cgi-bin/*
348
349%pre
350# Add the "apache" user
351/usr/sbin/useradd -c "Apache" -u 48 \
352        -s /sbin/nologin -r -d %{contentdir} apache 2> /dev/null || :
353
354%triggerpostun -- apache < 2.0
355/sbin/chkconfig --add apache2
356
357
358%post
359# Register the httpd service
360for mpm in %{mpms}; do
361  /sbin/update-alternatives --install %{_sbindir}/apache2 apache2 %{_sbindir}/apache2.$mpm 20;
362done
363/sbin/update-alternatives --install %{_sbindir}/apache2 apache2 %{_sbindir}/apache2.%{prefer_mpm} 30
364/sbin/chkconfig --add apache2
365
366%preun
367if [ $1 = 0 ]; then
368        /sbin/service apache2 stop > /dev/null 2>&1
369        /sbin/chkconfig --del apache2
370        for mpm in %{mpms}; do
371          /sbin/update-alternatives --remove apache2 %{_sbindir}/apache2.$mpm;
372        done 
373fi
374
375%postun
376if [ "$1" -ge 1 ]; then
377        /sbin/service apache2 condrestart
378fi
379/sbin/ldconfig
380
381%post -n mod_ssl-apache2
382/sbin/ldconfig ### is this needed?
383umask 077
384
385if [ ! -f %{_sysconfdir}/apache2/conf/ssl.key/server.key ] ; then
386%{_bindir}/openssl genrsa -rand /proc/apm:/proc/cpuinfo:/proc/dma:/proc/filesystems:/proc/interrupts:/proc/ioports:/proc/pci:/proc/rtc:/proc/uptime 1024 > %{_sysconfdir}/apache2/conf/ssl.key/server.key 2> /dev/null
387fi
388
389FQDN=`hostname`
390if [ "x${FQDN}" = "x" ]; then
391   FQDN=localhost.localdomain
392fi
393
394if [ ! -f %{_sysconfdir}/apache2/conf/ssl.crt/server.crt ] ; then
395cat << EOF | %{_bindir}/openssl req -new -key %{_sysconfdir}/apache2/conf/ssl.key/server.key -x509 -days 365 -out %{_sysconfdir}/apache2/conf/ssl.crt/server.crt 2>/dev/null
396--
397SomeState
398SomeCity
399SomeOrganization
400SomeOrganizationalUnit
401${FQDN}
402root@${FQDN}
403EOF
404fi
405
406%clean
407rm -rf $RPM_BUILD_ROOT
408
409%files
410%defattr(-,root,root)
411
412%doc ABOUT_APACHE README CHANGES LAYOUT LICENSE
413%doc migration.html migration.css
414
415%dir %{_sysconfdir}/apache2
416%{_sysconfdir}/apache2/modules
417%{_sysconfdir}/apache2/logs
418%{_sysconfdir}/apache2/run
419%dir %{_sysconfdir}/apache2/conf
420%config(noreplace) %{_sysconfdir}/apache2/conf/*.conf
421%config(noreplace) %{_sysconfdir}/apache2/conf/magic
422
423%config %{_sysconfdir}/logrotate.d/apache2
424%config %{_sysconfdir}/rc.d/init.d/apache2
425
426%dir %{_sysconfdir}/apache2/conf.d
427%{_sysconfdir}/apache2/conf.d/README
428
429%dir %{_sysconfdir}/apache2/conf/extra
430%config %{_sysconfdir}/apache2/conf/extra/*
431
432%dir %{_sysconfdir}/apache2/conf/original
433%{_sysconfdir}/apache2/conf/original/*
434
435%{_bindir}/ab
436%{_bindir}/ht*
437%{_bindir}/logresolve
438%{_sbindir}/ht*
439%{_sbindir}/apache2.*
440%{_sbindir}/apache2ctl
441%{_sbindir}/rotatelogs2
442%attr(4510,root,%{suexec_caller}) %{_libdir}/%{pkgname}/suexec
443
444%dir %{_libdir}/apache2
445%dir %{_libdir}/apache2/modules
446# everything but mod_ssl.so:
447%{_libdir}/apache2/modules/mod_[a-r]*.so
448%{_libdir}/apache2/modules/mod_s[petu]*.so
449%{_libdir}/apache2/modules/mod_[t-z]*.so
450
451%dir %{contentdir}
452%dir %{contentdir}/cgi-bin
453%dir %{contentdir}/html
454%dir %{contentdir}/icons
455%dir %{contentdir}/error
456%dir %{contentdir}/error/include
457%{contentdir}/icons/*
458%{contentdir}/error/README
459%{contentdir}/error/noindex.html
460%config(noreplace) %{contentdir}/error/*.var
461%config(noreplace) %{contentdir}/error/include/*.html
462
463%attr(0700,root,root) %dir %{_localstatedir}/log/apache2
464
465%attr(0700,apache,apache) %dir %{_localstatedir}/lib/dav
466
467%{_mandir}/man1/*
468
469%{_mandir}/man8/*
470
471%files manual
472%defattr(-,root,root)
473%{contentdir}/manual
474
475%files -n mod_ssl-apache2
476%defattr(-,root,root)
477%{_libdir}/apache2/modules/mod_ssl.so
478%config(noreplace) %{_sysconfdir}/apache2/conf.d/ssl.conf
479%attr(0700,root,root) %dir %{_sysconfdir}/apache2/conf/ssl.*
480%config %{_sysconfdir}/apache2/conf/Makefile
481%config %{_sysconfdir}/apache2/conf/ssl.*/*
482%attr(0700,apache,root) %dir %{_localstatedir}/cache/mod_ssl
483%attr(0600,apache,root) %ghost %{_localstatedir}/cache/mod_ssl/scache.dir
484%attr(0600,apache,root) %ghost %{_localstatedir}/cache/mod_ssl/scache.pag
485%attr(0600,apache,root) %ghost %{_localstatedir}/cache/mod_ssl/scache.sem
486
487%files devel
488%defattr(-,root,root)
489%{_includedir}/apache2
490%{_sysconfdir}/apache2/build
491%{_bindir}/apxs
492%{_mandir}/man8/apxs*
493%{_libdir}/apache2/build/*.mk
494%{_libdir}/apache2/build/*.sh
495
496%changelog
497* Sat Mar 20 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 2.2.14-5
498- add patch110 for fix CVE-2010-0434 from mdk 2010
499
500* Sun Mar  7 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 2.2.14-4
501- add patch100 for fix CVE-2010-0408 (mod_proxy_ajp)
502
503* Fri Feb  5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.2.14-3
504- rebuilt with rpm-4.8.0-3 (on ppc)
505
506* Tue Feb 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.14-2
507- rebuild with db4-4.8.0
508
509* Tue Jan 05 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.14-1
510- new upstream release with security fix
511  (CVE-2009-2699, CVE-2009-3095, CVE-2009-3094)
512- fix ssl.conf (2.2.13-1 includes wrong file)
513
514* Sun Aug 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.13-1
515- new upstream release
516
517* Wed Jul 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.12-1
518- new upstream release
519  (including security fix for CVE-2009-1890, CVE-2009-1191,
520   CVE-2009-1195, CVE-2009-1955, CVE-2009-1956, CVE-2009-0023)
521
522* Fri Jan 09 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.11-2
523- rebuilt with openldap-2.4.11
524
525* Fri Jan  2 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.11-1
526- new upstream release
527
528* Sat Oct 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.10-1
529- new upstream release (including security fix for CVE-2008-2939)
530
531* Fri Jun 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.9-1
532- new upstream release (including security fix for CVE-2008-2364, CVE-2007-6420)
533- built with db4-4.6.21, apr 1.3.0
534
535* Sun Apr 27 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 2.2.8-1
536- add Patch60 (to fix bug#31418).
537
538* Thu Feb 21 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.8-0vl2
539- rebuild with expat-2.0.1
540
541* Tue Jan 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.8-0vl1
542- new upstream release
543
544* Sat Nov  3 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.6-0vl2
545- added postun script from VinePlus/4.0 package
546  * Tue Sep 11 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.3-0vl3.2
547  - add postun script to restart daemon with message
548
549* Sun Jul 01 2007 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.3-0vl8
550- updated Patch2: httpd-2.2.3-apxs.patch
551
552* Sun Jun 24 2007 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.3-0vl7
553- modified libdir in config.layout for lib64 architecture
554
555* Sun May 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.3-0vl6
556- rebuilt with openssl-0.9.8e
557
558* Thu May 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.2.3-0vl5
559- rebuilt with new toolchain and db4-4.3.x
560
561* Tue Feb  7 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.3-0vl4
562- added BuildRequires: pcre-devel, sqlite3-devel <BTS:VineLinux:474>
563
564* Mon Sep 11 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.2.3-0vl3
565- change manual Group to Applications/Documentation. <BTS:VineLinux:163>
566
567* Sun Aug 27 2006 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.3-0vl2
568- rebuilt with openldap-2.3.27-0vl1
569
570* Sat Jul 29 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.3-0vl1
571- new upstream release including security fix (CVE-2006-3747)
572
573* Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
574- new upstream release
575  - update to 2.2.2
576- remove apr/apr-devel subpackage,
577  use external apr/apr-util instead of internal one.
578
579* Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.58-0vl1
580- new upstream release
581- use apache2.prefork as default.
582
583* Thu Mar 23 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.55-0vl3
584- rebuild to use new _localstatedir (rpm-4.4.2-0vl11)
585- remove unpackaged files in %%install section
586
587* Fri Jan 27 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.55-0vl2
588- fix logrotate configuration (use apache2.pid instead of httpd.pid)
589  (BTS:10)
590- use Epoch instead of Serial
591
592* Sat Oct 15 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.55-0vl1
593- new upstream release
594- drop obsolete security patches which is merged in upstream
595
596* Sat Oct 08 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.54-0vl1
597- new upstream release
598
599* Sun Sep 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.53-0vl2
600- added Patch122 to 125 for secutiry fix
601  (CAN-2004-{1268,2088,2700,2728})
602- fix %install section
603
604* Sun Apr 10 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.53-0vl1
605- new upstream release
606
607* Sat Nov 06 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.52-0vl1
608- new upstream release
609
610* Sun Oct 24 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.50-0vl4
611- rebuilt with db4-4.2.52
612
613* Sat Sep  4 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 2.0.50-0vl3
614- separate apr, apr-devel packages
615- add BuildPreReq: zlib-devel
616
617* Sun Jul 11 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.50-0vl2
618- fix %%files to include instdso.sh
619  thanks to jax <jax AT morejams DOT no-ip DOT com>
620- add %%{?_smp_mflags} to make option.
621
622* Sun Jul  4 2004 IWAI, Masaharu <iwai@alib.jp> 2.0.50-0vl1
623- new upstream version
624
625* Sun Nov 23 2003 IWAI, Masaharu <iwai@alib.jp> 2.0.48-0vl1
626- new upstream version
627
628* Mon Sep 15 2003 IWAI, Masaharu <iwai@alib.jp> 2.0.47-0vl1
629- new upstream version
630- update apxs patch (Patch101)
631- fix dependency:
632    - change file name to package name in Requires and {Build,}Prereq
633- add BuildPrereq: openldap-devel
634- update %%files section
635- rename httpd.8 manpage
636
637* Tue May 12 2003 Satoshi MACHINO <machino@vinelinux.org> 2.0.45-0vl1
638- new upstream version
639- used vine-config.layout in srclib
640
641* Tue May 12 2003 Satoshi MACHINO <machino@vinelinux.org> 2.0.44-0vl9
642- rebuild
643
644* Sun Apr  6 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl8
645- change pkg name from mod_ssl to mod_ssl-apache2
646- remove "apache-manual" entry from Obsoletes:
647
648* Thu Apr  3 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl7
649- remove "mod_dav" and "apache-devel" from Obsoletes:
650- enable MPMS(worker %mpms )
651
652* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl6
653- add correct config_vars.mk
654
655* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl5
656- apply apxs's patch ( from Debian)
657
658* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl4
659- add apr-config,apu-config to devel's %file
660
661* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl3
662- change apxs path ( /usr/sbin -> /usr/bin
663- add symlink under /etc/apache2/conf
664  (logs, run), httpd.conf -> apache2.conf
665- fixed apache2 initscript.
666
667* Sat Mar 29 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl2
668- build Vine Linux
669- new upstream version
670- sharing with apache1
671
672* Wed Sep  4 2002 Nalin Dahyabhai <nalin@redhat.com> 2.0.40-8
673- link httpd with libssl to avoid library loading/unloading weirdness
674
675* Tue Sep  3 2002 Joe Orton <jorton@redhat.com> 2.0.40-7
676- add LoadModule lines for proxy modules in httpd.conf (#73349)
677- fix permissions of conf/ssl.*/ directories; add Makefiles for
678  certificate management (#73352)
679
680* Mon Sep  2 2002 Joe Orton <jorton@redhat.com> 2.0.40-6
681- provide "httpd-mmn" to manage module ABI compatibility
682
683* Sun Sep  1 2002 Joe Orton <jorton@redhat.com> 2.0.40-5
684- fix SSL session cache (#69699)
685- revert addition of LDAP support to apr-util
686
687* Mon Aug 26 2002 Joe Orton <jorton@redhat.com> 2.0.40-4
688- set SIGXFSZ disposition to "ignored" (#69520)
689- make dummy connections to the first listener in config (#72692)
690
691* Mon Aug 26 2002 Joe Orton <jorton@redhat.com> 2.0.40-3
692- allow "apachectl configtest" on a 1.3 httpd.conf
693- add mod_deflate
694- enable LDAP support in apr-util
695- don't package everything in /var/www/error as config(noreplace)
696
697* Wed Aug 21 2002 Bill Nottingham <notting@redhat.com> 2.0.40-2
698- add trigger (#68657)
699
700* Mon Aug 12 2002 Joe Orton <jorton@redhat.com> 2.0.40-1
701- update to 2.0.40
702
703* Wed Jul 24 2002 Joe Orton <jorton@redhat.com> 2.0.36-8
704- improve comment on use of UserDir in default config (#66886)
705
706* Wed Jul 10 2002 Joe Orton <jorton@redhat.com> 2.0.36-7
707- use /sbin/nologin as shell for apache user (#68371)
708- add patch from CVS to fix possible infinite loop when processing
709  internal redirects
710
711* Wed Jun 26 2002 Gary Benson <gbenson@redhat.com> 2.0.36-6
712- modify init script to detect 1.3.x httpd.conf's and direct users
713  to the migration guide
714
715* Tue Jun 25 2002 Gary Benson <gbenson@redhat.com> 2.0.36-5
716- patch apachectl to detect 1.3.x httpd.conf's and direct users
717  to the migration guide
718- ship the migration guide
719
720* Fri Jun 21 2002 Joe Orton <jorton@redhat.com>
721- move /etc/httpd2 back to /etc/httpd
722- add noindex.html page and poweredby logo; tweak default config
723  to load noindex.html if no default "/" page is present.
724- add patch to prevent mutex errors on graceful restart
725
726* Fri Jun 21 2002 Tim Powers <timp@redhat.com> 2.0.36-4
727- automated rebuild
728
729* Wed Jun 12 2002 Joe Orton <jorton@redhat.com> 2.0.36-3
730- add patch to fix SSL mutex handling
731
732* Wed Jun 12 2002 Joe Orton <jorton@redhat.com> 2.0.36-2
733- improved config directory patch
734
735* Mon May 20 2002 Joe Orton <jorton@redhat.com>
736- initial build; based heavily on apache.spec and mod_ssl.spec
737- fixes: #65214, #58490, #57376, #61265, #65518, #58177, #57245
738
Note: See TracBrowser for help on using the repository browser.