source: projects/specs/trunk/a/apache2/apache2-vl.spec @ 12131

Revision 12131, 30.1 KB checked in by tomop, 5 years ago (diff)

Merge branch 'tomop'

Line 
1%define contentdir %{_datadir}/apache2
2%define docroot /var/www/apache2
3%define suexec_caller www-data
4%define mmn 20120211
5%define mmnisa %{mmn}%{__isa_name}%{__isa_bits}
6%define pkgname apache2
7%define vstring Vine
8
9Summary: Apache HTTP Server
10Name: %{pkgname}
11Version: 2.4.41
12Release: 1%{_dist_release}
13URL: http://httpd.apache.org/
14
15Vendor: Project Vine
16Distribution: Vine Linux
17Packager: daisuke
18
19Source0: http://www.apache.org/dist/httpd/httpd-%{version}.tar.bz2
20Source2: index.html
21Source3: apache2.logrotate
22Source4: apache2.init
23Source6: poweredby-vine.png
24Source7: apache2.tmpfiles
25Source10: httpd.conf
26Source11: 00-base.conf
27Source12: 00-mpm.conf
28Source13: 00-lua.conf
29Source14: 01-cgi.conf
30Source15: 00-dav.conf
31Source16: 00-proxy.conf
32Source17: 00-ssl.conf
33Source18: 01-ldap.conf
34Source19: 00-proxyhtml.conf
35Source20: userdir.conf
36Source21: ssl.conf
37Source22: welcome.conf
38Source23: manual.conf
39Source25: 01-session.conf
40Source28: 00-optional.conf
41# Documentation
42Source30: README.confd
43Source31: README.confmod
44# add vine entry to config.layout
45Source100: vine-config.layout
46
47# build/scripts patches
48Patch2: httpd-2.4.9-apxs.patch
49Patch3: httpd-2.4.1-deplibs.patch
50# Needed for socket activation and mod_systemd patch
51#Patch19: httpd-2.4.25-detect-systemd.patch
52# Features/functional changes
53Patch21: httpd-2.4.39-r1842929+.patch
54Patch23: httpd-2.4.41-export.patch
55Patch24: httpd-2.4.1-corelimit.patch
56#Patch25: httpd-2.4.25-selinux.patch
57#Patch26: httpd-2.4.4-r1337344+.patch
58Patch27: httpd-2.4.2-icons.patch
59#Patch29: httpd-2.4.27-systemd.patch
60Patch30: httpd-2.4.4-cachehardmax.patch
61Patch31: httpd-2.4.33-sslmultiproxy.patch
62Patch34: httpd-2.4.17-socket-activation.patch
63Patch36: httpd-2.4.38-r1830819+.patch
64#Patch37: httpd-2.4.34-r1827912+.patch
65Patch38: httpd-2.4.34-sslciphdefault.patch
66Patch39: httpd-2.4.37-sslprotdefault.patch
67Patch40: httpd-2.4.39-r1861269.patch
68Patch41: httpd-2.4.37-r1861793+.patch
69Patch42: httpd-2.4.37-r1828172+.patch
70
71# Bug fixes
72# https://bugzilla.redhat.com/show_bug.cgi?id=1397243
73Patch58: httpd-2.4.34-r1738878.patch
74Patch60: httpd-2.4.34-enable-sslv3.patch
75
76# Security fixes
77
78
79License: Apache Software License
80Group: System Environment/Daemons
81BuildRoot: %{_tmppath}/%{name}-%{version}-root
82BuildRequires: db4-devel, expat-devel, xmlto
83BuildRequires: findutils, perl, openldap-devel, zlib-devel
84BuildRequires: apr-devel, apr-util-devel
85BuildRequires: pcre-devel, sqlite3-devel
86BuildRequires: lua-devel, libxml2-devel
87BuildRequires: libnghttp2-devel
88BuildRequires: www-common
89Requires: mailcap, gawk, file, findutils, apr, apr-util
90Requires(pre): www-common
91Requires(pre): chkconfig, mktemp, fileutils
92Requires(pre): sh-utils, textutils, shadow-utils
93Requires(post): alternatives
94Provides: webserver
95Provides: httpd = %{version}
96Provides: httpd-mmn = %{mmn}
97Provides: apache2-mmn = %{mmn}
98Obsoletes: apache2-apr, apache2-apr-devel
99Obsoletes: apache < 2.0, apache-devel < 2.0
100
101%description
102Apache is a powerful, full-featured, efficient, and freely-available
103Web server. Apache is also the most popular Web server on the
104Internet.
105
106%package devel
107Group: Development/Libraries
108Summary: Development tools for the Apache HTTP server.
109Requires: libtool, apache2 = %{version}
110Requires: apr-devel, apr-util-devel
111
112%description devel
113The httpd-devel package contains the APXS binary and other files
114that you need to build Dynamic Shared Objects (DSOs) for Apache.
115
116If you are installing the Apache HTTP server and you want to be
117able to compile or develop additional modules for Apache, you need
118to install this package.
119
120%package manual
121Group: Applications/Documentation
122Summary: Documentation for the Apache HTTP server.
123
124%description manual
125The httpd-manual package contains the complete manual and
126reference guide for the Apache HTTP server. The information can
127also be found at http://httpd.apache.org/docs/.
128
129%package -n mod_ssl-apache2
130Group: System Environment/Daemons
131Summary: SSL/TLS module for the Apache HTTP server
132Epoch: 1
133BuildRequires: openssl-devel
134Requires(pre): net-tools, openssl, dev, /bin/cat
135Requires: apache2, make, apache2-mmn = %{mmn}
136
137%description -n mod_ssl-apache2
138The mod_ssl module provides strong cryptography for the Apache Web
139server via the Secure Sockets Layer (SSL) and Transport Layer
140Security (TLS) protocols.
141
142%prep
143%setup -q -n httpd-%{version}
144
145%patch2 -p1 -b .apxs
146%patch3 -p1 -b .deplibs
147#%patch6 -p1 -b .apctlsystemd
148
149#%patch19 -p1 -b .detectsystemd
150
151%patch21 -p1 -b .r1842929+
152%patch23 -p1 -b .export
153%patch24 -p1 -b .corelimit
154#%patch25 -p1 -b .selinux
155#patch26 -p1 -b .r1337344+
156%patch27 -p1 -b .icons
157#patch29 -p1 -b .systemd
158%patch30 -p1 -b .cachehardmax
159#%patch31 -p1 -b .sslmultiproxy
160%patch34 -p1 -b .socketactivation
161%patch36 -p1 -b .r1830819+
162#%patch37 -p1 -b .r1827912+
163%patch38 -p1 -b .sslciphdefault
164%patch39 -p1 -b .sslprotdefault
165%patch40 -p1 -b .r1861269
166%patch41 -p1 -b .r1861793+
167%patch42 -p1 -b .r1828172+
168
169%patch58 -p1 -b .r1738878
170%patch60 -p1 -b .enable-sslv3
171
172perl -pi -e 's|/httpd/build|/apache2/build|' support/apxs.in
173
174# Patch in the vendor string
175sed -i '/^#define PLATFORM/s/Unix/%{vstring}/' os/unix/os.h
176
177# Prevent use of setcap in "install-suexec-caps" target.
178sed -i '/suexec/s,setcap ,echo Skipping setcap for ,' Makefile.in
179
180# add Vine configure's option to config.layout
181sed -e "s|${prefix}/lib|${prefix}/%{_lib}|" \
182  < $RPM_SOURCE_DIR/vine-config.layout >> config.layout
183
184%build
185# remove bundled apr, apr-util, pcre
186rm -rf srclib/{apr,apr-util,pcre}
187
188# regenerate configure scripts
189autoheader && autoconf || exit 1
190
191CFLAGS="$RPM_OPT_FLAGS"
192SH_LDFLAGS="-Wl,-z,relro"
193export CFLAGS SH_LDFLAGS
194
195AP_CONFOPTS="\
196        --prefix=%{_sysconfdir}/apache2 \
197        --exec-prefix=%{_prefix} \
198        --bindir=%{_bindir} \
199        --sbindir=%{_sbindir} \
200        --mandir=%{_mandir} \
201        --libdir=%{_libdir} \
202        --sysconfdir=%{_sysconfdir}/apache2/conf \
203        --includedir=%{_includedir}/apache2 \
204        --libexecdir=%{_libdir}/apache2/modules \
205        --datadir=%{contentdir} \
206        --with-installbuilddir=%{_libdir}/apache2/build \
207        --enable-layout=Vine \
208        --with-program-name=apache2 \
209        --with-ldap \
210        --enable-ldap --enable-authnz-ldap \
211        --enable-mods-shared=all \
212        --enable-cache=shared \
213        --enable-cgi=shared \
214        --enable-cgid=shared \
215        --enable-rewrite=shared \
216        --enable-disk-cache=shared \
217        --enable-file-cache=shared \
218        --enable-mem-cache=shared \
219        --enable-authn-anon --enable-authn-alias \
220        --with-apr=%{_prefix} --with-apr-util=%{_prefix} \
221        --enable-suexec --with-suexec \
222        --enable-suexec-capabilities \
223        --with-suexec-caller=%{suexec_caller} \
224        --with-suexec-docroot=%{docroot} \
225        --with-suexec-logfile=%{_localstatedir}/log/apache2/suexec.log \
226        --with-suexec-bin=%{_sbindir}/suexec \
227        --with-suexec-uidmin=500 --with-suexec-gidmin=500 \
228        --with-pcre \
229        --enable-pie \
230        --enable-ssl --with-ssl \
231        --enable-deflate \
232        --enable-proxy --enable-proxy-connect \
233        --enable-proxy-http --enable-proxy-ftp \
234        --enable-case-filter --enable-case-filter-in \
235        --enable-http2 \
236        --enable-mpms-shared=all"
237./configure ${AP_CONFOPTS}
238make %{?_smp_mflags}
239
240%install
241rm -rf $RPM_BUILD_ROOT
242
243make DESTDIR=$RPM_BUILD_ROOT install
244
245# create apache2ctl symlink
246ln -sf apachectl $RPM_BUILD_ROOT%{_sbindir}/apache2ctl
247
248# install conf file/directory
249mkdir $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf.d \
250      $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf.modules.d \
251      $RPM_BUILD_ROOT%{_sysconfdir}/apache2/sites.d
252install -m 644 $RPM_SOURCE_DIR/README.confd \
253   $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf.d/README
254install -m 644 $RPM_SOURCE_DIR/README.confmod \
255   $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf.modules.d/README
256
257for f in 00-base.conf 00-mpm.conf 00-lua.conf 01-cgi.conf 00-dav.conf \
258         00-proxy.conf 00-ssl.conf 01-ldap.conf 00-proxyhtml.conf \
259         01-ldap.conf 01-session.conf 00-optional.conf; do
260  install -m 644 -p $RPM_SOURCE_DIR/$f \
261                    $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf.modules.d/$f
262done
263
264for f in welcome.conf ssl.conf manual.conf userdir.conf; do
265  install -m 644 -p $RPM_SOURCE_DIR/$f \
266     $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf.d/$f
267done
268
269# Split-out extra config shipped as default in conf.d:
270for f in autoindex; do
271  mv docs/conf/extra/httpd-${f}.conf \
272     $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf.d/${f}.conf
273done
274         
275# Extra config trimmed:
276rm -v docs/conf/extra/httpd-{ssl,userdir}.conf
277
278rm $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/*.conf
279install -m 644 -p $RPM_SOURCE_DIR/httpd.conf \
280   $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/httpd.conf
281ln -sf httpd.conf $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/apache2.conf
282
283# tmpfiles.d configuration
284mkdir -p $RPM_BUILD_ROOT%{_prefix}/lib/tmpfiles.d
285install -m 644 -p $RPM_SOURCE_DIR/apache2.tmpfiles \
286   $RPM_BUILD_ROOT%{_prefix}/lib/tmpfiles.d/apache2.conf
287
288# Other directories
289mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/lib/dav \
290         $RPM_BUILD_ROOT/run/apache2/htcacheclean
291
292# Create cache directory
293mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/cache/apache2 \
294         $RPM_BUILD_ROOT%{_localstatedir}/cache/apache2/proxy \
295         $RPM_BUILD_ROOT%{_localstatedir}/cache/apache2/ssl
296
297# Make the MMN accessible to module packages
298echo %{mmnisa} > $RPM_BUILD_ROOT%{_includedir}/apache2/.mmn
299mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/rpm
300cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.apache2 <<EOF
301%%_httpd_mmn %{mmnisa}
302%%_httpd_apxs %%{_bindir}/apxs
303%%_httpd_modconfdir %%{_sysconfdir}/apache2/conf.modules.d
304%%_httpd_confdir %%{_sysconfdir}/apache2/conf.d
305%%_httpd_contentdir %{contentdir}
306%%_httpd_moddir %%{_libdir}/apache2/modules
307%%_apache2_mmn %{mmnisa}
308%%_apache2_apxs %%{_bindir}/apxs
309%%_apache2_modconfdir %%{_sysconfdir}/apache2/conf.modules.d
310%%_apache2_confdir %%{_sysconfdir}/apache2/conf.d
311%%_apache2_contentdir %{contentdir}
312%%_apache2_moddir %%{_libdir}/apache2/modules
313EOF
314
315# Handle contentdir
316mkdir $RPM_BUILD_ROOT%{contentdir}/noindex
317install -m 644 -p $RPM_SOURCE_DIR/index.html \
318        $RPM_BUILD_ROOT%{contentdir}/noindex/index.html
319install -m 644 -p $RPM_SOURCE_DIR/poweredby-vine.png \
320        $RPM_BUILD_ROOT%{contentdir}/icons/
321rm -rf %{contentdir}/htdocs
322
323# remove manual sources
324find $RPM_BUILD_ROOT%{contentdir}/manual \( \
325    -name \*.xml -o -name \*.xml.* -o -name \*.ent -o -name \*.xsl -o -name \*.dtd \
326    \) -print0 | xargs -0 rm -f
327
328# Strip the manual down just to English and replace the typemaps with flat files:
329set +x
330for f in `find $RPM_BUILD_ROOT%{contentdir}/manual -name \*.html -type f`; do
331   if test -f ${f}.en; then
332      cp ${f}.en ${f}
333      rm ${f}.*
334   fi
335done
336set -x
337
338# Clean Document Root
339rm -v $RPM_BUILD_ROOT%{docroot}/html/*.html
340rm -v $RPM_BUILD_ROOT/var/www/cgi-bin/*
341
342# symlinks for /etc/apache2
343ln -s ../..%{_localstatedir}/log/apache2 $RPM_BUILD_ROOT/etc/apache2/logs
344ln -s /run/apache2 $RPM_BUILD_ROOT/etc/apache2/run
345ln -s ../..%{_libdir}/apache2/modules $RPM_BUILD_ROOT/etc/apache2/modules
346
347# install SYSV init stuff
348mkdir -p $RPM_BUILD_ROOT/etc/rc.d/init.d
349install -m755 $RPM_SOURCE_DIR/apache2.init \
350        $RPM_BUILD_ROOT/etc/rc.d/init.d/apache2
351%{__perl} -pi -e "s:\@docdir\@:%{_docdir}/%{name}-%{version}:g" \
352        $RPM_BUILD_ROOT/etc/rc.d/init.d/apache2
353
354# Install logrotate config
355mkdir -p $RPM_BUILD_ROOT/etc/logrotate.d
356install -m 644 -p $RPM_SOURCE_DIR/apache2.logrotate \
357        $RPM_BUILD_ROOT/etc/logrotate.d/apache2
358
359# fix man page paths
360sed -e "s|/usr/local/apache2/conf/httpd.conf|/etc/apache2/conf/httpd.conf|" \
361    -e "s|/usr/local/apache2/conf/mime.types|/etc/mime.types|" \
362    -e "s|/usr/local/apache2/conf/magic|/etc/apache2/conf/magic|" \
363    -e "s|/usr/local/apache2/logs/error_log|/var/log/apache2/error_log|" \
364    -e "s|/usr/local/apache2/logs/access_log|/var/log/apache2/access_log|" \
365    -e "s|/usr/local/apache2/logs/httpd.pid|/run/apache2/apache2.pid|" \
366    -e "s|/usr/local/apache2|/etc/httpd|" < docs/man/httpd.8 \
367  > $RPM_BUILD_ROOT%{_mandir}/man8/httpd.8
368
369# Make ap_config_layout.h libdir-agnostic
370sed -i '/.*DEFAULT_..._LIBEXECDIR/d;/DEFAULT_..._INSTALLBUILDDIR/d' \
371    $RPM_BUILD_ROOT%{_includedir}/apache2/ap_config_layout.h
372
373# Fix path to instdso in special.mk
374sed -i '/instdso/s,top_srcdir,top_builddir,' \
375    $RPM_BUILD_ROOT%{_libdir}/apache2/build/special.mk
376
377# Remove unpackaged files
378rm -vf \
379      $RPM_BUILD_ROOT%{_libdir}/*.exp \
380      $RPM_BUILD_ROOT/etc/apache2/conf/mime.types \
381      $RPM_BUILD_ROOT%{_libdir}/apache2/modules/*.exp \
382      $RPM_BUILD_ROOT%{_libdir}/apache2/build/config.nice \
383      $RPM_BUILD_ROOT%{_bindir}/{ap?-config,dbmmanage} \
384      $RPM_BUILD_ROOT%{_sbindir}/{checkgid,envvars*} \
385      $RPM_BUILD_ROOT%{contentdir}/htdocs/* \
386      $RPM_BUILD_ROOT%{_mandir}/man1/dbmmanage.* \
387      $RPM_BUILD_ROOT%{contentdir}/cgi-bin/*
388
389rm -rf $RPM_BUILD_ROOT/etc/apache2/conf/{original,extra}
390
391
392
393%triggerpostun -- apache < 2.0
394/sbin/chkconfig --add apache2
395
396
397%post
398/sbin/chkconfig --add apache2
399
400%preun
401if [ $1 = 0 ]; then
402        /sbin/service apache2 stop > /dev/null 2>&1
403        /sbin/chkconfig --del apache2
404fi
405
406%postun
407if [ "$1" -ge 1 ]; then
408        /sbin/service apache2 condrestart
409fi
410/sbin/ldconfig
411
412%define sslcert %{_sysconfdir}/pki/tls/certs/localhost.crt
413%define sslkey %{_sysconfdir}/pki/tls/private/localhost.key
414
415%post -n mod_ssl-apache2
416umask 077
417
418if [ -f %{sslkey} -o -f %{sslcert} ]; then
419  exit 0
420fi
421
422%{_bindir}/openssl genrsa \
423  -rand /proc/apm:/proc/cpuinfo:/proc/dma:/proc/filesystems:/proc/interrupts:/proc/ioports:/proc/pci:/proc/rtc:/proc/uptime \
424  2048 > %{sslkey} 2> /dev/null ||:
425
426FQDN=`hostname` ||:
427if [ "x${FQDN}" = "x" ]; then
428   FQDN=localhost.localdomain
429fi
430   
431cat << EOF | %{_bindir}/openssl req -new -key %{sslkey} \
432         -x509 -sha256 -days 3650 -set_serial $RANDOM -extensions v3_req \
433         -out %{sslcert} 2>/dev/null ||:
434--
435SomeState
436SomeCity
437SomeOrganization
438SomeOrganizationalUnit
439${FQDN}
440root@${FQDN}
441EOF
442
443%clean
444rm -rf $RPM_BUILD_ROOT
445
446%files
447%defattr(-,root,root)
448%license LICENSE
449%doc ABOUT_APACHE README CHANGES LAYOUT
450%doc docs/conf/extra/*.conf
451
452%dir %{_sysconfdir}/apache2
453%{_sysconfdir}/apache2/modules
454%{_sysconfdir}/apache2/logs
455%{_sysconfdir}/apache2/run
456%dir %{_sysconfdir}/apache2/conf
457%config(noreplace) %{_sysconfdir}/apache2/conf/httpd.conf
458%config(noreplace) %{_sysconfdir}/apache2/conf/apache2.conf
459%config(noreplace) %{_sysconfdir}/apache2/conf/magic
460
461%config(noreplace) %{_sysconfdir}/logrotate.d/apache2
462
463%config %{_sysconfdir}/rc.d/init.d/apache2
464
465%dir %{_sysconfdir}/apache2/conf.d
466%{_sysconfdir}/apache2/conf.d/README
467%config(noreplace) %{_sysconfdir}/apache2/conf.d/*.conf
468%exclude %{_sysconfdir}/apache2/conf.d/ssl.conf
469%exclude %{_sysconfdir}/apache2/conf.d/manual.conf
470
471%dir %{_sysconfdir}/apache2/conf.modules.d
472%{_sysconfdir}/apache2/conf.modules.d/README
473%config(noreplace) %{_sysconfdir}/apache2/conf.modules.d/*.conf
474%exclude %{_sysconfdir}/apache2/conf.modules.d/00-ssl.conf
475
476%dir %{_sysconfdir}/apache2/sites.d
477
478%{_prefix}/lib/tmpfiles.d/apache2.conf
479
480%{_bindir}/ab
481%{_bindir}/ht*
482%{_bindir}/logresolve
483%{_sbindir}/ht*
484%{_sbindir}/apache2
485%{_sbindir}/apachectl
486%{_sbindir}/apache2ctl
487%{_sbindir}/rotatelogs
488%{_sbindir}/fcgistarter
489%attr(4510,root,%{suexec_caller}) %{_sbindir}/suexec
490
491%dir %{_libdir}/apache2
492%dir %{_libdir}/apache2/modules
493%{_libdir}/apache2/modules/mod_*.so
494%exclude %{_libdir}/apache2/modules/mod_ssl.so
495
496%dir %{contentdir}
497%dir %{contentdir}/icons
498%dir %{contentdir}/error
499%dir %{contentdir}/error/include
500%dir %{contentdir}/noindex
501%{contentdir}/icons/*
502%{contentdir}/error/README
503%{contentdir}/error/*.var
504%{contentdir}/error/include/*.html
505%{contentdir}/noindex/index.html
506
507%dir %{docroot}/html
508%dir /var/www/cgi-bin
509
510%attr(0710,root,www-data) %dir /run/apache2
511%attr(0700,www-data,www-data) %dir /run/apache2/htcacheclean
512
513%attr(0700,root,root) %dir %{_localstatedir}/log/apache2
514%attr(0700,www-data,www-data) %dir %{_localstatedir}/lib/dav
515%attr(0700,www-data,www-data) %dir %{_localstatedir}/cache/apache2
516%attr(0700,www-data,www-data) %dir %{_localstatedir}/cache/apache2/proxy
517
518%{_mandir}/man1/*
519%exclude %{_mandir}/man1/apxs*
520
521%{_mandir}/man8/*
522
523
524%files manual
525%defattr(-,root,root)
526%{contentdir}/manual
527%config(noreplace) %{_sysconfdir}/apache2/conf.d/manual.conf
528
529
530%files -n mod_ssl-apache2
531%defattr(-,root,root)
532%{_libdir}/apache2/modules/mod_ssl.so
533%config(noreplace) %{_sysconfdir}/apache2/conf.modules.d/00-ssl.conf
534%config(noreplace) %{_sysconfdir}/apache2/conf.d/ssl.conf
535%attr(0700,www-data,www-data) %dir %{_localstatedir}/cache/apache2/ssl
536
537
538%files devel
539%defattr(-,root,root)
540%{_includedir}/apache2
541%{_bindir}/apxs
542%{_mandir}/man1/apxs*
543%dir %{_libdir}/apache2/build
544%{_libdir}/apache2/build/*.mk
545%{_libdir}/apache2/build/*.sh
546%{_sysconfdir}/rpm/macros.apache2
547
548
549%changelog
550* Thu Aug 29 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.41-1
551- new upstream release.
552- dropped Patch1 and 5.
553- updated Patch23, 36 and 39.
554- imported Patch21 and 40-42 from rawhide.
555
556* Tue Nov 06 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.37-1
557- new upstream release.
558- updated patches.
559
560* Sun Apr 01 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.33-1
561- new upstream release.
562- updated Patch35 and 58.
563- disabled Patch31.
564- dropped Patch23: fixed in upstream.
565- imported Patch23 from rawhide.
566
567* Mon Dec 18 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.29-1
568- new upstream release.
569- fixed apxs.
570- dropped Patch56,60 and 61: fixed in upstream.
571
572* Sun Oct 15 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.28-1
573- new upstream release.
574
575* Fri Mar 17 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.25-1
576- new upstream release.
577- dropped Patch55: fixed in upstream.
578
579* Fri Jul  8 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.23-1
580- new upstream release.
581
582* Tue Jun  7 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.20-2
583- enabled HTTP/2.
584
585* Sun May 29 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.20-1
586- updated to 2.4.20.
587- updated Patch58.
588- fixed %%files.
589- fixed location of suexec (BTS#3007).
590
591* Thu Mar 10 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.18-2
592- rebuilt with openssl 1.0.2g
593
594* Thu Feb  4 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.18-1
595- updated to 2.4.18.
596- fixed 00-base.conf.
597- updated Patch31.
598
599* Mon Dec  7 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.17-2
600- fixed configuration files.
601
602* Fri Dec  4 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.17-1
603- update to 2.4.17.
604- fixed dependency.
605
606* Wed Jun 25 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 2.4.9-2
607- modify dependency
608
609* Wed Jun 25 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 2.4.9-1
610- update to 2.4.9
611- remove suffix '2' from {htdigest,htpasswd,rotatelogs}2
612- use /run instead of /var/run
613- remove /etc/apache2/conf/ssl* , use /etc/pki now.
614- move suexec from %%{_libdir}/apache2 to %%{_sbindir}
615- split all LoadModules to conf.modules.d/*.conf
616- split module configs to conf.d/*.conf
617- cleanup docroot, move apache specific files to %%{_datadir}/apache2
618- add BR: lua-devel, libxml2-devel
619- add /etc/apache2/sites.d for virtual host settings.
620
621* Wed Dec 25 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.25-2
622- merge VineSeed spec file
623  * Wed Oct 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.23-2
624  - rebuild with pcre-8.31
625
626  * Wed Mar 21 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.23-1
627  - update to 2.2.23
628  - add R(pre): www-common, BR: www-common
629  - move apache contents to %{contentdir}
630
631* Sat Sep 28 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.25-1
632- new upstream release with security fix (CVE-2013-1862,1896)
633- drop patch100 (is included in new release)
634
635* Fri May 17 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.24-2
636- add patch100 for fix CVE-2013-1862 (mod_rewrite)
637
638* Wed Feb 27 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.24-1
639- new upstream release with security fix (CVE-2012-3499, 4558)
640
641* Sun Sep 16 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.23-1
642- new upstream release with security fix (CVE-2012-3502,CVE-2012-2687)
643- update patch22 to fit new release
644- update man filename convert list
645
646* Wed Mar 21 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.22-1
647- update to 2.2.22
648  - CVE-2012-0021 (mod_log_config)
649  - CVE-2012-0031
650  - CVE-2012-0053
651- remove upstreamed patches
652
653* Fri Dec  9 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.21-5
654- add patch120 for fix CVE-2011-4317 (mod_rewrite/mod_proxy)
655
656* Fri Nov 18 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.21-4
657- add patch110 for fix CVE-2011-3607-4415 (ModSetEnvIf)
658
659* Wed Oct 12 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.21-3
660- add patch70 for fix byterange filter
661
662* Tue Oct 11 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.21-2
663- add Patch100 for fix CVE-2011-3368 (mod_proxy)
664
665* Wed Sep 14 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.21-1
666- new upstream release with security fix (CVE-2011-3348)
667- regression fixes of CVE-2011-3192 byterange fix in 2.2.20
668
669* Tue Sep  6 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.20-3
670- update Patch101 (Thanks to debian team)
671
672* Sat Sep  3 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.20-2
673- add Patch101 for fix CVE-2011-3192 regression
674
675* Thu Sep  1 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.20-1
676- new upstream release with security fix (CVE-2011-3192)
677- drop patch100 (is included in new release)
678
679* Thu Aug 25 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.19-2
680- add patch100 for fix CVE-2011-3192 (Range Header DoS)
681
682* Mon May 23 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.19-1
683- update to 2.2.19
684
685* Sat Apr 30 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.14-9
686- remove old Obsoletes/Conflicts
687
688* Tue Jan 11 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.14-8
689- rebuild with openssl-1.0.0c
690
691* Sat Aug 21 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.14-7
692- add  patch120 for fix CVE-2010-1452 (mod_dav/mod_cache) from mdk2010
693
694* Wed Aug 18 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.14-6
695- add R(post): alternatives
696
697* Sat Mar 20 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 2.2.14-5
698- add patch110 for fix CVE-2010-0434 from mdk 2010
699
700* Sun Mar  7 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 2.2.14-4
701- add patch100 for fix CVE-2010-0408 (mod_proxy_ajp)
702
703* Fri Feb  5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.2.14-3
704- rebuilt with rpm-4.8.0-3 (on ppc)
705
706* Tue Feb 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.14-2
707- rebuild with db4-4.8.0
708
709* Tue Jan 05 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.14-1
710- new upstream release with security fix
711  (CVE-2009-2699, CVE-2009-3095, CVE-2009-3094)
712- fix ssl.conf (2.2.13-1 includes wrong file)
713
714* Sun Aug 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.13-1
715- new upstream release
716
717* Wed Jul 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.12-1
718- new upstream release
719  (including security fix for CVE-2009-1890, CVE-2009-1191,
720   CVE-2009-1195, CVE-2009-1955, CVE-2009-1956, CVE-2009-0023)
721
722* Fri Jan 09 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.11-2
723- rebuilt with openldap-2.4.11
724
725* Fri Jan  2 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.11-1
726- new upstream release
727
728* Sat Oct 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.10-1
729- new upstream release (including security fix for CVE-2008-2939)
730
731* Fri Jun 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.9-1
732- new upstream release (including security fix for CVE-2008-2364, CVE-2007-6420)
733- built with db4-4.6.21, apr 1.3.0
734
735* Sun Apr 27 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 2.2.8-1
736- add Patch60 (to fix bug#31418).
737
738* Thu Feb 21 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.8-0vl2
739- rebuild with expat-2.0.1
740
741* Tue Jan 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.8-0vl1
742- new upstream release
743
744* Sat Nov  3 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.6-0vl2
745- added postun script from VinePlus/4.0 package
746  * Tue Sep 11 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.3-0vl3.2
747  - add postun script to restart daemon with message
748
749* Sun Jul 01 2007 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.3-0vl8
750- updated Patch2: httpd-2.2.3-apxs.patch
751
752* Sun Jun 24 2007 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.3-0vl7
753- modified libdir in config.layout for lib64 architecture
754
755* Sun May 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.3-0vl6
756- rebuilt with openssl-0.9.8e
757
758* Thu May 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.2.3-0vl5
759- rebuilt with new toolchain and db4-4.3.x
760
761* Wed Feb  7 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.3-0vl4
762- added BuildRequires: pcre-devel, sqlite3-devel <BTS:VineLinux:474>
763
764* Mon Sep 11 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.2.3-0vl3
765- change manual Group to Applications/Documentation. <BTS:VineLinux:163>
766
767* Sun Aug 27 2006 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.3-0vl2
768- rebuilt with openldap-2.3.27-0vl1
769
770* Sat Jul 29 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.3-0vl1
771- new upstream release including security fix (CVE-2006-3747)
772
773* Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
774- new upstream release
775  - update to 2.2.2
776- remove apr/apr-devel subpackage,
777  use external apr/apr-util instead of internal one.
778
779* Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.58-0vl1
780- new upstream release
781- use apache2.prefork as default.
782
783* Thu Mar 23 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.55-0vl3
784- rebuild to use new _localstatedir (rpm-4.4.2-0vl11)
785- remove unpackaged files in %%install section
786
787* Fri Jan 27 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.55-0vl2
788- fix logrotate configuration (use apache2.pid instead of httpd.pid)
789  (BTS:10)
790- use Epoch instead of Serial
791
792* Sat Oct 15 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.55-0vl1
793- new upstream release
794- drop obsolete security patches which is merged in upstream
795
796* Sat Oct 08 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.54-0vl1
797- new upstream release
798
799* Sun Sep 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.53-0vl2
800- added Patch122 to 125 for secutiry fix
801  (CAN-2004-{1268,2088,2700,2728})
802- fix %install section
803
804* Sun Apr 10 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.53-0vl1
805- new upstream release
806
807* Sat Nov 06 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.52-0vl1
808- new upstream release
809
810* Sun Oct 24 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.50-0vl4
811- rebuilt with db4-4.2.52
812
813* Sat Sep  4 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 2.0.50-0vl3
814- separate apr, apr-devel packages
815- add BuildPreReq: zlib-devel
816
817* Sun Jul 11 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.50-0vl2
818- fix %%files to include instdso.sh
819  thanks to jax <jax AT morejams DOT no-ip DOT com>
820- add %%{?_smp_mflags} to make option.
821
822* Sun Jul  4 2004 IWAI, Masaharu <iwai@alib.jp> 2.0.50-0vl1
823- new upstream version
824
825* Sun Nov 23 2003 IWAI, Masaharu <iwai@alib.jp> 2.0.48-0vl1
826- new upstream version
827
828* Mon Sep 15 2003 IWAI, Masaharu <iwai@alib.jp> 2.0.47-0vl1
829- new upstream version
830- update apxs patch (Patch101)
831- fix dependency:
832    - change file name to package name in Requires and {Build,}Prereq
833- add BuildPrereq: openldap-devel
834- update %%files section
835- rename httpd.8 manpage
836
837* Mon May 12 2003 Satoshi MACHINO <machino@vinelinux.org> 2.0.45-0vl1
838- new upstream version
839- used vine-config.layout in srclib
840
841* Mon May 12 2003 Satoshi MACHINO <machino@vinelinux.org> 2.0.44-0vl9
842- rebuild
843
844* Sun Apr  6 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl8
845- change pkg name from mod_ssl to mod_ssl-apache2
846- remove "apache-manual" entry from Obsoletes:
847
848* Thu Apr  3 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl7
849- remove "mod_dav" and "apache-devel" from Obsoletes:
850- enable MPMS(worker %mpms )
851
852* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl6
853- add correct config_vars.mk
854
855* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl5
856- apply apxs's patch ( from Debian)
857
858* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl4
859- add apr-config,apu-config to devel's %file
860
861* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl3
862- change apxs path ( /usr/sbin -> /usr/bin
863- add symlink under /etc/apache2/conf
864  (logs, run), httpd.conf -> apache2.conf
865- fixed apache2 initscript.
866
867* Sat Mar 29 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl2
868- build Vine Linux
869- new upstream version
870- sharing with apache1
871
872* Wed Sep  4 2002 Nalin Dahyabhai <nalin@redhat.com> 2.0.40-8
873- link httpd with libssl to avoid library loading/unloading weirdness
874
875* Tue Sep  3 2002 Joe Orton <jorton@redhat.com> 2.0.40-7
876- add LoadModule lines for proxy modules in httpd.conf (#73349)
877- fix permissions of conf/ssl.*/ directories; add Makefiles for
878  certificate management (#73352)
879
880* Mon Sep  2 2002 Joe Orton <jorton@redhat.com> 2.0.40-6
881- provide "httpd-mmn" to manage module ABI compatibility
882
883* Sun Sep  1 2002 Joe Orton <jorton@redhat.com> 2.0.40-5
884- fix SSL session cache (#69699)
885- revert addition of LDAP support to apr-util
886
887* Mon Aug 26 2002 Joe Orton <jorton@redhat.com> 2.0.40-4
888- set SIGXFSZ disposition to "ignored" (#69520)
889- make dummy connections to the first listener in config (#72692)
890
891* Mon Aug 26 2002 Joe Orton <jorton@redhat.com> 2.0.40-3
892- allow "apachectl configtest" on a 1.3 httpd.conf
893- add mod_deflate
894- enable LDAP support in apr-util
895- don't package everything in /var/www/error as config(noreplace)
896
897* Wed Aug 21 2002 Bill Nottingham <notting@redhat.com> 2.0.40-2
898- add trigger (#68657)
899
900* Mon Aug 12 2002 Joe Orton <jorton@redhat.com> 2.0.40-1
901- update to 2.0.40
902
903* Wed Jul 24 2002 Joe Orton <jorton@redhat.com> 2.0.36-8
904- improve comment on use of UserDir in default config (#66886)
905
906* Wed Jul 10 2002 Joe Orton <jorton@redhat.com> 2.0.36-7
907- use /sbin/nologin as shell for apache user (#68371)
908- add patch from CVS to fix possible infinite loop when processing
909  internal redirects
910
911* Wed Jun 26 2002 Gary Benson <gbenson@redhat.com> 2.0.36-6
912- modify init script to detect 1.3.x httpd.conf's and direct users
913  to the migration guide
914
915* Tue Jun 25 2002 Gary Benson <gbenson@redhat.com> 2.0.36-5
916- patch apachectl to detect 1.3.x httpd.conf's and direct users
917  to the migration guide
918- ship the migration guide
919
920* Fri Jun 21 2002 Joe Orton <jorton@redhat.com>
921- move /etc/httpd2 back to /etc/httpd
922- add noindex.html page and poweredby logo; tweak default config
923  to load noindex.html if no default "/" page is present.
924- add patch to prevent mutex errors on graceful restart
925
926* Fri Jun 21 2002 Tim Powers <timp@redhat.com> 2.0.36-4
927- automated rebuild
928
929* Wed Jun 12 2002 Joe Orton <jorton@redhat.com> 2.0.36-3
930- add patch to fix SSL mutex handling
931
932* Wed Jun 12 2002 Joe Orton <jorton@redhat.com> 2.0.36-2
933- improved config directory patch
934
935* Mon May 20 2002 Joe Orton <jorton@redhat.com>
936- initial build; based heavily on apache.spec and mod_ssl.spec
937- fixes: #65214, #58490, #57376, #61265, #65518, #58177, #57245
938
Note: See TracBrowser for help on using the repository browser.