source: projects/specs/trunk/a/apache2/apache2-vl.spec @ 11281

Revision 11281, 29.2 KB checked in by tomop, 6 years ago (diff)

apache2-2.4.29-1

Line 
1%define contentdir %{_datadir}/apache2
2%define docroot /var/www/apache2
3%define suexec_caller www-data
4%define mmn 20120211
5%define mmnisa %{mmn}%{__isa_name}%{__isa_bits}
6%define pkgname apache2
7%define vstring Vine
8
9Summary: Apache HTTP Server
10Name: %{pkgname}
11Version: 2.4.29
12Release: 1%{_dist_release}
13URL: http://httpd.apache.org/
14
15Vendor: Project Vine
16Distribution: Vine Linux
17Packager: daisuke
18
19Source0: http://www.apache.org/dist/httpd/httpd-%{version}.tar.bz2
20Source2: index.html
21Source3: apache2.logrotate
22Source4: apache2.init
23Source6: poweredby-vine.png
24Source7: apache2.tmpfiles
25Source10: httpd.conf
26Source11: 00-base.conf
27Source12: 00-mpm.conf
28Source13: 00-lua.conf
29Source14: 01-cgi.conf
30Source15: 00-dav.conf
31Source16: 00-proxy.conf
32Source17: 00-ssl.conf
33Source18: 01-ldap.conf
34Source19: 00-proxyhtml.conf
35Source20: userdir.conf
36Source21: ssl.conf
37Source22: welcome.conf
38Source23: manual.conf
39Source25: 01-session.conf
40Source28: 00-optional.conf
41# Documentation
42Source30: README.confd
43Source31: README.confmod
44# add vine entry to config.layout
45Source100: vine-config.layout
46
47# build/scripts patches
48Patch1: httpd-2.4.1-apctl.patch
49Patch2: httpd-2.4.9-apxs.patch
50Patch3: httpd-2.4.1-deplibs.patch
51Patch5: httpd-2.4.3-layout.patch
52#Patch6: httpd-2.4.3-apctl-systemd.patch
53# Needed for socket activation and mod_systemd patch
54#Patch19: httpd-2.4.25-detect-systemd.patch
55# Features/functional changes
56Patch23: httpd-2.4.4-export.patch
57Patch24: httpd-2.4.1-corelimit.patch
58#Patch25: httpd-2.4.25-selinux.patch
59Patch26: httpd-2.4.4-r1337344+.patch
60Patch27: httpd-2.4.2-icons.patch
61Patch29: httpd-2.4.27-systemd.patch
62Patch30: httpd-2.4.4-cachehardmax.patch
63Patch31: httpd-2.4.18-sslmultiproxy.patch
64Patch34: httpd-2.4.17-socket-activation.patch
65Patch35: httpd-2.4.17-sslciphdefault.patch
66
67# Bug fixes
68# https://bugzilla.redhat.com/show_bug.cgi?id=1397243
69Patch58: httpd-2.4.25-r1738878.patch
70
71# Security fixes
72
73
74License: Apache Software License
75Group: System Environment/Daemons
76BuildRoot: %{_tmppath}/%{name}-%{version}-root
77BuildRequires: db4-devel, expat-devel, xmlto
78BuildRequires: findutils, perl, openldap-devel, zlib-devel
79BuildRequires: apr-devel, apr-util-devel
80BuildRequires: pcre-devel, sqlite3-devel
81BuildRequires: lua-devel, libxml2-devel
82BuildRequires: libnghttp2-devel
83BuildRequires: www-common
84Requires: mailcap, gawk, file, findutils, apr, apr-util
85Requires(pre): www-common
86Requires(pre): chkconfig, mktemp, fileutils
87Requires(pre): sh-utils, textutils, shadow-utils
88Requires(post): alternatives
89Provides: webserver
90Provides: httpd = %{version}
91Provides: httpd-mmn = %{mmn}
92Provides: apache2-mmn = %{mmn}
93Obsoletes: apache2-apr, apache2-apr-devel
94Obsoletes: apache < 2.0, apache-devel < 2.0
95
96%description
97Apache is a powerful, full-featured, efficient, and freely-available
98Web server. Apache is also the most popular Web server on the
99Internet.
100
101%package devel
102Group: Development/Libraries
103Summary: Development tools for the Apache HTTP server.
104Requires: libtool, apache2 = %{version}
105Requires: apr-devel, apr-util-devel
106
107%description devel
108The httpd-devel package contains the APXS binary and other files
109that you need to build Dynamic Shared Objects (DSOs) for Apache.
110
111If you are installing the Apache HTTP server and you want to be
112able to compile or develop additional modules for Apache, you need
113to install this package.
114
115%package manual
116Group: Applications/Documentation
117Summary: Documentation for the Apache HTTP server.
118
119%description manual
120The httpd-manual package contains the complete manual and
121reference guide for the Apache HTTP server. The information can
122also be found at http://httpd.apache.org/docs/.
123
124%package -n mod_ssl-apache2
125Group: System Environment/Daemons
126Summary: SSL/TLS module for the Apache HTTP server
127Epoch: 1
128BuildRequires: openssl-devel
129Requires(pre): net-tools, openssl, dev, /bin/cat
130Requires: apache2, make, apache2-mmn = %{mmn}
131
132%description -n mod_ssl-apache2
133The mod_ssl module provides strong cryptography for the Apache Web
134server via the Secure Sockets Layer (SSL) and Transport Layer
135Security (TLS) protocols.
136
137%prep
138%setup -q -n httpd-%{version}
139
140%patch1 -p1 -b .apctl
141%patch2 -p1 -b .apxs
142%patch3 -p1 -b .deplibs
143%patch5 -p1 -b .layout
144#%patch6 -p1 -b .apctlsystemd
145
146#%patch19 -p1 -b .detectsystemd
147
148%patch23 -p1 -b .export
149%patch24 -p1 -b .corelimit
150#%patch25 -p1 -b .selinux
151%patch26 -p1 -b .r1337344+
152%patch27 -p1 -b .icons
153%patch29 -p1 -b .systemd
154%patch30 -p1 -b .cachehardmax
155%patch31 -p1 -b .sslmultiproxy
156%patch34 -p1 -b .socketactivation
157%patch35 -p1 -b .sslciphdefault
158
159%patch58 -p1 -b .r1738878
160
161perl -pi -e 's|/httpd/build|/apache2/build|' support/apxs.in
162
163# Patch in the vendor string
164sed -i '/^#define PLATFORM/s/Unix/%{vstring}/' os/unix/os.h
165
166# Prevent use of setcap in "install-suexec-caps" target.
167sed -i '/suexec/s,setcap ,echo Skipping setcap for ,' Makefile.in
168
169# add Vine configure's option to config.layout
170sed -e "s|${prefix}/lib|${prefix}/%{_lib}|" \
171  < $RPM_SOURCE_DIR/vine-config.layout >> config.layout
172
173%build
174# remove bundled apr, apr-util, pcre
175rm -rf srclib/{apr,apr-util,pcre}
176
177# regenerate configure scripts
178autoheader && autoconf || exit 1
179
180CFLAGS="$RPM_OPT_FLAGS"
181SH_LDFLAGS="-Wl,-z,relro"
182export CFLAGS SH_LDFLAGS
183
184AP_CONFOPTS="\
185        --prefix=%{_sysconfdir}/apache2 \
186        --exec-prefix=%{_prefix} \
187        --bindir=%{_bindir} \
188        --sbindir=%{_sbindir} \
189        --mandir=%{_mandir} \
190        --libdir=%{_libdir} \
191        --sysconfdir=%{_sysconfdir}/apache2/conf \
192        --includedir=%{_includedir}/apache2 \
193        --libexecdir=%{_libdir}/apache2/modules \
194        --datadir=%{contentdir} \
195        --with-installbuilddir=%{_libdir}/apache2/build \
196        --enable-layout=Vine \
197        --with-program-name=apache2 \
198        --with-ldap \
199        --enable-ldap --enable-authnz-ldap \
200        --enable-mods-shared=all \
201        --enable-cache=shared \
202        --enable-cgi=shared \
203        --enable-cgid=shared \
204        --enable-rewrite=shared \
205        --enable-disk-cache=shared \
206        --enable-file-cache=shared \
207        --enable-mem-cache=shared \
208        --enable-authn-anon --enable-authn-alias \
209        --with-apr=%{_prefix} --with-apr-util=%{_prefix} \
210        --enable-suexec --with-suexec \
211        --enable-suexec-capabilities \
212        --with-suexec-caller=%{suexec_caller} \
213        --with-suexec-docroot=%{docroot} \
214        --with-suexec-logfile=%{_localstatedir}/log/apache2/suexec.log \
215        --with-suexec-bin=%{_sbindir}/suexec \
216        --with-suexec-uidmin=500 --with-suexec-gidmin=500 \
217        --with-pcre \
218        --enable-pie \
219        --enable-ssl --with-ssl \
220        --enable-deflate \
221        --enable-proxy --enable-proxy-connect \
222        --enable-proxy-http --enable-proxy-ftp \
223        --enable-case-filter --enable-case-filter-in \
224        --enable-http2 \
225        --enable-mpms-shared=all"
226./configure ${AP_CONFOPTS}
227make %{?_smp_mflags}
228
229%install
230rm -rf $RPM_BUILD_ROOT
231
232make DESTDIR=$RPM_BUILD_ROOT install
233
234# create apache2ctl symlink
235ln -sf apachectl $RPM_BUILD_ROOT%{_sbindir}/apache2ctl
236
237# install conf file/directory
238mkdir $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf.d \
239      $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf.modules.d \
240      $RPM_BUILD_ROOT%{_sysconfdir}/apache2/sites.d
241install -m 644 $RPM_SOURCE_DIR/README.confd \
242   $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf.d/README
243install -m 644 $RPM_SOURCE_DIR/README.confmod \
244   $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf.modules.d/README
245
246for f in 00-base.conf 00-mpm.conf 00-lua.conf 01-cgi.conf 00-dav.conf \
247         00-proxy.conf 00-ssl.conf 01-ldap.conf 00-proxyhtml.conf \
248         01-ldap.conf 01-session.conf 00-optional.conf; do
249  install -m 644 -p $RPM_SOURCE_DIR/$f \
250                    $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf.modules.d/$f
251done
252
253for f in welcome.conf ssl.conf manual.conf userdir.conf; do
254  install -m 644 -p $RPM_SOURCE_DIR/$f \
255     $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf.d/$f
256done
257
258# Split-out extra config shipped as default in conf.d:
259for f in autoindex; do
260  mv docs/conf/extra/httpd-${f}.conf \
261     $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf.d/${f}.conf
262done
263         
264# Extra config trimmed:
265rm -v docs/conf/extra/httpd-{ssl,userdir}.conf
266
267rm $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/*.conf
268install -m 644 -p $RPM_SOURCE_DIR/httpd.conf \
269   $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/httpd.conf
270ln -sf httpd.conf $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/apache2.conf
271
272# tmpfiles.d configuration
273mkdir -p $RPM_BUILD_ROOT%{_prefix}/lib/tmpfiles.d
274install -m 644 -p $RPM_SOURCE_DIR/apache2.tmpfiles \
275   $RPM_BUILD_ROOT%{_prefix}/lib/tmpfiles.d/apache2.conf
276
277# Other directories
278mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/lib/dav \
279         $RPM_BUILD_ROOT/run/apache2/htcacheclean
280
281# Create cache directory
282mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/cache/apache2 \
283         $RPM_BUILD_ROOT%{_localstatedir}/cache/apache2/proxy \
284         $RPM_BUILD_ROOT%{_localstatedir}/cache/apache2/ssl
285
286# Make the MMN accessible to module packages
287echo %{mmnisa} > $RPM_BUILD_ROOT%{_includedir}/apache2/.mmn
288mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/rpm
289cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.apache2 <<EOF
290%%_httpd_mmn %{mmnisa}
291%%_httpd_apxs %%{_bindir}/apxs
292%%_httpd_modconfdir %%{_sysconfdir}/apache2/conf.modules.d
293%%_httpd_confdir %%{_sysconfdir}/apache2/conf.d
294%%_httpd_contentdir %{contentdir}
295%%_httpd_moddir %%{_libdir}/apache2/modules
296%%_apache2_mmn %{mmnisa}
297%%_apache2_apxs %%{_bindir}/apxs
298%%_apache2_modconfdir %%{_sysconfdir}/apache2/conf.modules.d
299%%_apache2_confdir %%{_sysconfdir}/apache2/conf.d
300%%_apache2_contentdir %{contentdir}
301%%_apache2_moddir %%{_libdir}/apache2/modules
302EOF
303
304# Handle contentdir
305mkdir $RPM_BUILD_ROOT%{contentdir}/noindex
306install -m 644 -p $RPM_SOURCE_DIR/index.html \
307        $RPM_BUILD_ROOT%{contentdir}/noindex/index.html
308install -m 644 -p $RPM_SOURCE_DIR/poweredby-vine.png \
309        $RPM_BUILD_ROOT%{contentdir}/icons/
310rm -rf %{contentdir}/htdocs
311
312# remove manual sources
313find $RPM_BUILD_ROOT%{contentdir}/manual \( \
314    -name \*.xml -o -name \*.xml.* -o -name \*.ent -o -name \*.xsl -o -name \*.dtd \
315    \) -print0 | xargs -0 rm -f
316
317# Strip the manual down just to English and replace the typemaps with flat files:
318set +x
319for f in `find $RPM_BUILD_ROOT%{contentdir}/manual -name \*.html -type f`; do
320   if test -f ${f}.en; then
321      cp ${f}.en ${f}
322      rm ${f}.*
323   fi
324done
325set -x
326
327# Clean Document Root
328rm -v $RPM_BUILD_ROOT%{docroot}/html/*.html
329rm -v $RPM_BUILD_ROOT/var/www/cgi-bin/*
330
331# symlinks for /etc/apache2
332ln -s ../..%{_localstatedir}/log/apache2 $RPM_BUILD_ROOT/etc/apache2/logs
333ln -s /run/apache2 $RPM_BUILD_ROOT/etc/apache2/run
334ln -s ../..%{_libdir}/apache2/modules $RPM_BUILD_ROOT/etc/apache2/modules
335
336# install SYSV init stuff
337mkdir -p $RPM_BUILD_ROOT/etc/rc.d/init.d
338install -m755 $RPM_SOURCE_DIR/apache2.init \
339        $RPM_BUILD_ROOT/etc/rc.d/init.d/apache2
340%{__perl} -pi -e "s:\@docdir\@:%{_docdir}/%{name}-%{version}:g" \
341        $RPM_BUILD_ROOT/etc/rc.d/init.d/apache2
342
343# Install logrotate config
344mkdir -p $RPM_BUILD_ROOT/etc/logrotate.d
345install -m 644 -p $RPM_SOURCE_DIR/apache2.logrotate \
346        $RPM_BUILD_ROOT/etc/logrotate.d/apache2
347
348# fix man page paths
349sed -e "s|/usr/local/apache2/conf/httpd.conf|/etc/apache2/conf/httpd.conf|" \
350    -e "s|/usr/local/apache2/conf/mime.types|/etc/mime.types|" \
351    -e "s|/usr/local/apache2/conf/magic|/etc/apache2/conf/magic|" \
352    -e "s|/usr/local/apache2/logs/error_log|/var/log/apache2/error_log|" \
353    -e "s|/usr/local/apache2/logs/access_log|/var/log/apache2/access_log|" \
354    -e "s|/usr/local/apache2/logs/httpd.pid|/run/apache2/apache2.pid|" \
355    -e "s|/usr/local/apache2|/etc/httpd|" < docs/man/httpd.8 \
356  > $RPM_BUILD_ROOT%{_mandir}/man8/httpd.8
357
358# Make ap_config_layout.h libdir-agnostic
359sed -i '/.*DEFAULT_..._LIBEXECDIR/d;/DEFAULT_..._INSTALLBUILDDIR/d' \
360    $RPM_BUILD_ROOT%{_includedir}/apache2/ap_config_layout.h
361
362# Fix path to instdso in special.mk
363sed -i '/instdso/s,top_srcdir,top_builddir,' \
364    $RPM_BUILD_ROOT%{_libdir}/apache2/build/special.mk
365
366# Remove unpackaged files
367rm -vf \
368      $RPM_BUILD_ROOT%{_libdir}/*.exp \
369      $RPM_BUILD_ROOT/etc/apache2/conf/mime.types \
370      $RPM_BUILD_ROOT%{_libdir}/apache2/modules/*.exp \
371      $RPM_BUILD_ROOT%{_libdir}/apache2/build/config.nice \
372      $RPM_BUILD_ROOT%{_bindir}/{ap?-config,dbmmanage} \
373      $RPM_BUILD_ROOT%{_sbindir}/{checkgid,envvars*} \
374      $RPM_BUILD_ROOT%{contentdir}/htdocs/* \
375      $RPM_BUILD_ROOT%{_mandir}/man1/dbmmanage.* \
376      $RPM_BUILD_ROOT%{contentdir}/cgi-bin/*
377
378rm -rf $RPM_BUILD_ROOT/etc/apache2/conf/{original,extra}
379
380
381
382%triggerpostun -- apache < 2.0
383/sbin/chkconfig --add apache2
384
385
386%post
387/sbin/chkconfig --add apache2
388
389%preun
390if [ $1 = 0 ]; then
391        /sbin/service apache2 stop > /dev/null 2>&1
392        /sbin/chkconfig --del apache2
393fi
394
395%postun
396if [ "$1" -ge 1 ]; then
397        /sbin/service apache2 condrestart
398fi
399/sbin/ldconfig
400
401%define sslcert %{_sysconfdir}/pki/tls/certs/localhost.crt
402%define sslkey %{_sysconfdir}/pki/tls/private/localhost.key
403
404%post -n mod_ssl-apache2
405umask 077
406
407if [ -f %{sslkey} -o -f %{sslcert} ]; then
408  exit 0
409fi
410
411%{_bindir}/openssl genrsa \
412  -rand /proc/apm:/proc/cpuinfo:/proc/dma:/proc/filesystems:/proc/interrupts:/proc/ioports:/proc/pci:/proc/rtc:/proc/uptime \
413  2048 > %{sslkey} 2> /dev/null ||:
414
415FQDN=`hostname` ||:
416if [ "x${FQDN}" = "x" ]; then
417   FQDN=localhost.localdomain
418fi
419   
420cat << EOF | %{_bindir}/openssl req -new -key %{sslkey} \
421         -x509 -sha256 -days 3650 -set_serial $RANDOM -extensions v3_req \
422         -out %{sslcert} 2>/dev/null ||:
423--
424SomeState
425SomeCity
426SomeOrganization
427SomeOrganizationalUnit
428${FQDN}
429root@${FQDN}
430EOF
431
432%clean
433rm -rf $RPM_BUILD_ROOT
434
435%files
436%defattr(-,root,root)
437%license LICENSE
438%doc ABOUT_APACHE README CHANGES LAYOUT
439%doc docs/conf/extra/*.conf
440
441%dir %{_sysconfdir}/apache2
442%{_sysconfdir}/apache2/modules
443%{_sysconfdir}/apache2/logs
444%{_sysconfdir}/apache2/run
445%dir %{_sysconfdir}/apache2/conf
446%config(noreplace) %{_sysconfdir}/apache2/conf/httpd.conf
447%config(noreplace) %{_sysconfdir}/apache2/conf/apache2.conf
448%config(noreplace) %{_sysconfdir}/apache2/conf/magic
449
450%config(noreplace) %{_sysconfdir}/logrotate.d/apache2
451
452%config %{_sysconfdir}/rc.d/init.d/apache2
453
454%dir %{_sysconfdir}/apache2/conf.d
455%{_sysconfdir}/apache2/conf.d/README
456%config(noreplace) %{_sysconfdir}/apache2/conf.d/*.conf
457%exclude %{_sysconfdir}/apache2/conf.d/ssl.conf
458%exclude %{_sysconfdir}/apache2/conf.d/manual.conf
459
460%dir %{_sysconfdir}/apache2/conf.modules.d
461%{_sysconfdir}/apache2/conf.modules.d/README
462%config(noreplace) %{_sysconfdir}/apache2/conf.modules.d/*.conf
463%exclude %{_sysconfdir}/apache2/conf.modules.d/00-ssl.conf
464
465%dir %{_sysconfdir}/apache2/sites.d
466
467%{_prefix}/lib/tmpfiles.d/apache2.conf
468
469%{_bindir}/ab
470%{_bindir}/ht*
471%{_bindir}/logresolve
472%{_sbindir}/ht*
473%{_sbindir}/apache2
474%{_sbindir}/apachectl
475%{_sbindir}/apache2ctl
476%{_sbindir}/rotatelogs
477%{_sbindir}/fcgistarter
478%attr(4510,root,%{suexec_caller}) %{_sbindir}/suexec
479
480%dir %{_libdir}/apache2
481%dir %{_libdir}/apache2/modules
482%{_libdir}/apache2/modules/mod_*.so
483%exclude %{_libdir}/apache2/modules/mod_ssl.so
484
485%dir %{contentdir}
486%dir %{contentdir}/icons
487%dir %{contentdir}/error
488%dir %{contentdir}/error/include
489%dir %{contentdir}/noindex
490%{contentdir}/icons/*
491%{contentdir}/error/README
492%{contentdir}/error/*.var
493%{contentdir}/error/include/*.html
494%{contentdir}/noindex/index.html
495
496%dir %{docroot}/html
497%dir /var/www/cgi-bin
498
499%attr(0710,root,www-data) %dir /run/apache2
500%attr(0700,www-data,www-data) %dir /run/apache2/htcacheclean
501
502%attr(0700,root,root) %dir %{_localstatedir}/log/apache2
503%attr(0700,www-data,www-data) %dir %{_localstatedir}/lib/dav
504%attr(0700,www-data,www-data) %dir %{_localstatedir}/cache/apache2
505%attr(0700,www-data,www-data) %dir %{_localstatedir}/cache/apache2/proxy
506
507%{_mandir}/man1/*
508%exclude %{_mandir}/man1/apxs*
509
510%{_mandir}/man8/*
511
512
513%files manual
514%defattr(-,root,root)
515%{contentdir}/manual
516%config(noreplace) %{_sysconfdir}/apache2/conf.d/manual.conf
517
518
519%files -n mod_ssl-apache2
520%defattr(-,root,root)
521%{_libdir}/apache2/modules/mod_ssl.so
522%config(noreplace) %{_sysconfdir}/apache2/conf.modules.d/00-ssl.conf
523%config(noreplace) %{_sysconfdir}/apache2/conf.d/ssl.conf
524%attr(0700,www-data,www-data) %dir %{_localstatedir}/cache/apache2/ssl
525
526
527%files devel
528%defattr(-,root,root)
529%{_includedir}/apache2
530%{_bindir}/apxs
531%{_mandir}/man1/apxs*
532%dir %{_libdir}/apache2/build
533%{_libdir}/apache2/build/*.mk
534%{_libdir}/apache2/build/*.sh
535%{_sysconfdir}/rpm/macros.apache2
536
537
538%changelog
539* Mon Dec 18 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.29-1
540- new upstream release.
541- fixed apxs.
542- dropped Patch56,60 and 61: fixed in upstream.
543
544* Sun Oct 15 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.28-1
545- new upstream release.
546
547* Fri Mar 17 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.25-1
548- new upstream release.
549- dropped Patch55: fixed in upstream.
550
551* Fri Jul  8 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.23-1
552- new upstream release.
553
554* Tue Jun  7 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.20-2
555- enabled HTTP/2.
556
557* Sun May 29 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.20-1
558- updated to 2.4.20.
559- updated Patch58.
560- fixed %%files.
561- fixed location of suexec (BTS#3007).
562
563* Thu Mar 10 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.18-2
564- rebuilt with openssl 1.0.2g
565
566* Thu Feb  4 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.18-1
567- updated to 2.4.18.
568- fixed 00-base.conf.
569- updated Patch31.
570
571* Mon Dec  7 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.17-2
572- fixed configuration files.
573
574* Fri Dec  4 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.17-1
575- update to 2.4.17.
576- fixed dependency.
577
578* Wed Jun 25 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 2.4.9-2
579- modify dependency
580
581* Wed Jun 25 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 2.4.9-1
582- update to 2.4.9
583- remove suffix '2' from {htdigest,htpasswd,rotatelogs}2
584- use /run instead of /var/run
585- remove /etc/apache2/conf/ssl* , use /etc/pki now.
586- move suexec from %%{_libdir}/apache2 to %%{_sbindir}
587- split all LoadModules to conf.modules.d/*.conf
588- split module configs to conf.d/*.conf
589- cleanup docroot, move apache specific files to %%{_datadir}/apache2
590- add BR: lua-devel, libxml2-devel
591- add /etc/apache2/sites.d for virtual host settings.
592
593* Wed Dec 25 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.25-2
594- merge VineSeed spec file
595  * Wed Oct 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.23-2
596  - rebuild with pcre-8.31
597
598  * Wed Mar 21 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.23-1
599  - update to 2.2.23
600  - add R(pre): www-common, BR: www-common
601  - move apache contents to %{contentdir}
602
603* Sat Sep 28 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.25-1
604- new upstream release with security fix (CVE-2013-1862,1896)
605- drop patch100 (is included in new release)
606
607* Fri May 17 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.24-2
608- add patch100 for fix CVE-2013-1862 (mod_rewrite)
609
610* Wed Feb 27 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.24-1
611- new upstream release with security fix (CVE-2012-3499, 4558)
612
613* Sun Sep 16 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.23-1
614- new upstream release with security fix (CVE-2012-3502,CVE-2012-2687)
615- update patch22 to fit new release
616- update man filename convert list
617
618* Wed Mar 21 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.22-1
619- update to 2.2.22
620  - CVE-2012-0021 (mod_log_config)
621  - CVE-2012-0031
622  - CVE-2012-0053
623- remove upstreamed patches
624
625* Fri Dec  9 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.21-5
626- add patch120 for fix CVE-2011-4317 (mod_rewrite/mod_proxy)
627
628* Fri Nov 18 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.21-4
629- add patch110 for fix CVE-2011-3607-4415 (ModSetEnvIf)
630
631* Wed Oct 12 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.21-3
632- add patch70 for fix byterange filter
633
634* Tue Oct 11 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.21-2
635- add Patch100 for fix CVE-2011-3368 (mod_proxy)
636
637* Wed Sep 14 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.21-1
638- new upstream release with security fix (CVE-2011-3348)
639- regression fixes of CVE-2011-3192 byterange fix in 2.2.20
640
641* Tue Sep  6 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.20-3
642- update Patch101 (Thanks to debian team)
643
644* Sat Sep  3 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.20-2
645- add Patch101 for fix CVE-2011-3192 regression
646
647* Thu Sep  1 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.20-1
648- new upstream release with security fix (CVE-2011-3192)
649- drop patch100 (is included in new release)
650
651* Thu Aug 25 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.19-2
652- add patch100 for fix CVE-2011-3192 (Range Header DoS)
653
654* Mon May 23 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.19-1
655- update to 2.2.19
656
657* Sat Apr 30 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.14-9
658- remove old Obsoletes/Conflicts
659
660* Tue Jan 11 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.14-8
661- rebuild with openssl-1.0.0c
662
663* Sat Aug 21 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.14-7
664- add  patch120 for fix CVE-2010-1452 (mod_dav/mod_cache) from mdk2010
665
666* Wed Aug 18 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.14-6
667- add R(post): alternatives
668
669* Sat Mar 20 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 2.2.14-5
670- add patch110 for fix CVE-2010-0434 from mdk 2010
671
672* Sun Mar  7 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 2.2.14-4
673- add patch100 for fix CVE-2010-0408 (mod_proxy_ajp)
674
675* Fri Feb  5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.2.14-3
676- rebuilt with rpm-4.8.0-3 (on ppc)
677
678* Tue Feb 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.14-2
679- rebuild with db4-4.8.0
680
681* Tue Jan 05 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.14-1
682- new upstream release with security fix
683  (CVE-2009-2699, CVE-2009-3095, CVE-2009-3094)
684- fix ssl.conf (2.2.13-1 includes wrong file)
685
686* Sun Aug 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.13-1
687- new upstream release
688
689* Wed Jul 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.12-1
690- new upstream release
691  (including security fix for CVE-2009-1890, CVE-2009-1191,
692   CVE-2009-1195, CVE-2009-1955, CVE-2009-1956, CVE-2009-0023)
693
694* Fri Jan 09 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.11-2
695- rebuilt with openldap-2.4.11
696
697* Fri Jan  2 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.11-1
698- new upstream release
699
700* Sat Oct 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.10-1
701- new upstream release (including security fix for CVE-2008-2939)
702
703* Fri Jun 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.9-1
704- new upstream release (including security fix for CVE-2008-2364, CVE-2007-6420)
705- built with db4-4.6.21, apr 1.3.0
706
707* Sun Apr 27 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 2.2.8-1
708- add Patch60 (to fix bug#31418).
709
710* Thu Feb 21 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.8-0vl2
711- rebuild with expat-2.0.1
712
713* Tue Jan 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.8-0vl1
714- new upstream release
715
716* Sat Nov  3 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.6-0vl2
717- added postun script from VinePlus/4.0 package
718  * Tue Sep 11 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.3-0vl3.2
719  - add postun script to restart daemon with message
720
721* Sun Jul 01 2007 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.3-0vl8
722- updated Patch2: httpd-2.2.3-apxs.patch
723
724* Sun Jun 24 2007 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.3-0vl7
725- modified libdir in config.layout for lib64 architecture
726
727* Sun May 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.3-0vl6
728- rebuilt with openssl-0.9.8e
729
730* Thu May 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.2.3-0vl5
731- rebuilt with new toolchain and db4-4.3.x
732
733* Wed Feb  7 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.3-0vl4
734- added BuildRequires: pcre-devel, sqlite3-devel <BTS:VineLinux:474>
735
736* Mon Sep 11 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.2.3-0vl3
737- change manual Group to Applications/Documentation. <BTS:VineLinux:163>
738
739* Sun Aug 27 2006 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.3-0vl2
740- rebuilt with openldap-2.3.27-0vl1
741
742* Sat Jul 29 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.3-0vl1
743- new upstream release including security fix (CVE-2006-3747)
744
745* Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
746- new upstream release
747  - update to 2.2.2
748- remove apr/apr-devel subpackage,
749  use external apr/apr-util instead of internal one.
750
751* Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.58-0vl1
752- new upstream release
753- use apache2.prefork as default.
754
755* Thu Mar 23 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.55-0vl3
756- rebuild to use new _localstatedir (rpm-4.4.2-0vl11)
757- remove unpackaged files in %%install section
758
759* Fri Jan 27 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.55-0vl2
760- fix logrotate configuration (use apache2.pid instead of httpd.pid)
761  (BTS:10)
762- use Epoch instead of Serial
763
764* Sat Oct 15 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.55-0vl1
765- new upstream release
766- drop obsolete security patches which is merged in upstream
767
768* Sat Oct 08 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.54-0vl1
769- new upstream release
770
771* Sun Sep 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.53-0vl2
772- added Patch122 to 125 for secutiry fix
773  (CAN-2004-{1268,2088,2700,2728})
774- fix %install section
775
776* Sun Apr 10 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.53-0vl1
777- new upstream release
778
779* Sat Nov 06 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.52-0vl1
780- new upstream release
781
782* Sun Oct 24 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.50-0vl4
783- rebuilt with db4-4.2.52
784
785* Sat Sep  4 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 2.0.50-0vl3
786- separate apr, apr-devel packages
787- add BuildPreReq: zlib-devel
788
789* Sun Jul 11 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.50-0vl2
790- fix %%files to include instdso.sh
791  thanks to jax <jax AT morejams DOT no-ip DOT com>
792- add %%{?_smp_mflags} to make option.
793
794* Sun Jul  4 2004 IWAI, Masaharu <iwai@alib.jp> 2.0.50-0vl1
795- new upstream version
796
797* Sun Nov 23 2003 IWAI, Masaharu <iwai@alib.jp> 2.0.48-0vl1
798- new upstream version
799
800* Mon Sep 15 2003 IWAI, Masaharu <iwai@alib.jp> 2.0.47-0vl1
801- new upstream version
802- update apxs patch (Patch101)
803- fix dependency:
804    - change file name to package name in Requires and {Build,}Prereq
805- add BuildPrereq: openldap-devel
806- update %%files section
807- rename httpd.8 manpage
808
809* Mon May 12 2003 Satoshi MACHINO <machino@vinelinux.org> 2.0.45-0vl1
810- new upstream version
811- used vine-config.layout in srclib
812
813* Mon May 12 2003 Satoshi MACHINO <machino@vinelinux.org> 2.0.44-0vl9
814- rebuild
815
816* Sun Apr  6 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl8
817- change pkg name from mod_ssl to mod_ssl-apache2
818- remove "apache-manual" entry from Obsoletes:
819
820* Thu Apr  3 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl7
821- remove "mod_dav" and "apache-devel" from Obsoletes:
822- enable MPMS(worker %mpms )
823
824* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl6
825- add correct config_vars.mk
826
827* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl5
828- apply apxs's patch ( from Debian)
829
830* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl4
831- add apr-config,apu-config to devel's %file
832
833* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl3
834- change apxs path ( /usr/sbin -> /usr/bin
835- add symlink under /etc/apache2/conf
836  (logs, run), httpd.conf -> apache2.conf
837- fixed apache2 initscript.
838
839* Sat Mar 29 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl2
840- build Vine Linux
841- new upstream version
842- sharing with apache1
843
844* Wed Sep  4 2002 Nalin Dahyabhai <nalin@redhat.com> 2.0.40-8
845- link httpd with libssl to avoid library loading/unloading weirdness
846
847* Tue Sep  3 2002 Joe Orton <jorton@redhat.com> 2.0.40-7
848- add LoadModule lines for proxy modules in httpd.conf (#73349)
849- fix permissions of conf/ssl.*/ directories; add Makefiles for
850  certificate management (#73352)
851
852* Mon Sep  2 2002 Joe Orton <jorton@redhat.com> 2.0.40-6
853- provide "httpd-mmn" to manage module ABI compatibility
854
855* Sun Sep  1 2002 Joe Orton <jorton@redhat.com> 2.0.40-5
856- fix SSL session cache (#69699)
857- revert addition of LDAP support to apr-util
858
859* Mon Aug 26 2002 Joe Orton <jorton@redhat.com> 2.0.40-4
860- set SIGXFSZ disposition to "ignored" (#69520)
861- make dummy connections to the first listener in config (#72692)
862
863* Mon Aug 26 2002 Joe Orton <jorton@redhat.com> 2.0.40-3
864- allow "apachectl configtest" on a 1.3 httpd.conf
865- add mod_deflate
866- enable LDAP support in apr-util
867- don't package everything in /var/www/error as config(noreplace)
868
869* Wed Aug 21 2002 Bill Nottingham <notting@redhat.com> 2.0.40-2
870- add trigger (#68657)
871
872* Mon Aug 12 2002 Joe Orton <jorton@redhat.com> 2.0.40-1
873- update to 2.0.40
874
875* Wed Jul 24 2002 Joe Orton <jorton@redhat.com> 2.0.36-8
876- improve comment on use of UserDir in default config (#66886)
877
878* Wed Jul 10 2002 Joe Orton <jorton@redhat.com> 2.0.36-7
879- use /sbin/nologin as shell for apache user (#68371)
880- add patch from CVS to fix possible infinite loop when processing
881  internal redirects
882
883* Wed Jun 26 2002 Gary Benson <gbenson@redhat.com> 2.0.36-6
884- modify init script to detect 1.3.x httpd.conf's and direct users
885  to the migration guide
886
887* Tue Jun 25 2002 Gary Benson <gbenson@redhat.com> 2.0.36-5
888- patch apachectl to detect 1.3.x httpd.conf's and direct users
889  to the migration guide
890- ship the migration guide
891
892* Fri Jun 21 2002 Joe Orton <jorton@redhat.com>
893- move /etc/httpd2 back to /etc/httpd
894- add noindex.html page and poweredby logo; tweak default config
895  to load noindex.html if no default "/" page is present.
896- add patch to prevent mutex errors on graceful restart
897
898* Fri Jun 21 2002 Tim Powers <timp@redhat.com> 2.0.36-4
899- automated rebuild
900
901* Wed Jun 12 2002 Joe Orton <jorton@redhat.com> 2.0.36-3
902- add patch to fix SSL mutex handling
903
904* Wed Jun 12 2002 Joe Orton <jorton@redhat.com> 2.0.36-2
905- improved config directory patch
906
907* Mon May 20 2002 Joe Orton <jorton@redhat.com>
908- initial build; based heavily on apache.spec and mod_ssl.spec
909- fixes: #65214, #58490, #57376, #61265, #65518, #58177, #57245
910
Note: See TracBrowser for help on using the repository browser.