source: projects/specs/trunk/a/apache2/apache2-vl.spec @ 10560

Revision 10560, 28.3 KB checked in by tomop, 8 years ago (diff)

apache2-2.4.23-1

Line 
1%define contentdir %{_datadir}/apache2
2%define docroot /var/www/apache2
3%define suexec_caller www-data
4%define mmn 20051115
5%define mmnisa %{mmn}%{__isa_name}%{__isa_bits}
6%define pkgname apache2
7%define vstring Vine
8
9Summary: Apache HTTP Server
10Name: %{pkgname}
11Version: 2.4.23
12Release: 1%{_dist_release}
13URL: http://httpd.apache.org/
14
15Vendor: Project Vine
16Distribution: Vine Linux
17Packager: daisuke
18
19Source0: http://www.apache.org/dist/httpd/httpd-%{version}.tar.bz2
20Source2: index.html
21Source3: apache2.logrotate
22Source4: apache2.init
23Source6: poweredby-vine.png
24Source7: apache2.tmpfiles
25Source10: httpd.conf
26Source11: 00-base.conf
27Source12: 00-mpm.conf
28Source13: 00-lua.conf
29Source14: 01-cgi.conf
30Source15: 00-dav.conf
31Source16: 00-proxy.conf
32Source17: 00-ssl.conf
33Source18: 01-ldap.conf
34Source19: 00-proxyhtml.conf
35Source20: userdir.conf
36Source21: ssl.conf
37Source22: welcome.conf
38Source23: manual.conf
39Source25: 01-session.conf
40# Documentation
41Source30: README.confd
42Source31: README.confmod
43# add vine entry to config.layout
44Source100: vine-config.layout
45
46# build/scripts patches
47Patch1: httpd-2.4.1-apctl.patch
48Patch2: httpd-2.4.1-apxs.patch
49Patch3: httpd-2.4.1-deplibs.patch
50# Features/functional changes
51Patch23: httpd-2.4.4-export.patch
52Patch24: httpd-2.4.1-corelimit.patch
53Patch26: httpd-2.4.4-r1337344+.patch
54Patch27: httpd-2.4.2-icons.patch
55Patch30: httpd-2.4.4-cachehardmax.patch
56Patch31: httpd-2.4.18-sslmultiproxy.patch
57# Bug fixes
58Patch55: httpd-2.4.4-malformed-host.patch
59Patch56: httpd-2.4.4-mod_unique_id.patch
60Patch57: httpd-2.4.10-sigint.patch
61Patch58: httpd-2.4.20-debug-crash.patch
62
63# Security fixes
64
65License: Apache Software License
66Group: System Environment/Daemons
67BuildRoot: %{_tmppath}/%{name}-%{version}-root
68BuildRequires: db4-devel, expat-devel, xmlto
69BuildRequires: findutils, perl, openldap-devel, zlib-devel
70BuildRequires: apr-devel, apr-util-devel
71BuildRequires: pcre-devel, sqlite3-devel
72BuildRequires: lua-devel, libxml2-devel
73BuildRequires: libnghttp2-devel
74BuildRequires: www-common
75Requires: mailcap, gawk, file, findutils, apr, apr-util
76Requires(pre): www-common
77Requires(pre): chkconfig, mktemp, fileutils
78Requires(pre): sh-utils, textutils, shadow-utils
79Requires(post): alternatives
80Provides: webserver
81Provides: httpd = %{version}
82Provides: httpd-mmn = %{mmn}
83Provides: apache2-mmn = %{mmn}
84Obsoletes: apache2-apr, apache2-apr-devel
85Obsoletes: apache < 2.0, apache-devel < 2.0
86
87%description
88Apache is a powerful, full-featured, efficient, and freely-available
89Web server. Apache is also the most popular Web server on the
90Internet.
91
92%package devel
93Group: Development/Libraries
94Summary: Development tools for the Apache HTTP server.
95Requires: libtool, apache2 = %{version}
96Requires: apr-devel, apr-util-devel
97
98%description devel
99The httpd-devel package contains the APXS binary and other files
100that you need to build Dynamic Shared Objects (DSOs) for Apache.
101
102If you are installing the Apache HTTP server and you want to be
103able to compile or develop additional modules for Apache, you need
104to install this package.
105
106%package manual
107Group: Applications/Documentation
108Summary: Documentation for the Apache HTTP server.
109
110%description manual
111The httpd-manual package contains the complete manual and
112reference guide for the Apache HTTP server. The information can
113also be found at http://httpd.apache.org/docs/.
114
115%package -n mod_ssl-apache2
116Group: System Environment/Daemons
117Summary: SSL/TLS module for the Apache HTTP server
118Epoch: 1
119BuildRequires: openssl-devel
120Requires(pre): net-tools, openssl, dev, /bin/cat
121Requires: apache2, make, apache2-mmn = %{mmn}
122
123%description -n mod_ssl-apache2
124The mod_ssl module provides strong cryptography for the Apache Web
125server via the Secure Sockets Layer (SSL) and Transport Layer
126Security (TLS) protocols.
127
128%prep
129%setup -q -n httpd-%{version}
130
131%patch1 -p1 -b .apctl
132%patch2 -p1 -b .apxs
133%patch3 -p1 -b .deplibs
134
135%patch23 -p1 -b .export
136%patch24 -p1 -b .corelimit
137%patch26 -p1 -b .r1337344+
138%patch27 -p1 -b .icons
139%patch30 -p1 -b .cachehardmax
140%patch31 -p1 -b .sslmultiproxy
141
142%patch55 -p1 -b .malformedhost
143%patch56 -p1 -b .uniqueid
144
145%patch57 -p1 -b .sigint
146%patch58 -p1 -b .debug-crash
147
148# Patch in the vendor string
149sed -i '/^#define PLATFORM/s/Unix/%{vstring}/' os/unix/os.h
150
151# Prevent use of setcap in "install-suexec-caps" target.
152sed -i '/suexec/s,setcap ,echo Skipping setcap for ,' Makefile.in
153
154# add Vine configure's option to config.layout
155sed -e "s|${prefix}/lib|${prefix}/%{_lib}|" \
156  < $RPM_SOURCE_DIR/vine-config.layout >> config.layout
157
158%build
159# remove bundled apr, apr-util, pcre
160rm -rf srclib/{apr,apr-util,pcre}
161
162# regenerate configure scripts
163autoheader && autoconf || exit 1
164
165CFLAGS="$RPM_OPT_FLAGS"
166SH_LDFLAGS="-Wl,-z,relro"
167export CFLAGS SH_LDFLAGS
168
169AP_CONFOPTS="\
170        --prefix=%{_sysconfdir}/apache2 \
171        --exec-prefix=%{_prefix} \
172        --bindir=%{_bindir} \
173        --sbindir=%{_sbindir} \
174        --mandir=%{_mandir} \
175        --libdir=%{_libdir} \
176        --sysconfdir=%{_sysconfdir}/apache2/conf \
177        --includedir=%{_includedir}/apache2 \
178        --libexecdir=%{_libdir}/apache2/modules \
179        --datadir=%{contentdir} \
180        --with-installbuilddir=%{_libdir}/apache2/build \
181        --enable-layout=Vine \
182        --with-program-name=apache2 \
183        --with-ldap \
184        --enable-ldap --enable-authnz-ldap \
185        --enable-mods-shared=all \
186        --enable-cache=shared \
187        --enable-cgi=shared \
188        --enable-cgid=shared \
189        --enable-rewrite=shared \
190        --enable-disk-cache=shared \
191        --enable-file-cache=shared \
192        --enable-mem-cache=shared \
193        --enable-authn-anon --enable-authn-alias \
194        --with-apr=%{_prefix} --with-apr-util=%{_prefix} \
195        --enable-suexec --with-suexec \
196        --enable-suexec-capabilities \
197        --with-suexec-caller=%{suexec_caller} \
198        --with-suexec-docroot=%{docroot} \
199        --with-suexec-logfile=%{_localstatedir}/log/apache2/suexec.log \
200        --with-suexec-bin=%{_sbindir}/suexec \
201        --with-suexec-uidmin=500 --with-suexec-gidmin=500 \
202        --with-pcre \
203        --enable-pie \
204        --enable-ssl --with-ssl \
205        --enable-deflate \
206        --enable-proxy --enable-proxy-connect \
207        --enable-proxy-http --enable-proxy-ftp \
208        --enable-case-filter --enable-case-filter-in \
209        --enable-http2 \
210        --enable-mpms-shared=all"
211./configure ${AP_CONFOPTS}
212make %{?_smp_mflags}
213
214%install
215rm -rf $RPM_BUILD_ROOT
216
217make DESTDIR=$RPM_BUILD_ROOT install
218
219# create apache2ctl symlink
220ln -sf apachectl $RPM_BUILD_ROOT%{_sbindir}/apache2ctl
221
222# install conf file/directory
223mkdir $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf.d \
224      $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf.modules.d \
225      $RPM_BUILD_ROOT%{_sysconfdir}/apache2/sites.d
226install -m 644 $RPM_SOURCE_DIR/README.confd \
227   $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf.d/README
228install -m 644 $RPM_SOURCE_DIR/README.confmod \
229   $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf.modules.d/README
230
231for f in 00-base.conf 00-mpm.conf 00-lua.conf 01-cgi.conf 00-dav.conf \
232         00-proxy.conf 00-ssl.conf 01-ldap.conf 00-proxyhtml.conf \
233         01-ldap.conf 01-session.conf; do
234  install -m 644 -p $RPM_SOURCE_DIR/$f \
235                    $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf.modules.d/$f
236done
237
238for f in welcome.conf ssl.conf manual.conf userdir.conf; do
239  install -m 644 -p $RPM_SOURCE_DIR/$f \
240     $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf.d/$f
241done
242
243# Split-out extra config shipped as default in conf.d:
244for f in autoindex; do
245  mv docs/conf/extra/httpd-${f}.conf \
246     $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf.d/${f}.conf
247done
248         
249# Extra config trimmed:
250rm -v docs/conf/extra/httpd-{ssl,userdir}.conf
251
252rm $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/*.conf
253install -m 644 -p $RPM_SOURCE_DIR/httpd.conf \
254   $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/httpd.conf
255ln -sf httpd.conf $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/apache2.conf
256
257# tmpfiles.d configuration
258mkdir -p $RPM_BUILD_ROOT%{_prefix}/lib/tmpfiles.d
259install -m 644 -p $RPM_SOURCE_DIR/apache2.tmpfiles \
260   $RPM_BUILD_ROOT%{_prefix}/lib/tmpfiles.d/apache2.conf
261
262# Other directories
263mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/lib/dav \
264         $RPM_BUILD_ROOT/run/apache2/htcacheclean
265
266# Create cache directory
267mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/cache/apache2 \
268         $RPM_BUILD_ROOT%{_localstatedir}/cache/apache2/proxy \
269         $RPM_BUILD_ROOT%{_localstatedir}/cache/apache2/ssl
270
271# Make the MMN accessible to module packages
272echo %{mmnisa} > $RPM_BUILD_ROOT%{_includedir}/apache2/.mmn
273mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/rpm
274cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.apache2 <<EOF
275%%_httpd_mmn %{mmnisa}
276%%_httpd_apxs %%{_bindir}/apxs
277%%_httpd_modconfdir %%{_sysconfdir}/apache2/conf.modules.d
278%%_httpd_confdir %%{_sysconfdir}/apache2/conf.d
279%%_httpd_contentdir %{contentdir}
280%%_httpd_moddir %%{_libdir}/apache2/modules
281%%_apache2_mmn %{mmnisa}
282%%_apache2_apxs %%{_bindir}/apxs
283%%_apache2_modconfdir %%{_sysconfdir}/apache2/conf.modules.d
284%%_apache2_confdir %%{_sysconfdir}/apache2/conf.d
285%%_apache2_contentdir %{contentdir}
286%%_apache2_moddir %%{_libdir}/apache2/modules
287EOF
288
289# Handle contentdir
290mkdir $RPM_BUILD_ROOT%{contentdir}/noindex
291install -m 644 -p $RPM_SOURCE_DIR/index.html \
292        $RPM_BUILD_ROOT%{contentdir}/noindex/index.html
293install -m 644 -p $RPM_SOURCE_DIR/poweredby-vine.png \
294        $RPM_BUILD_ROOT%{contentdir}/icons/
295rm -rf %{contentdir}/htdocs
296
297# remove manual sources
298find $RPM_BUILD_ROOT%{contentdir}/manual \( \
299    -name \*.xml -o -name \*.xml.* -o -name \*.ent -o -name \*.xsl -o -name \*.dtd \
300    \) -print0 | xargs -0 rm -f
301
302# Strip the manual down just to English and replace the typemaps with flat files:
303set +x
304for f in `find $RPM_BUILD_ROOT%{contentdir}/manual -name \*.html -type f`; do
305   if test -f ${f}.en; then
306      cp ${f}.en ${f}
307      rm ${f}.*
308   fi
309done
310set -x
311
312# Clean Document Root
313rm -v $RPM_BUILD_ROOT%{docroot}/html/*.html
314rm -v $RPM_BUILD_ROOT/var/www/cgi-bin/*
315
316# symlinks for /etc/apache2
317ln -s ../..%{_localstatedir}/log/apache2 $RPM_BUILD_ROOT/etc/apache2/logs
318ln -s /run/apache2 $RPM_BUILD_ROOT/etc/apache2/run
319ln -s ../..%{_libdir}/apache2/modules $RPM_BUILD_ROOT/etc/apache2/modules
320
321# install SYSV init stuff
322mkdir -p $RPM_BUILD_ROOT/etc/rc.d/init.d
323install -m755 $RPM_SOURCE_DIR/apache2.init \
324        $RPM_BUILD_ROOT/etc/rc.d/init.d/apache2
325%{__perl} -pi -e "s:\@docdir\@:%{_docdir}/%{name}-%{version}:g" \
326        $RPM_BUILD_ROOT/etc/rc.d/init.d/apache2
327
328# Install logrotate config
329mkdir -p $RPM_BUILD_ROOT/etc/logrotate.d
330install -m 644 -p $RPM_SOURCE_DIR/apache2.logrotate \
331        $RPM_BUILD_ROOT/etc/logrotate.d/apache2
332
333# fix man page paths
334sed -e "s|/usr/local/apache2/conf/httpd.conf|/etc/apache2/conf/httpd.conf|" \
335    -e "s|/usr/local/apache2/conf/mime.types|/etc/mime.types|" \
336    -e "s|/usr/local/apache2/conf/magic|/etc/apache2/conf/magic|" \
337    -e "s|/usr/local/apache2/logs/error_log|/var/log/apache2/error_log|" \
338    -e "s|/usr/local/apache2/logs/access_log|/var/log/apache2/access_log|" \
339    -e "s|/usr/local/apache2/logs/httpd.pid|/run/apache2/apache2.pid|" \
340    -e "s|/usr/local/apache2|/etc/httpd|" < docs/man/httpd.8 \
341  > $RPM_BUILD_ROOT%{_mandir}/man8/httpd.8
342
343# Make ap_config_layout.h libdir-agnostic
344sed -i '/.*DEFAULT_..._LIBEXECDIR/d;/DEFAULT_..._INSTALLBUILDDIR/d' \
345    $RPM_BUILD_ROOT%{_includedir}/apache2/ap_config_layout.h
346
347# Fix path to instdso in special.mk
348sed -i '/instdso/s,top_srcdir,top_builddir,' \
349    $RPM_BUILD_ROOT%{_libdir}/apache2/build/special.mk
350
351# Remove unpackaged files
352rm -vf \
353      $RPM_BUILD_ROOT%{_libdir}/*.exp \
354      $RPM_BUILD_ROOT/etc/apache2/conf/mime.types \
355      $RPM_BUILD_ROOT%{_libdir}/apache2/modules/*.exp \
356      $RPM_BUILD_ROOT%{_libdir}/apache2/build/config.nice \
357      $RPM_BUILD_ROOT%{_bindir}/{ap?-config,dbmmanage} \
358      $RPM_BUILD_ROOT%{_sbindir}/{checkgid,envvars*} \
359      $RPM_BUILD_ROOT%{contentdir}/htdocs/* \
360      $RPM_BUILD_ROOT%{_mandir}/man1/dbmmanage.* \
361      $RPM_BUILD_ROOT%{contentdir}/cgi-bin/*
362
363rm -rf $RPM_BUILD_ROOT/etc/apache2/conf/{original,extra}
364
365
366
367%triggerpostun -- apache < 2.0
368/sbin/chkconfig --add apache2
369
370
371%post
372/sbin/chkconfig --add apache2
373
374%preun
375if [ $1 = 0 ]; then
376        /sbin/service apache2 stop > /dev/null 2>&1
377        /sbin/chkconfig --del apache2
378fi
379
380%postun
381if [ "$1" -ge 1 ]; then
382        /sbin/service apache2 condrestart
383fi
384/sbin/ldconfig
385
386%define sslcert %{_sysconfdir}/pki/tls/certs/localhost.crt
387%define sslkey %{_sysconfdir}/pki/tls/private/localhost.key
388
389%post -n mod_ssl-apache2
390umask 077
391
392if [ -f %{sslkey} -o -f %{sslcert} ]; then
393  exit 0
394fi
395
396%{_bindir}/openssl genrsa \
397  -rand /proc/apm:/proc/cpuinfo:/proc/dma:/proc/filesystems:/proc/interrupts:/proc/ioports:/proc/pci:/proc/rtc:/proc/uptime \
398  2048 > %{sslkey} 2> /dev/null ||:
399
400FQDN=`hostname` ||:
401if [ "x${FQDN}" = "x" ]; then
402   FQDN=localhost.localdomain
403fi
404   
405cat << EOF | %{_bindir}/openssl req -new -key %{sslkey} \
406         -x509 -sha256 -days 3650 -set_serial $RANDOM -extensions v3_req \
407         -out %{sslcert} 2>/dev/null ||:
408--
409SomeState
410SomeCity
411SomeOrganization
412SomeOrganizationalUnit
413${FQDN}
414root@${FQDN}
415EOF
416
417%clean
418rm -rf $RPM_BUILD_ROOT
419
420%files
421%defattr(-,root,root)
422%license LICENSE
423%doc ABOUT_APACHE README CHANGES LAYOUT
424%doc docs/conf/extra/*.conf
425
426%dir %{_sysconfdir}/apache2
427%{_sysconfdir}/apache2/modules
428%{_sysconfdir}/apache2/logs
429%{_sysconfdir}/apache2/run
430%dir %{_sysconfdir}/apache2/conf
431%config(noreplace) %{_sysconfdir}/apache2/conf/httpd.conf
432%config(noreplace) %{_sysconfdir}/apache2/conf/apache2.conf
433%config(noreplace) %{_sysconfdir}/apache2/conf/magic
434
435%config(noreplace) %{_sysconfdir}/logrotate.d/apache2
436
437%config %{_sysconfdir}/rc.d/init.d/apache2
438
439%dir %{_sysconfdir}/apache2/conf.d
440%{_sysconfdir}/apache2/conf.d/README
441%config(noreplace) %{_sysconfdir}/apache2/conf.d/*.conf
442%exclude %{_sysconfdir}/apache2/conf.d/ssl.conf
443%exclude %{_sysconfdir}/apache2/conf.d/manual.conf
444
445%dir %{_sysconfdir}/apache2/conf.modules.d
446%{_sysconfdir}/apache2/conf.modules.d/README
447%config(noreplace) %{_sysconfdir}/apache2/conf.modules.d/*.conf
448%exclude %{_sysconfdir}/apache2/conf.modules.d/00-ssl.conf
449
450%dir %{_sysconfdir}/apache2/sites.d
451
452%{_prefix}/lib/tmpfiles.d/apache2.conf
453
454%{_bindir}/ab
455%{_bindir}/ht*
456%{_bindir}/logresolve
457%{_sbindir}/ht*
458%{_sbindir}/apache2
459%{_sbindir}/apachectl
460%{_sbindir}/apache2ctl
461%{_sbindir}/rotatelogs
462%{_sbindir}/fcgistarter
463%attr(4510,root,%{suexec_caller}) %{_sbindir}/suexec
464
465%dir %{_libdir}/apache2
466%dir %{_libdir}/apache2/modules
467%{_libdir}/apache2/modules/mod_*.so
468%exclude %{_libdir}/apache2/modules/mod_ssl.so
469
470%dir %{contentdir}
471%dir %{contentdir}/icons
472%dir %{contentdir}/error
473%dir %{contentdir}/error/include
474%dir %{contentdir}/noindex
475%{contentdir}/icons/*
476%{contentdir}/error/README
477%{contentdir}/error/*.var
478%{contentdir}/error/include/*.html
479%{contentdir}/noindex/index.html
480
481%dir %{docroot}/html
482%dir /var/www/cgi-bin
483
484%attr(0710,root,www-data) %dir /run/apache2
485%attr(0700,www-data,www-data) %dir /run/apache2/htcacheclean
486
487%attr(0700,root,root) %dir %{_localstatedir}/log/apache2
488%attr(0700,www-data,www-data) %dir %{_localstatedir}/lib/dav
489%attr(0700,www-data,www-data) %dir %{_localstatedir}/cache/apache2
490%attr(0700,www-data,www-data) %dir %{_localstatedir}/cache/apache2/proxy
491
492%{_mandir}/man1/*
493%exclude %{_mandir}/man1/apxs*
494
495%{_mandir}/man8/*
496
497
498%files manual
499%defattr(-,root,root)
500%{contentdir}/manual
501%config(noreplace) %{_sysconfdir}/apache2/conf.d/manual.conf
502
503
504%files -n mod_ssl-apache2
505%defattr(-,root,root)
506%{_libdir}/apache2/modules/mod_ssl.so
507%config(noreplace) %{_sysconfdir}/apache2/conf.modules.d/00-ssl.conf
508%config(noreplace) %{_sysconfdir}/apache2/conf.d/ssl.conf
509%attr(0700,www-data,www-data) %dir %{_localstatedir}/cache/apache2/ssl
510
511
512%files devel
513%defattr(-,root,root)
514%{_includedir}/apache2
515%{_bindir}/apxs
516%{_mandir}/man1/apxs*
517%dir %{_libdir}/apache2/build
518%{_libdir}/apache2/build/*.mk
519%{_libdir}/apache2/build/*.sh
520%{_sysconfdir}/rpm/macros.apache2
521
522
523%changelog
524* Fri Jul  8 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.23-1
525- new upstream release.
526
527* Tue Jun  7 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.20-2
528- enabled HTTP/2.
529
530* Sun May 29 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.20-1
531- updated to 2.4.20.
532- updated Patch58.
533- fixed %%files.
534- fixed location of suexec (BTS#3007).
535
536* Thu Mar 10 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.18-2
537- rebuilt with openssl 1.0.2g
538
539* Thu Feb  4 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.18-1
540- updated to 2.4.18.
541- fixed 00-base.conf.
542- updated Patch31.
543
544* Mon Dec  7 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.17-2
545- fixed configuration files.
546
547* Fri Dec  4 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.17-1
548- update to 2.4.17.
549- fixed dependency.
550
551* Wed Jun 25 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 2.4.9-2
552- modify dependency
553
554* Wed Jun 25 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 2.4.9-1
555- update to 2.4.9
556- remove suffix '2' from {htdigest,htpasswd,rotatelogs}2
557- use /run instead of /var/run
558- remove /etc/apache2/conf/ssl* , use /etc/pki now.
559- move suexec from %%{_libdir}/apache2 to %%{_sbindir}
560- split all LoadModules to conf.modules.d/*.conf
561- split module configs to conf.d/*.conf
562- cleanup docroot, move apache specific files to %%{_datadir}/apache2
563- add BR: lua-devel, libxml2-devel
564- add /etc/apache2/sites.d for virtual host settings.
565
566* Wed Dec 25 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.25-2
567- merge VineSeed spec file
568  * Wed Oct 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.23-2
569  - rebuild with pcre-8.31
570
571  * Wed Mar 21 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.23-1
572  - update to 2.2.23
573  - add R(pre): www-common, BR: www-common
574  - move apache contents to %{contentdir}
575
576* Sat Sep 28 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.25-1
577- new upstream release with security fix (CVE-2013-1862,1896)
578- drop patch100 (is included in new release)
579
580* Fri May 17 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.24-2
581- add patch100 for fix CVE-2013-1862 (mod_rewrite)
582
583* Wed Feb 27 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.24-1
584- new upstream release with security fix (CVE-2012-3499, 4558)
585
586* Sun Sep 16 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.23-1
587- new upstream release with security fix (CVE-2012-3502,CVE-2012-2687)
588- update patch22 to fit new release
589- update man filename convert list
590
591* Wed Mar 21 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.22-1
592- update to 2.2.22
593  - CVE-2012-0021 (mod_log_config)
594  - CVE-2012-0031
595  - CVE-2012-0053
596- remove upstreamed patches
597
598* Fri Dec  9 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.21-5
599- add patch120 for fix CVE-2011-4317 (mod_rewrite/mod_proxy)
600
601* Fri Nov 18 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.21-4
602- add patch110 for fix CVE-2011-3607-4415 (ModSetEnvIf)
603
604* Wed Oct 12 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.21-3
605- add patch70 for fix byterange filter
606
607* Tue Oct 11 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.21-2
608- add Patch100 for fix CVE-2011-3368 (mod_proxy)
609
610* Wed Sep 14 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.21-1
611- new upstream release with security fix (CVE-2011-3348)
612- regression fixes of CVE-2011-3192 byterange fix in 2.2.20
613
614* Tue Sep  6 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.20-3
615- update Patch101 (Thanks to debian team)
616
617* Sat Sep  3 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.20-2
618- add Patch101 for fix CVE-2011-3192 regression
619
620* Thu Sep  1 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.20-1
621- new upstream release with security fix (CVE-2011-3192)
622- drop patch100 (is included in new release)
623
624* Thu Aug 25 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.19-2
625- add patch100 for fix CVE-2011-3192 (Range Header DoS)
626
627* Mon May 23 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.19-1
628- update to 2.2.19
629
630* Sat Apr 30 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.14-9
631- remove old Obsoletes/Conflicts
632
633* Tue Jan 11 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.14-8
634- rebuild with openssl-1.0.0c
635
636* Sat Aug 21 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.14-7
637- add  patch120 for fix CVE-2010-1452 (mod_dav/mod_cache) from mdk2010
638
639* Wed Aug 18 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.14-6
640- add R(post): alternatives
641
642* Sat Mar 20 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 2.2.14-5
643- add patch110 for fix CVE-2010-0434 from mdk 2010
644
645* Sun Mar  7 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 2.2.14-4
646- add patch100 for fix CVE-2010-0408 (mod_proxy_ajp)
647
648* Fri Feb  5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.2.14-3
649- rebuilt with rpm-4.8.0-3 (on ppc)
650
651* Tue Feb 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.14-2
652- rebuild with db4-4.8.0
653
654* Tue Jan 05 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.14-1
655- new upstream release with security fix
656  (CVE-2009-2699, CVE-2009-3095, CVE-2009-3094)
657- fix ssl.conf (2.2.13-1 includes wrong file)
658
659* Sun Aug 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.13-1
660- new upstream release
661
662* Wed Jul 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.12-1
663- new upstream release
664  (including security fix for CVE-2009-1890, CVE-2009-1191,
665   CVE-2009-1195, CVE-2009-1955, CVE-2009-1956, CVE-2009-0023)
666
667* Fri Jan 09 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.11-2
668- rebuilt with openldap-2.4.11
669
670* Fri Jan  2 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.11-1
671- new upstream release
672
673* Sat Oct 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.10-1
674- new upstream release (including security fix for CVE-2008-2939)
675
676* Fri Jun 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.9-1
677- new upstream release (including security fix for CVE-2008-2364, CVE-2007-6420)
678- built with db4-4.6.21, apr 1.3.0
679
680* Sun Apr 27 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 2.2.8-1
681- add Patch60 (to fix bug#31418).
682
683* Thu Feb 21 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.8-0vl2
684- rebuild with expat-2.0.1
685
686* Tue Jan 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.8-0vl1
687- new upstream release
688
689* Sat Nov  3 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.6-0vl2
690- added postun script from VinePlus/4.0 package
691  * Tue Sep 11 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.3-0vl3.2
692  - add postun script to restart daemon with message
693
694* Sun Jul 01 2007 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.3-0vl8
695- updated Patch2: httpd-2.2.3-apxs.patch
696
697* Sun Jun 24 2007 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.3-0vl7
698- modified libdir in config.layout for lib64 architecture
699
700* Sun May 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.3-0vl6
701- rebuilt with openssl-0.9.8e
702
703* Thu May 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.2.3-0vl5
704- rebuilt with new toolchain and db4-4.3.x
705
706* Wed Feb  7 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.3-0vl4
707- added BuildRequires: pcre-devel, sqlite3-devel <BTS:VineLinux:474>
708
709* Mon Sep 11 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.2.3-0vl3
710- change manual Group to Applications/Documentation. <BTS:VineLinux:163>
711
712* Sun Aug 27 2006 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.3-0vl2
713- rebuilt with openldap-2.3.27-0vl1
714
715* Sat Jul 29 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.3-0vl1
716- new upstream release including security fix (CVE-2006-3747)
717
718* Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
719- new upstream release
720  - update to 2.2.2
721- remove apr/apr-devel subpackage,
722  use external apr/apr-util instead of internal one.
723
724* Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.58-0vl1
725- new upstream release
726- use apache2.prefork as default.
727
728* Thu Mar 23 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.55-0vl3
729- rebuild to use new _localstatedir (rpm-4.4.2-0vl11)
730- remove unpackaged files in %%install section
731
732* Fri Jan 27 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.55-0vl2
733- fix logrotate configuration (use apache2.pid instead of httpd.pid)
734  (BTS:10)
735- use Epoch instead of Serial
736
737* Sat Oct 15 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.55-0vl1
738- new upstream release
739- drop obsolete security patches which is merged in upstream
740
741* Sat Oct 08 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.54-0vl1
742- new upstream release
743
744* Sun Sep 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.53-0vl2
745- added Patch122 to 125 for secutiry fix
746  (CAN-2004-{1268,2088,2700,2728})
747- fix %install section
748
749* Sun Apr 10 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.53-0vl1
750- new upstream release
751
752* Sat Nov 06 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.52-0vl1
753- new upstream release
754
755* Sun Oct 24 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.50-0vl4
756- rebuilt with db4-4.2.52
757
758* Sat Sep  4 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 2.0.50-0vl3
759- separate apr, apr-devel packages
760- add BuildPreReq: zlib-devel
761
762* Sun Jul 11 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.50-0vl2
763- fix %%files to include instdso.sh
764  thanks to jax <jax AT morejams DOT no-ip DOT com>
765- add %%{?_smp_mflags} to make option.
766
767* Sun Jul  4 2004 IWAI, Masaharu <iwai@alib.jp> 2.0.50-0vl1
768- new upstream version
769
770* Sun Nov 23 2003 IWAI, Masaharu <iwai@alib.jp> 2.0.48-0vl1
771- new upstream version
772
773* Mon Sep 15 2003 IWAI, Masaharu <iwai@alib.jp> 2.0.47-0vl1
774- new upstream version
775- update apxs patch (Patch101)
776- fix dependency:
777    - change file name to package name in Requires and {Build,}Prereq
778- add BuildPrereq: openldap-devel
779- update %%files section
780- rename httpd.8 manpage
781
782* Mon May 12 2003 Satoshi MACHINO <machino@vinelinux.org> 2.0.45-0vl1
783- new upstream version
784- used vine-config.layout in srclib
785
786* Mon May 12 2003 Satoshi MACHINO <machino@vinelinux.org> 2.0.44-0vl9
787- rebuild
788
789* Sun Apr  6 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl8
790- change pkg name from mod_ssl to mod_ssl-apache2
791- remove "apache-manual" entry from Obsoletes:
792
793* Thu Apr  3 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl7
794- remove "mod_dav" and "apache-devel" from Obsoletes:
795- enable MPMS(worker %mpms )
796
797* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl6
798- add correct config_vars.mk
799
800* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl5
801- apply apxs's patch ( from Debian)
802
803* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl4
804- add apr-config,apu-config to devel's %file
805
806* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl3
807- change apxs path ( /usr/sbin -> /usr/bin
808- add symlink under /etc/apache2/conf
809  (logs, run), httpd.conf -> apache2.conf
810- fixed apache2 initscript.
811
812* Sat Mar 29 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl2
813- build Vine Linux
814- new upstream version
815- sharing with apache1
816
817* Wed Sep  4 2002 Nalin Dahyabhai <nalin@redhat.com> 2.0.40-8
818- link httpd with libssl to avoid library loading/unloading weirdness
819
820* Tue Sep  3 2002 Joe Orton <jorton@redhat.com> 2.0.40-7
821- add LoadModule lines for proxy modules in httpd.conf (#73349)
822- fix permissions of conf/ssl.*/ directories; add Makefiles for
823  certificate management (#73352)
824
825* Mon Sep  2 2002 Joe Orton <jorton@redhat.com> 2.0.40-6
826- provide "httpd-mmn" to manage module ABI compatibility
827
828* Sun Sep  1 2002 Joe Orton <jorton@redhat.com> 2.0.40-5
829- fix SSL session cache (#69699)
830- revert addition of LDAP support to apr-util
831
832* Mon Aug 26 2002 Joe Orton <jorton@redhat.com> 2.0.40-4
833- set SIGXFSZ disposition to "ignored" (#69520)
834- make dummy connections to the first listener in config (#72692)
835
836* Mon Aug 26 2002 Joe Orton <jorton@redhat.com> 2.0.40-3
837- allow "apachectl configtest" on a 1.3 httpd.conf
838- add mod_deflate
839- enable LDAP support in apr-util
840- don't package everything in /var/www/error as config(noreplace)
841
842* Wed Aug 21 2002 Bill Nottingham <notting@redhat.com> 2.0.40-2
843- add trigger (#68657)
844
845* Mon Aug 12 2002 Joe Orton <jorton@redhat.com> 2.0.40-1
846- update to 2.0.40
847
848* Wed Jul 24 2002 Joe Orton <jorton@redhat.com> 2.0.36-8
849- improve comment on use of UserDir in default config (#66886)
850
851* Wed Jul 10 2002 Joe Orton <jorton@redhat.com> 2.0.36-7
852- use /sbin/nologin as shell for apache user (#68371)
853- add patch from CVS to fix possible infinite loop when processing
854  internal redirects
855
856* Wed Jun 26 2002 Gary Benson <gbenson@redhat.com> 2.0.36-6
857- modify init script to detect 1.3.x httpd.conf's and direct users
858  to the migration guide
859
860* Tue Jun 25 2002 Gary Benson <gbenson@redhat.com> 2.0.36-5
861- patch apachectl to detect 1.3.x httpd.conf's and direct users
862  to the migration guide
863- ship the migration guide
864
865* Fri Jun 21 2002 Joe Orton <jorton@redhat.com>
866- move /etc/httpd2 back to /etc/httpd
867- add noindex.html page and poweredby logo; tweak default config
868  to load noindex.html if no default "/" page is present.
869- add patch to prevent mutex errors on graceful restart
870
871* Fri Jun 21 2002 Tim Powers <timp@redhat.com> 2.0.36-4
872- automated rebuild
873
874* Wed Jun 12 2002 Joe Orton <jorton@redhat.com> 2.0.36-3
875- add patch to fix SSL mutex handling
876
877* Wed Jun 12 2002 Joe Orton <jorton@redhat.com> 2.0.36-2
878- improved config directory patch
879
880* Mon May 20 2002 Joe Orton <jorton@redhat.com>
881- initial build; based heavily on apache.spec and mod_ssl.spec
882- fixes: #65214, #58490, #57376, #61265, #65518, #58177, #57245
883
Note: See TracBrowser for help on using the repository browser.