source: projects/specs/trunk/a/apache/apache-vl.spec @ 521

Revision 521, 31.4 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define _sysconfdir /etc
2%define _localstatedir /var
3
4%define contentdir /home/httpd
5%define apache_ver 1.3.41
6%define mod_ssl_ver 2.8.31
7%define mm_ver 1.4.0
8
9Summary: The most widely used Web server on the Internet.
10Summary(ja): インターネットで最も広く利用されているウェブサーバ
11Name: apache
12Version: 1.3.41
13Release: 2%{?_dist_release}
14Group: System Environment/Daemons
15
16Vendor: Project Vine
17Distribution: Vine Linux
18
19#Source0: ftp://ftp.apache.org/apache/dist/apache_%{apache_ver}.tar.gz
20Source0: http://archive.apache.org/dist/httpd/apache_%{apache_ver}.tar.bz2
21Source1: ftp://ftp.modssl.org/source/mod_ssl-%{mod_ssl_ver}-%{apache_ver}.tar.gz
22#Source2: http://www.engelschall.com/sw/mm/mm-%{mm_ver}.tar.gz
23Source2: ftp://ftp.ossp.org/pkg/lib/mm/mm-%{mm_ver}.tar.gz
24
25Source3: http://www.snert.com/Software/Throttle/mod_throttle211.tgz
26Source4: spacer48.png
27Source5: apache-0vl4-index.html
28Source6: PoweredByVine.png
29Source7: httpd.init
30Source8: apache.logrotate
31Source9: apache-access.conf
32Source10: apache-0vl4-httpd.conf
33Source11: apache-srm.conf
34Source12: ftp://ftp.cohprog.com/pub/apache/module/1.3.0/mod_bandwidth.c
35Source13: mod_put.c
36Source14: SSL-Certificate-Creation
37Source20: README-apache.conf.d
38
39# Source100: www.apache.jp-20020317.tgz
40Source100: apache-jpdocs-20020327.tgz
41
42# for x86_64 architecture support
43Source207: httpd.init.lib64
44
45Patch1: apache-1.3.31-apxs.patch
46# Patch2: apache_1.3.14-phhttpd-eapi.patch
47Patch4: mod_ssl-2.6.4-tty.patch
48Patch5: apache_1.3.12-piranha.patch
49# Patch6: mod_ssl-2.8.8-openssl.patch
50
51# Patch for security fix
52# Patch200: patch for tmp-file problem from SuSE 8.0 mm-1.1.3-290
53# Patch200: mm-tmp-race.dif
54# Patch210: patch for htpasswd problem
55# Patch210: apache-htpasswd.patch
56# Patch290: apache-1.3.33_CVE-2007-5000.patch
57# Patch300: apache-1.3.39_CVE-2007-6388.patch
58Patch310: apache-1.3.39_CVE-2007-4465.patch
59Patch320: apache-1.3.39_CVE-2008-0005.patch
60
61# Patch for Vine
62Patch0: apache_1.3.26-vine.patch
63# Patch10: apache_1.3.12-disable_iso8859_charset.patch
64Patch20: apache_1.3.22-use_expat_lite.patch
65Patch30: apache_1.3.26-layout.patch
66
67# for x86_64 architecture support
68#Patch300: mod_ssl-2.8.28-libssl.lib64.patch
69Patch300: mod_ssl-2.8.31-libssl.lib64.patch
70
71
72License: Apache License, Version 2.0
73BuildRoot: %{_tmppath}/%{name}-root
74BuildRequires: findutils, openssl-devel, perl
75# Requires: /etc/mime.types, gawk, file, /usr/bin/find
76# Prereq: /sbin/chkconfig, /bin/mktemp, /bin/rm, mailcap, grep, textutils
77# Prereq: /usr/sbin/useradd
78Requires: mailcap, gawk, file, findutils
79Prereq: chkconfig, mktemp, fileutils, mailcap, grep textutils
80Prereq: shadow-utils
81Provides: webserver
82
83%description
84Apache is a powerful, full-featured, efficient and freely-available
85Web server. Apache is also the most popular Web server on the
86Internet.
87
88Install the apache package if you need a Web server.
89
90
91%description -l ja
92Apacheはパワフルで高機能, 有能でいてかつ自由に利用できるウェブサーバです。
93Apacheはインターネットで最も広く利用されているウェブサーバです。
94
95ウェブサーバを必要とするならapacheパッケージをインストールしてください。
96
97%package -n mod_ssl
98Group: System Environment/Daemons
99Version: %{mod_ssl_ver}
100Summary: Cryptography support for the Apache web server.
101Requires: apache = %{apache_ver}-%{release}
102Prereq: openssl, dev
103
104%description -n mod_ssl
105The mod_ssl module provides strong cryptography for the Apache web
106server via the Secure Sockets Layer (SSL) and Transport Layer Security
107(TLS) protocols.
108
109%description -n mod_ssl -l ja
110apache web サーバをSSL経由で動かすための mod_ssl モジュールです.
111mod_ssl を始めてインストールしたときにはインストール時には仮のCSR
112が作成されますが、正確な情報を記述したCSRを作成してください。
113
114作成方法は rpm -q --scripts mod_ssl によって表示されるコマンドを参考に
115することもできます。
116
117%package devel
118Group: Development/Libraries
119Summary: Development tools for the Apache Web server.
120Summary(ja): Apacheウェブサーバのための開発ツール
121Obsoletes: secureweb-devel
122
123%description devel
124The apache-devel package contains the APXS binary and other files that
125you'll need to build Dynamic Shared Objects (DSOs) for Apache.
126
127If you are installing the Apache Web server, and you want to be
128able to compile or develop additional modules for Apache, you'll
129need to install this package.
130
131%description -l ja devel
132apache-develパッケージは Apache用のダイナミック共有オブジェクト(DSOs)
133を構築するのに必要なApacheウェブサーバのソースコードとAPXSバイナリを含
134んでいます。
135
136Apacheウェブサーバをインストールして、かつ、追加モジュールを開発または
137コンパイルするには、このパッケージをインストールする必要があります。
138
139
140%package manual
141Group: Applications/Documentation
142Summary: Documentation for the Apache Web server.
143Summary(ja): Apacheウェブサーバのためマニュアル文章
144Requires: apache >= 1.3.26-0vl4
145
146%description manual
147The apache-manual package contains the complete manual and reference
148guide for the Apache Web server.  If you need Apache documentation
149installed on the local machine, install this package.  The information
150can also be found on the Web at http://www.apache.org/docs/.
151
152%description -l ja manual
153apache-manualパッケージは Apacheウェブサーバの完全なマニュアルとリファ
154レンスガイドを含んでいます。もしApacheの文章がローカルマシン上に必要な
155ら、このパッケージをインストールしてください。
156この情報は、http://www.apache.org/docs/にも見ることができます。
157
158%prep
159%setup -q -n apache_%{apache_ver} -a 1 -a 2 -a 3
160%ifarch x86_64
161%patch300 -p0 -b .lib64
162%endif
163
164
165EAPI_MM=`pwd`/mm-%{mm_ver} ; export EAPI_MM
166
167pushd mm-%{mm_ver}
168# %patch200 -p1 -b .mm
169%configure --disable-shared
170popd
171
172#%patch6 -p0 -b .openssl
173pushd mod_ssl-%{mod_ssl_ver}-%{apache_ver}
174%patch4 -p2 -b .tty
175%configure --with-apache=`cd ..;pwd` --with-mm=$EAPI_MM
176popd
177
178%patch0 -p1 -b .redhat
179%patch1 -p1 -b .apxs
180#%patch3 -p0 -b .eapi
181#%patch2 -p1 -b .phhttpd
182%patch5 -p1 -b .piranha
183#%patch10 -p1 -b .disable_iso8859_charset
184%patch20 -p1 -b .use_expat_lite
185%patch30 -p1 -b .layout
186
187# %patch210 -p1 -b .htpasswd
188# %patch290 -p1 -b .CVE-2007-5000
189# %patch300 -p4 -b .CVE-2007-6388
190%patch310 -p1 -b .CVE-2007-4465
191%patch320 -p1 -b .CVE-2008-0005
192
193# mv eapi guys
194mv mod_ssl-%{mod_ssl_ver}-%{apache_ver}/pkg.eapi/*.c src/ap/
195mv mod_ssl-%{mod_ssl_ver}-%{apache_ver}/pkg.eapi/*.h src/include/
196
197%build
198EAPI_MM=`pwd`/mm-%{mm_ver} ; export EAPI_MM
199
200pushd $EAPI_MM
201%configure --disable-shared
202make
203popd
204
205OPTIM="$RPM_OPT_FLAGS" \
206        ./configure --prefix=%{_prefix} \
207        --libexecdir=%{_libdir}/apache \
208        --mandir=%{_mandir} \
209        --with-layout=Vine \
210        --add-module=%{SOURCE12} \
211        --add-module=%{SOURCE13} \
212%if 0
213        --activate-module=src/modules/throttle/mod_throttle.o \
214%endif
215    --add-module=src/modules/throttle/mod_throttle.c \
216        --enable-module=all \
217        --enable-shared=max \
218        --enable-shared=ssl \
219        --enable-rule=EAPI \
220        --disable-rule=WANTHSREGEX \
221        --disable-module=auth_dbm \
222        --with-perl=/usr/bin/perl \
223        --enable-suexec \
224        --suexec-docroot=%{contentdir}/html \
225        --suexec-caller=apache
226make
227
228%install
229rm -rf $RPM_BUILD_ROOT
230make install root=$RPM_BUILD_ROOT
231strip $RPM_BUILD_ROOT%{_sbindir}/httpd
232strip $RPM_BUILD_ROOT%{_libdir}/apache/*so
233
234# remove apachectl; we have our own SYSV init stuff
235rm $RPM_BUILD_ROOT%{_sbindir}/apachectl
236rm $RPM_BUILD_ROOT%{_mandir}/man8/apachectl.8
237
238# install SYSV init stuff
239mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d
240%ifarch x86_64
241install -m755 %{SOURCE207} $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/httpd
242%else
243install -m755 %{SOURCE7} $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/httpd
244%endif
245
246for I in 0 1 2 6; do
247        mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/rc$I.d
248        ln -s ../init.d/httpd $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/rc$I.d/K15httpd
249done
250for I in 3 5; do
251        mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/rc$I.d
252        ln -s ../init.d/httpd $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/rc$I.d/S85httpd
253done
254
255# install log rotation stuff
256mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d
257install -m644 %{SOURCE8} $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/apache
258
259ln -s ../..%{_var}/log/httpd $RPM_BUILD_ROOT%{_sysconfdir}/httpd/logs
260ln -s ../..%{_libdir}/apache $RPM_BUILD_ROOT%{_sysconfdir}/httpd/modules
261
262mkdir -p $RPM_BUILD_ROOT%{contentdir}/html
263rm -f $RPM_BUILD_ROOT%{contentdir}/html/index.html.ja.*
264install -m644 %{SOURCE5} $RPM_BUILD_ROOT%{contentdir}/html/index.html.ja
265install -m644 %{SOURCE5} $RPM_BUILD_ROOT%{contentdir}/html/index.html.html
266install -m644 %{SOURCE6} $RPM_BUILD_ROOT%{contentdir}/html
267
268# jpdocs
269tar xzf %{SOURCE100}
270cp -r apache-jpdocs/httpd-docs-1.3-ja/htdocs/manual $RPM_BUILD_ROOT%{contentdir}/html/manual-ja
271mkdir -p $RPM_BUILD_ROOT%{_mandir}/ja/man1
272cp apache-jpdocs/httpd-docs-1.3-ja/man/*.1 $RPM_BUILD_ROOT%{_mandir}/ja/man1
273mkdir -p $RPM_BUILD_ROOT%{_mandir}/ja/man8
274cp apache-jpdocs/httpd-docs-1.3-ja/man/*.8 $RPM_BUILD_ROOT%{_mandir}/ja/man8
275rm $RPM_BUILD_ROOT%{_mandir}/ja/man8/apachectl.8
276pushd $RPM_BUILD_ROOT%{_mandir}/ja/man1 ; gzip -9 * ; popd
277pushd $RPM_BUILD_ROOT%{_mandir}/ja/man8 ; gzip -9 * ; popd
278
279# replace Apache's default config files with our own versions
280install -m644 %{SOURCE9} $RPM_BUILD_ROOT/etc/httpd/conf/access.conf
281install -m644 %{SOURCE10} $RPM_BUILD_ROOT/etc/httpd/conf/httpd.conf
282install -m644 %{SOURCE11} $RPM_BUILD_ROOT/etc/httpd/conf/srm.conf
283
284# install conf.d directory
285install -d $RPM_BUILD_ROOT/%{_sysconfdir}/httpd/conf.d
286install -m 644 %{SOURCE20} $RPM_BUILD_ROOT/%{_sysconfdir}/httpd/conf.d/README
287
288# Remove default keys and certs, install docs, and point to the right makefile.
289mkdir -p $RPM_BUILD_ROOT%{contentdir}/html/manual/mod/mod_ssl/
290install -m644 mod_ssl-%{mod_ssl_ver}-%{apache_ver}/pkg.ssldoc/*.{html,gif,jpg} \
291        $RPM_BUILD_ROOT%{contentdir}/html/manual/mod/mod_ssl/
292rm -f $RPM_BUILD_ROOT/etc/httpd/conf/ssl.*/server.*
293ln -s ../../../usr/share/ssl/certs/Makefile $RPM_BUILD_ROOT/etc/httpd/conf
294
295# install apache source code for devel package
296#mkdir -p $RPM_BUILD_ROOT/usr/src
297#tar xzf $RPM_SOURCE_DIR/apache_%{version}.tar.gz -C $RPM_BUILD_ROOT/usr/src
298find $RPM_BUILD_ROOT -type f | \
299        xargs grep -l "/usr/local/bin/perl5" | \
300        xargs perl -pi -e "s|/usr/local/bin/perl5|/usr/bin/perl|g;"
301find $RPM_BUILD_ROOT -type f | \
302        xargs grep -l "/usr/local/bin/perl" | \
303        xargs perl -pi -e "s|/usr/local/bin/perl|/usr/bin/perl|g;"
304
305
306# clean up apxs
307sed "s^$RPM_BUILD_ROOT^^g" $RPM_BUILD_ROOT%{_sbindir}/apxs > apxs.tmp && \
308cat apxs.tmp > $RPM_BUILD_ROOT%{_sbindir}/apxs
309
310# create a prototype session cache
311mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/cache/
312touch $RPM_BUILD_ROOT%{_localstatedir}/cache/ssl_gcache_data.{dir,pag,sem}
313
314# fixup the documentation file naming
315#find $RPM_BUILD_ROOT%{contentdir} -name "*.html.html" | xargs rename .html.html .html
316
317%clean
318rm -rf $RPM_BUILD_ROOT
319
320%post
321/sbin/chkconfig --add httpd
322/etc/rc.d/init.d/httpd condrestart
323[ -f %{_sysconfdir}/mime.types ] || exit 0
324# safely add .htm to mime types if it is not already there
325TEMPTYPES=`/bin/mktemp /tmp/mimetypes.XXXXXX`
326[ -z "$TEMPTYPES" ] && {
327  echo "could not make temporary file, htm not added to /etc/mime.types" >&2
328  exit 1
329}
330( grep -v "^text/html"  %{_sysconfdir}/mime.types
331  types=$(grep "^text/html" %{_sysconfdir}/mime.types | cut -f2-)
332  echo -en "text/html\t\t\t"
333  for val in $types ; do
334      if [ "$val" = "htm" ] ; then
335          continue
336      fi
337      echo -n "$val "
338  done
339  echo "htm"
340) > $TEMPTYPES
341cat $TEMPTYPES > %{_sysconfdir}/mime.types && /bin/rm -f $TEMPTYPES
342
343%pre
344# Add the "apache" user
345/usr/sbin/useradd -c "Apache" -u 48 \
346        -s /bin/false -r -d %{contentdir} apache 2> /dev/null || :
347exit 0
348
349%preun
350if [ $1 = 0 ]; then
351   %{_sysconfdir}/rc.d/init.d/httpd stop > /dev/null 2>&1
352   /sbin/chkconfig --del httpd
353fi
354 
355%files
356%defattr(-,root,root)
357%doc ABOUT_APACHE LICENSE README cgi-bin
358%dir %{_sysconfdir}/httpd/
359%dir %{_sysconfdir}/httpd/conf
360%dir %{_sysconfdir}/httpd/conf.d
361%{_sysconfdir}/httpd/conf.d/README
362%config(noreplace) %{_sysconfdir}/httpd/conf/access.conf
363%config(noreplace) %{_sysconfdir}/httpd/conf/srm.conf
364%config(noreplace) %{_sysconfdir}/httpd/conf/httpd.conf
365%config(noreplace) %{_sysconfdir}/httpd/conf/magic
366
367%{_sysconfdir}/httpd/logs
368%{_sysconfdir}/httpd/modules
369%config(noreplace) %{_sysconfdir}/logrotate.d/apache
370%config %{_sysconfdir}/rc.d/init.d/httpd
371
372%config(missingok) /etc/rc.d/rc3.d/S85httpd
373%config(missingok) /etc/rc.d/rc5.d/S85httpd
374%config(missingok) /etc/rc.d/rc0.d/K15httpd
375%config(missingok) /etc/rc.d/rc1.d/K15httpd
376%config(missingok) /etc/rc.d/rc2.d/K15httpd
377%config(missingok) /etc/rc.d/rc6.d/K15httpd
378
379%dir %{contentdir}
380%dir %{contentdir}/cgi-bin
381%dir %{contentdir}/html
382%config(noreplace) %{contentdir}/html/index.html*
383%{contentdir}/html/*.png
384%{contentdir}/html/*.gif
385%{contentdir}/icons
386
387%dir %{_libdir}/apache
388%{_libdir}/apache/httpd.exp
389%{_libdir}/apache/libproxy.so
390%{_libdir}/apache/mod*.so
391
392%{_mandir}/man1/*
393%{_mandir}/man8/ab.8*
394%{_mandir}/man8/httpd.8*
395%{_mandir}/man8/logresolve.8*
396%{_mandir}/man8/rotatelogs.8*
397%{_mandir}/man8/suexec.8*
398
399%{_mandir}/ja/*/*
400
401%{_sbindir}/ab
402%{_sbindir}/httpd
403%{_sbindir}/logresolve
404%{_sbindir}/rotatelogs
405#%attr(4510,root,apache) %{_sbindir}/suexec
406%attr(0711,root,root) %{_sbindir}/suexec
407%{_bindir}/*
408
409#%attr(-,nobody,nobody) %dir %{_var}/cache/httpd
410%attr(0755,apache,root) %dir %{_var}/cache/httpd
411%dir %{_var}/log/httpd
412
413%files manual
414%defattr(-,root,root)
415%{contentdir}/html/manual
416%{contentdir}/html/manual-ja
417
418%files devel
419%defattr(-,root,root)
420%{_includedir}/apache
421%{_sbindir}/apxs
422%{_mandir}/man8/apxs.8*
423
424
425%post -n mod_ssl
426/sbin/ldconfig
427umask 077
428
429if [ ! -f %{_sysconfdir}/httpd/conf/ssl.key/server.key ] ; then
430%{_bindir}/openssl genrsa -rand /proc/apm:/proc/cpuinfo:/proc/dma:/proc/filesystems:/proc/interrupts:/proc/ioports:/proc/pci:/proc/rtc:/proc/uptime 1024 > %{_sysconfdir}/httpd/conf/ssl.key/server.key 2> /dev/null
431fi
432
433if [ ! -f %{_sysconfdir}/httpd/conf/ssl.crt/server.crt ] ; then
434cat << EOF | %{_bindir}/openssl req -new -key %{_sysconfdir}/httpd/conf/ssl.key/server.key -x509 -days 365 -out %{_sysconfdir}/httpd/conf/ssl.crt/server.crt 2>/dev/null
435--
436SomeCountry
437SomeState
438SomeCity
439SomeOrganization
440SomeOrganizationalUnit
441localhost.localdomain
442root@localhost.localdomain
443EOF
444fi
445
446%files -n mod_ssl
447%defattr(-,root,root)
448%doc $RPM_SOURCE_DIR/SSL-Certificate-Creation
449%doc mod_ssl-%{mod_ssl_ver}-%{apache_ver}/{README*,LICENSE,NEWS,CHANGES,CREDITS}
450%{contentdir}/html/manual/mod/mod_ssl/
451%{_libdir}/apache/libssl.so
452%{_sysconfdir}/httpd/conf/Makefile
453%attr(0700,root,root) %dir %{_sysconfdir}/httpd/conf/ssl.*
454%attr(0600,root,root) %ghost %{_localstatedir}/cache/ssl_gcache_data.dir
455%attr(0600,root,root) %ghost %{_localstatedir}/cache/ssl_gcache_data.pag
456%attr(0600,root,root) %ghost %{_localstatedir}/cache/ssl_gcache_data.sem
457%dir %{_sysconfdir}/httpd
458%{_sysconfdir}/httpd/conf/ssl.*/*
459
460%changelog
461* Sat Aug 23 2008 Shu KONNO <owa@bg.wakwak.com> 1.3.41-2vl5
462- updated mod_ssl-2.8.28-libssl.lib64.patch to 2.8.31
463- spec in utf-8
464
465* Wed Jun 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.41-1vl5
466- rebuilt with db4-4.6.21
467- applied new versioning policy
468- sync with VinePlus/4.0 package
469  * Tue Feb 12 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.41-0vl1
470  - build for VinePlus 4.x
471  - new upstream release with security fix
472  - drop unnessary unnecessary patches (patch 290,300)
473  * Wed Jan 16 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.39-0vl2
474  - add patch310 for fix CVE-2007-4465
475  - add patch320 for fix CVE-2008-0005
476  * Thu Jan 10 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.39-0vl1
477  - new upstream release with security fix
478  - add patch290 CVE-2007-5000
479  - add patch300 CVE-2007-6388
480
481* Sat Jun  9 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.37-0vl6
482- rebuilt with openssl-0.9.8e
483
484* Thu May 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.3.37-0vl5
485- rebuilt with new toolchain and db4-4.3.x
486
487* Tue Mar 27 2007 Shu KONNO <owa@bg.wakwak.com> 1.3.37-0vl4
488- added Patch300: mod_ssl-2.8.28-libssl.lib64.patch
489
490* Sat Oct 21 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.37-0vl3
491- changed apache-manual Group to Applications/Documentation
492
493* Mon Jul 31 2006 Shu KONNO <owa@bg.wakwak.com> 1.3.37-0vl2
494- updated apache to 1.3.37 (CVE-2006-3747)
495- updated mod_ssl to 2.8.28-1.3.37
496- changed URLs
497
498* Fri Mar 03 2006 Shu KONNO <owa@bg.wakwak.com> 1.3.34-0vl2
499- added option '--libexecdir=%%{_libdir}/apache' to configure
500- added httpd.init.lib64
501
502* Wed Nov 09 2005 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.34-0vl1
503- rebuild for VineSeed
504- blush up doc section
505
506* Mon Oct 24 2005 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.34-0vl0.1
507- Test package
508- new upstream release
509  - update to 1.3.34
510  - update to mod_ssl 2.8.25-1.3.34
511  - update to mm 1.4.0
512
513* Sat Nov 27 2004 IKEDA Katsumi <ikeda@webmasters.gr.jp> 1.3.33-0vl2
514- Added a security patch for buffer overflow in the htpasswd utility.
515  - Patch210: apache-htpasswd.patch
516- Moved %%patch4 above %%configure in mod_ssl-* directory.
517
518* Sun Oct 31 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.33-0vl1
519- new upstream release
520  - update to 1.3.33
521  - update mod_ssl to 2.8.22-1.3.33
522- drop obsolete patch (Patch100)
523
524* Sat Oct 30 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.32-0vl2
525- add Patch100 to fix buffer overflow in mod_include (CAN-2004-0940).
526
527* Sun Oct 24 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.32-0vl1
528- new upstream release
529  - update to 1.3.32
530  - update mod_ssl to 2.8.21-1.3.32
531- drop obsolete patch (Patch210)
532
533* Wed Oct 13 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.3.31-0vl6
534- rebuilt with db4-4.2.25
535
536* Fri Jul 23 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 1.3.31-0vl5
537- Patch210: fix buffer overflow in mod_proxy (CVE CAN-2004-0492)
538- update License
539- apache-manual requires apache for %{contentdir} and MultiViews
540
541* Sun Jul 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.31-0vl4
542- update mod_ssl to 2.8.19-1.3.31
543  - Changes with mod_ssl 2.8.19 (27-May-2004 to 16-Jul-2004)
544     *) Fix ssl_log() related format string vulnerability in mod_proxy
545        hook functions.
546
547* Sun Jul 11 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.31-0vl3
548- add %%{_sysconfdir}/httpd/conf.d for additional configuration file (conf.d/*.conf)
549  thanks to HOTTA Michihide <hotta AT net-newbie DOT com>
550
551* Sat May 29 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.31-0vl2
552- update mod_ssl to 2.8.18-1.3.31
553  - Changes with mod_ssl 2.8.18 (11-May-2004 to 27-May-2004)
554     *) Fix buffer overflow in "SSLOptions +FakeBasicAuth" implementation
555        if the Subject-DN in the client certificate exceeds 6KB in length.
556        (CVE CAN-2004-0488).
557     *) Handle the case of OpenSSL retry requests after interrupted system
558        calls during the SSL handshake phase.
559     *) Remove some unused functions.
560
561* Thu May 13 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.31-0vl1
562- new upstream release
563- update mod_ssl to 2.8.17-1.3.31
564
565* Fri Mar 26 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.29-0vl2
566- rebuild with openssl-0.9.7d
567
568* Mon Nov 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.29-0vl1
569- new upstream release 1.3.29
570- update mod_ssl to 2.8.16-1.3.29
571
572* Sun Jul 20 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.28-0vl1
573- new upstream release 1.3.28
574- update mod_ssl to 2.8.15-1.3.28
575
576* Sat Mar 29 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.27-0vl3
577- update mod_ssl to 2.8.14-1.3.27
578  - Changes with mod_ssl 2.8.14 (18-Mar-2002 to 21-Mar-2003)
579    *) Fixed logic in the destruction of a temporary certificate
580       structure and this way avoid a crash due to freeing NULL object.
581    *) Removed one newly introduced X509_free() call in the context of
582       SSL_get_certificate(), because this function does not increment a
583       reference count (although SSL_get_peer_certificate() does).
584    *) Fixed hash-table based shared memory session cache (shmht)
585       implementation by making sure that the underlying hash table
586       library does not crash if memory cannot be allocated.
587  - Changes with mod_ssl 2.8.13 (23-Oct-2002 to 18-Mar-2003)
588    *) Always enforce RSA blinding on RSA private keys in order to be
589       resistent to timing attacks.
590    *) Added timeout also to the "pre-sucking" of the trailing data in
591       POST request handling.
592    *) Correctly shutdown shared memory pools on fork+exec situations.
593    *) Bugfix SSL client certificate verification: OpenSSL was not
594       informed with SSL_set_verify_result(ssl, X509_V_OK) in case
595       mod_ssl forced the verification to be ok.
596    *) Consistently use OPENSSL_free() instead of plain free() to
597       deallocate memory chunks allocated inside OpenSSL.
598    *) Fixed various memory leaks related to X509 certificates.
599
600* Sat Oct 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.27-0vl2
601- update mod_ssl to 2.8.12-1.3.27
602  - security bug fix.
603    - Fixed potential Cross-Site-Scripting bug.
604    - Allow also 8192 bytes of shared memory data size.
605
606* Sat Oct 5 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.27-0vl1
607- new upstream release 1.3.27 for security fix
608- update mod_ssl to 2.8.11-1.3.27
609
610* Thu Aug 8 2002 Masaki Shinomiya <shino@pos.to>  1.3.26-0vl4
611- MultiViews manual (see [VineSeed:06745] )
612- condrestart in %post
613- allow to rebuild on Vine 2.0/2.1/2.5
614
615* Wed Jul 31 2002 IWAI Masaharu <iwai@alib.jp> 1.3.26-0vl3
616- SECURITY: fixed for tmp-file problem
617  - from SuSE 8.0 mm-1.1.3-290
618    * Fri Jul 26 2002 - poeml@suse.de
619    - security fix for tmp-file problem
620
621* Sun Jun 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.26-0vl2
622- update mod_ssl to 2.8.10-1.3.26
623- update patch0,
624  do not show distribution name, when ServerTokens was set.
625
626* Wed Jun 19 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.26-0vl1
627- new upstream release 1.3.24
628  - fixed security hole
629- update mod_ssl to 2.8.9-1.3.26
630- add patch30 to use Vine Linux layout
631
632* Wed Mar 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.24-0vl1
633- new upstream release 1.3.24
634- update mod_ssl 2.8.8-1.3.24
635- fixed missing tag "</a>" in apache-vine-index.html
636- added manual-ja to %%files manual
637
638* Wed Mar 27 2002 Shoji Matsumoto <shom@vinelinux.org> 1.3.23-0vl5
639- update Japanese Document (www.apache.jp to CVS tree)
640- update apache-vine-index.html
641
642* Sun Mar 17 2002 Shoji Matsumoto <shom@vinelinux.org> 1.3.23-0vl4
643- add www.apache.jp-20020317.tgz (Japanese Document Mirror)
644- update apache-vine-index.html
645
646* Wed Feb 27 2002 Toru Sagami <sagami@vinelinux.org> 1.3.23-0vl3
647- use --add-module for mod_throttle.c instead of --activate-module
648- make configtest exits with RETVAL
649- remove missing doc
650
651* Wed Feb 27 2002 Satoshi MACHINO <machino@vinelinux.org> 1.3.23-0vl2
652- added patch2 for openssl patch(updated ;p)
653
654* Thu Feb 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.23-0vl1
655- new upstream release 1.3.23
656- update mod_throttle 2.11
657- update mod_ssl 2.8.7-1.3.23
658- drop patch2, patch6
659
660* Wed Jan 23 2002 Toru Sagami <sagami@vinelinux.org> 1.3.22-0vl3
661- added %%{_localstatedir} definition as /var (%%{_var})
662- added pre script to add user "apache" and prereq for /usr/sbin/useradd
663- change owner/group of cache directory to "apache" from "nobody"
664- changed httpd.conf to run httpd as user/owner "apache"
665- added more mod_ssl docs
666- typo fixed in default index.html
667- added graceful/configtest in httpd.init (courtesy of [vine-users:038237])
668- set NameWidth=* by default
669- don't put "noreplace" to httpd.init
670
671* Thu Oct 25 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.3.22-0vl2
672- added patch20 to force using libexpat-lite in the source
673  even if external expat packages (found in VineSeedPlus) are installed
674
675* Wed Oct 17 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.22-0vl1
676- upstream release 1.3.22
677- update mod_ssl to 2.8.5-1.3.22
678- remove waste files..
679
680* Thu Oct  4 2001 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.3.20-0vl7
681- added noreplace flag (%%config file is not replaced)
682
683* Thu Sep 13 2001 Tomoya TAKA <tomoya@olive.plala.or.jp>
684- 1.3.20-0vl6
685- fix a typo in Prereq
686
687* Wed Sep 12 2001 Shoji Matsumoto <shom@vinelinux.org> 1.3.20-0vl5
688- replace filenames in *Req: to packagenames (for apt)
689
690* Wed Aug 29 2001 Jun Nishii <jun@vinelinux.org> 1.3.20-0vl4
691- restore index.html and poweredby.png for Vine
692
693* Mon Jul 16 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
694- 1.3.20-0vl3
695- rebuilt with openssl-0.9.6b
696
697* Tue Jul  3 2001 Jun Nishii <jun@vinelinux.org> 1.3.20-0vl2
698- added mod_ssl subpackage
699
700* Thu Mar  1 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.20-0vl1
701- update to 1.3.20
702
703* Thu Mar  1 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.19-0vl1
704- update to 1.3.19
705
706* Fri Feb  2 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.17-0vl1
707- update to 1.3.17-fix
708
709* Wed Dec 27 2000 Tomoya TAKA <tomoya@olive.plala.or.jp> 1.3.14-0vl4
710- fix to handle man pages correctly with _mandir
711
712* Sun Nov 19 2000 Satoshi MACHINO <machino@vinelinux.org> 1.3.14-0vl3
713- build with gcc-2.95.3
714- partially used rpmmacros
715
716* Sat Nov  7 2000 Kazuhisa TAKEI <takei@vinelinux.org> 1.3.14-0vl2
717- change from file depend to package name depend. (Requires: )
718
719* Sat Oct 14 2000 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.14-0vl1
720- update to 1.3.14
721
722* Thu Jul 20 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
723- fixed typo at default index.html.
724
725* Thu Jun  8 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
726- remove '"' of path from default httpd.conf for linuxconf.
727
728* Thu Apr 20 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
729- added disable_iso8859_charset patch for character turnning depend on server side.
730
731* Wed Apr 19 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
732- modified default httpd.conf about LanguageProc
733- use vine-patch instead of RedHat.
734- modified default index.html for Vine.
735
736* Wed Apr 19 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
737- added japanese summary and descriptions
738
739* Wed Mar 01 2000 Nalin Dahyabhai <nalin@redhat.com>
740- make suexec limit UIDs and GIDs to < 51 instead of 100
741
742* Fri Feb 25 2000 Nalin Dahyabhai <nalin@redhat.com>
743- update to 1.3.12
744- add EAPI patch
745
746* Thu Feb 17 2000 Preston Brown <pbrown@redhat.com>
747- ifmodule directive for php stuff.
748- load mod_perl before mod_php (#8169)
749
750* Tue Feb 14 2000 Zach Brown <zab@redhat.com>
751- minor fix to phhttpd patch
752
753* Thu Feb 10 2000 Preston Brown <pbrown@redhat.com>
754- improved default index.html.
755
756* Thu Feb 03 2000 Preston Brown <pbrown@redhat.com>
757- strip dynamically loadable modules.
758
759* Mon Feb 02 2000 Zach Brown <zab@redhat.com>
760- add phhttpd 'Tunnel' directive and code to use it
761
762* Mon Jan 31 2000 Cristian Gafton <gafton@redhat.com>
763- rebuild to fix depenencies
764
765* Tue Jan 25 2000 Bernhard Rosenkraenzer <bero@redhat.com>
766- 1.3.11
767- deal with the fact that RPM now gzips man pages
768
769* Wed Jan 12 2000 Preston Brown <pbrown@redhat.com>
770- new poweredby.png w/new logo
771- apxs.8 man page moved to devel archive (#6661)
772- don't remove old logfiles on package de-install (#8268)
773- more updates to logrotate to avoid spurious cron mail (#8110)
774
775* Mon Jan 10 2000 Preston Brown <pbrown@redhat.com>
776- mod_throttle added; mod_bandwidth updated.
777
778* Mon Dec 17 1999 Dale Lovelace <dale@redhat.com>
779- Add configuration for mod_put to httpd.conf
780
781* Mon Dec 06 1999 Preston Brown <pbrown@redhat.com>
782- documentation cleanups in httpd.conf (#5357, #6655)
783- fixed logrotate script to ignore error if no apache running (#7074)
784
785* Wed Nov 10 1999 Jeff Johnson <jbj@redhat.com>
786- add put module.
787
788* Thu Nov 04 1999 Preston Brown <pbrown@redhat.com>
789- make suexec non-suid.  People can enable it if they wish themselves.
790- somehow the unified httpd.conf got trashed.  fixed.
791- manual is now a subpackage
792- point to /usr/share/magic as the magic file location; don't use the
793  apache-specific one.
794- fix apxs module installation issues (#5650)
795
796
797* Tue Sep 21 1999 Bill Nottingham <notting@redhat.com>
798- move DSO in httpd.conf to after ServerRoot
799
800* Mon Sep 20 1999 Preston Brown <pbrown@redhat.com>
801- it is httpd stop, not httpsd stop (# 5254)
802- suexec added (# 5257)
803
804* Thu Sep 09 1999 Preston Brown <pbrown@redhat.com>
805- remove apachectl man page (# 4459)
806
807* Fri Aug 27 1999 Preston Brown <pbrown@redhat.com>
808- upgraded to 1.3.9
809- fix bug # 3680 (suexec docroot was wrong)
810- fix bug # 2378 (logrotate with -USR1 not -HUP)
811- fix bug # 3548 (logrotate complains if apache not running)
812- httpd.conf is now in the unified apache format as distributed
813
814* Mon Aug 16 1999 Bill Nottingham <notting@redhat.com>
815- initscript munging
816
817* Sat May 21 1999 Bill Nottingham <notting@redhat.com>
818- fix broken link in index.html
819
820* Wed Apr 07 1999 Bill Nottingham <notting@redhat.com>
821- allow indexes in /doc
822
823* Tue Apr 06 1999 Preston Brown <pbrown@redhat.com>
824- strip binaries
825
826* Mon Apr 05 1999 Preston Brown <pbrown@redhat.com>
827- prerequire /bin/rm, added /doc path pointing to /usr/doc for localhost
828
829* Fri Mar 26 1999 Preston Brown <pbrown@redhat.com>
830- updated log rotating scripts to not complain if logs aren't present.
831
832* Thu Mar 25 1999 Preston Brown <pbrown@redhat.com>
833- fixed up path to perl
834
835* Wed Mar 24 1999 Preston Brown <pbrown@redhat.com>
836- updated init script to conform to new standards
837- upgraded to 1.3.6, fixed apxs patch
838
839* Mon Mar 22 1999 Preston Brown <pbrown@redhat.com>
840- clean up logfiles on deinstallation
841
842* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
843- auto rebuild in the new build environment (release 4)
844
845* Fri Mar 12 1999 Cristian Gafton <gafton@redhat.com>
846- added mod_bandwidth
847- updated to 1.3.4
848- prereq mailcap
849
850* Fri Dec 18 1998 Cristian Gafton <gafton@redhat.com>
851- added patch to disable building support for ndbm
852- build against glibc 2.1
853
854* Mon Oct 12 1998 Cristian Gafton <gafton@redhat.com>
855- updated to 1.3.3 to catch up with bug fixes
856- added the /usr/bin/* binaries to the spec file list
857
858* Fri Sep 25 1998 Cristian Gafton <gafton@redhat.com>
859- change ownership of cache dir to nobody
860- added "Red Hat" to the server string
861- updated to version 1.3.2
862- fixed all references to httpsd in config files
863
864* Fri Sep 04 1998 Cristian Gafton <gafton@redhat.com>
865- small fixes to the spec file
866- patch to handle correctly the -d <newroot> option
867- leave out the .usr.src.apache_%{version} for now
868
869* Thu Sep 03 1998 Preston Brown <pbrown@redhat.com>
870- patched apxs not to bomb out if it can't find httpd
871
872* Wed Sep 02 1998 Preston Brown <pbrown@redhat.com>
873- upgraded to apache 1.3.1.
874- Heavy rewrite.
875- changed providing a_web_server to just webserver.  Humor is not an option.
876
877* Mon Aug 10 1998 Erik Troan <ewt@redhat.com>
878- updated to build as non-root user
879- added patch to defeat header dos attack
880
881* Thu May 07 1998 Prospector System <bugs@redhat.com>
882- translations modified for de, fr, tr
883
884* Wed May 06 1998 Cristian Gafton <gafton@redhat.com>
885- fixed the default config files to be more paranoid about security
886
887* Sat May 02 1998 Cristian Gafton <gafton@redhat.com>
888- fixed init script
889- added index.htm to the list of acceptable indexes
890
891* Sat May 02 1998 Cristian Gafton <gafton@redhat.com>
892- updated to 1.2.6
893- added post script to install htm extension for text/html into
894  /etc/mime.types
895
896* Wed Apr 22 1998 Michael K. Johnson <johnsonm@redhat.com>
897- enhanced sysv init script
898
899* Tue Jan 06 1998 Erik Troan <ewt@redhat.com>
900- updated to 1.2.5, which includes many security fixes
901
902* Wed Dec 31 1997 Otto Hammersmith <otto@redhat.com>
903- fixed overkill on http.init stop
904
905* Wed Dec 31 1997 Erik Troan <ewt@redhat.com>
906- added patch for backslash DOS attach
907
908* Thu Nov 06 1997 Donnie Barnes <djb@redhat.com>
909- added htdigest binary to file list
910
911* Mon Nov 03 1997 Donnie Barnes <djb@redhat.com>
912- made the default index.html be config(noreplace) so we no longer
913  blow away other folks' index.html
914
915* Wed Oct 29 1997 Donnie Barnes <djb@redhat.com>
916- added chkconfig support
917- added restart|status options to initscript
918- renamed httpd.init to httpd
919
920* Tue Oct 07 1997 Elliot Lee <sopwith@redhat.com>
921- Redid spec file, patches, etc. from scratch.
Note: See TracBrowser for help on using the repository browser.