source: projects/specs/trunk/a/anthy/anthy-vl.spec @ 8954

Revision 8954, 11.8 KB checked in by inagaki, 10 years ago (diff)

2014-09-16 Ryoichi INAGAKI <ryo1@…>

  • anthy: fixed build problem


Line 
1%define __libtoolize :
2
3%define emacsen_pkg     1
4%{?without_emacsen: %define emacsen_pkg 0}
5
6%if %{emacsen_pkg}
7%undefine without_emacsen
8%define anthy_el        anthy-el
9%define anthy           anthy
10%define emacsen_pkgdir /usr/lib/emacsen-common/packages
11%else
12%define without_emacsen 1
13%endif
14
15%define ut_patch_date   20100517
16
17Name: anthy
18Summary: A Japanese character input system library (with dictionary).
19Summary(ja): Anthy - 日本語入力システムおよび辞書
20Version: 9100h
21Release: 14%{?_dist_release}
22
23License: GPL, LGPL, BSD
24Group: Applications/System
25URL: http://www.sourceforge.jp/projects/anthy/
26
27Source: %{name}-%{version}.tar.gz
28Source1: anthy-el-install.sh
29Source2: anthy-el-remove.sh
30Source3: anthy-init.el
31Source4: vine-default-anthy.el
32# large dictionary and improvement patch made by UTSUMI at
33# http://www.geocities.jp/ep3797/anthy_dict_01.html
34Source100: anthy-ut-patches-%{ut_patch_date}.tar.bz2
35# anthy patches made by G-HAL
36# http://www.fenix.ne.jp/~G-HAL/soft/nosettle/#anthy
37Patch100: anthy-9100h.patch13B-23-iconv-ucdict.2010507.alt-depgraph-100120-patch100126.alt-cannadic-091230.patch
38Patch110: anthy-9100h.patch13B-23-iconv-jisx0213.patch
39Patch120: anthy-ut-patches-20100517-ANTHY_ENCODING_EUCJP.patch
40Patch121: make-anthy.el-work-with-emacs-24.3.1.diff
41
42BuildRoot: %{_tmppath}/%{name}-%{version}-root
43BuildRequires: automake
44BuildRequires: autoconf
45
46Vendor: Project Vine
47Distribution: Vine Linux
48Packager: daisuke, kazutaka
49
50%description
51Anthy is free and secure Japanese input system.
52
53%description -l ja
54Anthy はフリーでセキュアな日本語入力システムです。
55
56%if %{emacsen_pkg}
57%package -n %{anthy_el}
58Summary: Emacs-lisp frontend for Anthy
59Summary(ja): Anthy 用 Emacs-lisp フロントエンド
60Group: Applications/Editors/Emacs
61BuildRequires: emacsen
62Requires(post,preun): emacsen, emacsen-common >= 0.1
63Requires: %{name} = %{version}-%{release}
64
65%description -n %{anthy_el}
66Emacs-lisp frontend for Anthy
67
68%description -n %{anthy_el} -l ja
69Anthy のための Emacs-lisp フロントエンド
70%endif
71
72%package devel
73Summary: Development files for libanthy
74Summary(ja): libanthy を使ったアプリケーションを開発するためのファイル
75Group: Development/Libraries
76Requires: %{name} = %{version}-%{release}
77Requires: pkgconfig
78
79%description devel
80Devepment files for anthy libraries.
81
82%description devel -l ja
83libanthy を利用したアプリケーションを開発するために必要なヘッダやライブラリ
84が含まれています。
85
86
87%prep
88%setup -q -a 100
89%patch100 -p1
90%patch110 -p1
91%patch120 -p1
92pushd src-util
93%patch121 -p1
94popd
95
96pushd anthy-ut-patches-%{ut_patch_date}
97./apply-patches.sh
98popd
99
100# fix file permission...
101chmod a+x ./depgraph/mkdepword \
102          ./calctrans/divide.sh \
103          ./mkworddic/mkucdic.pl
104
105%build
106#libtoolize --copy --force
107autoreconf -f -i
108%configure --localstatedir=%{_var}
109
110#%__make %{?_smp_mflags}
111# don't use smp option
112%__make
113
114
115%install
116%__rm -rf ${RPM_BUILD_ROOT}
117%makeinstall
118%if %{emacsen_pkg}
119%__mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{anthy}
120#%__mkdir -p ${RPM_BUILD_ROOT}%{_prefix}/lib/emacsen-common/packages/install
121#%__mkdir -p ${RPM_BUILD_ROOT}%{_prefix}/lib/emacsen-common/packages/remove
122%__cp -af %{SOURCE3} %{SOURCE4} \
123    ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{anthy}
124%__mkdir -p ${RPM_BUILD_ROOT}%{emacsen_pkgdir}/install
125%__mkdir -p ${RPM_BUILD_ROOT}%{emacsen_pkgdir}/remove
126%endif
127
128%if %{emacsen_pkg}
129%{?emacsen_pkg: %_installemacsenscript %{anthy} %{SOURCE1}}
130%{?emacsen_pkg: %_removeemacsenscript  %{anthy} %{SOURCE2}}
131%else
132%__rm -rf ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{anthy}
133%endif
134
135## remove unuse files
136rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
137
138
139%if %{emacsen_pkg}
140%post -n %{anthy_el}
141if [ "$1" = 2 ]; then
142  %{?emacsen_pkg: %_emacsenPackageRemove %{anthy}}
143fi
144%{?emacsen_pkg: %_addemacsenlist %{anthy}}
145%{?emacsen_pkg: %_emacsenPackageInstall %{anthy}}
146
147
148%preun -n %{anthy_el}
149if [ "$1" = 0 ]; then
150  %{?emacsen_pkg: %_emacsenPackageRemove %{anthy}}
151
152  %{?emacsen_pkg: %_removeemacsenlist %{anthy}}
153
154fi
155%endif
156
157
158%clean
159%__rm -rf ${RPM_BUILD_ROOT}
160
161
162%post -p /sbin/ldconfig
163
164
165%postun -p /sbin/ldconfig
166
167
168%files
169%defattr(-,root,root)
170%{_bindir}/*
171%{_sysconfdir}/*
172%{_datadir}/anthy
173%{_libdir}/libanthy*.so
174%{_libdir}/libanthy*.so.*
175%doc AUTHORS COPYING ChangeLog DIARY NEWS README doc Doxyfile README.en
176
177%if %{emacsen_pkg}
178%files -n %{anthy_el}
179%defattr(-, root, root)
180%{_datadir}/emacs/site-lisp/%{anthy}
181#%{_prefix}/lib/emacsen-common/packages/install/%{anthy}
182#%{_prefix}/lib/emacsen-common/packages/remove/%{anthy}
183%{emacsen_pkgdir}/install/%{anthy}
184%{emacsen_pkgdir}/remove/%{anthy}
185%endif
186
187%files devel
188%defattr(-,root,root)
189%{_includedir}/*
190%{_libdir}/libanthy*.a
191#%{_libdir}/libanthy*.la
192%{_libdir}/pkgconfig/*.pc
193
194%changelog
195* Tue Sep 16 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 9100h-14
196- fixed anthy-el packaging problem
197
198* Sun Aug 31 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 9100h-13
199- updated Source1, Source2 and Source3
200
201* Tue Jun 18 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 9100h-12
202- add anthy.el patch for Emacs 24.3 (Patch:121) <VineLinux:2629>
203
204* Tue Sep 28 2010 Shu KONNO <owa@bg.wakwak.com> 9100h-11
205- rebuilt with rpm-4.8.1 for pkg-config
206
207* Sun Jun 06 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 9100h-10
208- add patch110 to change EUCJP AS EUCJP/JISX0213
209- add patch120 to change default encoding to EUCJP for compatibility
210
211* Fri Jun 04 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 9100h-9
212- move ut patch to Source100
213- add Patch100 to add G-HAL's patches
214  - diffed from G-HAL's modified anthy archive.
215  - new ut patch does not include G-HAL's patches
216
217* Wed May 19 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 9100h-8
218- update Patch100 (anthy-ut-patches-20100517.tar.bz2)
219- run autoreconf at %%build section
220
221* Tue Jul 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 9100h-7
222- updated vine-default-anthy.el
223  - set 1 for anthy-accept-timeout (because default timeout is too long)
224
225* Sat Jun 27 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 9100h-6
226- update Patch100 (anthy-ut-patches-20090604.tar.bz2)
227
228* Mon May 11 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 9100h-5
229- update Patch100 (anthy-ut-patches-20090507.tar.bz2)
230
231* Wed May 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 9100h-4
232- updated anthy-el-install.sh
233  - *-init.el: changed from hard copy to symbolic link
234    on /etc/emacs-XX.YY/site-start.d
235- corrected byte-compiling messages of emacs flaver
236
237* Tue Apr 21 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 9100h-3
238- added vine-default-anthy.el
239- updated anthy-el-install.sh, anthy-el-remove.sh for vine-default-anthy.el
240
241* Tue Apr 07 2009 Shu KONNO <owa@bg.wakwak.com> 9100h-2
242- removed %%{?_smp_mflags} at make
243
244* Sun Mar 15 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 9100h-1
245- new upstream release
246- update Patch100
247
248* Wed Jan 21 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 9100e-3
249- add patch100 to improve conversion logic and add large dirctionary
250- add License LGPL and BSD for added patches
251-
252
253* Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 9100e-2vl5
254- added %%emacsen_pkgdir
255- removed *.la
256- spec in utf-8
257
258* Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 9100e-1vl5
259- new upstream release
260
2611* Fri Dec 28 2007 IWAI, Masaharu <iwai@alib.jp> 9100d-0vl1
262- new upstream release
263
264* Thu Aug 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 9100-0vl1
265- new upstream release
266
267* Fri Jun 15 2007 IWAI, Masaharu <iwai@alib.jp> 9011-0vl1
268- new upstream release
269
270* Tue Oct 17 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 7900-0vl3
271- use %%{_prefix}/lib instead of %%{_libdir} for elisp directory
272
273* Mon Sep 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7900-0vl2
274- changed anthy-el Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
275
276* Fri Aug 11 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 7900-0vl1
277- new upstream release
278
279* Fri Apr 28 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 7500b-0vl1
280- new upstream release
281
282* Sat Mar 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 7500-0vl1
283- new upstream release
284
285* Fri Dec 30 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 7100b-0vl3
286- add BuildRequires: emacsen instead of emacs
287- add Requires: %%{name} to anthy-el package
288- add libanthy*.la to devel package
289- update anthy-el-install.sh
290  - add anthy-azik.el, anthy-kyuri.el
291
292* Sun Dec 18 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 7100b-0vl2
293- add BuildRequires: emacs
294
295* Tue Dec 06 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 7100b-0vl1
296- new upstream release
297
298* Mon Oct 17 2005 IWAI, Masaharu <iwai@alib.jp> 7015-0vl1
299- new upstream release
300
301* Mon Oct 10 2005 IWAI, Masaharu <iwai@alib.jp> 6829-0vl1
302- new upstream release
303
304* Sun Jul 31 2005 IWAI, Masaharu <iwai@alib.jp> 6724-0vl1
305- new upstream release
306- add documents: Doxyfile and README.en
307
308* Sat Jul 30 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6700b-0vl1
309- new upstream release
310
311* Tue May 10 2005 IWAI, Masaharu <iwai@alib.jp> 6508-0vl1
312- new upstream release
313
314* Sat Apr  9 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6300d-0vl1
315- new upstream release
316- added %{_libdir}/pkgconfig/anthy.pc to devel package
317
318* Fri Oct 15 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 5812-0vl1
319- new upstream release
320
321* Sat Oct 09 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 5714-0vl1
322- new upstream release
323
324* Sun Jul 04 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 5500-0vl1
325- new upstream release
326
327* Thu Jun  3 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 5323-0vl3
328- move libanthy*.so to anthy main package. it is needed by some
329  anthy application.
330
331* Thu Jun  3 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 5323-0vl2
332- split development files to anthy-devel
333
334* Thu Jun  3 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 5323-0vl1
335- new upstream release
336
337* Wed Apr 21 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 5220-0vl1
338- new upstream release
339
340* Wed Mar 31 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 5122-0vl1
341- new upstream release
342
343* Sun Feb 29 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 5100-0vl1
344- new upstream release
345
346* Mon Feb 23 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 5021-0vl1
347- new upstream release
348
349* Wed Feb 11 2004 IWAI, Masaharu <iwai@alib.jp> 5008-0vl1
350- new upstream release
351
352* Tue Jan 27 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 4925-0vl1
353- new upstream release
354
355* Sun Jan 11 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 4901-0vl1
356- new upstream release
357
358* Thu Nov 27 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 4723-0vl1
359- new upstream release
360
361* Mon Nov 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 4708-0vl1
362- new upstream release
363
364* Fri Sep 26 2003 IWAI, Masaharu <iwai@alib.jp> 4524-0vl1
365- new upstream release
366
367* Mon Sep 22 2003 IWAI, Masaharu <iwai@alib.jp> 4520-0vl1
368- new upstream release
369
370* Tue Sep  9 2003 IWAI, Masaharu <iwai@alib.jp> 4507-0vl3
371- update anthy-el-install.sh (Source1): [VineSeed-Plus:01834]
372  - The files to byte-compile is made the same as the upstream.
373
374* Tue Sep  9 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 4507-0vl2
375- not bytecompile leim-list.el for XEmacs
376
377* Sun Sep 07 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 4507-0vl1
378- new upstream release
379
380* Sun Aug 31 2003 IWAI, Masaharu <iwai@alib.jp> 4431-0vl1
381- new upstream snapshot release
382- create anthy-el package for emacsen
383
384* Fri Aug 29 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 4421-0vl1
385- new upstream snapshot release
386
387* Fri Jul 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 4300-0vl1
388- initial build for Vine Linux
389
390* Thu Jul 10 2003 Yuhei Matsunaga <yuhei@users.sourceforge.jp>
391- up to 4200.
392- added description.
393
394* Fri Nov 25 2002 OGUMA "dellin" Hironori <dellin@team-ct.org>
395- 3500c-1
396- up to 3500c.
397- added some documents.
398
399* Fri Nov 22 2002 OGUMA "dellin" Hironori <dellin@team-ct.org>
400- up to 3500b.
401
402* Thu Jan  3 2002 Yusuke Tabata <yusuke@kmc.gr.jp>
403- changed my mail address and URL of web page
404
405* Thu Nov 11 2001 Takayoshi Nobuoka <taka@trans-nt.com>
406- add %{_sysconfdir}/* at %files
407
408* Wed Sep  9 2001 Takayoshi Nobuoka <taka@trans-nt.com>
409- use _bindir and so on.
410
411* Sun Aug 19 2001 Tabatee <yusuke@kmc.kyoto-u.ac.jp>
412- Initial build.
413
Note: See TracBrowser for help on using the repository browser.