source: projects/specs/trunk/a/anthy/anthy-vl.spec @ 9483

Revision 9483, 12.1 KB checked in by inagaki, 9 years ago (diff)

2015-04-03 Ryoichi INAGAKI <ryo1@…>

  • anthy: updated patch
  • m17n-db, m17n-lib, xosview: updated
  • uim: updated spec


Line 
1%define __libtoolize :
2
3%define emacsen_pkg     1
4%{?without_emacsen: %define emacsen_pkg 0}
5
6%if %{emacsen_pkg}
7%undefine without_emacsen
8%define anthy_el        anthy-el
9%define anthy           anthy
10%define emacsen_pkgdir /usr/lib/emacsen-common/packages
11%else
12%define without_emacsen 1
13%endif
14
15%define ut_patch_date   20110409
16
17Name: anthy
18Summary: A Japanese character input system library (with dictionary).
19Summary(ja): Anthy - 日本語入力システムおよび辞書
20Version: 9100h
21Release: 15%{?_dist_release}
22
23License: GPL, LGPL, BSD
24Group: Applications/System
25URL: http://www.sourceforge.jp/projects/anthy/
26
27Source: %{name}-%{version}.tar.gz
28Source1: anthy-el-install.sh
29Source2: anthy-el-remove.sh
30Source3: anthy-init.el
31Source4: vine-default-anthy.el
32# large dictionary and improvement patch made by UTSUMI at
33# http://www.geocities.jp/ep3797/anthy_dict_01.html
34Source100: anthy-ut-patches-%{ut_patch_date}.tar.bz2
35# anthy patches made by G-HAL
36# http://www.fenix.ne.jp/~G-HAL/soft/nosettle/#anthy
37Patch100: anthy-9100h.patch13B-23-iconv-ucdict.2010507.alt-depgraph-100120-patch100126.alt-cannadic-091230.patch
38Patch110: anthy-9100h.patch13B-23-iconv-jisx0213.patch
39Patch120: anthy-ut-patches-%{ut_patch_date}-ANTHY_ENCODING_EUCJP.patch
40Patch121: make-anthy.el-work-with-emacs-24.3.1.diff
41
42BuildRoot: %{_tmppath}/%{name}-%{version}-root
43BuildRequires: automake
44BuildRequires: autoconf
45BuildRequires: nkf
46
47Vendor: Project Vine
48Distribution: Vine Linux
49Packager: daisuke, kazutaka
50
51%description
52Anthy is free and secure Japanese input system.
53
54%description -l ja
55Anthy はフリーでセキュアな日本語入力システムです。
56
57%package devel
58Summary: Development files for libanthy
59Summary(ja): libanthy を使ったアプリケーションを開発するためのファイル
60Group: Development/Libraries
61Requires: %{name} = %{version}-%{release}
62Requires: pkgconfig
63
64%description devel
65Devepment files for anthy libraries.
66
67%description devel -l ja
68libanthy を利用したアプリケーションを開発するために必要なヘッダやライブラリ
69が含まれています。
70
71%if %{emacsen_pkg}
72%package -n %{anthy_el}
73Summary: Emacs-lisp frontend for Anthy
74Summary(ja): Anthy 用 Emacs-lisp フロントエンド
75Group: Applications/Editors/Emacs
76BuildRequires: emacsen
77Requires(post,preun): emacsen, emacsen-common >= 0.1
78Requires: %{name} = %{version}-%{release}
79
80%description -n %{anthy_el}
81Emacs-lisp frontend for Anthy
82
83%description -n %{anthy_el} -l ja
84Anthy の Emacs-lisp フロントエンドです。
85%endif
86
87%prep
88%setup -q -a 100
89%patch100 -p1
90%patch110 -p1
91%patch120 -p1
92pushd src-util
93%patch121 -p1
94popd
95
96pushd anthy-ut-patches-%{ut_patch_date}
97./apply-patches.sh
98popd
99
100# fix file permission...
101chmod a+x ./depgraph/mkdepword \
102          ./calctrans/divide.sh \
103          ./mkworddic/mkucdic.pl
104
105# fix file encoding
106for file in AUTHORS AUTHORS.patch DIARY NEWS README; do
107    nkf -O -w $file
108    mv nkf.out $file
109done
110
111%build
112#libtoolize --copy --force
113autoreconf -f -i
114%configure \
115    --disable-static \
116    --localstatedir=%{_var}
117
118#%__make %{?_smp_mflags}
119# don't use smp option
120%__make
121
122
123%install
124%__rm -rf ${RPM_BUILD_ROOT}
125
126%makeinstall
127%if %{emacsen_pkg}
128%__mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{anthy}
129#%__mkdir -p ${RPM_BUILD_ROOT}%{_prefix}/lib/emacsen-common/packages/install
130#%__mkdir -p ${RPM_BUILD_ROOT}%{_prefix}/lib/emacsen-common/packages/remove
131%__cp -af %{SOURCE3} %{SOURCE4} \
132    ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{anthy}
133%__mkdir -p ${RPM_BUILD_ROOT}%{emacsen_pkgdir}/install
134%__mkdir -p ${RPM_BUILD_ROOT}%{emacsen_pkgdir}/remove
135%endif
136
137%if %{emacsen_pkg}
138%{?emacsen_pkg: %_installemacsenscript %{anthy} %{SOURCE1}}
139%{?emacsen_pkg: %_removeemacsenscript  %{anthy} %{SOURCE2}}
140%else
141%__rm -rf ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{anthy}
142%endif
143
144## remove unuse files
145rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
146
147%clean
148%__rm -rf ${RPM_BUILD_ROOT}
149
150%post -p /sbin/ldconfig
151
152%postun -p /sbin/ldconfig
153
154%if %{emacsen_pkg}
155%post -n %{anthy_el}
156if [ "$1" = 2 ]; then
157    %{?emacsen_pkg: %_emacsenPackageRemove %{anthy}}
158fi
159%{?emacsen_pkg: %_addemacsenlist %{anthy}}
160%{?emacsen_pkg: %_emacsenPackageInstall %{anthy}}
161
162
163%preun -n %{anthy_el}
164if [ "$1" = 0 ]; then
165    %{?emacsen_pkg: %_emacsenPackageRemove %{anthy}}
166
167    %{?emacsen_pkg: %_removeemacsenlist %{anthy}}
168
169fi
170%endif
171
172%files
173%defattr(-,root,root)
174%doc AUTHORS* COPYING ChangeLog DIARY NEWS README* doc Doxyfile
175%{_bindir}/*
176%{_sysconfdir}/*
177%{_datadir}/anthy
178%{_libdir}/libanthy*.so.*
179
180%files devel
181%defattr(-,root,root)
182%{_includedir}/*
183#{_libdir}/libanthy*.a
184%{_libdir}/libanthy*.so
185%{_libdir}/pkgconfig/*.pc
186
187%if %{emacsen_pkg}
188%files -n %{anthy_el}
189%defattr(-, root, root)
190%{_datadir}/emacs/site-lisp/%{anthy}
191#%{_prefix}/lib/emacsen-common/packages/install/%{anthy}
192#%{_prefix}/lib/emacsen-common/packages/remove/%{anthy}
193%{emacsen_pkgdir}/install/%{anthy}
194%{emacsen_pkgdir}/remove/%{anthy}
195%endif
196
197
198%changelog
199* Thu Apr  2 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 9100h-15
200- updated Source100 as of 20110409
201- updated Patch120
202- fixed document encodings to UTF-8
203
204* Tue Sep 16 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 9100h-14
205- fixed anthy-el packaging problem
206
207* Sun Aug 31 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 9100h-13
208- updated Source1, Source2 and Source3
209
210* Tue Jun 18 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 9100h-12
211- add anthy.el patch for Emacs 24.3 (Patch:121) <VineLinux:2629>
212
213* Tue Sep 28 2010 Shu KONNO <owa@bg.wakwak.com> 9100h-11
214- rebuilt with rpm-4.8.1 for pkg-config
215
216* Sun Jun 06 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 9100h-10
217- add patch110 to change EUCJP AS EUCJP/JISX0213
218- add patch120 to change default encoding to EUCJP for compatibility
219
220* Fri Jun 04 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 9100h-9
221- move ut patch to Source100
222- add Patch100 to add G-HAL's patches
223  - diffed from G-HAL's modified anthy archive.
224  - new ut patch does not include G-HAL's patches
225
226* Wed May 19 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 9100h-8
227- update Patch100 (anthy-ut-patches-20100517.tar.bz2)
228- run autoreconf at %%build section
229
230* Tue Jul 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 9100h-7
231- updated vine-default-anthy.el
232  - set 1 for anthy-accept-timeout (because default timeout is too long)
233
234* Sat Jun 27 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 9100h-6
235- update Patch100 (anthy-ut-patches-20090604.tar.bz2)
236
237* Mon May 11 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 9100h-5
238- update Patch100 (anthy-ut-patches-20090507.tar.bz2)
239
240* Wed May 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 9100h-4
241- updated anthy-el-install.sh
242  - *-init.el: changed from hard copy to symbolic link
243    on /etc/emacs-XX.YY/site-start.d
244- corrected byte-compiling messages of emacs flaver
245
246* Tue Apr 21 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 9100h-3
247- added vine-default-anthy.el
248- updated anthy-el-install.sh, anthy-el-remove.sh for vine-default-anthy.el
249
250* Tue Apr 07 2009 Shu KONNO <owa@bg.wakwak.com> 9100h-2
251- removed %%{?_smp_mflags} at make
252
253* Sun Mar 15 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 9100h-1
254- new upstream release
255- update Patch100
256
257* Wed Jan 21 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 9100e-3
258- add patch100 to improve conversion logic and add large dirctionary
259- add License LGPL and BSD for added patches
260-
261
262* Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 9100e-2vl5
263- added %%emacsen_pkgdir
264- removed *.la
265- spec in utf-8
266
267* Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 9100e-1vl5
268- new upstream release
269
2701* Fri Dec 28 2007 IWAI, Masaharu <iwai@alib.jp> 9100d-0vl1
271- new upstream release
272
273* Thu Aug 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 9100-0vl1
274- new upstream release
275
276* Fri Jun 15 2007 IWAI, Masaharu <iwai@alib.jp> 9011-0vl1
277- new upstream release
278
279* Tue Oct 17 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 7900-0vl3
280- use %%{_prefix}/lib instead of %%{_libdir} for elisp directory
281
282* Mon Sep 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7900-0vl2
283- changed anthy-el Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
284
285* Fri Aug 11 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 7900-0vl1
286- new upstream release
287
288* Fri Apr 28 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 7500b-0vl1
289- new upstream release
290
291* Sat Mar 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 7500-0vl1
292- new upstream release
293
294* Fri Dec 30 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 7100b-0vl3
295- add BuildRequires: emacsen instead of emacs
296- add Requires: %%{name} to anthy-el package
297- add libanthy*.la to devel package
298- update anthy-el-install.sh
299  - add anthy-azik.el, anthy-kyuri.el
300
301* Sun Dec 18 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 7100b-0vl2
302- add BuildRequires: emacs
303
304* Tue Dec 06 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 7100b-0vl1
305- new upstream release
306
307* Mon Oct 17 2005 IWAI, Masaharu <iwai@alib.jp> 7015-0vl1
308- new upstream release
309
310* Mon Oct 10 2005 IWAI, Masaharu <iwai@alib.jp> 6829-0vl1
311- new upstream release
312
313* Sun Jul 31 2005 IWAI, Masaharu <iwai@alib.jp> 6724-0vl1
314- new upstream release
315- add documents: Doxyfile and README.en
316
317* Sat Jul 30 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6700b-0vl1
318- new upstream release
319
320* Tue May 10 2005 IWAI, Masaharu <iwai@alib.jp> 6508-0vl1
321- new upstream release
322
323* Sat Apr  9 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6300d-0vl1
324- new upstream release
325- added %{_libdir}/pkgconfig/anthy.pc to devel package
326
327* Fri Oct 15 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 5812-0vl1
328- new upstream release
329
330* Sat Oct 09 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 5714-0vl1
331- new upstream release
332
333* Sun Jul 04 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 5500-0vl1
334- new upstream release
335
336* Thu Jun  3 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 5323-0vl3
337- move libanthy*.so to anthy main package. it is needed by some
338  anthy application.
339
340* Thu Jun  3 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 5323-0vl2
341- split development files to anthy-devel
342
343* Thu Jun  3 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 5323-0vl1
344- new upstream release
345
346* Wed Apr 21 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 5220-0vl1
347- new upstream release
348
349* Wed Mar 31 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 5122-0vl1
350- new upstream release
351
352* Sun Feb 29 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 5100-0vl1
353- new upstream release
354
355* Mon Feb 23 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 5021-0vl1
356- new upstream release
357
358* Wed Feb 11 2004 IWAI, Masaharu <iwai@alib.jp> 5008-0vl1
359- new upstream release
360
361* Tue Jan 27 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 4925-0vl1
362- new upstream release
363
364* Sun Jan 11 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 4901-0vl1
365- new upstream release
366
367* Thu Nov 27 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 4723-0vl1
368- new upstream release
369
370* Mon Nov 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 4708-0vl1
371- new upstream release
372
373* Fri Sep 26 2003 IWAI, Masaharu <iwai@alib.jp> 4524-0vl1
374- new upstream release
375
376* Mon Sep 22 2003 IWAI, Masaharu <iwai@alib.jp> 4520-0vl1
377- new upstream release
378
379* Tue Sep  9 2003 IWAI, Masaharu <iwai@alib.jp> 4507-0vl3
380- update anthy-el-install.sh (Source1): [VineSeed-Plus:01834]
381  - The files to byte-compile is made the same as the upstream.
382
383* Tue Sep  9 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 4507-0vl2
384- not bytecompile leim-list.el for XEmacs
385
386* Sun Sep 07 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 4507-0vl1
387- new upstream release
388
389* Sun Aug 31 2003 IWAI, Masaharu <iwai@alib.jp> 4431-0vl1
390- new upstream snapshot release
391- create anthy-el package for emacsen
392
393* Fri Aug 29 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 4421-0vl1
394- new upstream snapshot release
395
396* Fri Jul 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 4300-0vl1
397- initial build for Vine Linux
398
399* Thu Jul 10 2003 Yuhei Matsunaga <yuhei@users.sourceforge.jp>
400- up to 4200.
401- added description.
402
403* Fri Nov 25 2002 OGUMA "dellin" Hironori <dellin@team-ct.org>
404- 3500c-1
405- up to 3500c.
406- added some documents.
407
408* Fri Nov 22 2002 OGUMA "dellin" Hironori <dellin@team-ct.org>
409- up to 3500b.
410
411* Thu Jan  3 2002 Yusuke Tabata <yusuke@kmc.gr.jp>
412- changed my mail address and URL of web page
413
414* Thu Nov 11 2001 Takayoshi Nobuoka <taka@trans-nt.com>
415- add %{_sysconfdir}/* at %files
416
417* Wed Sep  9 2001 Takayoshi Nobuoka <taka@trans-nt.com>
418- use _bindir and so on.
419
420* Sun Aug 19 2001 Tabatee <yusuke@kmc.kyoto-u.ac.jp>
421- Initial build.
422
Note: See TracBrowser for help on using the repository browser.