source: projects/specs/trunk/a/anacron/anacron-vl.spec @ 521

Revision 521, 7.7 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: A cron-like program that can run jobs lost during downtime.
2Name: anacron
3Version: 2.3
4Release: 29%{?_dist_release}
5License: GPL
6Group: System Environment/Base
7Source: ftp://ftp.debian.org/debian/pool/main/a/anacron/%{name}_%{version}.orig.tar.gz
8Source1: anacrontab
9Source2: anacron.init
10Patch0: anacron-2.3-mk-incl.patch
11Patch1: anacron-2.3-mail-content-type-77108.patch
12Patch2: anacron-2.3-gregor.patch
13Requires: /bin/sh
14Requires: crontabs
15Prereq: /sbin/chkconfig
16BuildRoot: %{_tmppath}/%{name}-%{version}-buildroot
17
18%description
19Anacron (like `anac(h)ronistic') is a periodic command scheduler.  It
20executes commands at intervals specified in days.  Unlike cron, it
21does not assume that the system is running continuously.  It can
22therefore be used to control the execution of daily, weekly and
23monthly jobs (or anything with a period of n days), on systems that
24don't run 24 hours a day.  When installed and configured properly,
25Anacron will make sure that the commands are run at the specified
26intervals as closely as machine-uptime permits. 
27
28This package is pre-configured to execute the daily jobs of the Red
29Hat Linux system. You should install this program if your system isn't
30powered on 24 hours a day to make sure the maintenance jobs of other
31Red Hat Linux packages are executed each day.
32
33%prep
34%setup -q
35%patch0 -p1 -b .incl
36%patch1 -p1 -b .charset
37%patch2 -p1 -b .gregor
38
39%build
40make CFLAGS="$RPM_OPT_FLAGS"
41
42%install
43mkdir -p $RPM_BUILD_ROOT/{etc/,usr/sbin/,%{_mandir}/man5,%{_mandir}/man8/}
44mkdir -p $RPM_BUILD_ROOT/var/spool/anacron/
45
46#
47cp anacron $RPM_BUILD_ROOT/usr/sbin
48cp anacron.8 $RPM_BUILD_ROOT/%{_mandir}/man8/
49cp anacrontab.5 $RPM_BUILD_ROOT/%{_mandir}/man5/
50cp %SOURCE1 $RPM_BUILD_ROOT/etc
51
52for i in cron.daily cron.weekly cron.monthly;do
53mkdir -p $RPM_BUILD_ROOT/etc/$i/
54cat << EOF > $RPM_BUILD_ROOT/etc/$i/0anacron
55#!/bin/sh
56#
57# anacron's cron script
58#
59# This script updates anacron time stamps. It is called through run-parts
60# either by anacron itself or by cron.
61#
62# The script is called "0anacron" to assure that it will be executed
63# _before_ all other scripts.
64
65anacron -u $i
66
67EOF
68chmod +x $RPM_BUILD_ROOT/etc/$i/0anacron
69done
70
71#
72#for i in `find $RPM_BUILD_ROOT/ -type 'f' -perm '+a=x'`;do
73#       file $i|grep -q "not stripped" && strip $i
74#done
75
76mkdir -p $RPM_BUILD_ROOT/etc/rc.d/init.d/
77install -c -m755 %SOURCE2 $RPM_BUILD_ROOT/etc/rc.d/init.d/anacron
78
79%clean
80rm -rf $RPM_BUILD_ROOT
81
82
83%post
84/sbin/chkconfig --add anacron
85
86%preun
87if [ "$1" = "0" ]; then
88    service anacron stop >/dev/null 2>&1
89    /sbin/chkconfig --del anacron
90fi
91
92%postun
93if [ "$1" -ge "1" ]; then
94    service anacron condrestart >/dev/null 2>&1
95fi
96
97%files
98%defattr(-,root,root,0755)
99%doc COPYING README
100%config /etc/anacrontab
101%dir /var/spool/anacron/
102%config /etc/rc.d/init.d/*
103/%{_mandir}/man5/*
104/%{_mandir}/man8/*
105/usr/sbin/anacron
106%config /etc/cron.daily/0anacron
107%config /etc/cron.monthly/0anacron
108%config /etc/cron.weekly/0anacron
109
110%changelog
111* Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 2.3-29vl5
112- applied new versioning policy
113
114* Sat Jul 08 2006 Shu KONNO <owa@bg.wakwak.com> 2.3-29vl2
115- added anacron-2.3-gregor.patch
116
117* Wed Jul 23 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.3-29vl1
118- rebuild for Vine Linux
119
120* Thu Jul 10 2003 Jens Petersen <petersen@redhat.com> - 2.3-29
121- don't require vixie-cron (#21176) [reported by Gerald Teschl]
122- in init script don't remove /var/lock/subsys/anacron when stopping (#58462)
123- exit init script with actual exit status (#44600) [reported by Enrico Scholz]
124
125* Thu Jul 10 2003 Jens Petersen <petersen@redhat.com> - 2.3-28
126- add a Content-Type header to mails giving the charset encoding (#77108)
127
128* Thu Jul 10 2003 Jens Petersen <petersen@redhat.com> - 2.3-27
129- in init script do not touch /var/lock/subsys/anacron when starting (#58462)
130- require crontabs (#21176)
131- update source url
132
133* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
134- rebuilt
135
136* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
137- rebuilt
138
139* Wed Dec 11 2002 Tim Powers <timp@redhat.com> 2.3-24
140- rebuild on all arches
141
142* Fri Aug 23 2002 Jens Petersen <petersen@redhat.com> 2.3-23
143- delay the start of anacron by 60min to make startup more pleasant (#68304)
144- at startup run jobs serially and nice 19 to reduce load (#65870, #68304)
145- spec file now in utf-8
146- dont install non-existant NEWS file
147- silence make include warnings
148
149* Fri Jul 19 2002 Akira TAGOH <tagoh@redhat.com> 2.3-22
150- fix the stripped binary issue.
151
152* Mon Jul 08 2002 Bill Huang <bhuang@redhat.com>
153- Update "Copyright" to "License" in spec file
154
155* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
156- automated rebuild
157
158* Thu May 23 2002 Tim Powers <timp@redhat.com>
159- automated rebuild
160
161* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
162- automated rebuild
163
164* Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
165- Bump release + rebuild.
166
167* Tue Apr  3 2001 Crutcher Dunnavant <crutcher@redhat.com>
168- add dependancy to vixie-cron (for /usr/bin/run-parts)
169
170* Tue Feb 13 2001 Tim Waugh <twaugh@redhat.com>
171- killproc is a shell function and can't be passed as a parameter
172  (bug #27150).
173
174* Mon Feb  5 2001 Bernhard Rosenkraenzer <bero@redhat.com>
175- Fix i18n in initscript ("Stopping anacron" wasn't translated)
176  (#26076)
177
178* Fri Feb  2 2001 Trond Eivind Glomsrød <teg@redhat.com>
179- i18nize initscript
180
181* Thu Dec  7 2000 Crutcher Dunnavant <crutcher@redhat.com>
182- rebuild in rebuild cycle.
183
184* Mon Oct 30 2000 Matt Wilson <msw@redhat.com>
185- touch /var/lock/subsys/anacron to prevent excess startage during
186  init level change
187
188* Wed Aug 30 2000 Bernhard Rosenkraenzer <bero@redhat.com>
189- Shut down earlier to prevent NFS mounted /usr filesystems from causing
190  problems (Bug #16257)
191
192* Fri Aug  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
193- Start it later so services some cron scripts may depend on are running
194  (Bug #15335)
195
196* Thu Aug  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
197- Fix up initscript (Bug #15123 and an unreported bug)
198
199* Sat Jul 15 2000 Bill Nottingham <notting@redhat.com>
200- move initscript back
201
202* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
203- automatic rebuild
204
205* Mon Jul 10 2000 Bernhard Rosenkraenzer <bero@redhat.com>
206- Fix up initscripts (Bug #13625)
207
208* Tue Jul  4 2000 Matt Wilson <msw@redhat.com>
209- Prereq: /sbin/chkconfig
210
211* Mon Jun 26 2000 Preston Brown <pbrown@redhat.com>
212- move initscript to /etc/init.d, fix up post/preun/postun scripts.
213
214* Sun Jun 26 2000 Bernhard Rosenkraenzer <bero@redhat.com>
215- 2.3
216
217* Sun Jun 18 2000 Matt Wilson <msw@redhat.com>
218- use %%{_mandir}
219
220* Fri Mar 03 2000 Tim Powers <timp@redhat.com>
221- fixed startup script so that it doesn't put stuff in /var/lock/subsys.
222        Complains since anacronda turns itself off when it is run, and the file in
223        /var/lock/subsys isn't removed.
224       
225* Mon Feb 28 2000 Tim Powers <timp@redhat.com>
226- fixed startup script, now it actually stops, gives status and restarts.
227        Fixes bug #9835
228
229* Mon Feb  7 2000 Bill Nottingham <notting@redhat.com>
230- handle compressed manpages
231
232* Fri Feb  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
233- rebuild to get compressed man pages
234- mark /etc/cron.daily/... as config files
235
236* Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
237- fix annoying defines
238- rebuild to update description and group
239
240* Thu Jan  6 2000 Bernhard Rosenkränzer <bero@redhat.com>
241- initial Red Hat package
242
243* Wed Dec 29 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
244- Remove cron.hourly check (unusefull).
245
246* Wed Nov 10 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
247- 2.1 from debian.
248- Fix typo in initscripts.
249
250* Thu Jul 22 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
251- Fix wrong entries in anacrontab.
252- Add a /etc/rc.sysinit/ script
253
254* Tue Apr 27 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
255- Fix bug with /var/spool/anacron/
256
257* Sat Apr 10 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
258- First version mainly inspired from the Debian package.
Note: See TracBrowser for help on using the repository browser.